Performance Center Support and News Forum
Showing results for 
Search instead for 
Do you mean 

Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

Occasional Contributor

Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

Hi All,
We are using Mercury Load runner 8.1 with VUGen, I created the script and tested on loacal machine and this works fine with our any error.And when I upload this to my load generator and try to execute the script, i get the failed message with below error.Could any one help me with the fix ?
====
Start auto log messages stack. [MsgId: MMSG-10546]
Virtual User Script started [MsgId: MMSG-15967]
Starting action vuser_init. [MsgId: MMSG-15919]
vuser_init.c(11): Think time - Waiting 30.00 seconds (according to limit). [MsgId: MMSG-15946]
vuser_init.c(11): lr_think_time: 30.00 seconds (recorded think time was 16.00 seconds). [MsgId: MMSG-15947]
vuser_init.c(12): Error: Failed to open new connection to server "GEWPT - PRE [ Basis Sandbox ]" Snapshot Info [MSH 0 0 1]. [MsgId: MERR-79999]
vuser_init.c(12): Error: Failed to get active window [MsgId: MERR-79952]
vuser_init.c(12): Error: Failed to find SapGui component by ID "sbar" [MsgId: MERR-79992]
vuser_init.c(12): Error: Failed to get the status bar text [MsgId: MERR-79946]
vuser_init.c(12): Error: Failed to get active window [MsgId: MERR-79952]
End auto log messages stack. [MsgId: MMSG-10544]
======================
Thanks,
Madhu Kumar
5 REPLIES
Super Advisor

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

connectivity issue
Valued Contributor Valued Contributor

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

Did you installed the SAPClinet login in the Load generators.
If not first install the SAP in the Loadgeneratos.
Highlighted
Occasional Advisor

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

Hi Madhu,
Yes prakash had given right solution, u need to install ur LG with SAPGUI first
Advisor

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1].[MsgId

also, if this is for SAP then you might want to check if the scripting parameter is enabled in ECC using Transaction Code RZ11
search for this parameter "sapgui/user_scripting" and make sure that its value is set to TRUE, every time a reboot takes place, this has to be re-done
Occasional Advisor

Re: Getting error as "Failed to open new connection to server 'SAPSID' Snapshot Info [MSH 0 0 1

Hi All

 

I notice that once we build the script, it was working fine for a day. Now we are noticing the same error coming up even though the SAP server is available.

 

Regards,

MMT