ProLiant Servers (ML,DL,SL)
Showing results for 
Search instead for 
Do you mean 

DL380 G6 Wont boot Virtual Media

Frequent Advisor

DL380 G6 Wont boot Virtual Media

[ Edited ]

I'm having problems on a DL380 G6 while trying to boot from virtual media:

I have ESXi installed on the internal USB port ... no idea if this might affect the booting but I'm out of ideas.

Ilo2 version 2.09
Ideas i tried:
- cd-rom first boot option ( virtual drive doesn't boot )
- external usb drives first boot option ( virtual drive doesn't boot)
- disable intel sata from bios ( virtual drive doesn't boot )
- verified virtual media port in case it's blocked ( port open , telnet works , virtual media still wont boot ).
- tried multiple java edition including even the recommended version by hp witch is : j2re-1_4_2_13 ( same story , doesn't boot)
- tried to restart ilo ( same story , doesn't boot )
- tried all the above steps from freshly installed OS's ( xp ; win7 x64  and Mac) -> same story , doesn't boot

In my case i was in need to use the firmware dvd and the new offline hp acu iso because we cannot use any hp tools due to virtualization layer. After we connect a iso image via ilo virtual media we can access the content of the iso via a guest virtual machine from ESXi but the only problem is that it just wont boot from it while restarting the server ( even tried pressing F11 at boot options to bypass the regular boot options and select option 1 to attempt to boot 1 time from cd-rom but without any success).

Hint): i also read all the ilo2 documentation and tried everything without success :(
Hint): i just had a technician that worked with a lot of servers to try it and he said something is wrong because on the boot menu (pressing F11 to bypass regular booting order) there's no "Virtual CD-ROM option" just the regular CD-ROM which should be the local installed cd-rom into the server.

hint): the technician told me that he did see a similar issue in the past when there were some bugs into the HP firmware's and the example he gave me was that virtual media didn't work when all the ram slots were in use (but this was a long time ago).

For the moment i have solved my problems by deploying the hp firmware iso and the hpacuoffline to my RIS server so i managed to boot from network to do the firmware updates and raid array tasks. But even if i solved the tasks for which i needed virtual media i still want to fix this for possible need in the near future.


Update[13.08.2012]:

- Updated ilo2 version to : 2.09 (still no help , cannot boot from virtual media cd-rom or virtual usbkey.)

- Cleared NVRAM from board switch
- Verified that virtual media port is accessible via netstat (ilo ip address: 10.60.2.104):

C:\Users\d3vnul>netstat -an|find "10.60.2.104"  
TCP 10.60.4.32:53451 10.60.2.104:443 ESTABLISHED
TCP 10.60.4.32:53452 10.60.2.104:443 ESTABLISHED
TCP 10.60.4.32:53455 10.60.2.104:443 ESTABLISHED
TCP 10.60.4.32:53456 10.60.2.104:443 ESTABLISHED
TCP 10.60.4.32:62253 10.60.2.104:17988 ESTABLISHED

 So it seems that there's no networking issues since port 17988 is open/established (while having a connected iso on virtual media).

 

- Two days ago we installed a sas expander and second drive cage into the server and while we tried to enter ORCA we noticed there wasn't an F8 message displaying anymore. However if i pressed F8 i manage to get inside ORCA. Now i wonder if this could be the same issue with virtual media booting option ? Does anyone know the F key that needs to be pressed to boot from virtual cd-rom ? I would like to try it even if the post doesn't show it. I'm still open for any other suggestions. I also added one picture from remote console settings while having iso connected to virtual media.

 

Thank you in advance.

21 REPLIES
HPE Pro

Re: DL380 G6 Wont boot Virtual Media


d3vnul wrote:

I have ESXi installed on the internal USB port ... no idea if this might affect the booting but I'm out of ideas.


Have you tried removing the internal USB device just to see if you can boot virtual media?




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

 Unfortunately i cannot do that because I'm way far from the datacenter .... and if I'm to ask the datacenter technician for admin time in order for this experiment it should cost me like 100 euros which I'm not really willing to pay for a thing that might not solve anything.

Attached some pictures from Ilo settings.

Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

Hello,

We haven't manage to identify or to solve this issue for a long time. Therefore we did few more tests two days ago. Updated the main post to reflect the new attempts.

Honored Contributor Honored Contributor

Re: DL380 G6 Wont boot Virtual Media

[ Edited ]

What ROM version do you have? I do remember an issue related to the G6 ROM that would prevent iLO2 Virtual Media from booting when there was another USB device connected to the server.  Latest ROM for the DL380G6 is dated 5/5/2011. I believe this one contains the fix.




__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

[ Edited ]

System ROM: P62 01/30/2011; backup system ROM: 08/16/2010 .

I was thinking to try a firmware update on the ROM but that wasn't possible since we couldn't boot the firmware dvd from virtual media. Also while reading the changelog for 2011.05.05 ROM i cannot see anything related to this issue. I'm going to update the firmware dvd iso that we have on our RIS server and give that a try as i guess it's not possible to perform a rom update from esxi. 

Update: It seems that the ROM version that we are running (2011.01.30) should contain the fix that you stated. However we still have the same issue.

Honored Contributor Honored Contributor

Re: DL380 G6 Wont boot Virtual Media

Can you tell me what other USB devices are attached to that server?




__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

[ Edited ]

- Internal USB Port is occupied with ESXi installation

- Internal SD Card is occupied with an empty card (i installed this with the idea that if the usb hypervisor will ever 'crash' , i can install esxi on the sd card).

- All external usb ports are unoccupied

HPE Pro

Re: DL380 G6 Wont boot Virtual Media

[ Edited ]

Hi

 

I see there is a fix for this problem in BIOS Version: 2011.01.30 (B)  (17 Mar 2011)

Resolved an issue where the system would not boot from iLO Virtual USB devices when configured with multiple local USB devices. This issue is usually seen as a failure to boot an iLO Virtual Medial USB key when 2 or more USB keys are installed locally in the server. iLO Virtual Devices will now always have priority over local USB devices.

 

the issues is with Virtual USB devices... so physical DVD ROM should work. there isn't any option in BIOS to select virtual media drive.

 

Please use physical machince on the same network rather than virtual machine to mount virtual media (Firmware DVD) or an ISO image from iLo Virtual Media.

 

Please let me know you thoughts.

 

Hope this helps,

 

Click on Star Kudos if you think information provided is helpful.

 

cheers

Aftab

 

I work for HP
Looking for a quick resolution to a technical issue for your HP Enterprise products? HP Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

Hello,

We have more colocated servers under the same rack/networking. All of them are working as expected without any issues related to virtual media. Only this DL380 G6 causes us this problems.

As for the Guest VM (installed on the machine) , we only tried to access the mounted iso from virtual media as a test to see if it's really mounted and that we can access the mounted iso content.

So the mounted iso from virtual media it's loaded without problems and it can be accessed. The only problem is making the server to boot from it. We even tried to mount the iso from ilo ssh with the same results (not booting). While the rest of the servers under the same rack/networking are performing without this kind of problems. So it's an isolated problem only to this machine.

HPE Pro

Re: DL380 G6 Wont boot Virtual Media

Hi,

 

I understand from the thread that you have tried every possible step to isolate the issue. Looks like issue with iLo itself if other identical machines are working fine with virtual media.

 

You may need to open a case with HP Support for further troubleshooting or part replacement if required.

 

Click on Star Kudos if you think information provided is helpful.

 

Thanks,

Aftab

I work for HP
Looking for a quick resolution to a technical issue for your HP Enterprise products? HP Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

That's the last resort indeed. We were hoping to find a possible fix without causing downtime for a technician to replace the motherboard. I also understood from the datacenter that if a hp tech will need to go on-site for motherboard replacement i will need to pay the datacenter to open the rack with a masterkey and to escort the hp technician to the rack. Second problem is that we can only afford downtime just between 01AM-07AM. I never had a hp technician on-site and i have no idea if we can request special hour for the replacement task. The server is still under warranty so i guess i will give it a try and contact hp support.
Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

One update on this old topic.

 

I just have a DL360 G6 next to me and i experienced the same problem with virtual media. Apparently the solution in this case was to remove the internal usb drive because i also had a SD card installed.

 

My main goal/idea was to install ESXi on the internal usb drive and have a empty sd card plugged-in so in case the internal usb drive will ever "die" i can easy install esxi on the sd card (or the vice-versa) .

 

As soon as i removed the internal usb-drive , i managed to boot from virtual media.

Honored Contributor Honored Contributor

Re: DL380 G6 Wont boot Virtual Media

Is there another USB attached to the server? Like an USB KVM dongle?




__________________________________________________
I work for Hewlett Packard

If you feel this was helpful please click the KUDOS! thumb below!
Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

[ Edited ]

Hi,

Nothing else was installed except the internal usb drive + sd card.
Apparently in my case it wont boot virtual media if i have both connected. As soon as i removed the internal usb drive , it works. P.S: Using latest ilo2 2.15 and latest bios.

Occasional Visitor

Re: DL380 G6 Wont boot Virtual Media

You can toggle the bios USB boot selection to Internal or External, choose the unpopulated one, you can still install to it in ESXi then change it back after.

 

I have no answer if both are populated, maybe you can disable the USB booting with one of the legacy USB options.

 

I also didn't try mapping the .iso to a USB instead of the CD.

Occasional Visitor

Re: DL380 G6 Wont boot Virtual Media

DL360 G6 with internal SD card installed. Same issue. Not sure of there is an external USB device installed but quite possible that there is. Disabling external USB ports in the BIOS allowed me to boot SPP 2013.09 .iso mounted via iLO virtual media. Hope this saves someone some time.

Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

[ Edited ]

 I still have the DL380 G6 with installed SD card and installed Internal USB drive that cannot boot from virtual media even if i disabled the External USB from bios. I guess the only inconvenient solution for me would be to pay a technician to remove the SD card from the server ...

 

 I would be really really curious if an official HP person could test a DL380 G6 with installed internal sd card & usb drive to see if they can boot from virtual media , or if this is a known limitation ...

Occasional Visitor

Re: DL380 G6 Wont boot Virtual Media

Enable USB 2.0 support. For me it was the solution.

Occasional Visitor

Re: DL380 G6 Wont boot Virtual Media

Thanks a lot!

Same problem with DL380 G6, newest Firmware for mainboard and iLO (both January, 2015)

Tried to remote install ESXi 5.5 on internal USB stick, USB Backup Drive connected to external USB connector.

Selected internal SD card boot for sequence (not populated) and enabled USB 2.0.

Finally ESXi ISO boots from ilo after eight hours of searching.

Thanks to the community and shame on HP for this strange behaviour of the BIOS.

Visitor

Re: DL380 G6 Wont boot Virtual Media

d3vnul,

 

I hope you have not paid yet! I was in the same boat as you and I have tried all the things you mentioned, read and studied iLO 2.0 and the server manual. I am using a DL120 G6, I know, different server but perhaps a solution I found that worked for me might work for you?

 

Follow this link, hopefuly it helps!

 

http://serverfault.com/questions/288936/hp-dl170-g6-and-lo100-ilo-cant-boot-from-virtual-media

Frequent Advisor

Re: DL380 G6 Wont boot Virtual Media

I have tested the ports and all that in the past and still not a solution for DL380 G6. I still haven't found a solution for this particular server model so far. I just never install both the internal usb and internal sd card anymore since this is what's causing the problem. Maybe HP should of added a notice " don't use both ports at the same time or your virtual media is screwed " :)). About that , i have a dl380 g6 at home right now ,which works perfectly with just internal usb drive. I will try to get a SD card to test and see if virtual media will still work if i plug the SD card and internal usb at the same time.