ProLiant Servers (ML,DL,SL)
Showing results for 
Search instead for 
Do you mean 

DL380e G8 + P420 - P420 crashing

Occasional Visitor

DL380e G8 + P420 - P420 crashing

Hello,

 

i have new DL380e G8 with P420 1GB BBWC + 8xSATA RAID 10, running Debian Jessie. Problem - P420 is crashing under load after 3-5 days:

 

P420 in slot2:

 

Aug 14 06:51:26 zaloher smartd[2296]: Device: /dev/sda [cciss_disk_00] [SAT], failed to read SMART Attribute Data
Aug 14 06:51:26 zaloher smartd[2296]: Sending warning via <mail> to root ...
Aug 14 06:51:27 zaloher smartd[2296]: Warning via <mail> to root: successful
Aug 14 06:51:27 zaloher smartd[2296]: Device: /dev/sda [cciss_disk_04] [SAT], previous self-test completed without error
Aug 14 07:15:09 zaloher kernel: [233654.188156] hpsa 0000:0a:00.0: cmd_special_alloc returned NULL!
Aug 14 07:21:26 zaloher smartd[2296]: Device: /dev/sda [cciss_disk_00] [SAT], failed to read SMART Attribute Data

 

checking hpacucli is randomly working/not working 2-3 hours and after it it definitely lost P420 and server hangs.

 

Two weeks before (different P420 in slot3, same server):

Onscreen info:

hpsa 0000:0d:00.0: cmd_special_alloc returned NULL

hpsa: 0000:0d:00.0: report physical LUNs failed.

Buffer I/O error  on device sda1, logical block XXXXXXXXX

...

Aborting journal on device sda1-8

...

server hangs.

 

In both cases in ILO is P420 active and all disks present (green status). No error in Health log etc., just high temperature (as usual on P420).

 

We are using Debian Jessie (kernel 3.14) on G6/G7 servers with p410 under load without problem. Only G8 (kernel 3.14,3.16) with P420 is hanging, when it ran 5 months without monitoring and load, no hangs occured.

 

Firmwares tested:

BIOS P73: 02/10/14, 11/12/2013

P420: 1.86, 5.42 (latest)

 

Any help or i need open case with HP? We dont have payed support.

3 REPLIES
Valued Contributor

Re: DL380e G8 + P420 - P420 crashing

Overtemperature will cause failure on the P420! it is very picky on thermal limits!

Also I might suggest dropping the bus speed of the disks back to 3gbp/sec like the P410 - P420 will try to run at 6gbp/sec which may cause issues with some drive combinations.

What drives are you using btw? NON-HP?
Occasional Visitor

Re: DL380e G8 + P420 - P420 crashing

We are using WD RED 4GB SATA disks 6Gbps. Dropping speed to 3Gbps is nonsense (i will test it, but for production - big NO) - thats why we bought P420s and not P410s.
Server is 8LFF, so cooling down P420 is problematic due backplane.
ILO fans: 34%, temp: 85C
hpacucli: Controller temp: 88C, Cache: 44C, Capacitor: 48C
Highlighted
Acclaimed Contributor Acclaimed Contributor

Re: DL380e G8 + P420 - P420 crashing

I would not use non-hp drives in a productive server, guess what hp will tell you about your problem ...

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!