ProLiant Servers - Netservers
Showing results for 
Search instead for 
Do you mean 

HP ProLiant MicroServer Remote Access Card: Serial setup?

Occasional Contributor

HP ProLiant MicroServer Remote Access Card: Serial setup?

I'd like to use Serial over LAN (SoL) with my HP ProLiant MicroServer Remote Access Card (aka BMC), firmware version 1.3, to view POST, my bootloader (I know how to adjust grub) and use it as a serial console for my Red Hat Enterprise Linux


The User Manual[1] does state on page 40

This page allows you to view the IPMI values. With Administrator or Operator privilege level, you can
modify the IPMI Serial attributes and IPMI LAN Settings values and then click Apply Changes to
execute validation against the Encryption key field and send all data to the server.

But then on page 41 only IPMI over LAN settings are described, no SoL settings. In the webUI of the BMC, there are no SoL settings at 'Remote Access Cars' / 'Configuration' / 'IPMI'


I can talk lanplus to the BMC just fine

[another host] $ ipmitool -I lanplus -U admin -H hp-bmc chassis power status
Chassis Power is on

but when I activate SoL

[another host] $ ipmitool -I lanplus -U admin -H hp-bmc  sol activate
[SOL Session operational.  Use ~? for help]

no output appears during post or boot (I did add console=ttyS0 to my kernel command line).



1)  is SoL available?

2) are the settings available in another location of the webUI

3) do I need to make any settings in the BIOS of my MicroServer N36L (F10 at POST)?

4) do I need to activate SoL (either via ipmitool or by ssh to the BMC? If yes, please provide the necessary commands.


Kind regards,



[1]: Part Number: 664489-002
February 2013
Edition: 2

Occasional Contributor

Re: HP ProLiant MicroServer Remote Access Card: Serial setup?

After adding


to my kernel line, to adjust for the wrong info in DMI[0], I can see it locally with ipmitool from within RHEL


[MicroServer]# ipmitool sol info 1
Info: SOL parameter 'Payload Channel (7)' not supported - defaulting to 0x01
Set in progress                 : set-complete
Enabled                         : true
Force Encryption                : false
Force Authentication            : false
Privilege Level                 : ADMINISTRATOR
Character Accumulate Level (ms) : 50
Character Send Threshold        : 255
Retry Count                     : 7
Retry Interval (ms)             : 480
Volatile Bit Rate (kbps)        : 115.2
Non-Volatile Bit Rate (kbps)    : 115.2
Payload Channel                 : 1 (0x01)
Payload Port                    : 623

but I still get no output (POST, grub[1], kernel[2] when I connect from another Linux box with

[another box]$ ipmitool -I lanplus -U admin -H hp-bmc sol activate


Could it be that my active IPMI user not being number 1 be part of the problem?

[MicroServer]# ipmitool sol payload status 1 1
User 1 on channel 1 is disabled
[MicroServer]# ipmitool sol payload status 1 2
User 2 on channel 1 is enabled


[0] see this posting

[1] added this to grub config

serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1
terminal --timeout=15 serial console
[2] added this to kernel command line

ipmi_si.ports=0xca2 console=ttyS0,115200