Project and Portfolio Management Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Firefox Product Info > Library gets a blank page

SOLVED
Go to Solution
Trusted Contributor

Firefox Product Info > Library gets a blank page

IEs work, most thngs work with firefox 3.6 and 10.0.10 except:

 

My Product Library with firefox does not display xml data:

- The documentation window opens but no data from the xml files display

- added document.write to Library.js

     1)  it looks like it cant file.load the first xml file titled Locale.xml

     2) catch returns 0x8000ffff (NS_ERROR_UNEXPECTED)

- firefox logger shows:

     1)  A response for the http request GET /itg/pdf/Locale.xml HTTP/1.1

     2)  It seems to keep going and gets a response for GET /itg/pdf/Library.xml HTTP/1.1

- All xml http responses return a Content-Type of text/xml.

     1) Modified Content-Type to application/xml - no help.

 

Anyone seen this problem ?

1 ACCEPTED SOLUTION
Highlighted
Trusted Contributor

Re: Firefox Product Info > Library gets a blank page

PPM 9.12

I am stuck with firefox 10.0.10. The highest approved version for our org.

People with XP can get to firefox 16.

 

Both 10.0.10 and 16 displayed the window with headers but no xml data. IEs work fine.

 

All xml files produce "The XML is valid", but this is done with the IE parser.

 

I did a hack in library.js (traverseLibraryFForMOZ) and got the data to display with good links.

 

<!-- The next  line chokes firefox -->              
<!--         document.write('<tr class="windoid-margins"><td colspan="2" class="header">'+htitle+'<span class="header-secondary"><br>'+libTree.nextSibling.nextSibling.firstChild.nodeValue+'</span></td></tr>'); -->
                       document.write('<tr class="windoid-margins"><td colspan="2" class="header">'+htitle+'<span class="header-secondary"><br>'+'</span></td></tr>');

3 REPLIES
Trusted Contributor

Re: Firefox Product Info > Library gets a blank page

Update:

  - Firefox browser is reading the xml files from the server

  - Library.js is getting lost in traverseFForMOZ

    It calls itself (recursion). Great !!!!

  - The first place it seems to hang is writing leftsection htitle

Honored Contributor Honored Contributor

Re: Firefox Product Info > Library gets a blank page

FYI, I'm sucessfully using FF 19.0.2 with no problems even though it's not officially certified.

Highlighted
Trusted Contributor

Re: Firefox Product Info > Library gets a blank page

PPM 9.12

I am stuck with firefox 10.0.10. The highest approved version for our org.

People with XP can get to firefox 16.

 

Both 10.0.10 and 16 displayed the window with headers but no xml data. IEs work fine.

 

All xml files produce "The XML is valid", but this is done with the IE parser.

 

I did a hack in library.js (traverseLibraryFForMOZ) and got the data to display with good links.

 

<!-- The next  line chokes firefox -->              
<!--         document.write('<tr class="windoid-margins"><td colspan="2" class="header">'+htitle+'<span class="header-secondary"><br>'+libTree.nextSibling.nextSibling.firstChild.nodeValue+'</span></td></tr>'); -->
                       document.write('<tr class="windoid-margins"><td colspan="2" class="header">'+htitle+'<span class="header-secondary"><br>'+'</span></td></tr>');