Project and Portfolio Management Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

ksc_store Command Failing after 9.13 upgrade

Respected Contributor Respected Contributor

ksc_store Command Failing after 9.13 upgrade

After I recently upgraded from 7.5 to 9.13, the 2 execution step beign used in Package workflow with below commands are Failing more than 95 % of the time. Sometimes it works for one pkg like but gets stuck in another with error " Failed [Line 1]" ....

 

Strangely this command seems to work just fine in my Test instance but in Production it is failing ...

 

Has any one run into this issue before ? Your Suggestion is appreciated.

Thanks.

-Raj

 

-- 

ksc_store PKGL.P.READ_ONLY="LOCKED", "LOCKED"

 

--

ksc_store PKGL.READ_ONLY="UNLOCKED", "UNLOCKED"

5 REPLIES
Honored Contributor Honored Contributor

Re: ksc_store Command Failing after 9.13 upgrade

It sounds like an error that has been reported with Deployment Management in general where the first line (when selecting multiple lines) processes successfully but the remaining lines fail citing Line x as the cause.  I know HP has a patch for 9.12, but I don't know about 9.13.  Hopefully, this will also be included with 9.14.

Respected Contributor Respected Contributor

Re: ksc_store Command Failing after 9.13 upgrade

Thank You Jason , That might make sense because one pretty big difference between Test and Prod that I realized is that we never installed the BEST PRACTICES in the Test environment which we did at the very End for Production case.   I wonder if that was the culprit here...
Since we are now already on 9.13 version, I am not sure if Re-applying deploy patch for 9.12 probably is an option anymore.  I have a ticket opwn with HP to see if they can suggest something here...

 

-Raj

Honored Contributor Honored Contributor

Re: ksc_store Command Failing after 9.13 upgrade

They may already have the patch for 9.13 or may just take some tweaks to make the 9.12 patch work for 9.13.  As I said before, hopefully the fix will be included in 9.14 and hopefully, it will be available soon.

Trusted Contributor

Re: ksc_store Command Failing after 9.13 upgrade

Hi Jason and Raj,

 

Most hotfixes for 9.12 can be applied on 9.13 also, so you might try it on a TEST instance if it works fine.

 

Regards,

 

Nikola

HPE Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Respected Contributor Respected Contributor

Re: ksc_store Command Failing after 9.13 upgrade

Hi Pogonchev,  thanks for the response.

The problem here is, we have already applied that patch in Production... just that we also applied BEST PRACTICES for 9.13 after appling that patch... So, wondering it could have affected it and whether it would be wise to re-apply that at all... Please note my Test is not having any issues at all.. So this seems tobe pretty much Prod related somehow :-(

-Raj