Quality Center Support and News
Showing results for 
Search instead for 
Do you mean 

503 error from Jetty when try to launch Mtours

Occasional Contributor

503 error from Jetty when try to launch Mtours

Hello we have just moved to  ALM 11.5.  We selected the option to install the test project on our initial install. We have the project available in the application, but cannot get the website to launch. When we follow the instructions in the "Getting Started" manual, we get a 503 error. Here are our steps:

 

1.  enter http://<Ourservername>:<our port number>/mtours in the URL field.

 

we get this error.  We are new to Jetty, which is now integrated with HP Quality Center. We used to use JBoss.  Any suggestions?

HTTP ERROR: 503

Problem accessing /mtours. Reason:

    Service Unavailable

 


Powered by Jetty://

3 REPLIES
Highlighted
Valued Contributor

Re: 503 error from Jetty when try to launch Mtours

you have java installed in your machine?

Occasional Contributor

Re: 503 error from Jetty when try to launch Mtours

We didn't; but I installed and restarted and i am still getting the same error. Any ideas of anything else I may be missing?  This is a brand new box, so if it didn't come installed with the Microsoft Server OS or ALM, it isn't there.

Thanks!

 

Occasional Contributor

Re: 503 error from Jetty when try to launch Mtours

Hi, we fixed the problem.

 

We selected a different path for our repository files during install, so we had two folders on the server: The HP Application LifeCycle Management  11.52 folder and the respository folder. I was trouble-shooting the application folder and everything looked fine.  I then noticed the the MTours.war file was missing from the repository folder, but the QCbin.war file was there.  I added the MTours.war file. I was still getting the same error, but if I changed the DBRepository path in the web.xml file inthe web-ini folder in the application folder, I would get a different error. Then I started mapping both folders. HP Support gave me a clue of what to look for in earlier service calls, so I found that the jetty-testrealm_xml was commented out in one start.ini file, but not the other. I uncommented the line and restarted the service and everything worked. 

 

I posted this for anyone else who selects a different path for your repository files and gets a mtours error.