Quality Center Support and News
Showing results for 
Search instead for 
Do you mean 

ALM 11 REST API test execution status change not reflected in WebUI

SOLVED
Go to Solution
Highlighted
Visitor

ALM 11 REST API test execution status change not reflected in WebUI

Hello all, 

 

Can anybody give me a hint over here please? I am trying to update a status of a test in test lab set via REST API. I have no problems creating a run and updating an exec-status value of the test i intend to change. Responsed of my requests prove that change has been commited, but for some reason HP QC execution grid shows still old status. If i open a test i can see my last run created via REST API, but no change on level of test in execution grid at all. 

 

Any suggestions? 

 

Thank you

Karol

1 ACCEPTED SOLUTIONS
Senior Member

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi,

I am new to HP ALM and my requirement is to update test execution status.

Could you share code to update a status of a test in test lab set via REST API?

 

Thanks

9 REPLIES
Visitor

Re: ALM 11 REST API test execution status change not reflected in WebUI

[ Edited ]

Ok, another observation:

 

If I update <Field Name="exec-status"> to something lets say Passed, REST response shows that it was successfully updated. However if i look at the execution grip view Status still holds old value, but (and this is weird), Test: Execution Status field has been updated instead. 

 

If you create a report in dashboard on top of tests this report shows new value, but execution grid and also email from execution grid shows old value. What is happening? How come REST API is updating Test Instance entity instead of Test entity? 

 

As per field description it should update TS_EXECUTION_STATUS, but seems TC_STATUS is updated instead.

<Field PhysicalName="TS_EXEC_STATUS" Name="exec-status" Label="Execution Status">

 

Still no suggestion?

Karol

Senior Member

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi,

I am new to HP ALM and my requirement is to update test execution status.

Could you share code to update a status of a test in test lab set via REST API?

 

Thanks

Visitor

Re: ALM 11 REST API test execution status change not reflected in WebUI

Thanks to the bdkakde i have reviewed my scripts rather more carefully and found out that i was updating wrong entity.

Thank you for making me see! All works like a charm now.

Karol
Senior Member

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi,

 

Congratulation you got solution.

Kind request please share code for me as it is very urgent.

mail id - bdkakde@rediffmail.com

Advisor

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi Karol,

 

I seem to be having a very similar issue.  First I create a new Run.  Then I update the test-instance and it modifies the status on the Execution Grid, but it also adds another "Run" to the list of Runs for that test instance.  (it's called "Fast_***")

 

from test-instance I update: exec-date,exec-time, status, actual-tester.

 

What entity are you changing for the status to be updated?  Do you get a second run added to the test-instance details?  

 

regards,

Chuck

 

 

Occasional Visitor

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi Mates,

I have similar requirement to update Test script status (PASS\FAIL)in Test Lab in QC ALM in my project. Could you plase help me with the code and steps.

Occasional Visitor

Re: ALM 11 REST API test execution status change not reflected in WebUI

[ Edited ]

Hi,

 

I am facing same issue that i can create a run id (by POST method) and run id is getting generated successfully.

But when i go to ALM Test lab, the Run and status are not created. Looks like my POST is not saving the run.

I also tried to update the runid by PUT method, but its not reflecting in test lab.

 

Can you please give more info on how you could fix the issue? please mail me at ravi.v.nair@gmail.com

 

Regards,

Ravi

Occasional Visitor

Re: ALM 11 REST API test execution status change not reflected in WebUI

Can you please post the code here OR send it across to subodhsoni@gmail.com as I am trying to do the same:

 

I have added 1 test to a test set in the Test lab in QC12. I would like to update the status of that test by marking it as Run and Passed. What would be the steps for the same?

 

Thanks & Regards

Subodh

Occasional Visitor

Re: ALM 11 REST API test execution status change not reflected in WebUI

Hi,

I have same requirement to update test run status on ALM test lab using rest api in C#. Please share your code with me(vijender08malav@gmail.com)

 

Thanks

Vijen