Quality Center Support and News
Showing results for 
Search instead for 
Do you mean 

ALM11: connection to qcsiteadmin_db failed during 'Upgrade a copy of the existing schema'

erl
Occasional Contributor

ALM11: connection to qcsiteadmin_db failed during 'Upgrade a copy of the existing schema'

I'm installing ALM11 at a Linux box. The new ALM11 server will share the database with a QC10 server (which is currently running).

 

During the ALM11 server configuration, I select ' Upgrade a copy of the existing schema ' and hope the application will make a copy of 'qcsiteadmin_db' and then created a new one called 'qcsiteadmin_db_ALM11' (default name).

 

But this step failed with connection error -- ' Database schema "qcsiteadmin_db" exists, but connection to it failed '

 

-------------------------------------------------------------------------------

   Schema name: [qcsiteadmin_db]

   Press 1 for default value, or 2 for no value: [1]

 

   Schema password: [******]

   New schema name: [qcsiteadmin_db_ALM11]

   Press 1 for default value, or 2 for no value: [1]

 

   Press 1 for Next, 2 for Previous, 3 for Cancel, or 4 for Redisplay [1]

   Validating user settings.

--------------------------------------------------------------------------------

   Error

 

   Database schema "qcsiteadmin_db" exists, but connection to it failed.

--------------------------------------------------------------------------------

 

From the error logs, I see the error message is:

 

<td title="Installation category">Installation</td>

<td title="Message">java.sql.SQLNonTransientConnectionException: [Mercury][Oracle JDBC Driver]Error establishing socket. Unknown host: sa_db_host

at com.mercury.jdbc.oraclebase.dda4.b(Unknown Source)......

 

It seems to me a permission issue. We use a password like 'pass123' for both the Database Admin User and for 'qcsiteadmin_db' schema. But when I entered the password (not using the default one), the installation failed again at the same point with the same error message.

 

Does anyboday know what is the issue?

 

3 REPLIES
Occasional Visitor

Re: ALM11: connection to qcsiteadmin_db failed during 'Upgrade a copy of the existing schema'

Hi, 

 

We are also facign this issue, please suugest how it resolved for you.

 

Thanks for Help!

 

Sarav

Valued Contributor

Re: ALM11: connection to qcsiteadmin_db failed during 'Upgrade a copy of the existing schema'

check your qcsiteadmin_db.xml

passwords set here must match the password you set in the siteadmin_db.

 

note : the password in the xml is encrypted, you might want to use this syntax in the db password parameter  "TXT:<password>" where <password> is the actual text password.

 

Also checked the namedpipes connections or tcp connections of your database.

Occasional Visitor

Re: ALM11: connection to qcsiteadmin_db failed during 'Upgrade a copy of the existing schema'

We are also facing similar issue, we are on windows.

While installing at Cluster config step I selected Secondary Node  and facing issues at SA DB Schema step.

Issue: "satabase schema qcsiteadmin_db exists but connection to it failed"

 

We are using the correct pssword only, help me to resolve this.

 

It is connecting to DB, but unable to conncet to SA schema.

 

I thought of configuring my both server into cluster after the installation. Can I do this after installing.