Security
Showing results for 
Search instead for 
Do you mean 

Disable Password Aging on Trusted System

SOLVED
Go to Solution
Regular Advisor

Disable Password Aging on Trusted System

Apparently my previous co-worker left me a going away present = Our batch account passwords are expired! I need a command line arg to 'turn off' password aging policy....
1 ACCEPTED SOLUTION
Honored Contributor Honored Contributor

Re: Disable Password Aging on Trusted System

If you're using a relatively recent version of HP-UX, the passwd command can set the aging value. Use something like: passwd -x 0 batch_user. The zero should turn off aging.
5 REPLIES
Outstanding Contributor Outstanding Contributor

Re: Disable Password Aging on Trusted System

Dan,

Try "modprpw -V" - see "man modprpw".


Pete

Pete
Regular Advisor

Re: Disable Password Aging on Trusted System

Thanks for the feedback, but the "-V" option only resets the clock. I was really hoping to find one simple command to 'disable' the policy of password aging without going into SAM.
Honored Contributor Honored Contributor

Re: Disable Password Aging on Trusted System

If you're using a relatively recent version of HP-UX, the passwd command can set the aging value. Use something like: passwd -x 0 batch_user. The zero should turn off aging.
Honored Contributor Honored Contributor

Re: Disable Password Aging on Trusted System

Hi,

Password aging could be disabled using
# modprpw -m mintm=0,lftm=0,exptm=0,expwarn=0

I guess the same command is ran when you use SAM to disable it.
Regular Advisor

Re: Disable Password Aging on Trusted System

Thank you all for the information!