Server Automation Support and News Forum
Showing results for 
Search instead for 
Do you mean 

SA Support tip: SA 10 Upgrade Guide - Installation will fail because it cannot find all the media

Highlighted
HPE Expert

SA Support tip: SA 10 Upgrade Guide - Installation will fail because it cannot find all the media

There is a known issue with the documentation.  When following the SA10 Upgrade Guide the installation will fail because it cannot find all the media.

 

 

This error is seen:

======

[root@stisalab /]/tmp/SA10/primary/disk001/opsware_installer/hpsa_upgrade.sh

 

 

 

 

You cannot run hpsa_upgrade.sh from /tmp/SA10/primary/disk001/opsware_installer

 

 

Please start with the primary distribution.  Aborting!

=====

 

 

This is because the mount point is wrongly detailed into the documentation.

 

 

 

By changing the default installation paths from

 

 

<mountpoint>/primary/disk001/...

 

 

to

 

 

<mountpoint>/-primary/disk001/...

 

 

The installation is successful.

 

 

Take note of the "-primary" in the correct line, and specially to the "-" sign that precedes the word primary.

 

This is the doc about this:

 

http://support.openview.hp.com/selfsolve/document/KM00466284

 

Hope this helps.



Ed Molina
HP Cloud Solution Support Engineer

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution. Also, if you liked this post please consider providing Kudos on the left side.
3 REPLIES

Re: SA Support tip: SA 10 Upgrade Guide - Installation will fail because it cannot find all the medi

Hello,

 

I have the same problem here, but I am not able to crate -primary directory to mount the media there, as we all know the dash (-) is not allowed for the directory name to start with!

Osama Selwadi - SSBS
Frequent Advisor

Re: SA Support tip: SA 10 Upgrade Guide - Installation will fail because it cannot find all the medi

mkdir -- "-primary"

Advisor

Re: SA Support tip: SA 10 Upgrade Guide - Installation will fail because it cannot find all the medi

The directory name does not have to be "-primary", it just has to END with "-primary".

In other words, the following directories are ALL acceptable:
"hpsa-primary"

"iLikeCake-primary"

"ThisIsRidiculous-primary"

 

Don't forget the new "disk001" requirement with HPSA 10.x now too...  So it would read more like:
"PleaseLetThisWork-primary/disk001"

 

And that's just for the Primary installation disk....

Your Upload disk (Agents & Utilities) needs to be mounted to something like:
"ThisIsOverlyComplicated-upload/disk001"

 

And your Patches get mounted to your version of:
"patchy-patch/disk001"