Server Automation Support and News Forum
Showing results for 
Search instead for 
Do you mean 

SA support tip: Issues with SA on RHEL 5.9

HPE Expert

SA support tip: Issues with SA on RHEL 5.9



In support we have ran into a few ocassions where customers have installed SA on RHEL 5.9, but this is not supported.  


Problems were discovered with the gateway component of Server Automation on RHEL 5.9. We believe these problems were exposed by changes made in the Linux kernel version 2.6.18-348.2.1.el5 included with RHEL 5.9. Symptoms of these problems include the following:


 -The SA Java client throws org.omg.CORBA.COMM_FAILURE errors

-Disconnection of the SA Java client

-Poor performance of the SA Java client


-The following error appears in the logs of the SA gateway component:


ogthreads.cpp:2839 preconnector_thread: portMap update race detected... this should not happen


 -General instability of the SA environment 


For these reasons, it is not recommended or supported to install Server Automation on RHEL 5.9.  If Server Automation has been mistakenly installed on RHEL 5.9, it may be possible to alleviate the above symptoms by downgrading the Linux kernel to the version 2.6.18-308.8.2.el5 that was included with RHEL 5.8.


Here is the reference:



Eduardo Molina

SA Support

Ed Molina
HP Cloud Solution Support Engineer

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution. Also, if you liked this post please consider providing Kudos on the left side.