Server Automation Support and News Forum
Showing results for 
Search instead for 
Do you mean 

java Errors in Jobs

Occasional Contributor

java Errors in Jobs

When we open jobs in HPSA Java client below are the java errors that we see


Job 1:

java.rmi.MarshalException: CORBA COMM_FAILURE 1398079691 Maybe; nested exception is: 
 org.omg.CORBA.COMM_FAILURE:   vmcid: SUN  minor code: 203 completed: Maybe 

org.omg.CORBA.COMM_FAILURE:   vmcid: SUN  minor code: 203 completed: Maybe Tunneling result not OK, result: 'DEAD', id: '1029'


Job 2:


java.rmi.MarshalException: CORBA MARSHAL 1398079698 Maybe; nested exception is:
 org.omg.CORBA.MARSHAL:   vmcid: SUN  minor code: 210 completed: Maybe

org.omg.CORBA.MARSHAL:   vmcid: SUN  minor code: 210 completed: Maybe

java.lang.OutOfMemoryError: Java heap space


tried to check all the twist logs but found nothing and also Java maximum memory is twist.mxMem=10240m.



Ravi S

Valued Contributor

Re: java Errors in Jobs

Job1: That exception means that the connection from the Java Desktop Client is getting improperly directed to a Twist that does not know about the Weblogic session id: 1029.   This can happen if a twist is restarted and connected clients are not.


Job2: OutOfMemoryError kind of says it all.


Re: java Errors in Jobs

We had those problems when we were on 9.10.


The issue was that our Core servers are on Red Hat Enterprise Linux 5.

Our Unix team had applied a particular kernel patch that did something to how network traffic was handled.  As a result, our Java web client kept trying to communicate with various twist servers (we had 2 Slice bundles in our environment).


At the time, there was no solution other than to remove the patch.  Technically, the patch couldn't be removed, what our Unix admins did was set the GRUB loader to boot to the previous kernel version.  Support had told us that the issue was also present on the earlier releases of RHEL 6.


However, this issue was resolved in a later HPSA patch/hotfix.  We didn't have the issue on 9.14 (I don't recall if a roll-up hotfix was necessary with 9.14).