Service Manager / Service Center Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Disable "assignment.qbe.g"

SOLVED
Go to Solution
Trusted Contributor

Disable "assignment.qbe.g"

[ Edited ]

Hi Experts,

 

How do I disable "assignment.qbe.g" while saving the change Management form? The Change Management forms are associated to phases. The first phase doesnt contain the Coordinator Group, however while saving the form the "assignment.qbe.g" page opens up prompting to select the assignment group. I dont want to save an assignment group in the first phase.

I want the assignment group to be saved from the second phase onwards.

 

From where do I disable the "assignment.qbe.g" for the first phase?

 

Thanks,

Sanjeev

15 REPLIES
Honored Contributor Honored Contributor

Re: Disable "assignment.qbe.g"

I am not sure where it is set exacty, but try to tailor the format control by excluding the first phase based on condition column.

Honored Contributor Honored Contributor

Re: Disable "assignment.qbe.g"

Hi,

It might be because of link line calling in you FC or '$fill.recurse' is set to true in immediate previous link line of link 'cm3r' or form level link record.

hth,
____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
Trusted Contributor

Re: Disable "assignment.qbe.g"

[ Edited ]

Hi Piku,

 

The $fill.recurse for the assignment groups is set to false.

 

Thanks,

Sanjeev

 

Valued Contributor

Re: Disable "assignment.qbe.g"

Following on from the previous 2 suggestions, the likeliest reason for this is in the format control validations. It is likely that there is a validation set to ensure that the assignment group is set.

 

To prevent this firing during the first phase you would need to change the validation condition to exclude the first phase (e.g.. phase in $file~="first") where phase is the phase name field in the record and the actual first phase name is "first".

 

The fill recurse option would fill the field automatically, so it is unlikely that is the cause, unless there is a query in place that may return multiple assignment groups.

 

Check the format control first.

 

Regards

Honored Contributor Honored Contributor

Re: Disable "assignment.qbe.g"

Hi,

@Stevo,
In case of blank assignment group , it will prompt.

@ Sanjeev
Check for the link line previous to assignment.
and post you subroutine of cm3r and form level fc.
Also possible 'validity.fields' subroutine is calling to check 'assignment.group'.

hth,
____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
Trusted Contributor

Re: Disable "assignment.qbe.g"

Hi Piku,

 

I was able to disable "assignment.qbe.g" from the cm3r subroutines.

In the 2nd phase I was able to choose the assignment group and the assignees. But while moving to the next phase the Assignment Group field got blank.

 

However, I have a defined autoassignment based on the category and the subcategory selected.

fc>cm3r>Calculations

Add:true

Update:false

assign.dept in $file=assignment in $file9

 

Queries contain $file9

 

Seems like while Moving from 2nd phase to 3rd phase, the Autoassignment logic is playing its part. But I have put Update:false, so why is the Assignment Group value changing to blank on moving to phase 3.

 

Thanks,

Sanjeev

 

Honored Contributor Honored Contributor

Re: Disable "assignment.qbe.g"

Hi Sanjeev,

In Change module or modules having phases , add is executed while adding new phase. Hence whenever you moves to new phase 'add' calculation will be executed along with update.
here you can just try to replace expression in add/update as,
current.phase in $file~="first phase name"

regarding blank of assign.dept , it depends on your calculation, here what are the expression placed in query no.9 in query tab.

hth,
____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
Trusted Contributor

Re: Disable "assignment.qbe.g"

Hi Piku,

 

Tried with current.phase in $file ~="phase 3" in Calculations add column. Its not working. The assignment field is left blank while moving to phase 3 from phase 2.

 

Expression in Query 9,

Add: true

Update:true

FileName: itcchgautoassignment

Query: itc.category=category in $file and itc.subcategory=subcategory in $file

 

Thanks,

Sanjeev

 

Honored Contributor Honored Contributor

Re: Disable "assignment.qbe.g"

Hi,

Cannot say there could be multiple reason for same.
Check if at add or initially is there any calculation make this dept filed blank.
Is this query matching any valid record ?

hth,
____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
Trusted Contributor

Re: Disable "assignment.qbe.g"

Hi Piku,

 

I tried with autoassignment ADD: false and Update:false. Its working.

But when I write a condition for autoassignment with Add:current.phase in $file~="Phase 3", the Coordinator field is left blanl while moving from Phase 2 to phase 3.

Any idea.

Any calculations depending on assignment group has been made false.

 

Thanks,

Sanjeev

Honored Contributor Honored Contributor

Re: Disable "assignment.qbe.g"

So you want to say if use false in add then dept is not blank?
then try condition current.phase in $file0="Phase 2" , check for any type error.

hth
____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
Trusted Contributor

Re: Disable "assignment.qbe.g"

Or shall I try with condition, current.phase in $file0~="Phase 3"

What does $file0 means?

 

Thanks,

Sanjeev

 

Honored Contributor Honored Contributor

Re: Disable "assignment.qbe.g"

$file0 == saved record value, that is before moving to next.
$file == current record.

Also may try the condition,
current.phase in $file0="Phase 2" and current.phase in $file="phase 3"

hth,
____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
Highlighted
Trusted Contributor

Re: Disable "assignment.qbe.g"

Hi Piku,

 

Can I write a condition like this,

current.phase in $file~="phase 3" | current.phase in $file~="phase 4"

 

Thanks,

Sanjeev

Honored Contributor Honored Contributor

Re: Disable "assignment.qbe.g"

yes can try , but '|' not works you have to use 'or'

current.phase in $file~="phase 3" or current.phase in $file~="phase 4"
____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.