Serviceguard
Showing results for 
Search instead for 
Do you mean 

Oracle integration toolkit

SOLVED
Go to Solution
Frequent Advisor

Oracle integration toolkit

Hi ,
I have integrated the files for Oracle HA WITH mc SERVICE GUARD ,
I have changed the HAORACLE.CONF file the pkg.conf and pkg.cntl ,
when runing the cluster , i have this error on the cntl log file :

/dev/vg_erp/rlv_oracle:file system is clean - log replay is not required
/dev/vg_erp/rlv_data_db:file system is clean - log replay is not required
Sep 24 09:40:14 - Node "apps1": Mounting /dev/vg_erp/lv_oracle at /oracle
Sep 24 09:40:14 - Node "apps1": Mounting /dev/vg_erp/lv_data_db at /data/db
Sep 24 09:40:14 - Node "apps1": Adding IP address 10.1.0.186 to subnet 10.1.0.0
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: MONITOR_PROCESSES^M: This is not an identi
fier.
ERROR: Function customer_defined_run_cmds
ERROR: Failed to RUN customer commands
Sep 24 09:40:14 - Node "apps1": Halting service PROD
cmhaltserv: Service name PROD is not running.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: ^M: not found.
/etc/cmcluster/pkg_erp/toolkit.sh[3]: MONITOR_PROCESSES^M: This is not an identi
fier.
ERROR: Function customer_defined_halt_cmds

can anyone help in this issue
10x
7 REPLIES
Honored Contributor Honored Contributor

Re: Oracle integration toolkit

hi

have you use ftp to transfer this script to the unix box?

open the file with vi:
vi /etc/cmcluster/pkg_erp/toolkit.sh

and check for the "^M" characters and remove them.

check this thread to remove this character:
http://forums.itrc.hp.com/service/forums/questionanswer.do?admit=109447626+1222248310302+28353475&threadId=1197383

regards
Frequent Advisor

Re: Oracle integration toolkit

Hi ,
I have solved the issue of CtrlM by copying the files in ASCII mode ,
but now i have an other problem
/dev/vg_erp/rlv_oracle:file system is clean - log replay is not required
/dev/vg_erp/rlv_data_db:file system is clean - log replay is not required
Sep 24 11:47:38 - Node "apps1": Mounting /dev/vg_erp/lv_oracle at /oracle
Sep 24 11:47:38 - Node "apps1": Mounting /dev/vg_erp/lv_data_db at /data/db
Sep 24 11:47:39 - Node "apps1": Adding IP address 10.1.0.186 to subnet 10.1.0.0
Sep 24 11:47:39 - Node "apps1" *** /etc/cmcluster/pkg_erp/toolkit.sh called with start argument. ***
Sep 24 11:47:39 - Node "apps1" : Starting Oracle SESSION PROD at Wed Sep 24 11:47:39 MDT 2008
ttytype: couldn't open /dev/tty for reading
stty: : Not a typewriter

Not a terminal
stty: : Not a typewriter
stty: : Not a typewriter
^[2 ^[2 ^[2 ^[2 ^[2 ^[2 ^[2 ^[2 ^[2 ^[2 ^[2 ^[2 ^[2 ^[2 ^[2
^[2 ^[2 ^[2 ^[2 ^[2
LSNRCTL for HPUX: Version 10.2.0.3.0 - Production on 24-SEP-2008 11:47:40

Copyright (c) 1991, 2006, Oracle. All rights reserved.

Starting /oracle/db/tech_st/10.2.0/bin/tnslsnr: please wait...

TNSLSNR for HPUX: Version 10.2.0.3.0 - Production
Log messages written to /oracle/db/tech_st/10.2.0/network/log/prod.log
TNS-01151: Missing listener name, PROD, in LISTENER.ORA

10x
Highlighted
Honored Contributor Honored Contributor

Re: Oracle integration toolkit

you are trying to start a listener called "PROD" which does not exist in:
/oracle/db/tech_st/10.2.0/network/admin/listener.ora
or
$TNS_ADMIN/listener.ora

you have to configure the PROD listener in this file.

# oerr tns 1151
01151, 00000, "Missing listener name, %s, in LISTENER.ORA"
// *Cause: The listener could not find the listener name specified.
// *Action: Make sure valid addresses on which to listen are specified for the
// listener name in LISTENER.ORA.


regards
Honored Contributor Honored Contributor

Re: Oracle integration toolkit

The error is related to Oracle config:

> TNS-01151: Missing listener name, PROD, in LISTENER.ORA



regards,
ivan

Frequent Advisor

Re: Oracle integration toolkit

Hi again ,

i can now run the cluster and mount the package on one node , but no failover is done ,
the Listenner is taken the name of the physical node and not of the virtual ip of the package ,
when creating the database , it takes the IP of listener the one of physical node even that i am installing Oracle from telneting the virtual ip of the package

any ideas pls
Honored Contributor Honored Contributor

Re: Oracle integration toolkit

please post the content of listener.ora and also the ip of your nodes and the virtual ip.
Frequent Advisor

Re: Oracle integration toolkit

we have solved the problem , it is related to the listenner creation