SharePoint Integration
Showing results for 
Search instead for 
Do you mean 

Error attempting to activate 'Integration Administration Feature on Web Application'

Occasional Visitor

Error attempting to activate 'Integration Administration Feature on Web Application'

[ Edited ]

Hi guys,


We are currently working through the installation of the HP TRIM SharePoint integration following the instructions set out in the Install guide.


We are up to the stage where we need to activate the  'HP SharePoint Integration Administration Feature on Web Application' in Central Admin.


We are receiving the following error:


The Execute method of job definition HP.Integration.SharePoint.DeploymentConfiguration.FeatureReceivers.AdministrationPropagationJob (ID <removed as it changes>) threw an exception. More information is included below.  Failed to set the Trim path to the environment variable, PATH       


We have AAM set, Kerberos setup and working and (hopefully) all permissions correctly set.


Our topology for this test installation is:


1 x SP WFE server

1 x SP App server

1 x SQL server

1 x TRIM Workgroup server


Software versions:

TRIM v7.2

SharePoint 2010

TRIM SharePoint integration v7.2.1


Does anyone have any guidance on where to look for the problem?








Re: Error attempting to activate 'Integration Administration Feature on Web Application'

[ Edited ]

You mention that TRIM is at v7.2 and the integration version you are using is 7.2.1.  You would need to make sure that these are at the same version and build.


This sounds like permissions on the SP farm servers for local admin rights. Check that the installing account has local admin rights on the App server and WFE. I've also see cases where the application pool account needed local admin rights as well. 


If this is a first time deployment, this feature should be automatically activated after the solution is deployed. So the error would indicate that the prereqs have not been met.


But bottom line, this error would come up if the prereq persmissions are not met for all the accounts. Make sure they are met prior to any deployment or feature activation.