System Administration
Showing results for 
Search instead for 
Do you mean 

NFS mount point "unreadable" using AUTOFS

SOLVED
Go to Solution
Valued Contributor Valued Contributor

NFS mount point "unreadable" using AUTOFS

 

Hi All,

 

I am getting the following error when I list the directory of an NFS mount point:

 

# ll /sapmnt/PRB
/sapmnt/PRB unreadable
total 0

 

I am sharing the FS from server1 using serviceguard hanfs. Following is the entry in the script:

 

nfs/hanfs_export/XFS            "-o ro /sapmnt/PRB"

 

 

OS is 11.31 on both cluster nodes. Any idea why I am getting this error?

 

 

Regards,

Taurian.

 

1 ACCEPTED SOLUTIONS
Highlighted
Valued Contributor Valued Contributor

Re: NFS mount point "unreadable" using AUTOFS

 

Hi All,

 

Thanks for your replies.

 

For the resolution I had to update the sharing options from the NFS server as below:

 

          -o rw=server1:server2:server3

 

 

Now I am able to write to the NFS shares from all servers.

 

 

Regards,

Taurian.

5 REPLIES
Valued Contributor Valued Contributor

Re: NFS mount point "unreadable" using AUTOFS

 

Anyone?

 

BTW I have already tried various resolutions on other threads. None are working.

 

 

Regards,

Taurian.

HPE Pro

Re: NFS mount point "unreadable" using AUTOFS

Can you try creating an empty directory on the NFS client and manually mount the NFS filesystem to see if you get the expected behavior in the mount point when Serviceguard and AutoFS are removed from the picture?

Dave
Honored Contributor Honored Contributor

Re: NFS mount point "unreadable" using AUTOFS

You're attempting to list a NFS directory as root.

 

Most NFS servers will map the "root" user of the NFS client host as equivalent to the "nobody" user.

 

Usually the right way to deal with this is to make sure your username <-> UID and groupname <-> GID mappings are consistent between the client and the server, assign some meaningful group permissions & memberships, and stop trying to work on NFS filesystems as root.

 

(In HP-UX, if a user has rwx access to a directory, has CHOWN privilege assigned to him/her in /etc/privgrp, and there is no sticky bit on the directory, then there is not much practical difference between root and that user regarding any files in that directory.)

 

The lazy/special-case way would be to change the share options at the NFS server to allow root access from that particular client to that particular NFS share. See "man share_nfs" for ideas.

MK
Honored Contributor Honored Contributor

Re: NFS mount point "unreadable" using AUTOFS

Can you see the mount point with the command bdf ?

Highlighted
Valued Contributor Valued Contributor

Re: NFS mount point "unreadable" using AUTOFS

 

Hi All,

 

Thanks for your replies.

 

For the resolution I had to update the sharing options from the NFS server as below:

 

          -o rw=server1:server2:server3

 

 

Now I am able to write to the NFS shares from all servers.

 

 

Regards,

Taurian.