System Administration
Showing results for 
Search instead for 
Do you mean 

XP Professional to HP-UX 11i LPR and LPD

SOLVED
Go to Solution
Occasional Visitor

XP Professional to HP-UX 11i LPR and LPD

Problem:Need reports to print in font 8 and landscape

Equipment Status:
XP Professional- unix services installed
- LPR configured
HP-UX 11i - remote printing configured

Printer HP5000 connected to Workstation
-Using LPT1:

Can print reports to printer but formatting is wrong. Anything changed in script does not reflect in printed document.

Troubleshooting: Changed print script in /etc/lp/interface/model.orig to landscape and font 8.

Results: Printer not picking up formatting when printed

Thanks,
Doug
1 ACCEPTED SOLUTIONS
Honored Contributor Honored Contributor

Re: XP Professional to HP-UX 11i LPR and LPD

HP-UX uses the SysV Unix spooling system while Windows and Linux use the Berkeley spooling system. The SysV spooler is defined by the RFC 1179 remote printing standard and thus, there is no option processing, so all -o options are completely ignored.

Now if this printer was properly created using SAM and selecting a "remote" (*NOT* network) printer, then there will be no printer script in the model.orig directory. It sounds as if you added the printer as a "network" printer (in SAM terminology) which is incorrect.

However, changing to remote will not fix the limitation. All options are ignored in remote print server connections. You have two choices:

1. Insert the required escape sequences in front of each job. You can do this with a simple file and then using cat to connect the two together as in:

cat font8landscape myprintfile | lp -dmyprinter

2. Move the printer from the PC to be connected directly to the HP-UX system with a parallel cable (you may need to add a Centronics I/O card). Then install the CIFS file and print sharing software and configure the printer as a share to your PC.

3. Purchase the HP JetDirect network card and put the printer on the network. Then change the PC to talk to the printer over the network and add the printer to HP-UX using the addqueue command.

The only practical solution is #3. For the PC, you can download the printer installer from:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=19656&pr...

or use the built-in port monitor in WinXP:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=bpj07072

Now the WinXP port monitor can be a bit temperamental so I prefer using the installer since you can bypass the 'discovery' section and just enter the IP or MAC address of the printer.

For HP-UX, you already have HPPI installed so you add the printer with addqueue:

addqueue -h 12.34.56.78 -q myprinter

(check the man page for other options like no banner). The man page for your printer options will be: man net_ljx000
3 REPLIES
Honored Contributor Honored Contributor

Re: XP Professional to HP-UX 11i LPR and LPD

Hi,

setting printer options for remote printing is a very limited feature at HP-UX.
I don't think, model.orig is the correct file used for remote printing - it's used for network printing (JetPrint).

Either try to embed the escape sequences to change to landsacpe + font8 into the file or create a seperate XP printer using your required settings as defaults (which would not require any changes at the HP-UX side).

mfG Peter
The Universe is a pretty big place, it's bigger than anything anyone has ever dreamed of before. So if it's just us, seems like an awful waste of space, right? Jodie Foster in "Contact"
Honored Contributor Honored Contributor

Re: XP Professional to HP-UX 11i LPR and LPD

HP-UX uses the SysV Unix spooling system while Windows and Linux use the Berkeley spooling system. The SysV spooler is defined by the RFC 1179 remote printing standard and thus, there is no option processing, so all -o options are completely ignored.

Now if this printer was properly created using SAM and selecting a "remote" (*NOT* network) printer, then there will be no printer script in the model.orig directory. It sounds as if you added the printer as a "network" printer (in SAM terminology) which is incorrect.

However, changing to remote will not fix the limitation. All options are ignored in remote print server connections. You have two choices:

1. Insert the required escape sequences in front of each job. You can do this with a simple file and then using cat to connect the two together as in:

cat font8landscape myprintfile | lp -dmyprinter

2. Move the printer from the PC to be connected directly to the HP-UX system with a parallel cable (you may need to add a Centronics I/O card). Then install the CIFS file and print sharing software and configure the printer as a share to your PC.

3. Purchase the HP JetDirect network card and put the printer on the network. Then change the PC to talk to the printer over the network and add the printer to HP-UX using the addqueue command.

The only practical solution is #3. For the PC, you can download the printer installer from:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=19656&pr...

or use the built-in port monitor in WinXP:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=bpj07072

Now the WinXP port monitor can be a bit temperamental so I prefer using the installer since you can bypass the 'discovery' section and just enter the IP or MAC address of the printer.

For HP-UX, you already have HPPI installed so you add the printer with addqueue:

addqueue -h 12.34.56.78 -q myprinter

(check the man page for other options like no banner). The man page for your printer options will be: man net_ljx000
Occasional Visitor

Re: XP Professional to HP-UX 11i LPR and LPD

Just came back from 2 week vacation...

The printer that has the formatting error is configured in SAM as a remote printer. The printer is also connected via parallel port. Unfortunately, the application that prints to it is encrypted. I will try the suggestions when my workload slows down.

Thanks,
Doug