Showing results for 
Search instead for 
Do you mean 

machinfo is not working

Occasional Contributor

machinfo is not working

Hello All,

Machinfo command is not working on this server.

mlmpgag9:/ 1 # machinfo
sh: machinfo: not found.
mlmpgag9:/ 2 # whereis machinfo
machinfo:
mlmpgag9:/ 3 # uname -a
HP-UX XXXXXX B.11.11 U 9000/800 893950610 unlimited-user license
11 REPLIES
Honored Contributor Honored Contributor

Re: machinfo is not working

HPUX 11.11 -> machinfo command does not exits

Only in HPUX 11.31

root@abc [/] # which machinfo;uname -a
no machinfo in /usr/sbin /usr/bin /usr/ccs/bin /usr/contrib/bin /opt/prm/bin /t
HP-UX abc B.11.11 U 9000/800 unlimited-user license

ABC:/ # which machinfo;uname -a
/usr/contrib/bin/machinfo
HP-UX abc B.11.31 U ia64 unlimited-user license


Problems are common to all, but attitude makes the difference
Honored Contributor Honored Contributor

Re: machinfo is not working

Hi Praveen,

I guess, machinfo might not work on PA RISC machines.
Try "#print_manifest" instead if ignite is installed.
Don't fix that what ain't broke
Honored Contributor Honored Contributor

Re: machinfo is not working

right machinfo is for Intrgrity box and its independent of OS, at least work on 11.23 and 11.31, don have any box 11.11 right now with me :(

BR,
Kapil+
I am in this small bowl, I wane see the real world......
Honored Contributor Honored Contributor

Re: machinfo is not working

Hey..
just got 11.11 system.

>machinfo
sh: machinfo: not found.
>whereis machinfo
machinfo:

>model
9000/800/A500-5X
>uname -a
HP-UX XXXXX B.11.11 U 9000/800 XXXXXX unlimited-user license
Don't fix that what ain't broke
Respected Contributor Respected Contributor

Re: machinfo is not working

Hi,

It is (or should be) a part of the HP-UX operating system on Itanium (HP-UX 11.2x).

It does not exist on PA-RISC versions of HP-UX (11.11 and below).

machinfo is bundled in OS-Core.USRCONTRB
on HP-UX 11.23 (Itanium) you can find it in
/usr/contrib/bin/machinfo

The machinfo tool is designed for Itaniums only.

You can also use
/opt/ignite/bin/print_manifest
to get a lot of information.

you can use dmesg , uname, model, getconf

Hope it will help, to resolve ur issue.

Rgds//
Taifur
Respected Contributor Respected Contributor

Re: machinfo is not working

machinfo will only work on Itanium systems not on PA-RISC .
All things excellent are as difficult as they are rare
Acclaimed Contributor Acclaimed Contributor

Re: machinfo is not working

As said, machinfo works on PA-RISC machines only with 11.31.


But you can pull all information from STM or SAM.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Valued Contributor Valued Contributor

Re: machinfo is not working

Hi,
You can use the below commands.

1. # print_manifest.
2. # cstm
>mapall
>il (infolog)


regards,
Prasanth Thomas.
Occasional Visitor

Re: machinfo is not working

info cpu -cores

 

or machinfo with HP RX 2800 i2

Occasional Visitor

Re: machinfo is not working

which correct commands?
Acclaimed Contributor Acclaimed Contributor

Re: machinfo is not working

>which are correct commands?

 

To do what?  machinfo will work on your Integrity server.