Showing results for 
Search instead for 
Do you mean 

stop ftp syslog entries

SOLVED
Go to Solution
Highlighted
Occasional Advisor

stop ftp syslog entries

I want to stop ftp syslog entries. I removed the "-l" option in inetd.conf and issued a "inetd -c" to reread the conf file - but I still get syslog entries for ftp transactions. I even restarted the network with /sbin/init.d/inetd stop; /sbin/init.d/inetd start.

No dice!

Any help is appreciated.

Thomas
1 ACCEPTED SOLUTIONS
Honored Contributor Honored Contributor

Re: stop ftp syslog entries

Thomas,

Even if you remove the -l option to ftpd from inetd.conf, if you have inetd running with -l option it will still log the ftp connections to /var/adm/syslog/syslog.log

Disable inetd connection logging

# inetd -l

inetd -l will toggle the connection logging.

# tail /var/adm/syslog/syslog.log
inetd: Connection logging disabled
#

Now try ftp

- Sundar.
Learn What to do ,How to do and more importantly When to do ?
3 REPLIES
Exalted Contributor Exalted Contributor

Re: stop ftp syslog entries

The -l option only disables enhanced logging. ftp logging is covered in the syslog configuration.
/etc/syslog.conf

You may want to try and shunt the ftp information into a seperate file so it stops bothering you.

perhaps add a line

ftp /var/adm/syslog/ftp.log

or

ftpd /var/adm/syslog/ftpd.log

save the file.

/sbin/init.d/syslogd stop
/sbin/init.d/syslogd start

The last part I'm sure of. That will stop and start the daemon.

The first part, i know you can do it in the syslog.conf file, but i'm not sure of the whether its ftp or ftpd

SEP

Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Honored Contributor Honored Contributor

Re: stop ftp syslog entries

Thomas,

Even if you remove the -l option to ftpd from inetd.conf, if you have inetd running with -l option it will still log the ftp connections to /var/adm/syslog/syslog.log

Disable inetd connection logging

# inetd -l

inetd -l will toggle the connection logging.

# tail /var/adm/syslog/syslog.log
inetd: Connection logging disabled
#

Now try ftp

- Sundar.
Learn What to do ,How to do and more importantly When to do ?
Honored Contributor Honored Contributor

Re: stop ftp syslog entries

hai,

If you want to use another file other that syslog to store file transfer logs then go to xferlog.

If you are not using that file, by default ftp transcations will be stored on syslog only there.

Start the ftpd on inetd.conf as,
.. ftpd -i -o

inetd -c

See more on xferlog man page.

HTH.

Easy to suggest when don't know about the problem!