System Administration
Showing results for 
Search instead for 
Do you mean 

vmunix: kthread: table is full

SOLVED
Go to Solution
Occasional Advisor

vmunix: kthread: table is full

dear sir/madam:
after i login the system, it always returns "fork failed" whatever i typed in. so I had to restart the system.
I found some messages in OLDsyslog.log that I pasted below:
----------------------------------------------
Mar 20 23:28:56 cs_svr03 vmunix: kthread: table is full
Mar 20 23:29:40 cs_svr03 inetd[915]: ftp/tcp: accept: Bad file number
Mar 20 23:31:22 cs_svr03 vmunix: kthread: ta...
Mar 20 10:37:02 cs_svr03 ACEAGENT: Failed to create Thread.
-----------------------------------------------
I guess the reason may be related to system resource limits. but I don't know which parameter should I tune? could you give me a hand?

sincerely yours

Andy.
9 REPLIES
Honored Contributor Honored Contributor

Re: vmunix: kthread: table is full

It is related with nkthread kernel parameter.

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=63788

--
Muthu
Easy to suggest when don't know about the problem!
Honored Contributor Honored Contributor

Re: vmunix: kthread: table is full

Hi Andy,

Can you post the output of this ?

# kmtune -l -q nkthread

# kmtune -l -q nproc

In my system, it is

#kmtune -l -q nkthread
Parameter: nkthread
Current: 499
Planned: (((NPROC*7)/4)+16)
Default: (((NPROC*7)/4)+16)
Minimum: -
Module: -
Version: -
Dynamic: No

#kmtune -l -q nproc
Parameter: nproc
Current: 276
Planned: (20+8*MAXUSERS)
Default: (20+8*MAXUSERS)
Minimum: -
Module: -
Version: -
Dynamic: No


-Arun
"A ship in the harbor is safe, but that is not what ships are built for"
Honored Contributor Honored Contributor

Re: vmunix: kthread: table is full

You might be hitting,nkthread or max_thread_proc parameter. check both.
There is no substitute to HARDWORK
Occasional Advisor

Re: vmunix: kthread: table is full

Sorry. I forgot some informations might be helpful for solving the problem. some parameters' value are here.
maxusers = 512
max_thread_proc = 4096
Occasional Advisor

Re: vmunix: kthread: table is full

hi, Arun
I've seen the problem. nkthread's value is 9458. it's even less than default value 17971 (((NPROC*7)/4)+16). the nproc is 10260.

Now I plan to reconfigure the kernel. Would you please have a look at the steps I wanna follow and correct it?
step 1: cd /stand; cp system system.prev
step 2: select "Process New Kernel" from the SAM action menu.
step 3: select "Move kernel into place"
step 4: select "Shutdown/Reboot System Now"

thanks!
Honored Contributor Honored Contributor

Re: vmunix: kthread: table is full

hi andy,

The steps are ok except:

step 1: cd /stand; cp system system.prev

i would also copy vmunix
e.g. cp vmunix vmunix.prev


just to be cautious...

kind regards
yogeeraj

No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Honored Contributor Honored Contributor

Re: vmunix: kthread: table is full

Hi Andy,

To Reconfigure kernel, you can follow these steps,

1) Copy /stand/system & /stand/vmunix

2) /stand/dlkm

3) Use SAM to reconfigure and build kernel

4) Reboot using new kernel.


-Arun
"A ship in the harbor is safe, but that is not what ships are built for"
Honored Contributor Honored Contributor

Re: vmunix: kthread: table is full

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=63788

Refer mike tully's reply. It is telling all about kernel rebuild after parameter change.

--
Muthu
Easy to suggest when don't know about the problem!
Honored Contributor Honored Contributor

Re: vmunix: kthread: table is full