System Management
Showing results for 
Search instead for 
Do you mean 

WARNING LDEV 15 IS A DUPLICATE OF LDEV 4

Occasional Visitor

WARNING LDEV 15 IS A DUPLICATE OF LDEV 4

I received this error message (subject line) after adding LDEVS 15,16,17,18 in SYSGEN and rebooting. The LDEVS are luns 0-3 in a 2nd MODEL 20 array that has been added to the system. LDEV 4 is a LUN on the original model 20. I spoke with an engineer from our service provider and he explained that it is just a warning because the new volumes have not been initialized. He told me that I won't see the message after I configure the new LDEVS in volutil and reboot. I was hesitant to do that the other night because I was worried I might destroy the member on ldev 4 so I backed out the configuration. I would like someone to verify whether I can proceed as suggested without worrying about destroying the volume on ldev 4.

Here is the current volume info:
:dstat all
LDEV-TYPE STATUS VOLUME VOLUME SET - GEN
---------- ------- ----------------------------------
1-C2300WDR1 MASTER MEMBER1 MPEXL_SYSTEM_VOLUME_SET-0
2-C2300WDR1 MEMBER MEMBER2 MPEXL_SYSTEM_VOLUME_SET-0
3-C2300WDR5 MASTER MEMBER1 NPROD1_VOLUME_SET-0
4-C2300WDR5 MEMBER MEMBER2 NPROD1_VOLUME_SET-0
5-C2300WDR5 MASTER MEMBER1 NPROD2_VOLUME_SET-0

Here are the volutil commands I would use for the new luns:

Add new ldevs using VOLUTIL

VOLUTIL
Volutil: newset SNAME=NPROD3_VOLUME_SET MASTER=MEMBER1 LDEV=15 PERM=100
Volutil: newvol VNAME=NPROD3_VOLUME_SET:MEMBER2 LDEV=16 PERM=100
Volutil: newvol VNAME=NPROD3_VOLUMT_SET:MEMBER3 LDEV=17 PERM=100
Volutil: newvol VNAME=NPROD3_VOLUME_SET:MEMBER4 LDEV=18 PERM=100

Here is the message I sent to the engineer (see attachment for current paths):

I installed the IO cards in slot 8 (path 1/10, connected to SP A) and slot 9 (path 1/4, connected to SP B). I was unable to screw in the cables and terminators in the model 20 chassis (something missing?) so the cables are not very secure. I brought the system back up after connecting the array and I stopped the bootup to get into ODE and MAPPER2. The I/O listing showed the paths of the LUNS in the new array as follows:

1/4/0/0.0.0
1/4/0/0.0.1
1/4/0/0.0.2
1/4/0/0.0.3

1/10/0/0.1.0
1/10/0/0.1.1
1/10/0/0.1.2
1/10/0/0.1.3

I brought the system up with START NORECOVERY NOSYSSTART, logged in as MANAGER.SYS and got into SYSGEN to add the following:

SYSGEN
Sysgen>IO

IO> ap 1/4 id=PAT_PCI_BC
IO> ap 1/4/0 id=PCI_DEVICE
IO> ap 1/4/0/0 id=A5150A
IO> ap 1/4/0/0.0 id=PSEUDO
IO> ad 15 1/4/0/0.0.0 HPC2300WD class=DISC
IO> ad 16 1/4/0/0.0.1 HPC2300WD class=DISC
IO> ap 1/10 id=PAT_PCI_BC
IO> ap 1/10/0 id=PCI_DEVICE
IO> ap 1/10/0/0 id=A5150A
IO> ap 1/10/0/0.1 id=PSEUDO
IO> ad 17 1/10/0/0.1.2 HPC2300WD class=DISC
IO> ad 18 1/10/0/0.1.3 HPC2300WD class=DISC
IO> HO
IO> exit
Sysgen> SY
Sysfile> HO
Sysfile> exit
Sysgen> KEEP
Sysgen> exit

I did a CTRL-A shutdown, CTRL-B RS, and brought the system up again with START NORECOVERY NOSSYSTART. As the system was coming up I saw that it listed LDEVS 15,16,17,18 and then it showed warning messages:

LDEV 15 DUPLICATE OF LDEV 4
LDEV 16 DUPLICATE OF LDEV 4
LDEV 17 DUPLICATE OF LDEV 4
LDEV 18 DUPLICATE OF LDEV 4

At that point I decided to back out the configuration so I logged back in, removed everything I added and rebooted again with NORECOVERY NOSYSSTART. I logged back in to make sure that there were no problems with the private volumes and LDEV 4 (there were no problems). I rebooted one more time with just START NORECOVERY. Everything came up OK and I restarted the schedule after backup and watched for 45 minutes while everything was running OK.

I hope you can help me figure out what went wrong with the configuration. Do we have to change some of the switches on the back of the model 20? I believe the settings are the same as the original model 20. Do we have to move the I/O cards to different paths? (see attached path listing before the addition).

Thanks,

Paul


6 REPLIES
Honored Contributor Honored Contributor

Re: WARNING LDEV 15 IS A DUPLICATE OF LDEV 4

Hi Paul,

Based on your config, this is an HP3000 N4000 server. The addresses 1/4 and 1/10 are corresponding to the correct side of the server (1=right bus, 1/4=slot #9, 1/10=slot #8).

The ldevs config is correct:
ldev#15 1/4/0/0.0.0 HPC2300WD class=DISC
ldev#16 1/4/0/0.0.1 HPC2300WD class=DISC
ldev#17 1/10/0/0.1.2 HPC2300WD class=DISC
ldev#18 1/10/0/0.1.3 HPC2300WD class=DISC

Please provide the ldev#4 config.

It is very important the Nike Model20 is terminated properly otherwise conflicting addressing may occur. Make sure all cables and terminators are solidly screwed.
King is the customer!
Occasional Visitor

Re: WARNING LDEV 15 IS A DUPLICATE OF LDEV 4

Here is the config for ldev 4. The full system config is in the attachment.

Thanks,

Paul

PATH: 0/4 LDEV: ID: PAT_PCI_BC TYPE: BC
PMGR: PCI_ELROY_MGR PMGRPRI: 2 LMGR: MAXIOS: 0

PATH: 0/4/0 LDEV: ID: PCI_DEVICE TYPE: BC
PMGR: PCI_DEVICE_MGR PMGRPRI: 2 LMGR: MAXIOS: 0

PATH: 0/4/0/0 LDEV: ID: A5150A TYPE: DA
PMGR: PCI_SCSI_DAM PMGRPRI: 6 LMGR: MAXIOS: 0

PATH: 0/4/0/0.1 LDEV: ID: PSEUDO TYPE: DA
PMGR: TRANSPARENT_MGR PMGRPRI: 6 LMGR: MAXIOS: 0

PATH: 0/4/0/0.1.1 LDEV: 2 ID: HPC2300WD TYPE: DISC
PMGR: SCSI_DISK_AND_ARRAY_DM PMGRPRI: 8 LMGR: LOGICAL_DEVICE_MANAGER MAXIOS: 0

PATH: 0/4/0/0.1.2 LDEV: 5 ID: HPC2300WD TYPE: DISC
PMGR: SCSI_DISK_AND_ARRAY_DM PMGRPRI: 8 LMGR: LOGICAL_DEVICE_MANAGER MAXIOS: 0

PATH: 0/4/0/0.1.4 LDEV: 4 ID: HPC2300WD TYPE: DISC
PMGR: SCSI_DISK_AND_ARRAY_DM PMGRPRI: 8 LMGR: LOGICAL_DEVICE_MANAGER MAXIOS: 0
Honored Contributor Honored Contributor

Re: WARNING LDEV 15 IS A DUPLICATE OF LDEV 4

Hi Paul,

Ldev#4 config is correct; it is on the left side bus (0). Ldev#15,16,17,18 cannot be a duplicate of ldev#4.

I would make sure the Nike array cables are solidly screwed and properly terminated.
King is the customer!
Occasional Visitor

Re: WARNING LDEV 15 IS A DUPLICATE OF LDEV 4

What about the claim from my tech guy? He says that the message will go away when I create new volumes on ldevs 15-18 with volutil and reboot. I don't have a test system I can try this on. If there is already a mounted volume on a LDEV and you try to create a new volume with volutil will it corrupt the mounted volume or just produce and error message that says the ldev already has a mounted volume on it?
Occasional Visitor

Re: WARNING LDEV 15 IS A DUPLICATE OF LDEV 4

I proceeded with the configuration. I made LDEV 15 the master volume in a new volumeset and the others as members to that volumeset. The LDEVS were in the UNKNOWN state before I used the volutil commands. I rebooted the system after the volutil commands and I no longer saw the error messages on boot up.
Highlighted
Occasional Visitor

Re: WARNING LDEV 15 IS A DUPLICATE OF LDEV 4

The warning messages were misleading and were probably there because the volumes were in the "UNKNOWN" state before being configured with volutil.