Systems Insight Manager Forum
Showing results for 
Search instead for 
Do you mean 

VCRM invalid or not reachable from all VCA's

SOLVED
Go to Solution
Occasional Contributor

VCRM invalid or not reachable from all VCA's

[ Edited ]

I am having an issue with the Version Control Repository Manager version 7.3. None of my Version Control Agents are able to communicate with it. When attempting to go through the VCA settings to save the new VCRM I get the message "The specified repository, servername.domainname.com, is invalid or not reachable."

 

This seems to have started happening after upgrading HP SIM and VCRM from 7.2 to 7.3 but I can't pinpoint the exact point in time that everything broke. Point is it used to work this way in the past and stopped.

 

HP SIM 7.3 and VCRM 7.3 are installed on the same 2008 R2 server. All the server agents can talk to HP SIM just fine. I am using username/password authentication for the VCA and I have verified the account has admin rights to the VCRM server OS.  I have tried using certificate authentication as well with the same resulting error message about the VCRM being invalid or unreachable.

 

To troubleshoot I even built a brand new server from scratch, installed HP SIM 7.3 and VCRM 7.3 (from scratch), and have the same issue.

 

What can I do to troubleshoot this? 

 

P.S. This thread has been moved from ProLiant Servers (ML,DL,SL) to ITRC HP Systems Insight Manager Forum. -HP Forum Moderator

17 REPLIES
Occasional Visitor

Re: VCRM invalid or not reachable from all VCA's

I have exactly the same problem. Been pulling my hair out for the last three days trying to fix it.

Not only can none of the VCA's talk to it, the local VCA running on the VCRM server can't talk to it locally even with localhost.

 

I have tried configuring via Certificate and Login, neither work.

 

Looks to me like VCRM 7.3 is fundementally broken.

 

Occasional Visitor

Re: VCRM invalid or not reachable from all VCA's

Ok, this works...

 

Manually update your VCA's to 7.3.0.0 and they can then talk to the VCRM.

 

However, according to another thread here (http://h30499.www3.hp.com/t5/ITRC-HP-Systems-Insight-Manager/HP-Version-Control-issues-after-upgrade-from-version-7-2-2-0-to/td-p/6319379#.Ut02qPRFDyM), this new version has issues with firmware and BIOS updates not being shown.

Honored Contributor

Re: VCRM invalid or not reachable from all VCA's

Hello there,

 

Looks a lot like the problem below:

 

http://h30499.www3.hp.com/t5/ITRC-HP-Systems-Insight-Manager/HP-Version-Control-issues-after-upgrade-from-version-7-2-2-0-to/td-p/6319379

 

Kind regards,

 

Andrew

Kind regards,

Andrew
Occasional Visitor

Re: VCRM invalid or not reachable from all VCA's

Hey guys,

 

I can just confirm Chris's approach to download the current version of vca 7.3.0.0 and install/update this on your managend systems. I also had to fight with your problems, but after I updated vca 7.2.0.0 to 7.3.0.0 it works well.

 

regards

wderr

Occasional Contributor

Re: VCRM invalid or not reachable from all VCA's

Support came back with the below commands to run on the HP VCRM server itself. It seems that HP removed some acceptable ciphers from 7.3 and that prevented the communication from earlier versions that were using communication not allowed by 7.3

 

C:\HP\hpsmh\bin>smhconfig.exe -Z ALL:!ADH:!EXPORT56:!EXPORT40:DES-CBC3-SHA:RC4-MD5:RC4-SHA:RC4+RSA:+HIGH:+MEDIUM:-SSLv2:+EXP:!LOW:!eNULL:!aNULL

C:\HP\hpsmh\bin>smhconfig.exe –r

 

After this I was able to have them communicate successfully.

 

 

This type of problem is very frustrating since it basically say that HP never did any kind of real testing before they released version 7.3.

Highlighted
Occasional Visitor

Re: VCRM invalid or not reachable from all VCA's

Worked perfectly! Thanks so much!
Occasional Visitor

Re: VCRM invalid or not reachable from all VCA's

C:\HP\hpsmh\bin>smhconfig.exe -Z ALL:!ADH:!EXPORT56:!EXPORT40:DES-CBC3-SHA:RC4-MD5:RC4-SHA:RC4+RSA:+HIGH:+MEDIUM:-SSLv2:+EXP:!LOW:!eNULL:!aNULL

C:\HP\hpsmh\bin>smhconfig.exe –r

 

Worked for me, too.  HUGE pull - THANKS!!

Occasional Visitor

Re: VCRM invalid or not reachable from all VCA's

Worked for us, Thanks a million!!!

Occasional Visitor

Re: VCRM invalid or not reachable from all VCA's

Thanks, that command resolved my issue as well!

 

Thanks HP!  Seems like I end up pulling out my hair everytime I work w/SIM updates.

Super Advisor Super Advisor

Re: VCRM invalid or not reachable from all VCA's

Thanks a lot! nightmare ended :)!
Frequent Advisor

Re: VCRM invalid or not reachable from all VCA's

That seems to help with my VCRM problems, as well. Thanks a lot.

 

AWo

Advisor

Re: VCRM invalid or not reachable from all VCA's

I have HP VCRM 7.4 installed and I have the same problem that the VCA's that have the version 7.2 cannot connect to the VCRM.

 

I tried the commands above and got some errors while exuting them - please see the attached screenshot.

 

Can anyone help me with this?

Honored Contributor

Re: VCRM invalid or not reachable from all VCA's

[ Edited ]

Have you updated the VCA to a 7.3 or higher ? That should help as a workaround . You can use HPSUM to push the newer VCA agent since you can't update trough the VCA.

 

You did run that command on the VCRM/HPSIM server ?

Kind regards,

Andrew
Advisor

Re: VCRM invalid or not reachable from all VCA's

I updated the VCA manually to the newest version and now it's working. Thanks!

Occasional Visitor

Re: VCRM invalid or not reachable from all VCA's

Worked for me, too.   THANKS!!

Occasional Advisor

Re: VCRM invalid or not reachable from all VCA's

I had the same issue - when copying and pasting from this webpage it adds a sneeky question mark before RC4, just delete that and it will run.

 

Didn't fix my problem though - still have some servers that can connect and others that can't even on the same version, will keep lookng...

Occasional Visitor

Re: VCRM invalid or not reachable from all VCA's

Well, after I almost brought my HPSIM Server to it's knee's trying to run

C:\HP\hpsmh\bin>smhconfig.exe -Z ALL:!ADH:!EXPORT56:!EXPORT40:DES-CBC3-SHA:RC4-MD5:RC4-SHA:RC4+RSA:+HIGH:+MEDIUM:-SSLv2:+EXP:!LOW:!eNULL:!aNULL

C:\HP\hpsmh\bin>smhconfig.exe -r

Which didn't fix the problem anyway, I updated the VCA Agent to 7.3.5 and the issue has been resolved.

Fix for The specified repository is invalid or not reachable

http://h20565.www2.hpe.com/hpsc/swd/public/detail?sp4ts.oid=4091567&swItemId=MTX_72d53359c85340f899e81986a7&swEnvOid=4064

** CRITICAL ** HP Version Control Agent for Windows x64

By downloading, you agree to the terms and conditions of the HP Software License Agreement.
Note: Some software requires a valid warranty, current HP support contract, or a license fee.

Type: Software - System Management Version: 7.3.5.0(5 Jun 2015)

 

http://community.hpe.com/t5/Systems-Insight-Manager-Forum/Version-Control-Agent-error-quot-The-specified-repository-quot/m-p/6812426#M60516

Thanks,

Brandy