Systems Management (OpenView-OP Mgmt) Support and News Forum
Showing results for 
Search instead for 
Do you mean 

Agent 11 patch error

Occasional Advisor

Agent 11 patch error

[ Edited ]



I am trying to insall agent patch Agent LINUX 11.02.011OALIN_00003.ISO and getting this error. I have followed the steps and my OML9 agent is 11.00.044


error is:

[root@oml linux-patch]# ./ -i -m
ERROR:   An incompatible version of the HP Operations agent deploy component was found on the HPOM management server.
         Minimum Version required for registering the patch deployable packages is 11.02
ERROR:   Install the HP Operations agent patch on the management server before registering the HP Operations agent
         patch deployable packages for all OS platforms.
ERROR:   Aborting installation.

[root@oml linux-patch]# ./ -inv
Active Versions
AIX     :PowerPC(32)    :11.00.044
AIX     :PowerPC(64)    :11.00.044
HP-UX   :IPF32          :11.00.044
HP-UX   :PA-RISC        :11.00.044
LIN     :IPF64(2.6)     :11.00.044
LIN     :PowerPC(2.6)   :11.00.044
LIN     :x64(2.6)       :11.00.044
LIN     :x86(2.6)       :11.00.044
SOL     :SPARC          :11.00.044
SOL     :x86            :11.00.044
WIN     :IPF64          :11.00.044
WIN     :x64            :11.00.044
WIN     :x86            :11.00.044


Error is asking me to get 11.02 but going from 11.00 to 11.02 is via this patch. Is there something I am missing here?




Valued Contributor

Re: Agent 11 patch error

according to KM1280022 :


The agent on the HPOM server should be upgraded
        first to 11.02 before registering the patch
        using the following commands:

        HPOM Unix/Linux:
        ./ -i -a

Occasional Advisor

Re: Agent 11 patch error

Thankyou, that worked.


Just wondering why HP can't continue with standard patch installation. ie install patch on mgmt server and then deploy it on itself and agents.