Systems Management (OpenView-OP Mgmt) Support and News Forum
Showing results for 
Search instead for 
Do you mean 

HP OMw 9.0 can supports SNMP v2?

Occasional Advisor

HP OMw 9.0 can supports SNMP v2?

Hi Experts,


I have a question, HP OMw 9.0 can supports SNMP v2, if this is possible, how can i do to setup this?.


Thnaks in advance.

Honored Contributor Honored Contributor

Re: HP OMw 9.0 can supports SNMP v2?



Yes you can handle snmpv2. You will have to set the SNMP_SESSION_MODE flag in the ovconfget settings so it is pointing to NNM_LIBS.


Check the OMW 9.0 Online Help topic "Configure SNMP conditions" as it has more details as well.

Hope this helps.


HPE Expert

Re: HP OMw 9.0 can supports SNMP v2?



Please take consideration that this is done by the Operations Agent so you can use for example:


SNMP_SESSION_MODE=NNM_LIBS  <<< this sets the session mode

SNMP_TRAP_PORT=5162 <<< This set the port


As you know opctrapi can register and listen on a different port from the default 162 that is uses. This is achieved by setting this variable.


Its possible to use also




Or even clear this setting and used only  SNMP_TRAP_PORT=5162


If no  value for SNMP_SESSION_MODE it assumes by default the setting "NETSNMP" and this usually works fine.


Details as follow:


SNMP session modes  variables (SNMP_SESSION_MODE)




NETSNMP – The trap interceptor uses Net-SNMP APIs to bind to udp:162 and udp6:162 (if available) to receive incoming SNMP traps.  >>> This is the default option <<<



NNM_LIBS – The trap interceptor uses NNM’s OvSNMP APIs to bind to udp:162 to receive incoming SNMP traps •       WIN_SNMP – The trap interceptor subscribes to Microsoft’s SNMP trap service to receive traps. In this mode, the interceptor can receive only SNMP v1 traps. This is a known limitation •      


TRY_BOTH – The trap interceptor first tries to subscribe to NNM’s PMD and if it fails, it uses NNM’s OvSNMP APIs, binds to udp:162 to receive incoming traps •       The “PMD” options only supported for Customers with extended support contracts


Please also notice from current feedback customers need to be testing NETSNMP options as the NNM formatting libraries are no longer supported by the NNM lab. Based on this your option is to use from now one the "NETSNMP" opposed to what was documented before.


Please make sure you have the latest Agent release in place which contains the latest bits and the most updated fixes.


Hope this information helps.


Thanks and Regards,

Carlos Pinto


HP Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

If you liked it I would appreciate KUDOs.

Carlos Pinto