Systems Management (OpenView-OP Mgmt) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Node group assignment to Responsibility of user

SOLVED
Go to Solution
Frequent Advisor

Node group assignment to Responsibility of user

Hello Experts,

 

I have created a new node group and assigned some nodes to the the node group. Now I need to create a user who can see/ ack run tools on the node group. I created the user. However when I try to assign the node group through "Edit Responsibilities" I can not see the node group.

 

Please note that I am not able to assign any of the newly created node groups to the user. Please help.

 

Regards,

Praveen...

9 REPLIES
Honored Contributor Honored Contributor

Re: Node group assignment to Responsibility of user

Hello Praveen,

I dont know what you mean by "Edit responsibilities" but if ithis is OMW than you should do this from "user roles configuration editor".

from this editor you can select all the roles you want to give to that user.

but make sure user is part of HP-OVE-Operator group.

HTH
-KAKA-
Honored Contributor Honored Contributor

Re: Node group assignment to Responsibility of user

Hello.

 

It tells you what to do when the view is empty - click 'Edit View' button at the bottom.

 

Regards,

    Goran

Frequent Advisor

Re: Node group assignment to Responsibility of user

Thanks for your suggestions.

 

@ KAKA: We have OMU 9.x installed on HPUX. Not OMW.

 

The problem is, the new node groups which I have created were not listed at all in the node group and message group matrix.

 

Surprisingly, today I can see all the node groups which I created. It appears that there is synchronization happening at certain time. (Im not sure at what time it happens)

 

To confirm this behavior,

 

1: I created a new node group.

2: Go to the "All User" and select the user

3: go to "Edit Responsibilities

4: Click on "Edit View"

 

Then tried to assign it to a user, the newly created node group was not visible in the responsibility matrix.

 

Is it expected behavior? Atleast I haven't come across any documentation explaining this.

 

Please let me know your thoughts.

 

Regards,

 

Praveen...

Honored Contributor Honored Contributor

Re: Node group assignment to Responsibility of user

Hello.

 

The same answer applies here as well - click "Edit View" to add the newly created group to the view first (make sure you transfer it from the "Available Node Groups" on the left to the "Visible Node Groups" on the right before clicking OK).

 

Regards,

    Goran

Frequent Advisor

Re: Node group assignment to Responsibility of user

Hello Goran,

 

Thats the issue, the new node group created is not listed under "Available Node Groups", as a result I can not move it to "Visible Node Groups"

 

Regards,

 

Praveen...

Honored Contributor Honored Contributor

Re: Node group assignment to Responsibility of user

Hi.

 

Apparently that information is cached, so it seems there's a bug where it's not being updated properly.  It would be best to open a case with HP to figure this out.

 

Restarting AdminUI shall help.

 

Regards,

    Goran

Frequent Advisor

Re: Node group assignment to Responsibility of user

Hello Goran

 

I restarted OMU completely(ovc -kill), not just AdminUI and it didnt help. Better to contact HP support. The problem can be reproduced easily, so HP should provide a solution.

 

Regards,

 

Praveen...

 

 

 

Honored Contributor Honored Contributor

Re: Node group assignment to Responsibility of user

I tried what you described on my OMU9.10 Solaris, admin UI 9.1.0 with 2 hotfixes, Firefox 21. I have no problems.
I have plans to install the new patch OMUADMINUI_00003

JP.
Highlighted
Frequent Advisor

Re: Node group assignment to Responsibility of user

Thank you all for your help. It appears to be some issue with IE 9. Works perfectly fine with FireFox. The problem was resolved after I switched to "Compatibility View"

 

Regards,

Praveen...