Systems Management (OpenView-OP Mgmt) Support and News Forum
Showing results for 
Search instead for 
Do you mean 

couldn't trigger certificate request

Go to Solution
Valued Contributor

couldn't trigger certificate request

Hello guys,


I'm not able to trigger certificate request. PFB output of ovc -status.. I tried ovc -kill -start etc but services remain stopped..Please suggest.. node is pointing to mgmt server only...coreid is present..


C:\Documents and Settings\#svchpbsm>ovc -status
agtrep        OV Discovery Agent                AGENT,AgtRep          Stopped
coda          OV Performance Core               COREXT       (1172)   Running
opcacta       OVO Action Agent                  AGENT,EA              Stopped
opccfgfile    OVO configfile Agent              AGENT,EA              Stopped
opceca        OVO Event Correlation             AGENT,EA              Stopped
opcecaas      ECS Annotate Server               AGENT,EA              Stopped
opcle         OVO Logfile Encapsulator          AGENT,EA              Stopped
opcmona       OVO Monitor Agent                 AGENT,EA              Stopped
opcmsga       OVO Message Agent                 AGENT,EA              Stopped
opcmsgi       OVO Message Interceptor           AGENT,EA              Stopped
opctrapi      OVO SNMP Trap Interceptor         AGENT,EA              Stopped
opcwbemi      OVO WMI Interceptor               AGENT,EA              Stopped
ovbbccb       OV Communication Broker           CORE                  Starting
ovcd          OV Control                        CORE         (2348)   Running
ovconfd       OV Config and Deploy              COREXT                Stopped
rtmd          HP Real Time Measurement          AGENT                 Stopped

C:\Documents and Settings\#svchpbsm>ovcert -certreq
ERROR:   ( Could not trigger certificate request.
          (bbc-431) HttpOutputRequestImpl::ProcessRedirection()
         HttpStatus::NotFound : caught ServiceUnknownException. There is no
         server process registered for address: http://localhost/

Valued Contributor

Re: couldn't trigger certificate request

thanks for ur suggestions

Regular Advisor

Re: couldn't trigger certificate request


    Did u saved  the ip address and hostname of node in server and servers's ip address and hostname in etc -host files?

 Next just confirm the hp services running properly by going to services.

Next try to put below path  in cmd,open cmd in, "Run as  Administrator"


  C:\Program Files\HP\HP BTO Software\bin\OpC\install


enter the command ,



then again check the status of agent.


I think it works for u.



With Regards,

Vasantha P.R

Honored Contributor Honored Contributor

Re: couldn't trigger certificate request


You have to start the services to be able to request certificate from your OM server.



Mahmoud Ibrahim
  • Say thanks by clicking the "Kudos! Star" which is on the left.

  • Make it easier for other people to find solutions, by marking my answer with "Accept as Solution" if it solves your issue.
  • Honored Contributor Honored Contributor

    Re: couldn't trigger certificate request



    can you check on your agent if the management server is registered? Did you only install the agent or also configure it. During configuration the management server address and the certificate server address is written into agent config.


    You can test it e.g. via



    You should have something like




    If not you need to configure the agent.



    Valued Contributor

    Re: couldn't trigger certificate request

    thanks for ur suggestions