UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICATE

SOLVED
Go to Solution
Highlighted
Frequent Advisor

FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICATE

Hi,

i have established ssh connection to the node and now try to push ud agent.bt i get this msg "FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICATE" and task get failed.

 

PFA .......

 

THANKS N ADVANCE

  YOGESH

13 REPLIES
Trusted Contributor

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICATE

what user you are using for ssh credentail, does this user has got admin privelge in the remote server.

 

 

The below user, usually comes when the ssh user you are using dont have permission to ftp the file .

 

ssh internally uses it's own ftp mechanism to upload the file.

 

<EXEC start="11:35:34" duration="126" CMD="uploadFile" RESULT="" IS_NULL="Y">
        <ERROR class="com.mindbright.ssh2.SSH2SFTP$SFTPDisconnectException">
            <message>[CDATA&colon; no message]</message>
            <stacktrace>
                <frame class="com.mindbright.ssh2.SSH2SFTP$SFTPPacket" method="readFailed" file="SSH2SFTP.java" line="842" />
                <frame class="com.mindbright.nio.Switchboard" method="handleKey" file="Switchboard.java" line="458" />
                <frame class="com.mindbright.nio.Switchboard" method="run" file="Switchboard.java" line="348" />
                <frame class="java.lang.Thread" method="run" file="Thread.java" line="722" />

Frequent Advisor

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICATE

Hi bravi,

 

Thanks for the reply.am using windows server 2008 and have installed cygwin with admin privilages .and i have opened port 22 and 2738 b/w this node and server for uda agent 2 communicate..... b/w firewall is present ...so i have opened the port.

 

so tel me wat action is required?

 

Thanks n advance

yogesh

HPE Expert

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICATE

Please check that sftp was installed along with Cygwin. More here http://superuser.com/questions/376819/sftp-client-with-cygwin-is-it-possible.

 

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at bottom to say 'Thanks'.
HPE Expert

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICATE

According to the logs, the problem related to lock. Install/Update UD Agent process should have exclusiveness on node - during Inventory Discovery Scanner updates some Agent Options which also updated/used during UD Agent deployment.

Please be sure to check that you have no Management zones with overlapped IP ranges.

You can find/remove the lock in Windows registry. Please check attached screenshots.

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at bottom to say 'Thanks'.
Frequent Advisor

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICAT

 

Hi Dima,

 

 

please explain me the lock concept clearly.......and let me know what i have to do? do i need to remove exclusive lock alone from registry...

 

please help me on this........

 

tanks n advance

yogesh s

HPE Expert

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICAT

When we starting connection for deployment we're putting lock. Removing at the end of the script.

 

In your case, logs showing  that you trying to connect to system that already locked.

It could be result of 2 jobs trying to do the same, or some problems.

 

We need to investigate this...

 

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at bottom to say 'Thanks'.
Frequent Advisor

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICAT

Hi Dima ,

 

at end of wat script do i need to add....please let m e know and i dnt see task running for install agent in my gui .......

 

thanks n advance

 

yogesh

HPE Expert

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICAT

Please do not modify script. 

Connect to the destination server and check the registry.

If you have lock, remove it and try to redeploy the agent.

Be sure that you have only one Job/activity performing that at the same time.

Regards,

-Dima

 

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at bottom to say 'Thanks'.
Frequent Advisor

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICAT

tanks dima..........
i can get you ..bt i dnt see a job runing for instal agent inspite of selecting instal agent...and their is only update lock dat appears in registry and disappear after task get fails...........
HPE Expert

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICAT

So, let's move discussion to HP SSO. We need investigate it. 

Sorry, no quick wins...

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at bottom to say 'Thanks'.
Frequent Advisor

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICAT

do you have any idea of licensing in ud.............
HPE Expert

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICAT

Please ask more specific question.

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at bottom to say 'Thanks'.
Frequent Advisor

Re: FAILED TO INSTALL UD AGENT AND FAILED TO UPLOAD UD AGENT CERTIFICAT

only sum files are getiing upload in path windows/uda_agent .while connection is getting disconnect for other transfer