UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

UCMDB 10.1 doesn't open login page after startup - error log message in body.

SOLVED
Go to Solution
Occasional Advisor

UCMDB 10.1 doesn't open login page after startup - error log message in body.

Hello,

 

I have a problem with the start of the UCMDB 10.1 server and I hope this is the right forum.

 

We had a functioning installation of UCMDB, but after a reboot of the server we can't log in anymore in UCMDB.

I simply start the server with the "server.sh start" command.

The startup.log says that everything is fine.

We can even connect to the status page (http://ipaddress:8080/status) that says that every component is UP .

 

But when we go to login page we get an "Internal Server Error".

 

If I open the error.log on server I can see that the following message is repeated continuosly:

 

[CmdbLifeCycleManager periodic customers detection] (CmdbConnectorImpl.java:166) ERROR - User name or password are wrong - failed to login on UCMDB

 

 

I am sure that the user/password of the Oracle DB are set and are correct.

But I just cannot say to what user and password the log is referring to.

Unfortunately, I have not installed and configured the product and the person who did it is no more available.

 

Any Help is appreciated

 

Thanks in Advance and Regards,

 

Dario Cuccaro

 

1 ACCEPTED SOLUTIONS
HPE Expert

Re: UCMDB 10.1 doesn't open login page after startup - error log message in body.

Hi,

The problem you're decribing could be result of changing  pwd for user UISysadmin. If this is a case, you needed to execute the jmx-console as documented in the developer guide:


There are two out-of-the-box system users; it is recommended to change their passwords after installation using the changeSystemUserPassword method.
- sysadmin/sysadmin
- UISysadmin/UISysadmin (This user is also the Super Integration User SuperIntegrationUser).
If you change the UISysadmin password using changeSystemUserPassword, you must execute the following method: in the JMX Console, locate the UCMDB-UI:name=UCMDB Integration service. Run setCMDBSuperIntegrationUser with the user name and new password of the integration user.

 

Hope this helps.

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at bottom to say 'Thanks'.
5 REPLIES
HPE Expert

Re: UCMDB 10.1 doesn't open login page after startup - error log message in body.

Hi,

The problem you're decribing could be result of changing  pwd for user UISysadmin. If this is a case, you needed to execute the jmx-console as documented in the developer guide:


There are two out-of-the-box system users; it is recommended to change their passwords after installation using the changeSystemUserPassword method.
- sysadmin/sysadmin
- UISysadmin/UISysadmin (This user is also the Super Integration User SuperIntegrationUser).
If you change the UISysadmin password using changeSystemUserPassword, you must execute the following method: in the JMX Console, locate the UCMDB-UI:name=UCMDB Integration service. Run setCMDBSuperIntegrationUser with the user name and new password of the integration user.

 

Hope this helps.

Regards
-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at bottom to say 'Thanks'.
Highlighted
Occasional Advisor

Re: UCMDB 10.1 doesn't open login page after startup - error log message in body.

Hi Dima,
sorry for late reply. I opened a case with support and what you described was exactly my problem.
I've marked your reply as a solution.

Thanks and Regards,
Dario
Frequent Advisor

Re: UCMDB 10.1 doesn't open login page after startup - error log message in body.

Hi,

 

I am facing the same issue, but executing "setCMDBSuperIntegrationUser" with the new credentials still fails/not resolve the issue.

 

Is there a restriction on the length and characters used in the password?

 

 

J

Advisor

Re: UCMDB 10.1 doesn't open login page after startup - error log message in body.

Hi,

 

I have the same problem - the method setCMDBSuperIntegrationUser doesn't do anything.

 

So I can't login in on the interface.

 

Do you have any solution for this?

 

Thanks,

Adina

Valued Contributor

Re: UCMDB 10.1 doesn't open login page after startup - error log message in body.

Out of the box, there are password restrictions:

 

The default password policy requires the UCMDB password to include at least one of
each of the four following types of characters:
Uppercase alphabetic characters
Lowercase alphabetic characters
Numeric characters
Symbol characters ,\:/. _?&%=+-[]()|

 

The OOTB minimum password length is 8 characters

 

You can reset a password in the JMX. UCMDB:service=Authorization Services and go to resetPassword

 

 

Rey Lejano

effectualsystems.com