UCMDB and UD Practitioners Forum (Previously CMS)
Showing results for 
Search instead for 
Do you mean 

upgrade process from uCMDB 8.07 to 9.05 fails

Frequent Advisor

upgrade process from uCMDB 8.07 to 9.05 fails


Does anyone know how to overcome the problem below?

We are upgrading uCMDB 8.07 to 9.05 The upgrade process fails in the 'Validate and upgrade the class model' step. 
Already tried to rerun several times the tool without success. 


The error.log reports: 
ERROR - upgrade error for [validateClassModelAndUpgrade] 
java.lang.IllegalArgumentException: User class model is not valid for upgrade. Please see details in logs. These problems must be fixed before continuation of upgrade process.


Thanks and regards.


HPE Expert

Re: upgrade process from uCMDB 8.07 to 9.05 fails


The error realted to the class model different from what 9.05 expected to see in your 8.07 system.

The deployment guide for UCMDB 9.05 has Prereuisitesfor upgrade section on p.62.

It states: 

If you have Discovery and Integration Content Pack 7.00 or earlier, you must install Content
Pack 8.00. This step must be performed after upgrading to version 8.04 or later.


Please pay attention to following:

Note: When upgrading from UCMDB 8.0x to 9.05, the highest Content Pack version you
can run is version 8.00. You cannot install Content Pack 10.00 with the upgrade.
However, after upgrading UCMDB, you can upgrade the Content Pack version separately.


In addition, I'd suggest installation latest CUP on top of 9.05 codebase prior to starting of Upgrade. Several upgrade related bug were fixed in CUPs.


-Dmitry Gomel, PMP
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Click the Like button at bottom to say 'Thanks'.
Trusted Contributor

Re: upgrade process from uCMDB 8.07 to 9.05 fails

Do you still see the same issue ?