Unified Functional Testing Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Compatibility of QTP 11 with jdk 1.7

Occasional Visitor

Compatibility of QTP 11 with jdk 1.7

I need patch to hot fix to support java7.

Could  anyone please share the   Java 7 -  QTPJV_00057

9 REPLIES
Honored Contributor

Re: Compatibility of QTP 11 with jdk 1.7

You need to open a request with HP to get that patch. Sharing of such items is generally a violation of licensing agreements between clients and HP.
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
HPE Expert

Re: Compatibility of QTP 11 with jdk 1.7

Hello ,

 

There are 2 Hotfixes required to support JDK 1.7.

QTPJV_00051 for desktop apps , QTPJV_00057 for testing Java applets.

 

Please open a support case with us requesting for the Hotfixes. It will be privately provided to you over an FTP link.

 

Regards,

HP support

[If this post or any other post helps to resolve your issue or query, mark the thread as solved and give KUDOS to the author for their assistance. ]

( Posts and opinions made here are my own and do not reflect the opinions of my employer HPE in any way . )
Frequent Advisor

Re: Compatibility of QTP 11 with jdk 1.7

HP recommened adding Patch QTP_00782 to resolve my issue and now QTP 11 works with Oracle objects.
Highlighted
Occasional Visitor

Re: Compatibility of QTP 11 with jdk 1.7

ORacle application with Java 7. 

have installed required java patches, but oracle objects are being identified as java objects.

Will this Patch QTP_00782 help identify Oracle objects?

 

 

Occasional Visitor

Re: Compatibility of QTP 11 with jdk 1.7

I have a similar issue here. I have QTP 11 and I am using oracle EBS. Recently we have to install JRE 1.7. The EBS application is no longer working. I submitted a support SR but did not get any resolution. not sure what to do with this issue.
Occasional Visitor

Re: Compatibility of QTP 11 with jdk 1.7

Looks like, these are the batch I need to fix the QTP JDK 1.7 issue, can anyone help getting these to fixexes.

There are 2 Hotfixes required to support JDK 1.7.

QTPJV_00051 for desktop apps , QTPJV_00057 for testing Java applets.

The support case I opened two weeks ago requesting fixes did not help.

Regards,
Occasional Visitor

Re: Compatibility of QTP 11 with jdk 1.7

hi,

can I have  the hotfix for jave version 1.7.55  , 1.7.51 and 1.7.11 , need to check which version we can use in our QTP project, thank you!!!

Frequent Advisor

Re: Compatibility of QTP 11 with jdk 1.7

[ Edited ]

I have QTP 11 and jdk 1.7 build 55 (32 bit) working on Win7 32-bit OS but am having trouble qetting the same to work on a Win7 64-bit OS.  I've installed pathes QTP_00699 and QTP_00709 but no luck. My Oracle EBS application is being recognized as SunAWTFrame objects.  Web pages are recognized correctly. 

Occasional Visitor

Re: Compatibility of QTP 11 with jdk 1.7

I am using UFT 12.5 and I'm not able to see java applet objects.   It sees it as a generic WinObject: SunAwtCanvas.  Does 12.5 support java applets?  Thanks