Unified Functional Testing Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Getting HLLAPI DLL was not found while selecting Terminal Emulator Add -ins checkbox

SOLVED
Go to Solution
Highlighted
Frequent Advisor

Getting HLLAPI DLL was not found while selecting Terminal Emulator Add -ins checkbox

Hi,

 

      I am getting the below error while selecting Terminal Emulator add-ins in qtp 11.

 

        "QuickTest Terminal Emulator support is not configured correctly. Either ther terminal emulator is not installed in your computer, or the HLLAPI.dll was not found."

 

     While running test batch, the error msg is showing and click ok. my application is running upto .net page once entering the silverlight (4.0)  page IE 8 Crashes. Please help.

4 REPLIES
Frequent Advisor

Re: Getting HLLAPI DLL was not found while selecting Terminal Emulator Add -ins checkbox

Are you testing any Mainframe Application?
If yes. Did you configure the TE Add-in in QTP with your Terminal Emulator(Bluezone, Attachmate, Hummingbird ..which ever you use)?
If you are not using any TE, why are you including it when you load QTP?
Frequent Advisor

Re: Getting HLLAPI DLL was not found while selecting Terminal Emulator Add -ins checkbox

Hi,

 

   I am not using any mainframe application. when i run my QTP script through Test Batch Runner, its showing this HLLAPI DLL was not found. after that IE crashes.

 

   My application developed by Silverlight 4.0 .

 

 

Regards,

S. Indra

Occasional Advisor

Re: Getting HLLAPI DLL was not found while selecting Terminal Emulator Add -ins checkbox

Hi Indira,

 

Please make sure that you are not loading Terminal Emulator add-in while launching the QTP.If TE Add-in is not required for you,then uninstall this add-in.

Honored Contributor Honored Contributor

Re: Getting HLLAPI DLL was not found while selecting Terminal Emulator Add -ins checkbox

QTP looks for HLLAPI.dll when you load Terminal Emulator add-in and if you don't have terminal emulator application, you get this error.

Uncheck or disable this from QTP add-in manager.....it should run fine in test batch runner too.