Unified Functional Testing (formerly QTP) News and Support Forum
Showing results for 
Search instead for 
Do you mean 

Object Repository, Object Idenfication problems with UFT12.0, Web IE7/8

Occasional Visitor

Object Repository, Object Idenfication problems with UFT12.0, Web IE7/8



I use UFT12.0 on CRM7 ( SAP) Application with IE7/8.


I store the objects in an Object Repository and i can find almost every objects of the application.


However there was an update of this application, and now in one Page UFT12 there is some objects I can't detect anymore. The properties to identify, the visual and the code didn't change on this Page.


I created a new Test and use Object Spy to add again the objects. But now, UFT12 take a long time to find them, i can add the objects in my OR. Altought UFT12 can't highlight the object or I can't use method on them because UFT12 get an error "Cannont found objects...."


Picture on attachments :

At left : OR before update

At right : OR after update

I hide some text but we can see that for the same object ( the webtables ), before the update we can see the properties, and after the update UFT12 show nothing and there is this error : "Descriptions are available only for test object operations."


I want to use a WebElement, it has 9 parent levels : 1 Browser, 1 Page, 1 SAPFRame and 6 WebTables. For each WebTables it is now impossible to see the properties.


Why UFT12 is able to add/find an object in OR but just after it can't find/use this object  ? Why properties are blank in my OR ?


Thanks for the reading and for your help.


P.S : Sorry for my english.