Unified Functional Testing Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

QTP 11 crashed when I try to open a test

Frequent Visitor

QTP 11 crashed when I try to open a test

Hi everyone,

I installed QTP 11.0 on Windows 7 Professional, everything was working fine but I tried to open some scripts that were already created and it sends me an error saying "Unexpected format file" and it replace all the code that I had in those scripts. Also once that I got that error and trying to recorder and save a new test, QTP sends another error "This operation cannot be performed. For futher help please contact support" and the message cannot close so I have to finish the QTP process.

 

Does anyone have an answer about it? Any kind of comments and suggestions are so welcome.

 

Thank you in advance!

 

Magali

2 REPLIES
Advisor

Re: QTP 11 crashed when I try to open a test

Hello,

 

Did you ever find a solution to this issue? I am having similar problem when I try to Run a Test in Service Test. If I choose for Results Location "New results in ALM/QC project" it gives em the error "The Operation cannot be performed. "

 

http://h30499.www3.hp.com/t5/Unified-Functional-Testing/The-Operation-cannot-be-performed-Service-Test-11-2-Patch-09/m-p/6510912

 

Any idea?

 

Thanks

Occasional Visitor

Re: QTP 11 crashed when I try to open a test

I installed QTP 11.0 on Windows 7 Professional, everything was working fine but I tried to open some scripts that were already created and it sends me an error saying "Unexpected format file"

 

I've gotten this several times and always found that there are extraneous actions in the directory structure -- the program thinks there should only be Action0 and Action1 but it's finding Action2. This usually occurs after I've loaded a script, changed a few things and then saved it. It really starts messing things up in a subversioned directory.

My workaround, though not elegant, is to create a new script, import the object repository, open the faulty script in a text editor (look under Action1 in the directory and open the Scripts.mts file), copy the code and paste it into the newly created script.

 

Save the script as a different name (I think the problem is that QTP/UFT appends new actions and it messes things up) and it should work. Again, not elegant but I've had a lot of success doing this.