Showing results for 
Search instead for 
Do you mean 

how to upgrade TruClient browser to Firefox 17

Occasional Visitor

how to upgrade TruClient browser to Firefox 17


we are using WebInspect latest version. Our application works in firefox version above17 and in IE10.Recording for login macro is not working fine in IE and since TruClient uses firefox 3.5 ,we are not able to record in that also. Can some one advice me how to upgrade TruClient browser Firefox 17 
Thank you

Esteemed Contributor

Re: how to upgrade TruClient browser to Firefox 17

Unfortunately in WebInspect 10.0 and 10.10, the TruClient uses a built-in version 3.6 of Mozilla.  You can find it under a path such as C:\Program Files (x86)\HP\HP WebInspect\Browser\browser.exe.  This lockdown is expected to change to support the latest build with the upcoming release(s) of WebInspect, although I do not know its development status.  You might be able to find out from Fortify Support (https://support.fortify.com), and if it is crucial, you may be able to get a pre-release version of WebInspect to try out or verify.


You indicated that the traffic-based Web Macro Recorder (WMR) did not function for you.  This same macro format can be recorded using the Web Proxy.  Perhaps this would work for you if you used the Web Proxy with your Firefox 17 browser to record the macro?

-- Habeas Data
HP Fortify Customers-Only Forums – https://protect724.hp.com/community/fortify