Respected Contributor Respected Contributor
Re: /usr/lib/hpux32/dld.so: Unsatisfied data symbol 'gss_nt_service_name' in load module '/usr/bin/ssh'
Don't your server have /usr/lib/hpux32/gss/libgssapi_krb5.so
or /usr/lib/hpux32/libgssapi_krb5.so ?

I'd recommend you to install KRB5CLIENT:

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=KRB5CLIENT