cannot change a password, Problem with pam_chauthtok
Hi,

I cannot change a password any more, I get always
XXXX# passwd
pam_chauthtok: Shared object load failure.

Same if I try it as root. I had "shadow" and I converted back to normal passwd but always the same result.

Any ideas what to check? Unfortunatly "reboot" is not an option.

Best Regards

Andreas
PS: HP-UX 11.23, Patchbundle Sep 2004
Exalted Contributor Exalted Contributor
Re: cannot change a password, Problem with pam_chauthtok
Shalom Andreas,

Has the pam.conf file been changed?

It is also possible that the pam_chauthtok file(if such a thing exists) has become corrupt and needs to be copied in from another system.

I'm pretty sure rebooting is not going to help.

You might try manually nulling out the passwd section of /etc/passwd and then running the passwd command.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Re: cannot change a password, Problem with pam_chauthtok
Hi Steven,

you got 10 Points, thank you very much. pam.conf was the problem. As I neither did the setup nor the updates I can only gues but it looks like someone "played" with the pam.conf and made additional entries. With the last patchbundle came additional stuff into this file and this caused the problems.

The other node in the cluster had not a modified pam.conf and there the patchbunde worked perfect. First time I`m happy that the nodes in these clusters have different setups...

Andreas