Honored Contributor
Re: QTP 10 Recording issue for internet explorer 11!
Yes. You need to downgrade your IE application to a supported version.

According to the QTP 10 Product Availability Matrix, IE 8 is the latest supported version.
http://support.openview.hp.com/selfsolve/document/KM744522/binary/QTP10_ProdAvailMatrx.pdf?searchIdentifier=&resultType=document
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)