Honored Contributor
Re: What is the latest version of Firefox that is compatible with QTP 10?
ALM/QC is not supported for any browser other than Microsoft Internet Explorer.

Questions about QTP should be posted on the Functional Testing forum.
http://h30499.www3.hp.com/t5/Functional-Testing-QTP/ct-p/sws-Fun_Test
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)