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Preface 

The H3C WX Series Access Controllers Web-Based Configuration Guide describes the web functions 
of the WX series, such as quick start, web overview, wireless service configuration, security and 
authentication related configurations, QoS configuration, and advanced settings. 

This preface includes: 

 Audience  

 Conventions 

 About the H3C WX Sereis Documentation Set 

 Obtaining Documentation 

 Technical Support 

 Documentation Feedback 

Audience 

This documentation is intended for: 

 Network planners 

 Field technical support and servicing engineers 

 Network administrators working with the WX series 

Conventions 

This section describes the conventions used in this documentation set.  

GUI conventions 

Convention Description 

Boldface Window names, button names, field names, and menu items are in Boldface. 
For example, the New User window appears; click OK. 

> Multi-level menus are separated by angle brackets. For example, File > Create 
> Folder. 

 

Symbols 

Convention Description 

 
Means reader be extremely careful. Improper operation may cause bodily 
injury.  

 
Means reader be careful. Improper operation may cause data loss or damage to 
equipment.  

 
Means an action or information that needs special attention to ensure 
successful configuration or good performance.  

 Means a complementary description.  



Convention Description 

 Means techniques helpful for you to make configuration with ease.  

 

Network topology icons 

Convention Description 

 
Represents a generic network device, such as a router, switch, or firewall. 

 
Represents a routing-capable device, such as a router or Layer 3 switch.  

 
Represents a generic switch, such as a Layer 2 or Layer 3 switch, or a router 
that supports Layer 2 forwarding and other Layer 2 features.  

 
 

Represents an access controller, an access controller module, or a switching 
engine on a unified switch. 

  
 

Represents an access point. 

 
 

Represents a mesh access point. 

 

 
Represents omnidirectional signals. 

  Represents directional signals. 

 

About the H3C WX Sereis Documentation Set 

The H3C WX  Series documentation set includes: 

Category Documents Purposes 

WX3000 Series Unified Wired and Wireless Switches 
Brochure 

WX5000 Series Access Controllers Brochure 

Product 
description and 
specifications 

WX6000 Series Access Controllers Brochure 

Describe product specifications and 
benefits. 

LSWM1WCM10 Access Controller Module Card 
Manual 

LSWM1WCM20 Access Controller Module Card 
Manual 

LSRM1WCM2A1 Access Controller Module Card 
Manual 

Provide the hardware specifications 
of the cards, and describe how to 
install and remove the cards. 

LSQM1WCMB0 Access Controller Module 
Installation Manual 

Hardware 
specifications 
and installation 

LSBM1WCM2A0 Access Controller Module 
Installation Manual 

Guide you through hardware 
specifications and installation 
methods to help you install your 
AC. 

http://www.h3c.com/portal/Products%5F%5F%5FSolutions/Products/WLAN/H3C%5FWX3000%5FSeries%5FWired%5Fand%5FWireless%5FUnified%5FSwitc/
http://www.h3c.com/portal/Products%5F%5F%5FSolutions/Products/WLAN/H3C%5FWX3000%5FSeries%5FWired%5Fand%5FWireless%5FUnified%5FSwitc/
http://www.h3c.com/portal/Products%5F%5F%5FSolutions/Products/WLAN/H3C%5FWX5000%5FSeries%5FAccess%5FControllers/
http://www.h3c.com/portal/Products%5F%5F%5FSolutions/Products/WLAN/H3C%5FWX6000%5FSeries%5FAccess%5FControllers/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSWM1WCM10%5FAccess%5FController%5FMoudle/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSWM1WCM10%5FAccess%5FController%5FMoudle/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSWM1WCM20%5FAccess%5FController%5FMoudle/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSWM1WCM20%5FAccess%5FController%5FMoudle/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSRM1WCM2A1%5FAccess%5FController%5FModule/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSRM1WCM2A1%5FAccess%5FController%5FModule/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSQM1WCMB0%5FAccess%5FController%5FModule/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSQM1WCMB0%5FAccess%5FController%5FModule/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSBM1WCM2A0%5FAccess%5FController%5FModule/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController%5FModule/H3C%5FLSBM1WCM2A0%5FAccess%5FController%5FModule/


Category Documents Purposes 

WX Series Access Controllers Getting Started Guides

Guide you through the main 
functions of your AC, and describes 
how to install and log in to your AC, 
perform basic configurations, 
maintain software, and 
troubleshoot your AC. 

WX Series Access Controllers Configuration Guides Describe software features and 
configuration procedures. 

WX Series Access Controllers Command References Provide a quick reference to all 
available commands. 

Software 
configuration 

WX Series Access Controllers Web-based 
Configuration Guides 

Describes configuration procedures 
through the web interface. 

WX3000 Series Unified Switches Release Notes 

WX5002 Series Access Controllers Release Notes 

WX5004 Series Access Controllers Release Notes 
Operations and 
maintenance 

WX6103 Series Access Controllers Release Notes 

Provide information about the 
product release, including the 
version history, hardware and 
software compatibility matrix, 
version upgrade information, 
technical support information, and 
software upgrading. 

 

Obtaining Documentation 

You can access the most up-to-date H3C product documentation on the World Wide Web at 
http://www.h3c.com. 

Click the links on the top navigation bar to obtain different categories of product documentation: 

[Technical Support & Documents > Technical Documents] – Provides hardware installation, software 
upgrading, getting started, and software feature configuration and maintenance documentation. 

[Products & Solutions] – Provides information about products and technologies, as well as solutions. 

[Technical Support & Documents > Software Download] – Provides the documentation released with 
the software version. 

Technical Support 

customer_service@h3c.com 

http://www.h3c.com 

Documentation Feedback 

You can e-mail your comments about product documentation to info@h3c.com.  

We appreciate your comments. 

 

http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController/H3C%5FWX5000%5FSeries%5FAccess%5FControllers/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController/H3C%5FWX5000%5FSeries%5FAccess%5FControllers/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController/H3C%5FWX5000%5FSeries%5FAccess%5FControllers/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController/H3C%5FWX5000%5FSeries%5FAccess%5FControllers/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/WLAN/Access%5FController/H3C%5FWX5000%5FSeries%5FAccess%5FControllers/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Software%5FDownload/Wireless/Wireless%5FLAN%5FControllers/H3C%5FWX3000/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Software%5FDownload/Wireless/Wireless%5FLAN%5FControllers/H3C%5FWX5002/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Software%5FDownload/Wireless/Wireless%5FLAN%5FControllers/H3C%5FWX5004/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Software%5FDownload/Wireless/Wireless%5FLAN%5FControllers/H3C%5FWX6103/
http://www.h3c.com/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Technical%5FDocuments/
http://www.h3c.com/portal/Products%5F%5F%5FSolutions/
http://www.h3c.com/portal/Technical%5FSupport%5F%5F%5FDocuments/Software%5FDownload/


 

 The H3C WX series access controller products include H3C access controllers, access controller 
modules, and H3C WX series unified switches' access controller engines. Support of the H3C WX 
series access controllers for features and commands may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The WX3000 series includes the WX3024, WX3010, and WX3008 unified switches. 

 The WX5000 series includes the WX5002, WX5002V2, and WX5004 access controllers, and the 
LS8M1WCMA0, LSWM1WCM10, and LSWM1WCM20 access controller modules. 

 The WX6000 series includes the WX6103 access controllers, and the LSQM1WCMB0, 
LSBM1WCM2A0, and LSRM1WCM2A1 access controller modules. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 
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1  Compatibility Matrix and Typical Network 
Scenarios 

Access Controller Module and Ethernet Switch Compatibility Matrix 

Table 1-1 Access controller module and Ethernet switch compatibility matrix 

Access controller module Ethernet switch model 

LSWM1WCM20 
S5800 series: 
S5800-60C-PWR/S5800-32F/S5800-56C/S5800-32C/S5800-32C-PWR/S58
00-56C-PWR 

LSWM1WCM10 

S5800 series: 
S5800-60C-PWR 
S5820 series: 
S5820-28C 

LS8M1WCMA0 
S7500 series: 
S7502/S7503/S7506/S7506R 

LSQM1WCMB0 
S7500E series: 
S7502E/S7503E-S/S7503E/S7506E-S/S7506E/S7506E-V/ S7510E 

LSBM1WCM2A0 
S9500 series: 
S9512/S9508/S9508V/S9505 

LSRM1WCM2A1 
S9500E series: 
S9505E/S9508E-V/S9512E 
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2  Applicable Models and Software Versions 

H3C WX series access controllers include the WX3000 series unified switches, WX5000 and WX6000 
series access controllers. Table 2-1 shows the applicable models and software versions. 

Table 2-1 Applicable models and software versions 

Model Software version 

WX3024 unified switches 

WX3010 unified switches 

WX3008 unified switches 

LSWM1WCM20 access controller module 

WX3000-CMW520-R3111P03 

WX5002 access controller 

LS8M1WCMA0 access controller module 
WX5002-CMW520-R1112 

WX5002V2 access controller 

WX5004 access controller 

LSWM1WCM10 access controller module 

WX5004-CMW520-R2107P04 

WX6103 access controller 

LSQM1WCMB0 access controller module 

LSBM1WCM2A0 access controller module 

LSRM1WCM2A1 access controller module 

WX6103-CMW520-R2115P08 
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3  Typical Network Scenarios 

AC Networking 

As shown in Figure 3-1, AC is connected to a switch (Layer 2 or Layer 3), which can be connected to 
APs directly or connected to APs over a network, and Clients can be connected to the network through 
APs to implement WLAN user access. 

Figure 3-1 AC networking 

 
 

Access Controller Module Networking 

As shown in Figure 3-2, installed with an access controller module, Switch (Layer 2 or Layer 3) can be 
connected to APs directly or connected to APs over a network, and Clients can be connected to the 
network through the APs to implement WLAN user access. 
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Figure 3-2 Access controller module networking 

 
 

Unified Switch Networking 

As shown in Figure 3-3, Unified switch can be connected to APs directly or connected to APs over a 
network, and Clients can be connected to the network through the APs to implement WLAN user 
access. 

Figure 3-3 Unified switch networking diagram 
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4  Feature Matrixes 

Feature Matrix for the WX5000 Series  

 

 

The LS8M1WCMA0, LSWM1WCM10, and LSWM1WCM20 on the WX5000 series adopt the OAP 
architecture. Installed on the expansion slots of switches, they work as OAP cards to exchange data, 
status and control information with the switches through their internal service interfaces. Do not 
configure services such as QoS, rate limiting and 802.1X authentication on GE interfaces on the 
LS8M1WCMA0, XGE 1/0/1 on the LSWM1WCM10, and the logical interface BAGG1 aggregated by 
GE1/0/1 and GE1/0/2 on the LSWM1WCM20. 

 

Table 4-1 Feature matrix for the WX5000 series 

Module Feature WX5002 WX5002V2 LS8M1WC
MA0 WX5004 LSWM1W

CM10 
LSWM1W

CM20 

Summary Summary IPv6 
supported 

IPv6 
supported 

IPv6 
supported 

IPv6 
supported 

IPv6 
supported 

IPv6 
supported 

License 

The 
WX5002 
supports 
32 
concurrent 
APs by 
default, 
and can be 
extended 
to support 
64 
concurrent 
APs. 

The 
WX5002V2 
supports 
32 
concurrent 
APs by 
default, 
and can be 
extended 
to support 
64 
concurrent 
APs. 

Not 
supported 

The 
WX5004 
supports 
64 
concurrent 
APs by 
default, 
and can be 
extended 
to support 
256 
concurrent 
APs. 

The 
LSWM1W
CM10 
supports 
64 
concurrent 
APs by 
default, 
and can be 
extended 
to support 
256 
concurrent 
APs. 

The 
LSWM1W
CM20 
supports 
32 
concurrent 
APs by 
default, 
and can be 
extended 
to support 
128 
concurrent 
APs. 

File 
managem
ent 

Flash 
supported 

CF 
supported 

Flash 
supported 

CF 
supported 

CF 
supported 

Flash 
supported 

Device 

Interface 
managem
ent 

Configurati
on of IPv6 
address for 
an 
interface is 
supported. 

Configurati
on of IPv6 
address for 
an 
interface is 
supported.

Configurati
on of IPv6 
address for 
an 
interface is 
supported.

Configurati
on of IPv6 
address for 
an 
interface is 
supported.

Configurati
on of IPv6 
address for 
an 
interface is 
supported. 

Configurati
on of IPv6 
address for 
an 
interface is 
supported.
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Module Feature WX5002 WX5002V2 LS8M1WC
MA0 WX5004 LSWM1W

CM10 
LSWM1W

CM20 

Port 
mirroring 

Remote 
port 
mirroring 
and 
cross-boar
d mirroring 
not 
supported 

Remote 
port 
mirroring 
and 
cross-boar
d mirroring 
not 
supported 

Not 
supported 

Remote 
port 
mirroring 
and 
cross-boar
d mirroring 
not 
supported 

Not 
supported 

Not 
supported 

SNMP 

Configurati
on of IPv6 
destination 
addresses 
is 
supported 

Configurati
on of IPv6 
destination 
addresses 
is 
supported 

Configurati
on of IPv6 
destination 
addresses 
is 
supported 

Configurati
on of IPv6 
destination 
addresses 
is 
supported 

Configurati
on of IPv6 
destination 
addresses 
is 
supported 

Configurati
on of IPv6 
destination 
addresses 
is 
supported 

Loopback 
test 

Supported 
on GE 
interfaces 

Supported 
on GE 
interfaces 

Internal 
loopback 
testing 
supported 
on GE 
interfaces 
only 

Supported 
on GE 
interfaces 

Internal 
loopback 
testing 
supported 
on XGE 
interfaces 
only 

Internal 
loopback 
testing 
supported 
on GE 
interfaces 
only 

IPv6 
routing Supported Supported Supported Supported Supported Supported 

Network 
Diagnostic 
tools 

IPv6 ping 
supported 

IPv6 ping 
supported 

IPv6 ping 
supported 

IPv6 ping 
supported 

IPv6 ping 
supported 

IPv6 ping 
supported 

ACL IPv6 Supported Supported Supported Supported Supported Supported 
QoS 

Line rate Supported Supported Supported Supported Supported Supported 

Advanced AC 
backup Supported Supported Supported Supported Supported  Not 

supported 

High 
availability 

Stateful 
failover 

Not 
supported Supported Not 

supported Supported Supported Not 
supported 

 

Feature Matrix for the WX6000 Series  

 

 

The switch interface module on the WX6103, and the LSQM1WCMB0, LSBM1WCM2A0, and 
LSRM1WCM2A1 access controller modules on the WX6000 series adopt the OAP architecture. 
Installed on the expansion slots of switches, they work as OAP cards to exchange data, status and 
control information with the switches through their internal service interfaces. The XGE interfaces on 
the switch interface module on the WX6103, and the LSQM1WCMB0, LSBM1WCM2A0, and 
LSWM1WCM10 access controller modules are internal interfaces. Therefore, you are not 
recommended to configure services such as QoS rate limiting and 802.1X authentication on them. 
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Table 4-2 Feature matrix for the WX6000 series 

Module Feature WX6103 LSQM1WCMB0 LSBM1WCM2A0 LSRM1WCM2A1 

Summary Summary IPv6 
supported IPv6 supported IPv6 not supported IPv6 supported 

License 

The 
WX6103 
supports 128 
concurrent 
APs by 
default, and 
can be 
extended to 
support 640 
concurrent 
APs. 

The 
LSQM1WCMB0 
supports 128 
concurrent APs by 
default, and can 
be extended to 
support 640 
concurrent APs. 

The 
LSBM1WCM2A0 
supports 128 
concurrent APs by 
default, and can be 
extended to support 
640 concurrent APs. 

The 
LSRM1WCM2A1 
supports 128 
concurrent APs by 
default, and can be 
extended to support 
640 concurrent APs.

File 
manageme
nt 

CF and USB 
supported 

CF and USB 
supported 

CF and USB 
supported 

CF and USB 
supported 

Interface 
manageme
nt 

Configuratio
n of IPv6 
address for 
an interface 
is supported.

Configuration of 
IPv6 address for 
an interface is 
supported. 

Configuration of 
IPv6 address for an 
interface is not 
supported. 

Configuration of IPv6 
address for an 
interface is 
supported. 

Port 
mirroring 

Not 
supported Not supported Not supported Not supported 

SNMP 

Configuratio
n of IPv6 
destination 
addresses is 
supported 

Configuration of 
IPv6 destination 
addresses is 
supported 

Configuration of 
IPv6 destination 
addresses is not 
supported 

Configuration of IPv6 
destination 
addresses is 
supported 

Device 

Loopback 
test 

Internal 
loopback 
testing 
supported 
on XGE 
interfaces 
only 

Internal loopback 
testing supported 
on XGE interfaces 
only 

Internal loopback 
testing supported on 
XGE interfaces only 

Internal loopback 
testing supported on 
XGE interfaces only

IPv6 
routing Supported Supported Not supported Supported 

Network 
Diagnostic 
tools 

IPv6 ping 
supported 

IPv6 ping 
supported 

IPv6 ping not 
supported IPv6 ping supported

ACL IPv6 Supported Supported Not supported Supported 
QoS 

Line rate Supported Supported Supported Supported 

Advanced AC backup Supported Supported Supported Supported 

High 
availability 

Stateful 
failover Supported Supported Supported Supported 
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Feature Matrix for the WX3000 Series  

 

 

The access controller engine and switching engine on the WX3000 series adopt the OAP architecture. 
The switching engine is integrated on the access controller engine as an OAP card. You actually log in 
to the access controller engine when you log in to the device by default. GE 1/0/1 interfaces on the 
WX3024, WX3010 and WX3008 are used to exchange data, status and control information with 
GE1/0/29 (WX3024), GE1/0/11 (WX3010) or GE1/0/9 (WX3008) on the switching engine. Therefore, 
you are not recommended to configure services such as QoS rate limiting and 802.1X authentication on 
these interfaces. 

 

Table 4-3 Feature matrix for the WX3000 series 

Module Feature WX3024 WX3010 WX3008 

Summary Summary IPv6 not supported IPv6 not supported IPv6 not supported 

License 

The WX3024 
supports 24 
concurrent APs by 
default, and can 
be extended to 
support 48 
concurrent APs. 

The WX3010 supports 12 
concurrent APs by default, 
and can be extended to 
support 24 concurrent 
APs. 

Not supported 

File 
management Flash supported Flash supported Flash supported 

Interface 
management 

Configuration of 
IPv6 address for 
an interface is not 
supported. 

Configuration of IPv6 
address for an interface is 
not supported. 

Configuration of IPv6 
address for an interface is 
not supported. 

Port mirroring Not supported Not supported Not supported 

SNMP 
IPv6 destination 
addresses not 
supported 

IPv6 destination 
addresses not supported 

IPv6 destination 
addresses not supported 

Device 

Loopback test 

Internal loopback 
testing supported 
on GE interfaces 
only 

Internal loopback testing 
supported on GE 
interfaces only 

Internal loopback testing 
supported on GE 
interfaces only 

IPv6 routing Not supported Not supported Not supported 
Network Diagnostic 

tools 
IPv6 ping not 
supported IPv6 ping not supported IPv6 ping not supported 

ACL IPv6 Not supported Not supported Not supported 
QoS 

Line rate Not supported Not supported Not supported 

Advanced AC backup Not supported Not supported Not supported 

High 
availability Stateful failover Not supported Not supported Not supported 
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5  Quick Start 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

The Quick Start wizard will lead you through the following configuration steps to make your device 
available for use: 

 Basic Configuration 

 Admin Configuration 

 IP Configuration 

 Wireless Configuration 

 RADIUS Configuration 

 Portal Configuration 

 Encryption Configuration 

 Guest Wireless Network Configuration 

 AP Configuration 

Quick Start 

Home Page of the Quick Start Wizard 

From the navigation tree, select Quick Start to enter the home page of the Quick Start wizard, as shown 
in Figure 5-1. 
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Figure 5-1 Home page of the Quick Start wizard 

 

 

Basic Configuration 

On the Quick Start wizard page, click start to enter the basic configuration page, as shown in Figure 
5-2. 
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Figure 5-2 Basic configuration page 

 

 

Table 5-1 lists the configuration items of the basic configuration page. 

Table 5-1 Configuration items of the basic configuration page 

Item Description 

System Name 
Specify the name of the current device. 
By default, the system name of the device is H3C. 

Country Code 

Select the code of the country where you are. This field defines the radio frequency 
characteristics such as the power and the total number of channels for frame 
transmission. Before configuring the device, you need to configure the country 
code correctly. 

Time Zone Select a time zone for the system. 

Time Specify the current time and date. 

 

 

If the Country Code field is grayed out, it cannot be modified.  

 

Admin Configuration 

On the basic configuration page, click Next to enter the Admin Configuration page, as shown in 
Figure 5-3. 
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Figure 5-3 Admin Configuration page 

 
 

Table 5-2 lists the configuration items of the Admin Configuration page. 

Table 5-2 Configuration items of the Admin Configuration page 

Item Description 

Password Specify the password used by the user to log in to the device. The default user is admin.

Confirm Password Type the password again to confirm the password. 

 

IP Configuration 

On the Admin Configuration page, click Next to enter the IP configuration page, as shown in Figure 
5-4. 
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Figure 5-4 IP configuration page 

 

 

Table 5-3 lists the configuration items of the IP configuration page. 

Table 5-3 Configuration items of the IP configuration page 

Item Description 

IP Address 
Specify the IP address of VLAN-interface 1. This IP address is used for logging into 
the device. 
The default is 192.168.0.100. 

Mask 
Specify the IP address mask of VLAN-interface 1. 
By default, the mask is 24-bit long. 

Default Gateway 
Specify the IP address of the next hop of the default route to the network.  
By default, no gateway is available. 

 

Wireless Configuration 

On the IP configuration page, click Next to enter the wireless configuration page, as shown in Figure 
5-5. 
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Figure 5-5 Wireless configuration page 

 

 

Table 5-4 lists the configuration items of the wireless configuration page. 

Table 5-4 Configuration items of the wireless configuration page 

Item Description 

Primary Service 
Authentication type 

Select the authentication type for the wireless service, which can be: 
 None: Performs no authentication. 
 User authentication (802.1X): Performs 802.1X authentication. 
 Portal: Performs Portal authentication. 

Wireless Service Specify the Service Set Identifier (SSID).  

Encrypt 
Select this check box to go to the 7/13: Encryption Configuration step. 
By default, no encryption is performed. If this option is not selected, the 7/13: 
Encryption Configuration step is skipped. 

 

RADIUS Configuration 

On the wireless configuration page, select User authentication (802.1X) or Portal for the Primary 
Service Authentication Type field, and then click Next to enter the RADIUS configuration page, as 
shown in Figure 5-6. 
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Figure 5-6 RADIUS configuration page 

 
 

Table 5-5 lists the configuration items of the RADIUS configuration page. 

Table 5-5 Configuration items of the RADIUS configuration page 

Item Description 

Service Type 

Select the type of the RADIUS server.  
Two types are available: standard and enhanced: 

 extended: Specifies extended RADIUS server, which is usually a CAMS iMC. 
In this case, the RADIUS client (access device) and the RADIUS server 
exchange packets based on the specifications and packet format definitions of 
a private RADIUS protocol. 

 standard: Specifies the standard RADIUS server. In this case, the RADIUS 
client (access device) and the RADIUS server exchange packets based on the 
specifications and packet format definitions of the standard RADIUS protocols 
(RFC 2138, RFC 2139, and the updates).  

Authentication IP Type the IP address of the RADIUS authentication server. 

Authentication UDP Port Type the port number of the RADIUS authentication server. 

Authentication Key Type the shared key of the RADIUS authentication server.  

Accounting IP Type the IP address of the RADIUS accounting server. 

Accounting UDP Port Type the port number of the RADIUS accounting server. 

Accounting Key Type the shared key of the RADIUS accounting server. 

 

Portal Configuration 

On the wireless configuration page, select Portal for the Primary Service Authentication Type field, 
and then click Next to enter the RADIUS configuration page. After you complete RADIUS configuration, 
click Next to enter the portal configuration page, as shown in Figure 5-7. 
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Figure 5-7 Portal configuration page 

 

 

Table 5-6 lists the configuration items of the portal configuration page. 

Table 5-6 Configuration items of the portal configuration page 

Item Description 

Server-name Specify the system name of the portal server. 

Server-IP Type the IP address of the portal server. 

Port Type the port number of the portal server. 

Redirect-URL Type the URL of the portal authentication server. 

Method 

Specify the portal authentication method to be used, which can be: 
 Direct: Before authentication, a user manually configures an IP address or 

directly obtains a public IP address through DHCP, and can access only the 
portal server and predefined free websites. After passing authentication, the 
user can access the network resources. The authentication process of direct 
authentication is relatively simple than that of the re-DHCP authentication. 

 Layer3: Layer 3 authentication is similar to direct authentication but allows 
Layer 3 forwarding devices to be present between the authentication client and 
the access device. 

 Redhcp: Before authentication, a user gets a private IP address through DHCP 
and can access only the portal server and predefined free websites. After 
passing authentication, the user is allocated a public IP address and can 
access the network resources. 
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Encryption Configuration 

You may enter the encryption configuration page in two ways: 

 On the wireless configuration page, select User authentication (802.1X) for the Primary Service 
Authentication Type field and click Next to enter the RADIUS configuration page. Complete 
RADIUS configuration and then click Next. 

 On the wireless configuration page, select Portal for the Primary Service Authentication Type 
field and click Next to enter the RADIUS configuration page. Complete RADIUS configuration and 
click Next to enter the portal configuration page. Then, complete portal authentication and click 
Next. 

The encryption configuration page is as shown in Figure 5-8. 

Figure 5-8 Encryption configuration page 

 

 

Table 5-7 lists the configuration items of the encryption configuration page. 
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Table 5-7 Configuration items of the encryption configuration page 

Item Description 

Provide Key 
Automatically 

Select whether to use an automatically provided WEP key. 
 Enable: Use an automatically provided WEP key. 
 Disable: Use a static WEP key. 

By default, a static WEP key is used. 
If you select to use an automatically provided WEP key, WEP104 will be selected 
as the WEP key type. 

 
If you want to select Enable from this drop-down list, you must first select the User 
authentication (802.1X) option from the Primary Service Authentication type 
drop-down list on the wireless configuration page. 

WEP Select the key type of the WEP encryption mechanism, which can be WEP40, 
WEP104, and WEP 128. 

Key ID 
Select the WEP key index, which can be 1, 2, 3, or 4. Each number represents one 
of the four static keys of WEP. The selected key index will be used for frame 
encryption and decryption 

Key Length 

Select the key length. 
 When the key type is WEP40, the key length can be five alphanumeric 

characters or ten hexadecimal characters. 
 When the key type is WEP104, the key length can be 13 alphanumeric 

characters or 26 hexadecimal characters. 
 When the key type is WEP128, the key length can be 16 alphanumeric 

characters or 32 hexadecimal characters. 

WEP Key Type the WEP key. 

 

Guest Wireless Network Configuration 

On the encryption configuration page, click Next to enter the guest wireless network configuration page, 
as shown in Figure 5-9. 
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Figure 5-9 Guest wireless network configuration page 

 

 

Select the Create Guest service check box to display the guest service configuration page, as shown 
in Figure 5-10. 

Figure 5-10 Guest service configuration page 

 

 

Table 5-8 lists the configuration items of the guest service configuration page. 
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Table 5-8 Configuration items of the guest service configuration page 

Item Description 

Guest Service 
Authentication type 

Select the guest authentication service authentication type, which can be: 
 None: Performs no authentication. 
 User authentication (802.1X): Performs 802.1X authentication. If you select 

this option and click Next, you will enter the RADIUS configuration page. For 
RADIUS configuration information, refer to RADIUS Configuration. 

 Portal: Performs portal authentication. If you select this option and click Next, 
you can enter the RADIUS configuration page to perform RADIUS 
configurations. Then, you can click Next on the RADIUS configuration page to 
enter the portal configuration page. For RADIUS configuration information, 
refer to RADIUS Configuration. For portal configuration information, refer to 
Portal Configuration. 

Wireless Type the access SSID of the guest. 

Default VLAN Type the default VLAN ID of the guest.  

Encrypt Select the Encrypt check box and click Next to enter the encryption configuration 
page. For encryption configuration information, refer to Encryption Configuration. 

Create Guest Vlan Create VLANs for guest users. 

 

AP Configuration 

On the guest service configuration page, click Next to enter the AP configuration page, as shown in 
Figure 5-11. You can configure an AP and click Add. The section at the bottom of the page displays all 
existing APs. 

Figure 5-11 AP configuration page 

 

 

Table 5-9 lists the configuration items of the AP configuration page. 
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Table 5-9 Configuration items of the AP configuration page 

Item Description 

AP Name Specify the name of the AP connected with the access controller (AC). 

Model Specify the type of the AP connected with the AC. 

Serial ID 

Specify the sequence number of the AP connected with the AC. 
If the Auto check box is not selected, you need to manually type a sequence number. You can 
also select the Auto check box to enable the automatic AP discovery function so that the AP 
can connect with the AC automatically. If there are a large number of APs, you can enable the 
automatic AP discovery function to relieve yourself of the burden to configure the AP sequence 
numbers. 

Radio Specify the radio. 

Mode The value of this item depends on the type of the AP and the radio. 

Channel 

Select the channel to be used. Channel number is selected based on the country code and 
radio mode. The channel list varies with device models. 
Auto: The channel is automatically selected by the device. 
After the channel is changed, the corresponding power column will be refreshed automatically.

Power 

Select the transmission power. 
The maximum transmission power depends on the country code, channel, AP model, radio 
mode, and antenna type. If the 802.11n radio mode is applied, the maximum transmission 
power also depends on the bandwidth mode. 

 

You can configure multiple APs on the page. 

Configuration Summary 

On the AP configuration page, click Next to enter the configuration summary page, as shown in Figure 
5-12. The configuration summary page will display all configurations you have made. Click finish to 
apply your configurations. 

Figure 5-12 Configuration summary page 
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6  Web Overview 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Hangzhou H3C Technologies Co., Ltd. (hereinafter referred to as H3C) provides the Web-based 
network management function to facilitate the operations and maintenance on H3C’s network devices. 
Through this function, the administrator can visually manage and maintain network devices through the 
Web-based configuration interfaces. 

Figure 6-1 shows a Web-based network management operating environment: 

Figure 6-1 Web-based network management operating environment 

 

 

Logging In to the Web Interface 

The device is provided with the default Web login information. You can use the default information to log 
in to the Web interface. The default Web login information is: 

 Username: admin 

 Password: admin 

 IP address of the device: 192.168.0.100. 

You can follow the steps below to log in to the device through the Web interface. 

1) Connect the device and PC 

Connect the Ethernet interface of the device to the PC using a crossover Ethernet cable.  
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2) Configure an IP address for the PC and ensure that the PC and device can communicate with each 
other properly.  

Modify the IP address of the PC to one that within the network segment 192.168.0.0/24 (except for 
192.168.0.100), for example, 192.168.0.2. 

3) Open the browser, and input the login information. 

On the PC, open the browser, type the IP address http://192.168.0.100 in the address bar, press Enter 
and you can enter the login page of the Web interface, as shown in Figure 6-2. Input the username 
admin and password admin, and the verification code, select the language (English and Chinese are 
supported at present), and click Login. 

Figure 6-2 Login page of the Web interface 

 

 

 

 The PC where you configure the device is not necessarily the Web-based network management 
terminal. A Web-based network management terminal is a PC (or another terminal) used to log in 
to the Web interface and is required to be reachable to the device. 

 After logging in to the Web interface, you can create a new user and configure the IP address of the 
interface connecting the user and the device. 

 If you click the verification code displayed on the Web login page, you can get a new verification 
code. 

 Up to five users can concurrently log in to the device through the Web interface. 

 

Logging Out of the Web Interface 

Click Logout in the upper-right corner of the Web interface to quit Web-based network management.  

The system will not save the current configuration before you log out of the Web interface. Therefore, 
you are recommended to save the current configuration before logout.  

Introduction to the Web Interface 

The Web interface is composed of three parts: navigation tree, title area, and body area, as shown in 
Figure 6-3. 
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Figure 6-3 Web-based configuration interface 

 
(1) Navigation area (2) Body area (3) Title area 

 

 Navigation area: Organizes the Web-based NM function menus in the form of a navigation tree, 
where you can select function menus as needed. The result is displayed in the body area. 

 Body area: The area where you can configure and display a function. 

 Title area: On the left, displays the path of the current configuration interface in the navigation area; 
on the right, provides the Save button to quickly save the current configuration, the Help button to 
display the Web related help information, and the Logout button to log out of the Web interface. 

 

 

The Web network management functions not supported by the device will not be displayed in the 
navigation area. 

 

Web User Level 

Web user levels, ranging from low to high, are visitor, monitor, configure, and management. A user 
with a higher level has all the operating rights of a user with a lower level. 

 Visitor: Users of this level can perform the ping and traceroute operations, but they can neither 
access the device data nor configure the device. 

 Monitor: Users of this level can only access the device data but cannot configure the device. 

 Configure: Users of this level can access data from the device and configure the device, but they 
cannot upgrade the host software, add/delete/modify users, or back up/restore the application file. 

 Management: Users of this level can perform any operations for the device. 
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Introduction to the Web-Based NM Functions 

Table 6-1 describes the Web-based network management functions in detail. 

 

 

 Support for the configuration items depends on the device model. For more information, see 
Compatibility Matrixes. 

 User level in Table 6-1 indicates that users of this level or users of a higher level can perform the 
corresponding operations. 

 

Table 6-1 Description of Web-based NM functions 

Function menu Description User level 

Quick Start Allows you to perform quick 
configuration of the device. Configure 

Device Info 

Displays and refreshes system 
resource state, device information, 
device interface information, and 
recent system operation logs. 

Monitor 

Wlan Service 

Displays the information of the 
queried WLAN service, including the 
detailed information, statistics, and 
connection history. 

Monitor 

Displays the information of the 
queried AP, including wireless 
service, connection history, radio, and 
detailed information. 

Monitor 
AP 

Allows you to reboot an AP. Configure 

Displays the detailed information, 
statistics, and roaming information of 
the client. 

Monitor 

Summary 

Client 
Allows you to clear statistics of the 
client, disconnect the connection, and 
add the client into the blacklist. 

Configure 

Device                      License
 

Displays license information. Monitor 
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Function menu Description User level 

Allows you to add licenses. Configure 

Set sysname Displays and allows configuration of 
the system name. Configure 

Basic 
Set idle 
timeout 

Displays and allows configuration of 
the idle timeout period for a logged-in 
user. 

Configure 

Software 
Upgrade 

Allows you to upload the file to be 
upgraded from the local host to 
upgrade the system software. 

Management 

Reboot Allows you to reboot the device. Management Device 
Maintenance 

Diagnostic 
Information 

Allows you to generate a diagnostic 
information file, view the file or save 
the file to the local host. 

Management 

System Time Displays and allows configuration of 
the system date and time. Configure 

Displays and refreshes system logs. Monitor 
Loglist 

Allows you to clear system logs. Configure 

Loghost Displays and allows configuration of 
the loghost. Configure Syslog 

Logset 
Displays and allows configuration of 
the buffer capacity, and refreshes 
interval for displaying system logs. 

Configure 

Backup 
Allows you to back up the 
configuration file for the next startup 
to the host of the current user. 

Management 

Restore 

Allows you to upgrade the 
configuration file on the host of the 
current user to the device for the next 
startup. 

Management 

Save 
Allows you to save the current 
configuration to the configuration file 
for the next startup. 

Configure 

Configuration 
management 

Initialize Allows you to restore the system to 
factory defaults. Configure 

File management 

Allows you to manage files on the 
device, including displaying file list, 
downloading a file, uploading a file, 
and removing a file. 

Management 

Displays interface information and 
statistics. Monitor 

Interface Management Allows you to create, modify, delete, 
and enable/disable an interface, and 
clear interface statistics. 

Configure 

Summary Displays the configuration information 
of a port mirroring group. Monitor 

Create Allows you to create a port mirroring 
group. Configure 

Port Mirroring 

Remove Allows you to remove a port mirroring 
group. Configure 
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Function menu Description User level 

Modify Port Allows you to configure ports for a 
mirroring group. Configure 

Summary Displays brief information of FTP and 
Telnet users. Monitor 

Super 
Password 

Allows you to configure the password 
for a lower-level user to switch from 
the current access level to the 
management level. 

Management 

Create Allows you to create an FTP or Telnet 
user. Management 

Modify Allows you to modify FTP or Telnet 
user information. Management 

Remove Allows you to remove an FTP or a 
Telnet user. Management 

User 
Management 

Switch To 
Management 

Allows you to switch the current user 
level to the management level. Monitor 

Displays and refreshes SNMP 
configuration and statistics 
information. 

Monitor 
Setup 

Allows you to configure SNMP. Configure 

Displays SNMP community 
information. Monitor 

Community 
Allows you to create, modify and 
delete an SNMP community. Configure 

Displays SNMP group information. Monitor 
Group Allows you to create, modify and 

delete an SNMP group. Configure 

Displays SNMP user information. Monitor 
User Allows you to create, modify and 

delete an SNMP user. Configure 

Displays the status of the SNMP trap 
function and information about target 
hosts. 

Monitor 

Trap 
Allows you to enable or disable the 
SNMP trap function, or create, modify 
and delete a target host. 

Configure 

Displays SNMP view information. Monitor 

SNMP 

View Allows you to create, modify and 
delete an SNMP view. Configure 

Loopback Test Allows you to perform the loopback 
test on Ethernet interfaces. Configure 
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Function menu Description User level 

Displays MAC address information. Monitor 
MAC Allows you to create or remove MAC 

addresses. Configure MAC 

Config Displays and allows configuration of 
MAC address aging time. Configure 

Displays all VLANs on the device and 
information about their member ports. Monitor 

VLAN 
Allows you to create, modify and 
delete VLANs. Configure 

Displays VLANs to which a port on 
the device belongs. Monitor 

VLAN 

Port 
Allows you to modify the VLANs to 
which a port belongs. Configure 

Displays ARP table information. Monitor 
ARP Table Allows you to add, modify or delete an 

ARP entry. Configure 

Displays configuration information of 
gratuitous ARP. Monitor 

ARP 
Management 

Gratuitous 
ARP Allows you to configure gratuitous 

ARP. Configure 

Displays the configuration information 
of ARP detection. Monitor 

ARP 
Detection Allows you to configure ARP 

detection. Configure 

Displays the configuration information 
of source MAC address based ARP 
attack detection, ARP active 
acknowledgement, and ARP packet 
source MAC address consistency 
check. 

Monitor ARP 
Anti-Attack 

Advanced 
Configuration 

Allows you to configure source MAC 
address based ARP attack detection, 
ARP active acknowledgement, and 
ARP packet source MAC address 
consistency check. 

Configure 

Displays global IGMP Snooping 
configuration information and the 
IGMP Snooping configuration 
information in a VLAN, and allows you 
to view the IGMP Snooping multicast 
entry information. 

Monitor 
Basic 

Allows you configure IGMP Snooping 
globally and in a VLAN. Configure 

Displays the IGMP Snooping 
configuration information on a port. Monitor 

IGMP 
Snooping 

Advance 
Allows you to configure IGMP 
Snooping on a port. Configure 

Summary Displays the IPv4 active route table. Monitor 

Network 

IPv4 Routing 

Create Allows you to create an IPv4 static 
route. Configure 
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Function menu Description User level 

Remove Allows you to delete the selected IPv4 
static routes. Configure 

Summary Displays the IPv6 active route table. Monitor 

Create Allows you to create an IPv6 static 
route. Configure IPv6 Routing 

Remove Allows you to delete the selected IPv6 
static routes. Configure 

Displays the DHCP service status, 
the DHCP address pool information, 
and the DHCP server status on an 
interface. 

Monitor 

DHCP Server
Allows you to set the DHCP service 
status, add, modify, or delete a DHCP 
address pool, and modify the DHCP 
server status on an interface. 

Configure 

Displays the status of a DHCP service 
and advanced configuration 
information of DHCP relay, displays 
information of a DHCP group, and 
status of the DHCP relay agent on an 
interface, and allows you to view the 
DHCP relay user information. 

Monitor 

DHCP Relay 
Allows you to configure the status of a 
DHCP service and advanced 
configuration information of DHCP 
relay, add or delete a DHCP group, 
and modify the status of the DHCP 
relay agent on an interface. 

Configure 

Displays the status of the DHCP 
Snooping function, and the trusted 
and untrusted attributes of a port, and 
allows you to view the DHCP 
Snooping user information. 

Monitor 

DHCP 

DHCP 
Snooping 

Allows you to configure the status of 
the DHCP Snooping function, and 
modify the trusted and untrusted 
attributes of a port. 

Configure 

Static Domain 
Name 
Resolution 

Allows you to display, create, modify 
or delete a static host name-to-IP 
address mapping. 

Configure 

DNS 
Dynamic 
Domain Name 
Resolution 

Displays and allows configuration of 
related parameters for dynamic 
domain name resolution. Allows you 
to display, create, or delete an IP 
address and the domain name suffix. 

Configure 

Displays the states of the services: 
enabled or disabled. Configure 

Service Management Specifies whether to enable various 
services, and sets related 
parameters. 

Management 

IPv4 Ping Allows you to ping an IPv4 address or 
host and display the result. Visitor Diagnostic 

Tools 

IPv6 Ping Allows you to ping an IPv6 address or 
host and display the result. Visitor 
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Function menu Description User level 

Trace Route Allows you to perform trace route 
operations and display the result. Visitor 

Displays AP-related information, 
including AP name, AP IP address, 
serial ID, model and status. 

Monitor 
AP Setup 

Allows you to add an AP and modify 
the AP configuration. Configure 

Displays auto AP information after 
auto AP is enabled, including AP 
name, model, serial ID and IP 
address. 

Monitor 
Auto AP 

Enables auto AP. Configure 

Displays AP group information. Monitor 

AP 

AP Group Allows you to create and configure an 
AP group. Configure 

Displays an access service, including 
security type, detailed information, 
service status and binding status. 

Monitor 

Access Service Allows you to create and configure an 
access service, map an access 
service to an AP radio, and add a 
MAC authentication list. 

Configure 

Displays a mesh service and its 
status. Monitor 

Mesh Service Allows you to create and configure a 
mesh service, including security 
settings. 

Configure 

Displays mesh policies. Monitor 
Mesh Policy Allows you to create and configure a 

mesh policy. Configure 

Displays mesh global setting, 
including basic setting and mesh 
portal service. 

Monitor 

WLAN Service 

Mesh Service 

Mesh Global 
Setting Allows you to configure mesh global 

setting, including basic setting and 
mesh portal service. 

Configure 

Displays a roaming group and its 
members. Monitor 

Roam Group 
Allows you to configure a roaming 
group and add a group member. Configure Roam 

Client Information 
Displays client information, including 
MAC address, BSSID, VLAN ID, 
home AC and roaming direction. 

Monitor 
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Function menu Description User level 

Displays radio status, including radio 
mode and radio status. Monitor 

Radio 
Allows you to configure radio status, 
including 802.11n settings. Configure 

Displays rate settings. Monitor 
Rate Allows you to configure 802.11n 

rates, including MCS index. Configure 

Displays channel scanning, including 
scanning mode, scanning type and 
scanning interval. 

Monitor 

Scan 
Allows you to configure channel 
scanning, including scanning mode 
and scanning type. 

Configure 

Displays or refreshes AP status, 
including channel status, neighbor 
information, and history information. 

Monitor Calibration 
Operations 

Manual calibration Configure 

Displays basic setup, channel setup 
and power setup. Monitor 

Calibration 

Parameter 
Setting Allows you to configure channel 

calibration parameters. Configure 

Radio 

Antenna Allows you to configure the antenna 
of an AP. Configure 

Displays the global 802.1X 
information and 802.1X information of 
a port. 

Monitor 
802.1X 

Displays the global 802.1X features 
and 802.1x features of a port. Configure 

Displays the portal server 
configuration information. Monitor 

Portal Server 
Allows you to add and delete a portal 
server. Configure 

Displays the portal-free rule 
configuration information. Monitor 

Portal 

Free Rule 
Allows you to add and delete a 
portal-free rule. Configure 

Displays ISP domain configuration 
information. Monitor 

Domain Setup
Allows you to add and remove ISP 
domains. Management 

Displays the authentication method 
configuration information of an ISP 
domain. 

Monitor 
Authentication

Allows you to specify authentication 
methods for an ISP domain. Management 

Authentication 

AAA 

Authorization 
Displays the authorization method 
configuration information of an ISP 
domain. 

Monitor 
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Function menu Description User level 

Allows you to specify authorization 
methods for an ISP domain. Management 

Displays the accounting method 
configuration information of an ISP 
domain. 

Monitor 
Accounting 

Allows you to specify accounting 
methods for an ISP domain. Management 

RADIUS 
Server 

Displays and allows configuration of 
RADIUS server information. Management 

RADIUS 
RADIUS 
Setup 

Displays and allows configuration of 
RADIUS parameters. Management 

Displays the configuration information 
of the local EAP service. Monitor 

Local EAP Server 
Allows you to configure the local EAP 
service. Configure 

Displays local users’ configuration 
information. Monitor 

Local User 
Allows you to add, modify, and 
remove local users. Management 

Displays user groups’ configuration 
information. Monitor 

User Group 
Allows you to add, modify, and 
remove user groups. Management 

Displays guest users’ configuration 
information. Monitor 

Guest 
Allows you to add, modify, and 
remove guest users. Management 

Displays user profile configuration 
information. Monitor 

Users 

User Profile 
Allows you to add, modify, remove, 
enable, and disable user profiles. Configure 

Displays information about PKI 
entities. Monitor 

Entity 
Allows you to add, modify, and delete 
a PKI entity. Configure 

Displays information about PKI 
domains. Monitor 

Domain 
Allows you to add, modify, and delete 
a PKI domain. Configure 

Displays the certificate information of 
PKI domains and allows you to view 
the contents of a certificate. 

Monitor 

Certificate Allows you to generate a key pair, 
destroy a key pair, retrieve a 
certificate, request a certificate, and 
delete a certificate. 

Configure 

PKI 

CRL Displays the contents of the CRL. Monitor 
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Function menu Description User level 

Allows you to receive the CRL of a 
domain. Configure 

Displays AP operating mode. Monitor 
AP Monitor Allows you to configure AP operating 

mode. Configure 

Displays list types for the rogue 
device detection and the detection 
rules. 

Monitor 
Rule List 

Allows you to configure list types for 
rogue device detection and the rules. Configure 

Displays monitor record of rogue 
device detection. Monitor 

Monitor 
Record Allows you to clear monitor record of 

rogue device detection, and add 
rogue devices to blacklist. 

Configure 

Displays rogue device detection 
history. Monitor 

Rogue device 
detection 

History 
Record Allows you to clear history of rogue 

device detection and add rogue 
devices to blacklist. 

Configure 

Displays IDS configuration. Monitor 

WIDS Setup Allows you to configure IDS detection, 
including flood attack detection, 
spoofing attack detection, and weak 
IV detection. 

Configure 

Displays IDS attack detection history. Monitor 

History 
Record 

Allows you to clear history record of 
IDS attack detection and add the 
detected devices that initiate attacks 
to blacklist. 

Configure 

Displays statistics of IDS attack 
detection. Monitor 

WIDS 

Statistics 
Allows you to clear the statistics. Configure 

Displays dynamic and static 
blacklists. Monitor 

Blacklist Allows you to clear dynamic blacklist 
and static blacklist; enable dynamic 
blacklist; add entries to the static 
blacklist. 

Configure 

Displays white list. Monitor 

Blacklist and 
White list 

White List Allows you to clear white list, and add 
entries to the white list. Configure 

Summary 

Displays the configurations of the 
authorized IP, the associated IPv4 
ACL rule list, and the associated IPv6 
ACL rule list. 

Management 

WLAN Security 

Authorized IP 

Setup Allows you to configure the 
authorized IP. Configure 
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Function menu Description User level 

User Isolation 
Allows you to display, add, modify 
and remove user isolation 
configuration. 

Management 

Display Displays time range configuration 
information. Monitor 

Create Allows you to create a time range. Configure Time Range 

Delete Allows you to delete a time range. Configure 

Display Displays IPv4 ACL configuration 
information. Monitor 

Create Allows you to create an IPv4 ACL. Configure 

Basic Setup Allows you to configure a rule for a 
basic IPv4 ACL. Configure 

Advanced 
Setup 

Allows you to configure a rule for an 
advanced IPv4 ACL. Configure 

Link Setup Allows you to create a rule for an 
Ethernet frame header ACL. Configure 

ACL IPv4 

Delete Allows you to delete an IPv4 ACL or 
its rules. Configure 

Display Displays IPv6 ACL configuration 
information. Monitor 

Create Allows you to create an IPv6 ACL. Configure 

Basic Setup Allows you to configure a rule for a 
basic IPv6 ACL. Configure 

Advanced 
Setup 

Allows you to configure a rule for an 
advanced IPv6 ACL. Configure 

ACL IPv6 

Delete Allows you to delete an IPv6 ACL or 
its rules. Configure 

Displays wireless QoS, including SVP 
mapping, CAC admission policy, 
radio EDCA and client EDCA. 

Monitor 

Wireless QoS Allows you to configure wireless QoS, 
including SVP mapping, CAC 
admission policy, radio EDCA and 
client EDCA. 

Configure 

Displays radio statistics, including 
WMM status and detailed radio 
information. 

Monitor 

Radio 
Statistics Displays radio statistics, including 

WMM status and detailed radio 
information, and allows you to clear 
the radio statistics. 

Configure 

Displays client statistics, including 
WMM status and detailed client 
information. 

Monitor 

QoS 

Wireless QoS 

Client 
Statistics Displays client statistics, including 

WMM status and detailed client 
information, and allows you to clear 
the client statistics. 

Configure 
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Function menu Description User level 

Displays the configured client rate 
limit information.  

Client Rate 
Limit Allows you to configure and modify 

client rate limiting mode, direction and 
rate. 

Configure 

Display Displays line rate configuration 
information. Monitor 

Line Rate 
Setup Allows you to configure the line rate. Configure 

Displays the priority and trust mode of 
a port. Monitor 

Port Priority 
Allows you to modify the priority and 
trust mode of a port. Configure 

Displays priority trust mode 
configuration information. Management 

Trust Mode 
Allows you to configure the priority 
trust mode. Management 

Display Displays classifier configuration 
information. Monitor 

Create Allows you to create a class. Configure 

Setup Allows you to configure the 
classification rules for a class. Configure 

Classifier 

Delete Allows you to delete a class or its 
classification rules. Configure 

Display Displays traffic behavior configuration 
information. Monitor 

Create Allows you to create a traffic behavior. Configure 

Setup Allows you to configure actions for a 
traffic behavior. Configure 

Behavior 

Delete Allows you to delete a traffic behavior. Configure 

Display Displays QoS policy configuration 
information. Monitor 

Create Allows you to create a QoS policy. Configure 

Setup 
Allows you to configure the 
classifier-behavior associations for a 
QoS policy. 

Configure 
QoS Policy 

Delete Allows you to delete a QoS policy or 
its classifier-behavior associations. Configure 

Display Displays the QoS policy applied to a 
port. Monitor 

Setup Allows you to apply a QoS policy to a 
port. Configure Port Policy 

Delete Allows you to remove the QoS policy 
from the port. Configure 

Service Policy Displays the QoS policy applied to a 
WLAN-ESS port. Monitor 
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Function menu Description User level 

Allows you to configure the QoS 
policy applied to a WLAN-ESS port. Configure 

Displays the district code. Monitor 
District code 

Allows you to modify the district code. Configure 

Displays the address of the backup 
AC. Monitor 

Setup 
Allows you to configure the address of 
the backup AC. Configure AC Backup 

Status Displays the status of the AC. Monitor 

Displays the load balancing mode 
and the current connection status. Monitor 

Load Balancing Allows you to configure the load 
balancing mode and refresh the 
current connection status. 

Configure 

Displays the AP version, including the 
AP model and software version. Monitor 

AP Version 
Allows you to upgrade the software. Configure 

Displays the model and IP address of 
the AP. Monitor 

AP Setup 

Switch to fat 
AP 

Switches to fat AP. Configure 

Displays the AP working mode 
switching information. Monitor 

Advanced 
Settings 

Switch to Fat AP 
Allows you to switch the working 
mode of an AP. Configure 

Displays stateful failover information. Monitor 
High Reliability Stateful Failover Allows you to modify stateful failover 

configuration. Configure 

 

Introduction to the Controls on the Web Pages 

Apply button 
Click to submit the input information. 

Cancel button 
Click to cancel the input information. The page changes to the display page of the function or to the 
Device Info page. 

Search button 
Select an item to be queried, input the keyword, and click the Query button to display the items that 
meet the requirements. 

The advance search function is also provided. You can click the plus sign before Search Item, as 
shown in Figure 6-4. You can select Match case and whole word, that is, the item to be searched must 
completely match the keyword, or you can select Search in previous results. If you do not select exact 
search, fuzzy search is performed. 
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Figure 6-4 Advanced search 

 

 

Refresh button 
Click to refresh the display information of the current page. 

Clear button 
Click to clear all the items in a list or all statistics. 

Remove button 
Click to remove the selected items. 

Select All button 
Click to select all the items in a list, or all the ports on the device panel. 

Select None button 
Click to deselect all the items in a list, or all the ports on the device panel. 

Restore button 
Click to restore all the items in the current configuration page to the system default. 

 icon 
Click to enter the modification page of an item to modify the configurations of the item. 

 icon 
Click to delete the item corresponding to this icon. 

Help button 
Click to open the online help page as shown in Figure 6-5. 
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Figure 6-5 Help 

 
 

Sort display 
On the page, you can click the blue items of each column to sort and display the records based on the 
item you selected. 
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Figure 6-6 Sort display 

 
 

Configuration Guidelines 

 The Web-based configuration interface supports the operating systems of Windows XP, Windows 
2000, Windows Server 2003 Enterprise Edition, Windows Server 2003 Standard Edition, Windows 
Vista, Linux and MAC OS. 

 The Web-based configuration interface supports the browsers of Microsoft Internet Explorer 6.0 
SP2 and higher, Mozilla Firefox 3.0 and higher, Google Chrome 2.0.174.0 and higher, and the 
browser must support and be enabled with JavaScript. 

 The Web-based configuration interface does not support the Back, Next, Refresh buttons 
provided by the browser. Using these buttons may result in abnormal display of Web pages. 

 When the device is performing the spanning tree calculation, you cannot log in to or use the Web 
interface. 

 As the Windows firewall limits the number of TCP connections, when you use IE to log in to the 
Web interface, sometimes you may be unable to open the Web interface. To avoid this problem, it 
is recommended to turn off the Windows firewall before login. 

 If the software version of the device changes, you are recommended to clear the cache data on the 
browser before logging in to the device through the Web interface; otherwise, the Web page 
content may not be displayed correctly. 

Troubleshooting Web Browser 

Cannot Access the Device Through the Web Interface 

Symptom 
You can ping the device successfully, and log in to the device through telnet. HTTP is enabled and the 
operating system and browser version meet the Web interface requirements. However, you cannot 
access the Web interface of the device. 
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Analysis 
 If you use the Microsoft Internet Explorer, you can access the Web interface only when these 

functions are enabled: Run ActiveX controls and plug-ins, script ActiveX controls marked safe for 
scripting and active scripting. 

 If you use the Mozilla Firefox, you can access the Web interface only when JavaScript is enabled. 

Configuring the Internet Explorer settings 
1) Open the Internet Explorer, and then select Tools > Internet Options. 

2) Click the Security tab, and then select a Web content zone to specify its security settings, as 
shown in Figure 6-7. 

Figure 6-7 Internet Explorer setting (I) 

 

 

3) Click Custom Level, and a dialog box Security Settings appears. 

4) As shown in Figure 6-8, set the enable these functions: Run ActiveX controls and plug-ins, script 
ActiveX controls marked safe for scripting and active scripting. 
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Figure 6-8 Internet Explorer Setting (II) 

 

 

5) Click OK in the Security Settings dialog box. 

Configuring Firefox Web browser Settings 
1) Open the Firefox Web browser, and then select Tools > Options. 

2) Click the Content tab, select the Enable JavaScript check box, and click OK, as shown in Figure 
6-9. 
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Figure 6-9 Firefox Web browser setting 
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7  Summary 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Device Information Overview 

You can view the following information on the Device Info menu: 

 Device information 

 System resource state 

 Device interface information 

 Recent system logs 

After logging in to the Web interface, you will enter the Summary > Device Info page, as shown in 
Figure 7-1. 
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Figure 7-1 Device info page 

 

 

Select the refresh mode from the Refresh Period drop-down box. 

 If you select a specific period (such as, 1 minute), the system periodically refreshes the Device 
Info page according to the specified period; 

 If you select Manual, you need to click Refresh to refresh the Device info page. 

Device Info 

Table 7-1 describes the device information configuration items. 

Table 7-1 Device information configuration items 

Item Description 

Device Name Displays the device model. 

Product Information Displays the product information. 

Device Location 
Displays the location of the device. 
You can set a character string to describe the physical location of the device on 
the SNMP Setup page by selecting Device > SNMP. 

Contact Information 
Displays the contact information for device maintenance. 
You can set a character string to describe the contact information for device 
maintenance on the SNMP Setup page by selecting Device > SNMP. 

SerialNum Displays the serial number of the device. 

Software Version Displays the software version of the device. 

Hardware Version Displays the hardware version of the device. 

Bootrom Version Displays the Boot ROM version of the device. 



 

7-3 

Item Description 

Running Time Display the running time after the latest boot of the device. 

 

System Resource State 

Table 7-2 describes the system resource state configuration items. 

Table 7-2 System resource state configuration items 

Item Description 

CPU Usage Displays the real-time CPU usage. 

Memory Usage Displays the real-time memory usage and the total memory. 

Temperature Displays the temperature of the device. 

 

Device Interface Information 

Table 7-3 describes the device interface information configuration items. 

Table 7-3 Device interface information configuration items 

Item Description 

Interface Displays interface name and interface number. 

IP Address/Mask Displays the IP address and mask of an interface. 

Status 

Displays interface status. 
 : The interface is up and is connected. 
 : The interface is up, but not connected. 
 : The interface is down. 

 

 

To know more information about device interfaces, click the More hyperlink under the Device Interface 
Information area to enter the Device > Interface page to view and operate the interfaces. For detailed 
information, refer to Interface Management Configuration. 

 

Recent System Logs 

Table 7-4 describes the recent system log configuration items. 
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Table 7-4 Recent system log configuration items 

Item Note: 

Time Displays the time when the system logs are generated. 

Level Displays the level of the system logs. 

Description Displays the contents of the system logs. 

 

 

 The device info page only displays at most five recent login and logout logs in all system logs.  

 To know more information about system logs, click the More hyperlink under the Recent System 
Operation Logs area to enter the Device > Syslog > Loglist page to view the logs. For detailed 
information, refer to Log Management Configuration of this manual. 

 

Displaying WLAN Service 

Select Summary > WLAN Service from the navigation tree, click the specified WLAN service to view 
the detailed information, statistics, or connection history. 

Displaying Detailed Information of WLAN Service 

The detailed information of WLAN service (clear type) is as shown in Figure 7-2. For the description of 
the fields in the detailed information, refer to Table 7-5. 

Figure 7-2 Display detailed information of WLAN service (clear type) 
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Table 7-5 Fields of detailed information of the WLAN service (clear type) 

Field Description 

Service Template Number Current service template number 

SSID Service set identifier (SSID) for the ESS 

Binding Interface Name of the interface bound with the service template 

Service Template Type Service template type 

Authentication Method 
Type of authentication used 
WLAN service of the clear type only uses open system authentication 

SSID-hide 
Disable: The SSID is advertised in beacon frames. 
Enable: Disables the advertisement of the SSID in beacon frames. 

Bridge Mode 
Forwarding mode: 

 Local forwarding: Uses local forwarding in the service template. 
 Remote forwarding: Uses AC remote forwarding in the service template. 

Service Template Status 
Status of service template: 

 Enable: Enables WLAN service. 
 Disable: Disables WLAN service. 

Maximum clients per BSS Maximum number of associated clients per BSS 

 

The detailed information of WLAN service (crypto type) is as shown in Figure 7-3. For the description of 
the fields in the detailed information, refer to Table 7-6. 

Figure 7-3 Display detailed information of WLAN service (crypto type) 
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Table 7-6 Fields of detailed information of the WLAN service (crypto type) 

Field Description 

Service Template Number Current service template number 

SSID SSID for the ESS 

Binding Interface Name of the interface bound with the service template 

Service Template Type Service template type 

Security IE Security IE: WPA or RSN 

Authentication Method Authentication method: open system or shared key 

SSID-hide 
Disable: The SSID is advertised in beacon frames. 
Enable: Disables the advertisement of the SSID in beacon frames. 

Cipher Suite Cipher suite: CCMP, TKIP, WEP40, WEP104, or WEP128 

TKIP Countermeasure Time(s) TKIP countermeasure time in seconds 

PTK Life Time(s) PTK lifetime in seconds 

GTK Rekey GTK rekey configured 

GTK Rekey Method GTK rekey method configured: packet based or time based 

GTK Rekey Time(s) 

Time for GTK rekey in seconds 
 If Time is selected, the GTK will be refreshed after a specified period of 

time. 
 If Packet is selected, the GTK will be refreshed after a specified number 

of packets are transmitted. 

Bridge Mode 
Forwarding mode: 

 Local forwarding: Uses local forwarding in the service template. 
 Remote forwarding: Uses AC remote forwarding in the service template.

Service Template Status 
Status of service template: 

 Enable: Enables WLAN service. 
 Disable: Disables WLAN service. 

Maximum clients per BSS Maximum number of associated clients per BSS 

 

Displaying Statistics of WLAN Service 

The statistics of WLAN service are as shown in Figure 7-4. 
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Figure 7-4 Display WLAN service statistics 

 
 

Displaying Connection History Information of WLAN Service 

The connection history information of WLAN service is as shown in Figure 7-5. 

Figure 7-5 Display the connection history information of WLAN service  

 

 

Displaying AP 

Select Summary > AP from the navigation tree to enter the AP page, as shown in Figure 7-6. You can 
display the WLAN service information, connection history, radio and detailed information of an AP by 
clicking the tabs on the page. 
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Displaying WLAN Service Information of an AP 

The WLAN service information of an AP is as shown in Figure 7-6. 

Figure 7-6 Display WLAN service information 

 

 

Displaying AP Connection History Information 

The connection history information of an AP is as shown in Figure 7-7. 

Figure 7-7 Display AP connection history information 

 
 

Displaying AP Radio Information 

Select Summary > AP from the navigation tree to enter the AP page, click the Radio tab on the page, 
and click the name of the specified AP to view the radio information of an AP. 

The radio information of an AP is as shown in Figure 7-8. For the description of the fields in the AP radio 
statistics, refer to Table 7-7. 



 

7-9 

Figure 7-8 Display AP radio information 

 

 

 

The Noise Floor item in the table indicates various random electromagnetic waves during the wireless 
communication. For the environment with a high noise floor, you can improve the signal-to-noise ration 
(SNR) by increasing the transmit power or reducing the noise floor. 

 

Table 7-7 Description on the fields of the AP radio information 

Field Description 

AP name Access point name 

Radio Id Radio ID 

Transmitted Frames Statistics Statistics of transmitted frames 

Total Frames Number of frames transmitted 

Unicast Frames Number of unicast frames transmitted 

Broadcast/Multicast Frames Number of broadcast or multicast frames transmitted 

Discard Frames Number of frames discarded. 

Retry Count Number of transmission retries 

Multiple Retry Count Number of frames that have been retransmitted 

Authentication Frames Number of authentication responses transmitted 
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Field Description 

Failed RTS Number of RTS failed during transmission 

Successful RTS Number of RTS transmitted successfully 

Failed ACK Number of transmitted frames for which no acknowledgement is 
received 

Association Frames Number of association responses transmitted 

Packet Count Statistics Based on Size 

Number of frames counted based on the frame size. The frame size 
falls in the following four ranges: 

 size < 128 
 128 < size < 512 
 512 < size < 1024 
 size > 1024 

Packet Count Statistics Based on Rate 

Numbers of frames counted separately based on their transmit 
rates: 802.11a, 802.11b, or 802.11g. Only the numbers of frames 
counted based on the data rates supported by the radio of the AP 
are displayed. For example, if the radio supports 802.11a, the 
number of 802.11a frames is displayed, and numbers of 802.11b 
and 802.11g frames will not be displayed. 

Packet Count Statistics Based on MCS 
Rate 

Numbers of frames counted separately based on their MCS rates. 
If the device does not support 802.11n, this field will not be 
displayed. 

Received Frames Statistics Statistics of received frames 

Total Frames Number of frames received 

Unicast Frames Number of unicast frames received 

Broadcast/Multicast Frames Number of broadcast or multicast frames received 

Fragmented Frames Number of fragmented frames received 

FCS Failures  Number of frames dropped due to FCS failure 

Authentication Frames Number of authentication requests received 

Duplicate Frames Number of duplicate frames received 

Decryption Errors Number of frames dropped due to decryption error 

Association Frames Number of association requests received 

 

Displaying AP Detailed Information 

Select Summary > AP from the navigation tree to enter the AP page, click the Detail tab on the page, 
and click the name of the specified AP to view the detailed information of an AP. 

The detailed information of an AP is as shown in Figure 7-9. For the description of the fields in the AP 
detailed information, refer to Table 7-8. 
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Figure 7-9 Display AP detailed information 

 

 

Table 7-8 Description on the fields of the AP information 

Field Description 

APID Access point identifier 

AP System Name Access point name 

Map Configuration Configuration file mapped to the AP 

State 

Current state of the AP: 
 ImageDownload: The AP is downloading the version. If the ImageDownload 

state persists, check the following: 1) The version of the fit AP saved on the AC 
matches with the version that the AC requires; 2) The space of the flash is 
enough. 

 Idle: The AP is idle. If the Idle state persists, check the following: 1) If the fields 
of Latest Join IP Address and Tunnel Down Reason are displayed as -NA-, 
it indicates that the AP has never connected to the AC successfully. You need 
to check the network cable, power supply of the fit AP, and the AP serial 
number if the serial number was manually input. 2) If the fields of Latest Join 
IP Address and Tunnel Down Reason are displayed as other contents, it 
indicates that the AP has connected to the AC successfully. Refer to the output 
of the Tunnel Down Reason field for the detailed reason. 

 Run: The AP is operating. It indicates that the AP has connected to the AC 
successfully. If the AC backup function is enabled, this field also displays the 
main or backup state of the AC. Run(M) indicates that the AC is a main AC, and 
Run(B) indicates a backup AC. 

 Config: The AC is delivering configuration file to the fit AP, and the fit AP is 
collecting radio information through the radio interface and reporting to the AC. 
This state is an instantaneous state. 

Up Time(hh:mm:ss) Time duration for which the AP has been connected to the AC. NA indicates AP is 
not connected to the AC. 

Model AP model name 

Serial-ID Serial ID of the AP 

IP Address IP address of the AP 

H/W Version Hardware version of the AP 
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Field Description 

S/W Version Software version of the AP 

Boot-Rom version Boot ROM version of the AP 

Description Description of the AP 

Connection Type AP connection type: “Master” or “Backup” 

Peer AC MAC Address Peer AC MAC address in case of AC backup 

Priority Level AP connection priority 

Echo Interval(s) Interval for sending echo requests, in seconds 

Statistics report 
Interval(s) Interval for sending statistics information messages, in seconds 

Cir (Kbps) Committed information rate in kbps 

Cbs (Bytes) Committed burst size in bytes 

Jumboframe Threshold Threshold value of jumbo frames 

Transmitted control 
packets Number of transmitted control packets 

Received control packets Number of received control packets 

Transmitted data packets Number of transmitted data packets 

Received data packets Number of received data packets 

Configuration Failure 
Count Count of configuration request message failures 

Last Failure Reason Last configuration request failure reason  

Last Reboot Reason 

Last reboot reason of the AP: 
 Normal: The AP was powered off. 
 Crash: The AP crashed, and the information is needed for analysis. 
 Tunnel Initiated: The reset wlan ap command is executed on the AC (in this 

case, the Tunnel Down Reason is displayed as Reset AP). 
 Tunnel Link Failure: The fit AP rebooted abnormally because an error occurred 

when the AP was establishing a connection with the AC. 

Latest Join IP Address IP address of the last AP 

Tunnel Down Reason 

The CAPWAP tunnel between the AC and the AP is down when one of the 
following occurs: 

 Neighbor Dead Timer Expire: The AC does not receive an Echo request from 
the AP within three times the handshake interval.  

 Response Timer Expire: The AC sends a control packet to the AP but does not 
receive any response within the specified waiting time.  

 Reset AP: The AP is rebooted by the execution of a command on the AC.  
 AP Config Change: The corresponding configurations are modified on the AC.
 No Reason: Other reasons. 

AP Mode Mode supported by the AP. Currently only the split MAC mode is supported. 

AP operation mode Operation mode of AP. Currently Normal and Monitor modes are supported. 

Portal Service Whether the portal service is enabled or not 

Device Detection Whether device detection is enabled or not 

Maximum Number of 
Radios Maximum number of radios supported by the AP 
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Field Description 

Current Number of 
Radios Number of radios in use on the AP 

Client Keep-alive Interval   Interval to detect clients segregated from the system due to various reasons such 
as power failure or crash, and disconnect them from the AP 

Client Idle Interval(s) 
If the client is idle for more than the specified interval, that is, if the AP does not 
receive any data from the client within the specified interval, the client will be 
removed from the network. 

Broadcast-probe Reply 
Status Whether the AP is enabled to respond to broadcast probe requests or not 

Basic BSSID MAC address of the AP 

Current BSS Count Number of BSSs connected with the AP 

Running Clients Count Number of clients currently running 

Wireless Mode Wireless mode: 802.11a, 802.11b, or 802.11g 

Client Dot11n-only 
 Enabled: Only 802.11n clients can be associated with the AP. 
 Disabled: 802.11a/b/g/n clients can be associated with the AP. 

Channel Band-width Channel bandwidth, 20 MHz or 40 MHz. 

Short GI for 20MHz Whether the AP supports short GI when it operates in 20 MHz mode. 

Short GI for 40MHz Whether the AP supports short GI when it operates in 40 MHz mode. 

Mandatory MCS Set Mandatory MCS for the AP 

Supported MCS Set Supported MCS for the AP 

Configured Channel 

Operating channel of the radio: 
 If the channel is manually configured, the configured channel number is 

displayed. 
 If the auto channel selection mode is adopted, auto(channel) is displayed. 

channel in the brackets is the optimum channel automatically selected by the 
AC. 

Configured Power(dBm) 

Transmission power on the radio 
 If one-time (transmit power control) is adopted, the configured transmit power 

is displayed; 
 If auto TPC is adopted, two values are displayed, with the first being the 

maximum power, and the second auto (number), where number in the 
brackets represents the actual power. 

Interference (%) Interference observed on the operating channel, in percentage 

Channel Load (%) Load observed on the operating channel, in percentage 

Utilization (%) Utilization rate of the operating channel, in percentage 

Co-channel Neighbor 
Count Number of neighbors found on the operating channel 

Channel Health Status of the channel 

Preamble Type Type of preamble that the AP can support: short or long 

Radio Policy Radio policy used 

Service Template Service template number 

SSID SSID for the ESS 

Port WLAN-DBSS interface associated with the service template 

Mesh Policy Mesh policy adopted 
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Field Description 

ANI Support ANI (Adaptive Noise Immunity) status: enabled or disabled 

11g Protection 11.g protection status: enable or disable. 

Admin State Administrative state of the radio 

Physical State Physical state of the radio 

Operational Rates (Mbps) Operational rates in Mbps 

Radar detected Channels Channels on which radar signals are detected 

 

Displaying Client 

Select Summary > Client from the navigation tree to enter the page as shown in Figure 7-10. 

Figure 7-10 Display client 

 
 

For the description of the fields in the client information, refer to Table 7-9. 

Table 7-9 Description on the fields of client information 

Field Description 

Refresh Refresh the current page. 

Add to Blacklist Add the selected client to the static blacklist, which you can display by 
selecting Security > Filter from the navigation tree. 

Reset Statistic Clear statistics of the specified client(s). 

Disconnect Log off the selected client. 

 

Displaying Client Detailed Information 

Select Summary > Client from the navigation tree to enter the Client page, click the Detail 
Information tab on the page, and click the name of the specified client to view the detailed information 
of the client. 

The detailed information of a client is as shown in Figure 7-11. For the description of the fields in the 
client detailed information, refer to Table 7-10. 
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Figure 7-11 Display client detailed information 

 
 

Table 7-10 Description on the fields of client information 

Field Description 

MAC address MAC address of the client 

AID Association ID of the client 

AP Name Name of the AP 

Radio Id Client-associated radio ID 

SSID SSID associated with the client 

BSSID Basic SSID 

Port WLAN-DBSS interface associated with the client 

VLAN VLAN to which the client belongs 

State State of the client such as running; Backup indicates a backup client. 

Power Save Mode Client’s power save mode: active or sleep 

Wireless Mode Wireless mode such as 802.11a, 802.11b, 802.11g, 802.11an, or 803.11gn 

Channel Band-width Channel bandwidth, 20 MHz or 40 MHz. 

SM Power Save Enable 

SM Power Save enables a client to have one antenna in the active state, and 
others in sleep state to save power. 

 Enabled: SM Power Save is supported. 
 Disabled: SM Power Save is not supported. 

Short GI for 20MHz Whether the client supports short GI when its channel bandwidth is 20 MHz. 

Short GI for 40MHz Whether the client supports short GI when its channel bandwidth is 40 MHz. 

Support MCS Set MCS supported by the client 

BLOCK ACK-TID 0 

BLOCK ACK is negotiated based on QoS priority ID 0: 
 OUT: Outbound direction 
 IN: Inbound direction 
 BOTH: Both directions 
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Field Description 

BLOCK ACK-TID 3 

BLOCK ACK is negotiated based on QoS priority ID 3: 
 OUT: Outbound direction 
 IN: Inbound direction 
 BOTH: Both directions. 

QoS Mode Whether the AP supports the WMM function. 

Listen Interval (Beacon 
Interval) Number of times the client has been activated to listen to beacon frames 

RSSI Received signal strength indication. This value indicates the client signal 
strength detected by the AP. 

Rx/Tx Rate 

Represents the reception/transmission rate of packets (including data, 
management and control packets). For the AC+ Fit AP mode, there is delay 
because Rx Rate is transmitted from AP to AC periodically depending on the 
statistics interval. 

Client Type Client type such as RSN, WPA, or Pre-RSN 

Authentication Method Authentication method such as open system or shared key 

AKM Method AKM suite used, such as Dot1X or PSK 

4-Way Handshake State 

Displays either of the 4-way handshake states: 
 IDLE: Displayed in initial state. 
 PTKSTART: Displayed when the 4–way handshake is initialized. 
 PTKNEGOTIATING: Displayed after the third message was sent. 
 PTKINITDONE: Displayed when the 4-way handshake is successful. 

Group Key State 

Displays the group key state: 
 IDLE: Displayed in initial state. 
 REKEYNEGOTIATE: Displayed after the AC sends the initial message to 

the client. 
 REKEYESTABLISHED: Displayed when re-keying is successful. 

Encryption Cipher  Encryption password: clear or crypto. 

Roam Status  Displays the roaming status: Normal or Fast Roaming 

Up Time Time for which the client has been associated with the AP. 

 

Displaying Client Statistics 

Select Summary > Client from the navigation tree to enter the Client page, click the Statistic 
Information tab on the page, and click the name of the specified client to view the statistics of the client. 

The statistics of a client is as shown in Figure 7-12. For the description of the fields in the client statistic 
information, refer to Table 7-11. 
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Figure 7-12 Display client statistics 

 
 

Table 7-11 Description on the fields of client statistics 

Field Description 

AP Name Name of the associated access point 

Radio Id Radio ID 

SSID SSID associated with the client 

BSSID Basic SSID 

MAC Address MAC Address of the client 

RSSI Received signal strength indication. This value indicates the client 
signal strength detected by the AP. 

Transmitted Frames Number of transmitted frames 

Best Effort(Frames/Bytes) Statistics of best effort traffic, in frames or in bytes. 

Video(Frames/Bytes) Statistics of video traffic, in frames or in bytes. 

Voice(Frames/Bytes) Statistics of voice traffic, in frames or in bytes. 

Received Frames Number of received frames 

Discarded Frames Number of discarded frames 

 

 

You can collect statistics of priority queues such as Back Ground, Best Effort, Video and Voice on a 
QoS client only. Traffic including SVP packets sent and received on a client where QoS is not enabled 
falls into Best Effort priority queue. Therefore, the queues collected may be different from the queues 
actually sent. You can collect statistics of priority queues carried in Dot11E or WMM packets; otherwise, 
statistics collection of priority queues on the receive end may fail. 
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Displaying Client Roaming Information 

Select Summary > Client from the navigation tree to enter the Client page, click the Roam 
Information tab on the page, and click the name of the specified client to view the roaming information 
of the client. 

Client roaming information is as shown in Figure 7-13. For the detailed description of the fields in the 
client roaming information, refer to Table 7-12. 

Figure 7-13 Display client roaming information  

 

 

Table 7-12 Fields of the client roaming information 

Field Description 

BSSID BSSID of the AP associated with the client 

Online-time Online time of the client 

AC-IP-address 
The IP address of the AC connected with the client. When the configured roaming 
channel type is IPv6, the IPv6 address of the AC is displayed. 
Support for IPv6 addresses depends on the device model. 
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8  License 

 

 

 Support for the license feature may vary by device. For more information, see "Feature Matrixes" in 
Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Licenses are used on the H3C WX series access controller products to control how many APs can be 
connected concurrently to a WX access controller product. The supported number of concurrent APs 
depends on the device model. 

Configuring License 

 

 

After adding the license successfully, you need to reboot the device to make the license effective. 

 

Select Device > License from the navigation tree to enter the license configuration page, as shown in 
Figure 8-1. 
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Figure 8-1 License configuration 

 
 

Table 8-1 describes license configuration items. 

Table 8-1 License configuration items 

Item Description 

License Key Type the license key of the license. 

Activation Key Type the activation key of the license. 

 

Check that the activation key you input is correct and click Add. The license is displayed in the license 
table. 
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9  Device Basic Information Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

The device basic information feature allows you to: 

 Set the system name of the device 

 Set the idle timeout period for a logged-in user. That is, the system will log an idle user off the Web 
for security purpose after the configured period. 

Configuring Device Basic Information 

Configuring System Name 

Select Device > Basic from the navigation tree to enter the system name page, as shown in Figure 9-1. 

Figure 9-1 System name 

 
 

Table 9-1 describes the system name configuration item. 
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Table 9-1 System name configuration item 

Item Description 

Sysname 
Set the system name, which cannot include question marks (?), less than signs (<), greater 
than signs (>), backward slashes (\), double quotation marks (“), percent signs (%), single 
quotation marks (‘), ampersand signs (&) or pound signs (#). 

 

Configuring Idle Timeout Period 

Select Device > Basic from the navigation tree to enter the idle timeout page, as shown in Figure 9-2. 

Figure 9-2 Configuring idle timeout period 

 

 

Table 9-2 describes the idle timeout period configuration item. 

Table 9-2 Idle timeout period configuration item 

Item Description 

Idle timeout Set the idle timeout period for a logged-in user 
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10  Device Maintenance 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Software Upgrade 

Software upgrade allows you to obtain a target application file from the current host and set the file as 
the main boot file or backup boot file to be used at the next reboot. 

A boot file, also known as the system software or device software, is an application file used to boot the 
device. A main boot file is used to boot a device and a backup boot file is used to boot a device only 
when the main boot file is unavailable. 

 

 

Software upgrade takes some time. You are recommended not to perform any operation on the web 
interface during the upgrading procedure; otherwise, the upgrade operation may be interrupted. 

 

Select Device > Device Maintenance from the navigation tree, and you will enter the Software 
Upgrade tab page by default, as shown in Figure 10-1. 
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Figure 10-1 Software upgrade configuration page 

 

 

Table 10-1 shows the detailed configuration for software upgrade. 

Table 10-1 Software upgrade configuration items 

Item Description 

File Specifies the path to save the local application file, where the filename must be with 
an extension .bin or .app. 

File Type 
Specifies the type of the boot file for the next boot: 

 Main 
 Backup 

If a file with the same 
name already exists, 
overwrite it without any 
prompt 

Specifies whether to overwrite the file with the same name.  
If you do not select the option, when a file with the same name exists, the system 
prompts “The file has existed.”, and you cannot upgrade the software. 

Reboot after the 
upgrade is finished. 

Specifies whether to reboot the device to make the upgraded software take effect 
after the application file is uploaded. 

 

Reboot 

 

 

Before rebooting the device, save the configuration; otherwise, all unsaved configurations will be lost 
after device reboot. After the device reboots, you need to re-log in to the Web interface. 

 

Select Device > Device Maintenance from the navigation tree, and then click Device Reboot to enter 
the page as shown in Figure 10-2. Click Apply to reboot the device. 
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Figure 10-2 Device reboot page 

 
 

You can choose to check whether the current configuration has been saved to the configuration file to 
be used at the next startup. 

 If you select the check box before “Check whether the current configuration is saved in the next 
startup configuration file”, the system will check the configuration before rebooting the device. If the 
check succeeds, the system will reboot the device; if the check fails, the system will pop up a dialog 
box to tell you that the current configuration and the saved configuration are inconsistent, and will 
not reboot the device. In this case, you need to save the current configuration manually before you 
can reboot the device.  

 If you do not select the check box, the system will reboot the device directly. 

Diagnostic Information 

Each functional module has its own running information, and generally, you need to view the output 
information for each module one by one. To receive as much information as possible in one operation 
during daily maintenance or when system failure occurs, the diagnostic information module allows you 
to save the running statistics of multiple functional modules to a file named default.diag, and then you 
can locate problems faster by checking this file. 

Select Device > Device Maintenance from the navigation tree, and click the Diagnostic Information 
tab to enter the page as shown in Figure 10-3. 

Figure 10-3 Diagnostic information 

 
 

When you click Create Diagnostic Information File, the system begins to generate diagnostic 
information file, and after the file is generated, the page is as shown in Figure 10-4. Click Click to 
Download, and the File Download dialog box appears. You can select to open this file or save this file 
to the local host. 
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Figure 10-4 The diagnostic information file is created 

 

 

 

 The generation of the diagnostic file will take a period of time. During this process, do not perform 
any operation on the Web page. 

 After the diagnostic file is generated successfully, you can view this file by selecting Device > File 
Management, or downloading this file to the local host. For the details, refer to File Management. 
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11  System Time 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

System Time Overview 

The system time module allows you to display and set the device system time on the Web interface. 
The device supports setting system time through manual configuration and automatic synchronization 
of NTP server time. 

An administrator can by no means keep time synchronized among all the devices within a network by 
changing the system clock on each device, because this is a huge amount of workload and cannot 
guarantee the clock precision. 

Defined in RFC 1305, the Network Time Protocol (NTP) synchronizes timekeeping among distributed 
time servers and clients. NTP allows quick clock synchronization within the entire network and ensures 
a high clock precision so that the devices can provide diverse applications based on the consistent time. 

Configuring System Time 

Select Device > System Time from the navigation tree. The system time configuration page appears 
by default, as shown in Figure 11-1. The current system time and clock status are displayed. 

Figure 11-1 System time configuration page 
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Configuring System Time Manually 

Select Device > System Time from the navigation tree to enter the system time configuration page as 
shown in Figure 11-1. Click the System Time Configuration text to open a calendar, as shown Figure 
11-2. 

Figure 11-2 Calendar page 

 

 

You can directly type the system date and time in the text box, or select the date and time in the calendar, 
where you can: 

 Click Today. The date setting in the calendar is synchronized to the current local date configuration, 
and the time setting does not change. 

  Or select the year, month, date, and time, and then click OK.  

Note that after finishing the configuration in the calendar, you need to click Apply in the system time 
configuration page to save your configuration.  

Configuring Network Time 

Select Device > System Time from the navigation tree, and then select the Net Time tab to enter the 
network time configuration page, as shown in Figure 11-3. 
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Figure 11-3 Network time configuration page 

 
 

Table 11-1 shows the network time configuration items. 

Table 11-1 Network time configuration items 

Item Description 

Clock status This field displays the synchronization status of the system clock.  

Local Reference Source 

Set the IP address of the local clock source to 127.127.1.u, where u ranges 
from 0 to 3, representing the NTP process ID. 

 If the IP address of the local clock source is specified, the local clock is 
used as the reference clock, and thus can provide time for other devices. 

 If the IP address of the local clock source is not specified, the local clock is 
not used as the reference clock. 

 
Support for this configuration item depends on the device model. 

Stratum 

Set the stratum level of the local clock. 
The stratum level of the local clock decides the precision of the local clock. A 
higher value indicates a lower precision. A stratum 1 clock has the highest 
precision, and a stratum 16 clock is not synchronized and cannot be used as a 
reference clock. 

 
Support for this configuration item depends on the device model. 

Source Interface 

Set the source interface for an NTP message. 
If you do not want the IP address of a certain interface on the local device to 
become the destination address of response messages, you can specify the 
source interface for NTP messages, so that the source IP address in the NTP 
messages is the primary IP address of this interface.  If the specified source 
interface is down, the source IP address is the primary IP address of the 
egress interface. 
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Item Description 

Key 1 

Key 2 

Set NTP authentication key. 
The NTP authentication feature should be enabled for a system running NTP 
in a network where there is a high security demand. This feature enhances the 
network security by means of client-server key authentication, which prohibits 
a client from synchronizing with a device that has failed authentication. 
You can set two authentication keys, each of which is composed of a key ID 
and key string. 

 ID is the ID of a key. 
 Key string is a character string for MD5 authentication key. 

NTP Server 
1/Reference 
Key ID 

External 
Reference 
Source NTP Server 

2/Reference 
Key ID 

Specify the IP address of an NTP server, and configure the authentication key 
ID used for the association with the NTP server. Only if the key provided by the 
server is the same with the specified key will the device synchronize its time to 
the NTP server. 
You can configure two NTP servers. The clients will choose the optimal 
reference source. 

 
The IP address of an NTP server is a unicast address, and cannot be a 
broadcast or a multicast address, or the IP address of the local clock source.

 

System Time Configuration Example 

Network requirements 
 As shown in Figure 11-4, the local clock of Device is set as the reference clock. 

 AC works in the client mode, and uses Device as the NTP server. 

 Configure NTP authentication on Device and AC. 

Figure 11-4 Network diagram for configuring system time 

 
 

Configuration procedure 
1) Configure Device 

# Configure the local clock as the reference clock, with the stratum of 2. Enable NTP authentication, set 
the key ID to 24, and specify the created authentication key aNiceKey is a trusted key. (Configuration 
omitted.) 

2) Configure AC 

# Configure Device as the NTP server of AC. 

 Select Device > System Time from the navigation tree, and then select the Net Time tab to 
perform the configurations as shown in Figure 11-5. 
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Figure 11-5 Configure Device as the NTP server of AC 

 
 

 Type 24 in the ID box, and type aNiceKey in the Key String text box for key 1. 

 Type 1.0.1.11 in the NTP Server 1 text box and type 24 in the Reference Key ID text box. 

 Click Apply. 

3) Verify the configuration 

After the above configuration, you can see that the current system time on Device is the same with that 
on AC. 

Configuration Guidelines 

When configuring system time, note that: 

 A device can act as a server to synchronize the clock of other devices only after its clock has been 
synchronized. If the clock of a server has a stratum level higher than or equal to that of a client’s 
clock, the client will not synchronize its clock to the server’s. 

 The synchronization process takes a period of time. Therefore, the clock status may be 
unsynchronized after your configuration. In this case, you can refresh the page to view the clock 
status and system time later on. 

 



 

12-1 

12  Syslog 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

System logs contain a large amount of network and device information, including running status and 
configuration changes. System logs are an important way for administrators to know network and 
device status. With system log information, administrators can take corresponding actions against 
network problems and security problems. 

System logs can be stored in the log buffer, or sent to the loghost. 

Configuring System Logs 

Configuration Task List 

Perform the tasks in Table 12-1 to configure system logs. 

Table 12-1 System logs configuration task list 

Task Description 

Setting Syslog Related 
Parameters 

Optional 
Set the number of logs that can be stored in the log buffer. 
Set the refresh period of the log information displayed on the Web interface.

Displaying Syslog Display detailed information of system logs. 

Setting Loghost 
Optional 
Set the loghost that can receive system logs. 
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Setting Syslog Related Parameters 

Select Device > Syslog from the navigation tree, and click the Logset tab to enter the syslog 
configuration page, as shown in Figure 12-1. 

Figure 12-1 Set system logs related parameters 

 
 

Table 12-2 describes the syslog configuration items. 

Table 12-2 Syslog configuration items 

Item Description 

Log Buffer Size Sets the number of logs that can be stored in the log buffer. 

Refresh Period 

Sets the refresh period on the log information displayed on the Web interface. 
You can select manual refresh or automatic refresh: 

 Manual: You need to click Refresh to refresh the Web interface when displaying 
log information. 

 Automatic: You can select to refresh the Web interface every 1 minute, 5 
minutes, or 10 minutes. 

 

Displaying Syslog 

Select Device > Syslog from the navigation tree to enter the syslog display page, as shown in Figure 
12-2. 
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Figure 12-2 Display syslog 

 
 

Table 12-3 describes the syslog display items. 

Table 12-3 Syslog display items 

Item Description 

Time/Date Displays the time/date when system logs are generated. 

Source Displays the module that generates system logs. 

Level Displays the severity level of system logs. For the detailed description of the severity 
levels, refer to Table 12-4. 

Digest Displays the brief description of system logs 

Description Displays the contents of system logs. 

 

You can perform the following operations in the syslog display page: 

 Click Clear to clear the log buffer. 

 Click Refresh to refresh the current page. 

Table 12-4 System logs severity level 

Severity level Description Value 

Emergency The system is unavailable. 0 

Alert Information that demands prompt reaction 1 

Critical Critical information 2 

Error Error information 3 

Warning Warnings 4 

Notification Normal information that needs to be noticed 5 

Informational Informational information to be recorded 6 

Debugging Information generated during debugging 7 

Note: A smaller value represents a higher severity level. 
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Setting Loghost 

Select Device > Syslog from the navigation tree, and click the Loghost tab to enter the loghost 
configuration page, as shown in Figure 12-3. 

Figure 12-3 Set loghost 

 

 

Table 12-5 describes the loghost configuration item. 

Table 12-5 Loghost configuration item 

Item Description 

IPv4/IPv6 

Loghost IP 

Specify the IPv4/IPv6 address of the loghost. You can specify up to four loghosts. 

 
Support for loghost IPv6 address depends on your device model. 
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13  Configuration Management 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Back Up Configuration 

Configuration backup provides the following functions: 

 Open and view the configuration file (.cfg file or .xml file) for the next startup 

 Back up the configuration file (.cfg file or .xml file) for the next startup to the host of the current user 

Select Device > Configuration from the navigation tree at the left side of the interface to enter the 
backup configuration page, as shown in Figure 13-1. 

Figure 13-1 Backup configuration page 

 

 

 After you click the upper Backup button in this figure, a file download dialog box appears. You can 
select to view the .cfg file or to save the file locally. 

 After you click the lower Backup button in this figure, a file download dialog box appears. You can 
select to view the .xml file or to save the file locally. 
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When backing up a configuration file, back up the configuration file with the extension .xml. Otherwise 
some configuration information may not be restored in some cases (for example, the configuration is 
removed). 

 

Restore Configuration  

Configuration restore provides the following functions: 

 Upload the .cfg file on the host of the current user to the device for the next startup 

 Upload the .xml file on the host of the current user to the device for the next startup, and delete the 
previous .xml configuration file that was used for the next startup 

Select Device > Configuration from the navigation tree at the left side of the interface, and then click 
the Restore tab to enter the configuration restore page, as shown in Figure 13-2. 

Figure 13-2 Configuration restore page 

 

 

 After you click the upper Browse button in this figure, the file upload dialog box appears. You can 
select the .cfg file to be uploaded, and then click OK. 

 After you click the lower Browse button in this figure, the file upload dialog box appears. You can 
select the .xml file to be uploaded, and then click OK. 

Save Configuration 

The save configuration module provides the function to save the current configuration to the 
configuration file (.cfg file or .xml file) for the next startup. 

Select Device or Configuration from the navigation tree at the left side of the interface, and then click 
the Save tab to enter the save configuration confirmation page, as shown in Figure 13-3. 

Figure 13-3 Save configuration confirmation 

 
 

Click the Save Current Settings button to save the current configuration to the configuration file. 
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 Saving the configuration takes a period of time. 

 The system does not support the operation of saving configuration of two or more consecutive 
users. If such a case occurs, the system prompts the latter users to try later. 

 

Initialize 

This operation will restore the system to factory defaults, delete the current configuration file, and reboot 
the device.  

Select Device > Configuration from the navigation tree at the left side of the interface, and then click 
the Initialize tab to enter the initialize confirmation page as shown in Figure 13-4. 

Figure 13-4 Initialize confirmation dialog box 

 
 

Click the Restore Factory-Default Settings button to restore the system to factory defaults. 
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14  File Management 

 

 

 There are many types of storage media such as flash and compact flash (CF). Support for different 
storage medium types depends on your device model. For more information, see "Feature 
Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

The device saves useful files (such as host software, configuration file) into the storage device, and the 
system provides the file management function for the users to manage those files conveniently and 
effectively. File management function provides the following operations: 

 Displaying File List 

 Downloading a File 

 Uploading a File 

 Removing a File 

File Management Configuration 

Displaying File List 

Select Device > File Manage from the navigation tree at the left side of the interface to enter the file 
management page, as shown in Figure 14-1. This page displays all files saved on the storage device, 
and filenames are displayed in the format of path + filename. 



 

14-2 

Figure 14-1 File management 

 
 

Downloading a File 

Select Device > File Manage from the navigation tree at the left side of the interface to enter the file 
management page, as shown in Figure 14-1. Select a file from the list, click the Download File button, 
and then a File Download dialog box appears. You can select to open the file or to save the file locally. 
You can download only one file at one time. 

Uploading a File 

Select Device > File Manage from the navigation tree at the left side of the interface to enter the file 
management page, as shown in Figure 14-1. You can type the file path and filename in the Upload File 
box at the bottom of the page, or click Browse to select a file, and then select a storage device from the 
drop-down list. Click Apply to upload the file to the specified storage device. 

 

 

Uploading a file takes some time. You are recommended not to perform any operation on the web 
interface during the upgrading procedure. 
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Removing a File 

Select Device > File Manage from the navigation tree at the left side of the interface to enter the file 
management page, as shown in Figure 14-1. You can remove a file by using one of the following ways: 

 Click the icon to remove a file.  
 Select one or multiple files from the file list, and then click Remove File. 

 



 

15-1 

15  Interface Management 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

In communications, an external interface (simply referred to as an interface defines a set of methods for 
two devices to exchange data and interact with each other. In the broad sense, interfaces fall into 
physical interfaces and logical interfaces. Physical interfaces are entities that physically exist and 
supported by components. Ethernet interfaces are an example of physical interfaces. Logical interfaces 
are interfaces created administratively or automatically by the system for data exchange but they do not 
exist in physical forms.  

Interface management on the Web-based configuration interface is to manage all physical interfaces on 
your device and the following two types of logical interfaces: 

 Layer 2 Ethernet interfaces, which are physical interfaces operating on the data link layer for 
forwarding Layer 2 protocol packets. 

 Management Ethernet interfaces, which are physical interfaces operating on the network layer. 
You can configure IP addresses for them. The administrator can log in to the device through a 
management Ethernet interface to manage the device. 

 Loopback interfaces, that is, logical interfaces whose IP addresses are on the network segment 
127.0.0.0. Loopback interfaces are used for receiving packets destined for the local device. 

 Null interfaces, which are always up but can neither forward data packets nor be configured with an 
IP address or any link layer protocol. Any data packets sent to a null interface will be dropped. 

 VLAN interfaces, which are virtual Layer 3 interfaces used for Layer 3 communications between 
VLANs. A VLAN interface corresponds to a VLAN. You can assign an IP address to a VLAN 
interface and specify it as the gateway of the corresponding VLAN to forward traffic destined for an 
IP network segment different from that of the VLAN. 
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 Virtual template (VT) interfaces, which are templates used for configuring virtual access (VA) 
interfaces.  

 Bridge-Aggregation interfaces, which are Layer 2 aggregate interfaces used in link aggregation. 

You can use the interface management feature to view interface information, create/remove logical 
interfaces, change interface status, and reset interface parameters.  

Configuring Interface Management 

Displaying Interface Information and Statistics 

Select Device > Interface in the navigation tree to enter the page shown in Figure 15-1. The page 
displays the interfaces’ names, IP addresses, masks, and status. You can click an interface name in the 
Name column to display the statistics of that interface, as shown in Figure 15-2.  

Figure 15-1 Interface management page 
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Figure 15-2 Statistics on an interface 

 

 

Creating an Interface 

Select Device > Interface in the navigation tree to enter the page shown in Figure 15-1. Then click Add 
to enter the page for creating an interface, as shown in Figure 15-3.  
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Figure 15-3 Create an interface 

 
 

Table 15-1 describes the configuration items of creating an interface. 

Table 15-1 Configuration items of creating an interface 

Item Description 

Interface Name Set the type and number of a logical interface.  

VID 

If you are creating a Layer 3 Ethernet subinterface, set the VLANs associated with the 
subinterface. 
This parameter is available only for Layer 3 Ethernet subinterfaces.  

 
Currently, this configuration item is not configurable because the device does not support 
Layer 3 Ethernet subinterfaces.  

MTU 

Set the maximum transmit unit (MTU) of the interface. 
The MTU value affects fragmentation and reassembly of IP packets. 

 
Support for this configuration item depends on the interface type. 

TCP MSS 

Set the maximum segment size (MSS) for IP packets on the interface.  
The TCP MSS value affects fragmentation and reassembly of IP packets.  

 
Support for this configuration item depends on the interface type. 
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Item Description 

IP Config 

Set the way for the interface to obtain an IP address, include: 
 None: Select this option if you do not want to assign an IP address for the interface. 
 Static Address: Select the option to manually assign an IP address and mask for the 

interface. If this option is selected, you must set the IP Address and Mask fields and the 
Secondary IP address and Mask fields. 

 DHCP: Select the option for the interface to obtain an IP address through DHCP 
automatically. 

 BOOTP: Select the option for the interface to obtain an IP address through BOOTP 
automatically. 

 PPP Negotiate: Select the option for the interface to obtain an IP address through PPP 
negotiation. 

 Unnumbered: Select this option to borrow the IP address of another interface on the 
same device for the interface. If this option is selected, you must select the interface 
whose IP address you want to borrow in the Unnumbered Interfaces drop-down list. 

 
Support for the way of obtaining an IP address depends on the device model and interface 
type. 

IP Address 

Mask 

If the Static Address option is selected as the way for the interface to obtain an IP address, 
you must set the primary IP address and subnet mask for the interface.  
The IP address cannot be set to 0.0.0.0; the length of the mask of a loopback interface is 
fixed to 32 bits and not configurable. 

Secondary IP 
Address 

Mask 

If the Static Address option is selected as the way for the interface to obtain an IP address, 
you must set the secondary IP address and subnet mask for the interface. 
You can configure multiple secondary IP addresses for an interface. Click Add, and you can 
add an IP address to the Secondary IP Address List. 
The IP address cannot be set to 0.0.0.0; the length of the mask of loopback interface is fixed 
to 32 bits and not configurable. 

Unnumbered 
Interface 

If the Unnumbered option is selected as the way for the interface to obtain an IP address, 
you must set the interface whose IP address is to be borrowed. 

IPv6 Config 

Set the way for the interface to obtain an IPv6 link-local 
address, include 

 None: Select this option if you do not want to assign 
an IPv6 link-local address to the interface. 

 Auto: Select this option for the system to 
automatically assign an IPv6 link-local address to 
the interface. 

 Manual: Select this option to manually assign an 
IPv6 link-local address to the interface. If this option 
is selected, you must set the IPv6 Link Local 
Address field. 

IPv6 Link Local 
Address 

If the Manual option is selected as the way for the 
interface to obtain an IPv6 link-local address, you must 
set an IPv6 link-local address for the interface. 

IPv6 unicast address: Set an IPv6 global unicast 
address or site-local address for an interface. 

IPv6 unicast 
config 

EUI64 encoding: Specify an IPv6 global unicast address 
or site local address in IEEE EUI-64 format. The prefix 
of the address is the specified prefix, and the interface 
identifier is converted from the MAC address of the 
interface. 

 
Support for the IPv6 address 
configuration of the interface 
depends on the device model. 
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Editing an Interface 

Select Device > Interface in the navigation tree to enter the page as shown in Figure 15-1, and then 
click the  icon corresponding to an interface to enter the Edit Interface page of the interface. For a 
Layer 2 physical port, the Edit Interface page is shown in Figure 15-4, and the editing items are shown 
in Table 15-2. For configurations of ports of other types, refer to Table 15-2. 

Figure 15-4 Edit a Layer 2 physical port 

 
 

Table 15-2 Configuration items of editing a Layer 2 physical port 

Item Description 

Port State Enables or disables the port. 

Flow Control Enables or disables flow control on the port. 

Link Type 

Sets the port’s link type, which can be access, hybrid or trunk.  
For more information about link types, refer to Table 15-3.  

 
To change a trunk port to a hybrid port or vice versa, you need to change it to an access 
port first.  

Jumbo Frame Allows or forbids jumbo frames to pass through the port.  

Speed 

Set the port’s transmission rate: 
 10: indicates 10 Mbps 
 100: indicates 100 Mbps 
 1000: indicates 1000 Mbps 
 Auto: indicates auto-negotiation 

Duplex 

Set the port’s duplex mode: 
 Auto: indicates auto-negotiation 
 Full: indicates full duplex 
 Half: indicates half duplex 
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Item Description 

MAX MAC Count 
Sets the maximum number of MAC addresses the port can learn: 

 User Defined: the user needs to manually input the maximum number 
 No Limited: there is no limit on the number of MAC addresses that can be learned 

PVID 

Set the port’s default VLAN ID 

 
 The trunk ports at the two ends of a link must have the same PVID. Otherwise, the link 

cannot properly transmit packets.  
 The hybrid ports at the two ends of a link must have the same PVID. Otherwise, the link 

cannot properly transmit packets.  

Broadcast 
Suppression 

Selects the parameter used in broadcast suppression and sets its value: 
 Ratio: indicates the maximum percentage of broadcast traffic to the total transmission 

capability of an Ethernet interface. When this parameter is selected, you need to 
provide a percentage in the box below.  

 PPS: indicates the maximum number of broadcast packets that can be forwarded on 
an Ethernet interface per second. When this parameter is selected, you need to 
provide a number in the box below. 

Multicast 
Suppression 

Selects the parameter used in multicast suppression and sets its value: 
 Ratio: indicates the maximum percentage of multicast traffic to the total transmission 

capability of an Ethernet interface. When this parameter is selected, you need to 
provide a percentage in the box below.  

 PPS: indicates the maximum number of multicast packets that can be forwarded on an 
Ethernet interface per second. When this parameter is selected, you need to provide a 
number in the box below. 

Unicast 
Suppression 

Selects the parameter used in unicast suppression and sets its value: 
 Ratio: indicates the maximum percentage of unicast traffic to the total transmission 

capability of an Ethernet interface. When this parameter is selected, you need to 
provide a percentage in the box below.  

 PPS: indicates the maximum number of unicast packets that can be forwarded on an 
Ethernet interface per second. When this parameter is selected, you need to provide a 
number in the box below. 

 

Table 15-3 Link type description 

Link type Description 

Access An access port can belong to only one VLAN and is usually used to connect a user device. 

Hybrid 
A hybrid port can be assigned to multiple VLANs, receive and send packets of multiple 
VLANs, and allow packets of multiple VLANs to pass through untagged. It can be used to 
connect network devices, as well as user devices.  

Trunk 
A trunk port can be assigned to multiple VLANs, receive and send packets of multiple 
VLANs, but allows only packets of the default VLAN to pass through untagged. It is usually 
used to connect network devices.  

 

Shutting Down/Bringing Up an Interface 

 

 

Do not shut down the Ethernet interface connecting the switch to the access controller module. 
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Select Device > Interface in the navigation tree to enter the page shown in Figure 15-1. By clicking the 
status icon of an interface, you can shut down the interface if it is currently up or bring up the interface if 
it is currently down.  

The following three icons show the status of an interface: 

 : indicates that the interface is up and connected.  

 : indicates that the interface is up but disconnected.  

 : indicates that the interface is down.  
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16  Port Mirroring Configuration 

 

 

 There are two kinds of port mirroring: local port mirroring and remote port mirroring. Unless 
otherwise specified, port mirroring in this document refers to local port mirroring. Support for port 
mirroring may vary by device. For more information, see "Feature Matrixes" in Compatibility 
Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Introduction to Port Mirroring 

Port mirroring is to copy the packets passing through one or multiple ports (called mirroring ports) to a 
port (called the monitor port) on the local device. The monitor port is connected with a monitoring device. 
By analyzing on the monitoring device the packets mirrored to the monitor port, you can monitor the 
network and troubleshoot possible network problems.  

Figure 16-1 A port mirroring implementation 
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Implementing Port Mirroring 

Port mirroring is implemented through mirroring groups.  

The mirroring ports and the monitor port are in the same mirroring group. With port mirroring enabled, 
the device copies packets passing through the mirroring ports to the monitor port.  

Other Supported Features 

Mirroring groups support inter-board mirroring, that is, the mirroring ports and the monitor port can be 
located on different boards.  

Besides, you can use one monitor port to monitor multiple mirroring ports 

 

 

Support for inter-board mirroring depends on your device model.  

 

Configuring Port Mirroring 

Configuration Task List 

Follow the steps in Table 16-1 to configure port mirroring: 

Table 16-1 Port mirroring configuration task list 

Task Remarks 

Create a mirroring group 
Required 
Refer to section Creating a Mirroring Group for details.  
You need to select the mirroring group type local in the Type drop-down list. 

Configure the mirroring ports 
Required 
Refer to section Configuring Ports for a Mirroring Group for details.  
During configuration, you need to select the port type Mirror Port.  

Configure the monitor port 
Required 
Refer to section Configuring Ports for a Mirroring Group for details.  
During configuration, you need to select the port type Monitor Port.  

 

Creating a Mirroring Group 

Select Device > Port Mirroring in the navigation tree and click the Create tab to enter the page for 
creating a mirroring port, as shown in Figure 16-2.  
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Figure 16-2 The page for creating a mirroring group 

 

 

Table 16-2 describes the configuration items of creating a mirroring group.  

Table 16-2 Configuration items of creating a mirroring group 

Item Description 

Mirroring Group ID ID of the mirroring group to be created  

Type 
Specify the type of the mirroring group to be created: 
Local: Creates a local mirroring group.  

 

Return to Port mirroring configuration task list.  

Configuring Ports for a Mirroring Group 

Select Device > Port Mirroring in the navigation tree and click Modify Port to enter the page for 
configuring ports for a mirroring group, as shown in Figure 16-3.  

Figure 16-3 The page for configuring ports for a mirroring group 

 

 

Table 16-3 describes the configuration items of configuring ports for a mirroring group.  
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Table 16-3 Configuration items of configuring ports for a mirroring group 

Item Description 

Mirroring Group ID 
ID of the mirroring group to be configured 
The available groups were created in advance.  

Port Type 
Sets the types of the ports to be configured: 

 Monitor Port: configures the monitor port for the mirroring group.  
 Mirror Port: configures mirroring ports for the mirroring group.  

Stream Orientation 

Set the direction of the traffic monitored by the monitor port of the mirroring group 
This configuration item is available when Mirror Port is selected is the Port Type 
drop-down list.  

 both: Mirrors both received and sent packets on mirroring ports.  
 inbound: Mirrors only packets received by mirroring port.  
 outbound: Mirrors only packets sent by mirroring ports.  

interface name Select the ports to be configured from the interface name list.  

 

Return to Port mirroring configuration task list.  

Configuration Examples 

Network requirements 
As shown in Figure 16-4, the customer network is as described below:  

 Packets from AP access AC through GigabitEthernet 1/0/1.  

 Server is connected to GigabitEthernet 1/0/2 of AC.  

Configure port mirroring to monitor the bidirectional traffic on GigabitEthernet 1/0/1 of AC on the server.  

To satisfy the above requirement through port mirroring, perform the following configuration on AC: 

 Configure GigabitEthernet 1/0/1 of AC as a mirroring port.  

 Configure GigabitEthernet 1/0/2 of AC as the monitor port.  

Figure 16-4 Network diagram for port mirroring configuration 

 

 

Configuration procedure 
# Create a mirroring group.  

 Select Device > Port Mirroring from the navigation tree and click Create to enter the page shown 
in Figure 16-5. 
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Figure 16-5 Create a mirroring group 

 

 

 Type mirroring group ID 1.  

 Select Local in the Type dropdown list.  

 Click Apply to complete the operation.  

# Configure the mirroring ports.  

 Click Modify Port to enter the page shown in Figure 16-6.  

Figure 16-6 Configure a mirroring port 
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 Select 1 – Local in the Mirroring Group ID dropdown list.  

 Select Mirror Port in the Port Type dropdown list.  

 Select both in the Stream Orientation dropdown list.  

 Select GigabitEthernet 1/0/1 in the interface name list.  

 Click Apply to complete the operation.  

# Configure the monitor port.  

In the page shown in Figure 16-7: 

Figure 16-7 Configure the monitor port 

 
 

 Select 1 – Local in the Mirroring Group ID dropdown list.  

 Select Monitor Port in the Port Type dropdown list.  

 Select GigabitEthernet 1/0/2 in the interface name list.  

 Click Apply to complete the operation. 

Configuration Guidelines 

When configuring port mirroring, note that: 

 To ensure operation of your device, do not enable STP, MSTP, or RSTP on the monitor port.  

 You can configure multiple mirroring ports but only one monitor port for a mirroring group.  

 A port can be assigned to only one mirroring group.  
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17  User Management 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

In the user management part, you can: 

 Set the username, password, and access level for an FTP or Telnet user. 

 Set the super password for switching the current Web user level to the management level 

 Switch the current Web user access level to the management level 

Users 

Creating a User 

Select Device > Users from the navigation tree, and click the Create tab to enter the page for creating 
local users, as shown in Figure 17-1. 
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Figure 17-1 Create a user 

 

 

Table 17-1 describes the configuration items for creating a user. 

Table 17-1 Configuration items for creating a user 

Item Description 

Username Sets the username for a user. The username cannot include two or more successive 
spaces and the signs mentioned on the page. 

Access Level 

Sets the access level for a user. Users of different levels can perform different operations.
Web user levels, from low to high, are visitor, monitor, configure, and management. 

 Visitor: Users of visitor level can only use the network diagnostic tool ping. They can 
neither access the device data nor configure the device. 

 Monitor: Users of this level can only access the device data but cannot configure the 
device. 

 Configure: Users of this level can access data on the device and configure the device, 
but they cannot upgrade the host software, add/delete/browse users, modify the 
passwords of other users, or restore the application file. 

 Management: Users of this level can perform any operations on the device. 

Password 

Sets the password for a user 
 When the password mode is Simple, the input password is in plain text.  
 When the password mode is Cipher, the input password is either in plain text or 

cipher text with a length of 24 or 88. In this case, the input plain password with the 
length smaller than or equal to 16 will be converted to a cipher password with a length 
of 24; the input plain password with a length greater than 16 but smaller than 63 will 
be converted to a cipher password with a length of 88. When the length of the input 
password is 24, if the system can decrypt the password, it considers the password as 
a ciphertext password; if not, the system considers the password as a plaintext 
password. When the length of the input password is 88, if the system can decrypt the 
password, it considers the password as a ciphertext password; if not, the system 
prompts that the password is invalid. 

Confirm Password Inputs the same password again. Otherwise, the system prompts that the two passwords 
input are not consistent when you apply the configuration.  
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Item Description 

Password Display 
Mode 

Sets the password display mode. 
 Simple: The password will be saved in the configuration file in plain text.  
 Cipher: The password will be saved in the configuration file in cipher text, even if the 

password is input in plain text when configured.  
The plaintext password is not safe, and you are recommended to use the ciphertext 
password.  
No matter the password mode is set to Simple or Cipher, you must enter the password in 
the form of plain text for login authentication.  

Service Type Sets the service type, including FTP and Telnet services. You must select either of them.

 

Setting the Super Password 

In this part, users of the management level can specify the password for a lower-level user to switch 
from the current access level to the management level. If no such a password is configured, the 
switchover will fail.  

Select Device > Users from the navigation tree, and click the Super Password tab to enter the super 
password configuration page, as shown in Figure 17-2. 

Figure 17-2 Super password 

 

 

Table 17-2 describes the configuration items of specifying a super password. 

Table 17-2 Super password configuration items 

Item Description 

Create/Remove 
Sets the operation type: 

 Create: Configure or modify the super password. 
 Remove: Remove the current super password. 

Password Sets the password for a user to switch to the management level. 

Confirm Password Inputs the same password again. Otherwise, the system prompts that the two passwords 
input are not consistent when you apply the configuration.  

Password Display 
Mode 

Sets the password display mode. 
 Simple: The password will be saved in the configuration file in plain text.  
 Cipher: The password will be saved in the configuration file in cipher text.  

The plaintext password is not safe, and you are recommended to use the ciphertext 
password.  
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Switching the User Access Level to the Management Level 

This function is provided for a user to switch the current user level to the management level. Note the 
following: 

 Before switching, make sure that the super password is already configured. A user cannot switch to 
the management level without a super password.  

 The access level switchover of a user is valid for the current login only. The access level configured 
for the user is not changed. When the user re-logs in to the Web interface, the access level of the 
user is still the original level.  

Select Device > Users from the navigation tree, and click the Switch To Management tab to enter the 
access level switching page, as shown in Figure 17-3. Type the super password and click Login. 

Figure 17-3 Switch to the management level. 
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18  SNMP Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

SNMP Overview 

Simple Network Management Protocol (SNMP) offers the communication rules between a 
management device and the managed devices on the network; it defines a series of messages, 
methods and syntaxes to implement the access and management from the management device to the 
managed devices. SNMP has the following characteristics: 

 Automatic network management. SNMP enables network administrators to search and modify 
information, find and diagnose network problems, plan for network growth, and generate reports on 
network nodes. 

 SNMP shields the physical differences between various devices and thus realizes automatic 
management of products from different manufacturers. Offering only the basic set of functions, 
SNMP makes the management tasks independent of both the physical features of the managed 
devices and the underlying networking technology. Thus, SNMP achieves effective management 
of devices from different manufacturers, especially in small, high-speed and low cost network 
environments. 

SNMP Mechanism 

An SNMP enabled network comprises Network Management Station (NMS) and agent. 

 An NMS is a station that runs the SNMP client software. It offers a user friendly interface, making it 
easier for network administrators to perform most network management tasks. 

 An agent is a program on the device. It receives and handles requests sent from the NMS. Only 
under certain circumstances, such as interface state change, will the agent inform the NMS. 

NMS manages an SNMP enabled network, whereas agents are the managed network device. NMS 
and agents exchange management information through the SNMP protocol. 
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SNMP provides the following four basic operations: 

 Get operation: NMS gets the value of a certain variable of the agent through this operation. 

 Set operation: NMS can reconfigure the value of one or more objects in the agent MIB 
(Management Information Base) by means of this operation. 

 Trap operation: The agent sends traps to the NMS through this operation. 

 Inform operation: The NMS sends traps to other NMSs through this operation. 

SNMP Protocol Version 

Currently, SNMP agents support SNMPv3 and are compatible with SNMPv1 and SNMPv2c. 

 SNMPv1 uses community name for authentication. Community name defines the relationship 
between an SNMP NMS and an SNMP agent. SNMP packets with community names that do not 
pass the authentication on the device are simply discarded. A community name plays a similar role 
as a key word and can be used to control access from NMS to the agent. 

 SNMPv2c uses community name for authentication. Compatible with SNMPv1, it extends the 
functions of SNMPv1. SNMPv2c provides more operation modes such as GetBulk and 
InformRequest; it supports more data types such as Counter64; and it provides various error codes, 
thus being able to distinguish errors in more detail. 

 SNMPv3 offers an authentication that is implemented with a User-Based Security Model (USM). 
You can set the authentication and privacy functions. The former is used to authenticate the validity 
of the sending end of the authentication packets, preventing access of illegal users; the latter is 
used to encrypt packets between the NMS and agents, preventing the packets from being 
intercepted. USM ensures a more secure communication between SNMP NMS and SNMP agent 
by authentication with privacy. 

Successful interaction between NMS and agents requires consistency of SNMP versions configured on 
them. You can configure multiple SNMP versions for an agent to interact with different NMSs. 

MIB Overview 

MIB 
Any managed resource can be identified as an object, which is known as the managed object. 
Management Information Base (MIB) is a collection of all the managed objects. It defines the hierarchy 
of the objects and a set of characteristics associated with the managed objects, such as the object 
identifier (OID), access right and data type. Each agent has its own MIB. NMS can read or write the 
managed objects in the MIB. The relationship between an NMS, agent and MIB is shown in Figure 18-1. 

Figure 18-1 Relationship between NMS, agent and MIB 

 

 

Subtree OID 
MIB stores data using a tree structure. A node of the tree is a managed object and can be uniquely 
identified by a path starting from the root node. As illustrated in Figure 18-2, the managed object A can 
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be uniquely identified by a string of numbers {1.2.1.1.5}. This string of numbers is the OID of the 
managed object A.  

A subtree can be identified by the OID of the root node of the subtree. For example, the OID of the 
subtree with the root node being B is the OID of node B –– {1.2.1.1}.  

Figure 18-2 MIB tree 
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Subtree mask 
A subtree OID used with a subtree mask defines a view subtree. A subtree mask is in hexadecimal 
format. After it is converted to binary bits, each bit corresponds to a node of the OID.  

 1 means precise matching, that is, the OID of the MIB object to be accessed must be identical with 
the subtree OID.  

 0 means wildcard matching, that is, the OID of the MIB object to be accessed can be different from 
the subtree OID.  

For example, provided the subtree mask 0xDB (11011011 in binary) and the subtree OID 1.3.6.1.6.1.2.1, 
their relationship is as shown in Figure 18-3. The view determined by them includes all the nodes under 
the subtree whose OID is 1.3.*.1.6.*.2.1, where * represents any number. 

Figure 18-3 Subtree OID and subtree mask 

 
 

 

 If the number of bits in the subtree mask is greater than the number of nodes of the OID, the 
excessive bits of the subtree mask will be ignored during subtree mask-OID matching. 

 If the number of bits in the subtree mask is smaller than the number of nodes of the OID, the short 
bits of the subtree mask will be set to 1 during subtree mask-OID matching. 

 If no subtree mask is specified, the default subtree mask (all Fs) will be used for mask-OID 
matching. 
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SNMP Configuration 

Configuration Task List 

Configuring SNMPv1 or SNMPv2c 
Perform the tasks in Table 18-1 to configure SNMPv1 or SNMPv2c: 

Table 18-1 SNMPv1 or SNMPv2c configuration task list 

Task Remarks 

Enabling SNMP 

Required 
The SNMP agent function is disabled by default. 

 
If SNMP is disabled, all SNMP-related configurations will be removed. 

Configuring an SNMP View 
Optional 
After creating SNMP views, you can specify an SNMP view for an SNMP 
group to limit the MIB objects that can be accessed by the SNMP group.

Configuring an SNMP Community Required 

Configuring SNMP Trap Function 

Optional 
Allows you to configure that the agent can send SNMP traps to the NMS, 
and configure information about the target host of the SNMP traps. 
By default, an agent is allowed to send SNMP traps to the NMS. 

 

Configuring SNMPv3 
Perform the tasks in Table 18-2 to configure SNMPv3: 

Table 18-2 SNMPv3 configuration task list 

Task Remarks 

Enabling SNMP 

Required 
The SNMP agent function is disabled by default. 

 
If SNMP is disabled, all SNMP-related configurations will be removed. 

Configuring an SNMP View 
Optional 
After creating SNMP views, you can specify an SNMP view for an SNMP 
group to limit the MIB objects that can be accessed by the SNMP group.

Configuring an SNMP Group 

Required 
After creating an SNMP group, you can add SNMP users to the group 
when creating the users. Therefore, you can realize centralized 
management of users in the group through the management of the group.

Configuring an SNMP User 
Required 
Before creating an SNMP user, you need to create the SNMP group to 
which the user belongs.  

Configuring SNMP Trap Function 

Optional 
Allows you to configure that the agent can send SNMP traps to the NMS, 
and configure information about the target host of the SNMP traps 
By default, an agent is allowed to send SNMP traps to the NMS. 
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Enabling SNMP 

Select Device > SNMP from the navigation tree to enter the SNMP configuration page, as shown in 
Figure 18-4. On the upper part of the page, you can select to enable or disable SNMP and configure 
parameters such as SNMP version; on the lower part of the page, you can view the SNMP statistics, 
which helps you understand the running status of the SNMP after your configuration. 

Figure 18-4 Set up 

 

 

Table 18-3 describes the configuration items for enabling SNMP. 
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Table 18-3 Configuration items for enabling SNMP 

Item Description 

SNMP Specify to enable or disable SNMP. 

Local Engine ID 

Configure the local engine ID. 
The validity of a user after it is created depends on the engine ID of the SNMP agent. 
If the engine ID when the user is created is not identical to the current engine ID, the 
user is invalid. 

Maximum Packet Size Configure the maximum size of an SNMP packet that the agent can receive/send. 

Contact 
Set a character string to describe the contact information for system maintenance.  
If the device is faulty, the maintainer can contact the manufacture factory according to 
the contact information of the device. 

Location Set a character string to describe the physical location of the device. 

SNMP Version Set the SNMP version run by the system 

 

Return to SNMPv1 or SNMPv2c configuration task list or SNMPv3 configuration task list. 

Configuring an SNMP View 

Select Device > SNMP from the navigation tree, and then click the View tab to enter the page as shown 
in Figure 18-5. 

Figure 18-5 View page 

 

 

Creating an SNMP view 
Click Add, the Add View window appears as shown in Figure 18-6. Type the view name and click 
Apply, and then you enter the page as shown in Figure 18-7. 

Figure 18-6 Create an SNMP view (I) 
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Figure 18-7 Create an SNMP view (II) 

 

 

Table 18-4 describes the configuration items for creating an SNMP view. After configuring the 
parameters of a rule, click Add to add the rule into the list box at the lower part of the page. After 
configuring all rules, click Apply to crate an SNMP view. Note that the view will not be created if you 
click Cancel. 

Table 18-4 Configuration items for creating an SNMP view 

Item Description 

View Name Set the SNMP view name. 

Rule Select to exclude or include the objects in the view range determined by the 
MIB subtree OID and subtree mask. 

MIB Subtree OID 
Set the MIB subtree OID (such as 1.4.5.3.1) or name (such as system). 
MIB subtree OID identifies the position of a node in the MIB tree, and it can 
uniquely identify a MIB subtree. 

Subtree Mask 
Set the subtree mask. 
If no subtree mask is specified, the default subtree mask (all Fs) will be used 
for mask-OID matching. 

 

Adding rules to an SNMP view 

Click the  icon corresponding to the specified view on the page as shown in Figure 18-5, the Add 

rule for the view ViewDefault window appears as shown in Figure 18-8. After configuring the 
parameters, click Apply to add the rule for the view. Table 18-4 describes the configuration items for 
creating an SNMP view. 
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Figure 18-8 Add rules to an SNMP view 

 

 

 

You can also click the  icon corresponding to the specified view on the page as shown in Figure 18-5, 
and then you can enter the page to modify the view. 

 

Return to SNMPv1 or SNMPv2c configuration task list or SNMPv3 configuration task list. 

Configuring an SNMP Community 

Select Device > SNMP from the navigation tree, then click the Community tab to enter the page as 
shown in Figure 18-9. Click Add to enter the Add SNMP Community page as shown in Figure 18-10. 

Figure 18-9 Configure an SNMP community 

 

 

Figure 18-10 Create an SNMP Community 

 
 

Table 18-5 describes the configuration items for configuring an SNMP community. 
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Table 18-5 Configuration items for configuring an SNMP community 

Item Description 

Community Name Set the SNMP community name. 

Access Right 

Configure SNMP NMS access right 
 Read only: The NMS can perform read-only operations to the MIB objects when it 

uses this community name to access the agent, 
 Read and write: The NMS can perform both read and write operations to the MIB 

objects when it uses this community name to access the agent. 

View Specify the view associated with the community to limit the MIB objects that can be 
accessed by the NMS. 

ACL Associate the community with a basic ACL to allow or prohibit the access to the agent 
from the NMS with the specified source IP address. 

 

Return to SNMPv1 or SNMPv2c configuration task list. 

Configuring an SNMP Group 

Select Device > SNMP from the navigation tree, then click the Group tab to enter the page as shown in 
Figure 18-11. Click Add to enter the Add SNMP Group page as shown in Figure 18-12. 

Figure 18-11 SNMP group 

 
 

Figure 18-12 Create an SNMP group 

 
 

Table 18-6 describes the configuration items for creating an SNMP group. 
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Table 18-6 Configuration items for creating an SNMP group 

Item Description 

Group Name Set the SNMP group name. 

Security Level 

Select the security level for the SNMP group. The available security levels are: 
 NoAuth/NoPriv: No authentication no privacy. 
 Auth/NoPriv: Authentication without privacy. 
 Auth/Priv: Authentication and privacy. 

Read View Select the read view of the SNMP group. 

Write View 
Select the write view of the SNMP group. 
If no write view is configured, the NMS cannot perform the write operations to all MIB 
objects on the device. 

Notify View 
Select the notify view of the SNMP group, that is, the view that can send trap messages. 
If no notify view is configured, the agent does not send traps to the NMS. 

ACL 
Associate a basic ACL with the group to restrict the source IP address of SNMP packets, 
that is, you can configure to allow or prohibit SNMP packets with a specific source IP 
address, so as to restrict the intercommunication between the NMS and the agent. 

 

Return to SNMPv3 configuration task list. 

Configuring an SNMP User 

Select Device > SNMP from the navigation tree, then click the User tab to enter the page as shown in 
Figure 18-13. Click Add to enter the Add SNMP User page, as shown in Figure 18-14. 

Figure 18-13 SNMP user 
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Figure 18-14 Create an SNMP user 

 

 

Table 18-7 describes the configuration items for creating an SNMP user. 

Table 18-7 Configuration items for creating an SNMP user 

Item Description 

User Name Set the SNMP user name. 

Security Level 

Select the security level for the SNMP group. The available security levels are: 
 NoAuth/NoPriv: No authentication no privacy. 
 Auth/NoPriv: Authentication without privacy. 
 Auth/Priv: Authentication and privacy. 

Group Name 

Select an SNMP group to which the user belongs. 
 When the security level is NoAuth/NoPriv, you can select an SNMP group 

with no authentication no privacy. 
 When the security level is Auth/NoPriv, you can select an SNMP group with 

no authentication no privacy or authentication without privacy. 
 When the security level is Auth/Priv, you can select an SNMP group of any 

security level. 

Authentication Mode Select an authentication mode (including MD5 and SHA) when the security level 
is Auth/NoPriv or Auth/Priv. 

Authentication Password 

Confirm Authentication 
Password 

Set the authentication password when the security level is Auth/NoPriv or 
Auth/Priv. 
The confirm authentication password must be the same with the authentication 
password. 

Privacy Mode Select a privacy mode (including DES56, AES128, and 3DES) when the security 
level is Auth/Priv. 

Privacy Password 

Confirm Privacy Password 

Set the privacy password when the security level is Auth/Priv. 
The confirm privacy password must be the same with the privacy password. 
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Item Description 

ACL 

Associate a basic ACL with the user to restrict the source IP address of SNMP 
packets, that is, you can configure to allow or prohibit SNMP packets with a 
specific source IP address, so as to allow or prohibit the specified NMS to access 
the agent by using this user name. 

 

Return to SNMPv3 configuration task list. 

Configuring SNMP Trap Function 

Select Device > SNMP from the navigation tree, and click the Trap tab to enter the page as shown in 
Figure 18-15. On the upper part of the page, you can select to enable the SNMP trap function; on the 
lower part of the page, you can configure target hosts of the SNMP traps. Click Add to enter the Add 
Trap Target Host page, as shown in Figure 18-16. 

Figure 18-15 Traps configuration 

 
 

Figure 18-16 Add a target host of SNMP traps 

 
 

Table 18-8 describes the configuration items for adding a target host of SNMP traps. 
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Table 18-8 Configuration items for adding a target host 

Item Description 

Destination IP 
Address 

Set the destination IP address. 
Select the IP address type: IPv4 or IPv6, and then type the corresponding IP address in 
the text box according to the IP address type. 

 
Support IPv6 depends on the device model. 

Security Name Set the security name, which can be an SNMPv1 community name, an SNMPv2c 
community name, or an SNMPv3 user name. 

UDP Port 

Set UDP port number. 

 
The default port number is 162, which is the SNMP-specified port used for receiving traps 
on the NMS. Generally (such as using iMC or MIB Browser as the NMS), you can use the 
default port number. To change this parameter to another value, you need to make sure 
that the configuration is the same with that on the NMS. 

Security Model Select the security model, that is, the SNMP version, which must be the same with that 
running on the NMS; otherwise, the NMS cannot receive any trap. 

Security Level 
Set the authentication and privacy mode for SNMP traps when the security model is 
selected as v3. The available security levels are: no authentication no privacy, 
authentication but no privacy, and authentication and privacy. 

 

Return to SNMPv1 or SNMPv2c configuration task list or SNMPv3 configuration task list. 

SNMP Configuration Examples 

Network requirements 
 As shown in Figure 18-17, the NMS connects to the agent, an AC, through an Ethernet. 

 The IP address of the NMS is 1.1.1.2/24. 

 The IP address of the VLAN interface on the AC is 1.1.1.1/24. 

 The NMS monitors the agent using SNMPv3. The agent reports errors or faults to the NMS. 

Figure 18-17 Network diagram for SNMP configuration 

 
 

Configuration procedure 
1) Configure the agent 

# Configuration IP addresses for the interfaces. (Omitted) 

# Enable SNMP. 

Select Device > SNMP from the navigation tree, and you will enter the Setup page, then perform the 
following configuration as shown in Figure 18-18. 
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Figure 18-18 Enable SNMP 

 
 

 Select the Enable radio box. 

 Select the v3 radio box. 

 Click Apply. 

# Configure an SNMP view. 

 Click the View tab and then click Add to enter the page as shown in Figure 18-19. 

Figure 18-19 Create an SNMP view (I) 

 

 

 Type view1 in the text box. 

 Click Apply to enter the SNMP rule configuration page, as shown in Figure 18-20. 
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Figure 18-20 Create an SNMP view (II) 

 
 

 Select the Included radio box. 

 Type the MIB subtree OID interfaces. 

 Click Add. 

 Click Apply. A configuration progress dialog box appears, as shown in Figure 18-21. 

Figure 18-21 Configuration progress dialog box 

 
 

 After the configuration process is complete, click Close. 

# Configure an SNMP group. 

 Click the Group tab and then click Add to enter the page as shown in Figure 18-22. 
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Figure 18-22 Create an SNMP group 

 
 

 Type group1 in the text box of Group Name. 

 Select view1 from the Read View drop-down box. 

 Select view1 from the Write View drop-down box. 

 Click Apply. 

# Configure an SNMP user 

 Click the User tab and then click Add to enter the page as shown in Figure 18-23. 

Figure 18-23 Create an SNMP user 

 

 

 Type user1 in the text box of User Name. 

 Select group1 from the Group Name drop-down box. 

 Click Apply. 
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# Enable the agent to send SNMP traps. 

 Click the Trap tab and enter the page as shown in Figure 18-24. 

Figure 18-24 Enable the agent to send SNMP traps 

 
 

 Select the Enable SNMP Trap check-box.  

 Click Apply. 

# Add target hosts of SNMP traps. 

 Click Add to enter the page as shown in Figure 18-25. 

Figure 18-25 Add target hosts of SNMP traps 

 
 

 Select the destination IP address type as IPv4. 

 Type the destination address 1.1.1.2. 

 Type the user name user1. 

 Select v3 from the Security Model drop-down box. 

 Click Apply. 
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2) Configure the NMS. 

 

 

The configuration on the NMS must be consistent with that on the agent. Otherwise, you cannot perform 
corresponding operations. 

 

SNMPv3 adopts a security mechanism of authentication and privacy. You need to configure username 
and security level. According to the configured security level, you need to configure the related 
authentication mode, authentication password, privacy mode, privacy password, and so on. 

Besides, you need to configure the aging time and retry times. After the above configurations, you can 
configure the device as needed through the NMS. For related configurations, refer to the manual 
provided for NMS. 

Verify the configuration 
 After the above configuration, an SNMP connection is established between the NMS and the agent. 

The NMS can get and configure the values of some parameters on the agent through MIB nodes. 

 If an idle interface on the agent is shut down or brought up, the NMS will receive a trap information 
sent by the agent. 
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19  Loopback 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

You can check whether an Ethernet port works normally by performing Ethernet port loopback test. 
During a loopback test, a port cannot forward data packets normally.  

Ethernet port loopback test can be internal or external. 

 In an internal loopback test, self loop is established in the switching chip to check whether there is 
a chip failure related to the port.  

 In an external loopback test, a self-loop header is used on the port. Packets forwarded by the port 
will be received by itself through the self-loop header. The external loopback test can be used to 
check whether there is a hardware failure on the port. 

Loopback Operation 

Select Device > Loopback from the navigation tree to enter the loopback test configuration page, as 
shown in Figure 19-1. 
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Figure 19-1 Loopback test configuration page 

 
 

Table 19-1 describes the loopback test configuration items. 

Table 19-1 Loopback test configuration items 

Item Description 

External Testing 
type Internal 

Sets the loopback test type, which can be selected between External and Internal. 
Support for the test type depends on the device model. 

Interface Specifies the Ethernet interface to have a loopback test. 

 

After the above configuration, click Test to start the loopback test, and you can see the test result at the 
right of the Test button, as shown in Figure 19-2. 
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Figure 19-2 Loopback test result 

 
 

Configuration Guidelines 

Note the following when performing a loopback test: 

 You can perform an internal loopback test but not an external loopback test for a port that is 
physically down, while you can perform neither test for a port that is manually shut down. 

 The system does not allow Rate, Duplex, and Port Status configuration on a port under the 
loopback test.  

 An Ethernet port works in the full duplex mode when the loopback test is performed, and restores 
its original duplex mode after the loopback test. 
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20  MAC Address Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 Currently, MAC address configurations related to interfaces only apply to Layer 2 Ethernet 
interfaces. 

 This manual covers only the management of static and dynamic MAC address entries, not 
multicast MAC address entries. 

 

Overview 

A device maintains a MAC address table for frame forwarding. Each entry in this table indicates the 
MAC address of a connected device, to which interface this device is connected and to which VLAN the 
interface belongs. A MAC address table consists of two types of entries: static and dynamic. Static 
entries are manually configured and never age out. Dynamic entries can be manually configured or 
dynamically learned and will age out.  

The following is how your device learns a MAC address after it receives a frame from a port, port A for 
example: 

1) Checks the frame for the source MAC address (MAC-SOURCE for example). 

2) Looks up the MAC address table for an entry corresponding to the MAC address and do the 
following: 

 If an entry is found for the MAC address, updates the entry. 

 If no entry containing the MAC address is found, adds an entry that contains the MAC address and 
the receiving port (port A) to the MAC address table. 

After the MAC address (MAC-SOURCE) is learned, if the device receives a frame destined for 
MAC-SOURCE, the device looks up the MAC address table and then forwards the frame from port A. 
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Dynamically learned MAC addresses cannot overwrite static MAC address entries, but the latter can 
overwrite the former. 

 

When forwarding a frame, the device adopts the following two forwarding modes based on the MAC 
address table: 

 Unicast mode: If an entry matching the destination MAC address exists, the device forwards the 
frame directly from the sending port recorded in the entry.  

 Broadcast mode: If the device receives a frame with the destination address being all Fs, or no 
entry matches the destination MAC address, the device broadcasts the frame to all the ports 
except the receiving port. 

Figure 20-1 MAC address table of the device 

 

 

Configuring MAC Addresses 

MAC addresses configuration includes the configuring and displaying of MAC address entries, and the 
setting of MAC address entry aging time. 

Configuring a MAC Address Entry 

Select Network > MAC from the navigation tree. The system automatically displays the MAC tab, which 
shows all the MAC address entries on the device, as shown in Figure 20-2. Click Add in the bottom to 
enter the page for creating MAC address entries, as shown in Figure 20-3.  
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Figure 20-2 The MAC tab 

 
 

Figure 20-3 Create a MAC address entry 

 
 

Table 20-1 shows the detailed configuration for creating a MAC address entry. 
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Table 20-1 Configuration items for creating a MAC address entry 

Item Description 

MAC Set the MAC address to be added. 

Type 

Set the type of the MAC address entry, which can be: 
 static: Indicates static MAC address entries that never age out. 
 dynamic: Indicates dynamic MAC address entries that will age out. 
 blackhole: Indicates blackhole MAC address entries that never age out. 

 
The types of the MAC address entries displayed in the tab are as follows: 

 Config static: Indicates static MAC address entries manually configured by the users. 
 Config dynamic: Indicates dynamic MAC address entries manually. configured by the users.
 Blackhole: Indicates blackhole MAC address entries. 
 Learned: Indicates dynamic MAC address entries learned by the device. 
 Other: Indicates types other than the ones mentioned above. 

VLAN Sets the ID of the VLAN to which the MAC address belongs. 

Port Sets the port to which the MAC address belongs. 

 

Setting the Aging Time of MAC Address Entries 

Select Network > MAC from the navigation tree, and then select the Setup tab to enter the page for 
setting the MAC address entry aging time, as shown in Figure 20-4. 

Figure 20-4 Set the aging time for MAC address entries 

 

 

The following table shows the detailed configuration of setting the MAC address entry aging time. 

Table 20-2 Configuration items of setting the aging time for a MAC address entry 

Item Description 

No-aging Specify that the MAC address entry never ages out. 

Aging time Set the aging time for the MAC address entry. 

 

MAC Address Configuration Examples 

Network requirements 
Use the MAC address table management function of the Web-based NMS. It is required to add a static 
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MAC address 00e0-fc35-dc71 under GigabitEthernet 1/0/1 in VLAN 1.  

Configuration procedure 
# Create a static MAC address entry. 

Select Network > MAC from the navigation tree to enter the MAC tab, and then click Add. The page 
shown in Figure 20-5 appears. 

Figure 20-5 Create a static MAC address entry 

 
 

Make the following configurations on the page shown in Figure 20-5:  

 Type in MAC address 00e0-fc35-dc71. 

 Select static in the Type drop down list. 

 Select 1 in the VLAN drop down list. 

 Select GigabitEthernet1/0/1 in the Port drop down list. 

 Click Apply to end the operation. 
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21  VLAN Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Introduction to VLAN 

Ethernet is a network technology based on the Carrier Sense Multiple Access/Collision Detect 
(CSMA/CD) mechanism. As the medium is shared, collisions and excessive broadcasts are common 
on an Ethernet. To address the issue, virtual LAN (VLAN) was introduced. The idea is to break a LAN 
down into separate VLANs, that is, Layer 2 broadcast domains whereby frames are switched between 
ports assigned to the same VLAN. VLANs are isolated from each other at Layer 2. A VLAN is a bridging 
domain, and all broadcast traffic is contained within it, as shown in Figure 21-1.  

Figure 21-1 A VLAN diagram 

VLAN 2

VLAN 5

Switch BSwitch A
Router
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A VLAN is logically divided on an organizational basis rather than on a physical basis. For example, all 
workstations and servers used by a particular workgroup can be connected to the same LAN, 
regardless of their physical locations.  

VLAN technology delivers the following benefits: 

 Confining broadcast traffic within individual VLANs. This reduces bandwidth waste and improves 
network performance.  

 Improving LAN security. By assigning user groups to different VLANs, you can isolate them at 
Layer 2. For hosts in different VLANs to communicate, routers or Layer 3 switches are required.  

 Flexible virtual workgroup creation. As users from the same workgroup can be assigned to the 
same VLAN regardless of their physical locations, network construction and maintenance is much 
easier and more flexible.  

How VLAN Works 

To enable a network device to identify frames of different VLANs, a VLAN tag field is inserted into the 
data link layer encapsulation.  

The format of VLAN-tagged frames is defined in IEEE 802.1Q-1999.  

In the header of a traditional Ethernet data frame as shown in Figure 21-2, the field after the destination 
MAC address and the source MAC address fields (DA&SA in the figure) is the Type field indicating the 
upper layer protocol type.  

Figure 21-2 The format of a traditional Ethernet frame 

 

 

IEEE 802.1Q inserts a four-byte VLAN tag before the Type field, as shown in Figure 21-3.  

Figure 21-3 The position and format of VLAN tag 

 

 

A VLAN tag comprises four fields: tag protocol identifier (TPID), priority, canonical format indicator (CFI), 
and VLAN ID.  

 The 16-bit TPID field with a value of 0x8100 indicates that the frame is VLAN tagged.  

 The 3-bit priority field indicates the 802.1p priority of the frame.  

 The 1-bit CFI field specifies whether the MAC addresses are encapsulated in the canonical format 
for the receiving device to correctly interpret the MAC addresses. Value 0 indicates that the MAC 
addresses are encapsulated in canonical format; value 1 indicates that the MAC addresses are 
encapsulated in non-canonical format. The field is set to 0 by default.  

 The 12-bit VLAN ID field identifies the VLAN the frame belongs to. The VLAN ID range is 0 to 4095. 
As 0 and 4095 are reserved by the protocol, the VLAN ID range available for assignment is 1 to 
4094.  

When receiving a frame, a network device looks at its VLAN tag to decide how to handle the frame.  
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The Ethernet II encapsulation format is used in this section. Besides this format, other encapsulation 
formats, including 802.2 LLC, 802.2 SNAP, and 802.3 raw, are also supported by Ethernet. The VLAN 
tag fields are also used in these encapsulations for VLAN identification.  

 

Types of VLAN 

You can create VLANs based on: 

 Port 

 MAC address 

 Protocol 

 IP subnet 

 Policy 

 Other criteria 

Because the Web interface is available only for port-based VLANs, this chapter introduces only 
port-based VLANs.  

Introduction to Port-Based VLAN 

Port-based VLANs group VLAN members by port. A port forwards traffic for a VLAN only after it is 
assigned to the VLAN.  

Port link type 
Depending on the tag handling mode, the link type of a port can be one of the following three: 

 Access. An access port belongs to only one VLAN and usually connects to a user device.  

 Trunk. A trunk port can join multiple VLANs to receive and send traffic for them. It usually connects 
to a network device.  

 Hybrid. A hybrid port can join multiple VLANs to receive and send traffic for them. It can connect 
either a user device or a network device.  

A hybrid port is different from a trunk port in that:  

 A hybrid port allows traffic of multiple VLANs to pass through untagged.  

 A trunk port allows only traffic of the default VLAN to pass through untagged.  

Default VLAN 
By default, VLAN 1 is the default VLAN for all ports. However, you can change the default VLAN for a 
port as required. When doing that, follow these guidelines: 

 Because an access port can join only one VLAN, its default VLAN is the VLAN to which it belongs 
and cannot be configured.  

 Because a trunk or hybrid port can join multiple VLANs, you can configure a default VLAN for the 
port.  
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A port configured with a default VLAN handles a frame as follows: 

Actions (in the inbound direction) 
Port type 

Untagged frame Tagged frame 
Actions (in the outbound direction)

Access 
Tag the frame with 
the default VLAN 
tag. 

 Receive the frame if its 
VLAN ID is the same as 
the default VLAN ID. 

 Drop the frame if its 
VLAN ID is different from 
the default VLAN ID.  

Remove the default VLAN tag and 
send the frame. 

Trunk 

 Remove the tag and send the 
frame if the frame carries the 
default VLAN tag. 

 Send the frame without removing 
the tag if its VLAN is carried on the 
port but is different from the default 
one.  

Hybrid 

Check whether the 
default VLAN is 
carried on the port: 

 If yes, tag the 
frame with the 
default VLAN 
tag. 

 If not, drop the 
frame. 

 Receive the frame if its 
VLAN is carried on the 
port. 

 Drop the frame if its 
VLAN is not carried on 
the port. Send the frame if its VLAN is carried on 

the port. The frame is sent with the 
VLAN tag removed or intact depending 
on your configuration.  

 

Configuring a VLAN 

Configuration Task List 

Perform the tasks in Table 21-1 to configure a VLAN: 

Table 21-1 VLAN configuration task list 

Task Remarks 

Creating a VLAN Required 

Modifying a VLAN 

Modifying a Port 

Required 
Select either task. 
Configure the untagged member ports and tagged member ports of the VLAN, or 
remove ports from the VLAN.  

 

Creating a VLAN 

Select Network > VLAN in the navigation tree. The system automatically selects the VLAN tab and 
enters the page as shown in Figure 21-4.  
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Figure 21-4 VLAN configuration page 

 

 

Click Add to enter the page for creating a VLAN, as shown in Figure 21-5. 

Figure 21-5 Create a VLAN 

 

 

Table 21-2 describes the configuration items of creating a VLAN.  

Table 21-2 Configuration items of creating a VLAN 

Item Description 

VLAN ID ID of the VLAN to be created 

 

Return to VLAN configuration task list.  

Modifying a VLAN 

Select Network > VLAN in the navigation tree. The system automatically selects the VLAN tab and 
enters the page as shown in Figure 21-4. In the Operation column for the VLAN you want to modify, 
click the  icon to enter the page for modifying the VLAN, as shown in Figure 21-6.  
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Figure 21-6 Modify a VLAN 

 

 

Table 21-3 describes the configuration items of modifying a VLAN.  

Table 21-3 Configuration items of modifying a VLAN 

Item Description 

ID This field displays the ID of the VLAN to be modified. 

Description 
Set the description string of the VLAN. 
By default, the description string of a VLAN is its VLAN ID, such as VLAN 0001.  

Untagged 
Member 

Tagged 
Member Port 

Not A 
Member 

Set the member type of the port to be modified in the VLAN. 
Find the port to be modified and select the Untagged Member, Tagged Member, or 
Not a Member option for the port: 

 Untagged Member: Indicates that the port sends the traffic of the VLAN with the 
VLAN tag removed.  

 Tagged Member: Indicates that the port sends the traffic of the VLAN without 
removing the VLAN tag.  

 Not a Member: Removes the port from the VLAN.  

 

Return to VLAN configuration task list. 

Modifying a Port 

Select Network > VLAN in the navigation tree, and select the Port tab to enter the page as shown in 
Figure 21-7.  
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Figure 21-7 Port configuration page 

 

 

In the Operation column, click the  icon for the port to be modified to enter the page for modifying the 
port, as shown in Figure 21-8.  

Figure 21-8 Modify a port 

 

 

Table 21-4 describes the configuration items of modifying a port.  

Table 21-4 Configuration items of modifying a port 

Item Description 

Port This field displays the port to be modified. 

Untagged Member This field displays the VLAN(s) to which the port belongs as an untagged member.

Tagged Member This field displays the VLAN(s) to which the port belongs as a tagged member. 

Untagged 

Tagged Member 
Type 

Not A 
Member 

Set the target member type of the port. 
Select the Untagged, Tagged, or Not a Member radio button: 

 Untagged: Indicates that the port sends the traffic of the VLAN with the VLAN 
tag removed.  

 Tagged: Indicates that the port sends the traffic of the VLAN without removing 
the VLAN tag.  

 Not a Member: Removes the port from the VLAN.  

VLAN ID Specify the VLAN to which the port belongs.  

 

Return to VLAN configuration task list. 
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VLAN Configuration Example 

Network requirements 
As shown in Figure 21-9: 

 GigabitEthernet 1/0/1 of AC 1 is connected to GigabitEthernet 1/0/1 of AC 2.  

 GigabitEthernet 1/0/1 on both devices are trunk ports with VLAN 100 as their default VLAN.  

 Configure GigabitEthernet 1/0/1 to permit packets of VLAN 2, VLAN 6 through VLAN 50, and VLAN 
100 to pass through.  

Figure 21-9 Network diagram for VLAN configuration 

 

 

Configuration procedure 
1) Configure AC 1 

# Create VLAN 2, VLAN 6 through VLAN 50, and VLAN 100.  

 Select Network > VLAN in the navigation tree to enter the VLAN tab, that is, the VLAN 
configuration page, as shown in Figure 21-10. Click Add to enter the page for creating a VLAN, as 
shown in Figure 21-11. 

Figure 21-10 VLAN configuration page 
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Figure 21-11 Create a VLAN 

 

 

 On the page shown in Figure 21-11, type 2,6-50,100 for VLAN ID.  

 Click Apply to end the operation.  

# Configure GigabitEthernet 1/0/1 as an untagged member of VLAN 100.  

 Type 100 in the VLAN Range text box, and then click Select, as shown in Figure 21-12.  

Figure 21-12 Select a VLAN 

 
 

 On the VLAN configuration page as shown in Figure 21-13, click the  icon for VLAN 100 (Only 
VLAN 100 is displayed in the VLAN list). The page shown in Figure 21-14 appears.  
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Figure 21-13 VLAN configuration page 

 
 

Figure 21-14 Modify a VLAN 

 

 

Make the following configurations on the page shown in Figure 21-14: 

 Find GigabitEthernet1/0/1 in the port list.  

 Select the Untagged Member option for the port.  

 Click Apply to end the operation.  

# Configure GigabitEthernet 1/0/1 as a tagged member of VLAN 2, and VLAN 6 through VLAN 50.  

 Select Network > VLAN in the navigation tree and then select the Port tab to enter the page shown 
in Figure 21-15.  

 Find GigabitEthernet1/0/1 in the port list, and click the corresponding  icon in the Operation 
column. The page for modifying the selected port appears, as shown in Figure 21-16. 
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Figure 21-15 The Port tab 

 
 

Figure 21-16 Modify a port 

 

 

Make the following configurations on the page: 

 Select the Tagged option.  

 Type 2,6-50 for VLAN ID.  

 Click Apply and a dialog box appears, asking you to confirm that interface GigabitEthernet 1/0/1 be 
changed to a hybrid port. Click OK to confirm the operation. 

2) Configure AC 2 

Configure AC 2 as you configure AC 1.  

Configuration Guidelines 

When configuring VLAN, note that: 

 VLAN 1 is the default VLAN, which cannot be manually created or removed.  

 Some VLANs are reserved for special purposes. You cannot manually create or remove them.  

 As shown in Figure 21-4., on the VLAN configuration page, when you type a VLAN range in the 
VLAN Range box and then click Select, the table below lists the information about all the VLANs 
within this range, which makes the operation much easier when the device contains a large number 
of VLANs; when you click Delete, all VLANs within this range will be removed.  

 Dynamic VLANs cannot be manually removed.  
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22  ARP Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

ARP Overview 

ARP Function 

The Address Resolution Protocol (ARP) is used to resolve an IP address into an Ethernet MAC address 
(or physical address). 

In an Ethernet LAN, when a device sends data to another device, it uses ARP to translate the IP 
address of the destination device to the corresponding MAC address. 

ARP Message Format 

ARP messages are classified into ARP requests and ARP replies. Figure 22-1 shows the format of the 
ARP request/reply. 

Figure 22-1 ARP message format 

 

 

The following describe the fields in Figure 22-1. 

 Hardware type: This field specifies the hardware address type. The value “1” represents Ethernet. 
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 Protocol type: This field specifies the type of the protocol address to be mapped. The hexadecimal 
value “0x0800” represents IP. 

 Hardware address length and protocol address length: They respectively specify the length of a 
hardware address and a protocol address, in bytes. For an Ethernet address, the value of the 
hardware address length field is "6”. For an IP(v4) address, the value of the protocol address length 
field is “4”. 

 OP: Operation code. This field specifies the type of the ARP message. The value “1” represents an 
ARP request and “2” represents an ARP reply. 

 Sender hardware address: This field specifies the hardware address of the device sending the 
message. 

 Sender protocol address: This field specifies the protocol address of the device sending the 
message. 

 Target hardware address: This field specifies the hardware address of the device the message is 
being sent to. 

 Target protocol address: This field specifies the protocol address of the device the message is 
being sent to. 

ARP Operation 

Suppose that Host A and Host B are on the same subnet and Host A sends a packet to Host B, as 
shown in Figure 22-2. The resolution process is as follows: 

 Host A looks into its ARP table to see whether there is an ARP entry for Host B. If yes, Host A uses 
the MAC address in the entry to encapsulate the IP packet into a data link layer frame and sends 
the frame to Host B. 

 If Host A finds no entry for Host B, Host A buffers the packet and broadcasts an ARP request, in 
which the sender IP address and the sender MAC address are the IP address and the MAC 
address of Host A respectively, and the target IP address and the target MAC address are the IP 
address of Host B and an all-zero MAC address respectively. Because the ARP request is a 
broadcast, all hosts on this subnet can receive the request, but only the requested host (namely, 
Host B) will respond to the request. 

 Host B compares its own IP address with the destination IP address in the ARP request. If they are 
the same, Host B saves the source IP address and source MAC address in its ARP table, 
encapsulates its MAC address into an ARP reply, and unicasts the reply to Host A. 

 After receiving the ARP reply, Host A adds the MAC address of Host B to its ARP table. Meanwhile, 
Host A encapsulates the IP packet and sends it out. 
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Figure 22-2 ARP address resolution process 

 

 

If Host A is not on the same subnet with Host B, Host A first sends an ARP request to the gateway. The 
target IP address in the ARP request is the IP address of the gateway. After obtaining the MAC address 
of the gateway from an ARP reply, Host A sends the packet to the gateway. If the gateway maintains the 
ARP entry of Host B, it forwards the packet to Host B directly; if not, it broadcasts an ARP request, in 
which the target IP address is the IP address of Host B. After obtaining the MAC address of Host B, the 
gateway sends the packet to Host B. 

ARP Table 

After obtaining the MAC address for the destination host, the device puts the IP-to-MAC mapping into its 
own ARP table. This mapping is used for forwarding packets with the same destination in future. 

An ARP table contains ARP entries, which fall into one of two categories: dynamic or static. 

Dynamic ARP entry 
A dynamic entry is automatically created and maintained by ARP. It can get aged, be updated by a new 
ARP packet, or be overwritten by a static ARP entry. When the aging timer expires or the interface goes 
down, the corresponding dynamic ARP entry will be removed. 

Static ARP entry 
A static ARP entry is manually configured and maintained. It cannot get aged or be overwritten by a 
dynamic ARP entry.  

Using static ARP entries enhances communication security. After a static ARP entry is specified, only a 
specific MAC address is associated with the specified IP address. Attack packets cannot modify the 
IP-to-MAC mapping. Thus, communications between devices are protected. 

Static ARP entries can be classified into permanent or non-permanent. 

 A permanent static ARP entry can be directly used to forward packets. When configuring a 
permanent static ARP entry, you must configure a VLAN and an outbound interface for the entry 
besides the IP address and the MAC address. 

 A non-permanent static ARP entry has only an IP address and a MAC address configured. If the 
outbound interface is a Layer 3 Ethernet interface, the non-permanent ARP entry can be directly 
used for forwarding data; if the outbound interface is a VLAN interface, it cannot be directly used for 
forwarding data. If a non-permanent static ARP entry matches an IP packet to be forwarded, the 
device sends an ARP request first. If the sender IP and MAC addresses in the received ARP reply 
are the same as those in the non-permanent static ARP entry, the device adds the interface 
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receiving the ARP reply to the non-permanent static ARP entry. Then the entry can be used for 
forwarding IP packets. 

 

 

Usually ARP dynamically resolves IP addresses to MAC addresses, without manual intervention. 

 

Configuring ARP Entries 

Displaying ARP Entries 

Select Network > ARP Management from the navigation tree to enter the default ARP Table page 
shown in Figure 22-3. All ARP entries are displayed on the page. 

Figure 22-3 ARP Table configuration page 

 

 

Creating a Static ARP Entry 

Select Network > ARP Management from the navigation tree to enter the default ARP Table page 
shown in Figure 22-3. Click Add to enter the New Static ARP Entry page. Select the Advanced 
Options checkbox to expand advanced configuration items, as shown in Figure 22-4. 
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Figure 22-4 Add a static ARP entry 

 

 

Table 22-1 describes the static ARP entry configuration items. 

Table 22-1 Static ARP entry configuration items 

Item Description 

IP Address Type an IP address for the static ARP entry. 

MAC Address Type a MAC address for the static ARP entry. 

VLAN 
ID Advanced 

Options 
Port 

Type a VLAN ID and specify a port for the static ARP entry. 

 
The VLAN ID must be the ID of the VLAN that has already been created, and the port 
must belong to the VLAN. The corresponding VLAN interface must have been created.

 

Static ARP Configuration Example 

Network Requirements 
As shown in Figure 22-5, an AC is connected to a router via GigabitEthernet 1/0/1, which belongs to 
VLAN 100. The IP address of the router is 192.168.1.1/24. The MAC address of the router is 
00e0-fc01-0000. 

To enhance communication security between the AC and the router, a static ARP entry needs to be 
configured on the AC. 

Figure 22-5 Network diagram for configuring static ARP entries (on an AC) 

 

 

 

Configuration procedure 
# Create VLAN 100. 
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 Select Network > VLAN from the navigation tree to enter the default VLAN page, click Add, and 
then perform the following operations, as shown in Figure 22-6. 

Figure 22-6 Create VLAN 100 

 

 

 Type 100 for VLAN ID. 

 Click Apply to complete the configuration. 

# Add GigabitEthernet 1/0/1 to VLAN 100. 

 On the VLAN page, click the corresponding  icon of VLAN 100 and then perform the following 
operations, as shown in Figure 22-7. 

Figure 22-7 Add GigabitEthernet 1/0/1 to VLAN 100 

 

 

 Click on the Untagged Member radio button next to the GigabitEthernet 1/0/1 port. 

 Click Apply to complete the configuration. 

# Configure VLAN-interface 100. 

 Select Device > Interface from the navigation tree, click Add, and then perform the following 
operations, as shown in Figure 22-8. 
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Figure 22-8 Configure VLAN-interface 100 

 
 

 Select Vlan-interface from the list next to Interface Name, and type 100 in the text box. 

 Click on the Static Address radio button in the IP Config field. 

 Type 192.168.1.2 for IP Address. 

 Select 24 (255.255.255.0) for Mask. 

 Click Apply to complete the configuration. 

# Create a static ARP entry. 

 Select Network > ARP Management from the navigation tree to enter the default ARP Table page. 
Click Add. Perform the following operations, as shown in Figure 22-9. 
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Figure 22-9 Create a static ARP entry 

 

 

 Type 192.168.1.1 for IP Address. 

 Type 00e0-fc01-0000 for MAC Address. 

 Select the Advanced Options checkbox. 

 Type 100 for VLAN ID. 

 Select GigabitEthernet1/0/1 for Port. 

 Click Apply to complete the configuration. 

Gratuitous ARP 

Introduction to Gratuitous ARP 

In a gratuitous ARP packet, the sender IP address and the target IP address are both the IP address of 
the device issuing the packet, the sender MAC address is the MAC address of the device, and the target 
MAC address is the broadcast address ff:ff:ff:ff:ff:ff. 

A device implements the following functions by sending gratuitous ARP packets: 

 Determining whether its IP address is already used by another device. 

 Informing other devices about the change of its MAC address so that they can update their ARP 
entries. 

A device receiving a gratuitous ARP packet adds the information carried in the packet to its own 
dynamic ARP table if it finds no corresponding ARP entry exists in the cache. 

Configuring Gratuitous ARP 

Select Network > ARP Management from the navigation tree, and click the Gratuitous ARP tab to 
enter the page shown in Figure 22-10. 
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Figure 22-10 Gratuitous ARP configuration page 

 

 

Table 22-2 describes the gratuitous ARP configuration items. 

Table 22-2 Gratuitous ARP configuration items 

Item Description 

Disable gratuitous ARP packets 
learning function 

Disable learning of ARP entries according to gratuitous ARP packets. 
Enabled by default. 

Send gratuitous ARP packets when 
receiving ARP requests from 
another network segment 

Enable the device to send gratuitous ARP packets upon receiving ARP 
requests from another network segment. 
Disabled by default. 
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23  ARP Attack Defense Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Although ARP is easy to implement, it provides no security mechanism and thus is prone to network 
attacks. Currently, ARP attacks and viruses are threatening LAN security. The device can provide 
multiple features to detect and prevent such attacks. This chapter mainly introduces these features. 

ARP Detection 

Introduction to ARP Detection 

The ARP detection feature allows only the ARP packets of authorized clients to be forwarded, hence 
preventing man-in-the-middle attacks. 

Man-in-the-middle attack 
According to the ARP design, after receiving an ARP reply, a host adds the IP-to-MAC mapping of the 
sender to its ARP mapping table. This design reduces the ARP traffic on the network, but also makes 
ARP spoofing possible. 

As shown in Figure 23-1, Host A communicates with Host C through a device. After intercepting the 
traffic between Host A and Host C, a hacker (Host B) forwards forged ARP replies to Host A and Host C 
respectively. Upon receiving the ARP replies, the two hosts update the MAC address corresponding to 
the peer IP address in their ARP tables with the MAC address of Host B (MAC_B). After that, Host B 
establishes independent connections with Host A and Host C and relays messages between them, 
deceiving them into believing that they are talking directly to each other over a private connection, while 
the entire conversation is actually controlled by Host B. Host B may intercept and modify the 
communication data. Such an attack is called a man-in-the-middle attack. 
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Figure 23-1 Man-in-the-middle attack 
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ARP detection mechanism 
With ARP detection enabled for a specific VLAN, ARP messages arriving on any interface in the VLAN 
are redirected to the CPU to have their sender MAC and IP addresses checked. ARP messages that 
pass the check are forwarded; otherwise, they are discarded. 

1) ARP detection based on static IP Source Guard binding entries/DHCP snooping entries/802.1X 
security entries/OUI MAC addresses 

With this feature enabled, the device compares the sender IP and MAC addresses of an ARP packet 
received from the VLAN against the static IP Source Guard binding entries, DHCP snooping entries, 
802.1X security entries, or OUI MAC addresses to prevent spoofing. 

After you enable this feature for a VLAN, 

 Upon receiving an ARP packet from an ARP untrusted port, the device compares the sender IP 
and MAC addresses of the ARP packet against the static IP Source Guard binding entries. If a 
match is found, the ARP packet is considered valid and is forwarded. If an entry with a matching IP 
address but an unmatched MAC address is found, the ARP packet is considered invalid and is 
discarded. If no entry with a matching IP address is found, the device compares the ARP packet's 
sender IP and MAC addresses against the DHCP snooping entries, 802.1X security entries, and 
OUI MAC addresses. 

 If a match is found in any of the entries, the ARP packet is considered valid and is forwarded. ARP 
detection based on OUI MAC addresses refers to that if the sender MAC address of the received 
ARP packet is an OUI MAC address, the packet is considered valid. 

 If no match is found, the ARP packet is considered invalid and is discarded. 

 Upon receiving an ARP packet from an ARP trusted port, the device does not check the ARP 
packet. 

2) ARP detection based on specified objects 

You can also specify objects in ARP packets to be detected. The objects involve: 
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 src-mac: Checks whether the sender MAC address of an ARP packet is identical to the source 
MAC address in the Ethernet header. If they are identical, the packet is forwarded; otherwise, the 
packet is discarded. 

 dst-mac: Checks the target MAC address of ARP replies. If the target MAC address is all-zero, 
all-one, or inconsistent with the destination MAC address in the Ethernet header, the packet is 
considered invalid and discarded. 

 ip: Checks both the source and destination IP addresses in an ARP packet. The all-zero, all-one or 
multicast IP addresses are considered invalid and the corresponding packets are discarded. With 
this object specified, the source and destination IP addresses of ARP replies, and the source IP 
address of ARP requests are checked. 

Configuring ARP Detection 

 

 

If both the ARP detection based on specified objects and the ARP detection based on static IP Source 
Guard binding entries/DHCP snooping entries/802.1X security entries/OUI MAC addresses are 
enabled, the former one applies first, and then the latter applies. 

 

Select Network > ARP Anti-Attack from the navigation tree to enter the default ARP Detection page 
shown in Figure 23-2. 

Figure 23-2 ARP Detection configuration page 

 
 

Table 23-1 describes the ARP Detection configuration items. 
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Table 23-1 ARP Detection configuration items 

Item Description 

VLAN Settings 

Select VLANs on which ARP detection is to be enabled. 
To add VLANs to the Enabled VLANs list box, select one or multiple VLANs from the 
Disabled VLANs list box and click the << button. 
To remove VLANs from the Enabled VLANs list box, select one or multiple VLANs from the 
list box and click the >> button. 

Trusted Ports 

Select trusted ports and untrusted ports. 
To add ports to the Trusted Ports list box, select one or multiple ports from the Untrusted 
Ports list box and click the << button. 
To remove ports from the Trusted Ports list box, select one or multiple ports from the list 
box and click the >> button. 

ARP Packet 
Validity Check 

Select ARP packet validity check modes, including: 
 Discard the ARP packet whose sender MAC address is different from the source MAC 

address in the Ethernet header 
 Discard the ARP packet whose target MAC address is all 0s, all 1s, or inconsistent with 

the destination MAC address in the Ethernet header 
 Discard the ARP request whose source IP address is all 0s, all 1s, or a multicast 

address, and discard the ARP reply whose source and destination IP addresses are all 
0s, all 1s, or multicast addresses 

If none of the above is selected, the system does not check the validity of ARP packets. 

 

Other ARP Attack Defense Functions 

Overview 

Source MAC address based ARP attack detection 
This feature allows the device to check the source MAC address of ARP packets. If the number of ARP 
packets received from a MAC address within five seconds exceeds the specified value, the device 
considers this an attack, thus generates an alarm, and blocks traffic from that source MAC address. 

Only the ARP packets delivered to the CPU are detected. 

ARP active acknowledgement 
Typically, the ARP active acknowledgement feature is configured on gateway devices to identify invalid 
ARP packets. With this feature enabled, the gateway, upon receiving an ARP packet with a sender MAC 
address different from that in the corresponding ARP entry, checks whether the ARP entry has been 
updated within the last minute: 

 If yes, the gateway does not update the ARP entry;  

 If not, the gateway unicasts an ARP request to the MAC address in the ARP entry. 

Then, 

 If an ARP reply is received within five seconds, the ARP packet is ignored;  

 If not, the gateway unicasts an ARP request to the sender MAC address of the ARP packet.  

Then, 

 If an ARP reply is received within five seconds, the gateway updates the ARP entry;  

 If not, the ARP entry is not updated. 
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ARP packet source MAC address consistency check 
This feature enables a gateway device to filter out ARP packets with the source MAC address in the 
Ethernet header different from the sender MAC address in the ARP message, so that the gateway 
device can learn correct ARP entries. 

Note that ARP detection also checks source MAC address consistency of ARP packets, but it is 
enabled on an access device to detect only ARP packets sent to it. 

Configuring Other ARP Attack Defense Functions 

Select Network > ARP Anti-Attack from the navigation tree, click the Advanced Configuration tab to 
enter the page shown in Figure 23-3. 

Figure 23-3 Advanced Configuration page 

 
 

Table 23-2 describes the configuration items of other ARP attack defense functions. 
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Table 23-2 Other ARP attack defense configuration items 

Item Description 

Detection Mode 

Select the detection mode for source MAC address based ARP attack 
detection. The detection mode can be: 

 Disable: The source MAC address attack detection is disabled. 
 Filter Mode: The device generates an alarm and filters out ARP packets 

sourced from a MAC address if the number of ARP packets received 
from the MAC address within five seconds exceeds the specified value.

 The device only generates an alarm if the number of ARP packets sent 
from a MAC address within five seconds exceeds the specified value. 

Aging Time Type the aging time of the source MAC address based ARP attack detection 
entries. 

Threshold Type the threshold of source MAC address based ARP attack detection. 

Source 
MAC 
Address 
Attack 
Detection 

Protected MAC 
Configuration 

Type a protected MAC address. 
A protected MAC address is excluded from ARP attack detection even if it is 
an attacker. You can specify certain MAC addresses, such as that of a 
gateway or an important server, as a protected MAC address. 
Expand Protected MAC Configuration and contents are displayed as 
shown in Figure 23-4. To add a protected MAC address, type a MAC 
address and click Add. 

Enable ARP Packet Active 
Acknowledgement Enable or disable ARP packet active acknowledgement. 

Enable Source MAC Address 
Consistency Check Enable or disable source MAC address consistency check. 

 

Figure 23-4 Protected MAC configuration 
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24  IGMP Snooping Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Internet Group Management Protocol Snooping (IGMP snooping) is a multicast constraining 
mechanism that runs on Layer 2 devices to manage and control multicast groups. 

Principle of IGMP Snooping 

By analyzing received IGMP messages, a Layer 2 device running IGMP snooping establishes 
mappings between ports and multicast MAC addresses and forwards multicast data based on these 
mappings.  

As shown in Figure 24-1, when IGMP snooping is not running on the switch, multicast packets are 
flooded to all devices at Layer 2. However, when IGMP snooping is running on the switch, multicast 
packets for known multicast groups are multicast to the receivers, rather than broadcast to all hosts, at 
Layer 2.  
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Figure 24-1 Multicast forwarding before and after IGMP snooping runs 
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IGMP Snooping Related Ports 

As shown in Figure 24-2, Router A connects to the multicast source, IGMP snooping runs on Switch A 
and Switch B, Host A and Host C are receiver hosts (namely, multicast group members). 

Figure 24-2 IGMP snooping related ports 
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IGMP snooping related ports include: 

 Router port: A router port is a port on an Ethernet switch that leads the switch towards the Layer 3 
multicast device (DR or IGMP querier). In the figure, Ethernet 1/1 of Switch A and Ethernet 1/1 of 
Switch B are router ports. A switch registers all its local router ports in its router port list.  

Member port: On an Ethernet switch, a member port (also known as multicast group member port) 
connects the switch to a multicast group member. In the figure, Ethernet 1/2 and Ethernet 1/3 of Switch 
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A and Ethernet 1/2 of Switch B are member ports. A switch registers all its member ports in the IGMP 
snooping forwarding table.  

 

 

 Whenever mentioned in this document, a router port is a port on the switch that leads the switch to 
a Layer 3 multicast device, rather than a port on a router.  

 Unless otherwise specified, router ports and member ports mentioned in this document consist of 
dynamic and static ports. 

 An IGMP-snooping-enabled switch deems that all its ports on which IGMP general queries with the 
source address other than 0.0.0.0 or PIM hello messages are received to be router ports.  

 

Work Mechanism of IGMP Snooping 

A switch running IGMP snooping performs different actions when it receives different IGMP messages, 
as follows: 

 

 

You can add or delete only dynamic ports rather than static ports.  

 

When receiving a general query 
The IGMP querier periodically sends IGMP general queries to all hosts and routers (224.0.0.1) on the 
local subnet to find out whether any active multicast group members exist on the subnet.  

Upon receiving an IGMP general query, the switch forwards it through all ports in the VLAN except the 
receiving port and performs the following to the receiving port: 

 The switch resets the aging timer for the receiving port if the port is in the router port list; 

 The switch adds the receiving port to the router port list if it is not in the list and starts the aging 
timer for the port. 

When receiving a membership report 
A host sends an IGMP membership report to the IGMP querier in the following circumstances: 

 Upon receiving an IGMP query, a multicast group member host responds with an IGMP report; 

 When intended to join a multicast group, a host sends an IGMP report to the querier to announce 
its interest in the multicast information addressed to that group. 

Upon receiving an IGMP report, the switch forwards it through all the router ports in the VLAN, resolves 
the address of the reported multicast group, and performs the following: 

 If no forwarding table entry exists for the reported group, the switch creates an entry, adds the port 
as a member port to the outgoing port list, and starts a member port aging timer for that port. 
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 If a forwarding table entry exists for the reported group, but the port is not included in the outgoing 
port list, the switch adds the port as a member port to the outgoing port list, and starts a member 
port aging timer for that port. 

If a forwarding table entry exists for the reported group and the port is not included in the outgoing port 
list, the switch resets the member port aging timer for that port. 

 

 

A switch does not forward an IGMP report through a non-router port. This is because if the switch 
forwards a report message through a member port, all the attached hosts listening to the reported 
multicast address will suppress their own reports upon hearing this report according to the IGMP report 
suppression mechanism on them, and this will prevent the switch from knowing whether any hosts 
attached to that port are still active members of the reported multicast group. 

 

When receiving a leave group message 
When an IGMPv1 host leaves a multicast group, the host does not send an IGMP leave message, so 
the switch cannot know immediately that the host has left the multicast group. However, as the host 
stops sending IGMP membership reports as soon as it leaves a multicast group, the switch deletes the 
forwarding entry for the member port corresponding to the host from the forwarding table when its aging 
timer expires.  

When an IGMPv2 or IGMPv3 host leaves a multicast group, the host sends an IGMP leave message to 
the multicast router to announce that it has left the multicast group. When the switch receives a 
group-specific IGMP leave group message on a member port, it first checks whether a forwarding table 
entry for that group exists, and, if one exists, whether its outgoing port list contains that port.  

 If the forwarding table entry does not exist or if its outgoing port list does not contain the port, the 
switch discards the IGMP leave group message instead of forwarding it to any port. 

 If the forwarding table entry exists and its outgoing port list contains the port, the switch forwards 
the IGMP leave group message to the router ports in the VLAN. Because the switch does not know 
whether any other member hosts for that group still exist under the port to which the leave message 
arrived, the switch does not immediately remove the port from the outgoing port list; instead, the 
switch resets the member port aging timer for that port.   

Upon receiving the IGMP leave group message from a host, the IGMP querier resolves from the 
message the address of the multicast group that the host just left and sends an IGMP group-specific 
query to that multicast group through the port that received the leave group message. Upon hearing the 
IGMP group-specific query, the switch forwards it through all its router ports in the VLAN and all member 
ports for that multicast group, and performs the following to the port (in case it is a dynamic member port) 
before the member port aging timer of the port expires:  

 If any IGMP report in response to the group-specific query is heard on a member port before its 
aging timer expires, this means that some host attached to the port is receiving or expecting to 
receive multicast data for that multicast group. The switch resets the aging timer of the member 
port.  
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 If no IGMP report in response to the group-specific query is heard on a member port before its 
aging timer expires, this means that no hosts attached to the port are still listening to that group 
address. The switch removes the port from the outgoing port list of the forwarding table entry for 
that multicast group when the aging timer expires.  

Processing of Multicast Protocol Messages 

With Layer 3 multicast routing enabled, an IGMP snooping switch processes multicast protocol 
messages differently under different conditions, specifically as follows: 

1) If only IGMP is enabled, or both IGMP and PIM are enabled on the switch, the switch handles 
multicast protocol messages in the normal way.  

2) If only PIM is enabled on the switch: 

 The switch broadcasts IGMP messages as unknown messages in the VLAN. 

 Upon receiving a PIM hello message, the switch will maintain the corresponding router port. 

3) When IGMP is disabled on the switch: 

 If PIM is disabled, the switch clears all dynamic member ports and dynamic router ports. 

 If PIM is disabled, the switch clears all dynamic member ports but still maintains dynamic router 
ports. 

4) When PIM is disabled on the switch: 

 If IGMP is disabled, the switch clears all its dynamic router ports. 

 If IGMP is enabled, the switch keeps maintaining all dynamic member ports and dynamic router 
ports. 

Protocols and Standards 

IGMP snooping is documented in: 

 RFC 4541: Considerations for Internet Group Management Protocol (IGMP) and Multicast Listener 
Discovery (MLD) Snooping Switches 

Configuring IGMP Snooping 

Configuration Task List 

Perform the tasks in Table 24-1 to configure IGMP snooping.  
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Table 24-1 IGMP snooping configuration task list 

Task Remarks 

Enabling IGMP Snooping 
Globally 

Required 
Disabled by default. 

Configuring IGMP Snooping 
in a VLAN 

Required 
Enable IGMP snooping in the VLAN and configure the IGMP snooping version 
and querier feature. 
By default, IGMP snooping is disabled in a VLAN. 

 
 IGMP snooping must be enabled globally before it can be enabled in a 

VLAN. 
 After enabling IGMP snooping in a VLAN, you cannot enable IGMP or PIM 

on the corresponding VLAN interface, and vice versa. 
 When you enable IGMP snooping in a VLAN, this function takes effect for 

ports in this VLAN only. 

Configuring IGMP Snooping 
Port Functions 

Optional 
Configure the maximum number of multicast groups allowed and the fast leave 
function for ports in the specified VLAN. 

 
 Multicast routing or IGMP snooping must be enabled globally before IGMP 

snooping can be enabled on a port. 
 IGMP snooping configured on a port takes effect only after IGMP snooping 

is enabled in the VLAN or IGMP is enabled on the VLAN interface.  

Display IGMP Snooping 
Multicast Entry Information Optional 

 

Enabling IGMP Snooping Globally 

Select Network > IGMP Snooping in the navigation tree to enter the basic configuration page shown in 
Figure 24-3. 

Figure 24-3 Basic IGMP snooping configurations 
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Table 24-2 describes the IGMP snooping configuration items.  

Table 24-2 IGMP snooping configuration items 

Item Description 

IGMP Snooping Globally enable or disable IGMP snooping.  

 

Return to IGMP snooping configuration task list.  

Configuring IGMP Snooping in a VLAN 

Select Network > IGMP Snooping in the navigation tree to enter the basic configuration page shown in 
Figure 24-3. Click the  icon corresponding to the VLAN to enter the page you can configure IGMP 
snooping in the VLAN, as shown in Figure 24-4.  

Figure 24-4 Configure IGMP snooping in the VLAN 

 

 

Table 24-3 describes the items for configuring IGMP snooping in a VLAN.  

Table 24-3 Items for configuring IGMP snooping in a VLAN 

Item Description 

VLAN ID This field displays the ID of the VLAN to be configured. 

IGMP Snooping 
Enable or disable IGMP snooping in the VLAN.  
You can proceed with the subsequent configurations only if Enable is selected here.  

Version 

By configuring an IGMP snooping version, you actually configure the versions of IGMP 
messages that IGMP snooping can process.  

 IGMP snooping version 2 can process IGMPv1 and IGMPv2 messages, but not 
IGMPv3 messages, which will be flooded in the VLAN. 

 IGMP snooping version 3 can process IGMPv1, IGMPv2, and IGMPv3 messages. 

Drop Unknown 

Enable or disable the function of dropping unknown multicast packets. 
Unknown multicast data refer to multicast data for which no entries exist in the IGMP 
snooping forwarding table.  

 With the function of dropping unknown multicast data enabled, the switch drops all the 
unknown multicast data received.  

 With the function of dropping unknown multicast data disabled, the switch floods 
unknown multicast data in the VLAN to which the unknown multicast data belong. 
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Item Description 

Querier 

Enable or disable the IGMP snooping querier function.  
On a network without Layer 3 multicast devices, no IGMP querier-related function can be 
implemented because a Layer 2 device does not support IGMP. To address this issue, 
you can enable IGMP snooping querier on a Layer 2 device so that the device can 
generate and maintain multicast forwarding entries at data link layer, thereby 
implementing IGMP querier-related functions. 

Query interval Configure the IGMP query interval.  

 

Return to IGMP snooping configuration task list.  

Configuring IGMP Snooping Port Functions 

Select Network > IGMP Snooping in the navigation tree to enter the basic configuration page and then 
click the Advance tab to enter the page shown in Figure 24-5.  

Figure 24-5 Advanced configuration 

 

 

Table 24-4 describes items for configuring advanced IGMP snooping features.  

Table 24-4 Configuration items for advanced IGMP snooping features 

Item Description 

Port 
Select the port on which advanced IGMP snooping features are to be configured. 
After a port is selected, advanced features configured on this port are displayed at 
the lower part of this page.  

VLAN ID Specify a VLAN in which you can configure the fast leave function for the port or the 
maximum number of multicast groups allowed on the port.  

Multicast Group Limit 

Configure the maximum number of multicast groups that the port can join.  
With this feature, you can regulate multicast traffic on the port. 

 
When the number of multicast groups a port has joined reaches the configured 
threshold, the system deletes all the forwarding entries persistent on that port from 
the IGMP snooping forwarding table, and the hosts on this port need to join the 
multicast groups again. 
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Item Description 

Fast Leave 

Enable or disable the fast leave function for the port.  
With the fast leave function enabled on a port, the switch, when receiving an IGMP 
leave message on the port, immediately deletes that port from the outgoing port list 
of the corresponding forwarding table entry. Then, when receiving IGMP 
group-specific queries for that multicast group, the switch will not forward them to 
that port. In VLANs where only one host is attached to each port, the fast leave 
function helps improve bandwidth and resource usage. 

 
If fast leave is enabled for a port to which more than one host is attached, when one 
host leaves a multicast group, the other hosts listening to the same multicast group 
will fail to receive multicast data. 

 

Return to IGMP snooping configuration task list.  

Display IGMP Snooping Multicast Entry Information 

Select Network > IGMP Snooping in the navigation tree to enter the basic configuration page shown in 
Figure 24-3. Click the plus sign (+) in front of Show Entries to display information about IGMP snooping 
multicast entries, as shown in Figure 24-6. You can view the detailed information of an entry by click the 

 icon corresponding to the entry, as shown in Figure 24-7.  

Figure 24-6 Display entry information 

 

 

Figure 24-7 IGMP snooping multicast entry details page 

 

 

Table 24-5 describes the IGMP snooping multicast entry information.  
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Table 24-5 Description of IGMP snooping multicast entries 

Item Description 

VLAN ID ID of the VLAN to which the entry belongs 

Source Multicast source address, where 0.0.0.0 indicates all multicast sources.  

Group Multicast group address 

Router Port(s) All router ports 

Member Port(s) All member ports 

 

Return to IGMP snooping configuration task list. 

IGMP Snooping Configuration Examples 

Network requirements 
 As shown in Figure 24-8, Router A connects to a multicast source (Source) through Ethernet 1/2, 

and to AC through Ethernet 1/1. 

 The multicast source multicasts data to group 224.1.1.1. Host A is a receiver of the multicast group.  

 IGMPv2 runs on Router A and IGMP snooping version 2 runs on AC.  

 The function of dropping unknown multicast packets is enabled on AC to prevent AC from flooding 
multicast packets in the VLAN if no corresponding Layer 2 forwarding entry exists.  

 The fast leave function is enabled for GigabitEthernet 1/0/2 on AC to save bandwidth and 
resources  

Figure 24-8 Network diagram for IGMP snooping configuration 

 

 

Configuration procedure 
1) Configure IP addresses 

Configure an IP address for each interface, as shown in Figure 24-8. The configuration procedure is 
omitted.  

2) Configure Router A 

Enable IP multicast routing, enable PIM-DM on each interface, and enable IGMP on Ethernet 1/1. The 
configuration procedure is omitted.  

3) Configure AC 

# Create VLAN 100 and add GigabitEthernet 1/0/1 and GigabitEthernet 1/0/2 to VLAN 100. 

 Select Network > VLAN in the navigation tree to enter the VLAN configuration page, as shown in 
Figure 24-9. Click Add to enter the page for creating a VLAN, as shown in Figure 24-10.  
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Figure 24-9 VLAN 

 
 

Figure 24-10 Create VLAN 100 

 

 

 Type 100 for VLAN ID. 

 Click Apply to complete the operation. 

 Click  corresponding to VLAN 100 to enter the page for modifying VLAN, as shown in Figure 
24-11. 
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Figure 24-11 Add a port to the VLAN 

 

 

 Click on the radio buttons next to GigabitEthernet 1/0/1 and GigabitEthernet 1/0/2 in the Untagged 
Member column. 

 Click Apply to complete the operation. 

# Enable IGMP snooping globally. 

 Select Network > IGMP Snooping from the navigation tree to enter the Basic configuration page 
and perform the following, as shown in Figure 24-12.  

Figure 24-12 Enable IGMP snooping globally 

 

 

 Select Enable and click Apply to globally enable IGMP snooping.  

# In VLAN 100, enable IGMP snooping and the dropping unknown multicast data function. 

 Click  corresponding to VLAN 100 to enter its configuration page and perform the following 
configuration, as shown in Figure 24-13. 
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Figure 24-13 Configure the VLAN 

 
 

 Click on the Enable radio button in the IGMP Snooping field.  

 Click on the Enable radio button in the Drop Unknown field. 

 Click Apply to complete the operation. 

# Enable the fast leave function for GigabitEthernet 1/0/2.  

 Click the Advance tab and perform the following configuration, as shown in Figure 24-14.  

Figure 24-14 Advanced configuration 

 
 

 Select GigabitEthernet 1/0/2 from the Port drop-down list. 

 Type 100 for VLAN ID. 

 Click on the Enable radio button in the Fast Leave field.  

 Click Apply to complete the operation. 
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Verification 
# Display the IGMP snooping multicast entry information on AC.  

 Click the Basic tab and the plus sign (+) in front of Show Entries to display IGMP snooping 
multicast entries, as shown in Figure 24-15.  

Figure 24-15 Output configuration of IGMP snooping multicast entry summary 

 
 

 Click  corresponding to the multicast entry to view details about this entry, as shown in Figure 
24-16.  

Figure 24-16  Output configuration of IGMP snooping multicast entry details 

 
 

As shown above, GigabitEthernet 1/0/2 of AC is added to multicast group 224.1.1.1. 
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25  IPv4 and IPv6 Routing Configuration 

 

 

 Support for IPv6 routing depends on your device model. For more information, see "Feature 
Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 The term “router” in this document refers to a router in a generic sense or WX series access 
controller running routing protocols. 

 

Overview 

Routers are responsible for routing packets on the Internet. A router selects an appropriate route 
according to the destination address of a received packet and forwards the packet to the next router. 
The last router on the path is responsible for sending the packet to the destination host. 

Routing Table 

Routers forward packets through a routing table. Each entry in the table specifies which physical 
interface a packet should go out to reach the next hop (the next router) or the directly connected 
destination. 

Routes in a routing table fall into three categories by origin: 

 Direct routes: Routes discovered by data link protocols, also known as interface routes. 

 Static routes: Routes that are manually configured. 

 Dynamic routes: Routes that are discovered dynamically by routing protocols. 

A route entry has the following items: 

 Destination IP address: Destination IP address or destination network. 

 Mask (IPv4)/prefix length (IPv6): Specifies, together with the destination address, the address of 
the destination network.  

 Outbound interface: Specifies the interface through which a matching IP packet is to be forwarded. 

 Next hop: Specifies the address of the next hop router on the path. 



 

25-2 

 Preference for the route: Routes to the same destination may be found by various routing protocols 
or manually configured, and routing protocols and static routes have different priorities configured. 
The route with the highest priority (the smallest value) will be selected as the optimal route. 

Static Route 

A static route is manually configured. If a network’s topology is simple, you only need to configure static 
routes for the network to work normally. The proper configuration and usage of static routes can 
improve network performance and ensure bandwidth for important network applications.  

The disadvantage of using static routes is that they cannot adapt to network topology changes. If a fault 
or a topological change occurs in the network, some routes will be unreachable. In this case, the 
network administrator has to modify the static routes manually.  

While configuring a static route, you can specify either the output interface or the next hop address as 
needed. The next hop address cannot be a local interface’s IP address; otherwise, the route 
configuration will not take effect. 

Actually, it is necessary to identify next hop addresses for all route entries because the router needs to 
use the next hop address of a matching entry to resolve the corresponding link layer address. 

Default Route 

A router selects the default route when it cannot find any matching entry in the routing table for a packet. 
If there is no default route, the packet will be discarded and an ICMP packet will be sent to the source to 
report that the destination is unreachable. 

You can configure the default route, and some dynamic routing protocols can also generate the default 
route. 

 An IPv4 static default route has both its destination IP address and mask configured as 0.0.0.0.  

 An IPv6 static default route has its destination IP address and prefix configured as ::/0.  

Configuring IPv4 Routing 

Displaying the IPv4 Active Route Table 

Select Network > IPv4 Routing from the navigation tree to enter the page shown in Figure 25-1. 

Figure 25-1 IPv4 active route table 

 
 

Table 25-1 describes the fields of the IPv4 active route table: 
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Table 25-1 Description of the fields of the IPv4 active route table 

Field Description 

Destination IP Address 

Mask 
Destination IP address and subnet mask of the IPv4 route 

Protocol Protocol that discovered the IPv4 route 

Preference 
Preference value for the IPv4 route 
The smaller the number, the higher the preference. 

Next Hop Next hop IP address of the IPv4 route 

Interface Outgoing interface of the IPv4 route. Packets destined for the specified 
network segment will be sent out the interface.  

 

Creating an IPv4 Static Route 

Select Network > IPv4 Routing from the navigation tree and click the Create tab to enter the IPv4 
static route configuration page, as shown in Figure 25-2.  

Figure 25-2 Create an IPv4 static route 

 
 

Table 25-2 describes the IPv4 static route configuration items:  

Table 25-2 IPv4 static route configuration items 

Item Description 

Destination IP Address Type the destination host or network IP address, in dotted decimal notation.  

Mask 
Type the mask of the destination IP address.  
Select a mask length (number of consecutive 1s in the mask) or a mask in dotted 
decimal notation from the drop-down list.  

Preference 

Set a preference value for the static route. The smaller the number, the higher the 
preference. 
For example, specifying the same preference for multiple static routes to the same 
destination enables load sharing on the routes, while specifying different 
preferences enables route backup.  

Next Hop Type the next hop IP address, in dotted decimal notation. 
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Item Description 

Interface 
Select the outgoing interface.  
You can select any available interface, for example, a virtual interface, of the 
device. If you select NULL 0, the destination IP address is unreachable.  

 

Configuring IPv6 Routing 

Displaying the IPv6 Active Route Table 

Select Network > IPv6 Routing from the navigation tree to enter the page shown in Figure 25-3. 

Figure 25-3 IPv6 active route table 

 

 

Table 25-3 describes the fields of the IPv6 active route table: 

Table 25-3 Description of the fields of the IPv6 active route table 

Field Description 

Destination IP Address 

Prefix Length 
Destination IP address and prefix length of the IPv6 route 

Protocol Protocol that discovered the IPv6 route 

Preference 
Preference value for the IPv6 route 
The smaller the number, the higher the preference. 

Next Hop Next hop IP address of the IPv6 route 

Interface Outgoing interface of the IPv6 route. Packets destined for the specified 
network segment will be sent out the interface.  

 

Creating an IPv6 Static Route 

Select Network > IPv6 Routing from the navigation tree and click the Create tab to enter the IPv6 
static route configuration page, as shown in Figure 25-4.  
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Figure 25-4 Create an IPv6 static route 

 
 

Table 25-4 describes the IPv6 static route configuration items: 

Table 25-4 IPv6 static route configuration items 

Item Description 

Destination IP Address 
Type the destination host or network IP address, in the X:X::X:X format. The 
128-bit destination IPv6 address is a hexadecimal address with eight parts 
separated by colons (:). Each part is represented by a 4-digit hexadecimal integer. 

Prefix Length  Type the prefix length of the destination IPv6 address.  

Preference 

Set a preference value for the static route. The smaller the number, the higher the 
preference. 
For example, specifying the same preference for multiple static routes to the same 
destination enables load sharing on the routes, while specifying different priorities 
for them enables route backup.  

Next Hop Type the next hop address, in the same format as the destination IP address.  

Interface 
Select the outgoing interface.  
You can select any available interface, for example, a virtual interface, of the 
device. If you select NULL 0, the destination IPv6 address is unreachable.  

 

Static Route Configuration Examples 

IPv4 Static Route Configuration Example 

Network requirements 
The IP addresses of devices are shown in Figure 25-5. IPv4 static routes need to be configured on 
Switch A, Switch B and AC for Host A and Host B to communicate with each other.  
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Figure 25-5 Network diagram for IPv4 static route configuration 

 
 

Configuration outlines 
1) On Switch A, configure a default route with Switch B as the next hop.  

2) On Switch B, configure one static route with Switch A as the next hop and the other with AC as the 
next hop.  

3) On AC, configure a default route with Switch B as the next hop.  

Configuration procedure 
1) Configure the IP addresses of the interfaces (omitted) 

2) Configure IPv4 static routes 

# Configure a default route with the next hop address 1.1.4.2 on Switch A (omitted). 

# Configure two static routes on Switch B: one with destination address 1.1.2.0/24 and next hop 
address 1.1.4.1, and the other with destination address 1.1.3.0/24 and next hop address 1.1.5.6 
(omitted).  

# Configure a default route on AC.  

 After you log in to the Web interface of AC, select Network > IPv4 Routing from the navigation 
tree and then click the Create tab to enter the IPv4 static route configuration page, as shown in 
Figure 25-6.  

Figure 25-6 Configure a default route 

 

 

 Type 0.0.0.0 for Destination IP Address.  

 Select 0 (0.0.0.0) from the Mask drop-down list.  

 Type 1.1.5.5 for Next Hop.  

 Click Apply.  
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Verify the configuration 
# Display the route table.  

Enter the IPv4 route page of Switch A, Switch B, and AC respectively to verify that the newly configured 
static routes are displayed as active routes on the page.  

# Use the ping command for verification. 

Ping Host B from Host A (assuming both hosts run Windows XP).  
C:\Documents and Settings\Administrator>ping 1.1.3.2 

 

Pinging 1.1.3.2 with 32 bytes of data: 

 

Reply from 1.1.3.2: bytes=32 time=1ms TTL=128 

Reply from 1.1.3.2: bytes=32 time=1ms TTL=128 

Reply from 1.1.3.2: bytes=32 time=1ms TTL=128 

Reply from 1.1.3.2: bytes=32 time=1ms TTL=128 

 

Ping statistics for 1.1.3.2: 

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), 

Approximate round trip times in milli-seconds: 

    Minimum = 1ms, Maximum = 1ms, Average = 1ms 

IPv6 Static Route Configuration Example 

Network requirements 
The IP addresses of devices are shown in Figure 25-7. IPv6 static routes need to be configured on 
Switch A, Switch B and AC for Host A and Host B to communicate with each other. 

Figure 25-7 Network diagram for IPv6 static route configuration 

 

 

Configuration outlines 
1) On Switch A, configure a default route with Switch B as the next hop.  

2) On Switch B, configure one static route with Switch A as the next hop and the other with AC as the 
next hop.  

3) On AC, configure a default route with Switch B as the next hop.  

Configuration procedure 
1) Configure IPv6 addresses for interfaces (omitted) 

2) Configure IPv6 static routes on the switches. 

# Configure a default route with the next hop address 4::2 on Switch A (omitted). 

# Configure two static routes on Switch B: one with destination address 1::/64 and next hop address 
4::1, and the other with destination address 3::/64 and next hop address 5::1 (omitted).  
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# Configure a default route on AC.  

 After you log in to the Web interface of AC, select Network > IPv6 Routing from the navigation 
tree and then click the Create tab to enter the IPv6 static route configuration page, as shown in 
Figure 25-8.  

Figure 25-8 Configure a default route 

 
 

 Type :: for Destination IP Address.  

 Select 0 from the Prefix Length drop-down list.  

 Type 5::2 for Next Hop.  

 Click Apply.  

Verify the configuration 
# Display the route table.  

Enter the IPv6 route page of Switch A, Switch B, and AC respectively to verify that the newly configured 
static routes are displayed as active routes on the page.  

# Use the ping command for verification. 

Ping Host B from Switch A.  
<SwitchA> system-view 

[SwitchA] ping ipv6 3::2 

  PING 3::2 : 56  data bytes, press CTRL_C to break 

    Reply from 3::2 

    bytes=56 Sequence=1 hop limit=254  time = 63 ms 

    Reply from 3::2 

    bytes=56 Sequence=2 hop limit=254  time = 62 ms 

    Reply from 3::2 

    bytes=56 Sequence=3 hop limit=254  time = 62 ms 

    Reply from 3::2 

    bytes=56 Sequence=4 hop limit=254  time = 63 ms 

    Reply from 3::2 

    bytes=56 Sequence=5 hop limit=254  time = 63 ms 

 

  --- 3::2 ping statistics --- 

    5 packet(s) transmitted 

    5 packet(s) received 

    0.00% packet loss 

    round-trip min/avg/max = 62/62/63 ms 
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Precautions 

When configuring a static route, note the following:  

1) If you do not specify the preference when configuring a static route, the default preference will be 
used. Reconfiguration of the default preference applies only to newly created static routes. 
Currently, the Web interface does not support configuration of the default preference.  

2) When configuring a static route, the static route does not take effect if you specify the next hop 
address first and then configure it as the IP address of a local interface, such as an Ethernet 
interface and VLAN interface.  

3) When specifying the output interface, note that: 

 If NULL 0 or a loopback interface is specified as the output interface, there is no need to configure 
the next hop address. 

 If a point-to-point interface is specified as the output interface, you don’t need to specify the next 
hop, and there is no need to change the configuration after the peer address has changed. For 
example, a PPP interface obtains the peer’s IP address through PPP negotiation, and therefore 
you only need to specify it as the output interface.  

 If the output interface is an NBMA or P2MP interface, which supports point-to-multipoint networks, 
the IP address-to-link layer address mapping must be established. Therefore, you are 
recommended to specify the next hop IP address when you configure it as the output interface.  

 If you want to specify a broadcast interface (such as an Ethernet interface, virtual template, or 
VLAN interface) as the output interface, which may have multiple next hops, you must specify the 
next hop at the same time.  
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26  DHCP Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

DHCP Overview 

 

 

After the DHCP client is enabled on an interface, the interface can dynamically obtain an IP address 
and other configuration parameters from the DHCP server. This facilitates configuration and centralized 
management. For details about the DHCP client configuration, refer to Interface Management 
Configuration in the Device Volume. 

 

Introduction to DHCP 

The fast expansion and growing complexity of networks result in scarce IP addresses assignable to 
hosts. Meanwhile, as many people need to take their laptops across networks, the IP addresses need to 
be changed accordingly. Therefore, related configurations on hosts become more complex. The 
Dynamic Host Configuration Protocol (DHCP) was introduced to solve these problems. 

DHCP is built on a client-server model, in which a client sends a configuration request and then the 
server returns a reply to send configuration parameters such as an IP address to the client. 

A typical DHCP application, as shown in Figure 26-1, includes a DHCP server and multiple clients (PCs 
and laptops). 
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Figure 26-1 A typical DHCP application 

 
 

A DHCP client can get an IP address and other configuration parameters from a DHCP server on 
another subnet via a DHCP relay agent. For details about the DHCP relay agent configuration, refer to 
DHCP Relay Agent Configuration. 

DHCP Address Allocation 

Allocation mechanisms 
DHCP supports three mechanisms for IP address allocation. 

 Manual allocation: The network administrator assigns an IP address to a client like a WWW server, 
and DHCP conveys the assigned address to the client. 

 Automatic allocation: DHCP assigns a permanent IP address to a client. 

 Dynamic allocation: DHCP assigns an IP address to a client for a limited period of time, which is 
called a lease. Most DHCP clients obtain their addresses in this way. 

Dynamic IP address allocation process 

Figure 26-2 Dynamic IP address allocation process 

 

 

As shown in Figure 26-2, a DHCP client obtains an IP address from a DHCP server via four steps: 

1) The client broadcasts a DHCP-DISCOVER message to locate a DHCP server. 

2) A DHCP server offers configuration parameters such as an IP address to the client in a 
DHCP-OFFER message. The sending mode of the DHCP-OFFER is determined by the flag field in 
the DHCP-DISCOVER message. 
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3) If several DHCP servers send offers to the client, the client accepts the first received offer, and 
broadcasts it in a DHCP-REQUEST message to request the IP address formally. 

4) All DHCP servers receive the DHCP-REQUEST message, but only the server from which the client 
accepts the offered IP address returns a DHCP-ACK message to the client, confirming that the IP 
address has been allocated to the client, or a DHCP-NAK unicast message, denying the IP 
address allocation. 

 

 

 After the client receives the DHCP-ACK message, it will probe whether the IP address assigned by 
the server is in use by broadcasting a gratuitous ARP packet. If the client receives no response 
within the specified time, the client can use this IP address. Otherwise, the client sends a 
DHCP-DECLINE message to the server and requests an IP address again. 

 IP addresses offered by other DHCP servers are still assignable to other clients. 

 

IP address lease extension 
The IP address dynamically allocated by a DHCP server to a client has a lease. When the lease expires, 
the DHCP server will reclaim the IP address. If the client wants to use the IP address longer, it has to 
extend the lease duration. 

When the half lease duration elapses, the DHCP client sends to the DHCP server a DHCP-REQUEST 
unicast to extend the lease duration. Upon availability of the IP address, the DHCP server returns a 
DHCP-ACK unicast confirming that the client’s lease duration has been extended, or a DHCP-NAK 
unicast denying the request. 

If the client receives no reply, it will broadcast another DHCP-REQUEST message for lease extension 
after 7/8 lease duration elapses. The DHCP server will handle the request as above mentioned. 

DHCP Message Format 

Figure 26-3 gives the DHCP message format, which is based on the BOOTP message format and 
involves eight types. These types of messages have the same format except that some fields have 
different values. The numbers in parentheses indicate the size of each field in bytes. 
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Figure 26-3 DHCP message format 

 
op (1)

0 7 15

htype (1) hlen (1) hops (1)

xid (4)

23 31

secs (2) flags (2)

ciaddr (4)

yiaddr (4)

siaddr (4)

giaddr (4)

chaddr (16)

sname (64)

file (128)

options (variable)
 

 

 op: Message type defined in option field. 1 = REQUEST, 2 = REPLY 

 htype, hlen: Hardware address type and length of a DHCP client. 

 hops: Number of relay agents a request message traveled. 

 xid: Transaction ID, a random number chosen by the client to identify an IP address allocation. 

 secs: Filled in by the client, the number of seconds elapsed since the client began address 
acquisition or renewal process. Currently this field is reserved and set to 0. 

 flags: The leftmost bit is defined as the BROADCAST (B) flag. If this flag is set to 0, the DHCP 
server sent a reply back by unicast; if this flag is set to 1, the DHCP server sent a reply back by 
broadcast. The remaining bits of the flags field are reserved for future use. 

 ciaddr: Client IP address. 

 yiaddr: 'your' (client) IP address, assigned by the server. 

 siaddr: Server IP address, from which the clients obtained configuration parameters. 

 giaddr: IP address of the first relay agent a request message traveled. 

 chaddr: Client hardware address. 

 sname: Server host name, from which the client obtained configuration parameters. 

 file: Bootfile name and path information, defined by the server to the client. 

 options: Optional parameters field that is variable in length, which includes the message type, 
lease, domain name server IP address, and WINS IP address. 

DHCP Options 

Overview 
The DHCP message adopts the same format as the Bootstrap Protocol (BOOTP) message for 
compatibility, but differs from it in the option field, which identifies new features for DHCP. 

DHCP uses the option field in DHCP messages to carry control information and network configuration 
parameters, implementing dynamic address allocation and providing more network configuration 
information for clients. 

Figure 26-4 shows the DHCP option format. 
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Figure 26-4 DHCP option format 

Option type Option length
0 7 15

Value (variable)

 

 

Introduction to DHCP options 
The common DHCP options are as follows: 

 Option 6: DNS server option. It specifies the DNS server IP address to be assigned to the client. 

 Option 51: IP address lease option. 

 Option 53: DHCP message type option. It identifies the type of the DHCP message. 

 Option 55: Parameter request list option. It is used by a DHCP client to request specified 
configuration parameters. The option contains values that correspond to the parameters requested 
by the client. 

 Option 66: TFTP server name option. It specifies a TFTP server to be assigned to the client. 

 Option 67: Bootfile name option. It specifies the bootfile name to be assigned to the client.  

 Option 150: TFTP server IP address option. It specifies the TFTP server IP address to be assigned 
to the client. 

 Option 121: Classless route option. It specifies a list of classless static routes (the destination 
addresses in these static routes are classless) that the requesting client should add to its routing 
table. 

 Option 33: Static route option. It specifies a list of classful static routes (the destination addresses 
in these static routes are classful) that a client should add to its routing table. If Option 121 exists, 
Option 33 is ignored. 

For more information about DHCP options, refer to RFC 2132. 

Introduction to Option 82 
Some options, such as Option 82, have no unified definitions in RFC 2132. 

Option 82 is the relay agent option in the option field of the DHCP message. It records the location 
information of the DHCP client. When a DHCP relay agent or DHCP snooping device receives a client’s 
request, it adds Option 82 to the request message before forwarding the message to the server. 

The administrator can locate the DHCP client to further implement security control and accounting. The 
Option 82 supporting server can also use such information to define individual assignment policies of IP 
address and other parameters for the clients. 

Option 82 involves at most 255 sub-options. At least one sub-option is defined. Currently the DHCP 
relay agent supports two sub-options: sub-option 1 (Circuit ID) and sub-option 2 (Remote ID). 

Option 82 has no unified definition. Its padding formats vary with vendors. 

By default, the normal padding format is used on the device. You can specify the code type for the 
sub-options as ASCII or HEX. The padding contents for sub-options in the normal padding format are as 
follows: 

 Sub-option 1: Padded with the VLAN ID and interface number of the interface that received the 
client’s request. The following figure gives its format. The value of the sub-option type is 1, and that 
of the circuit ID type is 0. 
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Figure 26-5 Sub-option 1 in normal padding format 

 

 

 Sub-option 2: Padded with the MAC address of the DHCP relay agent interface or the MAC 
address of the DHCP snooping device that received the client’s request. The following figure gives 
its format. The value of the sub-option type is 2, and that of the remote ID type is 0. 

Figure 26-6 Sub-option 2 in normal padding format 

 

 

Protocols and Standards 

 RFC 2131: Dynamic Host Configuration Protocol 

 RFC 2132: DHCP Options and BOOTP Vendor Extensions 

 RFC 1542: Clarifications and Extensions for the Bootstrap Protocol 

 RFC 3046: DHCP Relay Agent Information Option 

DHCP Server Configuration 

Application environment 

The DHCP server is well suited to the network where: 

 It is hard to implement manual configuration and centralized management. 

 The hosts are more than the assignable IP addresses and it is impossible to assign a fixed IP 
address to each host. For example, an ISP limits the number of hosts accessing the Internet at a 
time, so lots of hosts need to acquire IP addresses dynamically. 

 A few hosts need fixed IP addresses. 

DHCP Address Pool 

Address pool structure 
In response to a client’s request, the DHCP server selects an idle IP address from an address pool and 
sends it together with other parameters such as lease and DNS server address to the client. 

The address pool database is organized as a tree. The root of the tree is the address pool for natural 
networks, branches are address pools for subnets, and leaves are addresses statically bound to clients. 
For the same level address pools, a previously configured pool has a higher selection priority than a 
new one. 
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At the very beginning, subnetworks inherit network parameters and clients inherit subnetwork 
parameters. Therefore, common parameters, for example a DNS server address, should be configured 
at the highest (network or subnetwork) level of the tree. 

After establishment of the inheritance relationship, the new configuration at the higher level (father) of 
the tree will be: 

 Inherited if the lower level (child) has no such configuration, or 

 Overridden if the lower level (child) has such configuration. 

 

 

The IP address lease does not enjoy the inheritance attribute. 

 

Principles for selecting an address pool 
The DHCP server observes the following principles to select an address pool when assigning an IP 
address to a client: 

1) If there is an address pool where an IP address is statically bound to the MAC address or ID of the 
client, the DHCP server will select this address pool and assign the statically bound IP address to 
the client. 

2) Otherwise, the DHCP server will select the smallest address pool that contains the IP address of 
the receiving interface (if the client and the server reside on the same network segment), or the 
smallest address pool that contains the IP address specified in the giaddr field of the client’s 
request (if a DHCP relay agent is in-between). If no IP address is available in the address pool, the 
DHCP server will fail to assign an address to the client because it cannot assign an IP address from 
the father address pool to the client. 

For example, two address pools, 1.1.1.0/24 and 1.1.1.0/25, are configured on the DHCP server. If the IP 
address of the interface receiving DHCP requests is 1.1.1.1/25, the DHCP server will select IP 
addresses for clients from address pool 1.1.1.0/25. If no IP address is available in the address pool, the 
DHCP server will fail to assign addresses to clients. If the IP address of the interface receiving DHCP 
requests is 1.1.1.130/25, the DHCP server will select IP addresses for clients from the 1.1.1.0/24 
address pool. 

IP Address Allocation Sequence 

A DHCP server assigns an IP address to a client according to the following sequence: 

1) The IP address manually bound to the client’s MAC address or ID 

2) The IP address that was ever assigned to the client 

3) The IP address designated by the Option 50 field in the DHCP-DISCOVER message 

4) The first assignable IP address found in a proper DHCP address pool 

5) The IP address that was a conflict or passed its lease duration 

If no IP address is assignable, the server does not respond. 
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DHCP Server Configuration Task List 

Complete the following tasks to configure the DHCP server: 

Task Remarks 

Enabling DHCP 
Required 
Enable DHCP globally. 
By default, global DHCP is disabled. 

Creating a Static Address Pool 
for the DHCP Server 

Creating a Dynamic Address 
Pool for the DHCP Server 

Required to configure either of the two 

 
 If the DHCP server and DHCP clients are on the same subnet, make sure 

the address pool is on the same network segment as the interface with 
the DHCP server enabled; otherwise, the clients will fail to obtain IP 
addresses. 

 If a DHCP client obtains an IP address via a DHCP relay agent, an IP 
address pool on the same network segment as the DHCP relay agent 
interface must be configured; otherwise, the client will fail to obtain an IP 
address. 

Enabling the DHCP Server on 
an Interface 

Optional 
With the DHCP server enabled on an interface, upon receiving a client’s 
request, the DHCP server will assign an IP address from its address pool to 
the DHCP client. 
With DHCP enabled, interfaces work in the DHCP server mode. 

 
 An interface cannot serve as both the DHCP server and the DHCP relay 

agent. The latest configuration takes effect. 
 The DHCP server works on interfaces with IP addresses manually 

configured only. 

 

Enabling DHCP 

Select Network > DHCP from the navigation tree to enter the default DHCP Server page shown in 
Figure 26-7. Enable or disable DHCP on the upper part of the page. 
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Figure 26-7 DHCP configuration page 

 
 

 Click on the Enable radio button to enable DHCP globally. 

 Click on the Disable radio button to disable DHCP globally. 

Return to DHCP Server Configuration Task List. 

Creating a Static Address Pool for the DHCP Server 

Select Network > DHCP from the navigation tree to enter the default DHCP Server page shown in 
Figure 26-7. Click on the Static radio button in the Address Pool field to view all static address pools. 
Click Add to enter the page shown in Figure 26-8. 
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Figure 26-8 Create a static address pool 

 

 

Table 26-1 describes the static address pool configuration items. 

Table 26-1 Static address pool configuration items 

Item Description 

IP Pool Name Type the name of a static address pool. 

IP Address 

Mask 

Type an IP address and select a subnet mask for the static address pool. 
The IP address cannot be the IP address of any interface on the DHCP server. 
Otherwise, an IP address conflict may occur and the bound client cannot obtain an 
IP address correctly. 

Client MAC Address 

Client ID 

Configure the client MAC address or the client ID for the static address pool 

 
The client ID must be identical to the ID of the client to be bound. Otherwise, the 
client cannot obtain an IP address. 

Client Domain Name 
Type the domain name suffix for the client. 
With the suffix assigned, the client only needs to input part of a domain name, and 
the system will add the domain name suffix for name resolution. 

Gateway Address 

Type the gateway addresses for the client. 
A DHCP client that wants to access an external host needs to send requests to a 
gateway. You can specify gateways in each address pool and the DHCP server will 
assign gateway addresses while assigning an IP address to the client. 
Up to eight gateways can be specified in a DHCP address pool, separated by 
commas. 

DNS Server Address 

Type the DNS server addresses for the client. 
To allow the client to access a host on the Internet through DNS, you need to specify 
a DNS server address. 
Up to eight DNS servers can be specified in a DHCP address pool, separated by 
commas. 
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Item Description 

WINS Server Address 

Type the WINS server addresses for the client. 
If b-node is specified for the client, you do not need to specify any WINS server 
address. 
Up to eight WINS servers can be specified in a DHCP address pool, separated by 
commas. 

NetBIOS Node Type Select the NetBIOS node type for the client. 

 

Return to DHCP Server Configuration Task List. 

Creating a Dynamic Address Pool for the DHCP Server 

Select Network > DHCP from the navigation tree to enter the default DHCP Server page shown in 
Figure 26-7. Click on the Dynamic radio button in the Address Pool field to view all dynamic address 
pools. Click Add to enter the page shown in Figure 26-9. 

Figure 26-9 Create a dynamic address pool 

 
 

Table 26-2 describes dynamic address pool configuration items. 

Table 26-2 Dynamic address pool configuration items 

Item Description 

IP Pool Name Type the name of a dynamic address pool. 

IP Address 

Mask 

Type an IP address segment for dynamic allocation. 
To avoid address conflicts, the DHCP server excludes the IP addresses 
used by gateways or FTP servers from dynamic allocation. 
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Item Description 

Unlimited Lease 
Duration days/hours/minutes 

Configure the address lease duration for the address pool. 
Unlimited indicates the infinite duration. 

Client Domain Name 

Type the domain name suffix for the client. 
With the suffix assigned, the client only needs to input part of a domain 
name, and the system will add the domain name suffix for name 
resolution. 

Gateway Address 

Type the gateway addresses for the client. 
DHCP clients that want to access hosts outside the local subnet request 
gateways to forward data. You can specify gateways in each address pool 
for clients and the DHCP server will assign gateway addresses while 
assigning an IP address to the client. 
Up to eight gateways can be specified in a DHCP address pool, separated 
by commas. 

DNS Server Address 

Type the DNS server addresses for the client. 
To allow the client to access a host on the Internet via the host name, you 
need to specify DNS server addresses. 
Up to eight DNS servers can be specified in a DHCP address pool, 
separated by commas. 

WINS Server Address 

Type the WINS server addresses for the client. 
If b-node is specified for the client, you do not need to specify any WINS 
server address. 
Up to eight WINS servers can be specified in a DHCP address pool, 
separated by commas. 

NetBIOS Node Type Select the NetBIOS node type for the client. 

 

Return to DHCP Server Configuration Task List. 

Enabling the DHCP Server on an Interface 

Select Network > DHCP from the navigation tree to enter the default DHCP Server page shown in 
Figure 26-7. DHCP server state of interfaces is displayed in the Interface Configuration field. Click the 

 icon next to a specific interface to enter the page shown in Figure 26-10. 

Figure 26-10 Configure a DHCP server interface 

 

 

Table 26-3 describes the DHCP server interface configuration items on an interface. 
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Table 26-3 DHCP server interface configuration items 

Item Description 

Interface Name This field displays the name of a specific interface. 

DHCP Server 

Enable or disable the DHCP server on the interface. 
Upon receiving a DHCP request from a client, the interface with the DHCP server 
disabled will neither assign an IP address to the client, nor serve as a DHCP relay 
agent to forward the request. 

 

Return to DHCP Server Configuration Task List. 

DHCP Server Configuration Example 

DHCP networking involves two types: 

 The DHCP server and clients are on the same subnet. 

 The DHCP server and clients are not on the same subnet and communicate with each other via a 
DHCP relay agent. 

The DHCP server configuration for the two types is the same. 

Network requirements 
As shown in Figure 26-11, the DHCP client on subnet 10.1.1.0/24 obtains an IP address dynamically 
from the DHCP server (AC). The IP address of VLAN-interface 2 of the AC is 10.1.1.1/24. 

In subnet 10.1.1.0/24, the address lease duration is ten days and twelve hours and the gateway 
address is 10.1.1.1. 

Figure 26-11 Network diagram for DHCP configuration example 

 

 
 

Configuration procedure 
# Specify IP addresses for interfaces. (Omitted) 

# Enable DHCP. 

 Select Network > DHCP from the navigation tree to enter the default DHCP Server page. Perform 
the following operations, as shown in Figure 26-12. 



 

26-14 

Figure 26-12 Enable DHCP 

 

 

 Click on the Enable radio button in the DHCP Service field. 

# Enable the DHCP server on VLAN-interface 2. (This operation can be omitted because the DHCP 
server is enabled on the interface by default.) 

# Configure a dynamic address pool for the DHCP server. 

 The Dynamic radio button in the Address Pool field is clicked on by default. Click Add. Perform 
the following operations, as shown in Figure 26-13. 
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Figure 26-13 Configure a dynamic address pool for the DHCP server 

 

 

 Type test for IP Pool Name. 

 Type 10.1.1.0 for IP Address. 

 Select 255.255.255.0 for Mask. 

 Type 10 days 12 hours 0 minutes for Lease Duration. 

 Type 10.1.1.1 for Gateway Address. 

 Click Apply. 

DHCP Relay Agent Configuration 

Application Environment 

Since DHCP clients request IP addresses via broadcast messages, the DHCP server and clients must 
be on the same subnet. Therefore, a DHCP server must be available on each subnet, which is not 
practical.  

DHCP relay agent solves the problem. Via a relay agent, DHCP clients communicate with a DHCP 
server on another subnet to obtain configuration parameters. Thus, DHCP clients on different subnets 
can contact the same DHCP server, and centralized management and cost reduction are achieved. 

Fundamentals 

Figure 26-14 shows a typical application of the DHCP relay agent. 
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Figure 26-14 DHCP relay agent application 

IP network

DHCP server

DHCP relay agent

DHCP client DHCP client

DHCP clientDHCP client

 

 

No matter whether a relay agent exists or not, the DHCP server and client interact with each other in a 
similar way (see section Dynamic IP address allocation process). The following describes the 
forwarding process on the DHCP relay agent. 

Figure 26-15 DHCP relay agent work process 

 

 

As shown in Figure 26-15, the DHCP relay agent works as follows: 

1) After receiving a DHCP-DISCOVER or DHCP-REQUEST broadcast message from a DHCP client, 
the DHCP relay agent fills the giaddr field of the message with its IP address and forwards the 
message to the designated DHCP server in unicast mode. 

2) Based on the giaddr field, the DHCP server returns an IP address and other configuration 
parameters to the relay agent, which conveys them to the client. 

DHCP Relay Agent Configuration Task List 

Complete the following tasks to configure the DHCP relay agent: 

Task Remarks 

Enabling DHCP and 
Configuring Advanced 
Parameters for the DHCP 
Relay Agent 

Required 
Enable DHCP globally and configure advanced DHCP parameters. 
By default, global DHCP is disabled. 
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Task Remarks 

Creating a DHCP Server 
Group 

Required 
To improve reliability, you can specify several DHCP servers as a group on the 
DHCP relay agent and correlate a relay agent interface with the server group. 
When the interface receives requesting messages from clients, the relay agent 
will forward them to all the DHCP servers of the group. 

Enabling the DHCP Relay 
Agent on an Interface 

Required 
Enable the DHCP relay agent on an interface, and correlate the interface with a 
DHCP server group. 
With DHCP enabled, interfaces work in the DHCP server mode by default. 

 
 An interface cannot serve as both the DHCP server and the DHCP relay 

agent. The latest configuration takes effect. 
 If the DHCP relay agent is enabled on an Ethernet subinterface, a packet 

received from a client on this interface must contain a VLAN tag and the 
VLAN tag must be the same as the VLAN ID of the subinterface; otherwise, 
the packet is discarded. 

 The DHCP relay agent works on interfaces with IP addresses manually 
configured only. 

 If an Ethernet subinterface serves as a DHCP relay agent, it conveys IP 
addresses only to subinterfaces of DHCP clients. In this case, a PC cannot 
obtain an IP address as a DHCP client. 

Configuring and Displaying 
Clients' IP-to-MAC 
Bindings 

Optional 
Create a static IP-to-MAC binding, and view static and dynamic bindings. 
The DHCP relay agent can dynamically record clients’ IP-to-MAC bindings after 
clients get IP addresses. It also supports static bindings, that is, you can manually 
configure IP-to-MAC bindings on the DHCP relay agent, so that users can access 
external network using fixed IP addresses. 
By default, no static binding is created. 

 

Enabling DHCP and Configuring Advanced Parameters for the DHCP Relay Agent 

Select Network > DHCP from the navigation tree to enter the default DHCP Relay page shown in 
Figure 26-16. Enable or disable DHCP in the DHCP Service field. Click Display Advanced 
Configuration to expand the advanced DHCP relay agent configuration field. 
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Figure 26-16 DHCP relay agent configuration page 

 
 

Table 26-4 describes the DHCP service and advanced DHCP relay agent configuration items. 

Table 26-4 DHCP service and advanced DHCP relay agent configuration items 

Item Description 

DHCP Service Enable or disable global DHCP. 

Unauthorized 
Server Detect 

Enable or disable unauthorized DHCP server detection. 
There are unauthorized DHCP servers on networks, which reply DHCP clients with wrong IP 
addresses. 
With this feature enabled, upon receiving a DHCP request, the DHCP relay agent will record 
the IP address of any DHCP server that assigned an IP address to the DHCP client and the 
receiving interface. The administrator can use this information to check out DHCP 
unauthorized servers. The device puts a record once for each DHCP server. The 
administrator needs to find unauthorized DHCP servers from the log information. After the 
information of recorded DHCP servers is cleared, the relay agent will re-record server 
information following this mechanism. 



 

26-19 

Item Description 

Dynamic 
Bindings 
Refresh 

Track Timer 
Interval 

Enable or disable periodic refresh of dynamic client entries, and set the refresh interval. 
Via the DHCP relay agent, a DHCP client sends a DHCP-RELEASE unicast message to the 
DHCP server to relinquish its IP address. In this case the DHCP relay agent simply conveys 
the message to the DHCP server, thus it does not remove the IP address from dynamic 
client entries. To solve this problem, the periodic refresh of dynamic client entries feature is 
introduced. 
With this feature, the DHCP relay agent uses the IP address of a client and the MAC 
address of the DHCP relay agent interface to periodically send a DHCP-REQUEST 
message to the DHCP server. 

 If the server returns a DHCP-ACK message or does not return any message within a 
specified interval, which means that the IP address is assignable now, the DHCP relay 
agent will age out the client entry. 

 If the server returns a DHCP-NAK message, which means the IP address is still in use, 
the relay agent will not age it out. 

Note that if the Auto radio button is clicked on, the refresh interval is calculated by the relay 
agent according to the number of client entries. 

 

Return to DHCP Relay Agent Configuration Task List. 

Creating a DHCP Server Group 

Select Network > DHCP from the navigation tree to enter the default DHCP Relay page shown in 
Figure 26-16. In the Server Group field, click Add to enter the page shown in Figure 26-17. 

Figure 26-17 Create a server group 

 
 

Table 26-5 describes the DHCP server group configuration items. 

Table 26-5 DHCP server group configuration items 

Item Description 

Server Group ID 
Type the ID of a DHCP server group. 
You can create up to 20 DHCP server groups. 

IP Address 
Type the IP address of a server in the DHCP server group. 
The server IP address cannot be on the same subnet as the IP address of the DHCP 
relay agent; otherwise, the client cannot obtain an IP address. 

 

Return to DHCP Relay Agent Configuration Task List. 
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Enabling the DHCP Relay Agent on an Interface 

Select Network > DHCP from the navigation tree to enter the default DHCP Relay page shown in 
Figure 26-16. In the Interface Config field, the DHCP relay agent state of interfaces is displayed. Click 

the  icon of a specific interface to enter the page shown in Figure 26-18. 

Figure 26-18 Configure a DHCP relay agent interface 

 

 

Table 26-6 describes the DHCP relay agent interface configuration items. 

Table 26-6 DHCP relay agent interface configuration items 

Item Description 

Interface Name This field displays the name of a specific interface. 

DHCP Relay 
Enable or disable the DHCP relay agent on the interface. 
If the DHCP relay agent is disabled, the DHCP server is enabled on the interface.

Address Match Check 

Enable or disable IP address check. 
With this function enabled, the DHCP relay agent checks whether a requesting 
client’s IP and MAC addresses match a binding (dynamic or static) on the DHCP 
relay agent. If not, the client cannot access outside networks via the DHCP relay 
agent. This prevents invalid IP address configuration. 

Server Group ID 
Correlate the interface with a DHCP server group. 
A DHCP server group can be correlated with multiple interfaces. 

 

Return to DHCP Relay Agent Configuration Task List. 

Configuring and Displaying Clients' IP-to-MAC Bindings 

Select Network > DHCP from the navigation tree to enter the default DHCP Relay page shown in 
Figure 26-16. In the User Information field, click the User Information button to view static and 
dynamic bindings, as shown in Figure 26-19. Click Add to enter the page shown in Figure 26-20. 
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Figure 26-19 Display clients' IP-to-MAC bindings 

 

 

Figure 26-20 Create a static IP-to-MAC binding 

 

 

Table 26-7 describes static IP-to-MAC binding configuration items. 

Table 26-7 Static IP-to-MAC binding configuration items 

Item Description 

IP Address Type the IP address of a DHCP client. 

MAC Address Type the MAC address of the DHCP client. 

Interface Name 

Select the Layer 3 interface connected with the DHCP client. 

 
The interface of a static binding entry must be configured as a DHCP relay 
agent; otherwise, address entry conflicts may occur. 

 

Return to DHCP Relay Agent Configuration Task List. 

DHCP Relay Agent Configuration Example 

Network requirements 
As shown in Figure 26-21, VLAN-interface 1 on the DHCP relay agent (AC) connects to the network 
where DHCP clients reside. The IP address of VLAN-interface 1 is 10.10.1.1/24 and the IP address of 
VLAN-interface 2 is 10.1.1.1/24. VLAN-interface 2 is connected to the DHCP server whose IP address 
is 10.1.1.1/24. 

The AC forwards messages between DHCP clients and the DHCP server. 
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Figure 26-21 Network diagram for DHCP relay agent configuration 

 
 

Configuration procedure 
1) Specify IP addresses for interfaces (omitted) 

2) Configure the DHCP relay agent 

# Enable DHCP. 

 Select Network > DHCP from the navigation tree to enter the default DHCP Relay page. Perform 
the following operations, as shown in Figure 26-22. 

Figure 26-22 Enable DHCP 

 
 

 Click on the Enable radio button next to DHCP Service. 

 Click Apply. 

# Configure a DHCP server group. 

 In the Server Group field, click Add. Perform the following operations, as shown in Figure 26-23. 
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Figure 26-23 Add a DHCP server group 

 
 

 Type 1 for Server Group ID. 

 Type 10.1.1.1 for IP Address. 

 Click Apply. 

# Enable the DHCP relay agent on VLAN-interface 1. 

 In the Interface Config field, click the  icon of VLAN-interface 1. Perform the following 
operations, as shown in Figure 26-24. 

Figure 26-24 Enable the DHCP relay agent on an interface and correlate it with a server group 

 

 

 Click on the Enable radio button next to DHCP Relay. 

 Select 1 for Server Group ID. 

 Click Apply. 

 

 

Because the DHCP relay agent and server are on different subnets, you need to configure a static route 
or dynamic routing protocol to make them reachable to each other. 
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DHCP Snooping Configuration 

 

 

 A DHCP snooping enabled device does not work if it is between the DHCP relay agent and DHCP 
server, and it can work when it is between the DHCP client and relay agent or between the DHCP 
client and server. 

 You are not recommended to enable the DHCP client, BOOTP client, and DHCP snooping on the 
same device. Otherwise, DHCP snooping entries may fail to be generated, or the BOOTP 
client/DHCP client may fail to obtain an IP address. 

 

Functions of DHCP Snooping 

As a DHCP security feature, DHCP snooping can implement the following: 

1) Recording IP-to-MAC mappings of DHCP clients 

2) Ensuring DHCP clients to obtain IP addresses from authorized DHCP servers 

Recording IP-to-MAC mappings of DHCP clients 
DHCP snooping reads DHCP-REQUEST messages and DHCP-ACK messages from trusted ports to 
record DHCP snooping entries, including MAC addresses of clients, IP addresses obtained by the 
clients, ports that connect to DHCP clients, and VLANs to which the ports belong. 

Ensuring DHCP clients to obtain IP addresses from authorized DHCP servers 
If there is an unauthorized DHCP server on a network, DHCP clients may obtain invalid IP addresses 
and network configuration parameters, and cannot normally communicate with other network devices. 
With DHCP snooping, the ports of a device can be configured as trusted or untrusted, ensuring the 
clients to obtain IP addresses from authorized DHCP servers. 

 Trusted: A trusted port forwards DHCP messages normally. 

 Untrusted: An untrusted port discards the DHCP-ACK or DHCP-OFFER messages received from 
any DHCP server. 



 

26-25 

Application Environment of Trusted Ports 

Configuring a trusted port connected to a DHCP server 

Figure 26-25 Configure trusted and untrusted ports 

 

 

 

As shown in Figure 26-25, a DHCP snooping device’s port that is connected to an authorized DHCP 
server should be configured as a trusted port to forward reply messages from the DHCP server, so that 
the DHCP client can obtain an IP address from the authorized DHCP server. 

Configuring trusted ports in a cascaded network 
In a cascaded network involving multiple DHCP snooping devices, the ports connected to other DHCP 
snooping devices should be configured as trusted ports. 

To save system resources, you can disable the trusted ports, which are indirectly connected to DHCP 
clients, from recording clients’ IP-to-MAC bindings upon receiving DHCP requests.  

Figure 26-26 Configure trusted ports in a cascaded network 

 

 

 

Table 26-8 describes roles of the ports shown in Figure 26-26. 
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Table 26-8 Roles of ports 

Device Untrusted port Trusted port disabled from 
recording binding entries 

Trusted port enabled to 
record binding entries 

Switch A Ethernet 1/1 Ethernet 1/3 Ethernet 1/2 

Switch B Ethernet 1/3 and Ethernet 1/4 Ethernet 1/1 Ethernet 1/2 

Switch C Ethernet 1/1 Ethernet 1/3 and Ethernet 1/4 Ethernet 1/2 

 

DHCP Snooping Support for Option 82 

Option 82 records the location information of the DHCP client. The administrator can locate the DHCP 
client to further implement security control and accounting. For more information, refer to Introduction to 
Option 82. 

If DHCP snooping supports Option 82, it will handle a client’s request according to the contents defined 
in Option 82, if any. The handling strategies are described in the table below. 

If a reply returned by the DHCP server contains Option 82, the DHCP snooping device will remove the 
Option 82 before forwarding the reply to the client. If the reply contains no Option 82, the DHCP 
snooping device forwards it directly. 

If a client’s requesting 
message has… 

Handling 
strategy The DHCP snooping device will… 

Drop Drop the message. 

Keep Forward the message without changing Option 82. Option 82 

Replace Forward the message after replacing the original Option 82 
with the Option 82 padded in normal format. 

no Option 82 — Forward the message after adding the Option 82 padded in 
normal format. 

 

DHCP Snooping Configuration Task List 

Complete the following tasks to configure DHCP snooping: 

Task Remarks 

Enabling DHCP Snooping 
Required 
By default, DHCP snooping is disabled. 

Configuring DHCP Snooping 
Functions on an Interface 

Required 
Specify an interface as trusted and configure DHCP snooping to support 
Option 82. 
By default, an interface is untrusted and DHCP snooping does not support 
Option 82. 

 
You need to specify the ports connected to the authorized DHCP servers as 
trusted to ensure that DHCP clients can obtain valid IP addresses. The trusted 
port and the port connected to the DHCP client must be in the same VLAN. 

Displaying Clients' IP-to-MAC 
Bindings 

Optional 
Display clients' IP-to-MAC bindings recorded by DHCP snooping. 
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Enabling DHCP Snooping 

Select Network > DHCP from the navigation tree, and then click the DHCP Snooping tab to enter the 
page shown in Figure 26-27. You can enable or disable DHCP snooping in the DHCP Snooping field. 

Figure 26-27 DHCP snooping configuration page 

 

 

 To enable DHCP snooping, click on the Enable radio button in the DHCP Snooping field. 

 To disable DHCP snooping, click on the Disable radio button in the DHCP Snooping field. 

Return to DHCP Snooping Configuration Task List. 

Configuring DHCP Snooping Functions on an Interface 

Select Network > DHCP from the navigation tree, and then click the DHCP Snooping tab to enter the 
page shown in Figure 26-27. You can view trusted and untrusted ports in the Interface Config field. 

Click the  icon of a specific interface to enter the page shown in Figure 26-28. 

Figure 26-28 DHCP snooping interface configuration page 

 
 

Table 26-9 describes DHCP snooping interface configuration items. 
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Table 26-9 DHCP snooping interface configuration items 

Item Description 

Interface Name This field displays the name of a specific interface. 

Interface State Configure the interface as trusted or untrusted. 

Option 82 Support Configure DHCP snooping to support Option 82 or not. 

Option 82 Strategy 

Select the handling strategy for DHCP requests containing Option 82. The 
strategies include: 

 Drop: The message is discarded if it contains Option 82. 
 Keep: The message is forwarded without its Option 82 being changed. 
 Replace: The message is forwarded after its original Option 82 is replaced with 

the Option 82 padded in normal format. 

 

Return to DHCP Snooping Configuration Task List. 

Displaying Clients' IP-to-MAC Bindings 

Select Network > DHCP from the navigation tree, and then click the DHCP Snooping tab to enter the 
page shown in Figure 26-27. Click the User Information button to view clients' IP-to-MAC bindings 
recorded by DHCP snooping, as shown in Figure 26-29. 

Figure 26-29 DHCP snooping user information 

 

 

Table 26-10 describes DHCP snooping user information configuration items. 

Table 26-10 DHCP snooping user information configuration items 

Item Description 

IP Address This field displays the IP address assigned by the DHCP server to the client. 

MAC Address This field displays the MAC address of the client. 

Type 

This field displays the client type, which can be: 
 Dynamic: The IP-to-MAC binding is generated dynamically. 
 Static: The IP-to-MAC binding is configured manually. Currently, static 

bindings are not supported. 

Interface Name This field displays the device interface to which the client is connected. 

VLAN This field displays the VLAN to which the device belongs. 

Remaining Lease Time This field displays the remaining lease time of the IP address. 

 

Return to DHCP Snooping Configuration Task List. 
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DHCP Snooping Configuration Example 

Network requirements 
As shown in Figure 26-30, a DHCP snooping device (AC) is connected to a DHCP server through 
GigabitEthernet 1/0/2, and to an AP through GigabitEthernet 1/0/1. 

 Enable DHCP snooping on the AC and configure DHCP snooping to support Option 82. Configure 
the handling strategy for DHCP requests containing Option 82 as replace. 

 Enable GigabitEthernet 1/0/2 to forward DHCP server responses; disable GigabitEthernet 1/0/1 
from forwarding DHCP server responses. 

 Configure the AC to record clients’ IP-to-MAC address bindings in DHCP-REQUEST messages 
and DHCP-ACK messages received from a trusted port. 

Figure 26-30 Network diagram for DHCP snooping configuration 

 

 
 

Configuration procedure 
# Enable DHCP snooping. 

 Select Network > DHCP from the navigation tree, and then click the DHCP Snooping tab. Perform 
the following operation, as shown in Figure 26-31. 

Figure 26-31 Enable DHCP snooping 

  

 

 Click on the Enable radio button next to DHCP Snooping. 

# Configure DHCP snooping functions on GigabitEthernet 1/0/2. 

 Click the  icon of GigabitEthernet 1/0/2 on the interface list. Perform the following operations, as 
shown in Figure 26-32. 
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Figure 26-32 Configure DHCP snooping functions on GigabitEthernet 1/0/2 

 
 

 Click on the Trust radio button next to Interface State. 

 Click Apply. 

# Configure DHCP snooping functions on GigabitEthernet 1/0/1. 

 Click the  icon of GigabitEthernet 1/0/1 on the interface list. Perform the following operations, as 
shown in Figure 26-33. 

Figure 26-33 Configure DHCP snooping functions on GigabitEthernet 1/0/1 

 
 

 Click on the Untrust radio button for Interface State. 

 Click on the Enable radio button next to Option 82 Support. 

 Select Replace for Option 82 Strategy. 

 Click Apply. 
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27  DNS Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Domain Name System (DNS) is a distributed database used by TCP/IP applications to translate domain 
names into corresponding IP addresses. With DNS, you can use easy-to-remember domain names in 
some applications and let the DNS server translate them into correct IP addresses. 

There are two types of DNS services, static and dynamic. After a user specifies a name, the device 
checks the local static name resolution table for an IP address. If no IP address is available, it contacts 
the DNS server for dynamic name resolution, which takes more time than static name resolution. 
Therefore, some frequently queried name-to-IP address mappings are stored in the local static name 
resolution table to improve efficiency. 

Static Domain Name Resolution 

Configuring static domain name resolution is to set up mappings between domain names and IP 
addresses manually. IP addresses of the corresponding domain names can be found in the static 
domain resolution table when you use applications such as telnet. 

Dynamic Domain Name Resolution 

Resolving procedure 
Dynamic domain name resolution is implemented by querying the DNS server. The resolution 
procedure is as follows: 

1) A user program sends a name query to the resolver of the DNS client. 

2) The DNS resolver looks up the local domain name cache for a match. If a match is found, it sends 
the corresponding IP address back. If not, it sends a query to the DNS server. 
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3) The DNS server looks up the corresponding IP address of the domain name in its DNS database. If 
no match is found, it sends a query to a higher level DNS server. This process continues until a 
result, whether successful or not, is returned. 

4) The DNS client returns the resolution result to the application after receiving a response from the 
DNS server. 

Figure 27-1 Dynamic domain name resolution 

 

 

Figure 27-1 shows the relationship between the user program, DNS client, and DNS server. The 
resolver and cache comprise the DNS client. The user program and DNS client can run on the same 
device or different devices, while the DNS server and the DNS client usually run on different devices. 

Dynamic domain name resolution allows the DNS client to store latest mappings between domain 
names and IP addresses in the dynamic domain name cache. There is no need to send a request to the 
DNS server for a repeated query next time. The mappings are removed from the cache after some time 
to ensure latest entries are obtained from the DNS server. The DNS server decides how long a mapping 
is valid, and the DNS client gets the aging time from DNS messages. 

DNS suffixes 
The DNS client normally holds a list of suffixes which can be defined by users. It is used when the name 
to be resolved is incomplete. The resolver can supply the missing part. For example, a user can 
configure com as the suffix for aabbcc.com. After that, the user only needs to type aabbcc, and the 
resolver will add the suffix and delimiter. The following describes more details. 

 If there is no dot in the inputted domain name (for example, aabbcc), the resolver will consider it a 
host name and add a DNS suffix before query. If no match is found after all the configured suffixes 
are used respectively, the original domain name (for example, aabbcc) is used for query. 

 If there is a dot in the inputted domain name (for example, www.aabbcc), the resolver will directly 
use this domain name for query. If the query fails, the resolver adds a DNS suffix for another query. 

 If the dot is at the end of the inputted domain name (for example, aabbcc.com.), the resolver will 
consider it a fully qualified domain name (FQDN) and return the query result, successful or failed. 
Hence, the dot “.” at the end of the domain name is called the terminating symbol. 

DNS Proxy 

Introduction to DNS proxy 
A DNS proxy forwards DNS requests and replies between DNS clients and a DNS server. 
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As shown in Figure 27-2, a DNS client sends a DNS request to the DNS proxy, which forwards the 
request to the designated DNS server, and conveys the reply from the DNS server to the client. 

The DNS proxy simplifies network management. When the DNS server address is changed, you only 
need to change the configuration on the DNS proxy instead of on each DNS client. 

Figure 27-2 DNS proxy networking application 

 

 

Operation of a DNS proxy 
1) A DNS client considers the DNS proxy as the DNS server, and sends a DNS request to the DNS 

proxy, that is, the destination address of the request is the IP address of the DNS proxy. 

2) The DNS proxy searches the local static domain name resolution table after receiving the request. 
If the requested information exists in the table, the DNS proxy returns a DNS reply to the client. 

3) If the requested information does not exist in the static domain name resolution table, the DNS 
proxy sends the request to the designated DNS server for domain name resolution. 

4) After receiving a reply from the DNS server, the DNS proxy forwards the reply to the DNS client. 

Configuring DNS 

Configuration Overview 

DNS provides three functions, static name resolution, dynamic domain name resolution, and DNS 
proxy. 

 Static name resolution: Name resolution is carried out through manually configured name 
resolution entries. 

 Dynamic name resolution: A device resolves domain names through the DNS server. 

 DNS proxy: You can configure a device as a DNS proxy. 

 

 

If both static domain name resolution and dynamic domain name resolution are configured, the device 
first checks the static name resolution table for an IP address. If no IP address is available, it then 
contacts the DNS server for dynamic name resolution. 

 



 

27-4 

Configuring static name resolution table 
Perform the tasks in Table 27-1 to configure static name resolution table. 

Table 27-1 Static name resolution table configuration task list 

Task Remarks 

Configuring Static Name Resolution Table 
Required 
By default, no host name-to-IP address mappings are 
configured in the static domain name resolution table. 

 

Configuring dynamic domain name resolution 
Perform the tasks in Table 27-2 to configure dynamic domain name resolution. 

Table 27-2 Dynamic domain name resolution configuration task list 

Task Remarks 

Configuring Dynamic Domain Name Resolution 
Required 
Enable dynamic domain name resolution. 
This function is disabled by default. 

Adding a DNS Server Address 
Required 
Not configured by default. 

Adding a Domain Name Suffix 
Optional 
Not configured by default. 

 

Configuring DNS proxy 
Perform the tasks in Table 27-3 to configure DNS proxy. 

Table 27-3 DNS proxy configuration task list 

Task Remarks 

Configuring DNS Proxy 
Required 
Configure the device as a DNS proxy. 
By default, the device is not a DNS proxy. 

Adding a DNS Server Address 
Required 
Not configured by default. 

 

Configuring Static Name Resolution Table 

Select Network > DNS from the navigation tree to enter the default static domain name resolution 
configuration page shown in Figure 27-3. Click Add to enter the page shown in Figure 27-4. 
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Figure 27-3 Static domain name resolution configuration page 

 

 

Figure 27-4 Create a static domain name resolution entry 

 

 

Table 27-4 describes the static name resolution entry configuration items. 

Table 27-4 Static name resolution entry configuration items 

Item Description 

Host Name 

Host IP Address 

Configure the mapping between a host name and an IP address in the static domain 
mane table. 
Each host name corresponds to only one IP address. If you configure multiple IP 
addresses for a host name, the last configured one takes effect. 
You can create up to 50 static host name-to-IP address mappings. 

 

Return to Static name resolution table configuration task list. 

Configuring Dynamic Domain Name Resolution 

Select Network > DNS from the navigation tree and then click the Dynamic tab to enter the page 
shown in Figure 27-5. 
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Figure 27-5 Dynamic domain name resolution configuration page 

 

 

Table 27-5 describes the dynamic domain name resolution configuration items. 

Table 27-5 Dynamic domain name resolution configuration items 

Item Description 

Dynamic DNS Enable or disable dynamic domain name resolution. 

Clear Dynamic DNS cache Configure whether to remove all the information from the dynamic DNS cache.

 

Return to Dynamic domain name resolution configuration task list. 

Configuring DNS Proxy 

Select Network > DNS from the navigation tree and then click the Dynamic tab to enter the page 
shown in Figure 27-5. 

Table 27-6 describes the DNS proxy configuration items. 

Table 27-6 DNS proxy configuration items 

Item Description 

DNS proxy Enable or disable DNS proxy on the device. 

 

Return to DNS proxy configuration task list. 
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Adding a DNS Server Address 

Select Network > DNS from the navigation tree and then click the Dynamic tab to enter the page 
shown in Figure 27-5. Click Add IP to enter the page shown in Figure 27-6. 

Figure 27-6 Add a DNS server address 

 
 

Table 27-7 describes the DNS server address configuration items. 

Table 27-7 DNS server address configuration items 

Item Description 

DNS Server IP Address 
Type the IP addresses of DNS servers. 
You can configure up to six DNS servers. 

 

Return to Dynamic domain name resolution configuration task list. 

Return to DNS proxy configuration task list. 

Adding a Domain Name Suffix 

Select Network > DNS from the navigation tree and then click the Dynamic tab to enter the page 
shown in Figure 27-5. Click Add Suffix to enter the page shown in Figure 27-7. 

Figure 27-7 Add a domain name suffix 

 

 

Table 27-8 describes the domain name suffix configuration items. 
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Table 27-8 Domain name suffix configuration items 

Item Description 

DNS Domain Name Suffix 
Type a domain name suffix. 
You can configure up to 10 domain name suffixes. 

 

Return to Dynamic domain name resolution configuration task list. 

DNS Configuration Example 

Network requirements 
As shown in Figure 27-8, the IP address of the DNS server is 2.1.1.2/16 and the domain name suffix is 
com. AC serving as a DNS client uses dynamic domain name resolution to access the host with the 
domain name host.com and the IP address 3.1.1.1/16. 

Figure 27-8 Network diagram for DNS 

 

 

Configuration procedure 
 

 

Before performing the following configuration, make sure that AC and the host are reachable to each 
other, and related configurations are made on both AC and the host. For the IP addresses of the 
interfaces, see Figure 27-8. In addition, the mapping between host name host.com and IP address 
3.1.1.1/16 has been configured on the DNS server that works normally. 

 

# Enable dynamic domain name resolution. 

 Select Network > DNS from the navigation tree and then click the Dynamic tab. Perform the 
following operations, as shown in Figure 27-9. 
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Figure 27-9 Enable dynamic domain name resolution 

 
 

 Click on the Enable radio button next to Dynamic DNS. 

 Click on the Disable radio button for DNS Proxy. 

 Click Apply. 

# Configure the DNS server address. 

 Click Add IP on the Dynamic tab, as shown in Figure 27-10. Then perform the following operations, 
as shown in Figure 27-11. 

Figure 27-10 Click the Add IP button 
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Figure 27-11 Add a DNS server address 

 
 

 Type 2.1.1.2 for DNS Server IP Address. 

 Click Apply. 

# Configure the domain name suffix. 

 Click Add Suffix on the Dynamic tab, as shown in Figure 27-12. Then perform the following 
operations, as shown in Figure 27-13. 

Figure 27-12 Click the Add Suffix button 
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Figure 27-13 Add a DNS domain name suffix 

 

 

 Type com for DNS Domain Name Suffix. 

 Click Apply. 
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28  Service Management 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

The service management module provides six types of services: FTP, Telnet, SSH, SFTP, HTTP and 
HTTPS. You can enable or disable the services as needed. In this way, the performance and security of 
the system can be enhanced, thus secure management of the device can be achieved. 

The service management module also provides the function to modify HTTP and HTTPS port numbers, 
and the function to associate the FTP, HTTP, or HTTPS service with an ACL, thus reducing attacks of 
illegal users on these services. 

FTP service 
The File Transfer Protocol (FTP) is an application layer protocol for sharing files between server and 
client over a TCP/IP network. 

Telnet service 
The Telnet protocol is an application layer protocol that provides remote login and virtual terminal 
functions on the network. 

SSH service 
Secure Shell (SSH) offers an approach to securely logging in to a remote device. By encryption and 
strong authentication, it protects devices against attacks such as IP spoofing and plain text password 
interception.  

SFTP service 
The secure file transfer protocol (SFTP) is a new feature in SSH2.0. SFTP uses the SSH connection to 
provide secure data transfer. The device can serve as the SFTP server, allowing a remote user to log in 
to the SFTP server for secure file management and transfer. The device can also serve as an SFTP 
client, enabling a user to login from the device to a remote device for secure file transfer. 



 

28-2 

HTTP service 
The Hypertext Transfer Protocol (HTTP) is used for transferring web page information across the 
Internet. It is an application-layer protocol in the TCP/IP protocol suite.  

You can log in to the device using the HTTP protocol with HTTP service enabled, accessing and 
controlling the device with Web-based network management. 

HTTPS service 
The Secure HTTP (HTTPS) refers to the HTTP protocol that supports the Security Socket Layer (SSL) 
protocol. 

The SSL protocol of HTTPS enhances the security of the device in the following ways: 

 Uses the SSL protocol to ensure the legal clients to access the device securely and prohibit the 
illegal clients; 

 Encrypts the data exchanged between the HTTPS client and the device to ensure the data security 
and integrity, thus realizing the security management of the device; 

 Defines certificate attribute-based access control policy for the device to control the access right of 
the client, in order to further avoid attacks from illegal clients. 

Configuring Service Management 

Select Network > Service from the navigation tree to enter the service management configuration 
page, as shown in Figure 28-1. 

Figure 28-1 Service management 

 

 

Table 28-1 shows the detailed configuration for service management. 
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Table 28-1 Service management configuration items 

Item Description 

Enable FTP service 
Specifies whether to enable the FTP service. 
The FTP service is disabled by default. 

FTP  

ACL 

Associates the FTP service with an ACL. Only the clients that pass the 
ACL filtering are permitted to use the FTP service. 
You can view this configuration item by clicking the expanding button in 
front of FTP. 

Telnet  Enable Telnet 
service 

Specifies whether to enable the Telnet service. 
The Telnet service is disabled by default. 

SSH  Enable SSH service 
Specifies whether to enable the SSH service. 
The SSH service is disabled by default. 

SFTP  Enable SFTP 
service 

Specifies whether to enable the SFTP service. 
The SFTP service is disabled by default. 

 
When you enable the SFTP service, the SSH service must be enabled. 

Enable HTTP 
service 

Specifies whether to enable the HTTP service. 
The HTTP service is disabled by default. 

Port Number 

Sets the port number for HTTP service. 
You can view this configuration item by clicking the expanding button in 
front of HTTP. 

 
When you modify a port, ensure that the port is not used by other service.

HTTP  

ACL 

Associates the HTTP service with an ACL. Only the clients that pass the 
ACL filtering are permitted to use the HTTP service. 
You can view this configuration item by clicking the expanding button in 
front of HTTP. 

Enable HTTPS 
service 

Specifies whether to enable the HTTPS service. 
The HTTPS service is disabled by default. 

Port Number 

Sets the port number for HTTPS service. 
You can view this configuration item by clicking the expanding button in 
front of HTTPS. 

 
When you modify a port, ensure that the port is not used by other service.

HTTPS  

ACL 

Associates the HTTPS service with an ACL. Only the clients that pass the 
ACL filtering are permitted to use the HTTPS service. 
You can view this configuration item by clicking the expanding button in 
front of HTTPS. 
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Item Description 

PKI Domain 

Sets the PKI domain for the HTTPS service. 
You can configure the available PKI domains by selecting 
Authentication > PKI from the navigation tree at the left side of the 
interface. For more information, refer to PKI Configuration. 

 
The service management, portal authentication and local EAP service 
modules always reference the same PKI domain. Changing the 
referenced PKI domain in any of the three modules will also change that 
referenced in the other two modules. 
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29  Diagnostic Tools 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Ping 

You can use the ping function to check whether a device with a specified address is reachable, and to 
examine network connectivity.  

A successful execution of the ping command involves the following steps: 

1) The source device sends an ICMP echo request (ECHO-REQUEST) to the destination device. 

2) The destination device responds by sending an ICMP echo reply (ECHO-REPLY) to the source 
device after receiving the ICMP echo request. 

3) The source device displays related statistics after receiving the reply. 

Output of the ping command falls into the following: 

 The ping command can be applied to the destination’s host name or IP address. If the destination’s 
host name is unknown, the prompt information is displayed. 

 If the source device does not receive an ICMP echo reply within the timeout time, it displays the 
prompt information and the statistics during the ping operation. If the source device receives an 
ICMP echo reply within the timeout time, it displays the number of bytes of the echo reply, the 
message sequence number, Time to Live (TTL), the response time, and the statistics during the 
ping operation. Statistics during the ping operation include number of packets sent, number of echo 
reply messages received, percentage of messages not received, and the minimum, average, and 
maximum response time. 
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Trace Route 

By using the trace route command, you can display the Layer 3 devices involved in delivering a packet 
from source to destination. This function is useful for identification of failed node(s) in the event of 
network failure. 

The trace route command involves the following steps in its execution: 

1) The source device sends a packet with a TTL value of 1 to the destination device. 

2) The first hop (the Layer 3 device that first receives the packet) responds by sending a TTL-expired 
ICMP message to the source, with its IP address encapsulated. In this way, the source device can 
get the address of the first Layer 3 device. 

3) The source device sends a packet with a TTL value of 2 to the destination device. 

4) The second hop responds with a TTL-expired ICMP message, which gives the source device the 
address of the second Layer 3 device. 

5) The above process continues until the ultimate destination device is reached. In this way, the 
source device can trace the addresses of all the Layer 3 devices involved to get to the destination 
device. 

The traceroute command can be applied to the destination’s host name or IP address. If the 
destination’s host name is unknown, the prompt information is displayed. 

Diagnostic Tool Operations 

Ping Operation 

 

 

Support for the IPv6 ping operations depends on the device model. Refer to Compatibility Matrixes for 
details. 

 

IPv4 ping operation 
Select Diagnostic Tools > Ping from the navigation tree to enter the IPv4 Ping configuration page. 
Then click Display Advanced Config to display the configurations of the advanced parameters of IPv4 
ping operation, as shown in Figure 29-1. 
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Figure 29-1 IPv4 ping configuration page 

 
 

After the above configuration, type in the IPv4 address or host name of the destination device in the 
Destination IP address or host name box, and set the advanced parameters for the IPv4 ping 
operation. Then click Start to execute the ping command, and you can see the result in the Summary 
box. 

Figure 29-2 IPv4 ping operation results 
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IPv6 ping operation 
Select Diagnostic Tools > Ping from the navigation tree to enter the IPv6 ping configuration page. 
Then click Display Advanced Config to display the configurations of the advanced parameters of IPv6 
ping operation, as shown in Figure 29-3. 

Figure 29-3 IPv6 ping 

 
 

After the above configuration, type the IPv6 address or host name of the destination device in the 
Destination IP address or host name box, and set the advanced parameters for the IPv6 ping 
operation. Then click Start to execute the ping command, and you can see the result in the Summary 
box, as shown in Figure 29-4. 

Figure 29-4 IPv6 ping operation results 
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Trace Route Operation 

 

 

 The Web interface does not support trace route on IPv6 addresses. 

 Before performing the trace route operations, you need to execute the ip ttl-expires enable and ip 
unreachables enable commands to enable the sending of ICMP time-exceeded messages and 
ICMP port unreachable messages of the device. 

 

Select Diagnostic Tools > Trace Route from the navigation tree, and click the Trace Route tab to 
enter the Trace Route configuration page, as shown in Figure 29-5. 

Figure 29-5 Trace Route configuration page 

 

 

After the above configuration, type the destination IP address or host name in the text box, and click 
Start to execute the trace route command, and then you can see the result in the Summary box, as 
shown in Figure 29-6. 
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Figure 29-6 Trace route operation results 
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30  AP Configuration 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

The AP configuration module allows you to perform the following configurations: 

 Establish a CAPWAP connection 

 Configure auto AP 

 Configure an AP group 

Introduction to CAPWAP 

Control And Provisioning of Wireless Access Points (CAPWAP) defines how an AP communicates with 
an AC. It provides a generic encapsulation and transport mechanism between AP and AC, as shown in 
Figure 30-1. 

Figure 30-1 CAPWAP 

 

 

CAPWAP runs on an AP and an AC to provide a secured connection in between. It is built on a standard 
client/server model and employs UDP. 

On an AP, CAPWAP provides a data tunnel to encapsulate data packets to be sent to the AC. These 
packets can be raw 802.11 packets or 802.11 to 802.3 translated packets. On an AC, CAPWAP 
provides a control tunnel to support remote AP configuration and management, and WLAN and mobile 
management. 

With CAPWAP, the AC can dynamically configure an AP based on the information provided by the 
administrator. 
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CAPWAP supports both IPv4 and IPv6. 

Configuring Auto AP 

The auto AP feature allows an AP to automatically connect to an AC. When you deploy a wireless 
network with many APs, the auto AP function avoids configuration of many AP serial IDs, thus 
simplifying configuration. 

Configuring AP Group 

Some wireless service providers need to control the access positions of clients. For example, as shown 
in the figure below, to meet security or billing needs, it is required to connect wireless clients 1, 2 and 3 
to the wired network through APs 1, 2 and 3 respectively. To achieve this, you can configure an AP 
group and then apply the AP group in a user profile. 

Figure 30-2 Client access control 

AC 

AP 1

RADIUS server

Internet AP 2

Client 1

Client 2

Client 3  

 

Configuring an AP 

AP Setup 

Adding an AP 
Select AP > AP Setup from the navigation tree, and click New to enter the page for adding an AP, as 
shown in Figure 30-3. 
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Figure 30-3 Add an AP 

 

 

Table 30-1 shows the configuration items of adding an AP. 

Table 30-1 Configuration items of adding an AP 

Item Description 

AP Name AP name 

Model AP model 

Serial ID 

 Auto: If selected, the AP serial ID is automatically found. This function is 
used together with the auto AP function. For how to configure auto AP, 
refer to Configuring Auto AP. 

 Manual: If this mode is selected, you need to type an AP serial ID. 

 

Configure an AP 

Select AP > AP Setup from the navigation tree, find the AP to be configured, and click the  icon in 

the Operation column to enter the page for configuring an AP, as shown in Figure 30-4. 

Figure 30-4 AP setup 

 

 

Table 30-2 shows the configuration items of configuring an AP. 
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Table 30-2 Configuration items of configuring an AP 

Item Description 

AP Name Displays the name of the AP selected. 

Radio Number Number of the radios supported by the AP, which takes the value 1 or 2. The value 
depends on the AP model. 

Radio Type The value depends on the AP model and radio type. 

Serial ID 

Set a serial ID for the AP. 
 Auto: If selected, the AP serial ID is automatically found. This option is used together 

with the auto AP function. For how to configure auto AP, refer to Configuring Auto AP.
 Manual: You need to type an AP serial ID. 

 
The serial ID is the unique identity of the AP. If the AP has connected to the AC, changing 
or deleting its serial ID will render the CAPWAP tunnel down and the AP needs to 
discover the AC to connect again. 

Description Description of the AP 

 

Advanced setting 
Select AP > AP Setup from the navigation tree, find the AP to be configured, click the corresponding 
icon in the Operation column to enter the AP Setup page, and then click the Advanced Setup 
expansion button to enter the page shown in Figure 30-5. 

Figure 30-5 Advanced setting 

 

 

Table 30-3 shows the configuration items of advanced setting. 
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Table 30-3 Configuration items of advanced setting 

Item Description 

AP Connection Priority AP connection priority 

Broadcast Probe 
 enable: Enables the AP to respond to broadcast probe requests. 
 disable: Disables the AP from responding to broadcast probe requests. 

Configuration File 

Specifies a name for the configuration file in the flash and maps the specified 
configuration file to the AP. 
When local forwarding is enabled, you can use the configuration file to 
configure the AP. 

 
The commands in the configuration file must be in their complete form. 

Jumbo Frame Size Set the maximum size of jumbo frames. 

AP Echo Interval 

Set the interval for sending echo requests. 
There is a keep-live mechanism between AP and AC, to confirm whether the 
control channel is working or not. To keep the control channel alive, an AP 
periodically sends echo requests to an AC. The AC responds to echo requests 
by sending echo responses. 

Client Alive Time 

Set the client keep alive interval. 
The keep-alive mechanism is used to detect clients segregated from the 
system due to various reasons such as power failure or crash, and disconnect 
them from the AP. 
By default, the client keep-alive functionality is disabled. 

Client Free Time Maximum interval for which the link between the AP and a client can be idle 

Backup AC IPv4 Address 

Set the IPv4 address of the backup AC for the AP. For information about AC 
backup, refer to Advanced. If you configure the global backup AC information 
both by selecting Advanced Setup > AC Backup and AP > AP Setup, the 
configuration in AP > AP Setup takes precedence. 

Backup AC IPv6 Address Set the IPv6 address of the backup AC for the AP. 

AP CAR 
Select this box to configure CAR for the AP. 
By default, no CAR is set for an AP. 

CIR Committed information rate, in kbps. 

CBS 
Committed burst size, in bytes. 
By default, the CBS is the number of bytes transmitted in 500 ms at the rate of 
CIR. For example, if CIR is 100, CBS is 500000 bits by default. 

 

Configuring Auto AP 

Enable auto AP 
Select Advance > Auto AP from the navigation tree to enter the page shown in Figure 30-6. 
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Figure 30-6 Configure auto AP 

 

 

Table 30-4 shows the configuration items of configuring auto AP. 

Table 30-4 Configuration items of configuring auto AP 

Item Description 

Auto AP 

 enable: Select it to enable the auto AP function. You must also select Auto from the 
Serial ID drop-down box on the AP setup page to use the auto AP function. 

 disable: Select it to disable the auto AP function. 

 
After using the auto AP function, you are recommended to disable the auto AP function. 

 

Rename an AP 

After enabling auto AP, click Refresh. Then, to modify the automatically found AP name, click the  
icon in the Operation column. 

Figure 30-7 Rename an AP 

 

 

Table 30-5 shows the configuration items of renaming an AP. 

Table 30-5 Configuration items of renaming an AP 

Item Description 

Old AP Name Name of the automatically discovered AP 

AP Rename Select the AP Rename check box, and type the new AP name. 

 

For the example of configuring auto AP, refer to Wireless Service. 

Batch switch 
If you do not need to modify the automatically found AP names, you can select the AP Name check box, 
and then click Transmit All AP to complete auto AP setup. 
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Configuring an AP Group 

Creating an AP group 
Select AP > AP Group from the navigation tree, click New to enter the page for creating an AP group, 
as shown in Figure 30-8. 

Figure 30-8 Create an AP group 

 

 

Table 30-6 shows the configuration items of creating an AP group. 

Table 30-6 Configuration items of creating an AP group 

Item Description 

AP Group ID AP group ID 

 

Configuring an AP group 
Select AP > AP Group from the navigation tree, find the AP group to be configured, and click the 
corresponding icon in the Operation column to enter the page for configuring an AP group, as shown in 
Figure 30-9. 

Figure 30-9 Configure an AP group 

 
 

Table 30-7 shows the items of configuring an AP group. 

Table 30-7 AP group configuration items  

Item Description 

AP Group ID Displays the ID of the selected AP group. 

Description Select this option to configure a description for the AP group. 
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Item Description 

Exist AP List 

Set the APs in the configured AP group. 
 To add the APs to the Selected AP List, click the APs to be added to the AP group, and 

click the > button in the AP List area. 
 To delete the selected APs from the AP group, select the APs to be deleted in the 

Selected AP List, and click the < button. 
The APs to be added in AP Group ID should be created by selecting AP > AP Setup first. 

 

Applying the AP group 
Select Authentication > Users from the navigation tree to apply the AP group. For the related 
configuration, refer to Authentication. 
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31  Access Service Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Wireless Local Area Networks (WLAN) have become very popular because they are very easy to setup 
and use, and have low maintenance costs. Generally, several access points (APs) can cover a building 
or an area. A WLAN is not completely wireless because the servers in the backbone are fixed. 

The WLAN solution allows you to provide the following wireless LAN services to your customers: 

 Connectivity to conventional networks or the Internet 

 WLAN client connectivity to conventional 802.3 LANs 

 Secured WLAN access with different authentication and encryption methods 

 Seamless roaming of WLAN clients in a mobility domain 

Access Service Overview 

Terminology 

Client 
A handheld computer or laptop with a wireless Network Interface Card (NIC) can be a WLAN client. 

Access point (AP) 
An AP bridges frames between wireless and wired networks. 

Access controller (AC) 
An AC can control and manage APs associated with it in a WLAN. The AC communicates with an 
authentication server for WLAN client authentication. 

SSID 
The service set identifier. A client scans all networks at first, and then selects a specific SSID to connect 
to a specific wireless network. 
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Client Access 

A client access process involves three steps: active/passive scanning, authentication and association. 

Figure 31-1 Establish a client access 

 

 

Scanning 
A wireless client can get the surrounding wireless network information in two ways, passive scanning or 
active scanning. With passive scanning, a wireless client gets wireless network information through 
listening to Beacon frames sent by surrounding APs; with active scanning, a wireless client actively 
sends a probe request frame during scanning, and gets network signals by received probe response 
frames.  

Actually, when a wireless client operates, it usually uses both passive scanning and active scanning to 
get information about surrounding wireless networks. 

1) Active scanning 

When a wireless client operates, it periodically searches for (that is, scans) surrounding wireless 
networks. Active scanning falls into two modes according to whether a specified SSID is carried in a 
probe request. 

 A client sends a probe request (with the SSID null, that is, the length of the SSID is 0.): The client 
broadcasts a probe request frame on each of the channels supported by the NIC to scan wireless 
networks. APs that receive the probe request frame send a probe response frame. The client 
associates with the AP with the strongest signal. This active scanning mode enables a client to 
know the available wireless services and then access the target wireless network. 
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Figure 31-2 Active scanning (the SSID of the probe request is null, that is, no SSID information is 
carried) 

Probe request (with no SSID)

Probe request (with no SSID)
Probe response

Probe response

 

 

When the wireless client is configured to access a specific wireless network or has already been 
connected to a wireless network, the client periodically unicasts a probe request carrying the specified 
SSID of the configured or connected wireless network. When an AP that can provide the wireless 
service with the specified SSID receives the probe request, it sends a probe response. This active 
scanning mode enables a client to access a specified wireless network. The active scanning process is 
as shown in Figure 31-3. 

Figure 31-3 Active scanning (the probe request carries the specified SSID) 

 

 

2) Passive scanning 

Passive scanning is used by clients to discover surrounding wireless networks through listening to the 
beacon frames periodically sent by an AP. APs providing wireless services periodically broadcast 
beacon frames so that the clients can get the information of the surrounding wireless networks by 
listening to beacons on each of the channels supported. Passive scanning is used by a client when it 
wants to save battery power. Typically, VoIP clients adopt the passive scanning mode. The passive 
scanning process is as shown in Figure 31-4. 
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Figure 31-4 Passive scanning 

 
 

Authentication 
To secure wireless links, a wireless client must be authenticated before accessing an AP, and only 
wireless clients passing the authentication can be associated with the AP. 802.11 links define two 
authentication mechanisms: open system authentication and shared key authentication. 

 Open system authentication 

Open system authentication is the default authentication algorithm. This is the simplest of the available 
authentication algorithms. Essentially it is a null authentication algorithm. Any client that requests 
authentication with this algorithm can become authenticated. Open system authentication is not 
required to be successful as an AP may decline to authenticate the client. Open system authentication 
involves a two-step authentication process. At the first step, the wireless client sends a request for 
authentication. At the second step, the AP determines that the wireless client passes the authentication 
and returns the result that the authentication is successful to the client. 

Figure 31-5 Open system authentication process 

 

 

 Shared key authentication 

The following figure shows a shared key authentication process. The two parties have the same shared 
key configured.  

1) The client sends an authentication request to the AP. 

2) The AP randomly generates a challenge and sends it to the client. 

3) The client uses the shared key to encrypt the challenge and sends it to the AP. 

4) The AP uses the shared key to encrypt the challenge and compares the result with that received 
from the client. If they are identical, the client passes the authentication. If not, the authentication 
fails. 
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Figure 31-6 Shared key authentication process 

 

 

Association 
A client that wants to access a wireless network via an AP must be associated with that AP. Once the 
client chooses a compatible network with a specified SSID and authenticates to an AP, it sends an 
association request frame to the AP. The AP detects the capability information carried in the association 
request frame, determines the capability supported by the wireless client, and sends an association 
response to the client to notify the client of the association result. Usually, a client can associate with 
only one AP at a time, and an association process is always initiated by the client. 

Other related frames 
1) De-authentication 

A de-authentication frame can be sent by either an AP or wireless client to break an existing link. In a 
wireless system, de-authentication can occur due to many reasons, such as: 

 Receiving an association/disassociation frame from a client which is unauthenticated. 

 Receiving a data frame from a client which is unauthenticated. 

 Receiving a PS-poll frame from a client which is unauthenticated. 

2) Dissociation 

A dissociation frame can be sent by an AP or a wireless client to break the current wireless link. In a 
wireless system, dissociation can occur due to many reasons, such as: 

 Receiving a data frame from a client which is authenticated and unassociated. 

 Receiving a PS-Poll frame from a client which is authenticated and unassociated. 

A dissociation frame is either unicast or broadcast. 

WLAN Data Security 

Compared with wired networks, WLAN networks are more susceptible to attacks because all WLAN 
devices share the same medium and thus every device can receive data from any other sending device. 
If no security service is provided, plain-text data is transmitted over the WLAN. 

To secure data transmission, 802.11 protocols provide some encryption methods to ensure that devices 
without the right key cannot read encrypted data.  

1) WEP encryption 

Wired Equivalent Privacy (WEP) was developed to protect data exchanged among authorized users in 
a wireless LAN from casual eavesdropping. WEP uses RC4 encryption for confidentiality. WEP 
encryption falls into static and dynamic encryption according to how a WEP key is generated. 
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 Static WEP encryption 

With Static WEP encryption, all clients using the same SSID must use the same encryption key. If the 
encryption key is deciphered or lost, attackers will get all encrypted data. In addition, periodical manual 
key update brings great management workload. 

 Dynamic WEP encryption 

Dynamic WEP encryption is a great improvement over static WEP encryption. With dynamic WEP 
encryption, WEP keys are negotiated between client and server through the 802.1X protocol so that 
each client is assigned a different WEP key, which can be updated periodically to further improve 
unicast frame transmission security. 

Although WEP encryption increases the difficulty of network interception and session hijacking, it still 
has weaknesses due to limitations of RC4 encryption algorithm and static key configuration. 

2) TKIP encryption 

Temporal key integrity Protocol (TKIP) and WEP both use the RC4 algorithm, but TKIP has many 
advantages over WEP, and provides more secure protection for WLAN as follows: 

 First, TKIP provides longer IVs to enhance encryption security. Compared with WEP encryption, 
TKIP encryption uses 128–bit RC4 encryption algorithm, and increases the length of IVs from 24 
bits to 48 bits. 

 Second, TKIP allows for dynamic key negotiation to avoid static key configuration. TKIP replaces a 
single static key with a base key generated by an authentication server. TKIP dynamic keys cannot 
be easily deciphered. 

 Third, TKIP offers Message Integrity Check (MIC) and countermeasures. If a packet fails the MIC, 
the data may be tampered, and the system may be attacked. If two packets fail the MIC in a certain 
period, the AP automatically takes countermeasures. It will not provide services in a certain period 
to prevent attacks.  

3) CCMP encryption 

CTR with CBC-MAC protocol (CCMP) is based on the CCM of the AES encryption algorithm. CCM 
combines CTR for confidentiality and CBC-MAC for authentication and integrity. CCM protects the 
integrity of both the MPDU Data field and selected portions of the IEEE 802.11 MPDU header. The AES 
block algorithm in CCMP uses a 128-bit key and a 128-bit block size. Similarly, CCMP contains a 
dynamic key negotiation and management method, so that each wireless client can dynamically 
negotiate a key suite, which can be updated periodically to further enhance the security of the CCMP 
encryption mechanism. During the encryption process, CCMP uses a 48-bit packet number (PN) to 
ensure that each encrypted packet uses a different PN, thus improving the security to a certain extent. 

Client Access Authentication 

After a wireless client sets up a wireless link with an AP, the wireless client is considered as having 
accessed the wireless network. However, for the security and management of the wireless network, the 
wireless client can access the network resources only after passing subsequent authentication. Among 
the authentication mechanisms, preshared key (PSK) authentication and 802.1X authentication 
accompany the dynamic key negotiation and management of the wireless link, and therefore, they are 
closely related to wireless link negotiation. However, they are not directly related to the wireless link. 

1) PSK authentication 

Both WPA wireless access and WPA2 wireless access support PSK authentication. To implement PSK 
authentication, the client and the authenticator must have the same shared key configured.  
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4-way handshake key negotiation exchanges four key packets of 802.1X to negotiate the private keys 
of the wireless link at the wireless client side and the AP side, and the preshared key is used as the 
seed key for key negotiation. During the negotiation process, the seed key is used by two parties for 
verification. The key negotiation succeeds only when the key setting is the same, that is, the wireless 
client successfully passes the PSK access authentication. Otherwise, the wireless client fails to pass 
the PSK access authentication, and the link of the wireless client will be broken. 

2) 802.1X authentication 

As a port-based access control protocol, 802.1X authenticates and controls accessing devices at the 
port level. A device connected to an 802.1X-enabled port of a WLAN access control device can access 
the resources on the WLAN only after passing authentication. 

3) MAC authentication 

MAC authentication provides a way for authenticating users based on ports and MAC addresses. For 
this authentication, the user does not need to install any client software. When the device first detects 
the MAC address of a user, it starts the authentication for the user. During the authentication process, 
the user does not need to manually input username or password. In WLAN applications, MAC 
authentication needs to get the MAC addresses of the clients in advance. Therefore, MAC 
authentication is applicable to small-scaled networks with relatively fixed users, for example, SOHO 
and small offices. 

MAC authentication falls into two modes: 

 Local MAC authentication: To use this authentication mode, you need to configure local 
usernames and passwords on the device. Usually, you can use the MAC address as the username, 
and you need to know the MAC addresses of wireless access clients in advance and configure the 
MAC addresses as usernames. When clients access the wireless network, only the clients whose 
MAC addresses exist on the device can pass the authentication. 

Figure 31-7 Local MAC authentication 

AC L2 switch AP

Client: 0009-5bcf-cce3
Permitted MAC 

address list: 
0009-5bcf-cce3
0011-9548-4007
000f-e200-00a2

Client: 0011-9548-4007

Client: 001a-9228-2d3e  
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 Remote Authentication Dial-In User Service (RADIUS) based MAC authentication: When 
RADIUS-based MAC authentication is used, the device operates as the RADIUS client, and 
cooperates with a RADIUS server to perform MAC authentication on unknown clients. Clients 
passing authentication can access the wireless network and get authorization information from the 
RADIUS server. 

Figure 31-8 RADIUS-based MAC authentication 

AC L2 switch AP Client

RADIUS server

A permitted MAC address list has been 
configured on the RADIUS server

1. Association request

2. Association response

0009-5bcf-cce3

3. The L2 switch sends 
the MAC address of the 

client to the RADIUS 
server

4. After checking the MAC 
address, if the client passes 

the authentication, the 
RADIUS server sends a 

RADIUS-ACCEPT

 

 

You can specify a domain for each wireless service, and thus MAC authentication information of 
different SSIDs is sent to different remote RADIUS servers. 

802.11n 

As the next generation wireless LAN technology, 802.11n supports both 2.4GHz and 5GHz bands. It 
provides higher-speed services to customers by using the following two methods: 

1) Increasing bandwidth: 802.11n can bond two adjacent 20-MHz channels together to form a 
40-MHz channel. During data forwarding, the two 20-MHz channels can work separately with one 
acting as the primary channel and the other acting as the secondary channel or work together as a 
40-MHz channel. This provides a simple way of doubling the data rate. 

2) Improving channel utilization through the following ways: 

 A-MPDU frame: By aggregating multiple message protocol data units (MPDUs) and using only one 
PHY header for the aggregate MPDUs (A-MPDU), the overhead in transmission and the number of 
ACK frames to be used are reduced, which thus improves channel utilization. 

 A-MSDU: Multiple MAC service data units (MSDU) can be aggregated into a single A-MSDU. This 
reduces the MAC header overhead and thus improves MAC layer forwarding efficiency and 
channel utilization. 

 Short GI function at the physical layer: This feature shortens the guard interval (GI) of 800 us in 
802.11a/g to 400 us, thus effectively reducing the channel idle time, and improving channel 
utilization. The short GI feature can increase the performance by about 10 percent. 
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Configuring Access Service 

Creating a WLAN Service 

Select Wireless Service > Access Service from the navigation tree to enter the page for configuring 
access service, as shown in Figure 31-9: 

Figure 31-9 Configure access service 

 
 

Click New to enter the page for creating a wireless service, as shown in Figure 31-10: 

Figure 31-10 Create a wireless service 

 
 

Table 31-1 shows the configuration items of creating a wireless service. 

Table 31-1 Configuration items of creating a wireless service 

Item Description 

Wireless Service Name 

Set the Service Set Identifier (SSID). 
An SSID should be as unique as possible. For security, the company name 
should not be contained in the SSID. Meanwhile, it is not recommended to use a 
long random string as the SSID, because a long random string only adds 
payload to the header field, because it only adds the Beacon frame length and 
usage complexity, without any improvement to wireless security. 

Wireless Service Type 
Select the wireless service type: 

 clear: Indicates the SSID will not be encrypted. 
 crypto: Indicates the SSID will be encrypted. 

 

Configuring Clear Type Wireless Service 

Basic configuration of clear type wireless service 
Select Wireless Service > Access Service from the navigation tree, find the clear type wireless 
service in the list, and click the corresponding  icon to enter the page for configuring wireless service, 
as shown in Figure 31-11. 
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Before configure a clear-type wireless service, disable it first and then click the corresponding  icon.  

 

Figure 31-11 Configure clear type wireless service 

 

 

Table 31-2 shows the configuration items of basic configuration of clear type wireless service. 

Table 31-2 Configuration items of basic configuration of clear type wireless service 

Item Description 

Wireless Service Displays the selected Service Set Identifier (SSID). 

VLAN (Untagged) Set the ID of the VLAN whose packets are to be sent untagged. VLAN (Untagged) 
indicates that the port sends the traffic of the VLAN with the VLAN tag removed. 

Default VLAN 
Set the default VLAN of a port. 
By default, the default VLAN of all ports is VLAN 1. You can configure the default 
VLAN as needed. 

Delete VLAN Removes the VLAN of a port. 

SSID HIDE 

 Enable: Disables the advertisement of the SSID in beacon frames.  
 Disable: Enables the advertisement of the SSID in beacon frames.  

By default, the SSID is advertised in beacon frames.  

 
 If the advertising of the SSID in beacon frames is disabled, the SSID must be 

configured for the clients to associate with the AP. 
 Disabling the advertising of the SSID in beacon frames does little good to 

wireless security. 

 

Advanced configuration of clear type wireless service 
Select Wireless Service > Access Service from the navigation tree, find the clear type wireless 
service in the list, and click the corresponding  icon to enter the page for advanced settings of clear 
type wireless service, as shown in Figure 31-12. 
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Figure 31-12 Advanced configuration of clear type wireless service 

 

 

Table 31-3 shows the configuration items of advanced configuration of clear type wireless service. 

Table 31-3 Configuration items of basic configuration of clear type wireless service 

Item Description 

Local Forwarding 

Local forwarding enables an AP to forward data frames between clients. In a 
centralized WLAN architecture, an AP transparently transmits data frames to an AC 
for processing. With the increase of clients, the forwarding load of the AC increases 
either. With local forwarding enabled, an AP, rather the AC forwards client data, 
greatly reducing the load of the AC. 

 Enable: If local forwarding is enabled, data frames from an associated station 
will be forwarded by the AP itself. 

 Disable: If local forwarding is disabled, data frames from an associated station 
will be handled by the AC. 

Local Forwarding VLAN Clients using the same SSID may belong to different VLANs. You can configure a 
local forwarding VLAN when configuring a local forwarding policy. 

Client Max Users 

Maximum number of clients of an SSID that are associated with the same radio of 
an AP. 
If the number of associated clients reaches the maximum, no clients can join the 
SSID until some associated clients disassociate for some reason. 

Management Right 
Web interface management right of online clients 

 Disable: Disables the web interface management right of online clients.  
 Enable: Enables the web interface management right of online clients. 

MAC VLAN 

 Enable: Enables the MAC VLAN feature for the wireless service.  
 Disable: Disables the MAC VLAN feature for the wireless service.  

 
Before binding an AP radio to a VLAN, a step of enabling AP-based access VLAN 
recognition, enable the MAC VLAN feature first.  

 

Security configuration of clear type wireless service 
Select Wireless Service > Access Service from the navigation tree, find the clear type wireless 
service in the list, and click the corresponding  icon to enter the page for configuring clear type 
wireless service security. 
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Figure 31-13 Security configuration of a clear-type wireless service 

 

 

Table 31-4 shows the configuration items of security configuration of clear type wireless service. 
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Table 31-4 Configuration items of security configuration of clear type wireless service 

Item Description 

Authentication 
Type For the clear type wireless service, you can select Open-System only.  

Port Mode 

 mac-authentication: Performs MAC address authentication on users. 
 mac-else-userlogin-secure: This mode is the combination of the mac-authentication and 

userlogin-secure modes, with MAC authentication having a higher priority. Upon receiving 
a non-802.1X frame, a port in this mode performs only MAC authentication; upon receiving 
an 802.1X frame, the port performs MAC authentication and then, if MAC authentication 
fails, 802.1X authentication. 

 mac-else-userlogin-secure-ext: This mode is similar to the mac-else-userlogin-secure 
mode, except that it supports multiple 802.1X and MAC authentication users on the port. 

 userlogin-secure: In this mode, port-based 802.1X authentication is performed for users; 
multiple 802.1X authenticated users can access the port, but only one user can be online. 

 userlogin-secure-or-mac: This mode is the combination of the userlogin-secure and 
mac-authentication modes, with 802.1X authentication having a higher priority. For a 
wireless user, 802.1X authentication is performed first. If 802.1X authentication fails, MAC 
authentication is performed. 

 userlogin-secure-or-mac-ext: This mode is similar to the userlogin-secure-or-mac mode, 
except that it supports multiple 802.1X and MAC authentication users on the port. 

 userlogin-secure-ext: In this mode, a port performs 802.1X authentication on users in 
macbased mode and supports multiple 802.1X users. 

 
There are multiple security modes. To remember them easily, follow these rules to understand 
part of the port security mode names: 

 userLogin indicates port-based 802.1X authentication.  
 macAddress indicates MAC address authentication.  
 The authentication mode before Else is used preferentially. If the authentication fails, the 

authentication after Else may be used depending on the protocol type of the packets to be 
authenticated.  

 The authentication mode before Or and that after Or have the same priority. The device 
determines the authentication mode according to the protocol type of the packets to be 
authenticated. For wireless users, the 802.1X authentication mode is used preferentially. 

 userLogin together with Secure indicates MAC-based 802.1X authentication.  
 A security mode with Ext allows multiple 802.1X users to pass the authentication. A 

security mode without Ext allows only one 802.1X user to pass the authentication. 

Max User Maximum number of users that can be connected to the network through a specific port. 

 

1) Configuring mac-authentication 

Figure 31-14 mac-authentication port security configuration page 
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Table 31-5 shows the mac-authentication port security configuration items.  

Table 31-5 mac-authentication port security configuration items 

Item Description 

Port Mode mac-authentication: MAC-based authentication is performed on access users.  

Max User Control the maximum number of users allowed to access the network through the port. 

MAC Authentication Select the MAC Authentication check box.  

Domain 

Select an existing domain from the drop-down list.  
The default domain is system. To create a domain, select Authentication > AAA from 
the navigation tree, click the Domain Setup tab, and type a new domain name in the 
Domain Name combo box. 
The domain selected is applicable to only the current wireless service. 

 

2) Configuring userlogin-secure/userlogin-secure-ext 

Figure 31-15 userlogin-secure/userlogin-secure-ext port security configuration page (userlogin-secure 
is taken for example) 

 

 

Table 31-6 shows the userlogin-secure/userlogin-secure-ext port security configuration items.  

Table 31-6 userlogin-secure/userlogin-secure-ext port security configuration items 

Item Description 

Port Mode 

 userlogin-secure: Perform port-based 802.1X authentication for access users. In 
this mode, multiple 802.1X authenticated users can access the port, but only one 
user can be online.  

 userlogin-secure-ext: Perform MAC-based 802.1X authentication for access users. 
In this mode, the port supports multiple 802.1X users.  

Max User Control the maximum number of users allowed to access the network through the port. 

Mandatory Domain 

Select an existing domain from the drop-down list. After a mandatory domain is 
configured, all 802.1X users accessing the port are forced to use the mandatory domain 
for authentication, authorization, and accounting.  
The default domain is system. To create a domain, select Authentication > AAA from 
the navigation tree, click the Domain Setup tab, and type a new domain name in the 
Domain Name combo box.  
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Item Description 

Authentication 
Method 

 EAP: Use the Extensible Authentication Protocol (EAP). With EAP authentication, 
the authenticator encapsulates 802.1X user information in the EAP attributes of 
RADIUS packets and sends the packets to the RADIUS server for authentication; it 
does not need to repackage the EAP packets into standard RADIUS packets for 
authentication.  

 CHAP: Use the Challenge Handshake Authentication Protocol (CHAP). By default, 
CHAP is used. CHAP transmits only user names rather than passwords over the 
network. Therefore this method is safer.  

 PAP: Use the Password Authentication Protocol (PAP). PAP transmits passwords in 
plain text.  

Handshake 

 Enable: Enable the online user handshake function so that the device can 
periodically send handshake messages to a user to check whether the user is 
online. By default, the function is enabled.  

 Disable: Disable the online user handshake function.  

Multicast Trigger 

 Enable: Enable the multicast trigger function of 802.1X to send multicast trigger 
messages to the clients periodically for initiating authentication. By default, the 
multicast trigger function is enabled.  

 Disable: Disable the 802.1X multicast trigger function.  

 
For a WLAN, the clients can actively initiate authentication, or the AP can discover 
users and trigger authentication. Therefore, the ports do not need to send 802.1X 
multicast trigger messages for initiating authentication periodically. You are 
recommended to disable the multicast trigger function in a WLAN because the multicast 
trigger messages consume bandwidth.  

 

3) Configuring the other four port security modes 

Figure 31-16 Port security configuration page for the other four security modes 
(mac-else-userlogin-secure is taken for example) 

 

 

Table 31-7 shows the configuration items of the other four security modes.  
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Table 31-7 Configuration items of the other four security modes 

Item Description 

Port Mode 

 mac-else-userlogin-secure: This mode is the combination of the 
mac-authentication and userlogin-secure modes, with MAC authentication having 
a higher priority. Upon receiving a non-802.1X frame, a port in this mode performs 
only MAC authentication; upon receiving an 802.1X frame, the port performs 
MAC authentication and then, if MAC authentication fails, 802.1X authentication. 

 mac-else-userlogin-secure-ext: This mode is similar to the 
mac-else-userlogin-secure mode, except that it supports multiple 802.1X and 
MAC authentication users on the port.  

 userlogin-secure-or-mac: This mode is the combination of the userlogin-secure 
and mac-authentication modes, with 802.1X authentication having a higher 
priority. For a wireless user, 802.1X authentication is performed first. If 802.1X 
authentication fails, MAC authentication is performed.  

 userlogin-secure-or-mac-ext: This mode is similar to the userlogin-secure-or-mac 
mode, except that it supports multiple 802.1X and MAC authentication users on 
the port.  

Max User Control the maximum number of users allowed to access the network through the 
port.  

Mandatory Domain 

Select an existing domain from the drop-down list. After a mandatory domain is 
configured, all 802.1X users accessing the port are forced to use the mandatory 
domain for authentication, authorization, and accounting.  
The default domain is system. To create a domain, select Authentication > AAA 
from the navigation tree, click the Domain Setup tab, and type a new domain name 
in the Domain Name combo box.  

Authentication Method

 EAP: Use the Extensible Authentication Protocol (EAP). With EAP authentication, 
the authenticator encapsulates 802.1X user information in the EAP attributes of 
RADIUS packets and sends the packets to the RADIUS server for authentication; 
it does not need to repackage the EAP packets into standard RADIUS packets for 
authentication.  

 CHAP: Use the Challenge Handshake Authentication Protocol (CHAP). By 
default, CHAP is used. CHAP transmits only usernames but not passwords over 
the network. Therefore this method is safer.  

 PAP: Use the Password Authentication Protocol (PAP). PAP transmits 
passwords in plain text.  

Handshake 

 Enable: Enable the online user handshake function so that the device can 
periodically send handshake messages to a user to check whether the user is 
online. By default, the function is enabled.  

 Disable: Disable the online user handshake function.  

Multicast Trigger 

 Enable: Enable the multicast trigger function of 802.1X to send multicast trigger 
messages to the clients periodically for initiating authentication. By default, the 
multicast trigger function is enabled.  

 Disable: Disable the 802.1X multicast trigger function.  

 
For a WLAN, the clients can actively initiate authentication, or the AP can discover 
users and trigger authentication. Therefore, the ports do not need to send 802.1X 
multicast trigger messages periodically for initiating authentication. You are 
recommended to disable the multicast trigger function in a WLAN because the 
multicast trigger messages consume bandwidth.  

MAC Authentication Select the MAC Authentication check box.  

Domain 

Select an existing domain from the drop-down list.  
The default domain is system. To create a domain, select Authentication > AAA 
from the navigation tree, click the Domain Setup tab, and type a new domain name 
in the Domain Name combo box. 
The domain selected is applicable to only the current wireless service. 
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Configuring Crypto Type Wireless Service 

Basic configuration of crypto type wireless service 
Select Wireless Service > Access Service from the navigation tree, find the crypto type wireless 
service in the list, and click the corresponding  icon to enter the page for configuring wireless service, 
as shown in Figure 31-17: 

Figure 31-17 Crypto type wireless service 

 

 

See Table 31-2 for the configuration items of basic configuration of crypto type wireless service. 

Advanced configuration of crypto type wireless service 
Select Wireless Service > Access Service from the navigation tree, find the crypto type wireless 
service in the list, and click the corresponding  icon to enter the page for configuring wireless service, 
as shown in Figure 31-18: 

Figure 31-18 Advanced configuration of crypto type wireless service 

 

 

Table 31-8 shows the configuration items of advanced configuration of crypto type wireless service. 
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Table 31-8 Configuration items of advanced configuration of crypto type wireless service 

Item Description 

Local Forwarding 

Local forwarding enables an AP to forward data frames between clients. In a 
centralized WLAN architecture, an AP transparently transmits data frames to an 
AC for processing. With the increase of clients, the forwarding load of the AC 
increases either. With local forwarding enabled, an AP, rather the AC, forwards 
client data, greatly reducing the load of the AC. 

 Enable: If local forwarding is enabled, data frames from an associated station 
will be forwarded by the AP itself. 

 Disable: If local forwarding is disabled, data frames from an associated station 
will be handled by the AC. 

Local Forwarding VLAN Clients using the same SSID may belong to different VLANs. You can configure a 
local forwarding VLAN when configuring a local forwarding policy. 

Client Max Users 

Maximum number of clients of an SSID that are associated with the same radio of 
an AP. 
If the number of associated clients reaches the maximum, no clients can join the 
SSID until some associated clients disassociate for some reason. 

PTK Life Time Set the pairwise transient key (PTK) lifetime. A PTK is generated through a 
four-way handshake. 

TKIP CM Time 

Set the TKIP countermeasure time. 
By default, the TKIP countermeasure time is 0 seconds, that is, the TKIP 
countermeasure policy is disabled. If the TKIP countermeasure time is set to a 
value other than 0, the TKIP countermeasure policy is enabled. 
Message integrity check (MIC) is designed to avoid hacker tampering. It uses the 
Michael algorithm and is extremely secure. When failures occur to MIC, the data 
may have been tampered, and the system may be under attack. In this case, TKIP 
will enable the countermeasure policy to prevent hackers from attacking. With the 
countermeasure policy enabled, if more than two MIC failures occur within the 
specified time, the TKIP associations are disassociated and no new associations 
are allowed within the TKIP countermeasure time.  

Management Right 
Web interface management right of online clients 

 Disable: Disables the web interface management right of online clients.  
 Enable: Enables the web interface management right of online clients. 

GTK Rekey Method 

An AC generates a group transient key (GTK) and sends the GTK to a client during 
the authentication process between an AP and the client through group key 
handshake/the 4-way handshake. The client uses the GTK to decrypt broadcast 
and multicast packets. 

 If Time is selected, the GTK will be refreshed after a specified period of time. 
 If Packet is selected, the GTK will be refreshed after a specified number of 

packets are transmitted. 
By default, the GTK rekeying method is time-based, and the interval is 86400 
seconds. 

GTK User Down Status 
Enable refreshing the GTK when some client goes offline. 
By default, the GTK is not refreshed when a client goes off-line. 

 

Security configuration of crypto type wireless service 
Select Wireless Service > Access Service from the navigation tree, find the crypto type wireless 
service in the list, and click the corresponding  icon to enter the page for configuring crypto type 
wireless service, as shown in Figure 31-19. 
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Figure 31-19 Security configuration of crypto type wireless service 

 

 

Table 31-9 shows the configuration items of security configuration of crypto type wireless service. 

Table 31-9 Configuration items of security configuration of crypto type wireless service 

Item Description 

Authentication Type 

Authentication method, which can be: 
 Open-System: Namely, no authentication. With this authentication mode 

enabled, all the clients will pass the authentication. 
 Shared-Key: The two parties need to have the same shared key configured for 

this authentication mode. You can select this option only when WEP encryption 
mode is used. 

 Open-System and Shared-Key: It indicates that you can select both 
open-system and shared-key authentication. 

 
WEP encryption can be used together with open system and shared-key 
authentication. 

 Open system authentication: When this authentication mode is used, a WEP 
key is used for encryption only. If the two parities do not use the same key, a 
wireless link can still be established, but all data will be discarded. 

 Shared-key authentication: When this authentication mode is used, a WEP key 
is used for both authentication and encryption. If the two parties do not use the 
same key, the client cannot pass the authentication, and thus cannot access 
the wireless network. 

Cipher Suite 

Encryption mechanisms supported by the wireless service, including: 
 CCMP: Encryption mechanism based on the AES encryption algorithm.  
 TKIP: Encryption mechanism based on the RC4 algorithm and dynamic key 

management.  
 CCMP and TKIP: It indicates that you can select both CCMP and TKIP 

encryption. 

Security IE 

Wireless service type (IE information carried in the beacon or probe response 
frame): 

 WPA: Wi-Fi Protected Access 
 RSN: An RSN is a security network that allows only the creation of robust 

security network associations (RSNAs). It provides greater protection than 
WEP and WPA.  

 WPA and RSN: It indicates that you can select both WPA and RSN. 
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Item Description 

Encryption 

Provide Key 
Automatically 

 Enable: A WEP key is dynamically assigned. 
 Disable: A static WEP key is used. 

By default, a static WEP key is used. 
When you enable this function, the WEP option is automatically set to wep104. 

 
 This function must be used together with 802.1X authentication. 
 With dynamic WEP encryption configured, the WEP key used to encrypt 

unicast frames is negotiated between client and server. If the WEP default key 
is configured, the WEP default key is used to encrypt multicast frames. If not, 
the device randomly generates a multicast WEP key. 

WEP 
 wep40: Indicates the WEP40 key option. 
 wep104: Indicates the WEP104 key option. 
 wep128: Indicates the WEP128 key option. 

Key ID 

 1: Key index 1. 
 2: Key index 2. 
 3: Key index 3. 
 4: Key index 4. 

There are 4 static keys in WEP. The key index can be 1, 2, 3 or 4. The key 
corresponding to the specified key index will be used for encrypting and decrypting 
broadcast and multicast frames. 

Key Length 

Key length. 
 For wep40, the key is a string of 5 alphanumeric characters or a 10-digit 

hexadecimal number. 
 For wep104, the key is a string of 13 alphanumeric characters or a 26-digit 

hexadecimal number. 
 For wep128, the key is a string of 16 alphanumeric characters or a 32-digit 

hexadecimal number. 

WEP Key Configure the WEP key. 

Port Security 

See Table 31-4. 
Parameters such as authentication type and encryption type determine the port 
mode. For details, refer to Table 31-12. 
After you select the Cipher Suite option, the following three port security modes 
are added: 

 mac and psk: MAC-based authentication must be performed on access users 
first. If MAC-based authentication succeeds, an access user has to use the 
pre-configured PSK to negotiate with the device. Access to the port is allowed 
only after the negotiation succeeds.  

 psk: An access user must use the pre-shared key (PSK) that is pre-configured 
to negotiate with the device. The access to the port is allowed only after the 
negotiation succeeds.  

 userlogin-secure-ext: Perform MAC-based 802.1X authentication for access 
users. In this mode, the port supports multiple 802.1X users. 

 

1) Configuring mac and psk 
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Figure 31-20 mac and psk port security configuration page 

 
 

Table 31-10 shows the mac and psk port security configuration items.  

Table 31-10 mac and psk port security configuration items 

Item Description 

Port Mode 

mac and psk: MAC-based authentication must be performed on access users first. If 
MAC-based authentication succeeds, an access user has to use the pre-configured 
PSK to negotiate with the device. Access to the port is allowed only after the negotiation 
succeeds.  

Max User Control the maximum number of users allowed to access the network through the port. 

MAC Authentication Select the MAC Authentication check box.  

Domain 

Select an existing domain from the drop-down list.  
The default domain is system. To create a domain, select Authentication > AAA from 
the navigation tree, click the Domain Setup tab, and type a new domain name in the 
Domain Name combo box.  
The domain selected is applicable to only the current wireless service. 

Pre-shared Key 

 pass-phrase: Enter a PSK in the form of a character string. You should enter a string 
that can be displayed and is of 8 to 63 characters.  

 raw-key: Enter a PSK in the form of a hexadecimal number. You should input a valid 
64-bit hexadecimal number.  

 

2) Configuring psk 
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Figure 31-21 psk port security configuration page 

 
 

Table 31-11 shows the psk port security configuration items.  

Table 31-11 psk port security configuration items 

Item Description 

Port Mode psk: An access user must use the pre-shared key (PSK) that is pre-configured to negotiate 
with the device. The access to the port is allowed only after the negotiation succeeds.  

Max User Control the maximum number of users allowed to access the network through the port.  

Pre-shared Key 

 pass-phrase: Enter a PSK in the form of a character string. You should enter a string 
that can be displayed and is of 8 to 63 characters.  

 raw-key: Enter a PSK in the form of a hexadecimal number. You should input a valid 
64-bit hexadecimal number.  

 

3) Configuring userlogin-secure-ext 

Perform the configurations as shown in Configuring userlogin-secure/userlogin-secure-ext.  

Security Parameter Dependencies 

In a clear-type wireless service or crypto-type wireless service, the security parameter dependencies 
are as shown in Table 31-12.  

Table 31-12 Security parameter dependencies 

Service 
type 

Authentication 
mode 

Encryption 
type Security IE

WEP 
encryption/key 

ID 
Port mode 

Clear Open-System Unavailable Unavailable Unavailable 

mac-authentication 
mac-else-userlogin-secure 
mac-else-userlogin-secure-ext
userlogin-secure 
userlogin-secure-ext 
userlogin-secure-or-mac 
userlogin-secure-or-mac-ext 
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Service 
type 

Authentication 
mode 

Encryption 
type Security IE

WEP 
encryption/key 

ID 
Port mode 

Selected Required 

WEP encryption 
is available 
The key ID can 
be 1, 2, 3, or 4 

mac and psk 
psk 
userlogin-secure-ext-or-psk 
userlogin-secure-ext Open-System 

Unselected Unavailable

WEP encryption 
is required 
The key ID can 
be 1, 2, 3 or 4 

mac-authentication 
userlogin-secure 
userlogin-secure-ext 

Shared-Key Unavailable Unavailable

WEP encryption 
is required 
The key ID can 
be 1, 2, 3 or 4 

mac-authentication 

Selected Required 

WEP encryption 
is optional 
The key ID can 
be 1, 2, 3 or 4 

mac and psk 
psk 
userlogin-secure-ext 

Crypto 

Open-System 
and Shared-Key 

Unselected Unavailable

WEP encryption 
is required 
The key ID can 
be 1, 2, 3 or 4 

mac-authentication 
userlogin-secure 
userlogin-secure-ext 

 

Binding an AP Radio to a Wireless Service 

Binding an AP radio to a wireless service 
Select Wireless Service > Access Service from the navigation tree, find the wireless service to be 
bound, and click the corresponding binding icon on the right to enter the page for binding an AP radio to 
a wireless service, as shown in Figure 31-22: 

Figure 31-22 Bind an AP radio to a wireless service 

 

 

Select the AP radio to be bound, and click Bind. 
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Binding an AP radio to a VLAN 
Traffic of different services is identified by SSIDs. Locations are identified by APs. Users at different 
locations access different services. For a user roaming between different APs, you can provide services 
for the user based on its access AP. The detailed requirements are as follows: 

 Users with the same SSID but accessing through different APs can be assigned to different VLANs 
based on their configurations. 

 A roaming user always belongs to the same VLAN.  

 For a user roaming between ACs, if the local AC does not have a VLAN-interface, the user needs 
to use an HA in the roaming group for forwarding packets to avoid packet loss. 

Figure 31-23 Schematic diagram for WLAN support for AP-based access VLAN recognition 
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As shown in Figure 31-23, Client 1 goes online through AP 1 and belongs to VLAN 3. When Client 1 
roams within an AC or between ACs, Client 1 always belongs to VLAN 3. When Client 1 roams between 
ACs, if FA, that is, AC 2, has VLAN-interface 3, AC 2 forwards packets from Client 1. Otherwise, packets 
from Client 1 are sent to HA (AC 1) through the data tunnel and then HA forwards these packets.  

Client 2 goes online through AP 4 and belongs to VLAN 2. That is, a client going online through a 
different AP is assigned to a different VLAN. 

Select Wireless Service > Access Service from the navigation tree, find the wireless service to be 
bound in the list, and click the corresponding binding icon on the right to enter the AP radio setup page, 
as shown in Figure 31-22. 

Select the check box corresponding to the AP radio mode to be bound, input the VLAN to be bound in 
the Binding VLAN input box, and then click Bind to finish the binding VLAN operation.  
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Displaying the Detailed Information of a Wireless Service 

Displaying the detailed information of a clear-type wireless service 
Select Wireless Service > Access Service from the navigation tree to enter the service configuration 
page, and click the specified clear-type wireless service to see its detailed information, as shown in 
Figure 31-24.  

Figure 31-24 Display the detailed information of a clear-type wireless service 

 

 

Table 31-13 Clear-type wireless service output description 

Field Description 

Service Template Number Current service template number 

SSID Service set identifier 

Binding Interface  Name of the WLAN-ESS interface bound with the service template 

Service Template Type Service template type 

Authentication Method 
Type of authentication used 
A clear-type wireless service can use only Open System authentication.  

SSID-hide 
 Disable: Indicates that SSID advertisement is enabled.  
 Enable: Indicates that SSID advertisement is disabled, that is, the AP 

does not advertise the SSID in the beacon frames.  

Bridge Mode 

Forwarding mode, which can be: 
 Local Forwarding: Uses the local forwarding mode. 
 Remote Forwarding: Uses the remote forwarding mode, that is, uses the 

AC to forward data.  

Service Template Status 
Service template status, which can be: 

 Enable: Indicates that the wireless service is enabled.  
 Disable: Indicates that the wireless service is disabled.  

Maximum clients per BSS Maximum number of associated clients per BSS 
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Displaying the detailed information of a crypto-type wireless service 
Select Wireless Service > Access Service from the navigation tree to enter the service configuration 
page, and click a crypto-type wireless service to see its detailed information, as shown in Figure 31-25. 

Figure 31-25 Display the detailed information of a crypto-type wireless service 

 
 

Table 31-14 Crypto-type wireless service output description 

Field Description 

Service Template Number Current service template number 

SSID Service set identifier 

Binding Interface  Name of WLAN-ESS the interface bound with the service template 

Service Template Type Service template type 

Security IE Security IE, which can be WPA or RSN 

Authentication Method Type of authentication used, which can be Open System or Shared Key 

SSID-hide 
 Disable: Indicates that SSID advertisement is enabled.  
 Enable: Indicates that SSID advertisement is disabled, that is, the AP 

does not advertise the SSID in the beacon frames. 

Cipher Suite Cipher suite, which can be CCMP, TKIP, WEP40, WEP104, or WEP128 

TKIP Countermeasure Time(s) TKIP MIC failure holdtime, in seconds 

PTK Life Time(s) PTK lifetime in seconds 

GTK Rekey GTK rekey configured 
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Field Description 

GTK Rekey Method 
GTK rekey method configured, which can be: 

 Time-based, which displays the GTK rekey time in seconds 
 Packet-based, which displays the number of packets 

GTK Rekey Time Time for GTK rekey in seconds 

Bridge Mode 

Forwarding mode, which can be: 
 Local Forwarding: Uses the local forwarding mode 
 Remote Forwarding: Uses the remote forwarding mode, that is, uses 

the AC to forward data. 

Service Template Status 
Service template status, which can be: 

 Enable: Indicates that the wireless service is enabled.  
 Disable: Indicates that the wireless service is disabled. 

Maximum clients per BSS Maximum number of associated clients per BSS 

 

Wireless Access Configuration Examples 

Wireless Service Configuration Example 

Network requirement 
As shown in the following figure, an AC and an AP (serial ID 210235A29G007C000020) is connected 
through a Layer 2 switch. 

It is required to: 

 Manually type in the serial ID 

 Adopt 802.11g radio mode 

 Adopt simple text authentication 

Figure 31-26 WLAN service configuration 

 

 

Configuration procedure 
1) Configure the AP 

# Create an AP 

Select AP > AP Setup from the navigation tree, and click Create to enter the page for creating an AP, 
as shown in Figure 31-27: 
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Figure 31-27 Create an AP 

 
 

 Set the AP name to ap. 

 Select the AP model WA2220X-AG. 

 Select the serial ID as manual, and type the serial ID of the AP. 

 Click Apply. 

2) Configure wireless service 

# Create a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click New to enter the page 
for creating a wireless service, as shown in Figure 31-28: 

Figure 31-28 Create a wireless service 

 

 

 Set the service name to service1. 

 Select the wireless service type clear. 

 Click Apply. 

# Enable wireless service 

Select Wireless Service > Access Service from the navigation tree to enter the page for enabling 
wireless service, as shown in Figure 31-29: 



 

31-29 

Figure 31-29 Enable wireless service 

 

 

 Set the service1 check box. 

 Click Enable. 

3) Bind an AP radio to a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click Bind at the right side of 
the wireless service service1 to enter the page for binding an AP radio, as shown in Figure 31-30: 

Figure 31-30 Bind an AP radio 

 

 

 Select the check box before ap with radio type being 802.11g. 

 Click Bind. 

4) Enable 802.11g radio 

Select Radio > Radio from the navigation tree to enter the radio setup page, as shown in Figure 31-31: 

Figure 31-31 Enable 802.11g radio 

 

 

 Select the check box before wa2200 with the radio mode being 802.11g. 

 Click Enable. 
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Configuration verification 
 After enabling the radio, select AP > AP Setup from the navigation tree, and you can see the AP is 

in the Run status. 

 Select Summary > Client from the navigation tree to enter the page as shown in Figure 31-32 to 
view the online clients. 

Figure 31-32 View the online clients 

 

 

 

For an AC to get the IP address of a client, enable ARP snooping in system view. By default, ARP 
snooping is disabled, and IP address 0.0.0.0 is displayed in the IP Address column.  

 

Configuration guidelines 
Note the following when configuring a wireless service: 

 Select a correct district code. 

 Remove the binding between the wireless service and the AP before deleting a wireless service. 

 If an AP cannot be in the run state, verify that the AP and AC can communicate at Layer 3. 

Auto AP Configuration Example 

Network requirement 
As shown in Figure 31-33, an AC is connected to an AP through a Layer 2 switch. 

It is required to: 

 Use the auto AP function 

 Adopt 802.11g radio mode 

 Adopt simple text authentication 

Figure 31-33 Diagram for auto AP configuration 

 

 

Configuration procedure 
1) Configure the AP 

# Create an AP 
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Select AP > AP Setup from the navigation tree, and click Create to enter the page for creating an AP, 
as shown in Figure 31-34: 

Figure 31-34 Create an AP 

 
 

 Set the AP name to ap. 

 Select the AP model WA2220X-AG. 

 Select the serial ID as auto. 

 Click Apply. 

2) Configure wireless service 

# Create a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click New to enter the page 
for creating a wireless service, as shown in Figure 31-35: 

Figure 31-35 Create a wireless service 

 

 

 Set the service name to service1. 

 Select the wireless service type clear. 

 Click Apply. 

# Enable wireless service 

Select Wireless Service > Access Service from the navigation tree to enter the page for enabling 
wireless service, as shown in Figure 31-36: 
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Figure 31-36 Enable wireless service 

 

 

 Select the service1 check box. 

 Click Enable. 

3) Bind an AP radio to a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click Bind at the right side of 
the wireless service service1 to enter the page for binding an AP radio, as shown in Figure 31-37: 

Figure 31-37 Bind an AP radio 

 

 

 Select the check box before ap with radio mode 802.11g. 

 Click Bind. 

Select AP > AP Setup from the navigation tree to the see the AP is in IDLE state. 

Figure 31-38 AP status before auto AP is enabled 

 
 

4) Enable auto AP 

Select AP > Auto AP from the navigation tree to enter the page for configuring auto AP, as shown in 
Figure 31-39: 
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Figure 31-39 Configure auto AP 

 

 

 Select enable. 

 Click Apply. 

After enabling auto AP, you can view the automatically found AP (ap_001) by clicking Refresh. 

Figure 31-40 View the automatically found AP 

 

 

5) Rename an automatically found AP 

 If you do not need to modify the automatically found AP name, you can select the ap_001 check 
box, and then click Transmit All AP. 

 To modify the automatically found AP name, select the Auto AP tab, click the  icon in the 
Operation column to modify the AP name, and then click Apply, as shown in Figure 31-41: 

Figure 31-41 Modify the AP name 

 

 

Select AP > AP Setup from the navigation tree, and you can view the AP with the name modified. 
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Figure 31-42 Display AP 

 

 

6) Enable 802.11g radio 

Select Radio > Radio from the navigation tree, find the AP with the corresponding radio mode and 
select the check box before the AP, and then click Enable. 

Configuration verification 
 Select Summary > Client from the navigation tree to enter the page as shown in Figure 31-43 to 

view the online clients. 

Figure 31-43 View the online clients 

 

 

 

For an AC to get the IP address of a client, enable ARP snooping in system view. By default, ARP 
snooping is disabled, and IP address 0.0.0.0 is displayed in the IP Address column.  

 

 The client can be pinged successfully on the AC. 

Configuration guidelines 
Note the following when configuring an AP: 

 Select a correct district code. 

 Remove the binding between the wireless service and the AP before deleting a wireless service. 

 Select the AP (AP 1 in the example) with working mode having been switched when enabling the 
AP radio, rather than the AP in the auto AP template (ap in the example). 

 If you enable the radio of the AP in an auto AP template first, radios of all the automatically found 
APs are enabled. 
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802.11n Configuration Example 

Network requirement 
As shown in Figure 31-44, an AC is connected to an L2 switch. Configure the AP to support 802.11n. 

Figure 31-44 802.11n network diagram 

 

 

Configuration procedure 
# Create an AP 

Select AP > AP Setup from the navigation tree, and click Create to enter the page for creating an AP. 

 Set the AP name to 11nap. 

 Select the AP model WA22610E-AGN. 

 Select the serial ID as manual, and type in the serial ID of the AP. 

 Click Apply. 

# Create a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click New to enter the page 
for creating a wireless service. 

 Set the service name to 11nservice. 

 Select the wireless service type clear. 

 Click Apply. 

# Enable wireless service 

Select Wireless Service > Access Service from the navigation tree to enter the page for enabling 
wireless service. 

 Set the 11nservice check box. 

 Click Enable. 

# Bind an AP radio 

Select Wireless Service > Access Service from the navigation tree, and click Bind to enter the page 
for binding an AP radio. 

 Select the 11nap check box. 

 Click Bind. 

# Enable 802.11n(2.4GHZ) radio.  

Select Radio > Radio from the navigation tree to enter the page for setting radio, find the AP with the 
corresponding radio mode and select the 11nap check box before it, and then click Enable. 

Configuration verification 
Select Summary > Client from the navigation tree to enter the page as shown in Figure 31-45 to view 
the online clients. 
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Figure 31-45 View the online clients 

 

 

 

For an AC to get the IP address of a client, enable ARP snooping in system view. By default, ARP 
snooping is disabled, and IP address 0.0.0.0 is displayed in the IP Address column.  

 

0014-6c8a-43ff is an 802.11g user, and 001c-f0bf-9c92 is an 802.11n user. In this example, both of the 
two users can access the WLAN network because there is no limit on the user type. If you enable client 
802.11n only, only 001c-f0bf-9c92 can access the WLAN network. 

Configuration guidelines 
Note the following when configuring 802.11n: 

 Select Radio > Radio from the navigation tree, select the AP to be configured, and click Apply to 
enter the page for configuring a radio. Then you can modify the 802.11n parameters, including 
bandwidth mode, A-MSDU, A-MPDU, short GI and whether 802.11n clients are allowed. 

 Select Radio > Rate from the navigation tree to set 802.11n rates. 

WPA-PSK Authentication Configuration Example 

Network requirements 
As shown in Figure 31-46, it is required that the client access the wireless network by passing 
WPA-PSK authentication. The WPA-PSK key configuration on the client is the same as that on the AP, 
that is, 12345678. 

Figure 31-46 Diagram for WPA-PSK authentication 

 

 

Configuration procedure 
1) Configure the AP 

# Create an AP 

Select AP > AP Setup from the navigation tree, and click Create to enter the page for creating an AP, 
as shown in Figure 31-47: 
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Figure 31-47 Create an AP 

 
 

 Set the AP name to ap. 

 Select the AP model WA2220X-AG. 

 Select the serial ID as manual, and type the AP serial ID. 

 Click Apply. 

2) Configure wireless service 

# Create a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click New to enter the page 
for creating a wireless service, as shown in Figure 31-48: 

Figure 31-48 Create a wireless service 

 

 

 Set the service name to psk. 

 Select the wireless service type crypto. 

 Click Apply. 

# Configure wireless service. 

After you create a wireless service, you will enter the wireless service configuration page. You need to 
perform security setup when configuring PSK authentication, as shown in Figure 31-49: 
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Figure 31-49 Security setup 

 

 

 Select the Open-System from the Authentication Type drop-down list. 

 Select Cipher Suite check box, select CCMP and TKIP (select an encryption type as needed), 
and then select WPA from the Security IE drop-down list. 

 Select the Port Set check box, and select psk from the Port Mode drop-down list. 

 Select pass-phrase from the Preshared Key drop-down list, and type key ID 12345678. 

 Click Apply. 

# Enable wireless service. 

Select Wireless Service > Access Service from the navigation tree to enter the page for enabling 
wireless service, as shown in Figure 31-50: 

Figure 31-50 Enable wireless service 

 

 

 Select the psk[Bind] check box. 

 Click Enable. 

3) Bind an AP radio to a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click Bind at the right side of 
the wireless service psk to enter the page for binding an AP radio, as shown in Figure 31-51: 
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Figure 31-51 Bind an AP radio 

 

 

 Select the check box before ap with radio mode 802.11g. 

 Click Bind. 

4) Enable 802.11g radio 

Select Radio > Radio from the navigation tree. 

Figure 31-52 Enable 802.11g radio 

 

 

 Find the AP with the corresponding radio mode and select the ap check box before 802.11g. 

 Click Enable. 

Configuration verification 
The same PSK pre-shared key is configured on the client. The client can successfully associate with the 
AP and can access the WLAN network.  

Local MAC Authentication Configuration Example 

Network requirements 
AC is connected to AP through a Layer 2 switch, and they are in the same network. It is required to 
perform MAC authentication on the client. 

Figure 31-53 Diagram for local MAC authentication 
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Configuration procedure 
1) Configure the AP 

# Create an AP 

Select AP > AP Setup from the navigation tree, and click Create to enter the page for creating an AP, 
as shown in Figure 31-54: 

Figure 31-54 Create an AP 

 
 

 Set the AP name to ap. 

 Select the AP model WA2220X-AG. 

 Select the serial ID as manual, and type the AP serial ID. 

 Click Apply. 

2) Configure wireless service 

# Create a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click New to enter the page 
for creating a wireless service, as shown in Figure 31-55: 

Figure 31-55 Create a wireless service 

 
 

 Set the service name to mac-auth. 

 Select the wireless service type clear. 

 Click Apply. 

# Configure wireless service 

After you have created a wireless service, you will enter the wireless service configuration page. You 
need to perform security setup when configuring MAC authentication, as shown in Figure 31-56: 
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Figure 31-56 Security setup 

 

 

 Select the Open-System from the Authentication Type drop-down list. 

 Select the Port Set check box, and select mac-authentication from the Port Mode drop-down list. 

 Select MAC Authentication check box, and select system from the Domain drop-down list (you 
can select Authentication > AAA from the navigation tree, click the Domain tab, and create a 
domain in the Domain drop-down combo box). 

 Click Apply. 

# Enable wireless service 

Select Wireless Service > Access Service from the navigation tree to enter the page for enabling 
wireless service, as shown in Figure 31-57: 

Figure 31-57 Enable wireless service 

 

 

 Select the mac-auth check box. 

 Click Enable. 

3) Configure a MAC authentication list 

Select Wireless Service > Access Service from the navigation tree, and click MAC Authentication 
List to enter the page for configuring a MAC authentication list, as shown in Figure 31-58: 
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Figure 31-58 Add a MAC authentication list 

 

 

 Add a local user in the MAC Address box. 00-14-6c-8a-43-ff is used in this example. 

 Click Add. 

4) Bind an AP radio to a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click Bind at the right side of 
the wireless service service1 to enter the page for binding an AP radio, as shown in Figure 31-59: 

Figure 31-59 Bind an AP radio 

 

 

 Select the check box before ap with radio mode 802.11g. 

 Click Bind. 

5) Enable 802.11g radio 

Select Radio > Radio from the navigation tree to enter the radio setup page, as shown in Figure 31-60. 

Figure 31-60 Enable 802.11g radio 

 

 

 Find the AP with the corresponding radio mode and select the ap 802.11g check box. 

 Click Enable 
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Configuration verification 
If the MAC address of the client is in the MAC authentication list, the client can pass authentication and 
access the WLAN network. 

Dynamic WEP Encryption-802.1X Authentication Configuration Example 

Network requirements 
It is required to perform dynamic WEP encryption-802.1X authentication on the client. More specifically, 

 Use the CAMS or iMC as a RADIUS server for AAA. On the RADIUS server, configure the client’s 
username as user, password as dot1x, and shared key as expert. The IP address of the RADIUS 
server is 10.18.1.88. 

 On the AC, configure the shared key as expert, and configure the AC to remove the domain name 
of a username before sending it to the RADIUS server. The IP address of the AC is 10.18.1.1. 

Figure 31-61 Network diagram for dynamic WEP encryption-802.1X authentication  

 
 

Configuration procedure 
1) Configure the IP address for the AC 

In the Network > VLAN page, create a VLAN on the AC, and in the Device > Interface Management 
page, configure the VLAN interface. 

2) Configure a RADIUS scheme 

# Configure the RADIUS authentication server. 

From the navigation tree, select Authentication > RADIUS. The RADIUS server configuration page 
appears. Perform the following configuration, as shown in Figure 31-62. 

Figure 31-62 Configure the RADIUS authentication server 
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 Select Authentication Server as the server type.  

 Enter 10.18.1.88 as the IP address of the primary authentication server 

 Enter 1812 as the UDP port of the primary authentication server. 

 Select active as the primary server status. 

 Click Apply.  

# Configure the RADIUS accounting server. 

Perform the following configuration, as shown in Figure 31-63. 

Figure 31-63 Configure the RADIUS accounting server 

 

 

 Select Accounting Server as the server type.  

 Enter 10.18.1.88 as the IP address of the primary accounting server. 

 Enter 1813 as the UDP port of the primary accounting server. 

 Select active as the primary server status. 

 Click Apply.  

# Configure the parameters for communication between the AC and the RADIUS servers. 

 Select the RADIUS Setup tab and configure the parameters, as shown in Figure 31-64. 
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Figure 31-64 Configure RADIUS parameters 

 
 

 Select extended as the server type. 

 Select the Authentication Server Shared Key option and enter expert in the text box. 

 Enter expert in the Confirm Authentication Shared Key text box. 

 Select the Accounting Server Shared Key option and enter expert in the text box. 

 Enter expert in the Confirm Accounting Shared Key text box. 

 Select without-domain for Username Format.  

 Click Apply. 

3) Configure AAA 

# Create an ISP domain. 

 From the navigation tree, select Authentication > AAA. The domain setup page appears. In this 
example, the default domain system is used (you can create and configure a new ISP domain as 
needed). 

# Configure the AAA authentication method for the ISP domain. 

 Select the Authentication tab, and perform the following configuration, as shown in Figure 31-65.  
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Figure 31-65 Configure the AAA authentication method for the ISP domain 

 
 

 Select the ISP domain name system. 

 Select the LAN-access AuthN checkbox and then select RADIUS as the authentication mode. 

 Select system from the Name drop-down list to use it as the authentication scheme.  

 Click Apply. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

# Configure the AAA authorization method for the ISP domain. 

 Select the Authorization tab, and perform the following configuration, as shown in Figure 31-66.  

Figure 31-66 Configure the AAA authorization method for the ISP domain 

 
 

 Select the domain name system. 

 Select the LAN-access AuthZ checkbox and then select RADIUS as the authorization mode. 

 Select system from the Name drop-down list to use it as the authorization scheme. 

 Click Apply. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

# Configure the AAA accounting method for the ISP domain, and enable Accounting Optional. 

 Select the Accounting tab, and perform the following configuration, as shown in Figure 31-67.  
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Figure 31-67 Configure the AAA accounting method for the ISP domain 

 

 

 Select the domain name system. 

 Select the Accounting Optional checkbox and then select Enable. 

 Select the LAN-access Accounting checkbox and then select RADIUS as the accounting mode. 

 Select system from the Name drop-down list to use it as the accounting scheme. 

 Click Apply. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

4) Configure the AP 

# Create the AP. 

Select AP > AP Setup from the navigation tree, and then click Add to enter the AP Setup page, as 
shown in Figure 31-68. 

Figure 31-68 AP setup 

 
 

 Set the AP name to ap. 

 Select the AP model WA2220-AG. 

 Select the serial ID as manual, and type the AP serial ID. 

 Click Apply. 

5) Configure wireless service 

# Create a wireless service. 
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Select Wireless Service > Access Service from the navigation tree, and click Add to enter the page 
for creating a wireless service, as shown in Figure 31-69: 

Figure 31-69 Create a wireless service 

 
 

 Set the service name as dot1x. 

 Select the wireless service type crypto. 

 Click Apply. 

# Configure 802.1X authentication. 

After you create a wireless service, the wireless service configuration page appears. Then you can 
configure 802.1X authentication on the Security Setup area, as shown in Figure 31-70: 

Figure 31-70 Security setup 

 
 

 Select Open-System from the Authentication Type drop-down list. 

 Select Encryption, and select Enable from the Provide Key Automatically drop-down list. 

 Select the Cipher Suite option, select CCMP from the Cipher Suite drop-down list, and select 
WPA2 from the Security IE drop-down list. 

 Select the Port Set option, and select userlogin-secure-ext from the Port Mode drop-down list. 

 Select system from the Mandatory Domain drop-down list. 

 Select EAP from the Authentication Method drop-down list. 

 You are recommended to disable Handshake and Multicast Trigger. 
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 Click Apply. 

# Enable the wireless service 

Select Wireless Service > Access Service from the navigation tree to enter the page as shown in the 
following figure. 

Figure 31-71 Enable the wireless service 

 

 

 Select the dot1x option. 

 Click Enable. 

6) Bind an AP radio to the wireless service.  

Select Wireless Service > Access Service from the navigation tree, click the binding icon on the right 
of wireless service dot1x to enter the page for binding an AP radio to a wireless service, as shown in 
Figure 31-72: 

Figure 31-72 Bind an AP radio to a wireless service 

 
 

 Select the check box of the AP with the radio mode 802.11g. 

 Click Bind. 

7) Enable 802.11g radio. 

Select Radio > Radio from the navigation tree to enter the Radio page, as shown in Figure 31-73. 



 

31-50 

Figure 31-73 Enable 802.11g radio 

 

 

 Find the AP whose radio is to be enabled, and select the corresponding check box. 

 Click Enable. 

8) Configure the RADIUS server (iMC) 

 

 

The following takes the iMC (iMC PLAT 3.20-R2602 and iMC UAM 3.60-E6102) as an example to 
illustrate the basic configuration of the RADIUS server. 

 

# Add an access device. 

Log in to the iMC management platform. Select the Service tab, and then select Access Service > 
Access Device from the navigation tree to enter the access device configuration page. Click Add on 
the page to enter the configuration page as shown in Figure 31-74: 

 Input expert as the Shared Key. 

 Add ports 1812, and 1813 for Authentication Port and Accounting Port respectively. 

 Select LAN Access Service for Service Type. 

 Select H3C for Access Device Type. 

 Select or manually add the access device (the AC) with the IP address 10.18.1.1. 
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Figure 31-74 Add access device 

 

 

# Add a service. 

Select the Service tab, and then select Access Service > Service Configuration from the navigation 
tree to enter the add service page. Then click Add on the page to enter the following configuration page. 

 Set the service name as dot1x. 

 Set the Certificate Type to EAP-PEAP AuthN and the Certificate Sub Type to MS-CHAPV2 
AuthN. 
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Figure 31-75 Add service 

 

 

# Add an account. 

Select the User tab, and select User > All Access Users from the navigation tree to enter the user 
page. Then, click Add on the page to enter the page shown in Figure 31-76. 

 Enter username user. 

 Set the account name as user and password as dot1x. 

 Select the service dot1x. 

Figure 31-76 Add account 

 
 

9) Configure the wireless card 
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Double click the  icon at the bottom right corner of your desktop. The Wireless Network 

Connection Status window appears. Click Properties. The Wireless Network window appears. On 
this window, click Add. Select the Association tab, and type dot1x in the Network name (SSID) input 
box. Make sure that you have selected The key is provided for me automatically, as shown in Figure 
31-77. 

Figure 31-77 Configure the wireless card (I) 

 
 

Then, in the Authentication tab, select Protected EAP (PEAP) from the EAP type drop-down list, and 
click Properties. In the popup window, clear Validate server certificate, and click Configure. In the 
popup dialog box, clear Automatically use my Windows logon name and password (and domain if 
any), and then click OK, as shown in Figure 31-78 and Figure 31-79. 
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Figure 31-78 Configure the wireless card (II) 
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Figure 31-79 Configure the wireless card (III) 

 
 

Configuration verification 
 After the user inputs username user and password dot1x in the popup dialog box, the client can 

associate with the AP and access the WLAN. 

 You can view the online clients by selecting Summary > Client. 
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32  Mesh Service Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Different from a traditional WLAN, a WLAN mesh network allows for wireless connections between APs, 
making the WLAN more mobile and flexible. Moreover, multi-hop wireless links can be established 
between APs. From the perspective of end users, a WLAN mesh network has no difference from a 
traditional WLAN. 

Mesh Service Overview 

Basic Concepts in WLAN Mesh 

Figure 32-1 Typical WLAN mesh network 
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As shown in Figure 32-1, the concepts involved in WLAN mesh are described below. 

Concept Description 

Access controller (AC) A device that controls and manages all the APs in the WLAN.  

Mesh point (MP) A wireless AP that connects to a mesh portal point (MPP) through a 
wireless connection but cannot have any client attached 

Mesh access point (MAP) An AP providing the mesh service and the access service concurrently 

Mesh portal point (MPP) A wireless AP that connects to an AC through a wired connection 

Mesh link A wireless link between MPs 

 

Advantages of WLAN Mesh 

The WLAN mesh technology allows operators to easily deploy wireless networks anywhere and 
anytime. WLAN mesh has the following advantages: 

1) High performance/price ratio 

In a mesh network, only the MPPs need to connect to a wired network. In this way, the dependency on 
the wired network is reduced to the minimum extent, and the investment in wired devices, cabling, and 
installation is greatly reduced.  

2) Excellent scalability 

In a mesh network, the APs can automatically discover each other and initiate wireless link setup. To 
add new APs to the mesh network, you just need to install these new APs and perform the related 
configurations on them.  

3) Fast deployment 

Since only the MPPs need to connect to a wired network, WLAN mesh greatly reduces the network 
deployment time.  

4) Various application scenarios 

The mesh network is applicable to enterprise, office, and campus networks, which are common 
application scenarios of traditional WLANs, and also applicable to large-sized warehouse, port, MAN, 
railway transportation, and crisis communication networks.  

5) High reliability 

In a traditional WLAN, when the wired upstream link of an AP fails, all clients associated with the AP 
cannot access the WLAN. Comparatively, in a mesh network, all APs are fullly meshed. There are 
multiple available wireless links for a mesh AP to reach a portal node in the wired network, thus avoiding 
single point failure effectively.  

Deployment Scenarios 

This section covers deployment scenarios of WLAN mesh, which come into two categories: one is for 
subway networking and the other is for normal networking.  
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Normal WLAN mesh deployment 
1) Normal FIT MP scenario 

Figure 32-2 Normal FIT MP scenario 

 

 

As shown in Figure 32-2, two mesh networks are controlled by the same AC. At least one MPP in a 
mesh has wired connectivity with the AC. When an MP comes up, it scans the network and forms 
temporary connections with all available MPs in its vicinity. Such temporary connections allow the MP to 
connect to the AC for downloading its configurations. After downloading its configurations from the AC, 
the MP will establish secure connections with neighbors sharing the same preshared key.  

2) One FIT MP with two radios, each on a different mesh 
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Figure 32-3 Two radios on different meshes 
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As shown in Figure 32-3, to avoid cross-interruption between Mesh 1 and Mesh 2, you can configure 
two radios for an MP, each of which is present in a different mesh network. The only constraint is that 
both meshes have to be managed by the same AC. 

3) One FIT MP with two radios on the same mesh 

As shown in Figure 32-4, Radio 1 of MP 1 joins the mesh through the MPP. In this case, only Radio 1 
can provide access for downstream MPs. Radio 2 cannot automatically access the mesh and provide 
the mesh service.  

Figure 32-4 Two radios on different meshes 

 

 

If the MP supports three radios, in this case, you can configure Radio 1 as the uplink interface, Radio 2 
as the downlink interface, and Radio 3 as the multi-beam antenna. To utilize the dual-radio resources on 
the MP, you can establish the network as shown in Figure 32-5. In such a network, when Radio 1 of MP 
1 accesses the mesh, Radio 2 of MP 1 also automatically joins the mesh. In this network, you should 
apply radios joining the same mesh network to the same mesh service. For detailed configuration, refer 
to Tri-Radio Mesh Configuration Example. 
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Figure 32-5 Two radios on the same mesh 
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If the MP supports three radios, in this case, you can configure Radio 1 as the uplink interface, Radio 2 
as the downlink interface, and Radio 3 as the multi-beam antenna. For detailed configuration, refer to 
Tri-Radio Mesh Configuration Example.  

Subway WLAN mesh deployment 
Subway is an important traffic means for a modern city. In a subway system, control information needs 
to be sent to trains to effectively manage trains and provide various services to customers.  

As shown in Figure 32-6, a subway WLAN mesh solution has fit MPs deployed both on the train and 
along the rail, which are managed by the same AC. A train MP continuously scans new rail MPs, and 
sets up backup links with the multiple rail MPs with the best signal quality. The active mesh link is used 
for data transmission, and the backup mesh link is used as a backup.  

Figure 32-6 Subway deployment of mesh 
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The subway WLAN mesh deployment is based on the Mobile Link Switch Protocol (MLSP), which is a 
proprietary protocol developed by H3C for high-speed link switch with zero packet loss during train 
movement. H3C has adopted new IEEE standard 802.11s as the underlying protocol for link formation 
and communication between mobile radio (MR) and wayside AP. Train MPs are not required to act as 
authenticators.  

WLAN Mesh Security 

As a WLAN network uses air as the communication medium, it is very vulnerable to malicious attacks. 
In a mesh network, a wireless connection passes through multiple hops, and thus a mesh network is 
more vulnerable to malicious attacks. Therefore, WLAN mesh network security becomes an essential 
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part of WLAN mesh networks. Security involves encryption algorithms and distribution and 
management of keys. Currently, PSK + CCMP combination is used for securing mesh networks.  

Mobile Link Switch Protocol 

At any given time, an active link should be available between a rail MP and a train MP for data 
communication. MLSP was developed to create and break links during train movement.  

As shown in Figure 32-7, when the train is moving, it needs to break the existing active link with rail MP 
2 and create a new active link with another rail MP.  

Figure 32-7 Diagram for MLSP 
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 Active Link: Logical link through which all data communication from/to a train MP happens. 

 Dormant Link: Logical link over which no data transfer happens, but it satisfies all the criteria for 
becoming an active link. 

MLSP advantages 
1) MLSP ensures that the link switch time is less than 30 ms. 

2) MLSP works well even if the devices get saturated at high power level. 

3) MLSP achieves zero packet loss during link switch.  

Operation of MLSP 
MLSP establishes multiple links at any given time between a train MP and multiple rail MPs to provide 
link redundancy, thus ensuring high performance and good robustness for the network.  

The following four parameters are considered by MLSP for link switch. Based on the deployment, all 
these parameters are tunable to achieve best results. 

 Link formation RSSI/link hold RSSI: This is the minimum RSSI to allow a link to be formed and held. 
Therefore, the minimum RSSI must be ensured at any given point in the tunnel. Otherwise, the 
error rate can be very high. 

 Link switch margin: If the RSSI of the new link is greater than that of the current active link by the 
link switch margin, active link switch will happen. This mechanism is used to avoid frequent link 
switch. 

 Link hold time: An active link remains up within the link hold time, even if the link switch margin is 
reached. This mechanism is used to avoid frequent link switch. 
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 Link saturation RSSI: This is the upper limit of RSSI on the active link. If the value is reached, link 
switch will happen.  

Formation of dormant links 
A train MP performs active scanning to find neighboring rail MPs by sending probe requests at a very 
high rate. Based on probe responses received, the train MP forms a neighbor table.  

After that, the train MP creates dormant links with rail MPs that have an RSSI value greater than the link 
formation RSSI. 

Selection of active link 
A train MP selects the active link from dormant links based on the following rules: 

1) If no dormant link is available, the active link can not be formed. 

2) Active link switch will not happen within the link hold time, except the following two conditions: 

 Condition 1: The active link RSSI exceeds the link saturation RSSI.  

 Condition 2: The active link RSSI is below the link hold RSSI.  

3) When the link hold timer expires, if no dormant link has RSSI greater than the active link RSSI by 
the link switch margin, link switch will not happen. 

4) In normal scenarios, active link switch will happen when all of these following conditions are met:  

 The link hold timer expires.  

 The dormant link’s RSSI is higher than the current active link’s RSSI by the link switch margin.  

 The dormant link RSSI is not greater than the link saturation RSSI.  

5) Once the RSSI of the active and dormant links has gone below the link hold RSSI, links should be 
broken. However, to ensure service availability in worse cases, if the active link RSSI has gone 
below the link hold RSSI and no dormant links exist, the active link will not be broken.  

Mesh Network Topologies 

The mesh feature supports the following three topologies. Mesh is implemented through configuration 
of a peer MAC address for each AP. For details, refer to Configuring a Peer MAC Address. 

Point to point connection 
In this topology, by configuring the peer MAC address for an AP, you can determine the mesh link to be 
formed. 

Figure 32-8 Mesh point to point topology 

 
 

Point to multi-point connection 
In this topology, a centralized bridging device forms wireless links with multiple MPs to bridge data 
among multiple LAN segments. As shown below, data transferred between different LAN segments 
goes via AP 1. 



 

32-8 

Figure 32-9 Mesh point to multi-point topology 

AP 1AC 

AP 2

AP 3

AP 4

AP 5  
 

Self topology detection and bridging connection 
In this topology, MPs automatically detect neighbors and form wireless links to provide wireless 
connectivity between LAN segments, as shown Figure 32-10. Loops are easy to occur in the topology. 
In the topology, you can use mesh routes to selectively block redundant links to eliminate loops, and 
back up the links when the mesh links fail.  

Figure 32-10 Self topology detection and bridging 

 
 

Configuring Mesh Service 

Configuring Mesh Service 

Creating a mesh service 
Select Wireless Service > Mesh Service from the navigation tree, and click the Mesh Service tab to 
enter the mesh service configuration page, as shown in Figure 32-11: 
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Figure 32-11 Mesh service configuration page 

 
 

Click New to enter the page for creating a mesh service, as shown in Figure 32-12. 

Figure 32-12 Create a mesh service 

 
 

Table 32-1 shows the configuration items of mesh service configuration. 

Table 32-1 Configuration items of mesh service 

Item Description 

Mesh Service Name Name of the created mesh service 

 

Configuring a mesh service 
Select Wireless Service > Mesh Service from the navigation tree, click the Mesh Service tab, find the 
mesh service to be configured in the list, and click the corresponding  icon to enter the page for 
configuring mesh service, as shown in Figure 32-13. 
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Figure 32-13 Configure mesh service 

 
 

Table 32-2 shows the configuration items of mesh service. 

Table 32-2 Configuration items of mesh service 

Item Description 

Mesh Service Displays the selected mesh service name. 

VLAN (Tagged) Set the ID of the VLAN whose packets are to be sent tagged. VLAN (Tagged) 
indicates that the port sends the traffic of the VLAN without removing the VLAN tag.

VLAN (Untagged) Set the ID of the VLAN whose packets are to be sent untagged. VLAN (Untagged) 
indicates that the ports send the traffic of the VLAN with the VLAN tag removed. 

Default VLAN 
Set the default VLAN. 
By default, the default VLAN of all ports is VLAN 1. You can configure the default 
VLAN as needed. 

Exclude VLAN Removes the IDs of the VLANs whose packets are to be sent untagged and tagged.

Mesh Route Mesh loop detection algorithm 

Link Keep Alive Interval Configure the mesh link keep-alive interval 

Link Backhaul Rate Configure the backhaul radio rate 

Security Configuration 

Pass Phrase Input a pre-shared key in the format of character string. 

Raw Key Input a pre-shared key in the format of hexadecimal digits. 

Preshared Key 
Pre-shared key. 

 A string of 8 to 63 characters, or 
 A valid hexadecimal number of 64 bits 
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Binding an AP radio to a mesh service 
Select Wireless Service > Mesh Service from the navigation tree, find the mesh service to be bound in 
the list, and click the corresponding binding icon on the right to enter the page for binding an AP radio to 
a mesh service, as shown in Figure 32-14: 

Figure 32-14 Bind an AP radio to a mesh service 

 
 

Select the AP radio to be bound, and click Bind. 

Enabling a mesh service 
Select Wireless Service > Mesh Service from the navigation tree, and click the Mesh Service tab to 
enter the mesh service configuration page, as shown in Figure 32-15: 

Figure 32-15 Enable a mesh service 

 
 

Select the mesh service to be enabled, and click Enable. 

 

 

Before enabling a mesh service, configure a preshared key in the mesh service. For details, refer to 
Configuring a mesh policy. 

 

Displaying the detailed information of a mesh service 
Select Wireless Service > Mesh Service from the navigation tree, and select the Mesh Service tab to 
enter the mesh service configuration page. Click a mesh service to see its detailed information.  
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Figure 32-16 Mesh service detailed information 

 

 

Table 32-3 Mesh service output description 

Field Description 

Mesh Profile Number Mesh service number 

Mesh ID Mesh ID of the mesh service 

Binding Interface Mesh interface bound to the mesh service 

MKD Service 
MKD service status, which can be: 

 Enable: Indicates that the MKD service is enabled 
 Disable: Indicates that the MKD service is disabled 

Link Keep Alive Interval Interval to send keep-alive packets 

Link Backhaul Rate Link backhaul rate 

Mesh Profile Status 
Mesh service status, which can be: 

 Enable: Indicates that the mesh service is enabled. 
 Disable: Indicates that the mesh service is disabled.  

 

Configuring a Mesh Policy 

Creating a mesh policy 
Select Wireless Service > Mesh Service from the navigation tree, and click the Mesh Service tab to 
enter the mesh policy configuration page, as shown in Figure 32-17: 
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Figure 32-17 Mesh policy configuration page 

 
 

Click Create to enter the page for creating a mesh policy, as shown in Figure 32-18. 

Figure 32-18 Create a mesh policy 

 
 

Table 32-4 shows the configuration items of mesh policy. 

Table 32-4 Configuration items of mesh policy 

Item Description 

Mesh Policy Name 
Name of the created mesh policy 
The created mesh policies use the contents of the 
default mesh policy default_mp_plcy. 

 

Configuring a mesh policy 
Select Wireless Service > Mesh Service from the navigation tree, click the Mesh Policy tab, find the 
mesh policy to be configured, and click the corresponding  icon to enter the mesh policy configuration 
page, as shown in Figure 32-19: 
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Figure 32-19 Configure a mesh policy 

 
 

Table 32-5 shows the configuration items of mesh policy. 

Table 32-5 Configuration items of mesh policy 

Item Description 

Mesh Policy Displays the name of the created mesh policy. 

Link establishment 

By default, link initiation is enabled. 

 
 This feature should be disabled when you configure an MP policy for a 

rail AP. 
 This feature is used on train MPs in subway WLAN mesh deployment.

Minimum time to hold a link 
Set the link hold time. 
An active link remains up within the link hold time, even if the link switch 
margin is reached. This mechanism is used to avoid frequent link switch. 

Maximum number of links 

Set the maximum number of links that an MP can form in a mesh network.

 
When configuring mesh, if the number of mesh links configured on an AP is 
greater than 2, you need to configure the maximum links that an MP can 
form as needed. 

Minimum rssi to hold a link 

Set link formation/link hold RSSI (received signal strength indicator). 
This is the minimum RSSI to allow a link to be formed and held. Therefore, 
the minimum RSSI must be ensured at any given point in the tunnel. 
Otherwise, the error rate can be very high. 

Minimum margin rssi 

Set the link switch margin. 
If the RSSI of the new link is greater than that of the current active link by 
the link switch margin, active link switch will happen. This mechanism is 
used to avoid frequent link switch. 

Maximum rssi to hold a link 
Set link saturation RSSI. 
This is the upper limit of RSSI on the active link. If the value is reached, the 
chipset is saturated and link switch will happen. 
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Item Description 

Interval between probe requests Set the probe request interval. 

Role as authenticator By default, whether a device plays the role of an authenticator is based on 
negotiation results. 

 

 

The Mobile Link Switch Protocol (MLSP) implements high-speed link switch with zero packet loss 
during train movement. It is applicable to subway WLAN mesh deployment only. 

 

Figure 32-20 MLSP configuration page 

 
 

Table 32-6 shows the configuration items of MLSP. 

Table 32-6 Configuration items of MLSP 

Item Description 

Mlsp proxy MAC addresses Select the Mlsp proxy MAC addresses check box to 
specify the MAC addresses of the peer devices. 

 

Binding an AP radio to a mesh policy 
Select Wireless Service > Mesh Service from the navigation tree, click the Mesh Policy tab, find the 
mesh policy to be configured in the list, click the corresponding Bind button, select the AP radio to be 
bound, and then click Bind. 

Displaying the detailed information of a mesh policy 
Select Wireless Service > Mesh Service from the navigation tree, and select the Mesh Policy tab to 
enter the mesh policy configuration page. Click a mesh policy to see its detailed information.  
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Figure 32-21 Mesh policy detailed information 

 

 

Table 32-7 Mesh policy output description  

Field Description 

MP Policy Name Name of the mesh policy 

Mesh Link Initiation Whether link initiation is enabled or not 

Mlsp 
Mobile Link Switch Protocol (MLSP) status, which can be: 

 Enable: Indicates that MLSP is enabled 
 Disable: Indicates that MLSP is disabled 

Authenticator Role 
Authenticator role status, which can be: 

 Enable: Indicates that the authenticator role is enabled 
 Disable: Indicates that the authenticator role is disabled 

Max Links Maximum number of links on a device using this mesh policy 

Probe Request Interval (ms) Interval between probe requests sent by a device using this mesh policy 

Link Hold RSSI Link hold RSSI 

Link Hold Time (ms) Link hold time 

Link Switch Margin Link switch margin 

Link saturation RSSI Link saturation RSSI 

Link rate-mode 

Method of calculating the link cost, which can be: 
 Fixed: Indicates that the mesh interface rate is fixed.  
 real-time: Indicates that the mesh interface rate changes with the RSSI 

in real-time. 
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Mesh Global Setup 

Mesh basic setup 
Select Wireless Service > Mesh Service from the navigation tree, and click the Global Setup tab to 
enter the mesh global setup page, as shown in Figure 32-22. 

Figure 32-22 Mesh basic setup 

 
 

Table 32-8 shows the configuration items of mesh basic setup. 

Table 32-8 Configuration items of mesh basic setup 

Item Description 

MKD-ID 

Note that: 
 You need to make sure that the MAC address configured is unused and has the 

correct vendor specific part. 
 The MAC address of an AC should not be configured as the MKD ID. 

 

Enabling mesh portal service 
Select Wireless Service > Mesh Service from the navigation tree, and click the Global Setup tab to 
enter the mesh portal service configuration page, as shown in Figure 32-23. 

Figure 32-23 Mesh portal service configuration page 

 
 

Select the AP for which mesh portal service is to be enabled, and click Enable. 

Configuring a Working Channel 

You can configure a working channel in the following two ways: 

 Manual: To establish a mesh link between an MAP and MPP, you need to specify a working 
channel for the radios of the MAP and MPP, and the working channel on the radio of the MAP 
should be consistent with that on the MPP. Select Radio > Radio from the navigation tree to enter 
the radio setup page, as shown in Figure 32-24. 
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Figure 32-24 Working channel configuration page 

 
 

Select a specified channel from the Channel drop-down list. 

 Auto: Set the working channel mode on the MPP and MAP to auto so that the working channel is 
automatically negotiated when a WDS link is established between the MPP and MAP. 

 

 

If you configure the working channel mode of the radios of the MPP and MAP as auto, the automatically 
selected working channel is a non-radar channel. 

 

Enabling Radio 

Select Radio > Radio from the navigation tree to enter the radio setup page, as shown in Figure 32-25. 

Figure 32-25 Enable radio 

 
 

Select the radio mode to be enabled, and click Enable. 

Configuring a Peer MAC Address 

The mesh feature supports three topologies. For details, refer to Mesh Network Topologies. The mesh 
feature is implemented through configuration of peer MAC addresses for each AP. 

Select Wireless Service > Mesh Service from the navigation tree, find the mesh service to be bound in 
the list, and click the corresponding Bind button on the right to enter the page for binding an AP radio to 
a mesh service, as shown in Figure 32-14. 



 

32-19 

Then select the AP radio to be bound, and click the corresponding  icon to enter the page for 
configuring a peer MAC address, as shown in Figure 32-26. 

Figure 32-26 Configure a peer MAC address 

 
 

Table 32-9 Configuration items for configuring a peer MAC address 

Item Description 

Peer MAC Address 
The mesh feature supports three topologies. For details, refer to Mesh Network 
Topologies. The mesh feature is implemented through configuration of peer 
MAC addresses for each AP. 

cos 
Sets the STP cost of the mesh link to the peer. If not configured, the STP cost is 
automatically calculated by STP. 
You can view the cost of the mesh link on the page shown in Figure 32-26. 

 

Displaying the Mesh Link Status 

Mesh Link Monitoring 

Select Wireless Service > Mesh Service from the navigation tree, and click the Mesh Link Info tab to 
enter the mesh link monitoring page, as shown in Figure 32-27. 

Figure 32-27 Display the mesh link monitoring information 
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You can monitor the mesh link status in real-time on the mesh link monitoring page. 

Mesh Link test 

Select Wireless Service > Mesh Service from the navigation tree, and click the Mesh Link Test tab to 
enter the mesh link test page, as shown in Figure 32-28. 

Figure 32-28 Display mesh link test information 

 

 

On this page, select an AP, and then click Begin. The AC will send a link test notification to the AP. Upon 
receiving the notification, the AP sends link test packets to all its neighbor APs (at present, five link test 
packets are sent in one test). After the link test, the AP sends link test reports to the AC. You can display 
the mesh link status of the AP after refreshing the link test page of the AC. 

WLAN Mesh Configuration Examples 

Normal WLAN Mesh Configuration Example 

Network requirements 
As shown in the figure below, it is required to establish a mesh link between the MAP and the MPP. 

Configure 802.11g on the MAP so that the client can access the network. 

1) Establish a mesh link between the MPP and the MAP by following these steps: 

 Configure MAP and MPP: Select AP > AP Setup from the navigation tree, and click Create to 
configure MAP and MPP. For detailed configuration, refer to Configure MAP and MPP. 

 Configure mesh service: After creating a mesh service and configuring a pre-shared key, you can 
bind the mesh service to the AP and enable the mesh service. For the detailed configuration, refer 
to Configure mesh service. 

 Configure a mesh policy: A mesh policy exists by default. You can create a mesh policy and bind 
the mesh policy to an AP. For the detailed configuration, refer to Configure a mesh policy. 

 Mesh global setup: Configure an MKD-ID (which exists by default), enable mesh portal service for 
the MPP. For the detailed configuration, refer to Mesh global setup. 

 Configure the same working channel, and enable the radio. For the detailed configuration, refer to 
Configure the same working channel and enable the radio on the MAP and MPP.. 

2) Configure 802.11g service on the MAP to enable the client to access the WLAN network. 
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For detailed configuration, refer to Wireless Service Configuration Example. 

Figure 32-29 Network diagram for normal WLAN mesh configuration 

 
 

Configuration procedure 
1) Configure MAP and MPP 

Select AP> AP Setup from the navigation tree, and click New to enter the page for creating an AP, as 
shown in Figure 32-30. 

Figure 32-30 AP setup 

 

 

 Set the AP name to map. 

 Select the AP model WA2220X-AG. 

 Select the serial ID as manual, and type the AP serial ID. 

 Click Apply. 

Then configure MPP by following the same steps. 

2) Configure mesh service 

# Create a mesh service. 

Select Wireless Service > Mesh Service from the navigation tree, click the Mesh Service tab to enter 
the page for creating a mesh service, as shown in Figure 32-31. 

Figure 32-31 Create a mesh service 

 

 

 Set the mesh service name to outdoor. 

 Click Apply. 

# Configure a pre-shared key. 
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Figure 32-32 Configure a pre-shared key 

 

 

 Select Pass Phrase, and set the pre-shared key to 12345678. 

 Click Apply. 

# Bind an AP radio to the mesh service 

Select Wireless Service > Mesh Service from the navigation tree, click the Mesh Service tab, click 
the binding icon on the right of the mesh service outdoor to enter the page for binding an AP radio to a 
mesh service, as shown in Figure 32-33: 

Figure 32-33 Bind an AP radio to a mesh service 

 

 

Select the AP radios to be bound, and click Bind. 

# Enable the mesh service 

Select Wireless Service > Mesh Service from the navigation tree, and click the Mesh Service tab to 
enter the mesh service configuration page, as shown in Figure 32-34: 

Figure 32-34 Enable the mesh service 

 
 

Select the mesh service to be enabled, and click Enable. 

3) Configure a mesh policy 
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Select Wireless Service > Mesh Service from the navigation tree, and click the Mesh Policye tab to 
enter the mesh policy configuration page, as shown in Figure 32-35: 

Figure 32-35 Mesh policy configuration page 

 
 

 

A mesh policy exists by default. You can create a mesh policy and bind the mesh policy to an AP as 
needed. By default, the default_mp_plcy mesh policy is mapped to an AP. 

 

4) Mesh global setup 

# Configure an MKD-ID (By default, the MKD-ID exists. Therefore, this step is optional.) 

Select Wireless Service > Mesh Service from the navigation tree, and click the Global Setup tab to 
enter the mesh global setup page, where you can set the MKD-ID. 

# Enable mesh portal service 

Figure 32-36 Mesh portal service configuration page 

 
 

 Select the MPP that has wired connectivity with the AC. 

 Click Enable. 

5) Configure the same working channel and enable the radio on the MAP and MPP. 

# Configure the working channel. 
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Select Radio > Radio from the navigation tree, select the MAP to be configured in the list, and click the 
corresponding  icon to enter the radio setup page, as shown in Figure 32-37. 

Figure 32-37 Configure the working channel 

 
 

Select the channel to be used from the Channel drop-down list. You can follow this step to configure the 
working channel for the MPP. Note that the working channel of the radio on the MPP should be the 
same as that on the MAP. 

# Enable radio 

Select Radio > Radio from the navigation tree to enter the radio setup page, as shown in Figure 32-38. 

Figure 32-38 Enable radio 

 

 

Select the radio modes to be enabled for the MAP and MPP, and click Enable.  

Configuration verification 
 The mesh link between the MAP and the MPP has been established, and they can ping each other. 

 After 802.11g is configured on the MAP, the client and the AC can ping each other, and the client 
can access the network through the mesh link. 

Subway WLAN Mesh Configuration Example 

Network requirements 
As shown in Figure 32-39, all rail MPs are connected to an AC.  

It is required to configure WLAN mesh so that the train MP will form links with rail MPs during movement, 
among them one link is the active link and all others are dormant links. 

Subway WLAN mesh configuration is basically the same with normal WLAN mesh configuration. Note 
the following when configuring subway WLAN mesh: 

1) It is required to create a rail AP mesh policy:  
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 Disable the link initiation function. For the detailed configuration, refer to Configuring a Mesh 
Policy. 

 Enable mesh portal service. For the detailed configuration, refer to Enabling mesh portal service. 

2) Create a train AP mesh policy. 

 Enable MLSP. 

 Disable role as authenticator. For the detailed configuration, refer to Configuring a Mesh Policy. 

 Set the value of maximum links that an MP can form in a mesh network (the default value is 2.). For 
the detailed configuration, refer to Configuring a Mesh Policy. 

Figure 32-39 Network diagram for subway WLAN mesh configuration 

Rail MP 1
2.2.2.33/24

Train MP
2.2.2.88/24

AC
2.2.2.131/24

Rail MP 2
2.2.2.34/24

Rail MP 3
2.2.2.35/24

Active link Dormant link

... Rail MP n

 

 

Configuration procedure 
Subway mesh configuration differs from normal WLAN mesh configuration in mesh policy configuration 
of rail APs and train APs. Other configurations are the same. Refer to Normal WLAN Mesh 
Configuration Example for details. 

Mesh Point-to-Multipoint Configuration Example 

Network requirements 
It is required that AP 1 work as an MPP, and establish a mesh link with AP 2, AP 3, AP 4, and AP 5 
respectively. 

The mesh configuration is the same as the normal WLAN mesh configuration. Note the following when 
configuring mesh: 

 Configure a peer MAC address for each radio interface. 

 Set the value of maximum links that an MP can form in a mesh network (The default value is 2. It 
should be set to 4 in this example.). For the detailed configuration, refer to Configuring a Mesh 
Policy. 
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Figure 32-40 Diagram for mesh configuration 
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Configuration procedure 
Mesh configuration is the same as normal WLAN mesh configuration. Refer to Normal WLAN Mesh 
Configuration Example for details. 

Tri-Radio Mesh Configuration Example 

Network requirements 
As shown in Figure 32-41, set up mesh links between MPs and the MPP, and use radio resources to 
make Radio 1 of MPP, Radio 1 and Radio 2 of an MP, and Radio 1 of MP 2 join the same mesh and use 
Radio 3 as the multi-beam antenna, which provides the wireless access service.  

Figure 32-41 Network diagram for tri-radio mesh configuration 

 
 

Configuration considerations 
1) Configure the mesh service 

The mesh configuration here is similar to a common wireless mesh configuration. Pay attention to the 
following points: 

 Radios joining the same mesh must use the same mesh service. Bind Radio 1 of MPP, Radio 1 and 
Radio 2 of MP 1, and Radio 1 of MP 2 to the same mesh service as required. 
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Figure 32-42 Bind radios to the mesh service 

 

 

 On Radio 1 of the MPP, configure Radio 1 of MP 1 as the peer MAC address. Similarly, configure 
Radio 1 of the MPP as the peer MAC address on MP 1. Perform the same operation for Radio 2 of 
MP 1 and Radio 1 of MP 2.  

2) Configure the access service 

As the multi-beam antenna, Radio 3 provides the wireless access service. For related configuration, 
refer to Wireless Access Configuration Examples. You can strictly follow the configuration example to 
configure the access service.  

Configuration procedure 
The mesh configuration here is similar to a common wireless mesh configuration. For details, refer to 
Configuration procedure.  



 

33-1 

33  WLAN Roaming Configuration 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

WLAN Roaming Overview 

The Inter AC Tunneling Protocol (IACTP) is a tunneling protocol of H3C which defines how access 
controllers (ACs) communicate with each other. IACTP provides a generic encapsulation and transport 
mechanism between ACs to provide secure AC-AC communications based on the standard TCP 
client/server model. 

A mobility group is a group of ACs that communicate with each other using the IACTP protocol. A 
maximum of 8 ACs can be present in a mobility group in current version. Formation and maintenance of 
a mobility group is done using IACTP.  

IACTP provides a control tunnel for applications such as roaming to share/exchange messages. It also 
provides a data tunnel to encapsulate data packets to be transported between ACs. It can be used 
either with IPv4 or with IPv6.  

Whenever a station supporting key caching associates to any of the ACs in a mobility group (which 
would be it’s Home-AC (HA)) for the first time, it will go through 802.1X authentication followed by 11 
Key exchange. The station information will be synchronized across the ACs in the mobility group prior to 
the roaming of the station within an AC/across ACs. When this station roams to another AC in the 
mobility group (which would be its Foreign-AC (FA)), the station information is used to fast authenticate 
the station by skipping 802.1X authentication, and performing only 802.11 key exchange to facilitate 
seamless roaming within the mobility group. 

Terminology 

 HA: The AC to which a wireless station is connected by associating with an AP for the first time is 
the HA of the station. 

 FA: An AC that is other than the HA and to which a station is currently connected is an FA of the 
station. 
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 Fast-roam capable station: A wireless station which directly associates to an AC in the 
mobility-group, and supports fast-roam service (supporting key caching). 

 Roam-out station: A wireless station which has associated with an AC other than the HA in the 
mobility-group is referred to as a roam-out station at its HA. 

 Roam-in station: A wireless station which has associated with an AC other than the HA in the 
mobility-group is referred to as a roam-in station at the FA. 

 Intra-AC roaming: A procedure where a wireless station roams from one AP to another AP, which 
are connected to the same AC. 

 Inter-AC roaming: A procedure where a wireless station roams from one AP to another AP, which 
are connected to different ACs. 

 Inter-AC fast roaming capability: If a station uses 802.1x (RSN) authentication through 
negotiation and supports key caching, this station has inter-AC fast roaming capability. 

WLAN Roaming Topologies 

WLAN Roaming topologies consist of: 

 Intra-AC roaming topology 

 Inter-AC roaming topology 

 Intra-FA roaming topology 

 Inter-FA roaming topology 

 Roam-back topology 

Intra-AC roaming 

Figure 33-1 Intra-AC roaming 
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1) A station is associated with AP 1, which is connected to an AC. 

2) The station disassociates with AP 1 and roams to AP 2 connected to the same AC. 

3) The station is associated with AP 2 through intra-AC roam association.  
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Inter-AC roaming 

Figure 33-2 Inter-AC roaming 

 

 

As shown in the above figure:  

1) A station is associated with AP1, which is connected to AC 1. 

2) The station disassociates with AP1 and roams to AP2. 

3) The station is associated with AP2 through inter-AC roam association. Prior to inter-AC roaming, 
AC1 should synchronize the station information with AC2 over an IACTP tunnel. 

Intra-FA roaming 

Figure 33-3 Intra-FA roaming 

 
 

1) A station is associated with AP 1, which is connected to AC 1. 
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2) The station disassociates with AP 1 and roams to AP 2 connected to AC 2. Now AC 2 is the FA for 
the station. 

3) The station is associated with AP 2 through inter-AC roam association. Prior to inter-AC roaming, 
AC 1 should synchronize the station information with AC 2 through an IACTP tunnel. 

4) The station then disassociates with AP 2 and roams to AP 3 which is also connected to AC 2. The 
station is associated with AP 3 through intra-FA roam association. 

Inter-FA roaming 

Figure 33-4 Inter-FA roaming 
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1) A station is associated with AP 1, which is connected to AC 1. 

2) The station disassociates with AP 1 and roams to AP 2 connected to AC 2. Now AC 2 is the FA for 
the station. 

3) The station is associated with AP 2 through inter-AC roam association.  

4) The station then disassociates with AP 2 and roams to AP 3 which is connected to AC 3, which now 
is its FA. Prior to inter-AC roaming, AC 1 should synchronize the station information with AC 2 and 
AC 3 through IACTP tunnels. 
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Roam-back 

Figure 33-5 Roam-back 
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1) A station is associated with AP 1, which is connected to AC 1. 

2) The station disassociates with AP 1 and roams to AP 3 connected to AC 2. Now AC 2 is the FA for 
the station. 

3) The station is associated with AP 3 through inter-AC roam association. Prior to inter-AC roaming, 
AC 1 should synchronize the station information with AC 2 through an IACTP tunnel. 

4) The station then disassociates with AP 3 and roams back to AP 2 connected to AC 1, which is its 
HA. 

Configuring WLAN Roaming 

Configuring a Roaming Group 

Select Roam > Roam Group from the navigation tree to enter the page for configuring a roaming group, 
as shown in Figure 33-6: 

Figure 33-6 Configure a roaming group 

 

 

Table 33-1 describes the configuration items for configuring a roaming group. 

Table 33-1 Configuration items for configuring a roaming group 

Item Description 

Service status 
 enable: Enables IACTP service. 
 disable: Disables IACTP service. 

IP type Select IPv4 or IPv6 



 

33-6 

Item Description 

Source address Source address of the IACTP protocol 

Auth mode 

Select the check box before Auth mode, and select the MD5 authentication mode. This 
item is optional. 
The control message integrity can be verified when the MD5 authentication mode is 
selected. The sender (an AC) calculates a digest based on the content of a control 
message. On receiving such a message, the receiver (another AC in the roaming group) 
will calculate the digest again and compare it against the digest present in the message 
to verify the integrity of the packet received. If the digests are the same, the packet is not 
tampered. 

Auth key 
MD5 authentication key 
If you select the MD5 authentication mode, you need to input an authentication key. 

 

 

Roaming group configuration is available only for inter-AC roaming. For the configuration example of 
inter-AC roaming, see Inter-AC Roaming Configuration Example. 

 

Adding a Group Member 

Select Roam > Roam Group from the navigation tree to enter the page for adding a group member, as 
shown in Figure 33-7: 

Figure 33-7 Add a group member 

 
 

Table 33-2 describes the configuration items for adding a group member. 

Table 33-2 Configuration items for adding a group member 

Item Description 

IP address 

Add the IP address of an AC to a roaming group. 

 
When you configure a roaming group, the roaming group name configured for the ACs in 
the same roaming group must be the same. 

VLAN 

Configure the VLAN to which the roaming group member belongs. 
This configuration item is optional. A VLAN is specified to implement redirection of the 
traffic of a client from one AC to another. For detailed application, see Traffic Redirection 
Configuration Example. 
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 The user profile configurations of the ACs in a roaming group must be the same. 

 The ACs in a roaming group cannot be configured as hot backup ACs. 

 

Displaying Client Information 

Select Roam > Roam Client from the navigation tree to enter the page shown in Figure 33-8. 

 

 

The page you enter by selecting Roam > Roam Client shows the inter-AC roaming information of 
clients, if any. 

 

Figure 33-8 Display client information 

 
 

By clicking a target client, you can view the detailed information and roaming information of the client. 
The detailed information and roaming information of a client you can view by selecting Roam > Client 
Information are the same as those you can view by selecting Summary > Client. For the related 
information, refer to Summary. 

Wireless Roaming Configuration Example 

Intra-AC Roaming Configuration Example 

Network requirements 
As shown in the figure below, an AC has two APs associated and all of them are in VLAN 1. A client is 
associated with AP 1. It is required to configure intra-AC roaming so that the client can associate with 
AP 2 when roaming to AP 2. 
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Figure 33-9 Intra-AC roaming 
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Configuration procedure 
 

 

If remote authentication is needed in the authentication mode you select, you need to configure the 
RADIUS server. For how to configure the RADIUS server, refer to Authentication. 

 

1) Configuring APs 

# Create two APs. 

Select AP > AP Setup from the navigation tree, and click New. 

 Set the name of AP 1 to ap1. 

 Select the AP model WA2200X-AG. 

 Select manual from the Serial ID drop-down list and type the serial ID of the AP. 

 Click Apply. 

Follow the same steps to create the other AP (with the name ap2). 

2) Configure wireless service 

# Create a wireless service 

Select Wireless Service > Access Service from the navigation tree, and click New. 

 Set the service name to Roam. 
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For how to configure the authentication mode, refer to Wireless Service. However, fast roaming can be 
implemented only when the RSN+802.1x authentication mode is adopted. 

 

 Click Apply. 

# Enable wireless service 

Select Wireless Service > Access Service. 

 Select the Roam check box. 

 Click Enable. 

3) Bind AP radios to the wireless service 

Select Wireless Service > Access Service, and click Bind at the right side of the wireless service 
Roam to enter the page for binding AP radio, as shown in Figure 33-10: 

Figure 33-10 Bind AP radios 

 

 

 Select the check box before ap1 with radio type being 802.11g, and the check box before ap2 with 
radio type being 802.11n(2.4GHz). 

 Click Bind. 

4) Enable dot11g radio 

Select Radio > Radio Setup from the navigation tree to enter the radio setup page shown in Figure 
33-11: 
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Figure 33-11 Enable radio 

 

 

 Select the check box before ap1 with the radio mode being 802.11g, and select the check box 
before ap2 with the radio mode being 802.11n(2.4GHz). 

 Click Enable. 

Configuration verification 
1) Verification by displaying the roaming information of the client 

Select Summary > Client from the navigation tree, select the Roam Information tab, and then click 
the desired client to view the roaming information of the client. 

From the roaming information, you can see that the client accesses the WLAN through AP 1, and the 
BSSID of AP 1 is 000f-e27b-3d90. 

Figure 33-12 Client status before intra-AC roaming 

 
 

After intra-AC roaming, from the roaming information you can see that the client is connected to the 
WLAN through AP 2, and the BSSID of AP 2 is 000f-e233-5500. 
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Figure 33-13 Client status after intra-AC roaming 

 
 

2) Verification by viewing the Roam Status field 

Select Summary > Client from the navigation tree, click the Detail Information tab, and then click the 
desired client. You will see that Intra-AC roam association is displayed in the Roam Status field. 

Figure 33-14 Verify intra-AC roaming 

 

 

Configuration guidelines 
Note the following when configuring intra-AC roaming: 

The SSIDs of the two APs should be the same, that is, the same wireless service should be bound to 
the radios of the two APs in Bind AP radios to the wireless service. 
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Inter-AC Roaming Configuration Example 

Network requirements 
As shown in the figure below, two ACs that each are connected to an AP are connected through a Layer 
2 switch. Both ACs are in the same network. The IP address of AC 1 is 192.168.1.100 and that of AC 2 
is 192.168.1.101. A client associates with AP 1.  

It is required to configure inter-AC roaming so that the client can associate with AP 2 when roaming to it. 

Figure 33-15 Inter-AC roaming 
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Configuration procedure 
 

 

If remote authentication is needed in the authentication mode you select, you need to configure the 
RADIUS server. For how to configure the RADIUS server, refer to Authentication. 

 

1) Establish CAPWAP connections  

Configure AC 1 and AC 2 so that a CAPWAP connection can be established between AP 1 and AC 1, 
and between AP 2 and AC 2. Only after the CAPWAP connections are established can you see that the 
two APs are in the running status. Select Summary > AP or AP > AP Setup, and you can view the AP 
status. 

For the related configuration, refer to Wireless Service. 

 



 

33-13 

 

For the configuration of authentication mode, see Wireless Service. Fast roaming supporting key 
caching can be implemented only when RSN+802.1x authentication is adopted. 

 

2) Configure a roaming group 

Configure a roaming group on AC 1. 

Select Roam > Roam Group from the navigation tree to enter the page for configuring a roaming group, 
as shown in Figure 33-16: 

Figure 33-16 Configure a roaming group on AC 1 

 

 

 Select enable from the Service status drop-down list. 

 Select IPV4 from the Ip type drop-down list, and type 192.168.1.100 for Source address, namely, 
the IP address of AC 1. 

 Type the IP address of AC 2 in the member list, click Add. 

 Click Apply. 

Create a roaming group on AC 2. The source address is the IP address of AC 2, and the member 
address is the IP address of AC 1. 

Configuration verification 
1) Verify the status of the roaming group. 

On AC 1, you can see: 
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Figure 33-17 Check the roaming group state 

 

 

On AC 2, you can see: 

Figure 33-18 Check the roaming group state: 

 

 

You can see from the above figure that the roaming group is in the running state. 

2) Verification by displaying the client information 

After the client roams from AP 1 to AP 2, select Roam > Roam Client on AC 1, and you can see that the 
client roams out of 192.168.1.100, as shown in Figure 33-19; select Roam > Roam Client on AC 2, and 
you can see that the client roams in to 192.168.1.100. 

3) Verification by viewing the AC to which the client connects and the Roam Status field 

 Before roaming, select Summary > Client on the web interface of AC 1. If you can view the 
roaming information of the client, the client has been associated with AP 1. 

 After roaming, select Summary > Client on the web interface of AC 1. No client information will be 
displayed because client has roamed from AP 1 to AP 2. Select Summary > Client on the web 
interface of AC 2. Then select the Detail Information tab, and click the desired client to view the 
roaming information of the client. You will see Inter-AC roam association is displayed on the 
Roam Status field, which indicates that the client is associated with AP 2 through inter-AC 
roaming. 
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Figure 33-19 Verify inter-AC roaming 

 
 

4) Verification by viewing the BSSID field 

Before roaming, select Summary > Client, select the Detail Information tab, and then click the desired 
client to view the roaming information of the client. 

From the roaming information shown in the following figure, you can see that the client connects to the 
WLAN through AP 1, and the BSSID of AP 1 is 000f-e27b-3d90. 

Figure 33-20 Client status before inter-AC roaming 

 

 

After inter-AC roaming, you can see that the client is connected to the WLAN through AP 2, and the 
BSSID of AP 2 is 000f-e233-5500, as shown in Figure 33-21. 
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Figure 33-21 Client status after intra-AC roaming 

 

 

Configuration guidelines 
Note the following when configuring inter-AC roaming: 

 The SSIDs and the authentication and encryption modes of two APs should be the same. 

 A roaming group must be configured on both of the two ACs. 

 Do not configure ACs in a roaming group to back up each other. 

Traffic Redirection Configuration Example 

Network requirements 
 AC 1 and AC 2 are connected through a Layer 2 switch. Both ACs are in the same network. The IP 

address of AC 1 is 192.168.1.100 and that of AC 2 is 192.168.1.101. 

 A client associates to AP 1. Configure an IACTP tunnel between AC 1 and AC 2 to redirect the 
traffic of Client to AC 2. 

 Configure a VLAN for members in a roaming group to implement traffic redirection 
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Figure 33-22 Traffic redirection network diagram 
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Configuration procedures 
1) Configure IP addresses 

Create VLAN 3 on AC 1 and AC 2 respectively and configure IP addresses for the two VLAN interfaces. 
The IP address of VLAN-interface 3 on AC 1 is 192.168.3.100, and that of VLAN-interface 3 on AC 2 is 
192.168.3.101. 

# Select Network > VLAN from the navigation tree to enter the VLAN tab page, where you can see the 
created VLAN, as shown in Figure 33-23. 

Figure 33-23 Create a VLAN 

 

 

Select Device > Interface Management from the navigation tree to configure the IP address of 
VLAN-interface 3 on AC 1. 
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Figure 33-24 Configure an IP address 

 
 

 

For detailed VLAN configuration, see VLAN Configuration. 

 

2) Establish a CAPWAP connection 

Configure AC 1 so that AP 1 and AC 1 can establish a CAPWAP connection. 

For the related configuration, see Wireless Configuration. Note that you need to bind VLAN 3 to the 
service template when creating the service template. 

Figure 33-25 Create a service template 

 

 

3) Establish the CAPWAP connection 
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Configure a roaming group on AC 1. 

# Select Roam > Roam Group from the navigation tree. 

Figure 33-26 Configure a roaming group on AC 1 

 

 

 Select enable from the Service status drop-down list. 

 Select IPV4 from the Ip type drop-down list, and type 192.168.1.100 for Source address, namely, 
the IP address of VLAN-interface 1 on AC 1. 

 Type the IP address of VLAN-interface 1 on AC 2 in the member list, and click Add. 

 Click Apply. 

# Create a roaming group on AC 2. The source address is the IP address of VLAN-interface 1 on AC 2, 
and the member address is the IP address of VLAN-interface 1 on AC 1. The detailed configuration is as 
shown in Figure 33-27. 

Figure 33-27 Configure a roaming group on AC 2 

 

 

Configuration verification 
The client is connected to the WLAN through AP 1, and the traffic of the client is redirected to AC 2. 
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34  Radio Configuration 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Radio Overview 

Radio signals are susceptible to surrounding interference. Causes of radio signal attenuation in 
different directions are very complex. Therefore, we need to make careful plans before deploying a 
WLAN network. After WLAN deployment, the running parameters still need to be adjusted because the 
radio environment is always varying due to interference from mobile obstacles, micro-wave ovens and 
so on. To adapt to environment changes, radio resources such as working channels and transmit power 
should be dynamically adjusted. Such adjustments are complex and require experienced personnel to 
implement regularly, which brings high maintenance costs. 

WLAN radio resource management (RRM) is a scalable radio resource management solution. Through 
information collection (APs collect radio environment information in real time), information analysis (The 
AC analyzes the collected information), decision-making (The AC makes radio resource adjustment 
configuration according to analysis results), and implementation (APs implement the configuration 
made by the AC for radio resource optimization), WLAN RRM delivers a real-time, intelligent, integrated 
radio resource management solution, which enables a WLAN network to quickly adapt to radio 
environment changes and keep staying in a healthy state. 

Channel Adjustment 

Working channels available in WLANs are few. For example, there are only three working channels in a 
2.4G WLAN network. As a result, channel overlapping is very easy to occur. In addition, other radio 
sources may exist in a WLAN, such as radar, micro-wave ovens, which interfere with the operation of 
APs. All these problems can be resolved through dynamic channel adjustment.  

With dynamic channel adjustment, each AP can be assigned with the best channel in real time to avoid 
co-channel interference and interference from other radio sources, and thus continuous communication 
can be ensured to provide for high-reliability data transmission.  
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Figure 34-1 Dynamic channel adjustment 

 

 

Power Adjustment 

Traditionally, an AP has its transmitting power set to the maximum to cover an area as large as possible. 
This, however, affects the operation of surrounding wireless devices. Therefore, both coverage and 
capacity need to be considered.  

Power adjustment is responsible for real-time radio environment monitoring and dynamic power 
assignment. When an AP starts for the first time, it uses the maximum transmission power. Then, it 
collects reports from detected neighbors (which are managed by the same AC) to make a power 
adjustment decision.  

When a new neighbor joins, each AP reduces its transmission power. As shown in Figure 34-2, APs 1, 2 
and 3 cover an area. When AP 4 joins, the default maximum number of allowed neighbors (adjacency 
factor, which is configurable) is reached. Then, the APs perform power adjustment. You can find from 
the figure that they all reduce their transmission power.  
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Figure 34-2 Power reduction 

 
 

As shown in Figure 34-3, when AP 3 fails, the other APs increase their transmission power to cover the 
whole area.  
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Figure 34-3 Power increasing 
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Radio Setup 

Configuring Radio Parameters 

Select Radio > Radio from the navigation tree to enter the radio setup page, click the  icon of the 
target radio to enter the page for AP radio setup page, as shown in Figure 34-4: 

Figure 34-4 Radio setup 
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Table 34-1 shows the configuration items of radio setup. 

Table 34-1 Configuration items of radio setup 

Item Description 

AP Name Displays the selected AP. 

Radio Unit Displays the selected AP’s radios 

Radio Mode Displays the selected AP’s radio mode. 

Transmit Power 
Maximum radio transmission power, which varies with country codes, channels, AP 
models, radio modes and antenna types. If you adopt the 802.11n mode, the maximum 
transmit power of the radio also depends on the bandwidth mode. 

Channel 

Working channel of the radio, which varies with radio types and country codes. The 
working channel list varies with device models. 
auto: The working channel is selected by the driver in system initialization. 
If you modify the working channel configuration, the transmit power will be automatically 
adjusted. 

802.11n  
The option is available only when the AP supports 802.11n. 

bandwidth mode 

802.11n can bond two adjacent 20-MHz channels together to form a 40-MHz channel. 
During data forwarding, the two 20-MHz channels can work separately with one acting 
as the primary channel and the other acting as the secondary channel or work together 
as a 40-MHz channel. This provides a simple way of doubling the data rate. 
By default, the channel bandwidth of the 802.11n radio (5 GHz) is 40 MHz, and that of 
the 802.11n radio (2.4GHz) is 20 MHz. 

 
 If the channel bandwidth of the radio is set to 40 MHz, a 40 MHz channel is used as 

the working channel. If no 40 MHz channel is available, a 20 MHz channel is used. 
For the specifications, see IEEE P802.11n D2.00. 

 If you modify the bandwidth mode configuration, the transmit power will be 
automatically adjusted. 

client dot11n-only 
If you select the client dot11n-only check box, non-802.11n clients are prohibited from 
access. If you want to provide access for all 802.11a/b/g clients, you need to disable this 
function. 

A-MSDU 

Selecting the check box before A-MSDU enables A-MSDU. 
Multiple MAC Service Data Units (MSDU) can be aggregated into a single A-MSDU. 
This reduces the MAC header overhead and thus improves MAC layer forwarding 
efficiency. 
At present, only A-MSDUs can be received. 

A-MPDU 

Selecting the check box before A-MPDU enables A-MPDU. 
802.11n introduces the A-MPDU frame format. By using only one PHY header, each 
A-MPDU can accommodate multiple Message Protocol Data Units (MPDUs) which 
have their PHY headers removed. This reduces the overhead in transmission and the 
number of ACK frames to be used, and thus improves network throughput. 

short GI 

Selecting the check box before short GI enables short GI. 
Delays may occur during receiving radio signals due to factors like multi-path reception. 
Therefore, a subsequently sent frame may interfere with a previously sent frame. The 
GI function is used to avoid such interference. It increases the throughput by 10 percent.
The short GI function is independent of bandwidth and thus supports both 20MHz and 
40MHz bandwidths. 
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Figure 34-5 Radio setup (advanced setup) 

 

 

Table 34-2 shows the configuration items of radio setup. 

Table 34-2 Configuration items of radio setup 

Item Description 

Preamble 

Preamble is a pattern of bits at the beginning of a frame so that the receiver can 
sync up and be ready for the real data. There are two different kinds of preambles:

 Short preamble. A short preamble improves network performance. Therefore, 
this option is always selected. 

 Long preamble. A long preamble ensures compatibility between access point 
and some legacy client devices. Therefore, you can select this option to make 
legacy client devices support short preamble. 

Only 802.11b/g supports this configuration. 

Transmit Distance Maximum coverage of a radio 

ANI 

Adaptive Noise Immunity (ANI). After the ANI function is enabled, the device 
automatically adjusts the noise immunity level according to the surrounding signal 
environment to eliminate RF interference. 

 Enable: Enables ANI. 
 Disable: Disables ANI. 

Client Max Count Maximum number of clients that can be associated with one radio 

Fragment Threshold 

Specifies the maximum length of frames that can be transmitted without 
fragmentation. When the length of a frame exceeds the specified fragment 
threshold value, it is fragmented. 

 In a wireless network where error rate is high, you can decrease the fragment 
threshold by a rational value. In this way, when a fragment of a frame is not 
received, only this fragment rather than the whole frame needs to be 
retransmitted, and thus the throughput of the wireless network is improved. 

 In a wireless network where no collision occurs, you can increase the fragment 
threshold by a rational value to decrease acknowledgement packets and thus 
increase network throughput. 

Beacon Interval 
Interval for sending beacon frames. Beacon frames are transmitted at a regular 
interval to allow mobile clients to join the network. Beacon frames are used for a 
client to identify nearby APs or network control devices. 
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Item Description 

RTS Threshold 

Request to send (RTS) threshold length. If a frame is larger than this value, the RTS 
mechanism will be used. 
RTS is used to avoid data collisions in a WLAN.  
A smaller RTS threshold causes RTS packets to be sent more often, thus 
consuming more available bandwidth. However, the more often RTS packets are 
sent, the quicker the system can recover from interference or collisions. 
In a high-density WLAN, you can decrease the RTS threshold by a rational value to 
reduce collisions in the network. 

 
The RTS mechanism occupies bandwidth. Therefore, this mechanism applies only 
to data frames larger than the RTS threshold. 

DTIM Period 
Number of beacon intervals between delivery traffic indication message (DTIM) 
transmissions. The AP sends buffered broadcast/multicast frames when the DTIM 
counter reaches 0. 

Long Retry Threshold Number of retransmission attempts for unicast frames larger than the RTS 
threshold. 

Short Retry Threshold Number of retransmission attempts for unicast frames smaller than the RTS 
threshold if no acknowledgment is received for it. 

Max Receive Duration Interval for which a frame received by an AP can stay in the buffer memory 

 

Enabling a Radio 

Select Radio > Radio from the navigation tree to enter the radio setup page, as shown in Figure 34-6. 

Figure 34-6 Enable radio 

 

 

Select the check box of the target radio, and then click Enable. 

Locking the Channel 

Select Radio > Radio from the navigation tree, click the  icon of the target radio to enter the page as 
shown in Figure 34-7. 
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Figure 34-7 Lock a channel 

 

 

Select the check box of the target radio, and click Lock Channel. 

Note that: 

 Channel locking takes effect only when the AC adopts the auto mode. For more information about 
automatic channel adjustment, see Configuring Radio Parameters. 

 If you enable channel locking and then enable the radio, the AC automatically selects an optimal 
channel, and then locks the channel. 

 When the AC detects any radar signals, it immediately selects another channel even if the current 
channel is locked, and then locks the new channel. 

 If you lock the current channel first, and then enable channel adjustment, channel adjustment does 
not work because the current channel is locked. Therefore, before enabling channel adjustement, 
make sure that the current channel is not locked. If you enable channel adjustment and then lock 
the current channel, the last selected channel is locked. For information about channel adjustment, 
see Channel Adjustment. For how to configure channel adjustment, see Parameter Settings. 

Locking the Power 

Select Radio > Radio from the navigation tree to enter the page as shown in Figure 34-8. 

Figure 34-8 Lock the current power 

 

 

Select the check box of the target radio, and click Lock Power. 

Note that: 

 For transmission power configuration, see Configuring Radio Parameters. 
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 If you lock the current power first, and then enable power adjustment, power adjustment does not 
work because the power is locked. Therefore, before enabling power adjustment, make sure that 
the current power is not locked. If you enable power adjustment, and then lock the current power, 
the last selected power is locked. For information about power adjustment, see Power Adjustment. 
For how to configure power adjustment, see Parameter Settings. 

Configuring Data Transmit Rates 

Configuring 802.11a/802.11b/802.11g Rates 

Select Radio > Rate from the navigation tree to enter the rate setting page, as shown in Figure 34-9: 

Figure 34-9 Set 802.11a/802.11b/802.11g rates 

 
 

Table 34-3 shows the configuration items of setting rates. 

Table 34-3 Configuration items of setting 802.11a/802.11b/802.11g rates 

Item Description 

802.11a 

Configure rates (in Mbps) for 802.11a. 
By default: 

 Mandatory rates are 6, 12, and 24; 
 Supported rates are 9, 18, 36, 48, and 54; 
 Multicast rate: Automatically selected from the mandatory rates. The 

transmission rate of multicasts in a BSS is selected from the mandatory 
rates supported by all the clients. 

802.11b 

Configure rates (in Mbps) for 802.11b. 
By default: 

 Mandatory rates are 1 and 2; 
 Supported rates are 5.5 and 11; 
 Multicast rate: Automatically selected from the mandatory rates. The 

transmission rate of multicasts in a BSS is selected from the mandatory 
rates supported by all the clients. 
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Item Description 

802.11g 

Configure rates (in Mbps) for 802.11g. 
By default: 

 Mandatory rates are 1, 2, 5.5, and 11; 
 Supported rates are 6, 9, 12, 18, 24, 36, 48, and 54; 
 Multicast rate: Automatically selected from the mandatory rates. The 

transmission rate of multicasts in a BSS is selected from the mandatory 
rates supported by all the clients. 

 

Configuring 802.11n MCS 

Information about MCS 
Configuration of mandatory and supported 802.11n rates is achieved by specifying the maximum 
Modulation and Coding Scheme (MCS) index. The MCS data rate table shows relations between data 
rates, MCS indexes, and parameters that affect data rates. Sample MCS data rate tables for 20 MHz 
and 40 MHz are shown in Table 34-4 and Table 34-5 respectively. For the whole table, see IEEE 
P802.11n D2.00. 

The following tables indicate that MCS 0 through 7 are for one single spatial stream, and when the MCS 
is 7, the data rate is the highest. MCS 8 through 15 are for two spatial streams, and when the MCS is 15, 
the data rate is the highest. 

Table 34-4 MCS index table (20 MHz) 

Data rate (Mbps) 
MCS index Number of spatial 

streams Modulation 
800ns GI 400ns GI 

0 1 BPSK 6.5 7.2 

1 1 QPSK 13.0 14.4 

2 1 QPSK 19.5 21.7 

3 1 16-QAM 26.0 28.9 

4 1 16-QAM 39.0 43.3 

5 1 64-QAM 52.0 57.8 

6 1 64-QAM 58.5 65.0 

7 1 64-QAM 65.0 72.2 

8 2 BPSK 13.0 14.4 

9 2 QPSK 26.0 28.9 

10 2 QPSK 39.0 43.3 

11 2 16-QAM 52.0 57.8 

12 2 16-QAM 78.0 86.7 

13 2 64-QAM 104.0 115.6 

14 2 64-QAM 117.0 130.0 

15 2 64-QAM 130.0 144.4 
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Table 34-5 MCS index table (40 MHz) 

Data rate (Mbps) 
MCS index Number of spatial 

streams Modulation 
800ns GI 400ns GI 

0 1 BPSK 13.5 15.0 

1 1 QPSK 27.0 30.0 

2 1 QPSK 40.5 45.0 

3 1 16-QAM 54.0 60.0 

4 1 16-QAM 81.0 90.0 

5 1 64-QAM 108.0 120.0 

6 1 64-QAM 121.5 135.0 

7 1 64-QAM 135.0 150.0 

8 2 BPSK 27.0 30.0 

9 2 QPSK 54.0 60.0 

10 2 QPSK 81.0 90.0 

11 2 16-QAM 108.0 120.0 

12 2 16-QAM 162.0 180.0 

13 2 64-QAM 216.0 240.0 

14 2 64-QAM 243.0 270.0 

15 2 64-QAM 270.0 300.0 

 

For example, if you specify the maximum MCS index as 5 for mandatory rates, rates corresponding to 
MCS indexes 0 through 5 are configured as 802.11n mandatory rates. 

 Mandatory rates must be supported by the AP and the clients that want to associate with the AP. 

 Supported rates allow some clients that support both mandatory and supported rates to choose 
higher rates when communicating with the AP. 

 Multicast MCS: Specifies 802.11n multicast data rates. 

Configuring 802.11n rates 
Select Radio > Rate from the navigation tree to enter the rate setting page, as shown in Figure 34-10: 

Figure 34-10 Set 802.11n rate 

 
 

Table 34-6 shows the configuration items of setting 802.11n rate. 
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Table 34-6 Configuration items of setting 802.11n rate 

Item Description 

Mandatory 
Maximum MCS 

Set the maximum MCS index for 802.11n mandatory rates. 

 
If you select the client dot11n-only check box, you must configure the mandatory 
maximum MCS. 

Multicast MCS 

Set the multicast MCS for 802.11n. 
The multicast MCS is adopted only when all the clients use 802.11n. If a non 802.11n 
client exists, multicast traffic is transmitted at a mandatory MCS data rate. 

 
When the multicast MCS takes effect, the corresponding data rates defined for 20 MHz 
are adopted no matter whether the 802.11n radio operates in 40 MHz mode or in 20 
MHz mode. 

Supported Maximum 
MCS Set the maximum MCS index for 802.11n supported rates. 

 

Configuring Channel Scanning 

 

 

For the detailed description of active passive scanning, see Wireless Service. 

 

Select Radio > Scan from the navigation tree to enter the page for setting channel scanning, as shown 
in Figure 34-11: 

Figure 34-11 Set channel scanning 

 

 

Table 34-7 shows the configuration items of setting channel scanning. 

Table 34-7 Configuration items of setting channel scanning 

Item Description 

Scan Mode 
Set the scan mode. 

 Auto: Legal channels with the scanning mode under country code are scanned. 
 All: All the channels of the radio band are scanned. 
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Item Description 

Scan Non-802.11h 
Channel 

Some of 802.11h channels, also called radar channels, overlap some 802.11a 
channels. If the device operates on an overlapping channel, its service quality may be 
affected. With this function enabled, the device selects a working channel from 
non-802.11h channels belonging to the configured country code to avoid channel 
collision. 
Selecting the check box before Scan Non-802.11h Channel enables the function of 
scanning non-802.11h channels. 
By default, the scan mode is auto, that is, all channels of the country code being set are 
scanned. 

Scan Type 

Set the scan type. 
 Active: The active scanning mode requires a client to send a probe request. This 

scanning mode enables a client to discover APs more easily. 
 Passive: Passive scanning is used by a client when it wants to save battery power. 

Typically, VoIP clients adopt the passive scanning mode. 

Scan Interval 
Set the scan report interval. 

 A longer scan interval enables a client to have more chances to discover an AP. 
 A shorter scan interval enables a client to discover an AP more quickly. 

 

Configuring Calibration 

Parameter Settings 

Select Radio > Calibration, and select the Parameters tab to enter the page for setting channel 
calibration, as shown in Figure 34-12: 

Figure 34-12 Parameter settings 

 
 



 

34-14 

Table 34-8 shows the configuration items of parameter settings. 

Table 34-8 Configuration items of parameter settings 

Item Description 

Calibration 
Interval 

Channel and power calibration interval. RRM algorithms run periodically at the 
calibration interval for transmit power control or dynamic frequency selection.

802.11g 
Protection 
Mode 

 RTS/CTS: Uses RTS/CTS mode to implement 802.11g protection. Before 
sending data to a client, AP 1 sends an RTS packet to the client, ensuring 
that all the devices within the coverage of AP 1 do not send data in the 
specified time after receiving the RTS packet. Upon receiving the RTS 
packet, the client will send a CTS packet again, ensuring that all the 
devices within the coverage of the client do not send data in the specified 
time. 

 CTS-to-Self: Uses CTS-to-Self mode to implement 802.11g protection. 
When AP 1 sends packets to a client, it uses its IP address to send a CTS 
packet to inform the client that it will send a packet, ensuring that all the 
devices within the coverage of AP 1 do not send data in the specified time.

Basic Setup 

802.11g 
Protection 

Because dot11b devices cannot be aware of 802.11g packets, dot11g 
protection needs to be enabled for a 802.11g device to send RTS/CTS or 
CTS-to-self packets to 802.11b devices, which will defer access to the 
medium. 
An AP running 802.11g uses the 802.11g protection function in the following 
two cases: 

 An 802.11b client is associated with it. 
 It detects APs or clients running 802.11b on the same channel. 
 Enable: Enables 802.11g protection. 
 Close: Disables 802.11g protection. 

 
 Enabling 802.11g protection reduces network performance. 
 Enabling 802.11g protection applies to the second case only, because 

802.11g protection is always enabled for the first case. 

Note the following when configuring channel adjustment: 
 Before configuring channel adjustment, make sure that the AC adopts the auto channel 

adjustment mode (see Configuring Radio Parameters for more information). Otherwise, 
channel adjustment does not work. 

 If you lock the channel first, and then enable channel adjustment, channel adjustment does 
not work because the channel is locked. Therefore, before enabling channel adjustment, 
make sure that the channel is not locked. 

 If you enable channel adjustment and then lock the channel, the last selected channel is 
locked. 

For how to lock the channel, see Locking the Channel. 

Channel 
Setup 

Dynamic 
Channel 
Select 

 Close: Disables the channel adjustment function. 
 Auto: With automatic channel adjustment enabled, an AC performs 

channel adjustment for a radio when certain trigger conditions are met on 
the channel, and returns the result to the AP after a calibration interval (the 
default calibration interval is 8 minutes, which can be set through the 
Calibration Interval option). After that, the AC will make channel 
adjustment decisions at the calibration interval automatically. 

 Manual: With manual channel adjustment configured for a radio, an AC 
performs channel adjustment for the radio when certain trigger conditions 
are met on the channel, and returns the result to the AP after a calibration 
interval. After that, if you want the AC to perform channel adjustment for the 
radio, you have to make this configuration again. 

 
If you select the manual mode, you need to click Calibration on the 
Calibration page every time you perform channel calibration. 
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Item Description 

CRC Error 
Threshold Set the CRC error threshold value, in percentage. 

Channel 
Interference 
Threshold 

Set the channel interference threshold value, in percentage. 

Tolerance 
Factor 

A new channel is selected when either the configured CRC error threshold or 
interference threshold is exceeded on the current channel. However, the new 
channel is not applied until the quality of the current channel is worse than that 
of the new channel by the tolerance threshold. 

Spectrum 
Management 

 Enable: Enables spectrum management. 
 Close: Disables spectrum management. 

Note the following when configuring power adjustment: 
 If you lock the power first, and then enable power adjustment, power adjustment does not 

work because the power is locked. Therefore, before enabling power adjustment, make 
sure that the power is not locked. 

 If you enable power adjustment and then lock the power, the last selected power is locked.
For how to lock the power, see Locking the Power. 

Dynamic 
Power Select 

 Close: Disables power adjustment. 
 Auto: With automatic power adjustment enabled, the AC performs power 

adjustment for an AP upon certain interference and returns the result to the 
AP after a calibration interval (the default calibration interval is 8 minutes, 
which can be set through the Calibration Interval option). After that, the 
AC makes power adjustment decisions at the calibration interval 
automatically. 

 Manual: With manual power adjustment configured, an AC performs power 
adjustment for the AP upon certain interference, and returns the result to 
the AP after a calibration interval (the default calibration interval is 8 
minutes, which can be set through the Calibration Interval option). After 
that, if you want the AC to perform power adjustment for the AP, you have 
to make this configuration again. 

 
If you select the manual mode, you need to click Calibration on the 
Calibration page every time you perform channel calibration. 

Max 
Neighbor 
Count 

Specifies the number of neighbors. Neighbors refer to other APs that can be 
detected by this AP and managed by the same AC. 

Power Setup 

Power 
Constraint 

Set the power constraint for all 802.11a radios. For example, if the country 
code is China, the 802.11a rate is 19 dbm by default; if the power constraint is 
set to 4, the 802.11a rate is 15 dbm. 

 
Enable spectrum management before configuring the power constraint; 
otherwise, the configuration does not take effect. 

 

Configuring a Radio Group 

With channel adjustment or power adjustment configured for a radio, an AC calculates the channel 
quality or power of the radio at a specified interval. When the result meets certain trigger conditions, the 
AC selects a new channel or power for the radio. However, in an environment where interference is 
serious, frequent channel or power adjustments may affect user access to the WLAN network. In this 
case, you can configure a radio group to keep the channel or power of radios in the group unchanged 



 

34-16 

within a specified time. The channel and power of those radios that are not added to the radio group are 
adjusted accordingly. 

When a radio group is configured, the channel or power of radios that are added into the radio group 
keeps unchanged within the specified holddown time after a channel or power adjustment (manual, 
automatic, or initial channel adjustment). When the holddown time expires, the AC calculates the 
channel and power again. If the result meets a certain trigger condition, the channel or power of the 
radios in the radio group keeps unchanged within the specified holddown time after a channel or power 
adjustment. This mechanism continues. 

 

 

You need to configure a radio group on the Radio Group page. Before entering the Radio Group page, 
configure channel or power adjustment on the Parameters tab page. 

 

Select Radio > Calibration from the navigation tree, select Radio Group, and then click Add. The 
page as shown in Figure 34-13 appears. 

Figure 34-13 Configure a radio group 

 

 

Table 34-9 shows the radio group configuration items. 

Table 34-9 Radio group configuration items 

Item Remarks 

Group ID ID of the radio group 

Description 
Description of the radio group 
By default, a radio group has no description. 
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Item Remarks 

Channel 
Holddown 
Interval 

Specify that the current channel keeps unchanged within the specified time after a channel 
adjustment (manual, automatic, or initial channel selection). 

 
The AC immediately selects another channel when it detects any radar signals on the 
current channel, and then resets the channel holddown timer. 

Power Holddown 
Interval 

Specify that the current power keeps unchanged within the specified time after a power 
adjustment (manual or automatic power adjustment). 

Radio List 

 Select the target radios from the Radios Available area, and then click << to add them 
into the Radios Selected area. 

 Select the radios to be removed from the Radios Selected, and the click >> to remove 
them from the radio group. 

 

Calibration Operations 

 

 

If RRM is not enabled, or the radio to be displayed works on a fixed channel, you can only view the work 
channel and the power of the radio on the Operations tab in the Radio > Calibration page. Other 
information such as interference observed and the number of neighbors is displayed when RRM is 
enabled, that is, dynamic power selection or automatic dynamic frequency selection is enabled. For the 
configuration of RRM parameters, see Parameter Settings. 

 

Displaying channel status 
Select Radio > Calibration from the navigation tree, click the Operations tab, click the Channel 
Status tab, and then click the desired radio to enter the page for displaying channel status, as shown in 
Figure 34-14: 

Figure 34-14 Channel status 

 
 

Table 34-10 shows the configuration items of channel status. 

Table 34-10 Configuration items of setting channel status 

Item Description 

Channel No Running channel 

Neighbor Num Number of neighbors on a channel 

Load (%) Load detected on a channel 

Utilization (%) Channel utilization 
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Item Description 

Interference (%) Interference detected on a channel 

Packet Error Rate (%) Error rate for packets on a channel 

Retransmission Rate (%) Retransmission rate on a channel 

Radar Detect Radar detection status 

 

Displaying neighbor information 
Select Radio > Calibration from the navigation tree, click the Operations tab, and then click the 
Neighbor Info tab, and then click the desired radio to enter the page for displaying neighbor information, 
as shown in Figure 34-15: 

Figure 34-15 Neighbor information 

 
 

Table 34-11 shows the configuration items of neighbor information. 

Table 34-11 Configuration items of setting neighbor information 

Item Description 

AP MAC Address MAC address of an AP 

Channel No Running channel 

Interference (%) Interference detected on a channel 

RSSI (dBm) Received signal strength indication (RSSI) of AP, in dBm. 

AP Type AP type, managed or unmanaged 

 



 

34-19 

Displaying history information 
 

 

History information is available only if channel switching or power adjustment occurs after RRM is 
enabled. 

 

Select Radio > Calibration from the navigation tree, click the Operations tab, click the History Info 
tab, and then click the desired radio to enter the page for displaying neighbor information. 

Figure 34-16 Display neighbor information 

 

 

Table 34-12 shows the configuration items of history information. 

Table 34-12 Configuration items of setting history information 

Field Description 

Radio Radio ID of the AP  

Basic BSSID MAC address of the AP 

Chl Channel on which the radio operates in case of the change of channel or power 

Power Power of the radio in case of the change of channel or power 

Load Load observed on the radio in percentage in case of the change of channel or power  

Util Utilization of the radio in percentage in case of the change of channel or power 

Intf Interference observed on the radio in percentage in case of the change of channel or power 

PER Packet error rate observed on a channel, in percentage 

Retry Percentage of retransmission happened on the radio before/after the change of channel or 
power 

Reason Reason for the change of channel or power, such as Interference, packets discarded, 
retransmission, radar or coverage 
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Field Description 

Date Date when the channel or power change occurred 

Time Time when the channel or power change occurred  

 

Antenna 

Select Radio > Antenna to select an appropriate antenna for the corresponding radio, as shown in 
Figure 34-17. 

Figure 34-17 Configure antenna switching 

 

 

 

In the Antenna drop-down list, Internal Antenna is displayed for APs supporting internal antennas, the 
antenna model is displayed for APs supporting external antennas, and Internal Antenna and the 
antenna model are displayed for APs supporting both internal and external antennas.. 

 

Configuration Examples 

Manual Channel Adjustment Configuration Example 

Network requirements 
As shown in Figure 34-18, configure manual channel adjustment on the AC so that the AC can perform 
manual channel adjustment when the channel of AP 1 is unavailable. 

Figure 34-18 Network diagram for manual channel adjustment configuration 

AC L2 Switch AP 1
Client  

 

Configuration procedure 
1) Before configuring manual channel adjustment, complete the following task: 

Configure AP 1 on the AC to establish a CAPWAP connection between them. For the related 
configuration, see Wireless Service. 
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2) Configure manual channel adjustment 

Select Radio > Calibration from the navigation tree, and then select the Parameters tab to enter the 
Parameters tab page, as shown in Figure 34-19. 

Figure 34-19 Configure manual channel adjustment 

 

 

 Select Manual from the Dynamic Channel Select drop-down list. 

 Click Apply. 

3) Perform manual channel adjustment 

Select Radio > Calibration from the navigation tree, and then select the Operation tab to enter the 
Operation tab page, as shown in Figure 34-20. 
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Figure 34-20 Perform manual channel adjustment 

 

 

Select the check box of the target radio, and click Channel Optimize. 

Configuration verification 
 You can view the channel status on the Operation tab page, which you can enter by selecting 

Radio > Calibration from the navigation tree, and then selecting the Operation tab. 

 You can view the detailed information, such as the specific reason for channel adjustment on the 
History Info tab page, which you can enter by selecting Radio > Calibration from the navigation 
tree, selecting the Operation tab, and then selecting History Info. 

Configuration guidelines 
If you select manual channel adjustment, click Channel Optimize on the Operation tab page every 
time you perform manual channel adjustment. 

Automatic Power Adjustment Configuration Example 

Network requirements 
As shown in Figure 34-21, AP 1 through AP 3 are connected to the AC. It is required to configure 
automatic power adjustment and specify the adjacency factor as 3 on the AC. In this way, when AP 4 
joins, the AC performs automatic power adjustment to avoid interference. 

Figure 34-21 Network diagram for automatic power adjustment configuration 

 

 
 

1) Before configuring automatic power adjustment, complete the following task: 
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Configure AP 1 through AP 3 on the AC to establish a CAPWAP connection between the AC and each 
AP. For the related configuration, see Wireless Service. 

2) Configure automatic power adjustment 

Select Radio > Calibration from the navigation tree, and then select the Parameters tab to enter the 
Parameters tab page, as shown in Figure 34-22. 

Figure 34-22 Configure automatic power adjustment 

 
 

 Select Auto from the Dynamic Power Select drop-down list. 

 Click Apply. 

Configuration verification 
 You can view the power of each AP on the Operation tab page, which you can enter by selecting 

Radio > Calibration from the navigation tree and then selecting the Operation tab. 

 When AP 4 joins (the adjacency number becomes 3), the maximum number of neighbors reaches 
the upper limit (3 by default), and the AC performs power adjustment after the calibration interval. 
You can view the detailed information, such as decrease of the Tx power value, on the History Info 
tab page, which you can enter by selecting Radio > Calibration from the navigation tree, selecting 
the Operation tab, and then selecting History Info. 
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Radio Group Configuration Example 

Network requirements 
As shown in Figure 34-23, AP 1 through AP 3 are connected to the AC. It is required to: 

 Configure automatic channel adjustment so that the AC can automatically switch the channel when 
the signal quality on a channel is degraded to a certain level. 

 Configure automatic power adjustment so that the AC can automatically adjust the power when the 
third neighbor is discovered (or in other words, when AP 4 joins) to avoid interference. 

 Add radio 2 of AP 1 and radio 2 of AP 2 to a radio group to prevent frequent channel or power 
adjustments for the radios. 

Figure 34-23 Network diagram for radio group configuration 

 

 

1) Before configuring a radio group, complete the following task: 

Configure AP 1 through AP 3 on the AC to establish a CAPWAP connection between the AC and each 
AP. For the related configuration, see Wireless Service. 

2) Configure automatic channel and power adjustment 

Select Radio > Calibration from the navigation tree, and then select the Parameters tab to enter the 
Parameters tab page, as shown in Figure 34-24. 
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Figure 34-24 Configure automatic channel and power adjustment 

  
 

 Select Auto from the Dynamic Channel Select drop-down list. 

 Select Auto from the Dynamic Power Select drop-down list. 

 Click Apply. 

3) Configuring a radio group 

Select Radio > Calibration from the navigation tree, select Radio Group, and then click Add. The 
page as shown in Figure 34-25 appears. 
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Figure 34-25 Configure the radio group 

 
 

 Type the channel holddown interval 20. 

 Type the power holddown interval 30. 

 In the Radios Available area, select the target radios, and then click << to add them into the 
Radios Selected area. 

 Click Apply. 

Configuration verification 
 The working channel of radio 2 of AP 1 and that of radio 2 of AP 2 do not change within 20 minutes 

after each automatic channel adjustment. 

 The power of radio 2 of AP 1 and that of radio 2 of AP 2 do not change within 30 minutes after each 
automatic power adjustment. 
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35  802.1X 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

The 802.1X protocol was proposed by the IEEE 802 LAN/WAN committee for security of wireless LANs 
(WLAN).It has been widely used on Ethernet as a common port access control mechanism. 

As a port-based access control protocol, 802.1X authenticates and controls accessing devices at the 
port level. A device connected to an 802.1X-enabled port of an access control device can access the 
resources on the LAN only after passing authentication. 

Architecture of 802.1X 

802.1X operates in the typical client/server model and defines three entities: Client, Device, and Server, 
as shown in Figure 35-1. 

Figure 35-1 Architecture of 802.1X  

 

 

 Client is an entity seeking access to the LAN. It resides at one end of a LAN segment and is 
authenticated by Device at the other end of the LAN segment. Client is usually a user-end device 
such as a PC. 802.1X authentication is triggered when an 802.1X-capable client program is 
launched on Client. The client program must support Extensible Authentication Protocol over LAN 
(EAPOL). 

 Device, residing at the other end of the LAN segment, authenticates connected clients. Device is 
usually an 802.1X-enabled network device and provides access ports (physical or logical) for 
clients to access the LAN. 
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 Server is the entity that provides authentication services to Device. Server, normally running 
RADIUS (Remote Authentication Dial-in User Service), serves to perform authentication, 
authorization, and accounting services for users. 

Authentication Modes of 802.1X 

The 802.1X authentication system employs the Extensible Authentication Protocol (EAP) to exchange 
authentication information between the client, device, and authentication server. 

 Between the client and the device, EAP protocol packets are encapsulated using EAPOL to be 
transferred on the LAN. 

 Between the device and the RADIUS server, EAP protocol packets can be exchanged in two 
modes: EAP relay and EAP termination. In EAP relay mode, EAP packets are encapsulated in EAP 
over RADIUS (EAPOR) packets on the device, and then relayed by device to the RADIUS server. 
In EAP termination mode, EAP packets are terminated at the device, converted to RADIUS 
packets either with the Password Authentication Protocol (PAP) or Challenge Handshake 
Authentication Protocol (CHAP) attribute, and then transferred to the RADIUS server. 

Basic Concepts of 802.1X 

These basic concepts are involved in 802.1X: controlled port/uncontrolled port, authorized 
state/unauthorized state, and control direction. 

Controlled port and uncontrolled port 
A device provides ports for clients to access the LAN. Each port can be regarded as a unity of two 
logical ports: a controlled port and an uncontrolled port. Any packets arriving at the port are visible to 
both of the logical ports. 

 The uncontrolled port is always open in both the inbound and outbound directions to allow EAPOL 
protocol packets to pass, guaranteeing that the client can always send and receive authentication 
packets. 

 The controlled port is open to allow data traffic to pass only when it is in the authorized state. 

Authorized state and unauthorized state 
A controlled port can be in either authorized state or unauthorized state, which depends on the 
authentication result, as shown in Figure 35-2. 
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Figure 35-2 Authorized/unauthorized state of a controlled port 

 

 

You can control the port authorization status of a port by setting port authorization mode to one of the 
following three: 

 Force-Authorized: Places the port in authorized state, allowing users of the port to access the 
network without authentication. 

 Force-Unauthorized: Places the port in unauthorized state, denying any access requests from 
users of the port. 

 Auto: Places the port in the unauthorized state initially to allow only EAPOL packets to pass, and 
turns the port into the authorized state to allow access to the network after the users pass 
authentication. This is the most common choice. 

Control direction 
In the unauthorized state, the controlled port can be set to deny traffic to and from the client or just the 
traffic from the client.  

 

 

Currently, your device can only be set to deny traffic from the client. 

 

EAP over LANs 

EAPOL frame format 
EAPOL, defined in 802.1X, is intended to carry EAP protocol packets between clients and devices over 
LANs. Figure 35-3 shows the EAPOL frame format. 
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Figure 35-3 EAPOL frame format  

 
 

PAE Ethernet type: Protocol type. It takes the value 0x888E. 

Protocol version: Version of the EAPOL protocol supported by the sender. 

Type: Type of the EAPOL frame. Table 35-1 lists the types that the device currently supports. 

Table 35-1 Types of EAPOL frames 

Type Description 

EAP-Packet (a value of 0x00) 

Packet for carrying authentication information, present between the device 
and the authentication server. 
A packet of this type is repackaged and transferred by RADIUS on the 
device to get through complex networks to reach the authentication server.

EAPOL-Start (a value of 0x01) Packet for initiating authentication, present between a client and the device.

EAPOL-Logoff (a value of 0x02) Packet for the logoff request, present between a client and the device. 

 

Length: Length of the data, that is, length of the Packet body field, in bytes. If the value of this field is 0, 
no subsequent data field is present. 

Packet body: Content of the packet. The format of this field depends on the value of the Type field. 

EAP packet format 
An EAP-Packet-type EAPOL frame carries an EAP packet in its Packet body field. The format of the 
EAP packet is shown in Figure 35-4. 

Figure 35-4 EAP packet format 

 
 

Code: Type of the EAP packet, which can be Request, Response, Success, or Failure. 

 An EAP success/failure packet has no Data field, and has a length of 4. 

 An EAP Request/Response packet has a Data field in the format shown in Figure 35-5. The Type 
field indicates the EAP authentication type. A value of 1 represents Identity, indicating that the 
packet is for querying the identity of the client. A value of 4 represents MD5-Challenge, which are 
similar to the PPP CHAP protocol. 
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Figure 35-5 Format of the Data field in an EAP request/response packet 

 

 

Identifier: Helps match responses with requests. 

Length: Length of the EAP packet, including the Code, Identifier, Length, and Data fields, in bytes. 

Data: Content of the EAP packet. Its format is determined by the Code field. 

EAP over RADIUS 

Two attributes of RADIUS are intended for supporting EAP authentication: EAP-Message and 
Message-Authenticator. For information about RADIUS packet format, refer to MAC Address 
Configuration. 

EAP-Message 
The EAP-Message attribute is used to encapsulate EAP packets. Figure 35-6 shows its encapsulation 
format. The value of the Type field is 79. The String field can be up to 253 bytes long. If the EAP packet 
is longer than 253 bytes, it can be fragmented and encapsulated into multiple EAP-Message attributes. 

Figure 35-6 Encapsulation format of the EAP-Message attribute 
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Message-Authenticator 
Figure 35-7 shows the encapsulation format of the Message-Authenticator attribute. The 
Message-Authenticator attribute is used to prevent access requests from being snooped during EAP or 
CHAP authentication. It must be included in any packet with the EAP-Message attribute; otherwise, the 
packet will be considered invalid and discarded. 

Figure 35-7 Encapsulation format of the Message-Authenticator attribute 

 

 

802.1X Authentication Triggering 

802.1X authentication can be initiated by either a client or the device. 

Unsolicited triggering of a client 
A client can initiate authentication unsolicitedly by sending an EAPOL-Start packet to the device. The 
destination address of the packet is 01-80-C2-00-00-03, the multicast address specified by the IEEE 
802.1X protocol. 
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Some devices in the network may not support multicast packets with the above destination address, 
and unable to receive authentication requests of clients as a result. To solve this problem, the device 
also supports EAPOL-Start packets using a broadcast MAC address as the destination address. This 
solution requires the H3C iNode 802.1X client. 

Unsolicited triggering of the device 
The device can trigger authentication by sending EAP-Request/Identity packets to unauthenticated 
clients periodically (every 30 seconds by default). This method can be used to authenticate clients that 
cannot send EAPOL-Start packets unsolicitedly to trigger authentication, for example, a client running 
the 802.1X client application provided by Windows XP. 

Authentication Process of 802.1X 

An 802.1X device communicates with a remote RADIUS server in two modes: EAP relay and EAP 
termination. The following describes the 802.1X authentication procedure in the two modes, which is 
triggered by the client in the examples. 

EAP relay 
EAP relay is defined in IEEE 802.1X. In this mode, EAP packets are carried in an upper layer protocol, 
such as RADIUS, so that they can go through complex networks and reach the authentication server. 
Generally, relaying EAP requires that the RADIUS server support the EAP attributes of EAP-Message 
and Message-Authenticator, which are used to encapsulate EAP packets and protect RADIUS packets 
carrying the EAP-Message attribute respectively. 

Figure 35-8 shows the message exchange procedure with EAP-MD5. 
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Figure 35-8 802.1X authentication procedure in EAP relay mode  
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1) When a user launches the 802.1X client software and enters the registered username and 
password, the 802.1X client software generates an EAPOL-Start frame and sends it to the device 
to initiate an authentication process.  

2) Upon receiving the EAPOL-Start frame, the device responds with an EAP-Request/Identity packet 
for the username of the client. 

3) When the client receives the EAP-Request/Identity packet, it encapsulates the username in an 
EAP-Response/Identity packet and sends the packet to the device.  

4) Upon receiving the EAP-Response/Identity packet, the device relays the packet in a RADIUS 
Access-Request packet to the authentication server. 

5) When receiving the RADIUS Access-Request packet, the RADIUS server compares the identify 
information against its user information table to obtain the corresponding password information. 
Then, it encrypts the password information using a randomly generated challenge, and sends the 
challenge information through a RADIUS Access-Challenge packet to the device. 

6) After receiving the RADIUS Access-Challenge packet, the device relays the contained 
EAP-Request/MD5 Challenge packet to the client.  
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7) When receiving the EAP-Request/MD5 Challenge packet, the client uses the offered challenge to 
encrypt the password part (this process is not reversible), creates an EAP-Response/MD5 
Challenge packet, and then sends the packet to the device. 

8) After receiving the EAP-Response/MD5 Challenge packet, the device relays the packet through a 
RADIUS Access-Request packet to the authentication server. 

9) When receiving the RADIUS Access-Request packet, the RADIUS server compares the password 
information encapsulated in the packet with that generated by itself. If the two are identical, the 
authentication server considers the user valid and sends to the device a RADIUS Access-Accept 
packet. 

10) Upon receiving the RADIUS Access-Accept packet, the device opens the port to grant the access 
request of the client. After the client gets online, the device periodically sends handshake requests 
to the client to check whether the client is still online. By default, if two consecutive handshake 
attempts end up with failure, the device concludes that the client has gone offline and performs the 
necessary operations, guaranteeing that the device always knows when a client goes offline. 

11) The client can also send an EAPOL-Logoff frame to the device to go offline unsolicitedly. In this 
case, the device changes the status of the port from authorized to unauthorized and sends an 
EAP-Failure packet to the client. 

 

 

In EAP relay mode, a client must use the same authentication method as that of the RADIUS server. On 
the device, however, you only need to enable EAP relay. 

 

EAP termination 
In EAP termination mode, EAP packets are terminated at the device and then repackaged into the PAP 
or CHAP attributes of RADIUS and transferred to the RADIUS server for authentication, authorization, 
and accounting. Figure 35-9 shows the message exchange procedure with CHAP authentication. 
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Figure 35-9 802.1X authentication procedure in EAP termination mode  

EAPOL EAPOR

EAPOL-Start

EAP-Request / Identity

EAP-Response / Identity

EAP-Request / MD5 challenge

EAP-Success

EAP-Response / MD5 challenge

Handshake request
( EAP-Request / Identity )

Handshake response
( EAP-Response / Identity )

EAPOL-Logoff

......

Client Device Server

Port authorized

Handshake timer

Port unauthorized

RADIUS Access-Request
(CHAP-Response / MD5 challenge)

RADIUS Access-Accept
(CHAP-Success)

 
 

Different from the authentication process in EAP relay mode, it is the device that generates the random 
challenge for encrypting the user password information in EAP termination authentication process. 
Consequently, the device sends the challenge together with the username and encrypted password 
information from the client to the RADIUS server for authentication. 

802.1X Timers 

This section describes the timers used on an 802.1X device to guarantee that the client, the device, and 
the RADIUS server can interact with each other in a reasonable manner.  

 Username request timeout timer: This timer is triggered by the device in two cases. The first case is 
when the client requests for authentication. The device starts this timer when it sends an 
EAP-Request/Identity packet to a client. If it receives no response before this timer expires, the 
device retransmits the request. The second case is when the device authenticates the 802.1X 
client that cannot request for authentication actively. The device sends multicast 
EAP-Request/Identity packets periodically through the port enabled with 802.1X function. In this 
case, this timer sets the interval between sending the multicast EAP-Request/Identity packets. 
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 Client timeout timer: Once a device sends an EAP-Request/MD5 Challenge packet to a client, it 
starts this timer. If this timer expires but it receives no response from the client, it retransmits the 
request. 

 Server timeout timer: Once a device sends a RADIUS Access-Request packet to the 
authentication server, it starts this timer. If this timer expires but it receives no response from the 
server, it retransmits the request. 

 Handshake timer: After a client passes authentication, the device sends to the client handshake 
requests at this interval to check whether the client is online. If the device receives no response 
after sending the allowed maximum number of handshake requests, it considers that the client is 
offline. 

 Quiet timer (quiet-period): When a client fails the authentication, the device refuses further 
authentication requests from the client in this period of time. 

 Periodic re-authentication timer: If periodic re-authentication is enabled on a port, the device 
re-authenticates online users on the port at the interval specified by this timer. 

802.1X Extensions 

The devices extend and optimize the mechanism that the 802.1X protocol specifies by: 

 Allowing multiple users to access network services through the same physical port. 

 Supporting two port access control methods: MAC-based access control and port-based access 
control. With the MAC-based access control method configured on a port, all users of the port must 
be authenticated separately, and when a user goes offline, no other users are affected. With the 
port-based access control method configured on a port, after a user connected to the port passes 
authentication, all subsequent users of the port can access network resources without 
authentication. However, when the authenticated user goes offline, the others are denied as well. 

Features Working Together with 802.1X 

VLAN assignment 
After an 802.1X user passes the authentication, the server will send an authorization message to the 
device. If the server is configured with the VLAN assignment function, the assigned VLAN information 
will be included in the message. The device, depending on the link type of the port used to log in, adds 
the port to the assigned VLAN according to the following rules: 

 If the port link type is Access, the port leaves its initial VLAN, that is, the VLAN configured for it and 
joins the assigned VLAN. 

 If the port link type is Trunk, the assigned VLAN is allowed to pass the current trunk port. The 
default VLAN ID of the port is that of the assigned VLAN. 

 If the port link type is Hybrid, the assigned VLAN is allowed to pass the current port without carrying 
the tag. The default VLAN ID of the port is that of the assigned VLAN. Note that if the Hybrid port is 
assigned a MAC-based VLAN, the device will dynamically create a MAC-based VLAN according to 
the VLAN assigned by the authentication server, and remain the default VLAN ID of the port 
unchanged.  
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The assigned VLAN neither changes nor affects the configuration of a port. However, as the assigned 
VLAN has higher priority than the initial VLAN of the port, it is the assigned VLAN that takes effect after 
a user passes authentication. After the user goes offline, the port returns to the initial VLAN of the port. 

 

 

 With a Hybrid port, the VLAN assignment will fail if you have configured the assigned VLAN to carry 
tags. 

 With a Hybrid port, you cannot configure an assigned VLAN to carry tags after the VLAN has been 
assigned. 

 

Guest VLAN 
Guest VLAN allows unauthenticated users and users failing the authentication to access a specified 
VLAN, where the users can, for example, download or upgrade the client software, or execute some 
user upgrade programs. This VLAN is called the guest VLAN. 

Depending on the port access control method, a guest VLAN can be a port-based guest VLAN (PGV) or 
a MAC-based guest VLAN (MGV): 

 PGV is supported on a port that uses the access control method of port-based access control.  

 MGV is supported on a port that uses the access control method of MAC-based access control.  

1) PGV 

With PGV configured on a port, if no users are successfully authenticated on the port in a certain period 
of time (90 seconds by default), the port will be added to the guest VLAN and all users accessing the 
port will be authorized to access the resources in the guest VLAN. 

The device adds a PGV-configured port into the guest VLAN according to the port’s link type in the 
similar way as described in VLAN assignment. When a user of a port in the guest VLAN initiates an 
authentication, if the authentication is not successful, the port stays in the guest VLAN; if the 
authentication is successful, the port leaves the guest VLAN, and: 

 If the authentication server assigns a VLAN, the port joins the assigned VLAN. After the user goes 
offline, the port returns to its initial VLAN, that is, the VLAN specified for it during port configuration, 
or, in other words, the VLAN it was in before it joined the guest VLAN. 

 If the authentication server does not assign any VLAN, the port returns to its initial VLAN. After the 
client goes offline, the port just stays in its initial VLAN. 

2) MGV 

With MGV configured on a port, users failing the authentication are authorized to access the resources 
in the guest VLAN. 

If a user in the guest VLAN initiates another authentication process but fails the authentication, the 
device will keep the user in the guest VLAN. If the user passes the authentication, the device will add 
the user to the assigned VLAN or return the user to its initial VLAN, depending on whether the 
authentication server assigns a VLAN. 

ACL assignment 
ACLs provide a way of controlling access to network resources and defining access rights. When a user 
logs in through a port, and the RADIUS server is configured with authorization ACLs, the device will 
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permit or deny data flows traversing through the port according to the authorization ACLs. Before 
specifying authorization ACLs on the server, you need to configure the ACL rules on the device. You 
can change the access rights of users by modifying authorization ACL settings on the RADIUS server or 
changing the corresponding ACL rules on the device. 

Configuring 802.1X 

Configuration Task List 

802.1X provides a method for implementing user identity authentication. However, 802.1X cannot 
implement the authentication method solely by itself. RADIUS or local authentication must be 
configured to work with 802.1X. Therefore, before the 802.1X configuration, you need to configure the 
following: 

 Configure the ISP domain to which the 802.1X user belongs and the AAA method to be used (that 
is, local authentication or RADIUS authentication.  

 For remote RADIUS authentication, the username and password information must be configured 
on the RADIUS server. 

 For local authentication, the username and password information must be configured on the device 
and the service type must be set to LAN-access.  

Table 35-2 lists the 802.1X configuration procedure. 

Table 35-2 802.1X configuration procedure 

Task Description 

Configuring 802.1X Globally 

Required 
Enable 802.1X authentication globally and configure the authentication 
method and advanced parameters. 
By default, 802.1X authentication is disabled globally. 

Configuring 802.1X on a Port 

Required 
Enable 802.1X authentication on specified ports and configure 802.1X 
parameters for the ports. 
By default, 802.1X authentication is disabled on a port. 

 

Configuring 802.1X Globally 

From the navigation tree, select Authentication > 802.1X to enter the page shown as Figure 35-10. In 
the 802.1X Configuration area, you can view and configure the 802.1X feature globally. 
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Figure 35-10 802.1X 

 
 

Table 35-3 lists global 802.1X configuration items. 

Table 35-3 Global 802.1X configuration items 

Item Description 

Enable 802.1X Enable or disable 802.1X authentication globally. 

Authentication Method 
Specify the authentication method for 802.1X users.  
Options include CHAP, PAP, and EAP. 

Quiet  

Specify whether to enable the quiet timer. 
After an 802.1X user fails to be authenticated, the device will keep 
quiet for a period of time defined by Quiet Period. During the quiet 
period, the device will not perform 802.1X authentication on the user. 

Quiet Period Specify the value of the quiet timer. 

Retry Times 

Specify the maximum number of attempts to send an authentication 
request to a client. 
Within a specified period of time (defined by the TX Period or 
Supplicant Timeout Time option), if the device does not receive the 
response from the client, the device will determine whether to send 
an authentication request again according to the value defined by 
this parameter.  
1 means that the device will send an authentication request only 
once even if it does not receive any response from the client within 
the set interval. 2 means that the device will send an authentication 
request again if it does not receive any response from the client 
within the set interval, and so forth. 

TX Period Specify the transmission interval.  

Handshake Period Specify the handshake interval.  

Re-Authentication Period Specify the re-authentication interval. 

Supplicant Timeout Time Specify the client timeout interval. 

Advanced 

Server Timeout Time Specify the server timeout interval. 
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Return to 802.1X configuration procedure. 

Configuring 802.1X on a Port  

From the navigation tree, select Authentication > 802.1X to enter the page shown as Figure 35-10. In 
the Ports With 802.1X Enabled area, the 802.1X configuration on ports are listed. Click Add to enter 
the port 802.1X configuration page, as shown in Figure 35-11. 

Figure 35-11 802.1X configuration on a port 

 

 

Table 35-4 lists port 802.1X configuration items. 

Table 35-4 Port 802.1X configuration items  

Item Description 

Port 
Select the port to be enabled with 802.1X authentication. 
Only ports not enabled with 802.1X authentication are available. 

Port Control Specify the 802.1X port access control method for the port, which can be MAC Based 
or Port Based. 

Port Authorization 

Specify the 802.1X authorization mode for the port. 
Options include: 

 Auto: The initial state on the specified port is unauthorized and becomes 
authorized when the authentication is successful. This mode is commonly applied.

 Force-Authorized: The specified port is always in the authorized state. 
 Force-Unauthorized: The specified port is always in the unauthorized state. 

Max Number of Users Specify the maximum number of users allowed on the specified port. 

HandShake Specify whether to enable the online user handshake function, which is used by the 
device to periodically detect whether a user is still online.  

Re-authentication Specify whether to enable periodic re-authentication on the specified port. 
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Item Description 

Guest VLAN 

Specify whether to enable the guest VLAN function on the specified port. If you enable 
the function, you also need to specify the VLAN ID. 

 
 The specified VLAN ID must have existed. The VLAN ID can be configured on the 

page you enter by selecting Network > VLAN. 
 To configure a PGV, make sure that the 802.1X multicast trigger function is 

enabled on the port. To configure an MGV, make sure that the MAC VLAN function 
is enabled on the port. 

 

Return to 802.1X configuration procedure. 

Configuration Guidelines 

When configuring 802.1X, note that: 

1) 802.1X configuration on a specific port can take effect only after both global 802.1X and 802.1X on 
the specific port are enabled. 

2) Do not change the timer parameters of global 802.1X from their default values unless you have 
determined that the changes would better the interaction process in some special network 
environment. 

3) A port enabled with 802.1X cannot be added to an aggregation group. Meanwhile, it is prohibited to 
enable 802.1X on a port that belongs to an aggregation group. 

4) For an 802.1X client using Extensible Authentication Protocol (EAP) authentication, the device 
directly encapsulates contents from the client and sends them to the authentication server. In this 
scenario, the configuration on username format on the device does not take effect. For details 
about username format configuration, refer to MAC Address Configuration.  

5) The Voice VLAN and 802.1X functions are mutually exclusive on an access port if the connected 
client sends untagged traffic.  
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36  Portal Authentication 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Portal authentication, as its name implies, helps control access to the Internet. Portal authentication is 
also called web authentication and a website implementing portal authentication is called a portal 
website. 

With portal authentication, an access device forces all users to log into the portal website at first. Every 
user can access the free services provided on the portal website; but to access the Internet, a user must 
pass portal authentication on the portal website.  

A user can access a known portal website, enter username and password for authentication. This 
authentication mode is called active authentication. There is still another authentication mode, namely 
forced authentication, in which the access device forces a user trying to access the Internet through 
HTTP to log in to a portal website for authentication. 

The portal feature provides the flexibility for Internet service providers (ISPs) to manage services. A 
portal website can, for example, present advertisements, and deliver community services and 
personalized services. In this way, broadband network providers, equipment providers, and content 
service providers form an industrial ecological system. 

Introduction to Extended Portal Functions 

By forcing users to implement patching and anti-virus policies, extended portal functions help users to 
defend against viruses. The main extended functions are described as follows: 

 Security authentication mechanism: The security authentication mechanism works after the 
identity authentication process to check that the required anti-virus software, virus definition 
updates and OS patches are installed, and no unauthorized software is installed on the terminal of 
a user. 
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 Resource access limit: A user passing identity authentication can access only network resources 
like the anti-virus server or OS patch server, which are called the restricted resources. Only users 
passing security authentication can access more network resources, which are called the 
unrestricted resources.  

Portal System Components 

As shown in Figure 36-1, a typical portal system consists of five basic components: authentication client, 
access device, portal server, authentication/accounting server, and security policy server. 

 

 

A portal server can be an entity independent of the access device or an entity embedded in the access 
device. In this document, the term portal server refers to an independent portal server, and the term 
local portal server refers to an embedded one. 

 

Figure 36-1 Portal system components 

 

 

Authentication client 
Client system of a user to be authenticated. It can be a browser using the Hypertext Transfer Protocol 
(HTTP), or a host running the portal client software. The security authentication of a client depends on 
the communications between the portal client and the security policy server.  

Access device 
Device for broadband access. It can be a switch or a router that provides the following three functions: 

 Before authentication, redirecting all HTTP requests from users in the subnet to be authenticated to 
the portal server. 

 During authentication, interacting with the portal server, security policy server and the 
authentication/accounting server for identity authentication, security authentication and 
accounting. 

 After authentication, allowing users to access granted Internet resources. 
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Portal server 
Server that listens to authentication requests from portal clients and exchanges client authentication 
information with the access device. It provides free portal services and a web-based authentication 
interface. 

Authentication/accounting server 
Server that implements user authentication and accounting through interaction with the access device. 

Security policy server 
Server that interacts with portal clients and access devices for security authentication and resource 
authorization. 

The above five components interact in the following procedure: 

1) When an unauthenticated user enters a website address in the address bar of the IE to access the 
Internet, an HTTP request is created and sent to the access device, which redirects the HTTP 
request to the web authentication homepage of the portal server. For extended portal functions, 
authentication clients must run the portal client. 

2) On the authentication homepage/authentication dialog box, the user enters and submits the 
authentication information, which the portal server then transfers to the access device.  

3) Upon receipt of the authentication information, the access device communicates with the 
authentication/accounting server for authentication and accounting.  

4) After successful authentication, the access device checks whether there is corresponding security 
policy for the user. If not, it allows the user to access the Internet. Otherwise, the client, the access 
device and the security policy server communicates to perform security authentication of the user, 
and the security policy server authorizes the user to access resources depending on the security 
authentication result. 

 

 

 Since a portal client uses an IP address as its ID, ensure that there is no Network Address 
Translation (NAT) device between the authentication client, access device, portal server, and 
authentication/accounting server when deploying portal authentication. This is to avoid 
authentication failure due to NAT operations. 

 Currently, only a RADIUS server can serve as the remote authentication/accounting server in a 
portal system. 

 Currently, security authentication requires the cooperation of the H3C iNode client. 

 

Portal System Using the Local Portal Server 

System components 
In addition to use a separate device as the portal server, a portal system can also use the local portal 
server function of the access device to authenticate Web users directly. In this case, the portal system 
consists of only three components: authentication client, access device, and authentication/accounting 
server, as shown in Figure 36-2.  



 

36-4 

Figure 36-2 Portal system using the local portal server 

 

 

 

 A portal system using the local portal server does not support extended portal functions. Therefore, 
there is no need to configure any security policy server for it. 

 The local portal server function of the access device only implements some simple portal server 
functions, allowing users to log in and log out through the Web interface. It cannot completely take 
the place of an independent portal server.  

 If you disable portal function on the access interface, the local portal server becomes invalid. Thus, 
you also need to remove the local portal server 

 

Protocols used for interaction between client and local portal server 
HTTP and HTTPS can be used for interaction between an authentication client and the access device 
providing the local portal server function. If HTTP is used, there are potential security problems because 
HTTP packets are transferred in plain text; if HTTPS is used, data security is ensured because HTTPS 
packets are transferred in ciphertext based on SSL. 

Authentication page customization support 
The local portal server function allows you to customize authentication pages. You can customize 
authentication pages by editing the corresponding HTML files and then compress and save the files to 
the storage medium of the device. Each set of customized authentication pages consists of six 
authentication pages: the logon page, the logon success page, the online page, the logoff success page, 
the logon failure page, and the system busy page. A local portal server will push a corresponding 
authentication page at each authentication phase. 

 

 

 Authentication page customization applies to only wireless networking environments. For rules of 
customizing authentication pages, refer to Customizing Authentication Pages. 

 As an access controller (AC) in wireless Layer 3 networking cannot get user SSIDs, the 
authentication system can only provide the default authentication pages. 

 

Portal Authentication Modes 

Portal authentication supports two modes: non-Layer 3 authentication and Layer 3 authentication. 
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Non-Layer 3 authentication 
Non-Layer 3 authentication falls into two categories: direct authentication and Re-DHCP authentication. 

 Direct authentication 

Before authentication, a user manually configures an IP address or directly obtains a public IP address 
through DHCP, and can access only the portal server and predefined free websites. After passing 
authentication, the user can access the network resources. The process of direct authentication is 
simpler than that of re-DHCP authentication. 

 Re-DHCP authentication 

Before authentication, a user gets a private IP address through DHCP and can access only the portal 
server and predefined free websites. After passing authentication, the user is allocated a public IP 
address and can access the network resources. No public IP address is allocated to those who fails 
authentication. This solves the problem about IP address planning and allocation and proves to be 
useful. For example, a service provider can allocate public IP addresses to broadband users only when 
they access networks beyond the residential community network. 

 

 

The local portal server function does not support re-DHCP authentication. 

 

Layer 3 authentication 
Layer 3 portal authentication is similar to direct authentication. However, in Layer-3 portal 
authentication mode, Layer 3 forwarding devices can be present between the authentication client and 
the access device. 

Differences between Layer 3 and non-Layer 3 authentication modes 
 Networking mode 

From this point of view, the difference between these two authentication modes lies in whether or not a 
Layer 3 forwarding device can be present between the authentication client and the access device. The 
former supports Layer 3 forwarding devices, while the latter does not.  

 User identifier 

In Layer 3 authentication mode, a client is uniquely identified by an IP address. This is because the 
mode supports Layer 3 forwarding devices between the authentication client and the access device but 
the access device does not learn the MAC address of the authentication client. In non-Layer 3 
authentication mode, a client is uniquely identified by the combination of its IP address and MAC 
address because the access device can learn the MAC address of the authentication client. 

Due to the above differences, when the MAC address of an authentication client remains the same but 
the IP address changes, a new portal authentication will be triggered in Layer-3 authentication mode 
but will not be triggered in non-Layer 3 authentication mode. In non-Layer 3 authentication mode, a new 
portal authentication will be triggered only when both the MAC and IP address of the authentication 
client are changed. 



 

36-6 

Portal Authentication Process 

Direct authentication and Layer 3 authentication share the same authentication process, while 
re-DHCP authentication has a different process because of the presence of two address allocation 
procedures. 

Direct authentication/Layer 3 authentication process 

Figure 36-3 Direct authentication/Layer 3 authentication process 

 
 

The direct authentication/Layer 3 authentication process is as follows: 

1) A portal user initiates an authentication request through HTTP. When the HTTP packet arrives at 
the access device, the access device allows it to pass if it is destined for the portal server or a 
predefined free website, or redirects it to the portal server if it is destined for other websites. The 
portal server provides a web page for the user to enter the username and password. 

2) The portal server and the access device exchange Challenge Handshake Authentication Protocol 
(CHAP) messages. For Password Authentication Protocol (PAP) authentication, this step is 
skipped. 

3) The portal server assembles the username and password into an authentication request message 
and sends it to the access device. Meanwhile, the portal server starts a timer to wait for an 
authentication acknowledgment message. 

4) The access device and the RADIUS server exchange RADIUS packets to authenticate the user. 

5) If the user passes authentication, the access device sends an authentication acknowledgment 
message to the portal server. 

6) The portal server sends an authentication acknowledgment message to the authentication client to 
notify it of logon success. 

7) The portal server sends an affirmation message to the access device. 

With extended portal functions, the process includes two additional steps:  

8) The security policy server exchanges security authentication information with the client to check 
whether the authentication client meets the security requirements. 

9) The security policy server authorizes the user to access unrestricted resources based on the 
security configuration for the user. The authorization information is stored on the access device 
and used by the access device to control user access. 
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Re-DHCP authentication process 

Figure 36-4 Re-DHCP authentication process 
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The re-DHCP authentication process is as follows: 

Step 1 through step 6 are the same as those in the direct authentication/Layer 3 portal authentication 
process. 

7) After receiving an authentication acknowledgment message, the authentication client obtains a 
new public IP address through DHCP and notifies the portal server that it has obtained a public IP 
address. 

8) The portal server notifies the access device that the authentication client has obtained a new public 
IP address. 

9) Detecting the change of the IP address by examining ARP packets received, the access device 
notifies the portal server of the change. 

10) The portal server notifies the authentication client of logon success. 

11) The portal server sends a user IP address change acknowledgment message to the access 
device. 

With extended portal functions, the process includes two additional steps: 

12) The security policy server exchanges security authentication information with the client to check 
whether the authentication client meets the security requirements. 

13) The security policy server authorizes the user to access unrestricted resources based on the 
security configuration for the user. The authorization information is stored on the access device 
and used by the access device to take control of user access. 
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Authentication process with local portal server 

Figure 36-5 Authentication process with local portal server 

 

 

With local portal server, the direct/Layer 3 authentication process is as follows: 

1) When a portal user accesses a web page, the authentication client initiates an authentication 
request through HTTP or HTTPS. When the HTTP or HTTPS packet arrives at an access device 
using the local portal server, it is redirected to the local portal server, which then provides a Web 
page for the user to enter the username and password for authentication. 

2) The access device and the RADIUS server exchange RADIUS packets to authenticate the user. 

3) If the user passes authentication, the local portal server pushes a logon success page to the 
authentication client, informing the user of the authentication (logon) success. 

 

 

If HTTPS is used, after the portal user initiates an authentication request through HTTPS, the 
authentication client and the access device will first perform SSL negotiation to establish a secure path 
that encrypts packets to be transferred.  

 

Configuring Portal Authentication 

Configuration Prerequisites 

The portal feature provides a solution for user authentication and security authentication. However, the 
portal feature cannot implement this solution by itself. Currently, RADIUS authentication needs to be 
configured on the access device to cooperate with the portal feature to complete user authentication.  

The prerequisites for portal authentication are as follows: 

 The portal-enabled interfaces of the access device are configured with valid IP addresses or have 
obtained valid IP addresses through DHCP. 

 The portal server and the RADIUS server have been installed and configured properly. If you want 
to use the local portal server, no independent portal server is required. 

 With re-DHCP authentication, the invalid IP address check function of DHCP relay is enabled on 
the access device, and the DHCP server is installed and configured properly. 

 With RADIUS authentication, usernames and passwords of the users are configured on the 
RADIUS server, and the RADIUS client configurations are performed on the access device. For 
information about RADIUS client configuration, refer to MAC Address Configuration. 



 

36-9 

Configuration Task List 

Perform the tasks in Table 36-1 to configure the portal function. 

Table 36-1 Portal configuration task list 

Task Remarks 

Configuring the 
Portal Service 

Required 
Configure a portal server, apply the portal server to an interface, and configure the 
portal authentication parameters. 
By default, no portal server is configured.  

Configuring a 
Portal-Free Rule 

Optional 
Configure a portal-free rule, specifying the source and destination information for 
packet filtering 
A portal-free rule allows specified users to access specified external websites without 
portal authentication. Packets matching a portal-free rule will not trigger portal 
authentication and the users can directly access the specified external websites. 
By default, no portal-free policy is configured. 

 

Configuring the Portal Service 

Select Authentication > Portal from the navigation tree. The portal server configuration page will 
appear, as shown in Figure 36-6. Click Add to enter the portal service application page, as shown in 
Figure 36-7. 

Figure 36-6 Portal server configuration 
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Figure 36-7 Portal service application 

 
 

Table 36-2 describes the portal service configuration items. 

Table 36-2 Portal service configuration items 

Item Description 

Interface Specify the interface to be enabled with portal authentication. 

Portal Server 

Specify the portal server to be applied on the specified interface. Options include: 
 Select Server: Select an existing portal server from the portal server drop-down list. 
 New Server: If you select this option from the drop-down list, the portal server configuration 

area, as shown in Figure 36-8, will be displayed at the lower part of the page. You can add 
a portal server and apply the portal server to the interface. For detailed configuration, refer 
to Table 36-3. 

 Enable Local Server: If you select this option from the drop-down list, the local portal 
service configuration area, as shown in Figure 36-9, will be displayed at the lower part of 
the page. You can configure the parameters for local portal service. For detailed 
configuration, refer to Table 36-4. 

Method 

Specify the portal authentication mode, which can be: 
 Direct: Direct portal authentication. 
 Layer3: Layer 3 portal authentication. 
 Re-DHCP: Re-DHCP portal authentication. 

 
 In Layer-3 portal authentication mode, Layer 3 forwarding devices are not required to be 

present between the authentication client and the access device. However, if they are 
present, you must select the Layer 3 portal authentication mode. 

 In Re-DHCP portal authentication mode, a client is allowed to send out packets using a 
public IP address before it passes portal authentication. However, responses of the 
packets are restricted. 

 If the local portal server is used, you can configure the re-DHCP mode but it will not take 
effect. 

Auth Network 
IP 

Network Mask 

Specify the IP address and mask of the authentication subnet for Layer 3 portal authentication.
By configuring an authentication subnet, you can specify that only packets from users on the 
authentication subnet trigger portal authentication. Packets that are neither from portal-free 
users nor from the authentication subnet will be discarded. 
You can configure an authentication subnet only when the Layer 3 portal authentication mode 
is used. 

 
The authentication subnet in direct mode is any source IP address, and that in re-DHCP mode 
is the private subnet to which the interface’s private IP address belongs. 
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Item Description 

Specified 
Domain 

Specify the mandatory authentication domain for the interface. 
After you specify a mandatory authentication domain for an interface, the device will use the 
mandatory authentication domain for authentication, authorization, and accounting (AAA) of 
the portal users on the interface, ignoring the domain names carried in the usernames. 
Thereby, you can specify different authentication domains for different interfaces as needed.
The available ISP domains are those specified on the page you enter by selecting 
Authentication > AAA from the navigation tree. Refer to AAA for further details. 

 

Figure 36-8 Add a portal server 

 
 

Table 36-3 Portal server configuration items 

Item Description 

Server Name Specify the portal server name. 

IP Specify the IP address of the external portal server. 

Key 

Specify the shared key to be used for communication between the device and the portal server.

 
When a local portal server is used, you can specify the shared key but it does not take effect. 

Port 

Specify the destination port number to be used by the device to send packets to the portal 
server unsolicitedly. The port number must be the same with that used by the remote portal 
server. 

 
When a local portal server is used, you can specify the port number but it does not take effect.

URL 

Specify the URL for HTTP packets redirection. 

 
 DNS is supported, however, you need to configure a portal-free rule and add the DNS 

server address into the portal-free address range. 
 When a local portal server is used, you can specify the URL but it does not take effect. 
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Figure 36-9 Local portal service configuration 

 
 

Table 36-4 Local portal service configuration items 

Item Description 

Server Name Specify the local portal server name. 

IP Specify the IP address of the local portal server. You need to specify the IP address of 
the interface where the local portal server is applied. 

Protocol 
Specify the protocol to be used for authentication information exchange between the 
local portal server and the client. It can be HTTP or HTTPS. 
If you select HTTPS, you also need to specify the PKI domain. 

PKI Domain 

Specify the PKI domain for HTTPS. 
The available PKI domains are those specified on the page you enter by selecting 
Authentication > PKI from the navigation tree. Refer to PKI for further details.  

 
The service management, local portal authentication, and local EAP service modules 
always reference the same PKI domain. Changing the referenced PKI domain in any of 
the three modules will also change that referenced in the other two modules. 

SSID 

Page 
Custom
ization 

Page File 

Specify the authentication page files to be bound with SSIDs as required. 
After you bind SSIDs with authentication page files, when a user access the portal 
page, the local portal server pushes the authentication pages for the user according to 
the SSID of the user login interface and the bound authentication page file. 
By default, an SSID is not bound with any authentication page file. In this case, the 
system pushes the default authentication pages. 
You can edit an authentication page file as required and save it in the root directory or in 
the portal directory under the root directory of the access device. For rules of 
customizing authentication pages, refer to Customizing Authentication Pages. 

 

Return to Portal configuration task list. 

Configuring a Portal-Free Rule 

Select Authentication > Portal from the navigation tree, and then select the Free Rule tab to enter the 
portal-free rule list page, as shown in Figure 36-10. Click Add to enter the page for adding a new 
portal-free rule, as shown in Figure 36-11. 
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Figure 36-10 Portal-free rule configuration 

 

 

Figure 36-11 Add a portal-free rule 

 

 

Table 36-5 describes the configuration items for adding a portal-free rule. 

Table 36-5 Configuration items for adding a portal-free rule 

Item Description 

Number Specify the sequence number of the portal-free rule. 

Source-interface 
Specify the source interface of the portal-free rule. 
The SSIDs in the drop-down list are the corresponding SSIDs of the wireless ESS 
interfaces. 

Source IP address 

Mask 
Specify the source IP address and mask of the portal-free rule. 

Source MAC 

Specify the source MAC address of the portal-free rule. 

 
If you configure both the source IP address and the source MAC address, make sure 
that the mask of the specified source IP address is 255.255.255.255. Otherwise, the 
specified source MAC address will not take effect. 

Source-VLAN 

Specify the source VLAN of the portal-free rule. 

 
If you configure both a source interface and a source VLAN for a portal-free rule, make 
sure that the source interface is in the source VLAN. Otherwise, the portal-free rule will 
not take effect. 
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Item Description 

Destination IP 
Address 

Mask 
Specify the destination IP address and mask of the portal-free rule. 

 

Return to Portal configuration task list. 

Customizing Authentication Pages 

When the local portal server is used for portal authentication, one of its tasks is to push authentication 
pages to users. You can define different authentication pages for wireless users in different WLANs. 
Customized authentication pages exist in the form of HTML files. You can compress them, upload them 
through FTP or TFTP to the access device, and save them in the portal directory under the root 
directory of the access device. A set of authentication pages include six main pages: the logon page, the 
logon success page, the logon failure page, the online page, the system busy page, and the logoff 
success page. If you define only some of them, the system will use the default authentication pages for 
the undefined ones. 

For the local portal server to operate normally and steadily, you need to follow the following rules when 
customizing authentication pages: 

Rules on file names 
The main pages of the authentication pages have predefined file names, which cannot be changed. The 
following table lists the names. 

Table 36-6 Main authentication page file names 

Main authentication page File name 

Logon page logon.htm 

Logon success page logonSuccess.htm 

Logon failure page logonFail.htm 

Online page 
Pushed for online state notification 

online.htm 

System busy page 
Pushed when the system is busy or the user is in the logon process 

busy.htm 

Logoff success page logoffSuccess.htm 

 

 

You can define the names of the files other than the main page files. 

 

Rules on page requests 
The local portal server supports only Post and Get requests. 

 Post requests are used when users submit username and password pairs, log on the system, and 
log off the system. 
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 Get requests allow no recursion. For example, if file Logon.htm includes contents that perform Get 
action on file ca.htm, file ca.htm cannot include any reference to file Logon.htm. 

Rules on Post request attributes 
1) Observe the following requirements when editing a form of an authentication page: 

 An authentication page can have multiple forms, but there must be one and only one form whose 
action is logon.cgi. Otherwise, user information cannot be sent to the local portal server. 

 The username attribute is fixed as PtUser, and the password attribute is fixed as PtPwd. 

 Attribute PtButton is required to indicate the action that the user requests, which can be Logon or 
Logoff. 

 A logon Post request must contain PtUser, PtPwd, and PtButton attributes. 

 A logoff Post request must contain the PtButton attribute. 

2) Authentication pages logon.htm and logonFail.htm must contain the logon Post request. 

The following example shows part of the script in page logon.htm. 
<form action=logon.cgi method = post > 

<p>User name:<input type="text" name = "PtUser" style="width:160px;height:22px" 
maxlength=64> 

<p>Password :<input type="password" name = "PtPwd" style="width:160px;height:22px" 
maxlength=32> 

<p><input type=SUBMIT value="Logon" name = "PtButton" style="width:60px;"> 

</form> 

3) Authentication pages logonSuccess.htm and online.htm must contain the logoff Post request. 

The following example shows part of the script in page online.htm. 
<form action=logon.cgi method = post > 

<p><input type=SUBMIT value="Logoff" name="PtButton" style="width:60px;"> 

</form> 

Rules on page file compression and saving 
 A set of authentication page files must be compressed into a standard zip file. A zip file name is in 

the form of *****.zip, and can contain only letters, numerals, and underscores. 

 These zip files can be transferred to the device through FTP or TFTP, and must be saved in the 
root directory or the portal directory under the root directory of the device. 

Rules on file size and contents 
For the system to push customized authentication pages smoothly, you need comply with the following 
size and content requirements on authentication pages. 

 The size of the zip file of each set of authentication pages, including the main authentication pages 
and the page elements, should be no more than 500 KB.  

 The size of a single page, including the main authentication page and the page elements, should 
be no more than 50 KB before being compressed. 

 Page elements are files that the authentication pages need to reference, for example, back.jpg on 
page Logon.htm. Page elements, such as HTML, JS, CSS, and pictures, can contain only static 
contents. 

Portal Authentication Configuration Example 

Network requirements 
As shown in Figure 36-12: 
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 The wireless client (belongs to VLAN 2) accesses the network through the AP, which belongs to 
VLAN 3. The serial number of the AP is 210235A29G007C000020. 

 AC supports the local portal server, which runs HTTPS. The local portal server can push the 
corresponding customized pages according to the SSID of the user logon interface. 

 A RADIUS server (CAMS/iMC server) serves as the authentication/accounting server.  

 The client must pass direct portal authentication to access unrestricted Internet resources. Before 
authentication, the client can access only the local portal server. 

Figure 36-12 Configure direct portal authentication using the local portal server 

 

 

Configuration procedure 
 

  

Before performing portal configurations, be sure to: 

 Configure IP addresses for the client, AC, and server as shown in Figure 36-12 and ensure that 
they can reach each other. 

 Configure PKI domain test, and make sure that a local certificate and a CA certificate are obtained 
successfully. For more information, see PKI. 

 Complete the editing of the authentication page files to be bound with the client SSID. 

 Configure the RADIUS server properly to provide normal authentication/accounting functions for 
users. 

 It is not recommended to assign the wireless client and the AP to the same network segment. 
Otherwise, when portal authentication is configured on the network segment, the AP cannot 
establish a CAPWAP connection with the AC unless you configure a portal-free rule for the AP. 

 

Perform the following configurations on the AC: 

1) Configure the RADIUS scheme system 

# Specify the RADIUS authentication server.  

 From the navigation tree, select Authentication > RADIUS to enter the RADIUS server 
configuration page.  
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Figure 36-13 Configure the RADIUS authentication server 

 

 

Perform the following configurations as shown in Figure 36-13. 

 Select Authentication Server as the server type. 

 Enter the primary server IP address 1.1.1.2. 

 Enter the primary server UDP port number 1812. 

 Select active as the primary server status. 

 Click Apply. 

# Configure the RADIUS accounting server. 

Figure 36-14 Configure the RADIUS accounting server 

 

 

Perform the following configurations as shown in Figure 36-14. 

 Select Accounting Server as the server type. 

 Enter the primary server IP address 1.1.1.2. 

 Enter the primary server UDP port number 1813. 

 Select active as the primary server status. 

 Click Apply to finish the operation. 

# Configure the scheme used for communication between the device and the RADIUS servers as 
follows: 

 Select the RADIUS Setup tab to enter the RADIUS parameter configuration page.  
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Figure 36-15 Configure RADIUS parameters 

 
 

Perform the following configurations as shown in Figure 36-15. 

 Select extended as the server type. 

 Select the Authentication Server Shared Key checkbox, and enter expert in the textbox.  

 Enter expert again in the Confirm Authentication Shared Key textbox. 

 Select the Accounting Server Shared Key checkbox, and enter expert in the textbox. 

 Enter expert again in the Confirm Accounting Shared Key textbox. 

 Select without-domain as the username format. 

 Click Apply to finish the operation. 

2) Configure AAA 

# Create an ISP domain. 

 From the navigation tree, select Authentication > AAA. The domain setup page is displayed by 
default.  
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Figure 36-16 Create an ISP domain 

 

 

Perform the following configurations as shown in Figure 36-16. 

 Enter test in the Domain Name textbox. 

 Select Enable to use it as the default domain. 

 Click Apply to finish the operation. 

# Configure the AAA authentication method for the ISP domain. 

 Select the Authentication tab.  

Figure 36-17 Configuration the AAA authentication method for the ISP domain 

 
 

Perform the following configurations, as shown in Figure 36-17. 

 Select the domain name test. 

 Select the Default AuthN checkbox and then select RADIUS as the authentication mode. 
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 Select system from the Name drop-down list to use it as the authentication scheme  

 Click Apply. S configuration progress dialog box appears, as shown in Figure 36-18. 

Figure 36-18 Configuration progress dialog box 

 
 

 After the configuration process is complete, click Close. 

# Configure the AAA authorization method for the ISP domain. 

 Select the Authorization tab.  

Figure 36-19 Configure the AAA authorization method for the ISP domain 

 
 

Perform the following configurations, as shown in Figure 36-19. 

 Select the domain name test. 

 Select the Default AuthZ checkbox and then select RADIUS as the authorization mode. 

 Select system from the Name drop-down list to use it as the authorization scheme  

 Click Apply. A configuration progress dialog box appears 

 After the configuration process is complete, click Close. 

# Configure the AAA accounting method for the ISP domain, and enable accounting optional. 

 Select the Accounting tab.  
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Figure 36-20 Configure the AAA accounting method for the ISP domain 

 
 

Perform the following configurations, as shown in Figure 36-20. 

 Select the domain name test. 

 Select the Accounting Optional checkbox, and then select Enable for this parameter. 

 Select the Default Accounting checkbox and then select RADIUS as the accounting mode. 

 Select system from the Name drop-down list to use it as the accounting scheme  

 Click Apply. The configuration progress dialog box appears 

 After you see the prompt of configuration success, click Close to finish the operation. 

3) Configure the WLAN service 

# Create an AP. 

 From the navigation tree, select AP > AP Setup. Click Create and then perform the following 
configurations, as shown in Figure 36-21. 

Figure 36-21 Create an AP 

 
 

 Type the AP name ap1. 

 Select model WA2100. 

 Select the manual mode for serial ID and then type the serial ID 210235A29G007C000020. 

 Click Apply. 

# Create a wireless service. 

 From the navigation tree, select Wireless Service > Access Service. Click New and then perform 
the following configurations, as shown in Figure 36-22. 
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Figure 36-22 Create a wireless service 

 

 

 Type the wireless service name 1. 

 Select clear as the wireless service type. 

 Click Apply. 

 The wireless service configuration page appears. Configure parameters for the wireless service as 
shown in Figure 36-23. 

Figure 36-23 Configure parameters for the wireless service 

 

 

 Type 2 in the textbox of VLAN (Untagged). 

 Type 2 in the textbox of Default VLAN. 

 Click Apply. A configuration progress dialog box appears, as shown in Figure 36-24. 
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Figure 36-24 Configuration progress dialog box 

 
 

 After the configuration process is complete, click Close. 

# Enable the wireless service. 

 After the configuration above, the access service list appears. Perform the following configurations, 
as shown in Figure 36-25. 

Figure 36-25 Enable the wireless service 

 
 

 Select the check box before wireless service 1. 

 Click Enable. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

# Bind an AP radio with the wireless service. 

 On the wireless service list, click the Bind link of wireless service 1 and then perform the following 
configurations, as shown in Figure 36-26. 
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Figure 36-26 Bind an AP radio 

 
 

 Select the check box before ap1 with the radio mode of 802.11g. 

 Click Bind. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

# Enable 802.11g radio. 

 From the navigation tree select Radio > Radio. Perform the following configurations, as shown in 
Figure 36-27. 

Figure 36-27 Enable 802.11g radio 

 
 

 Select the check box before ap1 with the radio mode of 802.11g. 

 Click Enable. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

4) Configure portal authentication 

# Configure the portal service. 

 From the navigation tree select Authentication > Portal. The portal server configuration page will 
appear, as shown in Figure 36-28. Click Add to perform the following configurations, as shown in 
Figure 36-29. 
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Figure 36-28 Portal server configuration 

 

 

Figure 36-29 Portal service application 

 
 



 

36-26 

 Select interface VLAN-interface 2. 

 Select Enable Local Server for Portal Server. 

 Select Direct as the authentication method. 

 Type 192.168.1.1 as the server IP address. 

 Select HTTPS as the protocol type. 

 Select test as the PKI domain. 

 Select the checkbox before Page Customization. 

 Select the authentication page file ssid1.zip for SSID abc. 

 Click Apply. 

Verfiy the configuration 
When accessing network segment 1.1.1.0/24, a user on the client should be redirected to page 
https://192.168.1.1/portal/logon.htm and, after entering the correct username and password on the Web 
page, pass the authentication. 
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37  AAA 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Introduction to AAA 

Authentication, Authorization, and Accounting (AAA) provides a uniform framework for configuring 
these three security functions to implement network security management. 

AAA usually uses a client/server model, where the client runs on the network access server (NAS) and 
the server maintains user information centrally. In an AAA network, a NAS is a server for users but a 
client for the AAA servers, as shown in Figure 37-1. 

Figure 37-1 AAA networking diagram 

 

 

When a user tries to establish a connection to the NAS and to obtain the rights to access other networks 
or some network resources, the NAS authenticates the user or the corresponding connection. The NAS 
takes the responsibility to transparently pass the user’s AAA information to the server (RADIUS server, 
for example). The RADIUS protocol defines how a NAS and a server exchange user information 
between them.  
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In the AAA network shown in Figure 37-1, there are two RADIUS servers. You can determine which of 
the authentication, authorization and accounting functions should be assumed by which servers. For 
example, you can use RADIUS server 1 for authentication and authorization, and RADIUS server 2 for 
accounting.  

The three security functions are described as follows:  

 Authentication: Identifies remote users and judges whether a user is legal.  

 Authorization: Grants different users different rights. For example, a user logging into the server 
can be granted the permission to access and print the files in the server.  

 Accounting: Records all network service usage information of users, including the service type, 
start and end time, and traffic. In this way, accounting can be used for not only charging, but also 
network security surveillance.  

You can use AAA to provide only one or two security functions, if desired. For example, if your company 
only wants employees to be authenticated before they access specific resources, you only need to 
configure an authentication server. If network usage information is expected to be recorded, you also 
need to configure an accounting server.  

As described above, AAA provides a uniform framework to implement network security management. It 
is a security mechanism that enables authenticated and authorized entities to access specific resources 
and records operations of the entities. As the AAA framework allows for excellent scalability and 
centralized user information management, it has gained wide application.  

AAA can be implemented through multiple protocols. Currently, the device supports using RADIUS, 
which is often used in practice. For details about RADIUS, refer to MAC Address Configuration. 

Introduction to ISP Domain 

An Internet service provider (ISP) domain represents a group of users. For a username in the 
userid@isp-name format, the access device considers the userid part the username for authentication 
and the isp-name part the ISP domain name.  

In a networking scenario with multiple ISPs, an access device may connect users of different ISPs. As 
users of different ISPs may have different user attributes (such as username and password structure, 
service type, and rights), you need to configure ISP domains to distinguish the users. In addition, you 
need to configure different attribute sets including AAA methods for the ISP domains. 

For the NAS, each user belongs to an ISP domain. If a user does not provide the ISP domain name, the 
system considers that the user belongs to the default ISP domain. 

Configuring AAA 

Configuration Prerequisites 

1) To deploy local authentication, you need to configure local users on the access device. Refer to 
Users for details. 

2) To deploy remote authentication, authorization, or accounting, you need to create the RADIUS 
schemes to be referenced. For details about RADIUS scheme configuration, refer to MAC Address 
Configuration. 
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Configuration Task List 

Perform the tasks in Table 37-1 to configure AAA. 

Table 37-1 AAA configuration task list 

Task Remarks 

Configuring an ISP 
Domain 

Optional 
Create ISP domains and specify one of them as the default ISP domain. 
By default, there is an ISP domain named system, which is the default ISP domain.

Configuring 
Authentication Methods 
for the ISP Domain 

Optional 
Configure authentication methods for various types of 
users. 
By default, all types of users use local authentication. 

Configuring 
Authorization Methods 
for the ISP Domain 

Optional 
Specify the authorization methods for various types of 
users. 
By default, all types of users use local authorization. 

Configuring Accounting 
Methods for the ISP 
Domain 

Required 
Specify the accounting methods for various types of users. 
By default, all types of users use local accounting. 

AAA user types 
include LAN access 
users (such as 
802.1x authentication 
users and MAC 
authentication 
users), login users 
(such as SSH, 
Telnet, FTP, terminal 
access users), PPP 
users, Portal users, 
and Command users.

 

Configuring an ISP Domain 

Select Authentication > AAA from the navigation tree. The Domain Setup page appears, as shown in 
Figure 37-2.  
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Figure 37-2 Domain Setup page 

 
 

Table 37-2 describes the configuration items for creating an ISP domain. 

Table 37-2 ISP domain configuration items 

Item Description 

Domain Name 
Type the ISP domain name, which is for identifying the domain. 
You can type a new domain name to create a domain, or specify an existing domain to 
change its status (whether it is the default domain). 

Default Domain 

Specify whether to use the ISP domain as the default domain. 
 Enable: Uses the domain as the default domain. 
 Disable: Uses the domain as a non-default domain. 

There can only be one default domain at a time. If you specify a second domain as the 
default domain, the original default domain will become a non-default domain. 

 

Return to Configuration Task List. 

Configuring Authentication Methods for the ISP Domain 

Select Authentication > AAA from the navigation tree and then select the Authentication tab to enter 
the authentication method configuration page, as shown in Figure 37-3. 
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Figure 37-3 Authentication method configuration page 

 

 

Table 37-3 describes the configuration items for specifying the authentication methods for an ISP 
domain. 

Table 37-3 Authentication method configuration items 

Item Description 

Select an ISP domain Select the ISP domain for which you want to specify authentication methods. 

Default AuthN 

Name 

Secondary Method 

Configure the default authentication method and secondary authentication method 
for all types of users. 
Options include: 

 HWTACACS: Performs HWTACACS authentication. You need to specify the 
HWTACACS scheme to be used. 

 Local: Performs local authentication. 
 None: All users are trusted and no authentication is performed. Generally, this 

mode is not recommended. 
 RADIUS: Performs RADIUS authentication. You need to specify the RADIUS 

scheme to be used. 
 Not Set: Restore the default, that is, local authentication. 

LAN-access AuthN 

Name 

Secondary Method 

Configure the authentication method and secondary authentication method for 
LAN access users. 
Options include: 

 Local: Performs local authentication. 
 None: All users are trusted and no authentication is performed. Generally, this 

mode is not recommended. 
 RADIUS: Performs RADIUS authentication. You need to specify the RADIUS 

scheme to be used. 
 Not Set: Uses the default authentication methods. 

Login AuthN 

Name 

Secondary Method 

Configure the authentication method and secondary authentication method for 
login users. 
Options include: 

 HWTACACS: Performs HWTACACS authentication. You need to specify the 
HWTACACS scheme to be used. 

 Local: Performs local authentication. 
 None: All users are trusted and no authentication is performed. Generally, this 

mode is not recommended. 
 RADIUS: Performs RADIUS authentication. You need to specify the RADIUS 

scheme to be used. 
 Not Set: Uses the default authentication methods. 



 

37-6 

Item Description 

PPP AuthN 

Name 

Secondary Method 

Configure the authentication method and secondary authentication method for 
PPP users. 
Options include: 

 HWTACACS: Performs HWTACACS authentication. You need to specify the 
HWTACACS scheme to be used. 

 Local: Performs local authentication. 
 None: All users are trusted and no authentication is performed. Generally, this 

mode is not recommended. 
 RADIUS: Performs RADIUS authentication. You need to specify the RADIUS 

scheme to be used. 
 Not Set: Uses the default authentication methods. 

Portal AuthN 

Name 

Configure the authentication method for portal users. 
Options include: 

 None: All users are trusted and no authentication is performed. Generally, this 
mode is not recommended. 

 RADIUS: Performs RADIUS authentication. You need to specify the RADIUS 
scheme to be used. 

 Not Set: Uses the default authentication methods. 

 

Return to Configuration Task List. 

Configuring Authorization Methods for the ISP Domain 

Select Authentication > AAA from the navigation tree and then select the Authorization tab to enter 
the authorization method configuration page, as shown in Figure 37-4. 

Figure 37-4 Authorization method configuration page 

 

 

Table 37-4 describes the configuration items for configuring the authorization methods for an ISP 
domain. 

Table 37-4 Authorization method configuration items 

Item Description 

Select an ISP 
domain Select the ISP domain for which you want to specify authentication methods. 
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Item Description 

Default AuthZ 

Name 

Secondary 
Method 

Configure the default authorization method and secondary authorization method for all 
types of users. 
Options include: 

 HWTACACS: Performs HWTACACS authorization. You need to specify the 
HWTACACS scheme to be used. 

 Local: Performs local authorization. 
 None: All users are trusted and authorized. A user gets the corresponding default 

rights of the system. 
 RADIUS: Performs RADIUS authorization. You need to specify the RADIUS scheme 

to be used. 
 Not Set: Restore the default, that is, local authorization. 

LAN-access AuthZ 

Name 

Secondary 
Method 

Configure the authorization method and secondary authorization method for LAN access 
users. 
Options include: 

 Local: Performs local authorization. 
 None: All users are trusted and authorized. A user gets the corresponding default 

rights of the system. 
 RADIUS: Performs RADIUS authorization. You need to specify the RADIUS scheme 

to be used. 
 Not Set: Uses the default authorization methods. 

Login AuthZ 

Name 

Secondary 
Method 

Configure the authorization method and secondary authorization method for login users.
Options include: 

 HWTACACS: Performs HWTACACS authorization. You need to specify the 
HWTACACS scheme to be used. 

 Local: Performs local authorization. 
 None: All users are trusted and authorized. A user gets the corresponding default 

rights of the system. 
 RADIUS: Performs RADIUS authorization. You need to specify the RADIUS scheme 

to be used. 
 Not Set: Uses the default authorization methods. 

PPP AuthZ 

Name 

Secondary 
Method 

Configure the authorization method and secondary authorization method for PPP users.
Options include: 

 HWTACACS: Performs HWTACACS authorization. You need to specify the 
HWTACACS scheme to be used. 

 Local: Performs local authorization. 
 None: All users are trusted and authorized. A user gets the corresponding default 

rights of the system. 
 RADIUS: Performs RADIUS authorization. You need to specify the RADIUS scheme 

to be used. 
 Not Set: Uses the default authorization methods. 

Portal AuthZ 

Name 

Configure the authorization method for portal users. 
Options include: 

 None: All users are trusted and authorized. A user gets the corresponding default 
rights of the system. 

 RADIUS: Performs RADIUS authorization. You need to specify the RADIUS scheme 
to be used. 

 Not Set: Uses the default authorization methods. 

Command AuthZ 

Name 

Configure the authorization method for command users. 
Options include: 

 HWTACACS: Performs HWTACACS authorization. You need to specify the 
HWTACACS scheme to be used. 

 Not Set: Uses the default authorization methods. 

 

Return to Configuration Task List. 
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Configuring Accounting Methods for the ISP Domain 

Select Authentication > AAA from the navigation tree and then select the Accounting tab to enter the 
accounting method configuration page, as shown in Figure 37-5. 

Figure 37-5 Accounting method configuration page 

 

 

Table 37-5 describes the configuration items for configuring the accounting methods for an ISP domain. 

Table 37-5 Accounting method configuration items 

Item Description 

Select an ISP 
domain Select the ISP domain for which you want to specify authentication methods. 

Accounting 
Optional 

Specify whether to enable the accounting optional feature. 
 With the feature enabled, a user that will be disconnected otherwise can use the 

network resources even when there is no accounting server available or 
communication with the current accounting server fails. 

 If accounting for such a user fails, the device will not send real-time accounting 
updates for the user any more. 

Default 
Accounting 

Name 

Secondary 
Method 

Configure the default accounting method and secondary accounting method for all types 
of users. 
Options include: 

 HWTACACS: Performs HWTACACS accounting. You need to specify the 
HWTACACS scheme to be used. 

 Local: Performs local accounting. 
 None: Performs no accounting. 
 RADIUS: Performs RADIUS accounting. You need to specify the RADIUS scheme to 

be used. 
 Not Set: Restore the default, that is, local accounting. 

LAN-access 
Accounting 

Name 

Secondary 
Method 

Configure the accounting method and secondary accounting method for LAN access 
users. 
Options include: 

 Local: Performs local accounting. 
 None: Performs no accounting. 
 RADIUS: Performs RADIUS accounting. You need to specify the RADIUS scheme to 

be used. 
 Not Set: Uses the default accounting methods. 
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Item Description 

Login Accounting 

Name 

Secondary 
Method 

Configure the accounting method and secondary accounting method for login users. 
Options include: 

 HWTACACS: Performs HWTACACS accounting. You need to specify the 
HWTACACS scheme to be used. 

 Local: Performs local accounting. 
 None: Performs no accounting. 
 RADIUS: Performs RADIUS accounting. You need to specify the RADIUS scheme to 

be used. 
 Not Set: Uses the default accounting methods. 

PPP Accounting 

Name 

Secondary 
Method 

Configure the accounting method and secondary accounting method for PPP users. 
Options include: 

 HWTACACS: Performs HWTACACS accounting. You need to specify the 
HWTACACS scheme to be used. 

 Local: Performs local accounting. 
 None: Performs no accounting. 
 RADIUS: Performs RADIUS accounting. You need to specify the RADIUS scheme to 

be used. 
 Not Set: Uses the default accounting methods. 

Portal Accounting 

Name 

Configure the accounting method for portal users. 
Options include: 

 None: Performs no accounting. 
 RADIUS: Performs RADIUS accounting. You need to specify the RADIUS scheme to 

be used. 
 Not Set: Uses the default accounting methods. 

 

Return to Configuration Task List. 

AAA Configuration Example 

Network requirements 
As shown in Figure 37-6, configure the AC to perform local authentication, authorization, and 
accounting for Telnet users. 

Figure 37-6 Network diagram for AAA configuration example on an AC 

 

 

Configuration procedure 
 

 

Enable the Telnet server function, and configure the AC to use AAA for Telnet users. The configuration 
steps are omitted. 

 

# Configure IP addresses for the interfaces. (Omitted) 
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# Configure a local user. 

 Select Authentication > Users from the navigation tree. The Local User page appears, as shown 
in Figure 37-7. Click Add and then configure the local user as shown in Figure 37-8.  

Figure 37-7 Add a local user 

 

 

Figure 37-8 Configure the local user 

 

 

 Enter telnet as the username. 

 Enter abcd as the password. 

 Enter abcd to confirm the password. 

 Select Telnet as the service type. 

 Click Apply. 

# Configure ISP domain test. 

 Select Authentication > AAA from the navigation tree. The Domain Setup page appears, as 
shown in Figure 37-9. 
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Figure 37-9 Configure ISP domain test 

 

 

Perform the following configurations as shown in Figure 37-9: 

 Enter test as the domain name. 

 Click Apply. 

# Configure the ISP domain to use local authentication. 

 Select Authentication > AAA from the navigation tree and then select the Authentication tab and 
configure AAA authentication as shown in Figure 37-10. 

Figure 37-10  Configure the ISP domain to use local authentication 

 
 

Perform the following configurations as shown in Figure 37-10. 

 Select the domain test. 
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 Select the Login AuthN check box and select the authentication method Local. 

 Click Apply. A configuration progress dialog box appears, as shown in Figure 37-11. 

Figure 37-11 Configuration progress dialog box 

 

 

 After the configuration process is complete, click Close. 

# Configure the ISP domain to use local authorization. 

 Select Authentication > AAA from the navigation tree and then select the Authorization tab and 
configure AAA authorization as shown in Figure 37-12. 

Figure 37-12 Configure the ISP domain to use local authorization 

 
 

Perform the following configurations as shown in Figure 37-12: 

 Select the domain test. 

 Select the Login AuthZ check box and select the authorization method Local. 

 Click Apply. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

# Configure the ISP domain to use local accounting. 

 Select Authentication > AAA from the navigation tree and then select the Accounting tab and 
configure AAA accounting as shown in Figure 37-13.  
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Figure 37-13 Configure the ISP domain to use local accounting 

 

 

Perform the following configurations as shown in Figure 37-13: 

 Select the domain test. 

 Select the Login Accounting check box and select the accounting method Local. 

 Click Apply. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

Now, if you telnet to the AC and enter username telnet@test and password abcd, you should be 
serviced as a user in domain test.  
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38  RADIUS 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Remote Authentication Dial-In User Service (RADIUS) is protocol for implementing Authentication, 
Authorization, and Accounting (AAA). For details about AAA, refer to AAA. 

Introduction to RADIUS 

RADIUS is a distributed information interaction protocol using the client/server model. RADIUS can 
protect networks against unauthorized access and is often used in network environments where both 
high security and remote user access are required. RADIUS uses UDP, and its packet format and 
message transfer mechanism are based on UDP. It uses UDP port 1812 for authentication and 1813 for 
accounting.  

RADIUS was originally designed for dial-in user access. With the diversification of access methods, 
RADIUS has been extended to support more access methods, for example, Ethernet access and ADSL 
access. It uses authentication and authorization in providing access services and uses accounting to 
collect and record usage information of network resources.  

Client/Server Model 

 Client: The RADIUS client runs on the NASs located throughout the network. It passes user 
information to designated RADIUS servers and acts on the responses (for example, rejects or 
accepts user access requests). 

 Server: The RADIUS server runs on the computer or workstation at the network center and 
maintains information related to user authentication and network service access. It listens to 
connection requests, authenticates users, and returns the processing results (for example, 
rejecting or accepting the user access request) to the clients. 

In general, the RADIUS server maintains three databases, namely, Users, Clients, and Dictionary, as 
shown in Figure 38-1. 
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Figure 38-1 RADIUS server components 

 

 

 Users: Stores user information such as the usernames, passwords, applied protocols, and IP 
addresses. 

 Clients: Stores information about RADIUS clients, such as the shared keys and IP addresses. 

 Dictionary: Stores information about the meanings of RADIUS protocol attributes and their values. 

Security and Authentication Mechanisms 

Information exchanged between a RADIUS client and the RADIUS server is authenticated with a 
shared key, which is never transmitted over the network. This enhances the information exchange 
security. In addition, to prevent user passwords from being intercepted on insecure networks, RADIUS 
encrypts passwords before transmitting them.  

A RADIUS server supports multiple user authentication methods, for example, the Password 
Authentication Protocol (PAP) and Challenge Handshake Authentication Protocol (CHAP) of the 
Point-to-Point Protocol (PPP). Moreover, a RADIUS server can act as the client of another AAA server 
to provide authentication proxy services.  

Basic Message Exchange Process of RADIUS 

Figure 38-2 illustrates the interaction of the host, the RADIUS client, and the RADIUS server. 
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Figure 38-2 Basic message exchange process of RADIUS 

RADIUS client RADIUS server

1) Username and password

           3) Access-Accept/Reject

           2) Access-Request

4) Accounting-Request (start)

            5) Accounting-Response

7) Accounting-Request (stop)

            8) Accounting-Response

9) Notification of access termination

Host

6) The host accesses the resources

 

 

The following is how RADIUS operates: 

1) The host initiates a connection request carrying the username and password to the RADIUS client. 

2) Having received the username and password, the RADIUS client sends an authentication request 
(Access-Request) to the RADIUS server, with the user password encrypted by using the 
Message-Digest 5 (MD5) algorithm and the shared key.  

3) The RADIUS server authenticates the username and password. If the authentication succeeds, it 
sends back an Access-Accept message containing the user’s authorization information. If the 
authentication fails, it returns an Access-Reject message. 

4) The RADIUS client permits or denies the user according to the returned authentication result. If it 
permits the user, it sends a start-accounting request (Accounting-Request) to the RADIUS server.  

5) The RADIUS server returns a start-accounting response (Accounting-Response) and starts 
accounting.  

6) The user accesses the network resources. 

7) The host requests the RADIUS client to tear down the connection and the RADIUS client sends a 
stop-accounting request (Accounting-Request) to the RADIUS server.  

8) The RADIUS server returns a stop-accounting response (Accounting-Response) and stops 
accounting for the user.  

9) The user stops access to network resources. 

RADIUS Packet Format 

RADIUS uses UDP to transmit messages. It ensures the smooth message exchange between the 
RADIUS server and the client through a series of mechanisms, including the timer management 
mechanism, retransmission mechanism, and slave server mechanism. Figure 38-3 shows the RADIUS 
packet format. 
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Figure 38-3 RADIUS packet format 

 
 

Descriptions of the fields are as follows: 

1) The Code field (1-byte long) is for indicating the type of the RADIUS packet. Table 38-1 gives the 
possible values and their meanings. 

Table 38-1 Main values of the Code field 

Code Packet type Description 

1 Access-Request 

From the client to the server. A packet of this type carries user 
information for the server to authenticate the user. It must contain the 
User-Name attribute and can optionally contain the attributes of 
NAS-IP-Address, User-Password, and NAS-Port. 

2 Access-Accept 
From the server to the client. If all the attribute values carried in the 
Access-Request are acceptable, that is, the authentication succeeds, 
the server sends an Access-Accept response. 

3 Access-Reject 
From the server to the client. If any attribute value carried in the 
Access-Request is unacceptable, the server rejects the user and sends 
an Access-Reject response. 

4 Accounting-Request 

From the client to the server. A packet of this type carries user 
information for the server to start/stop accounting for the user. It contains 
the Acct-Status-Type attribute, which indicates whether the server is 
requested to start the accounting or to end the accounting. 

5 Accounting-Response 
From the server to the client. The server sends to the client a packet of 
this type to notify that it has received the Accounting-Request and has 
correctly started recording the accounting information.  

 

2) The Identifier field (1-byte long) is for matching request packets and response packets and 
detecting retransmitted request packets. The request and response packets of the same type have 
the same identifier.  

3) The Length field (2-byte long) indicates the length of the entire packet, including the Code, 
Identifier, Length, Authenticator, and Attribute fields. The value of the field is in the range 20 to 
4096. Bytes beyond the length are considered the padding and are neglected upon reception. If the 
length of a received packet is less than that indicated by the Length field, the packet is dropped. 

4) The Authenticator field (16-byte long) is used to authenticate replies from the RADIUS server, and 
is also used in the password hiding algorithm. There are two kinds of authenticators: request 
authenticator and response authenticator. 

5) The Attribute field, with a variable length, carries the specific authentication, authorization, and 
accounting information for defining configuration details of the request or response. This field is 
represented in triplets of Type, Length, and Value.  
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 Type: One byte, in the range 1 to 255. It indicates the type of the attribute. Commonly used 
attributes for RADIUS authentication, authorization and accounting are listed in Table 38-2. 

 Length: One byte for indicating the length of the attribute in bytes, including the Type, Length, and 
Value fields. 

 Value: Value of the attribute, up to 253 bytes. Its format and content depend on the Type and 
Length fields. 

Table 38-2 RADIUS attributes  

No. Attribute No. Attribute 

1 User-Name 45 Acct-Authentic 

2 User-Password 46 Acct-Session-Time 

3 CHAP-Password 47 Acct-Input-Packets 

4 NAS-IP-Address 48 Acct-Output-Packets 

5 NAS-Port 49 Acct-Terminate-Cause 

6 Service-Type 50 Acct-Multi-Session-Id 

7 Framed-Protocol 51 Acct-Link-Count 

8 Framed-IP-Address 52 Acct-Input-Gigawords 

9 Framed-IP-Netmask 53 Acct-Output-Gigawords 

10 Framed-Routing 54 (unassigned) 

11 Filter-ID 55 Event-Timestamp 

12 Framed-MTU 56-59 (unassigned) 

13 Framed-Compression 60 CHAP-Challenge 

14 Login-IP-Host 61 NAS-Port-Type 

15 Login-Service 62 Port-Limit 

16 Login-TCP-Port 63 Login-LAT-Port 

17 (unassigned) 64 Tunnel-Type 

18 Reply_Message 65 Tunnel-Medium-Type 

19 Callback-Number 66 Tunnel-Client-Endpoint  

20 Callback-ID 67 Tunnel-Server-Endpoint 

21 (unassigned) 68 Acct-Tunnel-Connection 

22 Framed-Route 69 Tunnel-Password 

23 Framed-IPX-Network 70 ARAP-Password 

24 State 71 ARAP-Features 

25 Class 72 ARAP-Zone-Access 

26 Vendor-Specific 73 ARAP-Security 

27 Session-Timeout 74 ARAP-Security-Data 

28 Idle-Timeout 75 Password-Retry 

29 Termination-Action 76 Prompt 

30 Called-Station-Id 77 Connect-Info 
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No. Attribute No. Attribute 

31 Calling-Station-Id 78 Configuration-Token 

32 NAS-Identifier 79 EAP-Message 

33 Proxy-State 80 Message-Authenticator 

34 Login-LAT-Service 81 Tunnel-Private-Group-id 

35 Login-LAT-Node 82 Tunnel-Assignment-id 

36 Login-LAT-Group 83 Tunnel-Preference 

37 Framed-AppleTalk-Link 84 ARAP-Challenge-Response 

38 Framed-AppleTalk-Network 85 Acct-Interim-Interval 

39 Framed-AppleTalk-Zone 86 Acct-Tunnel-Packets-Lost 

40 Acct-Status-Type 87 NAS-Port-Id 

41 Acct-Delay-Time 88 Framed-Pool 

42 Acct-Input-Octets 89 (unassigned) 

43 Acct-Output-Octets 90 Tunnel-Client-Auth-id 

44 Acct-Session-Id 91 Tunnel-Server-Auth-id 

 

 

The attribute types listed in Table 38-2 are defined by RFC 2865, RFC 2866, RFC 2867, and RFC 2568. 

 

Extended RADIUS Attributes 

The RADIUS protocol features excellent extensibility. Attribute 26 (Vender-Specific) defined by RFC 
2865 allows a vender to define extended attributes to implement functions that the standard RADIUS 
protocol does not provide.  

A vendor can encapsulate multiple type-length-value (TLV) sub-attributes in RADIUS packets for 
extension in applications. As shown in Figure 38-4, a sub-attribute that can be encapsulated in Attribute 
26 consists of the following four parts: 

 Vendor-ID (four bytes): Indicates the ID of the vendor. Its most significant byte is 0 and the other 
three bytes contain a code complying with RFC 1700. The vendor ID of H3C is 2011. 

 Vendor-Type: Indicates the type of the sub-attribute.  

 Vendor-Length: Indicates the length of the sub-attribute.  

 Vendor-Data: Indicates the contents of the sub-attribute.  
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Figure 38-4 Segment of a RADIUS packet containing an extended attribute 

 

 

Protocols and Standards 

The protocols and standards related to RADIUS include: 

 RFC 2865: Remote Authentication Dial In User Service (RADIUS) 

 RFC 2866: RADIUS Accounting 

 RFC 2867: RADIUS Accounting Modifications for Tunnel Protocol Support 

 RFC 2868: RADIUS Attributes for Tunnel Protocol Support 

 RFC 2869: RADIUS Extensions 

Configuring RADIUS 

Configuration Task List 

 

 

 The RADIUS scheme configured through the Web interface is named system. 

 If there is no RADIUS scheme named system in the system, when you select Authentication > 
RADIUS to enter the RADIUS module, a scheme named system will be created automatically. 

 

Table 38-3 lists the RADIUS configuration steps. 

Table 38-3 RADIUS configuration task list 

Task Description 

Configuring RADIUS 
Authentication Servers

Required 
Configure the information related to the primary and 
secondary RADIUS authentication servers. 
By default, no RADIUS authentication server is configured. 

Configuring RADIUS 
Accounting Servers 

Optional 
Configure the information related to the primary and 
secondary RADIUS accounting servers. 
By default, no RADIUS accounting server is configured. 

For configuration 
details, refer to 
Configuring RADIUS 
Servers. 



 

38-8 

Task Description 

Configuring RADIUS 
Parameters 

Required 
Configure the parameters that are necessary for information exchange between the 
device and RADIUS servers. 

 

Configuring RADIUS Servers 

From the navigation tree, select Authentication > RADIUS. The RADIUS server configuration page 
appears, as shown in Figure 38-5. 

Figure 38-5 RADIUS server configuration 

 

 

Table 38-4 lists the RADIUS server configuration items. 

Table 38-4 RADIUS server configuration 

Item Description 

Server Type Specify the type of the server to be configured, which can be Authentication 
Server and Accounting Sever. 

Primary Server IP 

Specify the IP address of the primary server. 
If no primary server is specified, the text box displays 0.0.0.0. 
To remove the previously configured primary server, enter 0.0.0.0 in the text 
box. 
The specified IP address of the primary server cannot be the same as that of 
the secondary server. 

Primary Server Shared Key Specify the shared key of the primary server. The primary server shared key 
can be different from the secondary server shared key. 

Primary Server UDP Port 

Specify the UDP port of the primary server. 
If the IP address of the primary server is not specified or the specified IP 
address is to be removed, the port number is 1812 for authentication or 1813 
for accounting. 

Primary Server Status 

Set the status of the primary server, including: 
 active: The server is working normally. 
 blocked: The server is down. 

If the IP address of the primary server is not specified or the specified IP 
address is to be removed, the status is blocked. 
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Item Description 

Secondary Server IP 

Specify the IP address of the secondary server. 
If no secondary server is specified, the text box displays 0.0.0.0. 
To remove the previously configured secondary server, enter 0.0.0.0 in the 
text box. 
The specified IP address of the secondary server cannot be the same as that 
of the primary server. 

Secondary Server Shared Key Specify the shared key of the secondary server. The primary server shared 
key can be different from the secondary server shared key. 

Secondary Server UDP Port 

Specify the UDP port of the secondary server. 
If the IP address of the secondary server is not specified or the specified IP 
address is to be removed, the port number is 1812 for authentication or 1813 
for accounting. 

Secondary Server Status 

Status of the secondary server, including: 
 active: The server is working normally. 
 blocked: The server is down. 

If the IP address of the secondary server is not specified or the specified IP 
address is to be removed, the status is blocked. 

 

Return to RADIUS configuration task list. 

Configuring RADIUS Parameters 

From the navigation tree, select Authentication > RADIUS and then select the RADIUS Setup tab to 
enter the RADIUS parameter configuration page, as shown in Figure 38-6. 
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Figure 38-6 RADIUS parameter configuration 

 

 

Table 38-5 lists the RADIUS parameters.  

Table 38-5 RADIUS parameters 

Item Description 

Server Type 

Specify the type of the RADIUS server supported by the device, 
including: 

 extended: Specifies an extended RADIUS server (usually a CAMS or 
iMC server). That is, the RADIUS client (the device) and RADIUS 
server communicate using the proprietary RADIUS protocol and 
packet format.  

 standard: Specifies a standard RADIUS server. That is, the RADIUS 
client (the device) and RADIUS server communicate using the 
standard RADIUS protocol and packet format defined in RFC 
2138/2139 or later.  

Authentication Server Shared Key 

Confirm Authentication Shared Key 
Specify and confirm the shared key for the authentication server. These 
two parameters must have the same values. 

Accounting Server Shared Key 

Confirm Accounting Shared Key 
Specify and confirm the shared key for the accounting server. These two 
parameters must have the same values. 
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Item Description 

NAS-IP 

Specify the source IP address for the device to use in RADIUS packets to 
be sent to the RADIUS server. It is recommended to use a loopback 
interface address instead of a physical interface address as the source IP 
address, because if the physical interface is down, the response packets 
from the server cannot reach the device. 

Timeout Interval Set the RADIUS server response timeout. 

Timeout Retransmission Times 
Set the maximum number of transmission attempts. 
The product of the timeout value and the number of retransmission 
attempts cannot exceed 75. 

Realtime-Accounting Interval 

Set the real-time accounting interval, whose value must be n times 3 (n is 
an integer). 
To implement real-time accounting on users, it is necessary to set the 
real-time accounting interval. After this parameter is specified, the device 
will send the accounting information of online users to the RADIUS 
server every the specified interval.  
The value of the real-time accounting interval is related to the 
requirement on the performance of the NAS and RADIUS server. The 
smaller the value, the higher the requirement. It is recommended to set a 
large value if the number of users is equal to or larger than 1000. Table 
38-6 shows the relationship between the interval value and the number of 
users. 

Realtime-Accounting Packet 
Retransmission Times 

Set the maximum number of real-time accounting request retransmission 
times.  

Stop-Accounting Buffer Enable or disable buffering stop-accounting requests without responses 
in the device. 

Stop-Accounting Packet 
Retransmission Times 

Set the maximum number of transmission attempts if no response is 
received for the stop-accounting packet.  

Quiet Interval Specify the interval the primary server has to wait before being active  

Username Format 

Set the format of username sent to the RADIUS server. 
A username is generally in the format of userid@isp-name, of which 
isp-name is used by the device to determine the ISP domain to which a 
user belongs. If a RADIUS server does not accept a username including 
an ISP domain name, you can configure the device to remove the 
domain name of a username before sending it to the RADIUS server.  
without-domain: Specifies to remove the domain name of a username 
that is to be sent to the RADIUS server. 
with-domain: Specifies to keep the domain name of a username that is to 
be sent to the RADIUS server. 

Unit of Data Flows 

Specify the unit for data flows sent to the RADIUS server, which can be:
 byte 
 kilo-byte 
 mega-byte 
 giga-byte 

Unit of Packets 

Specify the unit for data packets sent to the RADIUS server, which can 
be  

 one-packet 
 kilo-packet 
 mega-packet 
 giga-packet 
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Item Description 

EAP Offload Function 

Enable or disable the EAP offload function. 
Some RADIUS servers do not support EAP authentication, that is, do not 
support processing EAP packets. In this case, it is necessary to 
preprocess EAP packets sent from clients on the access device. The 
preprocessing of EAP packets is referred to as EAP offload for RADIUS.
After receiving an EAP packet, the access device enabled with the EAP 
offload function will first convert the authentication information in the EAP 
packet into the corresponding RADIUS attributes through the local EAP 
server, and then encapsulate the EAP packet into a RADIUS request and 
send the request to the RADIUS server for authentication. When the 
RADIUS server receives the request, it will analyze the carried 
authentication information, encapsulate the authentication result in a 
RADIUS packet, and then send the packet to the local EAP server on the 
access device for subsequent interaction with the client. 

 
Because the EAP packet preprocessing is implemented through the local 
EAP authentication server, it is required to configure the local EAP 
authentication server on the access device and specify the EAP 
authentication method as PEAP-MSCHAPv2. Refer to Local EAP 
Service. 

 

Table 38-6 Relationship between the real-time accounting interval and the number of users 

Number of users Real-time accounting interval (in minutes) 

1 to 99 3 

100 to 499 6 

500 to 999 12 

ú1000 ú15 

 

Return to RADIUS configuration task list. 

RADIUS Configuration Example 

Network requirements 
As shown in Figure 38-7, configure the access controller (AC) to implement Telnet user authentication 
and accounting (recording online durations of Telnet users) by the RADIUS server. 

On the RADIUS server (a CAMS or iMC server), the Telnet user’s username and password and the 
shared key expert have been configured.  

On the AC, it is required to configure the shared key as expert, and configure the system to remove the 
domain name of a username before sending it to the RADIUS server. 

Figure 38-7 Network diagram for RADIUS server configuration 
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Configuration procedure 
 

 

Enable the Telnet server function, and configure the AC to use AAA for authentication, authorization 
and accounting of Telnet users. (Omitted) 

 

1) Configure IP addresses for the interfaces. (Omitted) 

2) Configure RADIUS scheme system 

# Configure the RADIUS authentication server. 

 From the navigation tree, select Authentication > RADIUS. The RADIUS server configuration 
page appears.  

Figure 38-8 Configure the RADIUS authentication server 

 

 

Perform the following configurations, as shown in Figure 38-8. 

 Select Authentication Server as the server type.  

 Enter 10.110.91.146 as the IP address of the primary authentication server 

 Enter 1812 as the UDP port of the primary authentication server. 

 Select active as the primary server status. 

 Click Apply.  

# Configure the RADIUS accounting server. 
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Figure 38-9 Configure the RADIUS accounting server 

 

 

Perform the following configurations, as shown in Figure 38-9. 

 Select Accounting Server as the server type.  

 Enter 10.110.91.146 as the IP address of the primary accounting server. 

 Enter 1813 as the UDP port of the primary accounting server. 

 Select active as the primary server status. 

 Click Apply.  

# Configure the parameters for communication between the AC and the RADIUS servers. 

 Select the RADIUS Setup tab and perform the following configurations, as shown in Figure 38-10. 
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Figure 38-10 Configure RADIUS parameters 

 
 

 Select extended as the server type. 

 Select the Authentication Server Shared Key check box and enter expert in the text box. 

 Enter expert in the Confirm Authentication Shared Key text box. 

 Select the Accounting Server Shared Key check box and enter expert in the text box. 

 Enter expert in the Confirm Accounting Shared Key text box. 

 Select without-domain for Username Format.  

 Click Apply 

3) Configure AAA 

# Create an ISP domain. 

 From the navigation tree, select Authentication > AAA. The domain setup page appears.  
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Figure 38-11 Create an ISP domain 

 

 

Perform the following configurations, as shown in Figure 38-11. 

 Enter test in the Domain Name textbox. 

 Select Enable to use the domain as the default domain. 

 Click Apply. 

# Configure the AAA authentication method for the ISP domain. 

 Select the Authentication tab.  

Figure 38-12 Configure the AAA authentication method for the ISP domain 

 

 

Perform the following configurations, as shown in Figure 38-12. 
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 Select the domain name test. 

 Select the Default AuthN checkbox and then select RADIUS as the authentication mode. 

 Select system from the Name drop-down list to use it as the authentication scheme.  

 Click Apply. A configuration progress dialog box appears, as shown in Figure 38-13. 

Figure 38-13 Configuration progress dialog box 

 
 

 After the configuration process is complete, click Close. 

# Configure the AAA authorization method for the ISP domain. 

 Select the Authorization tab.  

Figure 38-14 Configure the AAA authorization method for the ISP domain 

 

 

Perform the following configurations, as shown in Figure 38-14. 

 Select the domain name test. 

 Select the Default AuthZ checkbox and then select RADIUS as the authorization mode. 

 Select system from the Name drop-down list to use it as the authorization scheme. 

 Click Apply. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

# Configure the AAA accounting method for the ISP domain, and enable accounting optional. 

 Select the Accounting tab.  
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Figure 38-15 Configure the AAA accounting method for the ISP domain 

 

 

Perform the following configurations, as shown in Figure 38-15. 

 Select the domain name test. 

 Select the Accounting Optional checkbox and then select Enable. 

 Select the Default Accounting checkbox and then select RADIUS as the accounting mode. 

 Select system from the Name drop-down list to use it as the accounting scheme. 

 Click Apply. A configuration progress dialog box appears. 

 After the configuration process is complete, click Close. 

Configuration Guidelines 

When configuring the RADIUS client, note that: 

1) When you modify the parameters of the RADIUS scheme, the system does not check whether the 
scheme is being used by users. 

2) After accounting starts, update-accounting and stop-accounting packets will be sent to the 
designated server, and no primary/secondary server switchover will take place even if the 
designated server fails. Such a switchover can take place only during AAA session establishment. 

3) If an AAA server has active TCP connections, it cannot be removed. 

4) RADIUS does not support accounting for FTP users. 

5) If the H3C CAMS/iMC server is used as the RADIUS server, it is necessary to configure accounting 
as optional for users in the ISP domain because the CAMS/iMC server does not respond to 
accounting packets.  
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39  Local EAP Service 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

In some simple application environments, you may want to use an access device to authenticate users 
locally, instead of deploying AAA servers for user authentication. In this case, if the Extensible 
Authentication Protocol (EAP) is used for user access authentication, you need to configure the local 
EAP authentication server to cooperate with local authentication method of AAA for local EAP 
authentication. For details about AAA, refer to AAA. 

Configuring Local EAP Service 

Select Authentication > Local EAP Server from the navigation. The Local EAP service configuration 
page appears, as shown in Figure 39-1. 

Figure 39-1 Local EAP service configuration page 
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Table 39-1 describes the configuration items for configuring the local EAP service. 

Table 39-1 Local EAP service configuration items 

Item Description 

EAP-server-status 
Enable or disable the EAP server. 
If the EAP server is enabled, the EAP authentication method and PKI domain 
configurations are required. 

Method 

Specify the EAP authentication methods, including: 
 MD5: Uses Message Digest 5 (MD5) for authentication. 
 PEAP-MSCHAPV2: Uses Protected Extensible Authentication Protocol (PEAP) for 

authentication and, specially, uses the Microsoft Challenge Handshake 
Authentication Protocol version 2 (MSCHAPv2) for authentication in the established 
TLS tunnel. 

 TLS: Uses the Transport Layer Security (TLS) protocol for authentication. 
You can select more than one authentication method. An authentication method 
selected earlier has a higher priority. 
When an EAP client and the local server communicate for EAP authentication, they first 
negotiate the EAP authentication method to be used. During negotiation, the local 
server prefers the authentication method with the highest priority from the EAP 
authentication method list. If the client supports the authentication method, the 
negotiation succeeds and they proceed with the authentication process. Otherwise, the 
local server tries the one with the next highest priority until a supported one is found, or 
if none of the authentication methods are found supported, the local server sends an 
EAP-Failure packet to the client for notification of the authentication failure. 

PKI domain 

Specify the PKI domain for EAP authentication. 
The available PKI domains are those configured on the page you enter by selecting 
Authentication > PKI. For details, refer to PKI. 

 
The service management, local portal authentication, and local EAP service modules 
always reference the same PKI domain. Changing the referenced PKI domain in any of 
the three modules will also change that referenced in the other two modules. 

 

Local EAP Service Configuration Example 

Network requirements 
As shown in Figure 39-2, configure AC to perform local EAP authentication and authorization for 802.1X 
users. The authentication method is EAP-TLS. 

Figure 39-2 Network diagram for configuring local EAP service 
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Configuration procedure 
 

 

 To use the authentication method of EAP-TLS, configure the network properties of the connection 
and the client certificate properly on the client. 

 For operations about how to configure PKI domain test, requesting a local certificate, and 
retrieving a CA certificate, refer to PKI. 

 

1) Configure a local user. 

# Create local user usera. 

 Select Authentication > Users from the navigation tree to enter the Local User page. Click Add 
to enter the local user configuration page, and perform the configurations shown in Figure 39-3.  

Figure 39-3 Local user configuration page 

 

 

 Type usera as the username. 

 Type 1234 as the password. 

 Type 1234 to confirm the password. 

 Select LAN-Access as the service type. 

 Click Apply. 

2) Configure the ISP domain. 

# Configure the ISP domain system to use local authentication and local authorization (The ISP domain 
system uses local authentication and local authorization by default). 

3) Configure the local EAP service. 
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# Enable the EAP server, configure the authentication method as TLS, and the PKI domain as test. 

 Select Authentication > Local EAP Server from the navigation tree to enter the local EAP server 
configuration page and configure the following as shown in Figure 39-4. 

Figure 39-4 Configure a local EAP server 

 

 

 Select Enabled for the EAP server status. 

 Select TLS from the Available methods list and click << to add TLS to the Selected methods list. 

 Select test from the PKI domain drop-down list. 

 Click Apply. 

4) Configure the AP. 

# Create an AP. 

 Select AP > AP Setup. Then click Add to enter the page and perform the following configuration as 
shown in Figure 39-5. 

Figure 39-5 Configure the AP 

 
 

 Type wa2200 as the AP name. 

 Select WA2220X-AG as the device model. 

 Select manual and type the serial number in the text box. 

 Click Apply. 
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5) Configure the wireless service. 

# Create the wireless service. 

 Select Wireless Service > Access Service. Then, click Add to enter the access service 
configuration page and perform the following configuration as shown in Figure 39-6. 

Figure 39-6 Create a wireless service 

 

 

 Type 802.1x-auth as the wireless service name. 

 Select crypto as the service type. 

 Click Apply. 

The wireless service configuration page appears. Perform the configurations shown in Figure 39-7. 
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Figure 39-7 Wireless service configuration page 

 
 

 Click the expand button before Security Setup to expand the configuration items. 

 Select Open-System as the authentication type. 

 Select the Cipher Suite check box, and then select CCMP and TKIP (select a cipher suite 
according to your actual network requirements). Select WPA as the security IE. 

 Click the expand button before Port Security to expand the configuration items. 

 Select the Port Set check box. 

 Select userlogin-secure-ext as the port mode. 

 Select the Mandatory Domain check box, and then select system. 

 Select EAP as the authentication method. 

 Disable handshake. 

 Disable multicast trigger. 

 Click Apply. A configuration progress dialog box appears, as shown in Figure 39-8. 
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Figure 39-8 Configuration progress dialog box 

 

 

 After the configuration process is complete, click Close. When the configuration is in progress, a 
dialog box appears asking for your confirmation to enable the EAP service. Just confirm the 
operation to proceed. 

# Enable the wireless service. 

 After you complete the configuration, the access service list page appears. Perform the 
configurations shown in Figure 39-9. 

Figure 39-9 Enable the wireless service 

 

 

 Select wireless service 802.1x-auth. 

 Click Enable. 

6) Bind the AP's radio mode with the wireless service. 

 In the wireless service list shown in Figure 39-9, click the Bind link next to the wireless service 
name 802.1x-auth. Then perform the configurations shown in Figure 39-10. 
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Figure 39-10 Bind the radio mode with the wireless service 

 

 

 Select the AP of wa2200 with the radio mode being 802.11g. 

 Click Bind. 

7) Enable 802.11g. 

 Select Radio > Radio from the navigation tree to enter the page and perform the configurations 
shown in Figure 39-11. 

Figure 39-11 Enable dot11g 

 

 

 Select the AP of wa2200 with the radio mode being 802.11g. 

 Click Enable. 

8) Verify the configuration. 

 After the above configuration, a client should be able to pass EAP authentication and access the 
wireless network. 

 You can ping the client successfully from the AC. 
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40  Users 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

This module allows you to configure local users, user groups, guests, and user profiles. 

Local user 
A local user represents a set of user attributes configured on a device (such as the user password, 
service type, and authorization attribute), and is uniquely identified by the username. For a user 
requesting a network service to pass local authentication, you must add an entry as required in the local 
user database of the device. For details about local authentication, refer to AAA. 

User group 
A user group consists of a group of local users and has a set of local user attributes. You can configure 
local user attributes for a user group to implement centralized management of user attributes for the 
local users in the group. All local users in a user group inherit the user attributes of the group, but if you 
configure user attributes for a local user, the settings of the local user take precedence over the settings 
for the user group.  

By default, every newly added local user belongs to a user group named system, which is automatically 
created by the system. 

Guest 
A guest is a local user for specific applications. If some users need to access the network temporarily, 
you can establish a guest account for them and control access of the users as required. 

User profile 
A user profile is a configuration template for saving predefined configurations. You can configure 
different items such as Quality of Service (QoS) policy, rate limit, wireless service, and AP group for 
different user profiles to accommodate to different application scenarios.  

When accessing the device, a user needs to be authenticated. During the authentication process, the 
authentication server sends the user profile name to the device, which then enables the configurations 
in the user profile. After the user passes the authentication and accesses the device, the device will 
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restrict the user’s access based on the configurations in the user profile. When the user logs out, the 
device automatically disables the configurations in the user profile, removing the restrictions on the user 
as a result. As the mechanism indicates, user profiles are for restricting online users’ access. If no user 
is online (no user is accessing the network, no user has passed authentication, or all users have logged 
out), user profiles do not take effect. 

With user profiles, you can: 

 Make use of system resources more granularly. For example, you can apply a QoS policy on a 
per-user basis. 

 Restrict users’ access rate more flexibly. For example, you can deploy traffic policing on a per-user 
basis by defining a rate limit in user profiles. 

 Restrict users' access more specifically. For example, you can deploy user access control on a 
per-wireless service basis by defining an SSID in user profiles. Or you can deploy user access 
control on a per-AP basis by defining APs in the user profiles.   

Configuring Users 

Configuring a Local User 

Select Authentication > Users from the navigation tree. The Local User page appears, displaying all 
local users and guests, as shown in Figure 40-1. Click Add to enter the local user configuration page. 

Figure 40-1 Local user list 
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Figure 40-2 Local user configuration page 

 
 

Table 40-1 describes the configuration items for creating a local user. 

Table 40-1 Local user configuration items 

Item Description 

Username Specify a name for the local user. 

Password 

Confirm 

Specify a password for the local user and confirm the password. 
The two passwords must be identical. 

 
It is recommended not specify a command starting with spaces because spaces at the 
beginning of the password string will be ignored, but they count at the user login page.

Group 
Select a user group for the local user. 
For information about user group configuration, refer for Configuring a User Group. 

Service-type 

Select the service types for the local user to use, including FTP, Telnet, PPP, Portal, 
LAN access (accessing through the Ethernet, such as 802.1x users), and SSH. 

 
 If you do not specify any service type for a local user who uses local authentication, 

the user cannot pass authentication and therefore cannot log in. 
 Telnet must be selected for a local user to access the device through Web. 

Expire-time 

Specify an expiration time for the local user, in the format HH:MM:SS-YYYY/MM/DD. 
When authenticating a local user with the expiration time argument configured, the 
access device checks whether the expiration time has elapsed. If not, the device 
permits the user to log in. 



 

40-4 

Item Description 

Level 
Select an authorization level for the local user, which 
can be Visitor, Monitor, Configure, or Management, in 
ascending order of priority. 

VLAN Specify the VLAN to be authorized to the local user 
after the user passes authentication. 

ACL 
Specify the ACL to be used by the access device to 
restrict the access of the local user after the user 
passes authentication. 

User-profile 
Specify the user profile for the local user. 
For information about user profile configuration, refer to 
Configuring a User Profile. 

 
Every authorization attribute 
has its definite application 
environments and purposes. 
Therefore, when configuring 
authorization attributes for a 
local user, determine what 
attributes are needed first. 

Password 

Confirm 
Specify and confirm the password of the local user. The settings of these two fields 
must be the same. 

 

Configuring a User Group 

Select Authentication > Users from the navigation tree, and then select the User Group tab to display 
the existing user groups, as shown in Figure 40-3. Then, click Add to enter the user group configuration 
page, as shown in Figure 40-4. 

Figure 40-3 User group list 

 
 

Figure 40-4 User group configuration page 
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Table 40-2 describes the configuration items for creating a user group. 

Table 40-2 User group configuration items 

Item Description 

Group-name Specify a name for the user group. 

Level Select an authorization level for the user group, which can be Visitor, Monitor, 
Configure, or Management, in ascending order of priority. 

VLAN Specify the VLAN to be authorized to a user in the user group after the user passes 
authentication. 

ACL Specify the ACL to be used by the access device to restrict the access of a user in the 
user group after the user passes authentication. 

User-profile 
Specify the user profile for the user group. 
For information about user profile configuration, refer to Configuring a User Profile. 

 

Configuring a Guest 

Select Authentication > Users from the navigation tree, and then select the Guest tab to display the 
guest information, as shown in Figure 40-5. Then, click Add to enter the guest configuration page, as 
shown in Figure 40-6. 

Figure 40-5 Guest list 

 
 

Table 40-3 Guest configuration page 

 

 

Table 40-4 describes the configuration items for creating a guest. 
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Table 40-4 Guest configuration items 

Item Description 

Username Specify a name for the guest. 

Password Specify a password for the guest. 

Group 
Select a user group for the guest. 
For information about user group configuration, refer to Configuring a User Group. 

Expire-time 

Specify an expiration time for the guest, in the format HH:MM:SS-YYYY/MM/DD. 
When authenticating a local user with the expiration time argument configured, the 
access device checks whether the expiration time has elapsed. If not, the device 
permits the user to log in. 

 

 

The guest accounts are also displayed in the local user list. You can click the icon  of a guest in the 
list to edit the guest information and authorization attributes. 

 

Configuring a User Profile 

Select Authentication > Users from the navigation tree, and then select the User Profile tab to display 
the existing user profiles, as shown in Figure 40-6. Then, click Add to enter the user profile name 
configuration page, as shown in Figure 40-7. 

Figure 40-6 User profile list 

 

 

Figure 40-7 User profile name configuration item 

 

 

Table 40-5 describes the user profile name configuration item. 
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Table 40-5 User profile name configuration item 

Item Description 

Userprofile name  Specify a name for the user profile. 

 

After the above configuration, click Apply. The page turns to the user profile configuration page as 
shown in Figure 40-8. 

Figure 40-8 User profile configuration page 

 

 

Table 40-6 describes the user profile configuration items. 

Table 40-6 User profile configuration items 

Item Description 

Userprofile name This field displays the user profile name. 

Qos-out policy Select a QoS policy in the outbound direction. 
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Item Description 

Qos-in policy Select a QoS policy in the inbound direction. 

limited-out rate Specify the rate limit in the outbound direction. 

limited-in rate Specify the rate limit in the inbound direction. 

Service permitted 

Specify the wireless services permitted in the user profile: 
Select the services in the Services list box and click the < button to add them to 
the Selected services list box. 
The available wireless services are those configured on the page you enter by 
selecting Wireless Service > Access Service. For details, refer to Wireless 
Service Configuration. 

APs permitted 

Specify the APs permitted in the user profile: 
Select the APs in the APs list box and click the < button to add them to the 
Selected APs list box. 
The available APs are those you configured on the page you enter by selecting AP 
> AP Group. For details, refer to AP Configuration. 

 

By default, a newly added user profile is disabled. You need to manually enable it by following these 
steps: 

1) From the page displaying the existing user profiles, select the check box before the user profile to 
be enabled. 

2) Click Enable. 

 

 

 A user profile takes effect and the authentication server notifies users of authentication results only 
after the user profile is enabled. Therefore, if you do not enable the user profile, users using the 
user profile will not be able to get online. 

 Only enabled user profiles can be referenced by users. Disabling a user profile will log out all users 
using the user profile. 

 Enabled user profiles cannot be modified or removed. To modify or remove an enabled user profile, 
you need to disable it first. 

 



 

41-1 

41  PKI 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

PKI Overview 

The Public Key Infrastructure (PKI) is a hierarchical framework designed for providing information 
security through public key technologies and digital certificates and verifying the identities of the digital 
certificate owners. 

PKI employs digital certificates, which are bindings of certificate owner identity information and public 
keys. It allows users to obtain certificates, use certificates, and revoke certificates. By leveraging digital 
certificates and relevant services like certificate distribution and blacklist publication, PKI supports 
authenticating the entities involved in communication, and thus guaranteeing the confidentiality, 
integrity and non-repudiation of data. 

PKI Terms 

Digital certificate 
A digital certificate is a file signed by a certificate authority (CA) that contains a public key and the 
related user identity information. A simplest digital certificate contains a public key, an entity name, and 
a digital signature from the CA. Generally, a digital certificate also includes the validity period of the key, 
the name of the CA and the sequence number of the certificate. A digital certificate must comply with the 
international standard of ITU-T_X.509. This manual involves two types of certificates: local certificate 
and CA certificate. A local certificate is a digital certificate signed by a CA for an entity, while a CA 
certificate, also known as a root certificate, is signed by the CA for itself. 

CRL 
An existing certificate may need to be revoked when, for example, the user name changes, the private 
key leaks, or the user stops the business. Revoking a certificate is to remove the binding of the public 
key with the user identity information. In PKI, the revocation is made through certificate revocation lists 
(CRLs). Whenever a certificate is revoked, the CA publishes one or more CRLs to show all certificates 
that have been revoked. The CRLs contain the serial numbers of all revoked certificates and provide an 
effective way for checking the validity of certificates. 
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A CA may publish multiple CRLs when the number of revoked certificates is so large that publishing 
them in a single CRL may degrade network performance. 

CA policy 
A CA policy is a set of criteria that a CA follows in processing certificate requests, issuing and revoking 
certificates, and publishing CRLs. Usually, a CA advertises its policy in the form of certification practice 
statement (CPS). A CA policy can be acquired through out-of-band means such as phone, disk, and 
e-mail. As different CAs may use different methods to check the binding of a public key with an entity, 
make sure that you understand the CA policy before selecting a trusted CA for certificate request. 

Architecture of PKI 

A PKI system consists of entities, a CA, a registration authority (RA) and a PKI repository, as shown in 
Figure 41-1. 

Figure 41-1 PKI architecture 

 

 

Entity 
An entity is an end user of PKI products or services, such as a person, an organization, a device like a 
router or a switch, or a process running on a computer. 

CA 
A certificate authority (CA) is a trusted authority responsible for issuing and managing digital certificates. 
A CA issues certificates, specifies the validity periods of certificates, and revokes certificates as needed 
by publishing CRLs. 

RA 
A registration authority (RA) is an extended part of a CA or an independent authority. An RA can 
implement functions including identity authentication, CRL management, key pair generation and key 
pair backup. It only examines the qualifications of users; it does not sign certificates. Sometimes, a CA 
assumes the registration management responsibility and therefore there is no independent RA. The 
PKI standard recommends that an independent RA be used for registration management to achieve 
higher security of application systems. 

PKI repository 
A PKI repository can be a Lightweight Directory Access Protocol (LDAP) server or a common database. 
It stores and manages information like certificate requests, certificates, keys, CRLs and logs while 
providing a simple query function. 
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LDAP is a protocol for accessing and managing PKI information. An LDAP server stores user 
information and digital certificates from the RA server and provides directory navigation service. From 
an LDAP server, an entity can retrieve digital certificates of its own and other entities. 

Applications of PKI 

The PKI technology can satisfy the security requirements of online transactions. As an infrastructure, 
PKI has a wide range of applications. Here are some application examples. 

VPN 
A virtual private network (VPN) is a private data communication network built on the public 
communication infrastructure. A VPN can leverage network layer security protocols (for instance, IPSec) 
in conjunction with PKI-based encryption and digital signature technologies to achieve confidentiality. 

Secure E-mail 
E-mails require confidentiality, integrity, authentication, and non-repudiation. PKI can address these 
needs. The secure E-mail protocol that is currently developing rapidly is Secure/Multipurpose Internet 
Mail Extensions (S/MIME), which is based on PKI and allows for transfer of encrypted mails with 
signature. 

Web security 
For Web security, two peers can establish a Secure Sockets Layer (SSL) connection first for 
transparent and secure communications at the application layer. With PKI, SSL enables encrypted 
communications between a browser and a server. Both the communication parties can verify the 
identity of each other through digital certificates. 

Operation of PKI 

In a PKI-enabled network, an entity can request a local certificate from the CA and the device can check 
the validity of certificate. The following describes how it works: 

1) An entity submits a certificate request to the CA. 

2) The RA verifies the identity of the entity and then sends the identity information and the public key 
with a digital signature to the CA. 

3) The CA verifies the digital signature, approves the application, and issues a certificate. 

4) The RA receives the certificate from the CA, sends it to the LDAP server to provide directory 
navigation service, and notifies the entity that the certificate is successfully issued. 

5) The entity retrieves the certificate. With the certificate, the entity can communicate with other 
entities safely through encryption and digital signature. 

6) The entity makes a request to the CA when it needs to revoke its certificate, while the CA approves 
the request, updates the CRLs and publishes the CRLs on the LDAP server. 

Configuring PKI 

Configuration Task List 

There are two PKI certificate request modes: 

 Manual: In manual mode, you need to retrieve a CA certificate, generate a local RSA key pair, and 
submit a local certificate request for an entity. 
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 Auto: In auto mode, an entity automatically requests a certificate through the Simple Certification 
Enrollment Protocol (SCEP) when it has no local certificate or the present certificate is about to 
expire. 

You can specify the PKI certificate request mode for a PKI domain. Different PKI certificate request 
modes require different configurations: 

Requesting a certificate manually 
Perform the tasks in Table 41-1 to request a certificate manually. 

Table 41-1 Configuration task list for requesting a certificate manually 

Task Remarks 

Creating a PKI Entity

Required 
Create a PKI entity and configure the identity information. 
A certificate is the binding of a public key and an entity, where an entity is the collection 
of the identity information of a user. A CA identifies a certificate applicant by entity.  
The identity settings of an entity must be compliant to the CA certificate issue policy. 
Otherwise, the certificate request may be rejected. 

Creating a PKI 
Domain 

Required 
Create a PKI domain, setting the certificate request mode to Manual. 
Before requesting a PKI certificate, an entity needs to be configured with some 
enrollment information, which is referred to as a PKI domain. 
A PKI domain is intended only for convenience of reference by other applications like 
IKE and SSL, and has only local significance. 

Generating an RSA 
Key Pair 

Required 
Generate a local RSA key pair. 
By default, no local RSA key pair exists. 
Generating an RSA key pair is an important step in certificate request. The key pair 
includes a public key and a private key. The private key is kept by the user, while the 
public key is transferred to the CA along with some other information. 

 
If there is already a local certificate, you need to remove the certificate before 
generating a new key pair, so as to keep the consistency between the key pair and the 
local certificate. 

Retrieving the CA 
certificate 

Required 
Certificate retrieval serves two purposes: 

 Locally store the certificates associated with the local security domain for improved 
query efficiency and reduced query count, 

 Prepare for certificate verification. 

 
If there are already CA certificates locally, you cannot perform the CA certificate 
retrieval operation. This is to avoid possible mismatch between certificates and 
registration information resulting from relevant changes. To retrieve the CA certificate, 
you need to remove the CA certificate and local certificate first. 
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Task Remarks 

Requesting a Local 
Certificate 

Required 
When requesting a certificate, an entity introduces itself to the CA by providing its 
identity information and public key, which will be the major components of the 
certificate.  
A certificate request can be submitted to a CA in two ways: online and offline. 

 In online mode, if the request is granted, the local certificate will be retrieved to the 
local system automatically. 

 In offline mode, you need to retrieve the local certificate by an out-of-band means.

 
If there is already a local certificate, you cannot perform the local certificate retrieval 
operation. This is to avoid possible mismatch between the local certificate and 
registration information resulting from relevant changes. To retrieve a new local 
certificate, you need to remove the CA certificate and local certificate first. 

Destroying the RSA 
Key Pair 

Optional 
Destroy the existing RSA key pair and the corresponding local certificate. 
If the certificate to be retrieved contains an RSA key pair, you need to destroy the 
existing key pair. Otherwise, the retrieving operation will fail.  

Retrieving a 
Certificate 

Optional 
Retrieve an existing certificate. 

Retrieving and 
Displaying a CRL 

Optional 
Retrieve a CRL and display its contents. 

 

Requesting a Certificate Automatically 
Perform the tasks in Table 41-2 to configure the PKI system to request a certificate automatically. 

Table 41-2 Configuration task list for requesting a certificate automatically 

Task Remarks 

Creating a PKI Entity

Required 
Create a PKI entity and configure the identity information. 
A certificate is the binding of a public key and an entity, where an entity is the collection 
of the identity information of a user. A CA identifies a certificate applicant by entity.  
The identity settings of an entity must be compliant to the CA certificate issue policy. 
Otherwise, the certificate request may be rejected. 

Creating a PKI 
Domain 

Required 
Create a PKI domain, setting the certificate request mode to Auto. 
Before requesting a PKI certificate, an entity needs to be configured with some 
enrollment information, which is referred to as a PKI domain. 
A PKI domain is intended only for convenience of reference by other applications like 
IKE and SSL, and has only local significance. 

Destroying the RSA 
Key Pair 

Optional 
Destroy the existing RSA key pair and the corresponding local certificate. 
If the certificate to be retrieved contains an RSA key pair, you need to destroy the 
existing key pair. Otherwise, the retrieving operation will fail.  

Retrieving a 
Certificate 

Optional 
Retrieve an existing certificate. 

Retrieving and 
Displaying a CRL 

Optional 
Retrieve a CRL and display its contents. 
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Creating a PKI Entity 

Select Authentication > PKI from the navigation tree. The PKI entity list page is displayed by default, 
as shown in Figure 41-2. Click Add on the page to enter the PKI entity configuration page, as shown in 
Figure 41-3. 

Figure 41-2 PKI entity list 

 

 

Figure 41-3 PKI entity configuration page 

 

 

Table 41-3 describes the configuration items for creating a PKI entity. 

Table 41-3 PKI entity configuration items 

Item Description 

Entity Name Type the name for the PKI entity. 

Common Name Type the common name for the entity. 

IP Address Type the IP address of the entity. 

FQDN 

Type the fully qualified domain name (FQDN) for the entity. 
An FQDN is a unique identifier of an entity on the network. It consists of a host name 
and a domain name and can be resolved to an IP address. For example, 
www.whatever.com is an FQDN, where www indicates the host name and 
whatever.com the domain name. 

Country/Region Code Type the country or region code for the entity. 
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Item Description 

State Type the state or province for the entity. 

Locality Type the locality for the entity. 

Organization Type the organization name for the entity. 

Organization Unit Type the unit name for the entity. 

 

Return to Configuration task list for requesting a certificate manually. 

Return to Configuration task list for requesting a certificate automatically. 

Creating a PKI Domain 

Select Authentication > PKI from the navigation tree, and then select the Domain tab to enter the 
page displaying existing PKI domains, as shown in Figure 41-4. Then, click Add to enter the PKI 
domain configuration page, as shown in Figure 41-5. 

Figure 41-4 PKI domain list 

 
 

Figure 41-5 PKI domain configuration page 

 
 

Table 41-4 describes the configuration items for creating a PKI domain. 
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Table 41-4 PKI domain configuration items 

Item Description 

Domain Name Type the name for the PKI domain. 

CA Identifier 

Type the identifier of the trusted CA. 
An entity requests a certificate from a trusted CA. The trusted CA takes the responsibility 
of certificate registration, distribution, and revocation, and query. 
In offline mode, this item is optional; while in other modes, this item is required. 

Entity Name 

Select the local PKI entity. 
When submitting a certificate request to a CA, an entity needs to show its identity 
information. 
Available PKI entities are those that have been configured. 

Institution 

Select the authority for certificate request. 
 CA: Indicates that the entity requests a certificate from a CA. 
 RA: Indicates that the entity requests a certificate from an RA. 

RA is recommended. 

Requesting URL 

Type the URL of the RA. 
The entity will submit the certificate request to the server at this URL through the SCEP 
protocol. The SCEP protocol is intended for communication between an entity and an 
authentication authority. 
In offline mode, this item is optional; while in other modes, this item is required. 

 
Currently, this item does not support domain name resolution. 

LDAP IP 

Port 

Version 

Type the IP address, port number and version of the LDAP server. 
In a PKI system, the storage of certificates and CRLs is a crucial problem, which is 
usually addressed by deploying an LDAP server. 

Request Mode Select the online certificate request mode, which can be auto or manual.  

Password Encrypt 
Select this check box to display the password in cipher text. 
This check box is available only when the certificate request mode is set to Auto. 

Password 
Type the password for certificate revocation. 
This item is available only when the certificate request mode is set to Auto. 

Hash 

Fingerprint 

Specify the hash algorithm and fingerprint for verification of the CA root certificate. 
Upon receiving the root certificate of the CA, an entity needs to verify the fingerprint of the 
root certificate, namely, the hash value of the root certificate content. This hash value is 
unique to every certificate. If the fingerprint of the root certificate does not match the one 
configured for the PKI domain, the entity will reject the root certificate.  

 
The fingerprint of the CA root certificate is required when the certificate request mode is 
Auto, and can be omitted when the certificate request mode is Manual. When it is 
omitted, no CA root certificate verification occurs automatically and you need to verify the 
CA server by yourself.  

Polling Count 

Polling Interval 

Set the polling interval and attempt limit for querying the certificate request status. 
After an entity makes a certificate request, the CA may need a long period of time if it 
verifies the certificate request in manual mode. During this period, the applicant needs to 
query the status of the request periodically to get the certificate as soon as possible after 
the certificate is signed. 

Enable CRL 
Checking Select this box to specify that CRL checking is required during certificate verification. 
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Item Description 

CRL Update Period 

Type the CRL update period, that is, the interval at which the PKI entity downloads the 
latest CRLs. 
This item is available when the Enable CRL Checking check box is selected. 
By default, the CRL update period depends on the next update field in the CRL file. 

CRL URL 

Type the URL of the CRL distribution point. 
This item is available when the Enable CRL Checking check box is selected. 
Note that when the URL of the CRL distribution point is not set, you should acquire the 
CA certificate and a local certificate, and then acquire a CRL through SCEP. 

 
Currently, this item does not support domain name resolution. 

 

Return to Configuration task list for requesting a certificate manually. 

Return to Configuration task list for requesting a certificate automatically. 

Generating an RSA Key Pair 

Select Authentication > PKI from the navigation tree, and then select the Certificate tab to enter the 
page displaying existing PKI certificates, as shown in Figure 41-6. Then, click Generate Key to enter 
RSA key pair parameter configuration page, as shown in Figure 41-7. 

Figure 41-6 Certificate configuration page 

 
 

Figure 41-7 Key pair parameter configuration page 

 

 



 

41-10 

Table 41-5 describes the configuration item for generating an RSA key pair. 

Table 41-5 Configuration item for generating an RSA key pair 

Item Description 

Key Length Type the length of the RSA keys. 

 

Return to Configuration task list for requesting a certificate manually. 

Destroying the RSA Key Pair 

Select Authentication > PKI from the navigation tree, and then select the Certificate tab to enter the 
page displaying existing PKI certificates, as shown in Figure 41-6. Click Destroy Key to enter RSA key 
pair destruction page, as shown in Figure 41-8. Then, click Apply to destroy the existing RSA key pair 
and the corresponding local certificate. 

Figure 41-8 Key pair destruction page 

 

 

Return to Configuration task list for requesting a certificate manually. 

Return to Configuration task list for requesting a certificate automatically. 

Retrieving a Certificate 

You can download an existing CA certificate or local certificate from the CA server and save it locally. To 
do so, you can use two ways: online and offline. In offline mode, you need to retrieve a certificate by an 
out-of-band means like FTP, disk, e-mail and then import it into the local PKI system. 

Select Authentication > PKI from the navigation tree, and then select the Certificate tab to enter the 
page displaying existing PKI certificates, as shown in Figure 41-6. Click Retrieve Cert to enter PKI 
certificate retrieval page, as shown in Figure 41-9. 

Figure 41-9 PKI certificate retrieval page 

 
 

Table 41-6 describes the configuration items for retrieving a PKI certificate. 
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Table 41-6 Configuration items for retrieving a PKI certificate 

Item Description 

Domain Name Select the PKI domain for the certificate. 

Certificate Type Select the type of the certificate to be retrieved, which can be CA or local. 

Enable Offline 
Mode 

Select this check box to retrieve a certificate in offline mode (that is, by an out-of-band 
means like FTP, disk, or e-mail) and then import the certificate into the local PKI system.

Get File From  
Device 

Get File From PC 

Specify the path and name of the certificate file. 
 If the certificate file is saved on the device, select Get File From Device and then 

specify the path of the file on the device. 
 If the certificate file is saved on a local PC, select Get File From PC and. then specify 

the path to the file and select the partition of the device for saving the file. 

Password Enter the password for protecting the private key, which was specified when the 
certificate was exported. 

 

After retrieving a certificate, you can click View Cert corresponding to the certificate from the PKI 
certificates list to display the contents of the certificate, as shown in Figure 41-10. 

Figure 41-10 Certificate details 

 
 

Return to Configuration task list for requesting a certificate manually. 

Return to Configuration task list for requesting a certificate automatically. 
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Requesting a Local Certificate 

Select Authentication > PKI from the navigation tree, and then select the Certificate tab to enter the 
page displaying existing PKI certificates, as shown in Figure 41-6. Click Request Cert to enter the local 
certificate request page, as shown in Figure 41-11. 

Figure 41-11 Local certificate request page 

 

 

Table 41-7 describes the configuration items for requesting a local certificate. 

Table 41-7 Configuration items for requesting a local certificate 

Item Description 

Domain Name Select the PKI domain for the certificate. 

Password Type the password for certificate revocation. 

Enable Offline Mode Select this check box to request a certificate in offline mode, that is, by an 
out-of-band means like FTP, disk, or e-mail. 

 

If you select the offline mode and click Apply, the offline certificate request information page appears, 
as shown in Figure 41-12. Submit the information to the CA to request a local certificate. 

Figure 41-12 Offline certificate request information page 

 

 

Return to Configuration task list for requesting a certificate manually. 
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Retrieving and Displaying a CRL 

Select Authentication > PKI from the navigation tree, and then select the CRL tab to enter the page 
displaying CRLs, as shown in Figure 41-13. 

Figure 41-13 CRL page 

 

 

 Click Retrieve CRL to retrieve the CRL of a domain. 

 Then, click View CRL for the domain to display the contents of the CRL, as shown in Figure 41-14. 

Figure 41-14 CRL details 

 
 

Return to Configuration task list for requesting a certificate manually. 

Return to Configuration task list for requesting a certificate automatically. 

PKI Configuration Example 

Configuring a PKI Entity to Request a Certificate from a CA 

Network requirements 
As shown in Figure 41-15, configure the AC working as the PKI entity, so that: 

 The AC submits a local certificate request to the CA server, which runs the RSA Keon software. 
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 The AC acquires CRLs for certificate verification. 

Figure 41-15 Network diagram for configuring a PKI entity to request a certificate from a CA 

 
 

Configuration procedure 
1) Configure the CA server 

# Create a CA server named myca. 

In this example, you need to configure the basic attributes of Nickname and Subject DN on the CA 
server at first: 

 Nickname: Name of the trusted CA. 

 Subject DN: DN information of the CA, including the Common Name (CN),  

 Organization Unit (OU),  

 Organization (O), and  

 Country (C).  

The other attributes may use the default values.  

# Configure extended attributes 

After configuring the basic attributes, you need to perform configuration on the Jurisdiction 
Configuration page of the CA server. This includes selecting the proper extension profiles, enabling 
the SCEP autovetting function, and adding the IP address list for SCEP autovetting. 

# Configure the CRL publishing behavior 

After completing the above configuration, you need to perform CRL related configurations. 

In this example, select the local CRL publishing mode of HTTP and set the HTTP URL to 
http://4.4.4.133:447/myca.crl. 

After the above configuration, make sure that the system clock of the AC is synchronous to that of the 
CA, so that the AC can request certificates and retrieve CRLs properly. 

2) Configure AC 

# Create a PKI entity. 

 Select Authentication > PKI from the navigation tree. The PKI entity list page is displayed by 
default. Click Add on the page, as shown in Figure 41-16, and then perform the following 
configurations as shown in Figure 41-17. 

Figure 41-16 PKI entity list 
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Figure 41-17 Configure a PKI entity 

 
 

 Type aaa as the PKI entity name. 

 Type ac as the common name. 

 Click Apply. 

# Create a PKI domain. 

 Select the Domain tab, and then click Add, as shown in Figure 41-18, and then perform the 
following configurations as shown in Figure 41-19. 

Figure 41-18 PKI domain list 
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Figure 41-19 Configure a PKI domain 

 
 

 Type torsa as the PKI domain name. 

 Type myca as the CA identifier. 

 Select aaa as the local entity. 

 Select CA as the authority for certificate request. 

 Type http://4.4.4.133:446/c95e970f632d27be5e8cbf80e971d9c4a9a93337 as the URL for 
certificate request. The URL must be in the format of http://host:port/Issuing Jurisdiction ID, where 
Issuing Jurisdiction ID is the hexadecimal string generated on the CA. 

 Select Manual as the certificate request mode. 

 Click Display Advanced Config to display the advanced configuration items. 

 Select the Enable CRL Checking check box. 

 Type http://4.4.4.133:447/myca.crl as the CRL URL. 

 Click Apply. A dialog box appears, asking "Fingerprint of the root certificate not specified. No root 
certificate validation will occur. Continue?" Click OK. 

# Generate an RSA key pair. 

 Select the Certificate tab, and then click Generate Key, as shown in Figure 41-20, and perform 
the configuration as shown in Figure 41-21. 
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Figure 41-20 Certificate list 

 
 

Figure 41-21 Generate an RSA key pair 

 

 

 Click Apply to generate an RSA key pair. 

# Retrieve the CA certificate. 

 Select the Certificate tab, and then click Retrieve Cert, as shown in Figure 41-22, and then 
perform the following configurations as shown in Figure 41-23. 

Figure 41-22 Certificate list 

 
 



 

41-18 

Figure 41-23 Retrieve the CA certificate 

 

 

 Select torsa as the PKI domain. 

 Select CA as the certificate type. 

 Click Apply. 

# Request a local certificate. 

 Select the Certificate tab, and then click Request Cert, as shown in Figure 41-24, and then 
perform the following configurations as shown in Figure 41-25. 

Figure 41-24 Certificate list 

 

 

Figure 41-25 Request a local certificate 
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 Select torsa as the PKI domain. 

 Select Password and then type challenge-word as the password. 

 Click Apply. 

# Retrieve the CRL. 

 After retrieving a local certificate, select the CRL tab. 

 Click Retrieve CRL of the PKI domain of torsa, as shown in Figure 41-26. 

Figure 41-26 Retrieve the CRL 

 

 

Configuration Guidelines 

When configuring PKI, note that: 

1) Make sure the clocks of entities and the CA are synchronous. Otherwise, the validity period of 
certificates will be abnormal. 

2) The Windows 2000 CA server has some restrictions on the data length of a certificate request. If 
the PKI entity identity information in a certificate request goes beyond a certain limit, the server will 
not respond to the certificate request. 

3) The SCEP plug-in is required when you use the Windows Server as the CA. In this case, you need 
to specify RA as the authority for certificate request when configuring the PKI domain. 

4) The SCEP plug-in is not required when you use the RSA Keon software as the CA. In this case, 
you need to specify CA as the authority for certificate request when configuring the PKI domain. 
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42  WLAN Security Configuration 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

WLAN Security Overview 

802.11 networks are susceptible to a wide array of threats such as unauthorized access points and 
clients, ad hoc networks, and Denial of Service (DoS) attacks. Rogue devices are a serious threat to 
enterprise security. To ensure security, the wireless intrusion detection system (WIDS) is introduced. 
WIDS provides early detection of malicious attacks and intrusions on a wireless network without 
affecting network performance, and provides real-time countermeasures. 

WLAN security provides these features: 

 Rogue detection 

 WIDS attack detection 

 Frame filtering. 

Terminology 

 Rogue AP: An unauthorized or malicious access point on the network, such as an employee setup 
AP, misconfigured AP, neighbor AP or an attacker operated AP. As it is not authorized, if there is 
any vulnerability in the AP, the hacker will have chance to compromise your network security. 

 Rogue client: An unauthorized or malicious client on the network.  

 Rogue wireless bridge: Unauthorized wireless bridge on the network. 

 Monitor AP: An AP that scans or listens to 802.11 frames to detect rogue devices in the network.  

 Ad hoc mode: A wireless client in ad-hoc mode can directly communicate with other stations 
without support from any other device. 

Detecting rogue devices 
Rogue detection is applicable to large wireless networks. It detects the presence of rogue devices in a 
WLAN network based on the pre-configured rules. 
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Rogue detection can detect different types of devices in a WLAN network, for example, rogue APs, 
rogue clients, rogue wireless bridges, and ad-hoc terminals. An AP can work in either of the following 
modes for rogue detection: 

 Monitor mode: In this mode, an AP scans all 802.11g frames in the WLAN, but cannot provide 
WLAN services. As shown in Figure 42-1, AP 1 works as an access AP, and AP 2 works as a 
monitor AP to listen to all 802.11g frames. AP 2 cannot provide wireless access services. 

Figure 42-1 Monitor AP for rogue detection 
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 Hybrid mode: In this mode, an AP can both scan devices in the WLAN and provide WLAN data 
services. 

Figure 42-2 Hybrid AP for rogue detection 
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Taking countermeasures against rogue device attacks 
You can enable the countermeasures on a monitor AP. The monitor AP downloads an attack list from 
the AC according to the countermeasure mode and takes countermeasures against detected rogue 
devices. The processing methods vary with rogue devices: 

 If the rogue device is a rogue client, it will be logged out. 

 If the rogue device is a rogue AP, legal clients will not use the rogue AP to access the WLAN. 

 If the rogue device is an ad-hoc client, it is denied and ad-hoc clients cannot communicate with 
each other. 

Figure 42-3 Take countermeasures against rogue devices 
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Functionalities supported 
The rogue detection feature supports the following functionalities: 

 RF monitoring in different channels 

 Rogue AP detection 

 Rogue client detection 

 Ad hoc network detection 

 Wireless bridge detection 

 Countermeasures against rogue devices, clients and ad hoc networks 

The current solution only supports detection of rogue devices managed by a single access controller. 

The rogue detection feature does not support the following functionalities: 

 Interfering AP (APs of other enterprises) detection 

 Physical location tracking on wireless side 

 Port location tracking and blocking on wire side 

 DoS attacks against rogue APs 

 Countermeasures against rogue wireless bridges 
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WIDS Attack Detection 

The WIDS attack detection function detects intrusions or attacks on a WLAN network, and informs the 
network administrator of the attacks through recording information or sending logs. At present, WIDS 
detection supports detection of the following attacks: 

 Flood attack 

 Spoofing attack 

 Weak IV attack 

Flood attack detection 
A flood attack refers to the case where WLAN devices receive large volumes of frames of the same kind 
within a short span of time. When this occurs, the WLAN devices get overwhelmed and consequently, is 
unable to service normal clients. 

WIDS attacks detection counters flood attacks by constantly keeping track of the density of traffic 
generated by each device. When the traffic density of a device exceeds the  limit, the device is 
considered flooding the network and will be blocked. If the dynamic blacklist feature is enabled, the 
detected device will be added to the blacklist. 

WIDS inspects the following types of frames: 

 Authentication requests and de-authentication requests 

 Association requests, disassociation requests and reassociation requests 

 Probe requests 

 Null data frames 

 Action frames. 

Spoofing attack detection 
In this kind of attack, a potential attacker can send a frame in the air on behalf of another device. For 
instance, a spoofed de-authentication frame can cause a station to get de-authenticated from the 
network. 

Spoofing attack detection counters this attack by detecting broadcast de-authentication and 
disassociation frames. When such a frame is received, this is identified as a spoofed frame, and the 
attack is immediately logged. 

Weak IV detection 
Wired Equivalent Privacy (WEP) uses an Initialization Vector (IV) to encrypt each frame. An IV and a 
key are used to generate a key stream, and thus encryptions using the same key have different results. 
When a WEP frame is sent, the IV used in encrypting the frame is also sent as part of the frame header.  

However, if a client generates IVs in an insecure way, for example, if it uses a fixed IV for all frames, the 
shared secret key may be exposed to any potential attackers. When the shared secret key is 
compromised, the attacker can access network resources. 

Weak IV detection counters this attack by verifying the IVs in WEP frames. Whenever a frame with a 
weak IV is detected, it is immediately logged. 

Frame Filtering 

You can specify rules to filter frames from clients and thus implement client access control. 

The wireless client access control is accomplished through the following three types of filtering lists. 



 

42-5 

 White list: Contains MAC addresses of stations whose frames can be processed. If the white list is 
used, only permitted clients can access the WLAN, and all frames from other clients will be 
discarded. 

 Static blacklist: Contains MAC addresses of stations whose frames should be dropped. This list is 
configured by the user. 

 Dynamic blacklist: Contains MAC addresses of clients whose frames will be dropped. A client is 
dynamically added to the list if it sends attacking frames. 

Figure 42-4 Network diagram for WLAN client access control 

 

 

In the topology above, three APs are connected to an AC. Configure white list and blacklist entries on 
the AC, which will send all the entries to the APs. If the MAC address of a station, Client 1 for example, 
is present in the blacklist, it cannot access any of the APs. If only the MAC address of Client 1 is present 
in the white list, it can access any of the APs but others cannot access any of the APs..  

Configuring Rogue Device Detection 

Perform the tasks in Table 42-1 to configure rogue detection. 

Table 42-1 Rogue detection configuration task list 

Task Remarks 

Configuring AP Operating Mode 
Required 
By default, the AP operates in normal mode and only 
provides WLAN data services. 

Configuring Detection Rule Lists Required 

Enabling Countermeasures and Configuring Aging 
Time for Detected Rogue Devices Optional 

 

Configuring AP Operating Mode 

Select  Security > Rogue Detection from the navigation tree, and then select the AP Monitor  tab to 
enter the AP monitor configuration page as shown in Figure 42-5. 
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Figure 42-5 AP monitor configuration 

 
 

Select the AP to be configured and click the icon  to enter the configuration page as shown in Figure 
42-6. 

Figure 42-6 AP operating mode configuration 

 

 

A WLAN consists of various APs that span across the building and offer WLAN services to the clients. 
The administrator may want some of these APs to detect rogue devices. The administrator can 
configure an AP to operate in any of the three modes, normal, monitor, and hybrid. 

Table 42-2 describes the configuration items for configuring AP operating mode. 

Table 42-2 AP operating mode configuration items 

Item Description 

Work mode 

Configure the AP operating mode: 
 In common mode, an AP provides WLAN data services but does not perform scanning.
 In monitor mode, an AP scans all 802.11g frames in the WLAN, but cannot provide 

WLAN services. 
 In hybrid mode, an AP can both scan devices in the WLAN and provide WLAN data 

services. 

 
 When an AP has its operating mode changed from normal to monitor, it does not 

restart. 
 When an AP has its operating mode changed from monitor to normal, it restarts. 
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 An AP operating in hybrid mode can provide WLAN data services as well as scanning devices in 
the WLAN, so WLAN configurations are needed. 

 An AP operating in monitor mode cannot provide WLAN data services, so WLAN configurations 
are not needed. 

 

Configuring Detection Rules 

Configuring detection rules is to configure rogue device classification rules. An AC classifies devices as 
rogues and friends based on the configured classification rules. 

 Check whether an AP is a rogue. 

Figure 42-7 Check whether an AP is a rogue 
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 Check whether a client is a rogue. 
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Figure 42-8 Check whether a client is a rogue 

 

In the static 
attack list?

No or the list is not 
configured

In the permitted 
MAC address list?

No or the list is not 
configured

Yes

Legal client
(Friend)

Check if AP (BSSID) 
associated with the client 

is legal

Illegal client 
(Rogue)

Yes

No

Client

Yes

 

 

 Check whether an ad hoc network or a wireless bridge is a rogue. 

Figure 42-9 Check whether an ad hoc network or a wireless bridge is a rogue 
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Configuring Detection Rule Lists 

Select Security > Rogue Detection from the navigation tree, and then select the Rule List tab to enter 
detection rule list configuration page, as shown in Figure 42-10. 

Figure 42-10 Rule list configuration 

 
 

Table 42-3 describes the rule list configuration items. 

Table 42-3 Rule list configuration items 

Item Description 

List Type 

 MAC: You can add MAC addresses to be permitted after selecting this option. 
 Wireless Service: You can add SSIDs to be permitted after selecting this option. 
 Vendor: You can specify vendors to be permitted after selecting this option. 
 Attacker: You can add the MAC address of a device to configure the device as a rogue.

 

Select MAC from the drop-down list and click Add to enter the MAC address configuration page, as 
shown in Figure 42-11. 

Figure 42-11 MAC address list configuration page 

 
 

Table 42-4 describes configuration items for configuring MAC address list. 
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Table 42-4 MAC address list configuration items 

Item Description 

MAC  Type the permitted MAC address in the text box. 

Select the existent 
devices 

If you select this button, the MAC address table displays MAC addresses of the 
current devices. Select the MAC addresses to be permitted.  

 

The operation to add other types of lists is similar to the add operation of a MAC address list, and thus 
the description is omitted. 

Enabling Countermeasures and Configuring Aging Time for Detected Rogue Devices 

Select Security > Rogue Detection from the navigation tree, and then select the AP Monitor tab. On 
the page, click Common Set to enter the configuration page, as shown in Figure 42-12. 

Figure 42-12 Countermeasures configuration 

 
 

Table 42-5 describes the common configuration items. 

Table 42-5 Common configuration items 

Item Description 

Contermeasures 
Mode 

 Rogue Device: Allows you to take countermeasures against rogue devices (including 
illegal APs and illegal clients). 

 Rogue Adhoc Device: Allows you to take countermeasures against ad hoc devices. 
 Static Rogue Device: Allows you to take countermeasures against rogue devices 

configured in the detection rule list. 

Device 
Aging-duration 

Configure the aging time of entries in the device list. 
Once a rogue device is detected, an entry for it is added to the monitor record and the 
aging time starts. The aging time restarts if the device is detected again during the time. 
When the aging time is reached, the entry is deleted from the monitor record and added to 
the history record. 

 

Displaying Monitor Record 

Select Security > Rogue Detection from the navigation tree, and then select the Monitor Record tab 
to enter the monitor record page, as shown in Figure 42-13. 
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Figure 42-13 Monitor record 

 

 

Table 42-6 describes the type item of monitor record. 

Table 42-6 Type item of monitor record 

Item Description 

Type 

 r: Rogue device. 
 p: Permitted device. 
 a: Ad hoc device. 
 w: AP. 
 b: Wireless bridge. 
 c: Client. 

For example, pw represents a permitted AP while rb represents a rogue wireless bridge. 

 

Displaying History Record 

Select Security > Rogue Detection from the navigation tree, and then select the Hisotry Record tab 
to enter the history record page, as shown in Figure 42-14. 

Figure 42-14 History record page 

 

 

Configuring WIDS 

Configuring WIDS 

Select Security > WIDS from the navigation tree, and then select the WIDS Setup tab to enter the 
WIDS configuration page, as shown in Figure 42-15. 
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Figure 42-15 WIDS configuration 

 
 

Table 42-7 describes the WIDS configuration items. 

Table 42-7 WIDS configuration items  

Item Description 

Flood Attack Detect 
If you select the check box, flood attack detection is enabled.  
It is disabled by default. 

Spoof Attack Detect If you select the check box, spoofing attack detection is enabled. It is disabled by 
default. 

Weak-iv Attack Detect If you select the check box, Weak IV attack detection is enabled. It is disabled by 
default. 

 

Displaying History Record 

Select Security > WIDS from the navigation tree, and then select the History Record tab to enter the 
history information page, as shown in Figure 42-16. 

Figure 42-16 History information 

 
 

Displaying Statistics Information 

Select Security > WIDS from the navigation tree, and then select the Statistics tab to enter the 
statistics information page, as shown in Figure 42-17. 
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Figure 42-17 Statistics information 

 

 

Configuring Frame Filtering 

Configuring Dynamic Blacklist 

Select Security > Filter from the navigation tree, and then select the Blacklist tab to enter the dynamic 
blacklist configuration page, as shown in Figure 42-18.  

Figure 42-18 Dynamic blacklist configuration page 

 
 

Table 42-8 describes the configuration items for configuring dynamic blacklist. 

Table 42-8 Dynamic blacklist configuration items 

Item Description 

Dynamic Blacklist 

 Enable: Enables dynamic blacklist. 
 Disable: Disables dynamic blacklist. 

 
Before enabling the dynamic blacklist function, you need to select the Flood 
Attack Detect check box in the WIDS Setup page. 

Lifetime Configure the lifetime of the entries in the blacklist. 
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Configuring Static Blacklist 

On the blacklist configuration page as shown in Figure 42-18, select the Static tab to enter the static 
blacklist configuration page, as shown in Figure 42-19. Click Add Static to enter the static blacklist 
configuration page.  

Figure 42-19 Static blacklist configuration 

  

 

Table 42-9 describes static blacklist configuration items. 

Table 42-9 Static blacklist configuration items 

Item Description 

MAC Address Add a MAC address to the static blacklist. 

Select Current Connect 
Client 

If you select the check box, the table below lists the current existing clients. Select 
the check boxes of the clients to add their MAC addresses to the static blacklist. 

 

Configuring White List 

Select Security > Filter from the navigation tree, and then select the Whitelist tab. Click Add to enter 
the white list configuration page, as shown in Figure 42-20. 

Figure 42-20 White list configuration 

 
 

Table 42-10 describes the white list configuration items. 
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Table 42-10 White list configuration items 

Item Description 

MAC Address Add a MAC address to the white list. 

Select Current Connect 
Client 

If you select the check box, the table below lists the current existing clients. Select 
the check boxes of the clients to add their MAC addresses to the white list. 

 

WLAN Security Configuration Example 

Rogue Detection Configuration Example 

Network requirements 
As shown in Figure 42-21, a monitor AP (AP 2 with serial ID 210235A29G007C000020) and AP 1 (serial 
ID 210235A29G007C000022) are connected to an AC through a Layer 2 switch.  

 AP 1 operates in normal mode and provides WLAN data services only.  

 AP 2 operates in monitor mode, and scans all 802.11g frames in the WLAN. 

 Client 1 (MAC address 000f-e215-1515), Client 2 (MAC address 000f-e215-1530), and Client 3 
(MAC address 000f-e213-1235) are connected to AP 1. They are configured as friends. 

 Client 4 (MAC address 000f-e220-405e) is connected to AP 2. It is configured as a rogue device. 

Figure 42-21 WLAN security configuration 

 
 

Configuration procedure 
1) Configure AP 1 to operate in normal mode 

In normal mode, AP 1 provides WLAN data services only. For how to configure WLAN services, refer to 
Wireless Service Configuration.  

2) Configure AP 2 to operate in monitor mode 

# Add an AP.  

Select AP > AP Setup in the navigation tree to enter the configuration page. Click Add to enter the AP 
setup page as shown in Figure 42-22. 
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Figure 42-22 AP configuration 

 

 

 Configure the AP name as wa2200. 

 Select WA2200X-AG for the model. 

 Select manual and type the serial ID of AP 2. 

 Click Apply. 

# Configure AP 2 to operate in monitor mode. 

Select Security > Rogue Detection from the navigation tree, and then select the AP Monitor tab to 
enter the AP monitor configuration page. Select the AP to be configured and click the  icon to enter 
the operating mode configuration page as shown in Figure 42-23. 

Figure 42-23 AP operating mode configuration 

 
 

 Select Monitor as the operating mode. 

 Click Apply. 

# Enable the 802.11g radio mode. 

Select Radio > Radio from the navigation tree to enter the AP radio configuration page, as shown in 
Figure 42-24. 

Figure 42-24 Radio configuration 

 
 

 Select the AP with the radio mode to be enabled (wa2200 with 802.11g in this example), and then 
select the check box before the AP name. 
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 Click Enable. 

3) Configure rogue detection rules. 

Select Security > Rogue Detection from the navigation tree, and then select the Rule List tab to enter 
the rule list configuration page. Then click Add.  

 Select MAC as the list type and type 000f-e215-1515, 000f-e215-1530, and 000f-e213-1235 in the 
MAC address text box. 

 Select Attacker as the list type and type 000f-e220-405e in the text box. 

 Click Apply. 

4) Enable countermeasures against the static rogue device. 

Select Security > Rogue Detection from the navigation tree, and then select the AP Monitor tab. On 
the page, click Common Set to enter the common configuration page, as shown in Figure 42-25. 

Figure 42-25 Countermeasures configuration 

 

 

 Select the Static Rogue Device check box. This is because the MAC address of Client 4 is added 
manually to the attacker list. 

 Click Apply.  

Configuration Guidelines 
 The radio must be disabled so that the AP operation mode can be changed. 

 If you configure more than one detection rule, you need to specify the rogue device types (AP, 
client, bridge, and ad hoc) and the rule matching order. For detailed information, refer to section 
"Configuring Detection Rules" on page 42-7. 

 The wireless service configuration is needed for an AP operating in hybrid mode The wireless 
service configuration is not needed for an AP in monitor mode.  
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43  Authorized IP 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

The authorized IP function is to associate the HTTP or Telnet service with an ACL to filter the requests of 
clients. Only clients that pass the ACL filtering can access the device.  

Configuring Authorized IP 

Before configuring authorized IP, you need to create and configure the ACL. For ACL configuration, 
refer to QoS Configuration.  

Select Security > Authorized IP from the navigation tree at the left side of the interface, and then 
select the Setup tab to enter the authorized IP configuration page, as shown in Figure 43-1. 
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Figure 43-1 Authorized IP configuration page 

 

 

Table 43-1 describes the authorized IP configuration items. 

Table 43-1 Authorized IP configuration items 

Item Description 

IPv4 ACL 
Select the IPv4 to be associated with the Telnet service.  
Available IPv4 ACLs are those configured on the page you enter by selecting 
QoS > ACL IPv4. 

Telnet 

IPv6 ACL 
Select the IPv6 to be associated with the Telnet service. 
Available IPv6 ACLs are those configured on the page you enter by selecting 
QoS > ACL IPv6. 

Web 
(HTTP) IPv4 ACL 

Select the IPv4 ACL to be associated with the HTTP service. 
Available IPv4 ACLs are those configured on the page you enter by selecting 
QoS > ACL IPv4. 
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44  User Isolation 

 

 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

User Isolation Overview 

Without user isolation, all the devices in the same VLAN can access each other directly, which brings 
forth security problems. User isolation can solve this problem. When an AC configured with user 
isolation receives unicast packets (broadcast packets and multicast packets in a VLAN are not isolated) 
from a wireless client to another wireless client or a wired PC in the same VLAN, or from a wired PC to 
a wireless client in the same VLAN, the AC determines whether to isolate the two devices according to 
the configured list of permitted MAC addresses. 

To avoid user isolation from affecting communications between users and the gateway, you can add the 
MAC address of the gateway to the list of permitted MAC addresses. 

User isolation both provides network services for users and isolates users, disabling them from 
communication at Layer-2 and thus ensuring service security. 

Before User Isolation Is Enabled 

As shown in Figure 44-1, before user isolation is enabled in VLAN 2 on the AC, wireless terminals Client 
A and Client B and wired terminal Host A in the VLAN can communicate with each other and access the 
Internet.  
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Figure 44-1 User communication 
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After User Isolation Is Enabled 

As shown in Figure 44-1, user isolation is enabled on the AC. Client A and Client B, and Host A in VLAN 
2 access the Internet through the gateway. 

 If you add the MAC address of the gateway to the permitted MAC address list, Client A, Client B, 
and Host A in the same VLAN are isolated, but they can access the Internet. 

 If you add the MAC address of a user (Client A, for example) to the permitted MAC address list, 
Client A and Client B, and Client A and Host A can access each other directly, but Client B and Host 
A cannot. 

To enable all the users in the VLAN to access one another and the Internet, you need to add the MAC 
address of the gateway and the MAC addresses of the users to the permitted MAC address list. 

Configuring User Isolation 

Configuration Procedure 

Select Security > User Isolation from the navigation tree, and click Add to enter the page for 
configuring user isolation as shown in Figure 44-2. 
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Figure 44-2 Configure user isolation 

 

 

Table 44-1 describes the user isolation configuration items. 

Table 44-1 User isolation configuration items 

Item Description 

VLAN ID Specify the VLAN in which user isolation is enabled. 

AccessMAC 

Specify the MAC addresses to be permitted by the AC. For more information, see After 
User Isolation Is Enabled. 

 Type a MAC address in the text box next to the Add button.  
 Click Add to add the MAC address to the permitted MAC list.  
 If you want to delete a MAC address from the list, select an entry and click Delete.

 
Broadcast or multicast MAC addresses cannot be specified as permitted MAC 
addresses. 

 

 

Up to 16 permitted MAC addresses can be configured for one VLAN. 

 

Displaying User Isolation Information 

Select Security > User Isolation from the navigation tree to enter the page displaying user isolation 
configuration summary, as shown in Figure 44-3. 
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Figure 44-3 Display user isolation summary 

 
 

User Isolation Configuration Example 

Network requirements 
As shown in Figure 44-4, it is required to isolate Client A, Client B, and Host A in VLAN 2 from one 
another while allowing them to access the Internet. The MAC address of the gateway is 
000f-e212-7788.  

Figure 44-4 Network diagram for configuring user isolation 
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Configuration procedure 
1) Configure wireless service 

For how to configure wireless service, see Wireless Service.  

2) Configure user isolation 
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Select Security > User Isolation from the navigation tree, and click Add to enter the page for 
configuring user isolation as shown in Figure 44-5. 

Figure 44-5 Configure user isolation 

 

 

 Type 2 as the VLAN ID. 

 Add MAC address 000f-e212-7788 to the permitted MAC address list.  

 Click Apply. 
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45  ACL Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. Refer to 
section "Feature Matrixes" in Compatibility Matrixes for details. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

ACL Overview 

With the growth of network scale and network traffic, network security and bandwidth allocation become 
more and more critical to network management. Packet filtering can be used to efficiently prevent illegal 
access to networks and to control network traffic and save network resources. One way to implement 
packet filtering is to use access control lists (ACLs). 

An ACL is a set of rules (or a set of permit or deny statements) for determining which packets can pass 
and which ones should be rejected based on matching criteria such as source address, destination 
address, and port number. ACLs are widely used with technologies such as firewall and QoS, where 
traffic identification is desired. 

Introduction to IPv4 ACL 

IPv4 ACL Classification 
IPv4 ACLs, identified by ACL numbers, fall into three categories, as shown in Table 45-1. 

Table 45-1 IPv4 ACL categories 

Category ACL number Matching criteria 

Basic IPv4 ACL 2000 to 2999 Source IP address 

Advanced IPv4 ACL 3000 to 3999 
Source IP address, destination IP address, 
protocol carried over IP, and other Layer 3 or 
Layer 4 protocol header information 

Ethernet frame header ACL 4000 to 4999 
Layer 2 protocol header fields such as source 
MAC address, destination MAC address, 802.1p 
priority, and link layer protocol type 
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IPv4 ACL Match Order 
An ACL may consist of multiple rules, which specify different matching criteria. These criteria may have 
overlapping or conflicting parts. The match order is for determining how packets should be matched 
against the rules. 

There are two types of IPv4 ACL match orders: 

 config: Packets are compared against ACL rules in the order that the rules are configured. 

 auto: Packets are compared against ACL rules in the depth-first match order. 

The term depth-first match has different meanings for different types of IPv4 ACLs, as shown in Table 
45-2. 

Table 45-2 Depth-first match for IPv4 ACLs 

IPv4 ACL category Depth-first match procedure 

Basic IPv4 ACL 
1) Sort rules by source IP address wildcard and compare packets against 

the rule configured with more zeros in the source IP address wildcard. 
2) In case of a tie, compare packets against the rule configured first. 

Advanced IPv4 ACL 

1) Sort rules by VPN instance first and compare packets against the rule 
configured with a VPN instance. 

2) In case of a tie, look at the protocol carried over IP. A rule with no limit to 
the protocol type (that is, configured with the ip keyword) has the lowest 
precedence. Rules each of which has a single specified protocol type are 
of the same precedence level. 

3) If the protocol types have the same precedence, look at the source IP 
address wildcards. Then, compare packets against the rule configured 
with more zeros in the source IP address wildcard. 

4) If the numbers of zeros in the source IP address wildcards are the same, 
look at the destination IP address wildcards. Then, compare packets 
against the rule configured with more zeros in the destination IP address 
wildcard. 

5) If the numbers of zeros in the destination IP address wildcards are the 
same, look at the Layer 4 port number ranges, namely the TCP/UDP port 
number ranges. Then compare packets against the rule configured with 
the smaller port number range. 

6) If the port number ranges are the same, compare packets against the rule 
configured first. 

Ethernet frame header ACL 

1) Sort rules by source MAC address mask first and compare packets 
against the rule configured with more ones in the source MAC address 
mask. 

2) If two rules are present with the same number of ones in their source MAC 
address masks, look at the destination MAC address masks. Then, 
compare packets against the rule configured with more ones in the 
destination MAC address mask. 

3) If the numbers of ones in the destination MAC address masks are the 
same, compare packets against the one configured first. 

 

The comparison of a packet against ACL rules stops immediately after a match is found. The packet is 
then processed as per the rule. 

Fragments Filtering with IPv4 ACL 
Traditional packet filtering performs match operation on only the first fragments. All subsequent non-first 
fragments are handled in the way the first fragments are handled. As attackers may fabricate non-first 
fragments to attack your network, this results in security risks. 

To address the risks, the device implements the following packet filtering functions: 

 IP-based filtering on all fragments. 
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 Standard match and exact match of ACLs containing advanced information such as TCP/UDP port 
number and ICMP type. The default is standard match. 

 

 

 Standard match considers only Layer 3 information. 

 Exact match considers all header information defined in ACL rules. 

These two ACL rule matching approaches are available only on firewalls. 

 

Introduction to IPv6 ACL 

 

 

Support of the H3C WX series access controllers for IPv6 ACL may vary by device model. Refer to 
section "Feature Matrixes" in Compatibility Matrixes for details. 

 

IPv6 ACL categories 
IPv6 ACLs, identified by ACL numbers, fall into two categories, as shown in Table 45-3. 

Table 45-3 IPv6 ACL categories 

Category ACL number Matching criteria 

Basic IPv6 ACL 2000 to 2999 Source IPv6 address 

Advanced IPv6 ACL 3000 to 3999 
Source IPv6 address, destination IPv6 address, 
protocol carried over IPv6, and other Layer 3 or 
Layer 4 protocol header information 

 

IPv6 ACL Match Order 
An ACL may consist of multiple rules, which specify different matching criteria. These criteria may have 
overlapping or conflicting parts. The match order is for determining how packets should be matched 
against the rules. 

There are two types of IPv6 ACL match orders: 

 config: Packets are compared against ACL rules in the order the rules are configured. 

 auto: Packets are compared against ACL rules in the depth-first match order. 

The term depth-first match has different meanings for different types of IPv6 ACLs, as shown in Table 
45-4. 
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Table 45-4 Depth-first match for IPv6 ACLs 

IPv6 ACL Category Depth-first match procedure 

Basic IPv6 ACL 
1) Sort rules by source IPv6 address prefix first and compare packets against the 

rule configured with a longer prefix for the source IPv6 address. 
2) In case of a tie, compare packets against the rule configured first. 

Advanced IPv6 ACL 

1) Look at the protocol type field in the rules first. A rule with no limit to the protocol 
type (that is, configured with the ipv6 keyword) has the lowest precedence. Rules 
each of which has a single specified protocol type are of the same precedence 
level. Compare packets against the rule with the highest precedence. 

2) In case of a tie, look at the source IPv6 address prefixes. Then, compare packets 
against the rule configured with a longer prefix for the source IPv6 address. 

3) If the prefix lengths for the source IPv6 addresses are the same, look at the 
destination IPv6 address prefixes. Then, compare packets against the rule 
configured with a longer prefix for the destination IPv6 address.  

4) If the prefix lengths for the destination IPv6 addresses are the same, look at the 
Layer 4 port number ranges, namely the TCP/UDP port number ranges. Then 
compare packets against the rule configured with the smaller port number range.

5) If the port number ranges are the same, compare packets against the rule 
configured first. 

 

The comparison of a packet against ACL rules stops immediately after a match is found. The packet is 
then processed as per the rule. 

Effective Period of an ACL 

You can control when a rule can take effect by referencing a time range in the rule. 

A referenced time range can be one that has not been created yet. The rule, however, can take effect 
only after the time range is defined and becomes active. 

ACL Step 

 

 

Currently, the Web interface does not support ACL step configuration. 

 

Meaning of the step 
The step defines the difference between two neighboring numbers that are automatically assigned to 
ACL rules by the device. For example, with a step of 5, rules are automatically numbered 0, 5, 10, 15, 
and so on. By default, the step is 5. 

Whenever the step changes, the rules are renumbered, starting from 0. For example, if four rules are 
numbered 0, 5, 10, and 15 respectively, changing the step from 5 to 2 will cause the rules to be 
renumbered 0, 2, 4, and 6. 

Benefits of using the step 
With the step and rule numbering/renumbering mechanism, you do not need to assign numbers to rules 
when defining them. The system will assign a newly defined rule a number that is the smallest multiple 
of the step bigger than the current biggest number. For example, with a step of five, if the biggest 
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number is currently 28, the newly defined rule will get a number of 30. If the ACL has no rule defined 
already, the first defined rule will get a number of 0. 

Another benefit of using the step is that it allows you to insert new rules between existing ones as 
needed. For example, after creating four rules numbered 0, 5, 10, and 15 in an ACL with a step of five, 
you can insert a rule numbered 1. 

Configuring an ACL 

Configuration Task List 

Configuring an IPv4 ACL 
Table 45-5 lists the IPv4 ACL configuration tasks. 

Table 45-5 IPv4 ACL configuration task list 

Task Remarks 

Configuring a Time Range 
Optional 
A rule referencing a time range takes effect only 
during the specified time range. 

Creating an IPv4 ACL 
Required 
The category of the created ACL depends on the ACL 
number that you specify. 

Configuring a Rule for a Basic IPv4 ACL 

Configuring a Rule for an Advanced IPv4 ACL 

Configuring a Rule for an Ethernet Frame Header ACL

Required 
Complete one of the three tasks according to the ACL 
category. 

 

Configuring an IPv6 ACL 
Table 45-6 lists the IPv6 ACL configuration tasks. 

Table 45-6 IPv6 ACL configuration task list 

Task Remarks 

Configuring a Time Range 
Optional 
A rule referencing a time range takes effect only during the 
specified time range. 

Creating an IPv6 ACL 
Required 
The category of the created IPv6 ACL depends on the ACL 
number that you specify. 

Configuring a Rule for a Basic IPv6 ACL 

Configuring a Rule for an Advanced IPv6 ACL 

Required 
Complete one of the tasks according to the ACL category. 

 

Configuring a Time Range 

Select QoS > Time Range from the navigation tree and then select the Create tab to enter the time 
range configuration page, as shown in Figure 45-1.  
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Figure 45-1 The page for creating a time range 

 

 

Table 45-7 describes the configuration items for creating a time range. 

Table 45-7 Time range configuration items 

Item Description 

Time Range Name Set the name for the time range. 

Start Time Set the start time of the periodic time range. 

End Time Set the end time of the periodic time range. The end time must be 
greater than the start time. Periodic 

Time 
Range Sun, Mon, 

Tue, Wed, 
Thu, Fri, 
and Sat. 

Select the day or days of the week on which the periodic time 
range is valid. You can select any combination of the days of the 
week. 

These items are 
available after 
you select the 
Periodic Time 
Range check 
box. 

From 
Set the start time of the absolute time range. The time of the day 
is in the hh:mm format (24-hour clock), and the date is in the 
MM/DD/YYYY format. Absolute 

Time 
Range 

To 

Set the end time of the absolute time range. The time of the day 
is in the hh:mm format (24-hour clock), and the date is in the 
MM/DD/YYYY format. The end time must be greater than the 
start time. 

These items are 
available after 
you select the 
Absolute Time 
Range check 
box. 

 

Return to IPv4 ACL configuration task list. 

Return to IPv6 ACL configuration task list. 
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Creating an IPv4 ACL 

Select QoS > ACL IPv4 from the navigation tree and then select the Create tab to enter the IPv4 ACL 
configuration page, as shown in Figure 45-2.  

Figure 45-2 The page for creating an IPv4 ACL 

 
 

Table 45-8 describes the configuration items for creating an IPv4 ACL. 

Table 45-8 IPv4 ACL configuration items 

Item Description 

ACL Number Set the number of the IPv4 ACL. 

Match Order 

Set the match order of the ACL. Available values are: 
 Config: Packets are compared against ACL rules in the order that the rules are 

configured. 
 Auto: Packets are compared against ACL rules in the depth-first match order. 

 

Return to IPv4 ACL configuration task list. 

Configuring a Rule for a Basic IPv4 ACL 

Select QoS > ACL IPv4 from the navigation tree and then select the Basic Setup tab to enter the rule 
configuration page for a basic IPv4 ACL, as shown in Figure 45-3. 
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Figure 45-3 The page for configuring an basic IPv4 ACL 

 
 

Table 45-9 describes the configuration items for creating a rule for a basic IPv4 ACL. 

Table 45-9 Configuration items for a basic IPv4 ACL rule 

Item Description 

ACL 
Select the basic IPv4 ACL for which you want to configure rules. 
Available ACLs are basic IPv4 ACLs that have been configured. 

Rule ID 
Select the Rule ID check box and type a number for the rule. 
If you do not specify the rule number, the system will assign one automatically. 

Action 
Select the action to be performed for IPv4 packets matching the rule. 

 Permit: Allows matched packets to pass. 
 Deny: Drops matched packets. 

Check Fragment 
Select this check box to apply the rule to only non-first fragments. 
If you do no select this check box, the rule applies to all fragments and 
non-fragments. 

Check Logging 

Select this check box to keep a log of matched IPv4 packets. 
A log entry contains the ACL rule number, operation for the matched packets, 
protocol that IP carries, source/destination address, source/destination port number, 
and number of matched packets. 

Source IP Address 

Source Wildcard 
Select the Source IP Address check box and type a source IPv4 address and 
source wildcard, in dotted decimal notation.  

Time Range 
Select the time range during which the rule takes effect. 
Available time ranges are those that have been configured. 
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Return to IPv4 ACL configuration task list. 

Configuring a Rule for an Advanced IPv4 ACL 

Select QoS > ACL IPv4 from the navigation tree and then select the Advance Setup tab to enter the 
rule configuration page for an advanced IPv4 ACL, as shown in Figure 45-4.  

Figure 45-4 The page for configuring an advanced IPv4 ACL 

 

 

Table 45-10 describes the configuration items for creating a rule for an advanced IPv4 ACL. 
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Table 45-10 Configuration items for an advanced IPv4 ACL rule 

Item Description 

ACL 

Select the advanced IPv4 ACL for which you want to configure 
rules. 
Available ACLs are advanced IPv4 ACLs that have been 
configured. 

Rule ID 
Select the Rule ID check box and type a number for the rule. 
If you do not specify the rule number, the system will assign 
one automatically. 

Action 

Select the action to be performed for IPv4 packets matching 
the rule. 

 Permit: Allows matched packets to pass. 
 Deny: Drops matched packets. 

Non-First Fragments Only 

Select this check box to apply the rule to only non-first 
fragments. 
If you do no select this check box, the rule applies to all 
fragments and non-fragments. 

Logging 

Select this check box to keep a log of matched IPv4 packets. 
A log entry contains the ACL rule number, operation for the 
matched packets, protocol that IP carries, source/destination 
address, source/destination port number, and number of 
matched packets. 

Source IP Address 

Source Wildcard 
Select the Source IP Address check box and type a source 
IPv4 address and source wildcard, in dotted decimal notation.

Destination IP Address 
IP Address 
Filter 

Destination Wildcard 
Select the Source IP Address check box and type a source IP 
address and source wildcard, in dotted decimal notation. 

Protocol 

Select the protocol to be carried by IP. 
If you select 1 ICMP, you can configure the ICMP message 
type and code; if you select 6 TCP or 17 UDP, you can 
configure the TCP or UDP specific items. 

ICMP Message 

ICMP Type 
ICMP Type 

ICMP Code 

Specify the ICMP message type and code. 
These items are available only when you select 1 ICMP from 
the Protocol drop-down box. 
If you select Other from the ICMP Message drop-down box, 
you need to type values in the ICMP Type and ICMP Code 
fields. Otherwise, the two fields will take the default values, 
which cannot be changed. 
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Item Description 

TCP Connection 
Established 

Select this check box to make the rule match packets used for 
establishing and maintaining TCP connections. 
These items are available only when you select 6 TCP from the 
Protocol drop-down box. 
On a device, a rule with this item configured matches TCP 
connection packets with the ACK or RST flag. 

Operator

Port Source 

- 

Operator

Port 

TCP/UDP Port 

Destination 

- 

Select the operators and type the source port numbers and 
destination port numbers as required. 
These items are available only when you select 6 TCP or 17 
UDP from the Protocol drop-down box. 
Different operators have different configuration requirements 
for the port number fields: 

 Not Check: The following port number fields cannot be 
configured. 

 Range: The following port number fields must be 
configured to define a port range. 

 Other values: The first port number field must be configured 
and the second must not. 

DSCP Specify the DSCP priority. 

TOS Specify the ToS preference. Precedence 
Filter 

Precedence Specify the IP precedence. 

Time Range 
Select the time range during which the rule takes effect. 
Available time ranges are those that have been configured. 

 

Return to IPv4 ACL configuration task list. 

Configuring a Rule for an Ethernet Frame Header ACL 

Select QoS > ACL IPv4 from the navigation tree and then select the Link Setup tab to enter the rule 
configuration page for an Ethernet frame header IPv4 ACL, as shown in Figure 45-5. 
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Figure 45-5 The page for configuring a rule for an Ethernet frame header ACL 

 

 

Table 45-11 describes the configuration items for creating a rule for an Ethernet frame header IPv4 
ACL. 

Table 45-11 Configuration items for an Ethernet frame header IPv4 ACL rule 

Item Description 

ACL 

Select the Ethernet frame header IPv4 ACL for which you want to 
configure rules. 
Available ACLs are Ethernet frame header IPv4 ACLs that have been 
configured. 

Rule ID 
Select the Rule ID check box and type a number for the rule. 
If you do not specify the rule number, the system will assign one 
automatically. 

Action 
Select the action to be performed for IPv4 packets matching the rule. 

 Permit: Allows matched packets to pass. 
 Deny: Drops matched packets. 

Source MAC Address 

Source Mask 
Select the Source MAC Address check box and type a source MAC 
address and wildcard. 

Destination MAC 
Address 

MAC 
Address 
Filter 

Destination Mask 

Select the Destination MAC Address check box and type a 
destination MAC address and wildcard. 

COS(802.1p priority) Specify the 802.1p priority for the rule. 
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Item Description 

LSAP Type 

LSAP Mask 

Select the LSAP Type check box and specify the DSAP and SSAP 
fields in the LLC encapsulation by configuring the following two items:

 LSAP Type: Indicates the frame encapsulation format. 
 LSAP Mask: Indicates the LSAP wildcard. 

Protocol Type 
Type Filter 

Protocol Mask 

Select the Protocol Type check box and specify the link layer protocol 
type by configuring the following two items: 

 Protocol Type: Indicates the frame type. It corresponds to the 
type-code field of Ethernet_II and Ethernet_SNAP frames. 

 Protocol Mask: Indicates the wildcard. 

Time Range 
Select the time range during which the rule takes effect. 
Available time ranges are those that have been configured. 

 

Return to IPv4 ACL configuration task list. 

Creating an IPv6 ACL 

Select QoS > ACL IPv6 from the navigation tree and then select the Create tab to enter the IPv6 ACL 
configuration page, as shown in Figure 45-6.  

Figure 45-6 The page for creating an IPv6 ACL 

 

 

Table 45-12 describes the configuration items for creating an IPv6 ACL. 

Table 45-12 IPv6 ACL configuration items 

Item Description 

ACL Number Type a number for the IPv6 ACL. 

Match Order 

Select a match order for the ACL. Available values are: 
 Config: Packets are compared against ACL rules in the order the rules are 

configured. 
 Auto: Packets are compared against ACL rules in the depth-first match order. 

 

Return to IPv6 ACL configuration task list. 
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Configuring a Rule for a Basic IPv6 ACL 

Select QoS > ACL IPv6 from the navigation tree and then select the Basic Setup tab to enter the rule 
configuration page for a basic IPv6 ACL, as shown in Figure 45-7. 

Figure 45-7 The page for configuring a rule for a basic IPv6 ACL 

 
 

Table 45-13 describes the configuration items for creating a rule for a basic IPv6 ACL. 

Table 45-13 Configuration items for a basic IPv6 ACL rule 

Item Description 

Select Access Control List 
(ACL) 

Select the basic IPv6 ACL for which you want to configure rules. 
Available ACLs are basic IPv6 ACLs that have been configured. 

Rule ID 
Select the Rule ID check box and type a number for the rule. 
If you do not specify the rule number, the system will assign one automatically.

Operation 
Select the operation to be performed for IPv6 packets matching the rule. 

 Permit: Allows matched packets to pass. 
 Deny: Drops matched packets. 

Check Fragment 
Select this check box to apply the rule to only non-first fragments. 
If you do no select this check box, the rule applies to all fragments and 
non-fragments. 

Check Logging 

Select this check box to keep a log of matched IPv6 packets. 
A log entry contains the ACL rule number, operation for the matched packets, 
protocol that IP carries, source/destination address, source/destination port 
number, and number of matched packets. 
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Item Description 

Source IP Address 

Source Prefix 

Select the Source IP Address check box and type a source IPv6 address and 
prefix length. 
The IPv6 address must be in a format like X:X::X:X. An IPv6 address consists 
of eight 16-bit long fields, each of which is expressed with two hexadecimal 
numbers and separated from its neighboring fields by colon (:). 

Time Range 
Select the time range during which the rule takes effect. 
Available time ranges are those that have been configured. 

 

Return to IPv6 ACL configuration task list. 

Configuring a Rule for an Advanced IPv6 ACL 

Select QoS > ACL IPv6 from the navigation tree and then select the Advance Setup tab to enter the 
rule configuration page for an advanced IPv6 ACL, as shown in Figure 45-8. 

Figure 45-8 The page for configuring a rule for an advanced IPv6 ACL 
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Table 45-14 describes the configuration items for creating a rule for an advanced IPv6 ACL. 

Table 45-14 Configuration items for an advanced IPv6 ACL rule 

Item Description 

Select Access Control List (ACL) 
Select the advanced IPv6 ACL for which you want to configure rules. 
Available ACLs are advanced IPv6 ACLs that have been configured. 

Rule ID 
Select the Rule ID check box and type a number for the rule. 
If you do not specify the rule number, the system will assign one 
automatically. 

Operation 

Select the operation to be performed for IPv6 packets matching the 
rule. 

 Permit: Allows matched packets to pass. 
 Deny: Drops matched packets. 

Check Fragment 
Select this check box to apply the rule to only non-first fragments. 
If you do no select this check box, the rule applies to all fragments and 
non-fragments. 

Check Logging 

Select this check box to keep a log of matched IPv6 packets. 
A log entry contains the ACL rule number, operation for the matched 
packets, protocol that IP carries, source/destination address, 
source/destination port number, and number of matched packets. 

Source IP Address 

Source Prefix 

Select the Source IP Address check box and type a source IPv6 
address and prefix length. 
The IPv6 address must be in a format like X:X::X:X. An IPv6 address 
consists of eight 16-bit long fields, each of which is expressed with two 
hexadecimal numbers and separated from its neighboring fields by 
colon (:). 

Destination IP Address 

IP 
Address 
Filter 

Destination Prefix 

Select the Destination IP Address check box and type a destination 
IPv6 address and prefix length. 
The IPv6 address must be in a format like X:X::X:X. An IPv6 address 
consists of eight 16-bit long fields, each of which is expressed with two 
hexadecimal numbers and separated from its neighboring fields by 
colon (:). 

Protocol 

Select the protocol to be carried by IP. 
If you select 58 ICMPv6, you can configure the ICMP message type 
and code; if you select 6 TCP or 17 UDP, you can configure the TCP or 
UDP specific items. 

Named ICMPv6 Type 

ICMPv6 Type ICMPv6 
Type 

ICMPv6 Code 

Specify the ICMPv6 message type and code. 
These items are available only when you select 58 ICMPv6 from the 
Protocol drop-down box. 
If you select Other from the Named ICMPv6 Type drop-down box, you 
need to type values in the ICMPv6 Type and ICMPv6 Code fields. 
Otherwise, the two fields will take the default values, which cannot be 
changed. 

Operator 

Port Source 

To Port 

Operator 

Port 

TCP/UDP 
Port 

Destination 

Port 

Select the operators and type the source port numbers and destination 
port numbers as required. 
These items are available only when you select 6 TCP or 17 UDP from 
the Protocol drop-down box. 
Different operators have different configuration requirements for the 
port number fields: 

 Not Check: The following port number fields cannot be configured.
 Range: The following port number fields must be configured to 

define a port range. 
 Other values: The first port number field must be configured and 

the second must not. 
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Item Description 

Time Range 
Select the time range during which the rule takes effect. 
Available time ranges are those that have been configured. 

 

Return to IPv6 ACL configuration task list. 

Configuration Guidelines 

When configuring an ACL, note that: 

1) When defining rules in an ACL, you do not necessarily assign them numbers; the system can do 
this automatically. Refer to ACL Step. 

2) You cannot create a rule with, or modify a rule to have, the same permit/deny statement as an 
existing rule in the ACL. 

3) You can only modify the existing rules of an ACL that uses the match order of config. When 
modifying a rule of such an ACL, you may choose to change just some of the settings, in which 
case the other settings remain the same. 
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46  QoS Configuration 

 

 

 Support of the H3C WX series access controllers for line rate may vary by device model. Refer to 
section "Feature Matrixes" in Compatibility Matrixes for details. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

QoS Overview 

In data communications, Quality of Service (QoS) is the ability of a network to provide differentiated 
service guarantees for diversified traffic regarding bandwidth, delay, jitter, and drop rate.  

Network resources are always scarce. Wherever there is contention for resources, there is a demand 
for QoS to prioritize important traffic flows over trivial traffic flows. When making a QoS scheme, a 
network administrator must plan network resources carefully considering the characteristics of various 
applications to balance the interests of diversified users and fully utilize network resources.  

The following part introduces the QoS service models, and some mature QoS techniques in wide use. 
Appropriately using these techniques in specific environments, you can improve QoS effectively.  

Traditional packet forwarding services 
On traditional IP networks, devices treat all packets equally and handle them using the first in first out 
(FIFO) policy. All packets share the resources of the network and devices. How many resources the 
packets can obtain completely depends on the time they arrive. This service is called best-effort. It 
delivers packets to their destinations as possibly as it can, without any guarantee for delay, jitter, packet 
loss ratio, reliability and so on.  

This service policy is only suitable for applications insensitive to bandwidth and delay, such as WWW, 
file transfer and e-mail.  

New requirements from emerging applications 
The Internet has been growing along with the fast development of networking technologies. More and 
more users take the Internet as their data transmission platform to implement various applications.  

Besides traditional applications such as WWW, e-mail and FTP, network users are experiencing new 
services, such as tele-education, telemedicine, video telephone, videoconference and 
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Video-on-Demand (VoD). The enterprise users expect to connect their regional branches together 
through VPN technologies to carry out operational applications, for instance, to access the database of 
the company or to monitor remote devices through Telnet.  

These new applications have one thing in common, that is, they all have special requirements for 
bandwidth, delay, and jitter. For instance, videoconference and VoD need large bandwidth, low delay 
and jitter. As for mission-critical applications, such as transactions and Telnet, they may not require 
large bandwidth but do require low delay and preferential service during congestion.  

The new emerging applications demand higher service performance of IP networks. Better network 
services during packets forwarding are required, such as providing dedicated bandwidth, reducing 
packet loss ratio, managing and avoiding congestion, regulating network traffic, and setting the 
precedence of packets. To meet these requirements, networks must provide more improved services.  

Congestion 

Congestion occurs on a link or node when traffic size is so large that the processing capability of the link 
or node is exceeded. It results in extra delay and even packet drop.  

Causes 
Congestion is typical of a statistical multiplexing network and can be caused by link failure, insufficient 
resources, and various other causes. The following figure shows two common congestion scenarios: 

Figure 46-1 Traffic congestion causes 

 

 

 The traffic enters a device from a high speed link and is forwarded over a low speed link; 

 The packet flows enter a device from several interfaces with the same speed and are forwarded 
through an interface with the same speed as well.  

When traffic arrives at the line speed, congestion may occur due to the network resource bottleneck.  

Besides the link bandwidth bottleneck, congestion can also be caused by resource shortage, such as 
insufficient processor time, buffer, and memory. In addition, congestion may occur if the arriving traffic is 
not managed efficiently, thus resulting in inadequate network resources.  

Impacts 
Congestion may bring these negative results: 

 Increased delay and jitter during packet transmission  

 Decreased network throughput and resource use efficiency 

 Network resource (memory in particular) exhaustion and even system breakdown 

Congestion is unavoidable in switched networks or multi-user application environments. To improve the 
service performance of your network, you must take measures to manage and control it.  

One major issue that congestion management deals with is how to define a resource dispatching policy 
to prioritize packets for forwarding when congestion occurs.  
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Countermeasures 
A simple solution for congestion is to increase network bandwidth. However, it cannot solve all the 
problems that cause congestion.  

A more effective solution is to provide differentiated services for different applications through traffic 
control and resource allocation. In this way, resources can be used more properly. During resources 
allocation and traffic control, the direct or indirect factors that might cause network congestion should be 
controlled to reduce the probability of congestion. Once congestion occurs, resource allocation should 
be performed according to the characteristics and demands of applications to minimize the effects of 
congestion on QoS.  

CBQ 

In general, congestion management adopts queuing technology. The system uses a certain queuing 
algorithm for traffic classification, and then uses a certain precedence algorithm to send the traffic. Each 
queuing algorithm is used to handle a particular network traffic problem and has significant impacts on 
bandwidth resource assignment, delay, and jitter.  

Class-based queuing (CBQ) assigns an independent reserved FIFO queue for each user-defined class 
to buffer data of the class. In the case of network congestion, CBQ assigns packets to queues by 
user-defined traffic classification rules. It is necessary to perform the congestion avoidance mechanism 
(tail drop or weighted random early detection (WRED)) and bandwidth restriction check before packets 
are enqueued. When being dequeued, packets are scheduled by WFQ.  

CBQ provides an emergency queue to enqueue emergent packets. The emergency queue is a FIFO 
queue without bandwidth restriction. However, delay sensitive flows like voice packets may not be 
transmitted timely in CBQ since packets are fairly treated. To solve this issue, Low Latency Queuing 
(LLQ) was introduced to combine PQ (Priority Queuing) and CBQ to transmit delay sensitive flows like 
voice packets preferentially.  

When defining traffic classes for LLQ, you can configure a class of packets to be transmitted 
preferentially. Such a class is called a priority class. The packets of all priority classes are assigned to 
the same priority queue. It is necessary to check bandwidth restriction of each class of packets before 
the packets are enqueued. During the dequeuing operation, packets in the priority queue are 
transmitted first. WFQ is used to dequeue packets in the other queues.  

In order to reduce the delay of the other queues except the priority queue, LLQ assigns the maximum 
available bandwidth for each priority class. The bandwidth value is used to police traffic in the case of 
congestion. In the case of no congestion, a priority class can use more than the bandwidth assigned to 
it. In the case of congestion, the packets of each priority class exceeding the assigned bandwidth are 
discarded. LLQ can also specify burst-size. 

The system matches packets with classification rules in the following order: 

 Match packets with priority classes and then the other classes. 

 Match packets with priority classes in the order configured. 

 Match packets with other classes in the order configured. 

 Match packets with classification rules in a class in the order configured. 
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Line Rate 

Line rate is a traffic control method using token buckets. The line rate of a physical interface specifies 
the maximum rate for forwarding packets (including critical packets). Line rate can limit all the packets 
passing a physical interface.  

Traffic evaluation and token bucket 
A token bucket can be considered as a container holding a certain number of tokens. The system puts 
tokens into the bucket at a set rate. When the token bucket is full, the extra tokens will overflow.  

Figure 46-2 Evaluate traffic with the token bucket 

 

 

The evaluation for the traffic specification is based on whether the number of tokens in the bucket can 
meet the need of packet forwarding. If the number of tokens in the bucket is enough to forward the 
packets (generally, one token is associated with a 1-bit forwarding authority), the traffic conforms to the 
specification, and the traffic is called conforming traffic; otherwise, the traffic does not conform to the 
specification, and the traffic is called excess traffic.  

A token bucket has the following configurable parameters: 

 Mean rate: At which tokens are put into the bucket, namely, the permitted average rate of traffic. It 
is usually set to the committed information rate (CIR). 

 Burst size: the capacity of the token bucket, namely, the maximum traffic size that is permitted in 
each burst. It is usually set to the committed burst size (CBS). The set burst size must be greater 
than the maximum packet size.  

One evaluation is performed on each arriving packet. In each evaluation, if the number of tokens in the 
bucket is enough, the traffic conforms to the specification and the corresponding tokens for forwarding 
the packet are taken away; if the number of tokens in the bucket is not enough, it means that too many 
tokens have been used and the traffic is excessive.  

The working mechanism of line rate 
With line rate configured on an interface, all packets to be sent through the interface are firstly handled 
by the token bucket of line rate. If there are enough tokens in the token bucket, packets can be 
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forwarded; otherwise, packets are put into QoS queues for congestion management. In this way, the 
traffic passing the physical interface is controlled.  

Figure 46-3 Line rate implementation 
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With a token bucket used for traffic control, when there are tokens in the token bucket, the bursty 
packets can be transmitted; if no tokens are available, packets cannot be transmitted until new tokens 
are generated in the token bucket. In this way, the traffic rate is restricted to the rate for generating 
tokens, thus limiting traffic rate and allowing bursty traffic.  

Priority Mapping 

When a packet enters a device, the device assigns a set of QoS priority parameters to the packet and 
sometimes may modify its priority, according to certain rules depending on device status. This process 
is called priority mapping. The set of QoS priority parameters decides the scheduling priority and 
forwarding priority of the packet.  

The device provides various types of priority mapping tables, or rather, priority mappings. By looking up 
a priority mapping table, the device decides which priority value is to assign to a packet for subsequent 
packet processing.  

Configuring QoS 

QoS Configuration Task List 

Configuring line rate 
Perform the task in Table 46-1 to configure line rate: 

Table 46-1 Line rate configuration task list 

Task Remarks 

Configuring Line Rate 
Required 
Limit the rate of incoming packets or outgoing packets of a physical port. 

 

Configuring priority mapping 
You can configure priority mapping in two approaches:  
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 Configuring priority trust mode. In this approach, you can configure a port to look up the priority 
mapping tables based on a certain priority such as 802.1p carried in incoming packets. If a packet 
does not carry the trusted priority field or if no packet priority is trusted, the port priority of the 
incoming port is used.  

 Changing port priority. By default, all ports are assigned the port priority of zero. By changing the 
port priority of a port, you can change the priority of the incoming packets on the port.  

Perform the task in Table 46-2 to configure priority mapping: 

Table 46-2 Priority mapping configuration task list 

Task Remarks 

Configuring Priority Trust Mode for Ports in bulk 

Changing port priority and priority trust mode for ports individually. 

Required 
Use either approach.  

 

Configuring a QoS policy 
A QoS policy defines what QoS actions to take on what class of traffic for purposes such as traffic 
shaping or traffic policing. Before configuring a QoS policy, be familiar with these concepts: class, traffic 
behavior, and policy.  

1) Class 

Classes are used to identify traffic.  

A class contains some match criteria for identifying traffic. The operator between the criteria can be 
AND or OR.  

 AND: A packet is considered belonging to a class only when the packet matches all the criteria in 
the class.  

 OR: A packet is considered belonging to a class if it matches any of the criteria in the class.   

2) Traffic behavior 

A traffic behavior defines a set of QoS actions for packets.  

3) Policy 

A policy associates a class with a traffic behavior to define what actions to take on which class of traffic.  

You can define multiple class-to-traffic behavior associations in a policy.  

You can apply a policy to a port to regulate traffic sent or received on the port. A QoS policy can be 
applied to multiple ports, but in one direction (inbound or outbound) of a port, only one QoS policy can 
be applied.  

Perform the tasks in Table 46-3 to configure a QoS policy: 

Table 46-3 QoS policy configuration task list 

Task Remarks 

Creating a Class 
Required 
Create a class and specify the logical relationship 
between match criteria of the class.  Configure a 

class 

Configuring Classification Rules 
Required 
Configure match criteria for the class.  
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Task Remarks 

Creating a Traffic Behavior 
Required 
Create a traffic behavior.  Configure the 

traffic behavior 
Configuring Actions in a Traffic 
Behavior 

Use either approach 
Configure various actions for the traffic behavior.  

Creating a Policy 
Required 
Create a policy.  

Configure the 
policy 

Configuring Classifier-Behavior 
Associations for the Policy 

Required 
Associate a traffic behavior with a class in the QoS 
policy.  
A class can be associated with only one traffic behavior 
in a QoS policy. If a class is associated with multiple 
traffic behaviors, the last associated one takes effect.  

Applying a Policy to a Port 
Apply the 
policy Applying a QoS policy to a WLAN 

Service 

Use either approach 
Apply the QoS policy to a port or WLAN service.  

 

Configuring Line Rate 

Select QoS > Line rate from the navigation tree and click the Setup tab to enter the line rate 
configuration page, as shown in Figure 46-4.  
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Figure 46-4 The page for configuring line rate on a port 

 

 

Table 46-4 describes the configuration items for configuring line rate on a port.  

Table 46-4 Configuration items for configuring line rate on a port 

Item Description 

Please select an interface type 
Select the types of interfaces to be configured with line rate.  
The interface types available for selection depend on your device model.  

Rate Limit 
Enable or disable line rate on the specified port. 

 Enable: Enables line rate on all selected ports.  
 Disable: Disables line rate on all selected ports.  

Direction Outbound: Limits the rate of packets sent by the specified port.  

CIR Set the committed information rate (CIR), the average traffic rate.  

CBS Set the committed burst size (CBS), number of bits that can be sent in each 
interval.  

EBS 
Set the excess burst size (EBS). 
EBS is available when the CBS option is selected.  

Please select port(s) 
Specify the ports to be configured with line rate 
Click the ports to be configured with line rate in the port list. You can select 
one or more ports.  
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Return to Line rate configuration task list. 

Configuring Priority Mapping 

You can configure priority mapping in two approaches:  

 Configuring Priority Trust Mode for Ports in bulk. In this approach, you can configure multiple ports 
to look up the priority mapping tables based on a certain priority such as 802.1p carried in incoming 
packets. If no packet priority is trusted, the port priority of the incoming port is used.  

 Changing port priority and priority trust mode for ports individually. By default, all ports are 
assigned the port priority of zero. By changing the port priority of a port, you can change the priority 
of the incoming packets on the port.  

Configuring Priority Trust Mode for Ports in bulk 
Select QoS > Trust Mode from the navigation tree to enter the priority trust mode configuration page, 
as shown in Figure 46-5. 

Figure 46-5 The page for configuring priority trust mode 

 

 

Table 46-5 describes the priority trust mode configuration items.  
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Table 46-5 Priority trust mode configuration items 

Item Description 

Please select the interface type 

Select the type of the ports to be configured. The interface types available 
depend on your device model. 

 
If a WLAN-ESS interface in use contains WLAN-DBSS interfaces, its priority 
trust mode cannot be modified. To do that, you must stop the service the 
interface is providing to log off all online users. 

Trust Mode 

Select the priority trust mode, which can be: 
 Dot1p: Uses the 802.1p priority of incoming packets for mapping.  
 Dscp: Uses the DSCP precedence of incoming packets for mapping.  
 Dot11e: Uses the 802.11e priority of incoming packets for mapping. This 

option is only available for WLAN-ESS interfaces.  

 
Available priority trust modes vary with interface types.  

(Select ports) Click to select ports to be configured from the list of available ports.  

 

Changing port priority and priority trust mode for ports individually 
Select QoS > Port Priority from the navigation tree to enter the page shown in Figure 46-6. Click the  
icon specific to a port to enter the page for configuring the priority and priority trust mode of the port, as 
shown in Figure 46-7.  

Figure 46-6 The page displaying the port priority and priority trust mode of ports 

 
 

Figure 46-7 Modify the port priority and priority trust mode of a port 

 

 

Table 46-6 shows the items for changing the priority and priority trust mode for a port.  
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Table 46-6 Items for changing the priority and priority trust mode for a port 

Item Remarks 

Interface Name Name of the interface being configured. 

Priority 

Set the port priority of the port. Port priority is identical to local precedence on the 
WX series access controllers.  
Local precedence is allocated by the device and has only local significance. A local 
precedence value corresponds to an output queue. A packet with higher local 
precedence is assigned to a higher priority output queue to be preferentially 
scheduled.  

Trust Mode 

Select the priority trust mode, which can be: 
 Untrust: Uses the port priority rather than a packet priority field for mapping.  
 Dot1p: Uses the 802.1p priority of incoming packets for mapping.  
 DSCP: Uses the DSCP precedence of incoming packets for mapping.  

 
Available priority trust modes vary with interface types.  

 

Return to Priority mapping configuration task list. 

Creating a Class 

Select QoS > Classifier from the navigation tree and click Create to enter the page for creating a class, 
as shown in Figure 46-8.  

Figure 46-8 The page for creating a class 

 

 

Table 46-7 shows the configuration items for creating a class.  
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Table 46-7 Configuration items for creating a class 

Item Description 

Classifier Name Specify a name for the classifier to be created.  

Operator 

Specify the logical relationship between rules of the classifier.  
 and: Specifies the relationship between the rules in a class as logic AND. That is, 

the device considers a packet belongs to a class only when the packet matches 
all the rules in the class.  

 or: Specifies the relationship between the rules in a class as logic OR. That is, 
the device considers a packet belongs to a class as long as the packet matches 
one of the rules in the class.  

 

Return to QoS policy configuration task list. 

Configuring Classification Rules 

Select QoS > Classifier from the navigation tree and click Setup to enter the page for setting a class, 
as shown in Figure 46-9.  

Figure 46-9 The page for configuring classification rules 
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Table 46-8 shows the configuration items for configuring classification rules.  

Table 46-8 Configuration items for configuring classification rules 

Item Description 

Please select a classifier Select an existing classifier in the drop-down list.  

Any 
Define a rule to match all packets.  
Select the check box to match all packets.  

DSCP 

Define a rule to match DSCP values.  
If multiple such rules are configured for a class, the new configuration does not 
overwrite the previous one.  
You can configure up to eight DSCP values each time. If multiple identical 
DSCP values are specified, the system considers them as one. The 
relationship between different DSCP values is OR. After such configurations, 
all the DSCP values are arranged in ascending order automatically.  

IP Precedence 

Define a rule to match IP precedence values.  
If multiple such rules are configured for a class, the new configuration does not 
overwrite the previous one.  
You can configure up to eight IP precedence values each time. If multiple 
identical IP precedence values are specified, the system considers them as 
one. The relationship between different IP precedence values is OR. After 
such configurations, all the IP precedence values are arranged in ascending 
order automatically.  

Classifier Define a rule to match a QoS class.  

Inbound Interface Define a rule to match inbound interfaces.  

RTP Port 

Define a rule to match a range of RTP ports 
Specify the start port in the from text box and the end port in the to textbox.  

 
This configuration item is not supported currently.  

Service 802.1p 

Define a rule to match the service 802.1p priority values. 
If multiple such rules are configured for a class, the new configuration does not 
overwrite the previous one.  
You can configure up to eight Dot1p values each time. If multiple identical 
Dot1p values are specified, the system considers them as one. The 
relationship between different Dot1p values is OR. After such configurations, 
all the Dot1p values are arranged in ascending order automatically. 

Dot1p 

Customer 802.1p 

Define a rule to match the customer 802.1p priority values. 
If multiple such rules are configured for a class, the new configuration does not 
overwrite the previous one.  
You can configure up to eight Dot1p values each time. If multiple identical 
Dot1p values are specified, the system considers them as one. The 
relationship between different Dot1p values is OR. After such configurations, 
all the Dot1p values are arranged in ascending order automatically. 

Source MAC 

Define a rule to match a source MAC address.  
If multiple such rules are configured for a class, the new configuration does not 
overwrite the previous one.  
A rule to match a source MAC address is significant only to Ethernet interfaces. 

MAC 

Destination MAC 

Define a rule to match a destination MAC address.  
If multiple such rules are configured for a class, the new configuration does not 
overwrite the previous one.  
A rule to match a destination MAC address is significant only to Ethernet 
interfaces.  
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Item Description 

Service VLAN 

Define a rule to match service VLAN IDs.  
If multiple such rules are configured for a class, the new configuration does not 
overwrite the previous one.  
You can configure multiple VLAN IDs each time. If the same VLAN ID is 
specified multiple times, the system considers them as one. The relationship 
between different VLAN IDs is logical OR. After such a configuration. You can 
specify VLAN IDs in two ways: 

 Enter a range of VLAN IDs, such as 10-500. The number of VLAN IDs in 
the range is not limited. 

 Specify a combination of individual VLAN IDs and VLAN ID ranges, such as 
3, 5-7, 10. You can specify up to eight VLAN IDs in this way. 

VLAN 

Customer VLAN 

Define a rule to match customer VLAN IDs.  
If multiple such rules are configured for a class, the new configuration does not 
overwrite the previous one.  
You can configure multiple VLAN IDs each time. If the same VLAN ID is 
specified multiple times, the system considers them as one. The relationship 
between different VLAN IDs is logical OR. You can specify VLAN IDs in two 
ways: 

 Enter a range of VLAN IDs, such as 10-500. The number of VLAN IDs in 
the range is not limited. 

 Specify a combination of individual VLAN IDs and VLAN ID ranges, such as 
3, 5-7, 10. You can specify up to eight VLAN IDs in this way. 

ACL ACL IPv4 
Define an IPv4 ACL-based rule.  
The ACLs available for selection are existing IPv4 ACLs.  

 

Return to QoS policy configuration task list. 

Creating a Traffic Behavior 

Select QoS > Behavior from the navigation tree and click the Create tab to enter the page for creating 
a traffic behavior, as shown in Figure 46-10.  

Figure 46-10 The page for creating a traffic behavior 

 

 

Table 46-9 describes the configuration items for creating a behavior.  
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Table 46-9 Configuration items for creating a behavior 

Item Description 

Behavior name Specify a name for the behavior to be created.  

 

Return to QoS policy configuration task list. 

Configuring Actions in a Traffic Behavior 

Select QoS > Behavior from the navigation tree and click Setup to enter the page for configiuring 
actions in a traffic behavior, as shown in Figure 46-11.  

Figure 46-11 The page for setting a traffic behavior 

 
 

Table 46-10 describes how to configure actions in a traffic behavior.  
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Table 46-10 Items for configuring actions for a traffic behavior 

Item Description 

Please select a behavior Select an existing behavior in the drop-down list.  

Enable/Disable Enable or disable CAR 

CIR Set the committed information rate (CIR), the average traffic rate.  

CBS Set the committed burst size (CBS), number of bits that can be sent in 
each interval.  

Discard 

Pass 

CAR 

Red 
Remark 
DSCP Pass 

Set the action to perform for exceeding packets.  
After selecting the Red check box, you can select one of the following 
two options: 

 Discard: Drops the exceeding packet.  
 Pass: Permits the exceeding packet to pass through.  

IP Precedence 

Configure the action of marking IP precedence for packets.  
Select the IP Precedence check box and then select the IP 
precedence value to be marked for packets in the following drop-down 
list. Select Not Set to cancel the action of marking IP precedence.  

Dot1p 

Configure the action of marking 802.1p priority for packets.  
Select the Dot1p check box and then select the 802.1p priority value to 
be marked for packets in the following drop-down list. Select Not Set 
to cancel the action of marking 802.1p priority.  

Local Precedence 

Configure the action of marking local precedence for packets.  
Select the Local Precedence check box and then select the local 
precedence value to be marked for packets in the following drop-down 
list. Select Not Set to cancel the action of marking local precedence. 

Remark 

DSCP 

Configure the action of marking DSCP precedence for packets.  
Select the DSCP check box and then select the DSCP precedence 
value to be marked for packets in the following drop-down list. Select 
Not Set to cancel the action of marking DSCP precedence.  

Max Bandwidth Configure the maximum bandwidth for expedited forwarding (EF). 

CBS Configure the CBS for EF. 

Percent Configure the percent of available bandwidth for EF. 
EF 

CBS-Ratio Configure the ratio of CBS to CIR for EF. 

Min Bandwidth Configure the minimum guaranteed bandwidth for assured forwarding 
(AF). AF 

Percent Configure the percent of available bandwidth for AF. 

Queue 

WFQ Configure WFQ for the default class by inputting the total number of 
fair queues, which must be a power of two. 

Filter 

Configure the packet filtering action.  
After selecting the Filter check box, select one item in the following 
drop-down list: 

 Permit: Forwards the packet.  
 Deny: Drops the packet.  
 Not Set: Cancels the packet filtering action.  

Accounting 
Configure the traffic accounting action.  
Select the Accounting check box and select Enable or Disable in the 
following drop-down list to enable/disable the traffic accounting action. 
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Return to QoS policy configuration task list. 

Creating a Policy 

Select QoS > QoS Policy from the navigation tree and click Create to enter the page for creating a 
policy, as shown in Figure 46-12.  

Figure 46-12 The page for creating a policy 

 

 

Table 46-11 describes the configuration items for creating a policy.  

Table 46-11 Configuration items for creating a policy 

Item Description 

Policy Name Specify a name for the policy to be created.  

 

Return to QoS policy configuration task list. 

Configuring Classifier-Behavior Associations for the Policy 

Select QoS > QoS Policy from the navigation tree and click Setup to enter the page for setting a policy, 
as shown in Figure 46-13.  
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Figure 46-13 The page for setting a policy 

 
 

Table 46-12 describes the items for configuring classifier-behavior associations for the policy.  

Table 46-12 Items for configuring classifier-behavior associations for the policy 

Item Description 

Please select a policy Select a created policy in the drop-down list.  

Classifier Name 
Select an existing classifier in the drop-down list.  
The classifiers available for selection are created on the page for 
creating a classifier.  

Behavior Name 
Select an existing behavior in the drop-down list.  
The behaviors available for selection are created on the page for 
creating a behavior.  

 

Return to QoS policy configuration task list. 

Applying a Policy to a Port 

Select QoS > Port Policy from the navigation tree and click Setup to enter the page for applying a 
policy to a port, as shown in Figure 46-14.  
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Figure 46-14 The page for applying a policy to a port 

 
 

Table 46-13 describes the configuration items for applying a policy to a port.  

Table 46-13 Configuration items for applying a policy to a port 

Item Description 

Please select a policy Select a created policy in the drop-down list.  

Direction 
Set the direction in which the policy is to be applied.  

 Inbound: Applies the policy to the incoming packets of the specified ports.  
 Outbound: Applies the policy to the outgoing packets of the specified ports.  

Please select port(s) Click the ports to which the QoS policy is to be applied in the port list. You can select 
one or more ports.  

 

Return to QoS policy configuration task list. 

Applying a QoS policy to a WLAN Service 

Select QoS > Service Policy from the navigation tree to enter the service policy page shown in Figure 

46-15. Click the  icon of a WLAN service to enter the service policy setup page shown in Figure 

46-16.  
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Figure 46-15 Service policy 

 
 

Figure 46-16 Service policy setup 

 

 

Table 46-14 shows the configuration items for applying a policy to a WLAN service.  

Table 46-14 Configuration items for applying the QoS policy to a WLAN service 

Item Remarks 

Wlan Service Displays the specified WLAN service  

Inbound Policy Select an existing policy, and then the QoS policy is applied to the packets received 
by the WLAN service 

Outbound Policy Select an existing policy, and then the QoS policy is applied to the packets sent by 
the WLAN service 

Trust Mode 
 dot11e: Uses the 802.11e priority of received 802.11 packets for mapping.   
 dscp: Uses the DSCP values of received IP packets for mapping.  

QoS Priority Priority value, 0 by default 

 

Return to QoS policy configuration task list. 

Configuration Guidelines 

When configuring QoS, note that: 

1) When configuring line rate and traffic policing for a behavior, make sure that the ratio of CBS to CIR 
is more than 100:16. Otherwise, the handling for bursty traffic may be affected.  
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2) If an ACL is referenced by a QoS policy for defining traffic classification rules, the operation of the 
QoS policy varies by interface: The definition of software/hardware interface varies with device 
models. The specific process is as follows: 

 If the QoS policy is applied to a software interface and the referenced ACL rule is a deny clause, 
the ACL rule does not take effect and packets go to the next classification rule.  

 If the QoS policy is applied to a hardware interface, packets matching the referenced ACL rule are 
organized as a class and the behavior defined in the QoS policy applies to the class regardless of 
whether the referenced ACL rule is a deny or permit clause.  

3) If a QoS policy is applied in the outbound direction of a port, the QoS policy cannot influence local 
packets. Local packets refer to the important protocol packets that maintain the normal operation of 
the device. QoS must not process such packets to avoid packet drop. Commonly used local 
packets are: link maintenance packets, ISIS packets, OSPF packets, RIP packets, BGP packets, 
LDP packets, RSVP packets, and SSH packets and so on.  

4) When configuring queuing for a traffic behavior: 

 In a policy, a traffic behavior with EF configured cannot be associated with the default class, while 
a traffic behavior with WFQ configured can only be associated with the default class.  

 In a policy, the total bandwidth assigned to the AF and EF classes cannot be greater than the 
available bandwidth of the interface to which the policy applies; the total bandwidth percentage 
assigned to the AF and EF classes cannot be greater than 100%. 

 In the same policy, the same bandwidth unit must be used to configure bandwidth for AF classes 
and EF classes, either absolute bandwidth value or percent.  
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47  ACL/QoS Configuration Example 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. Refer to 
section "Feature Matrixes" in Compatibility Matrixes for details. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

ACL/QoS Configuration Example 

Network Requirements 

As shown in Figure 47-1, in the WLAN, the FTP server at IP address 10.1.1.1/24 is connected to the AC, 
and the clients access the FTP server through WLAN-ESS1 of the AC.  

Configure an ACL and a QoS policy as follows to prohibit the hosts from accessing the FTP server from 
8:00 to 18:00 every day: 

1) Create an ACL to prohibit the hosts from accessing the FTP server from 8:00 to 18:00 every day.  

2) Configure a QoS policy to drop the packets matching the ACL.  

3) Apply the QoS policy in the inbound direction of WLAN-ESS1.  

Figure 47-1 Network diagram for ACL/QoS configuration 
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Configuration Procedure 

1) Configure the time range 

# Define a time range to cover the time range from 8:00 to 18:00 every day.  

 Select QoS > Time Range from the navigation tree and click Create. Perform configuration as 
shown in Figure 47-2.  

Figure 47-2 Define a time range covering 8:00 to 18:00 every day 

 

 

 Type the time range name test-time.  

 Select the Periodic Time Range check box, set the Start Time to 8:00 and the End Time to 18:00, 
and then select the checkboxes Sun through Sat.  

 Click Apply.  

2) Define an IPv4 ACL for traffic to the FTP server.  

# Create an advanced IPv4 ACL.  

 Select QoS > ACL IPv4 from the navigation tree and click Create. Perform configuration as shown 
in Figure 47-3.  
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Figure 47-3 Create an advanced IPv4 ACL 

 
 

 Type the ACL number 3000.  

 Click Apply.  

# Define an ACL rule for traffic to the FTP server.  

 Click Advance Setup. Perform configuration as shown in Figure 47-4.  
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Figure 47-4 Define an ACL rule for traffic to the FTP server 

 

 

 Select 3000 in the ACL drop-down list.  

 Select the Rule ID check box, and type rule ID 2.  

 Select Permit in the Action drop-down list.  

 Select the Destination IP Address check box, and type IP address 10.1.1.1 and destination 
wildcard 0.0.0.0.  

 Select test-time in the Time Range drop-down list.  

 Click Add.  

3) Configure a QoS policy 

# Create a class.  

 Select QoS > Classifier from the navigation tree and click Create. Perform configuration as shown 
in Figure 47-5.  
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Figure 47-5 Create a class 

 
 

 Type the class name class1.  

 Click Create.  

# Define classification rules.  

 Click Setup. Perform configuration as shown in Figure 47-6.  
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Figure 47-6 Define classification rules 

 
 

 Select the class name class1 in the drop-down list.  

 Select the ACL IPv4 check box, and select ACL 3000 in the following drop-down list.  

 Click Apply.  

# Create a traffic behavior.  

 Select QoS > Behavior from the navigation tree and click Create. Perform configuration as shown 
in Figure 47-7.  
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Figure 47-7 Create a traffic behavior 

 
 

 Type the behavior name behavior1.  

 Click Create.  

# Configure actions for the traffic behavior.  

 Click Setup. Perform configuration as shown in Figure 47-8.  
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Figure 47-8 Configure actions for the behavior 

 

 

 Select behavior1 in the drop-down list.  

 Select the Filter check box, and then select Deny in the following drop-down list.  

 Click Apply.  

# Create a policy.  

 Select QoS > QoS Policy from the navigation tree and click the Create tab. Perform configuration 
as shown in Figure 47-9.  



 

47-9 

Figure 47-9 Create a policy 

 

 

 Type the policy name policy1.  

 Click Create.  

# Configure classifier-behavior associations for the policy.  

 Click Setup. Perform configuration as shown in Figure 47-10.  

Figure 47-10 Configure classifier-behavior associations for the policy 

 

 

 Select policy1.  

 Select class1 in the Classifier Name drop-down list.  

 Select behavior1 in the Behavior Name drop-down list.  

 Click Apply.  

# Apply the QoS policy in the inbound direction of WLAN-ESS1.  

 Select QoS > Port Policy from the navigation tree and click the Setup tab. Perform configuration 
as shown in Figure 47-11.  
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Figure 47-11 Apply the QoS policy in the inbound direction of WLAN-ESS1 

 
 

 Select policy1 in the Please select a policy drop-down list.  

 Select Inbound in the Direction drop-down list.  

 Select port WLAN-ESS1.  

 Click Apply.  

After you complete the above configurations, the wireless users cannot access the FTP server at IP 
address 10.1.1.1/24 from 8:00 to 18:00 every day, but they can do that at any other time. 
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48  Wireless QoS Configuration 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. Refer to 
section "Feature Matrixes" in Compatibility Matrixes for details. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

An 802.11 network offers contention-based wireless access. To provide applications with QoS services, 
IEEE developed 802.11e for the 802.11-based WLAN architecture. 

While IEEE 802.11e was being standardized, Wi-Fi Alliance defined the Wi-Fi Multimedia (WMM) 
standard to allow QoS provision devices of different vendors to interoperate. WMM makes a WLAN 
network capable of providing QoS services.  

Terminology 

1) WMM 

WMM is a wireless QoS protocol designed to preferentially transmit packets with high priority, thus 
guaranteeing better QoS services for voice and video applications in a wireless network.  

2) EDCA 

Enhanced distributed channel access (EDCA) is a channel contention mechanism designed by WMM 
to preferentially transmit packets with high priority and allocate more bandwidth to such packets.  

3) AC 

Access category (AC), is used for channel contention. WMM defines four access categories; they are 
AC-VO (voice), AC-VI (video), AC-BE (best-effort), and AC-BK (background) in the descending order of 
priority. When contending for a channel, a high-priority AC preempts a low-priority AC.  

4) CAC 

Connection admission control (CAC) limits the number of clients that are using high-priority ACs 
(AC-VO and AC-VI) to guarantee sufficient bandwidth for existing high-priority traffic.  

5) U-APSD 
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Unscheduled automatic power-save delivery (U-APSD) is a new power saving mechanism defined by 
WMM to enhance the power saving capability of clients.  

6) SVP 

SpectraLink voice priority (SVP) is a voice priority protocol designed by the Spectralink company to 
guarantee QoS for voice traffic.  

WMM Protocol Overview 

The distributed coordination function (DCF) in 802.11 stipulates that access points (APs) and clients 
use the carrier sense multiple access with collision avoidance (CSMA/CA) access mechanism. APs or 
clients listen to the channel before they hold the channel for data transmission. When the specified idle 
duration of the channel times out, APs or clients randomly select a backoff slot within the contention 
window to perform backoff. The device that finishes backoff first gets the channel. With 802.11, all 
devices have the same idle duration and contention window. Therefore, they are equal when 
contending for a channel. In WMM, this fair contention mechanism is changed.  

EDCA parameters 
WMM assigns data packets in a basic service set (BSS) to four ACs. By allowing a high-priority AC to 
have more channel contention opportunities than a low-priority AC, WMM offers different service levels 
to different ACs.  

WMM define a set of EDCA parameters for each AC, covering the following:  

 Arbitration inter-frame spacing number (AIFSN): Different from the 802.11 protocol where the idle 
duration (set using DIFS) is a constant value, WMM can define an idle duration per AC. The idle 
duration increases as the AIFSN value increases (see Figure 48-1 for the AIFS durations).  

 Exponent form of CWmin (ECWmin) and exponent form of CWmax (ECWmax) determine the 
average backoff slots, which increases as the two values increase (see Figure 48-1 for the backoff 
slots).  

 Transmission opportunity limit (TXOPLimit) indicates the maximum time for which a user can hold 
a channel after a successful contention. The greater the TXOPLimit is, the longer the user can hold 
the channel. The value 0 indicates that the user can send only one packet each time it holds the 
channel. 
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Figure 48-1 Per-AC channel contention parameters in WMM 

 

 

CAC admission policies 
CAC requires that a client obtain permission of the AP before it can use a high-priority AC for 
transmission, thus guaranteeing bandwidth to the clients that have gained access. CAC controls real 
time traffic (AC-VO and AC-VI traffic) but not common data traffic (AC-BE and AC-BK traffic). 

If a client wants to use a high-priority AC, it needs to send a request to the AP. The AP returns a positive 
or negative response based on either of the following admission control policy:  

 Channel utilization-based admission policy: the AP calculates the total time that the existing 
high-priority ACs occupies the channel in one second, and then calculates the time that the 
requesting traffic will occupy the channel in one second. If the sum of the two values is smaller than 
or equal to the maximum hold time of the channel, the client can use the requested AC. Otherwise, 
the request is rejected.  

 Users-based admission policy: if the number of clients using high-priority ACs plus the requesting 
clients is smaller than or equal to the maximum number of high-priority AC clients, the request is 
accepted. Otherwise, the request is rejected. During calculation, a client is counted once even if it 
is using both AC-VO and AC-VI. 

U-APSD power-save mechanism 
U-APSD improves the 802.11 APSD power saving mechanism. When associating clients with ACs, you 
can specify some ACs as trigger-enabled, some ACs as delivery-enabled, and the maximum number of 
data packets that can be delivered after receiving a trigger packet. Both the trigger attribute and the 
delivery attribute can be modified when flows are established using CAC. When a client sleeps, the 
delivery-enabled AC packets destined for the client are buffered. The client needs to send a 
trigger-enabled AC packet to get the buffered packets. After the AP receives the trigger packet, packets 
in the transmit queue are sent. The number of sent packets depends on the agreement made when the 
client was admitted. ACs without the delivery attribute store and transmit packets as defined in the 
802.11 protocol.  
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SVP 
SVP can assign packets with the protocol ID 119 in the IP header to a specific AC. SVP stipulates that 
random backoff is not performed for SVP packets. Therefore, you can set both ECWmin and ECWmax 
to 0 when there are only SVP packets in an AC.  

ACK policy 
WMM defines two ACK policies: Normal ACK and No ACK.  

 When the no acknowledgement (No ACK) policy is used, the recipient does not acknowledge 
received packets during wireless packet exchange. This policy is suitable in the environment where 
communication quality is fine and interference is weak. While the No ACK policy helps improve 
transmission efficiency, it can cause increased packet loss when communication quality 
deteriorates. This is because when this policy is used, a sender does not retransmit packets that 
have not been received by the recipient. 

 When the Normal ACK policy is used, the recipient acknowledges each received unicast packet.  

Configuring Wireless QoS 

Enabling Wireless QoS 

Select QoS > Wireless QoS from the navigation tree, and select the Wireless QoS tab to enter the 
page displaying the QoS, as shown in Figure 48-2.  

Figure 48-2 Wireless QoS 

 

 

 

The 802.11n protocol stipulates that all 802.11n clients support WLAN QoS. Therefore, when the radio 
works in 802.11an or 802.11gn mode, you must enable WMM. Otherwise, the associated 802.11n 
clients may fail to communicate.  

 

Setting SVP Mapping 

Select QoS > Wireless QoS from the navigation tree on the left of the interface, and then select 
Wireless QoS to enter the page for displaying wireless QoS, as shown in Figure 48-3. 
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Figure 48-3 Wireless QoS 

 

 

Find the desired AP in the AP list, and click the  icon in the Operation column to enter the page for 
setting SVP mapping, as shown in Figure 48-4. 

Figure 48-4 Set SVP mapping 

 

 

Table 48-1 shows the configuration items for setting SVP mapping. 

Table 48-1 Configuration items for setting SVP mapping 

Item Description 

AP Name Displays the selected AP 

Radio Displays the selected AP’s radio 

SVP Mapping 

Select the check box before SVP Mapping, and then select the AC priority 
queue to be used by the SVP service: 

 AC-VO 
 AC-VI 
 AC-BE 
 AC-BK 

 

 

SVP mapping is applicable only to non-WMM clients.  

 

Setting CAC Admission Policy 

Select QoS > Wireless QoS from the navigation tree on the left of the interface, select the Wireless 
QoS tab, find the desired AP in the AP list, and click the corresponding icon in the Operation column to 
enter the page for setting CAC admission policy, as shown in Figure 48-5. 
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Figure 48-5 Set CAC admission policy 

 

 

Table 48-2 shows the configuration items for setting CAC admission policy. 

Table 48-2 Configuration items for setting CAC admission policy 

Item Description 

Client Number 

Users-based admission policy, namely, maximum number of clients allowed 
to be connected. A client is counted only once, even if it is using both AC-VO 
and AC-VI. 
By default, the users-based admission policy applies, with the maximum 
number of users being 20. 

Channel Utilization 
Channel utilization-based admission policy, namely, the rate of the medium 
time of the accepted AC-VO and AC-VI traffic to the valid time during the unit 
time. The valid time is the total time during which data is transmitted. 

 

Setting Radio EDCA Parameters 

Select QoS > Wireless QoS from the navigation tree on the left of the interface, select the Wireless 
QoS tab, find the desired AP in the AP list, and click the corresponding  icon in the Operation column 
to enter the page for setting wireless QoS. In the Radio EDCA list, select the priority type (AC_BK is 
taken for example here) to be modified, and click the corresponding  icon in the Operation column to 
enter the page for setting radio EDCA parameters.  

Figure 48-6 Set EDCA 

 

 

Table 48-3 shows the configuration items for setting radio EDCA parameters. 

Table 48-3 Configuration items for setting AP EDCA 

Item Description 

AP Name Displays the selected AP 

Radio Displays the selected AP’s radio 

Priority type Displays the priority type 



 

48-7 

Item Description 

AIFSN Arbitration inter-frame spacing number 

TXOP Limit Transmission opportunity limit 

ECWmin Exponent form of CWmin, namely, minimum ECWmin allowed by the radio chip 

ECWmax Exponent form of CWmax, namely, maximum ECWmin allowed by the radio chip

No ACK 
If you select the checkbox before No ACK, the No ACK policy is adopted. 
By default, the normal ACK policy is adopted. 

 

Table 48-4 shows the default EDCA parameters. 

Table 48-4 Default radio EDCA parameters 

AC AIFSN ECWmin ECWmax TXOP Limit 

AC-BK 7 4 10 0 

AC-BE 3 4 6 0 

AC-VI 1 3 4 94 

AC-VO 1 2 3 47 

 

 

 ECWmin cannot be greater than ECWmax.  

 On an AP operating in 802.11b radio mode, you are recommended to set the TXOP-Limit to 0, 0, 
188, and 102 for AC-BK, AC-BE, AC-VI, and AC-VO.  

 

Setting Client EDCA Parameters 

Select QoS > Wireless QoS from the navigation tree on the left of the interface, select the Wireless 
QoS tab, find the desired AP in the AP list, and click the corresponding  icon in the Operation column 
to enter the page for setting wireless QoS. In the Client EDCA list, find the priority type (AC_BK is taken 
for example here) to be modified, and click the corresponding  icon in the Operation column to enter 
the page for setting client EDCA parameters. 

Figure 48-7 Set client EDCA parameters 

 
 

Table 48-5 shows the configuration items for setting client EDCA parameters. 
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Table 48-5 Configuration items for setting client EDCA 

Item Description 

AP Name Displays the selected AP 

Radio Displays the selected AP’s radio 

Priority type Displays the priority type 

AIFSN Arbitration inter-frame spacing number 

TXOP Limit Transmission opportunity limit 

ECWmin Exponent form of CWmin, namely, minimum ECWmin allowed by the radio chip 

ECWmax Exponent form of CWmax, namely, maximum ECWmin allowed by the radio chip 

CAC 

Enables CAC. AC-VO and AC-VI support CAC, which is disabled by default. AC-BE 
and AC-BK do not support CAC. 

 Enable: Enables CAC. 
 Disable: Disables CAC. 

 

Table 48-6 shows the default client EDCA parameters. 

Table 48-6 Default EDCA parameters for clients 

AC AIFSN ECWmin ECWmax TXOP Limit 

AC-BK 7 4 10 0 

AC-BE 3 4 10 0 

AC-VI 2 3 4 94 

AC-VO 2 2 3 47 

 

 

 ECWmin cannot be greater than ECWmax.  

 If all clients operate in 802.11b radio mode, you are recommended to set TXOPLimit to 188 and 
102 for AC-VI and AC-VO.  

 If some clients operate in 802.11b radio mode and some clients operate in 802.11g radio mode in 
the network, the TXOPLimit parameters in Table 48-6 are recommended.  

 Once you enable CAC for an AC, it is enabled automatically for all ACs with higher priority. For 
example, if you enable CAC for AC-VI, CAC is also enabled for AC-VO. However, enabling CAC for 
AC-VO does not enable CAC for AC-VI.  

 

Display the Radio Statistics 

Select QoS > Wireless QoS from the navigation tree, and select the Radio Statistics tab to enter the 
page displaying radio statistics. Click an AP name to see its details.  
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Figure 48-8 Display the radio statistics 

 
 

Table 48-7 shows the description on the output for a radio.  

Table 48-7 Description on the output for a radio 

Field Description 

AP ID AP ID 

AP Name AP name 

Radio Radio ID 

Client EDCA update count Number of client EDCA parameter updates 

QoS mode QoS mode: WMM indicates that QoS mode is enabled; None indicates that 
QoS mode is not enabled.  

Radio chip QoS mode Radio chip’s support for the QoS mode 

Radio chip max AIFSN Maximum AIFSN allowed by the radio chip 

Radio chip max ECWmin Maximum ECWmin allowed by the radio chip 

Radio chip max TXOPLimit Maximum TXOPLimit allowed by the radio chip 

Radio chip max ECWmax Maximum ECWmax allowed by the radio chip 

Client accepted 
Number of clients that have been admitted to access the radio, including the 
number of clients that have been admitted to access the AC-VO and the 
AC-VI 

Total request mediumtime(us) Total requested medium time, including that of the AC-VO and the AC-VI 

Calls rejected due to insufficient 
resource Number of requests rejected due to insufficient resources 

Calls rejected due to invalid 
parameters Number of requests rejected due to invalid parameters 

Calls rejected due to invalid 
mediumtime Number of requests rejected due to invalid medium time 

Calls rejected due to invalid 
delaybound Number of requests rejected due to invalid delay bound 
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Displaying the Client Statistics 

Select QoS > Wireless QoS from the navigation tree, and select the Client Statistics tab to enter the 
page displaying client statistics. Click a client name to see its details.  

Figure 48-9 Display the client statistics 

 

 

Table 48-8 shows the description on the output for a client.  

Table 48-8 Description on the output for a client 

Field Description 

MAC address MAC address of the client 

SSID Service set ID (SSID) 

QoS Mode QoS mode: WMM indicates that QoS mode is enabled; None indicates that 
QoS mode is not enabled.  

Max SP length Maximum service period 

AC Access category 

State 

APSD attribute of an AC, which can be:  
 T: The AC is trigger-enabled.  
 D: The AC is delivery-enabled.  
 T | D: The AC is both trigger-enabled and delivery-enabled.  
 L: The AC is of legacy attributes. 

Assoc State APSD attribute of the four ACs when a client accesses the AP 

Uplink CAC packets Number of uplink CAC packets 

Uplink CAC bytes Number of uplink CAC bytes 

Downlink CAC packets Number of downlink CAC packets 

Downlink CAC bytes Number of downlink CAC bytes 

Downgrade packets Number of downgraded packets 

Downgrade bytes Number of downgraded bytes 

Discard packets Number of dropped packets 
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Field Description 

Discard bytes Number of dropped bytes 

 

Setting Rate Limiting 

To ensure that all clients in a WLAN can use the network services normally, you need to configure rate 
limiting for clients in the WLAN. You can perform client-based rate limiting in one of the following two 
modes: 

 Dynamic mode: Allows you to configure the total rate of all clients associated with the same AP. 
The rate limit of a client is the configured total rate/the number of clients. For example, if the 
configure total rate is 10 Mbps and five clients are online, the rate of each client is 2 Mbps.  

 Static mode: Allows you to configure a rate limit for each client associated with the same AP. That 
is, each client of the AP cannot exceed the rate limit. For example, if the configured rate is 1 Mbps, 
the rate limit of each user online is 1 Mbps. When the set rate limit multiplied by the number of 
access clients exceeds the total bandwidth, the bandwidth is assigned to the clients equally. No 
clients can get the guaranteed bandwidth in this case.  

Select QoS > Wireless QoS from the navigation tree on the left, and select the Client Rate Limit tab to 
enter the page for setting rate limiting, as shown in Figure 48-10. 

Figure 48-10 Set rate limiting 

 

 

Table 48-9 shows the configuration items for setting rate limiting.  

Table 48-9 Configuration items for setting rate limiting 

Item Description 

Wireless Service Displays an existing wireless service 

Direction 

Inbound or outbound 
 Inbound: from clients to the AP 
 Outbound: from the AP to clients 
 Both: Includes inbound (from clients to the AP) and outbound (from the AP to 

clients) 

Mode 

Rate limiting mode, dynamic or static 
 Dynamic mode: configures the total rate of all clients associated with the same AP. 

The rate limit of a client is the configured total rate/the number of clients.  
 Static mode: configures the rate limit for each client.  
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Item Description 

Rate 

Sets the rate of the clients 
 If you select the static mode, static rate is displayed, and the rate is the rate of 

each client. 
  If you select the dynamic mode, share rate is displayed, and the rate is the total 

rate of all clients.  

 

Wireless QoS Configuration Example 

CAC Service Configuration Example 

Network requirements 
As shown in Figure 48-11, an AC is connected to a Layer 2 switch, and an AP is in the same network as 
the AC. Enable CAC for AC-VO and AC-VI for the clients of the AP.  

Use the user number-based admission policy, allowing up to 10 users to set up AC-VO and AC-VI flows 
with the AP.  

Figure 48-11 Network diagram for CAC service configuration 

 

 

Configuration procedure 
1) Configure the wireless service 

# Configure the AP, and establish a CAPWAP connection between the AC and the AP.  

For related configurations, refer to Wireless Service Configuration. Strictly follow the steps in the related 
configuration example to establish a CAPWAP connection between the AC and the AP.  

2) Configure wireless QoS 

# Select QoS > Wireless QoS from the navigation tree, and select the Wireless QoS tab to enter the 
page shown in Figure 48-12. Make sure that WMM is enabled.  

Figure 48-12 Wireless QoS configuration page 

 
 

# Select the AP to be configured in the list and click the corresponding  icon in the Operation column 
to enter the page for configuring wireless QoS. In the Client EDCA list, select the priority type (AC_VO 
is taken for example here) to be modified, and click the corresponding  icon in the Operation column 
to enter the page for setting client EDCA parameters.  
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Figure 48-13 Enable CAC 

 
 

 Select Enable from the CAC drop-down list.  

 Click Apply.  

# Enable CAC for AC_VI in the same way described above.  

# Select QoS > Wireless QoS from the navigation tree, select the Wireless QoS tab, find the AP to be 
configured in the list, and click the corresponding  icon in the Operation column to enter the page for 
configuring wireless QoS.  

Figure 48-14 The page for setting CAC client number 

 
 

 Select the Client Number option, and then input 10.  

 Click Apply.  

Verifying the configuration 
If the number of existing clients in the high-priority ACs plus the number of clients requesting access is 
smaller than or equal to the user-defined maximum number of users allowed in high-priority ACs), which 
is 10 in this example, the request is allowed. Otherwise, the request is rejected.  

SVP Service Configuration Example 

Network requirements 
As shown in Figure 48-15, the AC is connected to a Layer 2 switch, and the AP is in the same network 
as the AC. It is required that the AP assign SVP packets to AC-VO. To guarantee the highest priority for 
AC-VO, set the ECWmin and ECWmax to 0 for AC-VO.  
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Figure 48-15 Network diagram for SVP service configuration 

 

 

Configuration procedure 
1) Configure the wireless service 

# Configure the AP, and establish a CAPWAP connection between the AC and the AP.  

For related configurations, refer to Wireless Service Configuration. You can strictly follow the steps in 
the related configuration example to establish a CAPWAP connection between the AC and the AP.  

2) Configure wireless QoS 

# Select QoS > Wireless QoS from the navigation tree, and select the Wireless QoS tab to enter the 
page shown in Figure 48-16. Make sure that WMM is enabled.  

Figure 48-16 Wireless QoS configuration page 

 
 

# Select QoS > Wireless QoS from the navigation tree, select the Wireless QoS tab, find the AP to be 
configured in the list, and click the corresponding  icon in the Operation column to enter the page for 
configuring wireless QoS.  

Figure 48-17 Configure SVP mapping 

 
 

 Select the SVP Mapping option, and select AC_VO from the following drop-down list.  

 Click Apply.  

# Select the AP to be configured in the list and click the corresponding  icon in the Operation column 
to enter the page for configuring wireless QoS. In the Radio EDCA list, select the priority type (AC_VO 
is taken for example here) to be modified, and click the corresponding  icon in the Operation column 
to enter the page for setting radio EDCA parameters.  
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Figure 48-18 Configure radio EDCA 

 

 

Verifying the configuration 
A non-WMM client logs in, and injects SVP packets. The SVP packets will be forwarded through the 
configured AC-VO queue.  
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49  Advanced Settings 

 

 

 Support of the H3C WX series access controllers for features may vary by device model. For more 
information, see "Feature Matrixes" in Compatibility Matrixes. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Advanced Settings Overview 

The advanced settings module allows you to configure the following: 

 District Code 

 AC Backup 

 WLAN Load Balancing 

 AP Settings 

 Wireless Location  

District Code 

Radio frequencies for countries and regions vary based on country regulations. A district code 
determines characteristics such as frequency range, channel, and transmit power level. Configure the 
valid country code or area code for a WLAN device to meet the specific country regulations. 

AC Backup 

1+1 AC backup 
 

 

Support for the feature depends on the device model. 
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In large-scale networking, acting as the key access point and service entrance, an AC is required to 
provide high reliability. 1+1 AC backup mechanism can ensure that the information flow is not affected 
and thus the WLAN services are not interrupted in the case of single point failure. 

1) WLAN dual link establishment 

In the H3C WLAN dual link mechanism, in order to achieve AC backup, an AP needs to establish two 
tunnel links with two different ACs. Only the AC which works in active mode provides services to the AP 
and the standby AC acts as the backup AC. If the master AC fails, APs should quickly use the services 
provided by the standby AC. A fast link fault detection mechanism is used between these two ACs, 
which ensures that failure of the master will be detected quickly by the backup AC. The two ACs can 
both work in master mode for different APs. For configuration, refer to Backup setup. 

Figure 49-1 Dual link topology 
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AP 4 AP 1

AP 2 AP 3
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In the above figure, AC 1 and AC 2 backs up each other. AC 1 is working in active mode and providing 
services to AP 1, AP 2, AP 3 and AP 4. AC 2 is working in standby mode. APs are connected to AC 2 
through backup links. By configuring AC backup, when AC 1 is down, AC 2 converts to work in active 
mode even after AC 1 is up again, in which case, AC 1 is in standby mode. However, this is not so if an 
AC is configured as the primary AC. For description about primary AC, refer to Primary AC recovery. 

2) Primary AC recovery 

Primary AC provides a mechanism to ensure that the primary AC is chosen in precedence by APs as an 
active AC. When the primary AC goes down, the APs switch to connect to the standby AC. As soon as 
the active AC recovers, the APs automatically connect to the primary AC again. 



 

49-3 

Figure 49-2 Primary AC recovery 

 

 

In the above figure, AC 1 is the primary AC with the connection priority of 7, and it establishes a 
CAPWAP connection with the AP; AC 2 acts as the secondary AC. If AC 1 goes down, AC 2 takes over 
to provide services to AP until AC 1 recovers. This means once the primary AC is reachable again, the 
AP automatically establishes a connection with the primary AC. For priority configuration, refer to 
Configuring connection priority. 

1:1 fast backup 
Fast link fault detection allows two ACs in 1:1 backup to detect the failure of each other in time. To 
achieve this, WLAN dual link mechanism is used. When the active AC goes down, the standby AC can 
quickly detect the faults and become the new active AC. This is implemented in milliseconds. Support 
for the 1:1 fast backup feature depends on the device model. 

1+N AC backup 
1+N AC backup allows an AC to operate as a backup for multiple ACs. The active ACs independently 
provide services for APs connecting to them, and the only one standby AC provides backup service for 
the active ACs. If any active AC goes down, the APs connecting to it can detect the failure quickly and 
make connections to the standby AC. As soon as the active AC recovers, the APs automatically 
connect to the original active AC again. This ensures that the standby AC works as a dedicated backup 
for the active ACs. 1+N AC backup delivers high reliability and saves network construction cost greatly. 

Continuous Transmitting Mode 

The continuous transmitting mode is used for test only. It is recommended to not use the function unless 
necessary. 

Channel Busy Test 

The channel busy test is a tool to test how busy a channel is. It tests channels currently supported by 
the district code one by one, and provides a busy rate for each channel. This avoids the situation that 
some channels are heavily loaded and some are idle.  

During a channel busy test, APs do not provide any WLAN services. All the connected clients are 
disconnected and WLAN packets are discarded. 
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WLAN Load Balancing 

WLAN load balancing dynamically adjusts loads among APs to ensure adequate bandwidth for clients. 
It is mainly used in high-density WLAN networks. 

An AC balances load during the association of a client. It checks whether the load on the AP with which 
the client is attempting to connect reaches the upper limit. If not, the association request is accepted. 
Otherwise, load balancing is carried out depending on the configuration. As the result of load balancing, 
the current association request might be accepted or rejected. 

As shown in Figure 49-3, Client LB is trying to connect with AP 1. When AP 1’s load reaches the upper 
limit, Client LB is connected with AP 2. 

Figure 49-3 Network diagram for load balancing  
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Requirement of WLAN load-balancing implementation 
As shown in Figure 49-4, Client 6 wants to associate with AP 3. Because AP 3 has reached its 
maximum load, it rejects the association request. After that, Client 6 tries to associate with AP 1 or AP 2, 
but it cannot receive signals from these two APs, so it has to resend an association request to AP 3. 

Therefore, to implement load-balancing, the APs should be associated with the same AC, and the 
clients can find the APs.  
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Figure 49-4 Requirement of WLAN load-balancing implementation 
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Load-balancing entities 
Currently, the AC supports AP load balancing and radio load balancing. 

 AP load balancing 

Load balancing is carried out on an AP either based on the number of users connected with it or based 
on the traffic load on it. The AP will start load balancing when the threshold and load gap are reached, 
and will not accept any further associations unless the load decreases below the threshold, a client is 
not able to associate with any other AP, or the load gap is less than the pre-defined limit.  

 Radio load balancing 

Load balancing can be carried out on a radio only when its AP is not overloaded. A radio will start load 
balancing when the threshold and maximum load gap are reached and will reject any further 
associations unless the load decreases below the threshold, a client is not able to associate with any 
other radio, or the load gap is less than the pre-defined limit. 

Load-balancing modes 
Currently, the AC supports two load balancing modes, session mode and traffic mode.  

 Session mode load-balancing: 

Session-mode load balancing is based on the number of users associated with the AP/radio.  

As shown in Figure 49-5, Client 1 is associated with AP 1, and Client 2 through Client 6 are associated 
with AP 2. The AC has user-based load balancing configured: the maximum number of sessions is 5 
and the maximum load gap is 4. Then, Client 7 sends an association request to AP 2. The session 
threshold and load gap have been reached on AP 2, so it rejects the request. At last, Client 7 associates 
with AP 1. 
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Figure 49-5 Network diagram for user-based load balancing 

 

 

 Traffic mode load-balancing: 

When the traffic mode is configured, traffic snapshot is considered for load balancing. 

As shown in Figure 49-6, Client 1 and Client 2 that adopt 802.11g radio mode are associated with AP 1. 
The AC has traffic-mode load balancing configured: the maximum traffic threshold is 10% and the 
maximum traffic gap is 20%. Then, Client 3 wants to access the WLAN. When the maximum traffic 
threshold and traffic gap have been reached on AP 1, it rejects the request. At last, Client 3 associates 
with AP 2. 

Figure 49-6 Network diagram for traffic-based load balancing 
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AP Settings 

AP setting includes two parts: 
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 AP version settings: A fit AP is a zero-configuration device. It can automatically discover an AC 
after power-on. To ensure that a fit AP can associate with an AC, their software versions must be 
consistent by default, which complicates maintenance. This task allows you designate the software 
version of an AP on the AC, so that they can associate with each other even if their software 
versions are inconsistent. 

 AP working mode switching: Switches the working mode of an AP between the fit mode and the fat 
mode. 

 Wireless Location 

 

 

Support for the wireless location feature depends on your device model. 

 

Wireless location is a technology to locate, track and monitor specified devices by using WiFi-based 
Radio Frequency Identification (RFID) and sensors. With this function enabled, APs send Tag or MU 
messages to an AeroScout Engine (referred to as AE hereinafter), which performs location calculation 
and then sends the data to the graphics software. You can get the location information of the assets by 
maps, forms, or reports. Meanwhile, the graphics software provides the search, alert and query 
functions to facilitate your operations. 

Wireless location can be applied to medical monitoring, asset management, and logistics, helping users 
effectively manage and monitor assets. 

Architecture of the wireless location system 
A wireless location system is composed of three parts: devices or sources to be located, location 
information receivers and location systems. 

 Devices or sources to be located, which can be Tags (small, portable RFIDs, which are usually 
placed or glued to the assets to be located) of Aero Scout or Mobile Units (MU), that is, wireless 
terminals or devices running 802.11. These devices can send wireless messages periodically. 

 Location information receivers, for example, 802.11 APs, and AeroScout Exciters that are standard 
compliant Tags to send wireless messages but do not collect location information. 

 Location systems, including location server, AE calculation software, and different types of 
graphics software. 

Wireless locating process 
A wireless location system can locate wireless clients, APs, rogue APs, rogue clients, Tags and other 
devices supporting WLAN protocols. Except Tags, all wireless devices will be identified as MUs by the 
wireless location system. 

1) Send Tag and MU messages 

A Tag message is a message sent by an RFID. A Tag message contains the channel number so that an 
AP can filter Tag messages whose channel numbers are not consistent with the AP’s operating channel. 
To ensure that more Tags can be detected by the AP, a Tag sends messages on different channels. 
Generally, a Tag periodically sends messages on one or multiple pre-configured channels, and then 
sends location messages on channels 1, 6, and 11 in turn periodically. 
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MU messages are sent by standard wireless devices. An MU message does not contain the channel 
number; therefore, an AP cannot filter MU messages whose channel numbers are not consistent with 
the AP’s operating channel or illegal packets, which is done by the location server according to a certain 
algorithm and rules. 

2) Collect Tag and MU messages 

The working mode of an AP determines how it collects Tag and MU messages: 

 When the AP works in monitor mode or hybrid mode, it can locate wireless clients or other wireless 
devices that are not associated with it. 

 When the AP works in normal mode, it can only locate wireless clients associated with it. The 
wireless location system considers wireless clients associated with the AP as wireless clients, and 
considers wireless clients or other wireless devices not associated with the AP as unknown 
devices. 

 

 

 For more information about monitor mode and hybrid mode, see Security Configuration. 

 An AP works in normal mode when it functions as a WLAN access point. For more information, see 
Wireless Service Configuration. 

 

After the processes, the AP begins to collect Tag and MU messages. 

 Upon receiving Tag messages (suppose that the Tags mode has been configured on the AC, and 
the location server has notified the AP to report Tag messages), the AP checks the Tag messages, 
encapsulates those passing the check and reports them to the location server. The AP 
encapsulates Tag messages by copying all the information (message header and payload 
inclusive) except the multicast address, and adding the BSSID, channel, timestamp, data rate, 
RSSI, SNR and radio mode of the radio on which the relevant Tag messages were received. 

 Upon receiving MU messages (suppose that the MUs mode has been configured on the AC, and 
the location server has notified the AP to report MU messages), the AP checks the messages, 
encapsulates those that pass the check and reports the messages to the location server. The AP 
encapsulates an MU message by copying its source address, Frame Control field and Sequence 
Control field, and adding the BSSID, channel, timestamp, data rate, RSSI, SNR and radio mode of 
the radio on which the relevant Tag messages were received. 

3) Calculate the locations of Tags or MUs 

After receiving Tag and MU messages from APs, the location server uses an algorithm to calculate the 
locations of the Tag and MU devices according to the RSSI, SNR, radio mode and data rate carried in 
the messages, and displays the locations on the imported map. Typically, a location server can 
calculate the locations as long as more than 3 APs working in monitor or hybrid report Tag or MU 
messages. 
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Configuring WLAN Advanced Settings 

Setting a District Code 

Select Advanced > District Code from the navigation tree to enter the page for setting a district code, 
as shown in Figure 49-7. 

Figure 49-7 Set a district code 

 
 

Table 49-1 shows the configuration item of setting a district code. 

Table 49-1 Configuration item of setting a district code 

Item Description 

District Code 
Select a district code. 
Configure the valid district code for a WLAN device to meet the country regulations.

 

 

If the drop-down list is grayed out, the setting is preconfigured to meet the requirements of the target 
market and is locked. It cannot be changed. 

 

Configuring AC Backup 

Backup setup 
Select Advanced > AC Backup from the navigation tree to enter the page for configuring AC backup, 
as shown in Figure 49-8. 
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Figure 49-8 Configure AC backup 

 

 

Table 49-2 shows the configuration items of configuring AC backup. 

Table 49-2 Configuration items of configuring AC backup 

Item Description 

IPv4 
Select the IPv4 check box, and type the IPv4 address of the backup AC. If the 
backup AC is configured on the page you enter by selecting AP > AP Setup, 
the configuration is used in precedence. 

IPv6 
Select the IPv6 check box, and type the IPv6 address of the backup AC. If the 
backup AC is configured on the page you enter by selecting AP > AP Setup, 
the configuration is used in precedence. 

Fast Backup Mode 
disable: Disables fast backup. 
enable: Enables fast backup. 
By default, fast backup is disabled. 

Hello Interval 
Heartbeat interval, in milliseconds, for an AC connection. 
If no heartbeat is received during the continuous three intervals, the device 
considers the peer is down. 

VLAN ID ID of the VLAN to which the port where the backup is performed belongs 

Backup Domain ID ID of the domain to which the AC belongs 

 

 

 The wireless services configured on the two ACs should be consistent, that is, the access mode 
configuration must be the same.  

 Specify one AC on the other AC in an AC backup. 

 Do not configure the ACs in a roaming group for AC backup. 
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Displaying status information 
Select Advanced > AC Backup from the navigation tree and select the Status tab to enter the page as 
shown in Figure 49-9. 

Figure 49-9 Status information 

 
 

Table 49-3 Fast backup status 

Field Description 

AP Name Select to display the AP connecting to the AC. 

Status Current status of the current AC 

Vlan ID ID of the VLAN to which the port belongs. 

Domain ID The domain to which the AC belongs. 

Link State 

Link status of the AC connection: 
 Close: Means no connection is established. 
 Init: Means the connection is being set up. 
 Connect: Means the connection has been established. 

Peer Board MAC MAC address of the peer AC. 

Peer Board State 

Status of the peer AC. 
 Normal: Means the peer AC is normal. 
 Abnormal: Means the peer AC is malfunctioning. 
 Unknown: Means no connection is present. 

Hello Interval Heartbeat interval for an AC connection.  

 

Configuring AC backup 
Select AP > AP Setup from the navigation tree to enter the page for configuring AP. Select the target AP, 

and then click the icon  in the operation column to enter the page as shown in Figure 49-10. 
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Figure 49-10 Configure AC backup 

 

 

Table 49-4 describes the configuration items of configuring AC backup. 

Table 49-4 Configuration items of configuring AC backup 

Item Description 

Backup AC IPv4 Address 
Set the IPv4 address of the backup AC. If the global backup AC is also 
configured on the page you enter by selecting Advanced > AC Backup, the 
configuration here is used in precedence. 

Backup AC IPv6 Address 
Set the IPv6 address of the backup AC. If the global backup AC is also 
configured on the page you enter by selecting Advanced > AC Backup, the 
configuration here is used in precedence. 

 

Configuring connection priority 
Select AP > AP Setup from the navigation tree to enter the page for configuring AP. Select the target AP, 

and then click the corresponding icon  to enter the page as shown in Figure 49-11. 
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Figure 49-11 Configure connection priority 

 
 

Table 49-5 describes the configuration items of configuring connection priority. 

Table 49-5 Connection priority configuration items 

Item Description 

AP Connection Priority Set the priority for the AP connection to the AC. 

 

Configuring Load Balancing 

Configuration prerequisites 
Before configuring load balancing, make sure that: 

 The target APs are associated with the same AC. 

 The clients can find the APs. 

Configuration task list 
Perform the following tasks to configure load balancing: 

Task Remarks 

Configuring a load balancing mode Required 

Configuring AP-based load 
balancing 

Configuring group-based load 
balancing 

Required 
Use either approach 

 AP-based load balancing: After you complete Configuring a load 
balancing mode, the AC adopts by default. 

 Group-based load balancing: You are recommended to complete 
Configuring a load balancing mode first. A load balancing group 
takes effect only when a load balancing mode is configured. 
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Configuring a load balancing mode 
 

 

If the AC has a load balancing mode configured but has no load balancing group created, it adopts 
AP-based load balancing by default. 

 

1) Configure session-mode load balancing 

Select Advanced > Load Balance from the navigation tree to enter the page for setting load balancing, 
as shown in Figure 49-12. 

Figure 49-12 Set session-mode load balancing 

 
 

Table 49-6 shows the configuration items of configuring session-mode load balancing. 

Table 49-6 Configuration items of configuring session-mode load balancing 

Item Description 

Loadbalance Mode Select Session. 

Threshold Load balancing is carried out for a radio when the session threshold and 
session gap threshold are reached. 

Gap Load balancing is carried out for a radio when the session threshold and 
session gap threshold are reached. 

 

2) Configure traffic-mode load balancing 

Select Advanced > Load Balance from the navigation tree to enter the page for setting load balancing, 
as shown in Figure 49-13. 
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Figure 49-13 Set traffic-mode load balancing 

 

 

Table 49-7 shows the configuration items of configuring traffic-mode load balancing. 

Table 49-7 Configuration items of configuring traffic-mode load balancing 

Item Description 

Loadbalance Mode Select Traffic. 

Traffic Load balancing is carried out for a radio when the traffic threshold and traffic 
gap threshold are reached. 

Gap Load balancing is carried out for a radio when the traffic threshold and traffic 
gap threshold (the traffic gap between the two APs) are reached. 

 

 

The maximum throughput of 802.11g/802.11a is 30 Mbps. 

 

Configuring group-based load balancing 
 

 

You are recommended to complete Configuring a load balancing mode on the Load Balance tab page. 
A load balancing group takes effect only when a load balancing mode is configured. 

 

Select Advanced > Load Balance Group from the navigation tree, select the Load Balance Group 
tab to enter the page for configuring a load balancing group, and click Add. A page as shown in Figure 
49-14 appears. 
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Figure 49-14 Configure a load balancing group 

 
 

Table 49-8 shows the load balancing group configuration items. 

Table 49-8 Load balancing group configuration items 

Item Remarks 

Group ID Displays the ID of the load balancing group 

Description 
Configure a description for the load balancing group. 
By default, the load balancing group has no description. 

Radio List 

 In the Radios Available area, select the target radios, and then click << to add them 
into the Radios Selected area. 

 In the Radios Selected area, select the radios to be removed, and then click >> to 
remove them from the load balancing group. 

 

Configuring AP 

Setting AP version 
Select Advanced > AP from the navigation tree, click the AP Module tab, select the desired AP, and 
then click Version Update to enter the page for AP version upgrade. 

Table 49-9 shows the configuration items of AP upgrade. 

Table 49-9 Configuration items of AP version upgrade 

Item Description 

AP Model Displays the selected AP model. 

Software Version Type the software version of the AC in a correct format. 

 

Switching to fat AP 
Select Advanced > AP Setup from the navigation tree, select the Switch to Fat AP tab, select the 
desired AP, and then click Switch to Fat AP to perform AP working mode switchover. 
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Before switching the work mode, you must download the fat AP software to the AP. Then select Device 
> Software Upgrade from the navigation tree to enter the page where you can get the application file 
from the local host. 

 

Configuring Wireless Location 

Select Advanced > Wireless Location from the navigation tree to enter the page for displaying and 
configuring wireless location on an AC, as shown in Figure 49-15. 

Figure 49-15 Wireless location configuration page 

 

 

Table 49-10 describes the configuration items of wireless location. 

Table 49-10 Wireless location configuration items 

Item Description 

Location Function 

 Enable: Enables the wireless location function globally. The device begins to listen to 
packets when wireless location is enabled. 

 Disable: Disables wireless location globally. 
To ensure the location function, complete the configuration on the location server and AC:

 On the location server: Configure whether to locate Tags or MUs, Tag message 
multicast address, and dilution factor on the location server. These settings will be 
notified to the APs through the configuration message. For more information about 
location server and configuration parameters, see the location server manuals. 

 On the AC: Configure the AP mode settings, and enable the wireless location function.
When configurations are correctly made, APs wait for the configuration message sent by 
the location server, and after receiving that message, start to receive and report Tag and 
MU messages.  
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Item Description 

Vendor Port Set listening port number for vendors. The port number must be the same as that defined 
in AE. 

Tag Mode Select this check box to enable the Tag report function on the radio (you also need to 
enable Tags mode on the AE). 

MU Mode Select this check box to enable the MU report function on the radio (you also need to 
enable the MUs mode on the AE). 

 

 

An AP reports IP address change and device reboot events to the location server so that the location 
server is able to respond in time. The AP reports a reboot message according to the IP address and port 
information of the location server recorded in its flash.  

 The AP updates the data in the flash after receiving a configuration message. To protect the flash, 
the AP does not update the flash immediately after receiving a configuration message, but waits for 
10 minutes. If receiving another configuration message within 10 minutes, the AP only updates the 
configuration information in the cache, and when the 10-minute timer is reached, saves the cache 
information in the flash. 

 If the AP reboots within 10 minutes after receiving the first configuration message, and no 
configuration is saved in the flash, it does not send a reboot message to the location server. 

 

Advanced Setting Configuration Examples 

AC Backup Configuration Example 

Network requirements 
As shown in Figure 49-16, AC 1 and AC 2 are connected to a Layer 2 switch. An AP (serial ID 
210235A045B05B1236550) is connected to AC 1 and AC 2 through the L2 switch. AC 1, AC 2 and the 
AP are in the same network. The AP gets its IP address from the DHCP server. The IP address of AC 1 
is 10.18.1.1 and the IP address of AC 2 is 10.18.1.2. AC 1 is working in master mode while AC 2 is 
working in slave mode. When AC 2 detects that AC 1 is down, AC 2 converts its work mode from slave 
to master. The AP that is connected to AC 2 through a slave tunnel will transform the tunnel mode to 
master and use AC 2 as the master AC. 
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Figure 49-16 Network diagram for configuring AC backup 
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1) Configuration on AC 1 

# Configure AP, and establish a CAPWAP connection between AC 1 and AP. 

For the related configuration, refer to Wireless Service Configuration. 

# Configure the IP address of the backup AC. 

Select Advance > AC Backup from the navigation tree to enter the page for configuring the IP address 
of the backup AC, as shown in Figure 49-17. 

Figure 49-17 Configure the IP address of the backup AC 

 
 

 Select the IPv4 checkbox, and set the IP address of the backup AC to 10.18.1.2. 

 Click Apply. 

2) Configuration on AC 2 

# Configure AP, and establish a CAPWAP connection between AC 2 and AP. 

For the related configuration, refer to Wireless Service Configuration. 

# Configure the IP address of the backup AC. 

Select Advanced > AC Backup from the navigation tree to enter the page for configuring the IP 
address of the backup AC, as shown in Figure 49-18. 

Figure 49-18 Configure the address of the backup AC 

 
 

 Select the IPv6 check box, and set the address of the backup AC to 10.18.1.1. 

 Click Apply. 
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Configuration guidelines 
 The wireless services configured on the two ACs should be consistent. 

 You can select Overview > AP or AP > AP Setup from the navigation tree to view the AP status, 
and you can see the AP status on the two ACs only after you configure the IP address of the AC.  

 Specify the backup AC on each AC. 

 AC backup has no relation with the access authentication method; however, the authentication 
method of the two ACs must be the same. 

 Do not configure the ACs in a roaming group for AC backup. 

AP-Based Session-Mode Load Balancing Configuration Example 

Network requirements 
 As shown in Figure 49-19, all APs operate in 802.11g mode. Client 1 is associated with AP 1. Client 

2 through Client 6 are associated with AP 2. 

 Configure session-mode load balancing on the AC. The threshold, that is, the maximum number of 
sessions, is 5, and the session gap is 4. 

Figure 49-19 Network diagram for configuring session-mode load balancing 

 

 

Configuration procedure 
1) Before configuring load balancing, complete the following: 

 Configure AP 1 and AP 2 on the AC to establish a CAPWAP connection between the AC and each 
AP. For the related configuration, see Wireless Service. 

2) Configure session-mode load balancing 

Select Advanced > Load Balance from the navigation tree to enter the page for setting load balancing, 
as shown in Figure 49-20. 
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Figure 49-20 Set session-mode load balancing 

 

 

 Select the Session mode. 

 Type the threshold 5, and use the default value for the gap. 

 Click Apply. 

Configuration verification 
Client 1 is associated with AP 1, and Client 2 through Client 6 are associated with AP 2. Because the 
number of clients associated with AP 1 reaches 5, and the session gap between AP 2 and AP 1 reaches 
4, Client 7 is associated with AP 1. 

Configuration guidelines 
An AP starts session-mode load balancing only when both the maximum sessions and maximum 
session gap are reached. 

AP-Based Traffic-Mode Load Balancing Configuration Example 

Network requirements 
 As shown in Figure 49-21, all APs operate in 802.11g mode. Client 1 and Client 2 are associated 

with AP 1, and no client is associated with AP 2. 

 Configure traffic-mode load balancing on the AC. The traffic threshold is 3 Mbps that corresponds 
to the threshold value of 10 in percentage, and the traffic gap is 12 Mbps that corresponds to the 
traffic gap value 40 in percentage. 
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Figure 49-21 Network diagram for configuring traffic-mode load balancing 

 

 
 

Configuration procedure 
1) Before configuring load balancing, complete the following: 

 Configure AP 1 and AP 2 on the AC to establish a CAPWAP connection between the AC and each 
AP. For the related configuration, see Wireless Service. 

2) Configure traffic-mode load balancing 

Select Advanced > Load Balance from the navigation tree to enter the page for setting load balancing, 
as shown in Figure 49-22. 

Figure 49-22 Set traffic-mode load balancing 

 
 

 Select the Traffic mode. 

 Type the threshold 10, and the traffic gap 40. 

 Click Apply. 

Configuration verification 
Client 1 and Client 2 are associated with AP 1. Add Client 3 to the network. When the maximum traffic 
threshold and traffic gap are reached on AP 1, Client 3 is associated with AP 2. 
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Configuration guidelines 
An AP starts traffic-mode load balancing only when both the maximum traffic threshold and maximum 
traffic gap are reached. 

Group-Based Session-Mode Load Balancing Configuration Example 

Network requirements 
 As shown in Figure 49-23, all APs operate in 802.11g mode. Client 1 is associated with AP 1. Client 

2 through Client 6 are associated with AP 2, and no client is associated with AP 3. 

 Configure session-mode load balancing on the AC. The maximum number of sessions is 5 and the 
maximum session gap is 4. 

 Session-mode load balancing is required on only radio 2 of AP 1 and radio 2 of AP 2. Therefore, 
add them into a load balancing group. 

Figure 49-23 Network diagram for group-based session-mode load balancing 
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Configuration procedure 
1) Before configuring load balancing, complete the following task: 

 Configure AP 1 and AP 2 on the AC to establish a CAPWAP connection between the AC and each 
AP. For the related configuration, see Wireless Service. 

2) Configure load balancing 

Select Advanced > Load Balance from the navigation tree, and then select Load Balance to enter the 
load balancing group configuration page, as shown in Figure 49-24. 
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Figure 49-24 Configure session-mode load balancing 

 

 

 Select Session from the Loadbalance Mode drop-down list. 

 Type the threshold 5, and use the default value for the gap. 

 Click Apply. 

3) Configure a load balancing group 

Select Advanced > Load Balance from the navigation tree, and then select the Load Balance Group 
tab to enter the load balancing group configuration page. Then click Add, and a page as shown in 
Figure 49-25 appears. 

Figure 49-25 Load balancing group configuration 

 

 

 In the Radios Available area, select the target radios, and then click << to add them into the 
Radios Selected area. 

 Click Apply. 
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Configuration verification 
 Radio 2 of AP 1 and radio 2 of AP 2 are in the same load balancing group, and the radio of AP 3 

does not belong to any load balancing group. Because load balancing takes effect on only radios in 
a load balancing group, AP 3 does not take part in load balancing. 

 Assume Client 7 wants to associate with AP 2. Because the number of clients associated with AP 2 
reaches 5, and the session gap between AP 2 and AP 1 reaches 4, Client 7 is associated with AP 
1. 

Group-Based Traffic-Mode Load Balancing Configuration Example 

Network requirements 
 As shown in Figure 49-26, all APs operate in 802.11g mode. Client 1 and Client 2 are associated 

with AP 1, and no client is associated with AP 2 and AP 3. 

 Configure traffic-mode load balancing on the AC. The maximum traffic threshold is 10% and the 
maximum traffic gap is 20%. 

 Traffic-mode load balancing is required on only radio 2 of AP 1 and radio 2 of AP 2. Therefore, add 
them to a load balancing group. 

Figure 49-26 Network diagram for group-based traffic-mode load balancing 
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Configuration procedure 
1) Before configuring load balancing, complete the following task: 

 Configure AP 1 and AP 2 on the AC to establish a CAPWAP connection between the AC and each 
AP. For the related configuration, see Wireless Service. 

2) Configure load balancing 

Select Advanced > Load Balance from the navigation tree to enter the load balancing configuration 
page, as shown in Figure 49-27. 
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Figure 49-27 Configure traffic load balancing 

 

 

 Select Traffic from the Loadbalance Mode drop-down list. 

 Type the threshold 10 and the gap 40. 

 Click Apply. 

3) Configure a load balancing group 

Select Advanced > Load Balance from the navigation tree, and then select the Load Balance Group 
tab to enter the load balancing group configuration page. Then click Add, and a page as shown in 
Figure 49-28 appears. 

Figure 49-28 Load balancing group configuration 

 

 

 In the Radios Available area, select the target radios, and then click << to add them into the 
Radios Selected area. 

 Click Apply. 
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Configuration verification 
 Radio 2 of AP 1 and radio 2 of AP 2 are in the same load balancing group, and the radio of AP 3 

does not belong to any load balancing group. Because load balancing takes effect on only radios in 
a load balancing group, AP 3 does not take part in load balancing. 

 Assume Client 3 wants to associate with AP 1. Because the maximum traffic threshold and traffic 
gap have been reached on AP 1, Client 3 is associated with AP 2. 

Wireless Location Configuration Example 

Network requirements 
As shown in Figure 49-29, AP 1, AP 2, and AP 3 work in monitor mode, and send the collected tag and 
MU messages to an AE (the location server), which performs location calculation and then sends the 
data to the graphics software. You can get the location information of the rogue AP, APs, and clients by 
maps, forms or reports.  

Figure 49-29 Network diagram for configuring wireless location 

 

 

Configuration procedure 
1) Configure the AE. 

 Configure the IP addresses of AP 1, AP 2, and AP 3 on the AE, or select broadcast for the AE to 
discover APs. 

 Perform configuration related to wireless location on the AE. 

2) On the AC, configure AP 1, AP 2, and AP 3 to work in monitor mode. 

AP 1, AP 2, and AP 3 are configured similarly, and thus this section only describes how to configure AP 
1 for illustration. 

# Create AP 1. 

Select AP > AP Setup from the navigation tree, and click New to enter the page for adding an AP, as 
shown in Figure 49-30. 
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Figure 49-30 Create an AP 

 

 

 Type ap1 as the name for the AP.  

 Select the model WA2220X-AG. 

 Select manual from the Serial ID drop-down list and type the AP serial ID in the text box. 

 Click Apply. 

# Configure AP to work in monitor mode. 

Select Security > Rogue Detection from the navigation tree, and then select the AP Monitor tab. On 
the page, select the AP to be configured and click the icon  to enter the page for configuring the work 
mode, as shown in Figure 49-31. 

Figure 49-31 Set the work mode 

 

 

 Select Monitor as the work mode. 

 Click Apply.  

# Enable 802.11g. 

Select Radio > Radio from the navigation tree to enter the page for configuring radio, as shown in 
Figure 49-32. 

Figure 49-32 Enable 802.11g 

 

 

 Locate the target APs and select the check boxes before the APs. 
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 Click Enable.  

3) Configure wireless location. 

Select Advanced > Wireless Location from the navigation tree to enter the page for displaying and 
configuring wireless location on a fat AP, as shown in Figure 49-33. 

Figure 49-33 Wireless location configuration page 

 

 

 Select Enable to enable the location function globally. 

 Select the check boxes of tag mode and MU mode for 802.11g to enable the Tag report function 
and MU report function. 

 Click Apply. 

Verification 
You can display the location information of the rogue AP, APs, and clients by maps, forms or reports. 

Configuration guidelines 
 Before enabling the wireless location function, ensure that at least three APs work in monitor or 

hybrid mode so that the APs can detect Tags and clients not associated with them, and the AE can 
implement location calculation. 

 Because an AP monitors clients on different channels periodically, if the Tag message sending 
interval is configured as 1 second, the AP scans and reports Tag messages every half a minute. If 
higher location efficiency is required, you can set the Tag sending interval to the smallest value, 
that is, 124 milliseconds. 
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50  Stateful Failover Configuration 

 

 

 Support for Stateful Failover depends on the device model.. Refer to section "Feature Matrixes" in 
Compatibility Matrixes for details. 

 The sample output in this manual was created on the WX5004. The output on your device may 
vary. 

 The grayed out functions or parameters on the Web interface indicate that they are not supported 
or cannot be modified. 

 The models listed in this manual are not applicable to all regions. Please consult your local sales 
office for the models applicable to your region. 

 

Overview 

Introduction to Stateful Failover 

Some customers require their wireless networks to be highly reliable to ensure continuous data 
transmission. In Figure 50-1, deploying only one AC (even with high reliability) risks a single point of 
failure and therefore cannot meet the requirement.  

Figure 50-1 Network with one AC deployed 
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The stateful failover feature (supporting portal service currently) is introduced to meet the requirement. 
In Figure 50-2, two ACs that are enabled with stateful failover are deployed in the network. You need to 
specify a VLAN on the two ACs as the backup VLAN, and add the interfaces between the ACs to the 
backup VLAN. The backup VLAN is like a failover link, through which the two ACs exchange state 
negotiation messages periodically. After the two ACs enter the synchronization state, they back up the 
service entries of each other to ensure that the service entries on them are consistent. If one AC fails, 
the other AC, which has already backed up the service information, can take over the services, thus 
avoiding service interruption.  

Figure 50-2 Network diagram for stateful failover 
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Introduction to Stateful Failover States 

The stateful failover states include: 

 Silence: Indicates that the device is just started and waiting for the stable running of the system, or 
the state between synchronization and independence. 

 Independence: Indicates that the silence timer expires, but no backup link to any other device is 
established. 

 Synchronization: Indicates that state negotiation with another device is complete and ready for 
data backup. 

The following figure shows state relations. 
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Figure 50-3 Stateful failover state diagram 

 

 

Configuring Stateful Failover 

Select High reliability > Stateful Failover from the navigation tree to enter the stateful failover 
configuration page, as shown in Figure 50-4. 

Figure 50-4 Stateful failover configuration page 

 

 

Table 50-1 describes the stateful failover configuration items. 

Table 50-1 Stateful failover configuration items 

Item Description 

Enable Stateful Failover Enable/disable the stateful failover feature. 

Backup Type 

Select whether to support asymmetric path. 
This option is available when the Enable Stateful Failover check box is selected. 

 Unsupport Asymmetric Path. When the two devices operate normally, each 
session goes in and out the internal network through the same device. that is, the 
master device, and the other device serves as the backup.  

 Support Asymmetric Path. When two devices operate normally, a session can 
go into the internal network through one device and go out through the other 
device. That is, the session passes through one of the two devices randomly 
when leaving the internal network, thus to achieve load sharing. The two devices 
work in the load sharing mode and serve as backup for each other.  
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Item Description 

Backup VLAN 

Set the backup VLAN. 
After a VLAN is configured as a backup VLAN, the interface(s) in the VLAN is used 
to transmit stateful failover packets.  

 
 A device uses VLAN tag+protocol number to identify stateful failover packets, 

and broadcasts stateful failover packets to the peer within the backup VLAN. 
Therefore, you are not recommended to configure other services (such as voice 
VLAN) for a backup VLAN to avoid impact on the operation of stateful failover. 

 An interface added to the backup VLAN can transmit other packets besides 
stateful failover packets.  

 

The lower part of the page displays the current stateful failover configuration. 

Table 50-2 Current stateful failover configuration information 

Display information Description 

Current Status Displays the hot backup state of the device. 

 

Stateful Failover Configuration Example 

Network requirements 
In Figure 50-5, the IP address of VLAN-interface 1 on AC 1 is 8.190.1.60/24, and that on AC 2 is 
8.190.1.61/24. In the wireless network, configure AC 1 and AC 2 to backup each other, so that when 
one device fails, the other device takes over the services to ensure portal service continuity.  

Figure 50-5 Stateful failover network diagram 
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Configuration procedure 
 

 

 Before performing the following configuration, you need to configure a portal server and enable 
portal authentication on VLAN-interface 1.  

 The portal group configuration on the two stateful failover devices must be consistent.  

 

1) Configure AC 1. 

# Create VLAN 2, add interface GigabitEthernet 1/0/2 to VLAN 2 and configure the interface to send 
packets with VLAN 2 tagged (omitted).  

# Configure failover link support for CAPWAP so as to ensure that traffic can switch to AC 2 when AC 1 
fails.  

Select Advanced > AC Backup from the navigation tree to enter the default Setup page, as shown in 
Figure 50-6. Then perform the following settings on the page:  

Figure 50-6 Setup page 

 

 

 Select the IPv4 check box and type the IP address of AC 2 (8.190.1.61) as the backup AC address.  

 Select enable for Fast Backup Mode.  

 Click Apply.  

# Configure stateful failover.  

 Select High reliability > Stateful Failover from the navigation tree to enter the page as shown in 
Figure 50-7. Then perform the following settings on the page:  
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Figure 50-7 Stateful failover configuration 

 

 

 Select the Enable Stateful Failover check box. 

 Select Support Asymmetric Path for Backup Type. 

 Type 2 for Backup VLAN.  

 Click Apply. 

Configure portal to support stateful failover at the command line interface: 

# Specify AC 2’s IP address as the backup source IP address for RADIUS packets to be sent.  
[AC1]radius nas-backup-ip 8.190.1.54  

# Specify the device ID to be used in stateful failover mode as 1.  
[AC1]nas device-id 1  

# Specify portal group 2 for interface VLAN-interface 1. 
[AC1]interface Vlan-interface 1 

[AC1-Vlan-interface1]portal backup-group 2 

2) Configure AC 2. 

The configuration on AC 2 is similar to that on AC 1 except that: 

 When configuring AC backup, specify AC 1’s IP address as the backup AC address.  

 Specify AC 1’s IP address as the backup source IP address for RADIUS packets to be sent, and 
specify the device ID to be used in stateful failover mode as 2. 

The configuration on AC 2 is omitted here. For details, refer to the configuration on AC 1.  

Configuration Guidelines 

1) You need to configure stateful failover link support on CAPWAP to ensure that the traffic can 
automatically switch to the other device if one device fails. For details, refer to Advanced Settings.  

2) Currently, only two hot backup devices are supported. 

3) You need to configure portal stateful failover to implement portal service backup. For details, refer 
to Portal Configuration in the Security Volume of H3C WX Series Access Controllers  User Manual. 
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