システム管理
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

GCCがインストールできません!

So_K
アドバイザー

GCCがインストールできません!

OS: HP-UX11i v1 に

gcc3.4.2をインストールしたく、

http://h21007.www2.hp.com/dspp/tech/tech_TechSoftwareDetailPage_IDX/1,1703,547,00.html

より、「GCC 3.4.2 PA-RISC 11i v1 」

をダウンロードし、解凍後 swinstall

を実行したところ、

下記のエラーとなりました。

どのように解決すれば良いかを教えて下さい。

---------------------------------------------------------------------

* Source:

PWMHSU07:/var/src/gcc/gcc_3.4.2_hppa-hp-hpux11.11_depot

* Target: PWMHSU07:/

* Target logfile: PWMHSU07:/var/adm/sw/swagent.log

* Reading source for product information.

* Reading source for file information.

The corequisite "binutils.binutils" for fileset

"gcc.gcc,r=3.4.2" cannot be successfully resolved.

ERROR: The dependencies for fileset "gcc.gcc,r=3.4.2" cannot be

resolved (see previous lines).

You must resolve the above dependencies before operating on

this fileset or change the "enforce_dependencies" option to

"false".

* Executing preDSA command.

* Summary of Analysis Phase:

ERROR: Exclude gcc.gcc,r=3.4.2

ERROR: 1 of 1 filesets had Errors.

ERROR: The Analysis Phase had errors. See the above output for

details.

---------------------------------------------------------------------

以上
6 件の返信
isao
頻繁なアドバイザー

GCCがインストールできません!

エラーは、binutilのファイルセットが入っていないというものです。

上記URLのREADMEを読むと、GCCをインストールするときには、binutilのパッケージが必須とあります。

上記URLからbinutilのパッケージをダウンロードして試してみたらどうでしょう。
So_K
アドバイザー

GCCがインストールできません!

isaoさん、レスありがとうございました。

binutils_2.15_hppa-hp-hpux11.11_depot をインストールしたところ、

下記エラーとなりました。

どのように解決すれば良いか、教えて下さい。

-----------------------------------------------------------------------

* Installing fileset "binutils.binutils,r=2.15" (1 of 1).

ERROR: Could not access remote file "/usr/local/bin/addr2line" in

software item "binutils.binutils,r=2.15,a=,v=:/usr/local" due

to an internal error on the remote system.

ERROR: Failed installing fileset "binutils.binutils,r=2.15". Check

the above output for details.

* Retry number 1 of 1 for loading files for fileset

"binutils.binutils,r=2.15".

* Installing fileset "binutils.binutils,r=2.15" (1 of 1).

ERROR: Could not access remote file "/usr/local/bin/addr2line" in

software item "binutils.binutils,r=2.15,a=,v=:/usr/local" due

to an internal error on the remote system.

ERROR: Failed installing fileset "binutils.binutils,r=2.15". Check

the above output for details.

NOTE: The Install Phase has suspended. Check the above output for

reasons.

-----------------------------------------------------------------------
isao
頻繁なアドバイザー

GCCがインストールできません!

エラー内容からすると、depotの中に “/usr/local/bin/addr2line”が見つからないということではないですか?

当方でダウンロードしてインストールは問題なく通ります。

# tar tvf binutils_2.15_hppa-hp-hpux11.11_depot | grep addr2line

と実行したら、その中にbinutils/binutils/usr/local/bin/addr2line

は見つかりますか?

depotが壊れているかもしれないのでもう一度ダウンロードしてインストールしなおしてみればいかがでしょう?

So_K
アドバイザー

GCCがインストールできません!



お世話になっております。

> # tar tvf binutils_2.15_hppa-hp-

> pux11.11_depot | grep addr2line

> と実行したら、その中に

> binutils/binutils/usr/local/bin/addr2line

> は見つかりますか?

以下結果より見つかります。

この先どうしたら良いのでしょうか?

質問ばかりですみませんが

ご教示ください。

# tar tvf binutils_2.15_hppa-hp-hpux11.11_depot | grep addr2line

r-xr-xr-x 2/2 401440 May 20 16:28 2004 binutils/binutils/usr/local/bin/addr2line

r--r--r-- 2/2 7535 May 20 16:24 2004 binutils/binutils/usr/local/man/man1/addr2line.1

r-xr-xr-x 2/2 729130 May 20 16:28 2004 binutils/binutils/usr/local/pa64/bin/hppa64-hp-hpu

x11.11-addr2line

r--r--r-- 2/2 7535 May 20 16:27 2004 binutils/binutils/usr/local/pa64/man/man1/hppa64-h

p-hpux11.11-addr2line.1

Na_Ka
頻繁なアドバイザー

GCCがインストールできません!

/usr/local ディレクトリはありますか?

ある場合、書き込み権限はどうでしょうか?
So_K
アドバイザー

GCCがインストールできません!

みなさん回答ありがとうございました。

以下で正常にできました。

対象プロセス:/usr/sbin/swagentd -r

(1) ps -ef |grep swagentd

root 8978 1 0 15:45:23 ? 0:00 /usr/sbin/swagentd -r

(2) kill -9 (1)のプロセス番号

(3) rm /var/adm/sw/products/swlock

(4) /usr/sbin/swagentd -r

(5) swinstall -s depot のフルパス ソフトの名前