システム管理
次の結果を表示 
次の代わりに検索 
もしかして 

Mailの通知について

頻繁なアドバイザー

Mailの通知につい

早速ですが質問させてください。

<環境>
マシン:C8000 Workstation
OS:HP-UX 11i V1.0

<実現したいこと>
 上記環境にて、dttermを起動して作業(lsやcpなどのコマンドを実行)をしていると、
「You have mail~」というメッセージがたまに表示されることがあります。
 このメールの通知を表示(ターミナルに通知させない)させないようにできないでしょうか?

 ちなみに、ユーザ同士でのメールのやり取りは一切しておらず、メールの内容を見てみると、
 メールの送信元も送信先も、同じマシンで、「Event Monitoring Service Event Notification」
 というタイトルがついています。
4 件の返信
尊敬されているコントリビューター

Mailの通知につい

root で作業されているようなので、自分用のアカウントを作成すれば、お知らせメッセージを目にすることがないのでは?

環境変数 MAILCHECK を極端に長くすることで、デフォルト 600 秒ごとのチェックを調整できますが、Disable にできませんね。
頻繁なアドバイザー

Mailの通知につい

shinji様回答ありがとうございます。
やはり、disableにはできないですか、、
商用環境ではrootユーザで作業を行っていますので、
運用のほうで対処したいと思います。
時折のビジター

Mailの通知につい

ksh.1 に

> Unsetting ERRNO, LINENO, MAILCHECK, OPTARG,
> OPTIND, RANDOM, SECONDS, TMOUT, and _ removes
> their special meaning even if they are
> subsequently assigned to.

とあるので MAILCHECK を unset してみてはいかがでしょう。

また "ksh MAILCHEK" で検索すると

> If $MAILCHECK is unset, or is set to a
> non-numeric value, checking for mail is
> disabled.

というのもありました。 HP-UX であてはまる
かどうかはわかりませんが。
頻繁なアドバイザー

Mailの通知につい

noeruke様、回答ありがとうございます。
早速試したところ、「MAILCHECK=600」のunsetでは
メッセージの表示を止めることはできませんでした、、が
「MAIL=/var/mail/root」をunsetしたところ、
止めることができました。
ちなみに、unset後に送られたメールは/var/mail/root
に保存されていました。
ありがとうございました。
//Add this to "OnDomLoad" event