システム管理
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

swinstallでパッチが適用できません(2回目)

hp-engineer
時折のコントリビューター

swinstallでパッチが適用できません(2回目)



対象環境:11i v2 (Itenium)

Oracleの前提パッチ

PHSS_33277

PHSS_33278

PHSS_33279

をswinstallしようと思うのですが適用できません。

下記 エラーメッセージからは、それぞれ

"C-ANSI-C.C,fr=C.06.00,v=HP"

"ACXX.ACXX,fr=C.06.00,v=HP"

"ACXX.ACXX-STDLIB,fr=C.06.00,v=HP"

"Auxiliary-Opt.LANG-AUX,fr=B.11.23.06,v=HP"

コンパイラ系 06.00が、インストールされていないから適用できません。のようなメッセージだと思います。ですが、実際は06.15がすでに導入されています。

■エラー時の /var/adm/sw/swagent.log

======= 10/27/07 20:30:40 JST BEGIN install AGENT SESSION (pid=21031)

* Agent session started for user "root@XXXXXX". (pid=21031)

* Beginning Analysis Phase.

* Source: XXXXXX:/tmp/20071027/depot

* Target: XXXXXX:/

* Target logfile: XXXXXX:/var/adm/sw/swagent.log

* Reading source for product information.

* Reading source for file information.

NOTE: The patch fileset "PHSS_33277.C,r=1.0" may only be installed

upon a previously installed base fileset. The specification

for this base fileset is "C-ANSI-C.C,fr=C.06.00,v=HP". Since

there is no fileset on the target or selected from the source

which matches this specification, fileset "PHSS_33277.C,r=1.0"

will be excluded.

NOTE: The patch fileset "PHSS_33278.ACXX,r=1.0" may only be

installed upon a previously installed base fileset. The

specification for this base fileset is

"ACXX.ACXX,fr=C.06.00,v=HP". Since there is no fileset on the

target or selected from the source which matches this

specification, fileset "PHSS_33278.ACXX,r=1.0" will be

excluded.

以下同様に、"ACXX.ACXX-STDLIB,fr=C.06.00,v=HP"と、"Auxiliary-Opt.LANG-AUX,fr=B.11.23.06,v=HP"に対しても同エラーが出ています。

〜略〜



* Executing preDSA command.

NOTE: The bundle "BUNDLE,r=B.11.23" is already installed. If you

wish to reinstall this bundle, change the "reinstall" option

to "true".

NOTE: Could not install the bundle "BUNDLE,r=B.11.23" because none

of its filesets could be installed.

* Summary of Analysis Phase:

* 4 of 4 filesets will be Skipped.

* The Analysis Phase succeeded.



ーーー

ところが、OSのswlistを出力すると全て最新版が導入されているような気がします。。

パッチ要求の06.00に対して06.15が導入されている。

■現在のOS swlistから対象を抜粋

# B9007AA C.11.23.

14 HP C/aC++ Developer's Bundle

# B9007AA.C-ANSI-C C.06.15 HP C/aC++ Compiler

B9007AA.C-ANSI-C.C C.06.15 C Programming Language

# B9007AA.ACXX C.06.15 HP C/aC++ Compiler

B9007AA.ACXX.ACXX C.06.15 HP aC++ Programming Language

〜略〜

B9007AA.ACXX.ACXX-STDLIB C.06.15 HP aC++ Standard library

@

# B9007AA.Auxiliary-Opt C.06.15 Auxiliary Optimizer for HP Languages.

B9007AA.Auxiliary-Opt.LANG-AUX C.06.15 Advanced Optimization Tools

この場合には、パッチはあたらない(06.15に含まれているから良い)ということでしょうか?

それとも、何か他に前提があるのでしょうか。

Oracleとしては、PHSS_33277、PHSS_33278、PHSS_33279 を前提としていても実際に後継バージョンで含まれていれば前提パッチ確認でエラーが出ても良いと思うのですがそう判断できるのでしょうか。。。

3 件の返信
ちんねん
レギュラーアドバイザー

swinstallでパッチが適用できません(2回目)

PHSS_33277 は ANSI C++ コンパイラの 6.0x 用ですよね?

システムに導入されている ANSI C++ コンパイラは 6.1x なわけですよね?

普通に考えると、アップグレード済である製品に対して、古いバージョン用のパッチをあてているのでは? と思ってしまいます。

PHSS_33277 等が ANSI C++ 6.15 に対して適用可能であるという証明はありますか?

あれば、サポートコールにすればいいと思います。
tomonari
頻繁なアドバイザー

swinstallでパッチが適用できません(2回目)

HP-UXのコンパイラは、対象バージョンの不具合修正というより、「バージョンアップ」になります。ですので、PHSS_33277はANSI-Cのバージョンを6.00から6.02にあげる働きがあります。

HP-UX用のパッケージソフトウェアで、ANSI-Cのバージョン指定が「6.02以上」の場合、「PHSS_33277が必要」と記載されたりしますよ。

既に、6.15なので、このパッチはあたらないです。たぶん、6.15が今の最新なので、これ以上にバージョンアップは現在ないので、パッチも無いと思いますよ。ITRCでパッチ検索しても見付かりませんでしたよ。

hp-engineer
時折のコントリビューター

swinstallでパッチが適用できません(2回目)

>ちんねん様

>tomonari 様

>普通に考えると、アップグレード済である製品に対して、古いバージョン用のパッチをあてているのでは? と思ってしまいます。

> 既に、6.15なので、このパッチはあたらないです。たぶん、6.15が今の最新なので、これ以上にバージョンアップは現在ないので、パッチも無いと思いますよ。ITRCでパッチ検索しても見付かりませんでしたよ。

コメントいただいている通り、要求されているバージョン以上のものが既に導入されている為、Oracleインストーラーの警告は無視できることがわかりました。

ありがとうございました。