システム管理
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

wget1.9.1でエラー

ISD
アドバイザー

wget1.9.1でエラー

wgetを取得してswinstallにてインストールしたのですが、実行時下記のエラーが出ます。

何が足りないのか教えてください。

よろしくお願い致します。

$ svr@root:/ /usr/local/bin/wget -h

/usr/lib/dld.sl: Can't find path for shared library: libcrypto.sl

/usr/lib/dld.sl: No such file or directory

Abort(coredump)
4 件の返信
テレコム担当者
尊敬されているコントリビューター

wget1.9.1でエラー

http://forums1.itrc.hp.com/service/forums/bizsupport/questionanswer.do?threadId=68546

上記を参照にすると、$SHLIB_PATH の設定が必要です。
ISD
アドバイザー

wget1.9.1でエラー

早速の回答ありがとうございます。

ちなみにSHLIB_PATHには何を設定してあげればよいのでしょう?

英文を見たのですがわかりませんでした。(涙)
yoshimura
レギュラーアドバイザー

wget1.9.1でエラー

http://hpux.connect.org.uk/hppd/hpux/Gnu/wget-1.9.1/ を見ると、

"Run-time dependencies"(実行時に依存するソフト)

として "gettext", "libiconv", "openssl", "perl" がリストされています。

エラーで見つからないといっている "libcrypto.sl"

は名前からすると暗号化関係のライブラリーの

ようで OpenSSL が関係しそうですね。

上記のサイトのリンク先から dependencies を

ダウンロードしてインストールしてみては

いかがでしょうか?

テレコム担当者
尊敬されているコントリビューター

wget1.9.1でエラー

まず、システムに libcrypto.sl が無いとだめですね。

# find / -name libcrypto.sl

また、SHLIB_PATH は、

# chatr wget

を行うと、以下のような出力があると思います。(例)

shared library list:

dynamic /lib/libm.sl

dynamic /lib/libc.sl

dynamic /usr/lib/libdld.1

上記の例の場合には、

# SHLIB_PATH=/lib:/usr/lib

# export SHLIB_PATH