系統管理
取消
顯示結果 
搜尋替代 
您的意思是: 

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

我安裝 PHP 4.3.10



當載入 Apache 時,出現此一錯誤訊息,請問我要如何解決此一問題呢?



錯誤訊息如下:



# uname -a

HP-UX lc B.11.11 U 9000/800 839849660 unlimited-user license



# /usr/local/apache/bin/httpd -t

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

Syntax error on line 238 of /usr/local/apache/etc/httpd.conf:

Cannot load /usr/local/apache/lib/modules/libphp4.sl into server: Unresolved external

8 回覆

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

1. 請檢查libphp4.sl是否存在/usr/local/apache/lib/modules/

2. 請檢查你的httpd.conf第238行或者將httpd.conf貼上來

3. 若還是不行, 也請將你config php的參數貼上來, 及./configure --後面的東西.

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

若要解決問題請用以下command link檔案

# ln -s /usr/local/apache/lib/modules/libphp4.so /usr/local/apache/lib/modules/libphp4.sl



安裝方式可參考以下網址

http://th.php.net/install.unix.hpux

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

你安裝的 apache 看起來不像是 HP 所提供的, 要不要試試看安裝由 HP 所提供的 apache server ? (當然也會有 php module)



可以到 http://software.hp.com 來取得你所需要的 apache 軟體

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

1. 請檢查libphp4.sl是否存在/usr/local/apache/lib/modules/



Ans: Yes



2. 請檢查你的httpd.conf第238行或者將httpd.conf貼上來



Ans: LoadModule php4_module lib/modules/libphp4.sl



3. 若還是不行, 也請將你config php的參數貼上來, 及./configure --後面的東西.



Ans: 還是不行!



我的 configure 參數如下:



'./configure' \

'--with-apxs=/usr/local/apache/bin/apxs' \

'--with-config-file-path=/etc' \

'--enable-track-vars' \

'--disable-debug' \

'--disable-cli' \

'--disable-pear' \

'--with-curl' \

'--with-iconv' \

'--with-zlib' \

'--with-mysql'

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

我從 software.hp.com 看到 Apache 的最新版是 v2.10



第一個問題,請問我要如何查看我現有 HP 提供的 Apache 版本?



# /opt/hpws/apache/bin/httpd -v

Server version: HP-UX_Apache-based_Web_Server/2.0.46

Server built: Jun 27 2003 04:43:11

#



我打 swlist 列出的 Apache 相關資訊如下:



hpuxwsApache A.1.0.06.02 HP-UX Apache-based Web Server

hpuxwsTomcat A.1.0.03.03 HP-UX Tomcat-based Servlet Engine

hpuxwsWebmin A.1.0.05.02 HP-UX Webmin-based Admin

hpuxwsXml A.1.0.01.02 HP-UX XML Web Server Tools



第二個問題,透過 swinstall 要怎麼升級 package ?

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

answer 1:

Server version: HP-UX_Apache-based_Web_Server/2.0.46



the hp package provide apache version is 2.0.46



answer 2:

for example, 把你抓到的depot解到 /tmp/httpd2下.

接著下swinstall -s /tmp/httpd2/*.depot

再把要安裝的東西以m標示起來, 然後 Action -> install

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

answer 1:



Feedback: 不好意思,我沒說清楚。我是指 HP 提供的版本編號,不是 Apache 的版本編號。



我在 software.hp.com 查到的最新版(v.2.10)是在這看到的:

http://software.hp.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXWSATW210



這 v2.10 是 HP 編號的,我不知道我現在這台所裝的 HP-UX Apache-based Web Server 是哪個版本?



answer 2:



Feedback: 這我知道。不過同樣的 Package 不同版本也是這樣直接 Install 嗎?會不會有潛在問題發生?是否需要先移除舊版的 HP-UX Apache-based Web Server 版本。

/usr/lib/dld.sl: Unresolved symbol: ntohs (code) from /usr/local/apache/lib/modules/libphp4.sl

answer 1:

The following changes and security fixes were made in this release:

HP-UX Web Server Suite v.2.10

HP-UX Apache-based Web Server v.2.0.52.00

This release of HP-UX Apache-based Web Server is primarily a security and bug fix release.

Apache upgraded to 2.0.52:



answer 2:

yes, make sure your apache web server is down. then use swremove to remove old packages.