3PAR StoreServ Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

3PAR Virtual Service Processor VSP fails after Migration in Hyper-V

SOLVED
Go to solution
Markus-M
Regular Visitor

3PAR Virtual Service Processor VSP fails after Migration in Hyper-V

Hi,

I recently setup VSP V4.4.0 GA-22 on a Hyper-V Standalone Host. We configured the VSP accordingly, running fine.
This VSP needs to be moved to a different Hyper-V Host. I stopped the VM, did a "Shared-Nothing" Livemigration to the destination Hyper-V Host. This step processed successfully.
After I started the VM, the network-configuration in the VM failed. Error in console log:
>>Device eth0 does not seem to be present, delaying initialization.
>>Device eth1 does not seem to be present, delaying initialization.

The VSP is not accessible through network at all.

Even when migrating the VM back to the origin Hyper-V Host, the VSP fails with same error.
Restored the VSP from backup to this host, success.

Checked VSP Best practise, but content is confusing:

Page 8:

Protecting your VSP using VMware HA or Microsoft Failover Clustering
Users should consider running the VSP on a VMware HA cluster or Microsoft Failover Cluster as applicable.....

Page 9:

VSP and Hypervisor VM mobility

At the time of the writing of this paper and with the release of HP 3PAR SP 4.2, the VMware VMotion or Microsoft Live Migration are not supported. It is recommended that users do not attempt to use such features with the current VSP release

 

How should I supply a VSP in Hyper-V with high-availibility, when HA Features like migrations are not supported?And why is the VSP so picky against (Live-) Migrations?

For reply thanks in advance,

Markus

1 REPLY
Markus-M
Regular Visitor
Solution

Re: 3PAR Virtual Service Processor VSP fails after Migration in Hyper-V

After I changed the Network settings inside the VM from MAC "dynamic" to "static" on both adapters, the problem seems to be solved.