3PAR StoreServ Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't see storage system WWNs when adding host in 3Par

 
SOLVED
Go to solution
Highlighted
OG_Monaco
Occasional Visitor

Can't see storage system WWNs when adding host in 3Par

hi,

i am trying to add a host to our 3par (new blade added in a C7000 chassis) and i am having some trouble with it and therefore i'd like your advices. to be honest this is the first time i add a host via this console so it might be a normal situation and i might miss some information,

when i look at other previously added hosts in our 3Par, if i do an edit on them, i can see the host WWNs with all storage system ports in "assigned WWNs", so about 8 entries for each host (with the WWN of the two host HBAs, assign to each 3par port, 0:1:1, 0:1:2, 0:2:1 etc.) - screenshot attached existing_hosts.jpg

however, when i'm trying to add my new host, i could only select 2 available WWNs (the two WWNs of the host HBAs. now in "assigned WWNs", i can see only 2 entries, and more important, there are no "ports" listed, as seen in the screenshot attached faulty.jpg

i just double/triple checked the zoning on the SAN Switches, and it looks good (similar as all the other zones for all the other hosts).

note : the new host doesn't have an OS installed yet, as we plan to make it booting from the SAN (like all others), so i would like to create a dedicated volume and export it to this host, but currently i can't, as it says there are no paths available and therefore it cannot assign any LUN.

i'm pretty sure that i'm missing some information on how to add a host properly, but......

thanks for your hints

regards,

8 REPLIES 8
Highlighted
Dennis Handly
Acclaimed Contributor

Re: Can't see storage system WWNs when adding host in HPE 3PAR

Can you see the HBAs when you use the following commands:

showportdev fcfabric 0:1:1

showportdev fcfabric 0:1:2

etc.

 

If this shows it, then it isn't zoned correctly.

Highlighted
OG_Monaco
Occasional Visitor

Re: Can't see storage system WWNs when adding host in HPE 3PAR

thanks for your quick anser

well it's a trunk (connected to a chassis), i can see the ports configured correctly but can't see the WWNs as it says "Multiple" as you can see in the screenshot attached.

on the SAN switches, ports 0 & 1 are attached to the chassis (where my new host is, with all the others, it is blades)

and ports 12 to 15 are connections to the 3Par

 

 

Highlighted
Cali
Honored Contributor
Solution

Re: Can't see storage system WWNs when adding host in HPE 3PAR

Hi,

the WWN is only Online (and seen by Storage) if the HBA Driver is loaded. So it need naturaly an runnung OS.

You can try to boot from Windows ISO, ESX or Win-PE with injected Driver.

Other way is to go in the BIOS Config for the HBA, this brings also the Ports online (most times).


======================
That was not planned in this way.
Highlighted
apol
Occasional Advisor

Re: Can't see storage system WWNs when adding host in HPE 3PAR

For all eight paths to show up, an active/loaded MPIO driver is also needed.

One port (one of the two hba ports or npiv wwns) active when in bios / scanning for devices. Two ports/wwns, each connected to one storage port / one per fabric connected when os loads / hba driver is loaded, and all paths up when os is loaded and mpio kicks in.

Highlighted
Dennis Handly
Acclaimed Contributor

Re: Can't see storage system WWNs when adding host in HPE 3PAR

> can't see the WWNs as it says "Multiple"

 

A newer version of HPE 3PAR will show all of the NPIV ports, instead of "Multiple".

Highlighted
OG_Monaco
Occasional Visitor

Re: Can't see storage system WWNs when adding host in HPE 3PAR

thanks a lot, it perfectly makes sense.

so basically as i want to setup a boot on SAN (no OS yet), i have to start on the ESX ISO, or go the the BIOS to activate the paths, and if i understand it well, the 8 paths will be automatically shown afterwards once the OS is installed and all paths are up ?

 

Highlighted
Cali
Honored Contributor

Re: Can't see storage system WWNs when adding host in HPE 3PAR

Yes


======================
That was not planned in this way.
Highlighted
OG_Monaco
Occasional Visitor

Re: Can't see storage system WWNs when adding host in HPE 3PAR [SOLVED]

excellent, i went to the HBA BIOS and did a "scan for target devices" on each HBA and could see them both in the 3Par available WWNs now (all of them, so 8 total). it works like a charm. 

now let's see if i see the disks in the Vmware installer :) but it looks good so far

thanks again for your help!