3PAR StoreServ Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 3PAR cli issue with linux

technique3740
Occasional Collector

HP 3PAR cli issue with linux

Hi,

I installed inform_cli_3.1.1 on my debian linux distro and whenever I tried to connect to my HP 3PAR I have this issue.

Could not open connection to CLI server process on "HP3PARQC":
-sockssl option not supported, libtls not loaded
System name may be invalid, or the process may not have started yet
or may have failed.

Here are the infos :

deb-mgmt# CLI Client version: 3.1.1 (P27)

deb-mgmt# # sestatus
SELinux status:                 disabled

 

HP3PARQC cli% showclienv
Parameter Value
csvtable 0
nohdtot 0
hafter -1
histstatnum 0
listdom 0
editor emacs

I need to use Inform_cli to build some scripts, and prior to do that I need to be able to connect properly to my HP 3PAR NAS.


Thanks in advance

 

 

2 REPLIES
Dennis Handly
Acclaimed Contributor

Re: HPE 3PAR cli issue with linux

> inform_cli_3.1.1

 

Why such an old version of the Remote CLI client?

You might get it to work with -nosockssl.

 

>HP3PARQC cli% showclienv

 

This shows it working at one time.  What changed?

 

 

> need to use Inform_cli to build some scripts, and prior to do that I need to be able to connect properly to my HP 3PAR NAS.

 

(This is a SAN, not a NAS.)

You might want to switch to using ssh to access your array:

ssh 3paradm@HP3PARQC

technique3740
Occasional Collector

Re: HPE 3PAR cli issue with linux

I know it'a SAN and not a NAS,  I just mispelled.

I finally resolved my issue by upgrading Inform CLI to 3.2.2 mu3

Case closed