3PAR StoreServ Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

HPE 3PAR Host Explorer Installation issue on RHEL 7.3

 
Highlighted

HPE 3PAR Host Explorer Installation issue on RHEL 7.3

Unable to install the HPE3PAR version 3.2.1 Host Explorer in RHEL 7.3. 

Summary of the installation failure:

--

This package works for only Red Hat Linux 2.6 kernels...
error: %pre(HostExplorer-rhel-3.2.1-0.i386) scriptlet failed, exit status 1
Error in PREIN scriptlet in rpm package HostExplorer-rhel-3.2.1-0.i386
Verifying : HostExplorer-rhel-3.2.1-0.i386

------

 

 

Accept or Kudo

3 REPLIES 3
Highlighted
CentralM
Occasional Contributor

Re: HPE 3PAR Host Explorer Installation issue on RHEL 7.3

warning: HostExplorer-rhel-3.2.1-0.i386.rpm: Header V3 RSA/SHA256 Signature
Preparing...                ########################################### [100%]
This package works for only Red Hat Linux 2.6 kernels...
error: %pre(HostExplorer-rhel-3.2.1-0.i386) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping HostExplorer-rhel-3.2.1-0

Help!

Highlighted
Orlando-Torres3
Occasional Visitor

Re: HPE 3PAR Host Explorer Installation issue on RHEL 7.x

I'm facing the same issue, with RedHat 7.x, OL 7.x

rpm -ivh HostExplorer-rhel-3.2.1-0.i386.rpm
warning: HostExplorer-rhel-3.2.1-0.i386.rpm: Header V3 RSA/SHA256 Signature, key ID b9a3b236: NOKEY
Preparing... ########################################### [100%]
This package works for only Red Hat Linux 2.6 kernels...
error: %pre(HostExplorer-rhel-3.2.1-0.i386) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping HostExplorer-rhel-3.2.1-0

Help will be appreciated.

Please at least a link to download previous version.

Thanks!

Highlighted
PawelKrauze
Occasional Visitor

Re: HPE 3PAR Host Explorer Installation issue on RHEL 7.x

kernelver=`uname -r`
kver=`echo $kernelver | awk -F"." '{print $1 "." $2}'`
if ! [ $kver = 2.6 ]; then
if ! [ $kver = 3.1 ]; then
echo "This package works for only Red Hat Linux 2.6 kernels..."
exit 1
fi
fi

this is the PREIN script from rpm. It can't work since rhel 7 kernel version starts from 3.10