3PAR StoreServ Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem Adding Volume to Replication Group: Zero_detect Disabled?

 
Highlighted
L1nklight
Valued Contributor

Problem Adding Volume to Replication Group: Zero_detect Disabled?

I am trying to add a volume to a remote copy group. This is an activity I've done quite often in the last few weeks successfully. In order to add the volume, I must create the target volume on the destination 3PAR. When I go to do this, I am getting an error message that states "Error: Conflict between policies zero_detect and no_zero_detect." To me this seems to indicate that some how, zero_detect got turned off on one of my 3PARs cpgs during the upgrade to 3.2.1 MU2 as I was able to add volumes to remote copy groups and create their destination volumes.

 

A couple questions:

 

  1. How do I view the status of zero_detect on the cpgs/volumes? I can see how I can create a cpg/volume with zero detect however I don't see a way to view the status of zero_detect per cpg/volume. Also, I am not even sure this is a legit error as turning off zero_detect seems like a pretty big deal for a cpg/volume.
  2. If I can figure out which cpg/volume (default SSD_r5 cpg) has zero_detect disabled, whether it's the local or remote 3PAR system, how would I go about re-enabling it?
  3. What are the ramifications of re-enabling zero_detect after it has been disabled?

I have opened a ticket with 3PAR support on this, but I was looking for a bit more of an immediate response or maybe someway I can help myself.

18 REPLIES 18
Highlighted

Re: Problem Adding Volume to Replication Group: Zero_detect Disabled?

Remember that everything can be done from the CLI. When in doubt, the command line is your friend.

Zero_detect is a characteristic of a virtual volume, not a CPG. As zero_detect is one of the policies, try

showvv -pol [<VV_name|pattern|VV_set> ...]

 

There is no problem turning zero_detect on for a volume:

setvv -pol zero_detect <VV_name|pattern>...

 

 

Note: While I work for HP, all of my comments (whether noted or not), are my own and are not any official representation of the company.
----------
If my post was useful, click on my KUDOS! "White Star" !


Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

Accept or Kudo

Highlighted

Re: Problem Adding Volume to Replication Group: Zero_detect Disabled?

Granted, there's a learning curve with the command line. However, the 3PAR commands are quite consistent and you will quickly see the patterns to how the commands are organized.
In addition, as you perform functions with the GUI, you can look in the recent Events to see the corresponding commands executed by the GUI. (Do something in the GUI, look at the events of the last few minutes.)

 

Personally, I have PuTTY installed on my desktop and in my path so that I can easily connect to an array from the Run dialog box. Something like "putty 3paradm@10.11.12.13".


Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

Accept or Kudo

Highlighted
L1nklight
Valued Contributor

Re: Problem Adding Volume to Replication Group: Zero_detect Disabled?

I actually just found those commands as well (I am not unfamiliar with the CLI). As I am looking through my volumes and there are a lot of them, some of them have zero_detect enabled but most of them have no_zero_detect enabled. In my mind, I think I'd want zero_detect enabled globally but as I am reading through the 3.1.2 CLI document I have (which I am not sure if it's relevant for 3.2.1 MU2) I have found this piece of information:



"Thin Persistence can have some performance implications during extremely busy system conditions. HP recommends the zero_detect policy only be enabled during Thin Persistence and Thin Conversion operations. The zero_detect policy should be disabled during normal operation. "

 

 

For the record, I am running 7450s in both locations. What should I be running them as (zero_detect or no_zero_detect)?

Highlighted

Re: Problem Adding Volume to Replication Group: Zero_detect Disabled?

DEFINITELY zero_detect!

 

While older arrays sometimes had "performance implications", I have not heard of any with either the 7xxx or 10xxx. Zero detect is handled by the ASIC. I am not aware of any customers that are toggling zero_detect.

 

I think you can do a blanket enable:

setvv -pol zero_detect <vvname|pattern>...

 

 


Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

Accept or Kudo

Highlighted
L1nklight
Valued Contributor

Re: Problem Adding Volume to Replication Group: Zero_detect Disabled?

What about if the volumes are in a remote copy group? I imagine you'd have to do something like the following:

 

  1. Stop All Remote Copy Activities
  2. Enable zero_detect on source
  3. Enable zero_detect on destination
  4. Start All Remote Copy Activities

 

Will there be any sort of huge replication deluge to worry about?

Highlighted

Re: Problem Adding Volume to Replication Group: Zero_detect Disabled?

As far as I know, there is no need to stop Remote Copy. Zero_detect can be enabled on a volume at any time. And you would need to enable zero detect on both the primary and the secondary volumes.

 

And as far as Remote Copy, anytime you need to stop a group, wait until the volumes are "sync"ed. When stopped, snapshots will be automatically created on each primary volume, then when the group is restarted, the volumes will use the snapshots to get caught up.


Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

Accept or Kudo

Highlighted
L1nklight
Valued Contributor

Re: Problem Adding Volume to Replication Group: Zero_detect Disabled?

Hey sorry for the late reply. After I was looking through the configuration guide I found this line:

 

NOTE: Thin persistence can have some performance implications during extremely busy system

conditions. HP recommends the zero_detect policy only be enabled during Thin Persistence

and Thin Conversion operations. The zero_detect policy should be disabled during normal

operation.

 

 

Seems to suggest that the zero_detect option should be turned off by default. Is this correct?

Highlighted

Re: Problem Adding Volume to Replication Group: Zero_detect Disabled?

No. Go back and read Message 5 of 8.

 

And what document are you reading?


Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

Accept or Kudo

Highlighted
L1nklight
Valued Contributor

Re: Problem Adding Volume to Replication Group: Zero_detect Disabled?

Re-read 5 of 8. Here's the output:

 

3PAR7450 cli% showvv -pol Volume_Name
  Id Name               ---------------------Policies----------------------
1781 Volume_Name stale_ss,no_system,no_one_host,cache,no_zero_detect
---------------------------------------------------------------------------
   1 total
3PAR7450 cli% setvv -pol zero_detect Volume_Name
Error: VV Volume_Name is a TDVV and thus cannot have zero_detect policy enabled
3PAR7450 cli%

 

Document is titled: HP 3PAR Command Line Interface Administrator's Manual HP 3PAR OS 3.1.2. Page 86 about midway down.

 

Also found on document titled: HP 3PAR Command Line Interface Reference HP 3PAR OS 3.2.1. Page 336 a little more than midway down under the setvv command flags.